TP Packet Tracer et Routage Cisco en PDF


Télécharger TP Packet Tracer et Routage Cisco en PDF
3.73.7 étoiles sur 5 a partir de 14 votes.
Votez ce document:

Télécharger aussi :



Table des matières

INTRODUCTION 4

I.EXAMEN DES CONNEXIONS D’UN ROUTEUR .. 4

A.INSTALLATION ET CONFIGURATION PHYSIQUE DES PERIPHERIQUES: .. 5

1. MISE EN PLACE DES PERIPHERIQUES DANS LA TOPOLOGIE 5 2. AJOUT DES MODULES AUX ROUTEURS : . 5

B.ATTRIBUTION D'UN NOM AUX PERIPHERIQUES: .. 6C.CONNEXION DES PERIPHERIQUES. 7D.CHECKRESULTS: . 8E.QUESTIONS: . 9II.CONFIGURATION DES INTERFACES ETHERNET .. 9

A.CONFIGURATION DES INFORMATIONSIPSUR LES INTERFACESETHERNET DUN RESEAU9

1. CONFIGURATION DES PC : .. 9 2. CONFIGURATION IP DES INTERFACES ETHERNET DU ROUTEUR. 10

B.TACHE2:VERIFICATION DU BON FONCTIONNEMENT. 11C.CHECKRESULTS: .. 11

D.QUESTIONS. 12

III.CONFIGURATION DES INTERFACES SERIE ET VERIFICATION DE LA TABLE DE ROUTAGE .. 12

A.CONFIGURATION DES INTERFACES SERIE SUR LES ROUTEURS.. 13

1. CONFIGURATION DE R1 : .. 13 2. CONFIGURATION DE R2 : .. 13 3. CONFIGURATION R3 : . 14 4. VERIFICATION DES DIFFERENTES INTERFACES DES ROUTEURS : .. 15

B.TACHE2:VERIFICATION DES INFORMATIONS SUR LA TABLE DE ROUTAGE. 16

1. VERIFIER LES INFORMATIONS SUR LA TABLE DE ROUTAGE POUR LES RESEAUX DIRECTEMENT CONNECTES. . 16

2. OBSERVEZ LES PROCESSUS DE MISES A JOUR DE LA TABLE DE ROUTAGE . 17

C.    CHECK RESULT: . 18

D.    QUESTIONS. 18

IV.   VERIFICATION DE LA CONNECTIVITE DES PERIPHERIQUES DIRECTEMENT CONNECTES . 19

V.  SUPPRESSION ET CONFIGURATION DES ROUTES STATIQUES . 22

A.EXAMEN ET MODIFICATION DES ROUTES STATIQUES. 22B.CHECK RESULT: . 24

C.QUESTIONS. 25

VI.CONFIGURATION D’UN ROUTE STATIQUE PAR DEFAUT . 25

A.   EXAMEN DU RESEAU AVEC LES ROUTES STATIQUES DE TOUS LES RESEAUX. 25

B.    RESUME DES ROUTES STATIQUES VERS LES RESEAUX CONTIGUS. 27C.CONFIGURATION D'UN RESEAU DEXTREMITE. 27D.CHECK RESULT28

E.QUESTIONS: .. 29

VII.CABLAGE ET CONFIGURATION D’UN ROUTEUR CISCO .. 30

A.CONFIGURATIONR1 30

1. CONNEXION SUR L’INTERFACE CONSOLE DU ROUTEUR R1 30 2. CONFIGURATION DE L’INTERFACE FAST ETHERNET 0 . 31 3. CONFIGURATION DE L’INTERFACE SERIAL 0 : 32

B.     CONFIGURATIONPC1LINUX32C.TEST DE CONNECTIVITEPC1ETR1 33D.CONFIGURATIONR2 33 A. CONFIGURATION DE L’INTERFACE FAST ETHERNET DU ROUTEUR R2 . 33 B. CONFIGURATION DE L’INTERFACE SERIAL 0 DU ROUTEUR R2 : 34

C.     CONFIGURATION DEPC2 34E.CONFIGURATION DES TABLES DEROUTAGE35

1. CONFIGURATION DE LA TABLE DE ROUTAGE DES ROUTEURS : .. 35

2. CONFIGURATION DE LA TABLE DE ROUTAGE DE PC1 36 F.TEST DU BON FONCTIONNEMENT DU RESEAU. 37VIII.SYNTHESE 38

A.   CABLAGE DU RESEAU: 38

B.    APPLICATION D'UNE CONFIGURATION FONDAMENTALE AUX PERIPHERIQUES.. 39

1. CONFIGURATION DU ROUTEUR HQ : .. 39 2. CONFIGURATION DU ROUTEUR B1: .. 40 3. CONFIGURATION DU ROUTEUR B2: .. 42 4. CONFIGURATION DES PC : 43

C.CONFIGURATION D'UN ROUTAGE STATIQUE ET PAR DEFAUT. 44

1. ROUTEUR HQ : 44 2. ROUTEUR B1 : .. 44

3. ROUTEUR B2: 44 D.CHECK RESULT: .. 45A.TEST DES CONNEXIONS: .. 45

1. TESTS DE COMMUNICATION .. 45 2. EXAMINEZ LA CONFIGURATION. .. 46

Table des figures

FIGURE 1- PACKET TRACER . 4 FIGURE 2- LE PT ACTIVITY 5 FIGURE 3-PERIPHERIQUES DE LA TOPOLIOGIE 1 . 5 FIGURE 4- AJOUT MODULE WIC-2T AU ROUTEUR 6 FIGURE 5-CHANGEMENT DE NOM D’UN ROUTEUR .. 6 FIGURE 6-ROUTEUR MODE CONSOLE  PACKET TRACER .. 7 FIGURE 7-CONNEXION DES EQUIPEMENTS . 8 FIGURE 8-CHECK RESULT 1 . 8 FIGURE 9-TOPOLOGIE DU RESEAUX  1 PACKET TRACER . 9 FIGURE 10-CONFIGURATION DE L’INTERFACE RESEAUX  D'UN PC PACKET TRACER .10 FIGURE 16-PLAN D'ADRESSAGE PARTIE 7 ..30 FIGURE 17-CONFIGURATION MINICOM .31 FIGURE 18-CONFIGURAITON PC2 35

INTRODUCTION

Ce TP a pour objectif de comprendre le fonctionnement d’un routeur Cisco, et d’en connaitre les principales commandes de configuration. 

Ce TP nous a demandé une certaine connaissance en routage, mais aussi sur le protocole IP, la notion de route statique et dynamique…

La première partie du TP s’effectue à l’aide du logiciel Packet Tracer, fourni par Cisco. Cette application permet d’émuler des PCs et les équipements Cisco afin de schématiser des réseaux locaux ou étendus.

La deuxième partie est le montage d’un réseau avec deux routeurs et deux PC. Nous avons commencé par ce point lors du la réalisation du TP.

     I.    EXAMEN DES CONNEXIONS D’UN ROUTEUR

Dans un premier temps, nous téléchargeons l’exo 1 sur notre poste de travail :

# wget

Nous ouvrons le fichier avec Packet Tracer.

FIGURE 1- PACKET TRACER

Ensuite nous suivons les instructions du PT Activity. 

 FIGURE 2- LE PT ACTIVITY

Le PT Activity nous indique  les étapes à suivre dans notre initiation Cisco.

A.Installation et configuration physique des périphériques :

1.  Mise en place des périphériques dans la topologie

Dans cette partie nous faisons glisser les différents équipements du réseau (Routeurs, Commutateurs et PC) sur l’espace de travail afin d’arriver à la figure suivante :

2.  Ajout des modules aux routeurs :

Les Routeurs Cisco offrent la possibilité d’ajouter différents modules. L’outil de simulation Packet Tracer permet de simuler une façade de routeur et ainsi monter différents modules. Pour ajouter un module il faut le faire dans cet ordre :

•    Mettre hors tension le routeur ;

•    Glisser le module dans l’emplacement prévu à cet effet ; • Remettre en tension le routeur.

FIGURE 4- AJOUT MODULE WIC-2T AU ROUTEUR

B.Attribution d'un nom aux périphériques :

En suivant le PT Activity nous attribuons un nouveau nom d’affichage sur l’espace de travail aux différents équipements du réseau ainsi qu’aux routeurs :

FIGURE 5-CHANGEMENT DE NOM D’UN ROUTEUR

De plus nous changeons également le « hostname » des routeurs avec les commandes suivante en mode

CLI :

Router1 >

Router1> enable 

Router1 # conf t

 Router(config)#

Router(config)#hostname R1  

R1(config)#exit

R1#

FIGURE 6-ROUTEUR MODE CONSOLE  PACKET TRACER

C. Connexion des périphériques

Nous relions à l’aide de câble série l'interface Serial0/0/0 du routeur R1 à l'interface Serial0/0/0 du routeur R2.

Nous relions à l’aide de câble série l'interface Serial0/0/1 du routeur R2 à l'interface Serial0/0/1 du routeur R3.

Nous relions les autres équipements à l’aide de câbles Ethernet.

D.Check Results :

Après cette phase de mise en place des équipements de notre futur réseau, nous nous assurons que le réseau fonctionne grâce au bouton Check Results du PT Activity. 

FIGURE 8-CHECK RESULT 1

E.Questions :

•    Ce réseau comporte 5 sous-réseaux : 172.16.1.0/24 , 172.6.3.0/24,172.16.2.0/24, 192.168.1.0/24 et 192.168.2.0/24 .

•    Il est utile d’utiliser un commutateur afin de relier plusieurs PC entre eux dans le sous-réseau, car les routeurs ont un unique port Ethernet.

•    Les routeurs permettent de relier des réseaux séparés par de grandes distances. Or, d’après la norme, un câble Ethernet ne doit pas dépasser 100m (en CAT 5 et 5e). Nous utilisons donc des câbles séries qui sont prévus à cet effet. De plus les câbles séries permettent d’atteindre de plus grandes vitesses que les câbles Ethernet.

•    Nous utilisons des câbles droits car le routeur et/ou le commutateur permettent le croisement.

II.      CONFIGURATION DES INTERFACES ETHERNET

Nous téléchargeons l’exercice 2 sur le poste de travail.

# wget

A. Configuration des informations IP sur les interfaces Ethernet d’un réseau

1.Configuration des PC : 

Avec Packet Tracer nous pouvons simuler des PCs, nous configurons les trois PCs en suivant la topologie du TP Figure 9.


FIGURE 10-CONFIGURATION DE L’INTERFACE RESEAUX  D'UN PC PACKET TRACER

2.Configuration IP des interfaces Ethernet du routeur.

Dans cette partie nous allons configurer les interfaces FastEthernet des routeurs R1 R2 et R3 en suivant le plan  d’adressage donné ci-dessus. 

Pour R1 :

R1>enable

R1# conf t

R1(config)# interface fastEthernet0/0 

R1(config-if)# ip address 172.16.3.1 255.255.255.0 

R1(config-if)# no shutdown

R1(config-if)#exit

R1# copy running-config startup-config

Pour R2 :

R2>enable

R2# conf t

R2(config)# interface fastEthernet0/0 

R2(config-if)# ip address 172.16.1.1 255.255.255.0 

R2(config-if)# no shutdown

R2(config-if)#exit

R3# copy running-config startup-config

Pour R3 :

R3>enable

R3# conf t

R3(config)# interface fastEthernet0/0 

R3(config-if)# ip address 192.168.2.1 255.255.255.0 

R3(config-if)# no shutdown

R3(config-if)#exit

R3# copy running-config startup-config

B. Tâche 2 : vérification du bon fonctionnement

Nous vérifions la configuration des routeurs avec la commande suivante :

show ip interface brief

C.Check Results :

Après cette phase de configuration IP de notre réseau nous vérifions la bonne manipulation.

FIGURE 12-EXO2 VERIFICATION

D. Questions

•    Pour PC1 et PC2 ont une adresse IP de classe B. Nous utilisons un masque de classe C pour découper le réseau de classe B en sous réseau (CIDR). Ainsi PC1 et PC2 sont dans deux sous réseaux différents.

•    Configurer un routeur en mode CLI signifie que le routeur est configuré par un PC relié directement avec un câble console.

•    Les paquets ARP sont envoyés avant les requêtes ICMP dans le but de remplir les tables ARPs voici le fonctionnement décrit : 

o   A tente un ping vers B, A vérifie que l’adresse de B est dans sa table ARP. Ayant vidé toutes les tables avant, le système ne connait pas l’adresse de B ;

o   A envoie alors un message à destination de tous les PCs du réseau en broadcast pour savoir qui possède l’adresse IP de B ;

o   B reconnait son adresse et répond à l’adresse MAC de A. Il en profite également pour mettre à jour sa table ARP ;

o   A met à jour sa table ARP ; o A envoie la requête ICMP vers B.

III.    CONFIGURATION DES INTERFACES SERIE ET VERIFICATION DE LA TABLE DE ROUTAGE

Nous téléchargeons l’exo 3 sur notre poste de travail et ensuite nous l’ouvrons avec Packet Tracer :

# wget

A. Configuration des interfaces série sur les routeurs

Nous configurons les routeurs en suivant le plan d’adressage de la figure 11.

1.Configuration de R1 :

Vérifions si R1 S0/0/1 est DCE ou DTE :

Router(config)#hostname R1

R1(config-if)#^Z

R1#show controllers serial0/0/1

Interface Serial0/0/1

Hardware is PowerQUICC MPC860

DCE V.35

R1 est DTE donc pas d’horloge à configurer.

R1(config)#interface serial0/0/0

R1(config-if)#ip address 172.16.2.1 255.255.255.0

R1(config-if)# no clock rate

R1(config-if)#^Z

%SYS-5-CONFIG_I: Configured from console by console

R1#copy run start

Destination filename [startup-config]? 

Building configuration

[OK] R1#

2.Configuration de R2 :

Vérifions si R2  S0/0/0 est DTE ou DCE

R3#show controllers serial0/0/0

Interface Serial0/0/0

Hardware is PowerQUICC MPC860

DCE V.35

S0/0/0 de R2 est DCE donc nous devrons configurer la clock rate.

Router(config)#hostname R2

R2(config)#interface serial0/0/0

R2(config-if)#ip address 172.16.2.2 255.255.255.0

R2(config-if)# clock rate 64000 

R2(config-if)#no shutdown 

R2#copy run start

Destination filename [startup-config]?  Building configuration

[OK] R2#

Vérifions si S0/0/1 de R2 est DTE ou DCE :

R2#show controllers serial0/0/1

Interface Serial0/0/1

Hardware is PowerQUICC MPC860 DTE v.35

L’interface S0/0/1 de R2 relié à R3 n’est pas DCE donc inutile de régler la clock rate.

R2(config)#interface serial0/0/1

R2(config-if)#ip address 192.168.1.2  255.255.255.0

R2(config-if)#no clock rate 

R2(config-if)#no shutdown 

R2#copy run start

Destination filename [startup-config]? 

Building configuration

[OK] R2#

3.Configuration R3 :

Vérifions si l’interface s0/0/0 de R3 est DCE ou DTE :

R3#show controllers serial0/0/0

Interface Serial0/0/0

Hardware is PowerQUICC MPC860

No serial cable attached

Nous constatons qu’il n’y a aucun câble de connecté à S0/0/0 de R3. Testons une autre interface:

R3#show controllers serial0/0/1

Interface Serial0/0/1

Hardware is PowerQUICC MPC860 DCE 

L’interface S0/0/1 est bien connectée et est DCE. Donc il faudra configurer la clock rate.

R3(config)#interface s0/0/1

R3(config-if)#ip address 192.168.1.1 255.255.255.0

R3(config-if)# clock rate 64000

R3(config-if)#no shutdown 

R3#copy run start

Destination filename [startup-config]? 

Building configuration

[OK]

4.Vérification des différentes interfaces des routeurs :

La commande « #show ip interface brief » permet d’afficher un résumé sous forme de tableau afin de voir si la configuration est conforme à nos attentes.

Routeur 1 :

R1#show ip interface brief 

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 172.16.3.1      YES manual up                    up

FastEthernet0/1 unassigned      YES manual administratively down down

Serial0/0/0 172.16.2.1      YES manual up                    up

Serial0/0/1 unassigned      YES manual down                  down

Vlan1 unassigned      YES manual administratively down down

Routeur 2 :

R2#show ip interface brief 

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 172.16.1.1      YES manual up                    up

FastEthernet0/1 unassigned      YES manual administratively down down

Serial0/0/0 172.16.2.2      YES manual up                    up

Serial0/0/1 192.168.1.2     YES manual up                    up

Routeur 3 :

R3#show ip interface brief 

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 192.168.2.1     YES manual up                    up

FastEthernet0/1 unassigned      YES manual administratively down down

Serial0/0/0 unassigned      YES manual administratively down down

Serial0/0/1 192.168.1.1     YES manual up                    up

Nous activons à présent le mode debug afin que l’OS Cisco nous informe des changements d’états des connexions.

R3#debug ip routing

IP routing debugging is on

Les interfaces des différents routeurs sont conformes à notre configuration et sont « up » c'est-à-dire allumées.

B. Tâche 2 : vérification des informations sur la table de routage

1.Vérifier les informations sur la table de routage pour les réseaux directement connectés.

Après avoir configuré les 3 routeurs nous regardons leurs tables de routages. 

Table de routage de R1 :

R1#show ip route

172.16.0.0/24 is subnetted, 2 subnets

C 172.16.2.0 is directly connected, Serial0/0/0

C 172.16.3.0 is directly connected, FastEthernet0/0

R1 est connecté au réseau 172.16.2.0 par l’interface S0/0/0

R1 connecté directement au réseau 172.16.3.0 par FA0/0/0.

Cette configuration est conforme à notre configuration de câblage.

Table de routage de R2 :

R2#show ip route

172.16.0.0/24 is subnetted, 2 subnets

C 172.16.1.0 is directly connected, FastEthernet0/0

C 172.16.2.0 is directly connected, Serial0/0/0

C 192.168.1.0/24 is directly connected, Serial0/0/1

•    R2 est directement relié par FA 0/0 au réseau 172.16.1.0 ;

•    R2 est directement relié par s0/0/0 au réseau 172.16.2.0 ( R1) ;

•    R2 est directement relié par s0/0/1 au réseau 192.168.1.0  ( R3).

Cette configuration est conforme à notre configuration de câblage.

Table de routage de R3 :

R3#show ip route

C 192.168.1.0/24 is directly connected, Serial0/0/1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

•    R3 est directement relié par s0/0/1 au réseau 192.168.1.0 ( R2)

•    R3 est directement relié par FA 0/0 au réseau 192.168.2.0 

Nous effectuons des testes de communication :

•    R2 arrive à pinger R1.

•    R2 arrive à pinger R3.

•    R1 et R3 ne parviennent pas à se pinger car la table de routage n’est pas encore configurée.

2.Observez les processus de mises à jour de la table de routage

Désactivons les interfaces série de R2 et observons ce qui se passe :

R2(config)#interface s0/0/1 R2(config-if)#shutdown

R2(config)#interface s0/0/0 R2(config-if)#shutdown

Nous avons désactivé S0/0/1 et S0/0/0 de R2. Nous constatons que les communications entre R2 et R1 sont interrompues, comme celles entre R2 et R3.

La commande « R3#debug ip routing » permet de voir les modifications apportées par le routeur lors de l’ajout et de la suppression de routes.

Comme nous avons mis la commande « debug ip routing  »  sur R3, lors de la désactivation du port série entre R2 et R3, R3 nous informe directement du changement d’état de la connexion avec R2, et il supprime la route dans sa table de routage.

R3#

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to down

RT: interface Serial0/0/1 removed from routing tableRT: del 192.168.1.0 via 0.0.0.0, connected metric [0/4294967295]

RT: delete network route to 192.168.1.0

RT: NET-RED 192.168.1.0/24

L’entrée vers R2 n’existe plus dans les tables de R1 et R3.

R3#show ip route

C 192.168.2.0/24 is directly connected, FastEthernet0/0

R3#

R1#show ip route

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.3.0 is directly connected, FastEthernet0/0

R1#

A l’activation des interfaces séries de R2 les différent routeurs R1 R2 R3  nous informe des changements d’états et les table de routage sont mise à jour.

R2 :

R2(config)#interface s0/0/0 R2(config-if)# no shutdown

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

RT: interface Serial0/0/0 added to routing tableRT: SET_LAST_RDB for 172.16.2.0/24 R2(config-if)#exit 

R2(config)#interface S0/0/1

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

interface Serial0/0/1 added to routing tableRT: SET_LAST_RDB for 192.168.1.0/24

R3 : mise à jour automatique et ajout de la table.

R3#

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up RT: interface Serial0/0/1 added to routing tableRT: SET_LAST_RDB for 192.168.1.

R1 fait de même il met à jour sa table.

Pour sortir du mode debug, il faut entrer la commande suivante «R3# undebug ip routing » 

C.Check result :

Dans le PT Activity nous vérifions que nous avons tout bien configuré.

FIGURE 13-CHECK RESULT EXO3

D. Questions

 Un modem par exemple est un équipement DCE. Le DCE est le fournisseur de service et le DTE est le périphérique connecté. 

En règle générale, le routeur est le périphérique ETTD et il est connecté à un fournisseur de service type ( CSU/DSU), qui est le périphérique DCE. Le périphérique DCE est utilisé pour convertir les données du routeur (périphérique ETTD) dans un format acceptable pour le fournisseur de services de réseau étendu (par exemple un FAI).

Dans une liaison série il y a donc un DCE et un DTE. Un PC ne peut être DCE il est DTE car il utilise les services fournis par le routeur (le DCE).

Les interfaces série nécessitent un signal d’horloge pour contrôler la synchronisation des communications. Dans la plupart des environnements, le fournisseur de services (un périphérique DCE) fournit cette synchronisation.

Dans notre cas un des routeurs sert de DCE et il fournit le signal d’horloge au routeur DTE connecté à l’autre bout de la liaison série. 

IV.    VERIFICATION DE LA CONNECTIVITE DES PERIPHERIQUES DIRECTEMENT CONNECTES

Nous téléchargeons l’exercice 4 sur notre poste de travail et ensuite nous l’ouvrons avec Packet Tracer :

# wget

Dans cette partie nous allons vérifier la connectivité entre les équipements. Nous n’avons pas établi de table de routage, donc normalement les périphériques ne pourront communiquer qu’avec leurs voisins directement connecté. Pour rappel voici le plan du réseau construit :

FIGURE 14-RAPPEL DE LA TOPOLOGIE DU RESEAU EN COURS DE CREATION

Depuis PC 1 nous pingons172.16.3.1 c'est-à-dire l’interface FA 0/0 de   R1 son routeur directement branché. 

Le ping est un succès comme nous pouvions l’attendre.

A présent avec PC1 nous tentons de pinguer l’interface S0/0/0 de R1 :

PC1>ping 172.16.2.1

Pinging 172.16.2.1 with 32 bytes of data:

Reply from 172.16.3.1: Destination host unreachable.

Reply from 172.16.3.1: Destination host unreachable.

Reply from 172.16.3.1: Destination host unreachable.

Nous constatons que le PC1 n’arrive pas à atteindre cette interface. Normalement le pc aurais du pouvoir atteindre cette interface ! Y a-t-il un défaut de configuration de R1 ? Nous allons le vérifier maintenant.



D’abord vérifions  l’état des interfaces de routeur R1 (pour plus de lisibilité nous avons renommé en R1 le hostname ):

R1#show ip interface brief

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 172.16.3.1      YES manual up                    up

FastEthernet0/1 unassigned      YES manual administratively down down

Serial0/0/0 172.16.2.1      YES manual up                    down

En effet l’interface le protocole de Serial0  de R1 est down. Donc le problème vient soit De R1 qui a sa clock  rate mal réglé soit de R2 qui à sa clock rate  mal réglé.

R1#show controllers S0/0/0

Interface Serial0/0/0

Hardware is PowerQUICC MPC860 DTE V.35clocks stopped.

R1 est DTE et n’a pas reçu de signal d’horloge, donc le problème vient de R2. Faisons la même commande sur R2 et nous constatons qu’il n’y a pas de clock rate de configurée. :

R2#show controllers S0/0/0

Interface Serial0/0/0

Hardware is PowerQUICC MPC860

DTE V.35 no clock …

Après que nous ayons reconfiguré la clock rate sur R2 la liaison série de R1 est passé à up !

Nous refaisons le test de PC1 vers l’interface S0/0/1 de R1 :

PC>ping 172.16.2.1

Pinging 172.16.2.1 w 

Reply from 172.16.2.1: bytes=32 time=62ms TTL=255 Reply from 172.16.2.1: bytes=32 time ith 32 bytes of data:

=47ms TTL=255

Reply from 172.16.2.1: bytes=32 time=62ms TTL=255

Reply from 172.16.2.1: bytes=32 time=47ms TTL=255

Après ce rapide dépannage, PC1 Ping bien l’interface S0/0/0 de R1. Testons maintenant un ping vers l’interface S0/0/0 de R2 :

PC>ping 172.16.2.2

Pinging 172.16.2.2 with 32 bytes of data:

Request timed out.

Request timed out.

Ping statistics for 172.16.2.2:

Packets: Sent = 2, Received = 0, Lost = 2 (100% loss),

Control-C

Comme nous nous y attendions le ping ne fonctionne pas.

Tentons à présent des tests depuis PC1 et PC3 vers les routeurs R1 R2 et R3.

Après un petit dépannage sur la connexion série (problème de clock) entre R2 et R3 nous continuons les tests. (R3 et relié à R2 par S0/0/1 et non serial0/0/0 comme indiqué dans le PT activity!)

FA 0/0 de R1

FA 0/0 de R2

FA 0/0 de R3

S 0/0/0 de R2

S 0/0/1 de R2

S 0/0/0 de R1

S0/0/1 de R3

PC2

OK

OK

OK

PC3

OK

OK

Nous constatons que le seul le ping entre les équipements directement connectés entres eux est OK. 

Maintenant nous faisons des ping entre tous les routeurs du réseau. Le tableau ci-dessous récapitule tous les tests.

•    Les cases noirs sont les tests inutiles car c’est le routeur lui-même ;

•    Les case rouges sont les échecs de Ping ;

•    Les cases vertes sont les réussites de Ping.

FA 0/0 de R1

FA 0/0 de R2

FA 0/0 de R3

S 0/0/0 de R2

S 0/0/1 de R2

S 0/0/0 de R1

S0/0/1de R3

R1

R2

R3

Nous constatons que les routeurs ne peuvent communiquer qu’avec les routeurs directement connecté sur l’interface du même réseau uniquement.

A ce stade PC3 ne peux pas pinger l’interface série de R2.

     V.    SUPPRESSION ET CONFIGURATION DES ROUTES STATIQUES

Nous téléchargeons l’exo 5 puis nous l’ouvrons avec Packet Tracer.

A. Examen et modification des routes statiques 

Nous effectuons la commande suivante sur le Routeur R1 :

R1#show run

Cette commande nous permet de voir la configuration en cours. Le résultat nous renvoi les différentes configurations IP de toutes les interfaces, les routes statiques entrées, et les mots de passe activés.

Ensuite nous effectuons des ping sur tout le réseau et nous constatons qu’ils sont tous ok. 

Le tableau ci-dessous est un récapitulatif.

FA 0/0 de R1

FA 0/0 de R2

FA 0/0 de R3

S 0/0/0 de R2

S 0/0/1 de R2

S 0/0/0 de R1

S0/0/1de R3

PC1

PC2

PC3

R1

R2

R3

PC1

PC2

PC3

Nous désactivons toutes les routes statiques en suivants les commandes du PT Activity :

Exemple pour le Routeur R1 :

Suppression de route par rapport à l’@IP

R1(config)#no ip route 172.16.1.0 255.255.255.0 172.16.2.2 

R1(config)#no ip route 192.168.1.0 255.255.255.0 172.16.2.2 

R1(config)#no ip route 192.168.2.0 255.255.255.0 172.16.2.2

Ajout des routes en fonction de l’interface :

R1(config)#ip route 172.16.1.0 255.255.255.0 s0/0/0 

R1(config)#ip route 192.168.1.0 255.255.255.0 s0/0/0 

R1(config)#ip route 192.168.2.0 255.255.255.0 s0/0/0

En résumé pour atteindre les réseau 172.16.1.0/24 , 192.168.1.0/24 et 192.168.2.0/24 nous passons par l’interface S0/0/0.

La commande show IP route permet de visualiser la table de routage. 

•    Les C indiquent que les réseaux sont directement connectés au routeur.

•    Les S indiquent que ce sont des routes statiques, effectivement nous les avons entrées en dur avec les commandes ci-dessus.

.R1#show ip route ….

172.16.0.0/24 is subnetted, 3 subnets

S 172.16.1.0 is directly connected, Serial0/0/0

C 172.16.2.0 is directly connected, Serial0/0/0

C 172.16.3.0 is directly connected, FastEthernet0/0

S 192.168.1.0/24 is directly connected, Serial0/0/0

S 192.168.2.0/24 is directly connected, Serial0/0/0 R1#

Après reconfiguration des différentes tables de routage en fonction des interfaces, tous les Ping sont OK. Notre réseau est correctement configuré.

Table de routage de R3 :

S 172.16.1.0 is directly connected, Serial0/0/1

S 172.16.2.0 is directly connected, Serial0/0/1

S 172.16.3.0 is directly connected, Serial0/0/1

C 192.168.1.0/24 is directly connected, Serial0/0/1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

Table de routage de R2 :

S       172.16.1.0 is directly connected, Serial0/0/1

S 172.16.2.0 is directly connected, Serial0/0/1

S 172.16.3.0 is directly connected, Serial0/0/1

C 192.168.1.0/24 is directly connected, Serial0/0/1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

B.Check result :

Afin de vérifier que nous avons fait correctement ce qui était demandé par le PT Activity, nous effectuons un check result.

C. Questions

•    #show run

Cette commande affiche la configuration en cours stockée dans la mémoire vive. 

•    #show ip route

Cette commande affiche la table de routage actuellement utilisée par l’IOS pour choisir le meilleur chemin à emprunter afin d’atteindre les réseaux de destination.

•    Routes statiques

Une route statique indique le chemin à suivre pour atteindre une destination. Elle est indiquée en dur dans le routeur et ne change pas.  Il y a deux façons de créer une route statique :

R#ip route [@IP du réseaux dest ] [masque du réseaux dest] [@IP du prochain équipement]

R#ip route [@IP du réseaux dest ] [masque du réseaux dest] [interface de sortie]

•    Recherche récursive :

Si le routeur dois chercher une route pour une trame celui-ci regarde dans sa table de routage le meilleur chemin,  il peut être choisi selon plusieurs critères : le nombre de saut, la qualité de lien , le débit… c’est le principe de recherche récursive si pour une destination il existe plusieurs chemins et le  routeur prendra la meilleur route.

VI.      CONFIGURATION D’UN ROUTE STATIQUE PAR DEFAUT

A. Examen du réseau avec les routes statiques de tous les réseaux

Nous allons nous intéresser aux routes des 3 routeurs.

Pour le routeur R1 :

R1# show run

Ip classless ip route 172.16.1.0 255.255.255.0 Serial0/0/0  ip route 192.168.1.0 255.255.255.0 Serial0/0/0 

ip route 192.168.2.0 255.255.255.0 Serial0/0/0

R1#show ip route  

 S 172.16.1.0 is directly connected, Serial0/0/0 C       172.16.2.0 is directly connected, Serial0/0/0

C 172.16.3.0 is directly connected, FastEthernet0/0

S 192.168.1.0/24 is directly connected, Serial0/0/0

S 192.168.2.0/24 is directly connected, Serial0/0/0

Pour le routeur R2 :

R2#show run

ip route 172.16.3.0 255.255.255.0 Serial0/0/0 

ip route 192.168.2.0 255.255.255.0 Serial0/0/1

R2#show ip route

172.16.0.0/24 is subnetted, 3 subnets

C 172.16.1.0 is directly connected, FastEthernet0/0

C 172.16.2.0 is directly connected, Serial0/0/0

S 172.16.3.0 is directly connected, Serial0/0/0

C 192.168.1.0/24 is directly connected, Serial0/0/1

S 192.168.2.0/24 is directly connected, Serial0/0/1

Pour le routeur R3 :

R3#show run

172.16.0.0/24 is subnetted, 3 subnets

S 172.16.1.0 is directly connected, Serial0/0/0

C 172.16.2.0 is directly connected, Serial0/0/0

C 172.16.3.0 is directly connected, FastEthernet0/0

S 192.168.1.0/24 is directly connected, Serial0/0/0

S 192.168.2.0/24 is directly connected, Serial0/0/0

R3#show ip route

172.16.0.0/24 is subnetted, 3 subnets

S 172.16.1.0 is directly connected, Serial0/0/1

S 172.16.2.0 is directly connected, Serial0/0/1

S 172.16.3.0 is directly connected, Serial0/0/1

C 192.168.1.0/24 is directly connected, Serial0/0/1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

Nous constatons que les routeurs ont la même configuration que la partie précédente de ce TP.

Les tests avec des Ping sont concluants !

B. Résumé des routes statiques vers les réseaux contigus

Maintenant nous allons mettre supprimer les 3 routes statiques de R3 :

R3(config)#no ip route 172.16.1.0 255.255.255.0 s0/0/1 

R3(config)#no ip route 172.16.2.0 255.255.255.0 s0/0/1 

R3(config)#no ip route 172.16.3.0 255.255.255.0 s0/0/1

Nous mettons une route pour le réseau 172.16.0.0/22.

R3(config)#ip route 172.16.0.0 255.255.252.0 s0/0/1

Nous faisons un Ping avec R3 pour voir si c’est réellement identique :

R3#ping 172.16.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 46/58/62 ms

Le Ping est concluant donc la configuration que nous venons de modifier revient à faire la même chose.

Regardons la configuration :

R3#show run

ip classless

ip route 172.16.0.0 255.255.252.0 Serial0/0/1

Regardons la table de routage 

R3#show ip route

172.16.0.0/22 is subnetted, 1 subnets

S 172.16.0.0 is directly connected, Serial0/0/1

C 192.168.1.0/24 is directly connected, Serial0/0/1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

C. Configuration d'un réseau d’extrémité

Maintenant pour R1 nous allons le configuré comme un routeur d’extrémité, en effet toutes les chemins sortant du réseau local de R1 passent par R1 via l’interface S0/0/0.

Nous entrons la suite de commandes :

R1(config)#no ip route 172.16.1.0 255.255.255.0 s0/0/0 

R1(config)#no ip route 192.168.1.0 255.255.255.0 s0/0/0 

R1(config)#no ip route 192.168.2.0 255.255.255.0 s0/0/0 

R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0

La dernière commande indique que s0/0/0 de R1 est la route par défaut.

Regardons ce qui c’est passé au niveau de la configuration :

R1#show run

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR        P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

172.16.0.0/24 is subnetted, 2 subnets

C 172.16.2.0 is directly connected, Serial0/0/0

C 172.16.3.0 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 is directly connected, Serial0/0/0

Pour tester si le chemin est respecté nous faisons un Ping de PC1 vers PC3.

PC>ping 192.168.2.10

Pinging 192.168.2.10 with 32 bytes of data:

Reply from 192.168.2.10: bytes=32 time=188ms TTL=125

Reply from 192.168.2.10: bytes=32 time=172ms TTL=125

Ping statistics for 192.168.2.10:

Packets: Sent = 2, Received = 2, Lost = 0 (0% loss), Approximate round trip times in milli-seconds:

Minimum = 172ms, Maximum = 188ms, Average = 180ms

Control-C

Le Ping est ok donc R1 fait bien son travail de routeur d’extrémité.

D. Check result

E.Questions :

Ceci est vrai car dans le réseau 172.16.0.0/22 il y  a les compris l72.16.3.0 172.16.2.0 et 172.16.1.0. Donc ce n’est qu’un et un seul réseau.

172.16.0.0/22 :

•    Adresse du 1er hôte : 172.16.0.1

•    Adresse du dernier hôte 172.16.3.254

L’inconvénient de définir une route par défaut :

•    Niveau sécurité il n’y a aucun contrôle, 

•    Pas de séparation distincts, c'est-à-dire que tous les hôtes du réseau local de R1 peuvent atteindre les 3 autres réseaux.

La seule façon de faire autrement est de rentrer toutes les routes statiques pour atteindre chaque réseau à la main et non une route par défaut.

Il n’est pas possible de jouer avec les masque pour configurer la route de R1 afin d’englober les trois réseaux car ils ne sont pas contigus.

VII.     CABLAGE ET CONFIGURATION D’UN ROUTEUR CISCO

Dans cette partie notre objectif et de réaliser un mini réseau, à l’aide de vrais périphériques. Nous disposons de deux routeurs Cisco de type 2800 et 2 PCs : un sous linux Debian et un sous Windows Vista.

Voici notre plan d’adressage :

A. Configuration R1

1.Connexion sur l’interface console du Routeur R1

L’interface console est l’interface principale permettant de configurer physiquement le routeur. A noter que l’accès physique d’un étranger sur cette interface peut nuire à la sécurité du réseau local.

Tous d’abord nous configurons le routeur R1 (voir figure 11). Afin d'administrer notre R1, nous nous connectons via le port COM de la machine PC1 sur le port console à l’aide d’un câble console de R1, puis nous lançons l'utilitaire « minicom » sous linux

Nous entrons la commande ci-dessous :

$ minicom -o

FIGURE 17-CONFIGURATION MINICOM

Nous configurons « minicom » avec les options suivantes :

•    9600 bits/s ;

•    8 bits de donnée ;

•    N pas de parité ;

•    1 bit d’arrêt.

2.Configuration de l’interface Fast Ethernet 0

Cette interface est utilisée pour connecter des périphériques de Réseaux locaux, comme des ordinateurs ou des commutateurs.

Une fois connecté au Routeur R1 nous pouvons commencer à le configurer.

router > Router> enable 

Router # conf t

 Router(config)#

/*Changement de nom*/

Router(config)#hostname Router1  

Router1(config)#

/*Configuration de fastEthernet 0*/

Router1(config)#interface fastEthernet 0                                          

Router1(config-if)#

Router1(config-if)#ip address 192.168.12.1 255.255.255.0 

/* Activation de l’interface */

Router1(config-if)#no shutdiown

/* Activation et Enregistrement de la configuration */Router1#copy running-config startup-config  Destination filename [startup-config]? Routeur1#  

3.Configuration de l’interface Serial 0 :

Bien que l’on peut connecter deux routeurs entre eux par le biais de l’interface Ethernet, il est vivement conseillé d’utiliser l’interface série. Elle permet d’effectuer une connexion étendue point à point pour relier plusieurs réseaux. Afin de synchroniser les deux routeurs il est primordial de configurer l’horloge sur le routeur DCE. 

D’abord nous regardons si le routeur est DCE ou DTE :

Router1#show controllers serial 0 ….

DCE 

Nous constatons que le routeur 1 est DCE, il faudra donc configurer l’horloge.

Router1> enable  Router1 # conf t

 Router1(config)#

Router1(config)#interface serial 0    

/*Description permet de decrier rapidement*/

Router1(config-if)#description Laison vers R2

/*Configuration IP*/                                           

Router1(config-if)#ip address 192.168.13.1 255.255.255.0  

/*Configuration de l’horloge */                       

 Router1(config-if)#clock rate 64000 

/*activation */                                           

 Router1(config-if)#no shutdown                                                   

Router1(config-if)#exit

Router1(config)#exit

 /*Validation et enregistrement */                                        

Router1#copy running-config startup-config Destination filename [startup-config]?                                           

Building configuration [OK]                                        

A partir de cette étape nous avons configuré les différentes interfaces de R1.

B. Configuration PC1 Linux

Nous configurons l’interface ETH1( nous avons souhaité gardé notre connexion internet sur eth0 ) du PC1.

# ifconfig eth1 192.168.12.2 netmask 255.255.255.0 up

Ensuite nous relions le PC1 au Routeur R1 à l’aide d’un câble Ethernet droit.  Puis nous passons à la phase de tests.

C. Test de connectivité PC1 et R1

Cette première phase de tests entre PC1 et R1 nous permet de tester la bonne communication entre les deux équipements. Pour ce faire nous réalisons un ping entre l’interface eth1 du PC et l’interface FA0/0 du Routeur R1. Nous ne pouvons pas pinger l’interface Serial de notre routeur 1 (voir Figure 16), étant dans deux réseaux différents,  il faut configurer la table de routage de PC 1, ce que nous réaliserons plus tard. 

Depuis PC 1 le ping vers FA 0/0 du routeur R1 est OK :

# ping 192.168.12.1

PING 192.168.12.1 (192.168.12.1) 56(84) bytes of data. 

64 bytes from 192.168.12.1: icmp_seq=1 ttl=255 time=7.78 ms 

64 bytes from 192.168.12.1: icmp_seq=2 ttl=255 time=0.780 ms 

64 bytes from 192.168.12.1: icmp_seq=3 ttl=255 time=0.978 ms 

64 bytes from 192.168.12.1: icmp_seq=4 ttl=255 time=0.685 ms

5 packets transmitted, 5 received, 0% packet loss, time 4001ms rtt min/avg/max/mdev = 1.940/2.762/5.693/1.466 ms

Comme décrit précédemment en attendant de paramétrer la table de routage, le ping vers l’interface serial du Routeur est un échec :

# ping 192.168.13.1

--- 192.168.13.1 ping statistics ---

2 packets transmitted, 0 received, 100% packet loss, time 1009ms

D. Configuration R2

Pour configurer R2 nous procédons de la même façon que sur R1. Nous configurons à l’aide de PC1 branché sur le port console du routeur R2. Nous paramétrons l’application minicom avec les mêmes options que pour routeur R1 96008N1.  Ensuite nous configurons l’interface FA 0 et serial comme indiqué à la figure 11.

A.Configuration de l’interface Fast Ethernet du routeur R2

router > Router> enable 

Router # conf t

 Router(config)#

/*Changement de nom*/

Router(config)#hostname Router2

Router2(config)#

/*Configuration de fastEthernet 0*/

Router2(config)#interface fastEthernet 0                                         

Router2(config-if)#

Router2(config-if)#ip address 192.168.14.1 255.255.255.0 

/* Activation de l’interface */

Router2(config-if)#no shutdiown

/* Activation et Enregistrement de la configuration */

Router2#copy running-config startup-config  Destination filename [startup-config]?

Routeur2#

B.Configuration de l’interface Serial 0 du Routeur R2 :

Normalement le Routeur R2 est le routeur DTE car Routeur R1 est DCE, pour étayer notre affirmation, nous réalisons la commande permettant de tester ceci :

Router2#show controllers serial 0

HD unit 0, idb = 0x9B05C, driver structure at 0x9F3F8 buffer size 1524 HD unit 0, X.21 DTE cable cpb = 0x65, eda = 0x9A80, cda = 0x9800 RX ring with 32 entries at 0x659800

Nous constatons bien que le routeur est DTE , il ne faudra pas configurer la clock rate car c’est le DCE qui donne le rythme de l’horloge pour l’interface série.

Router2 # conf t

 Router2(config)#

Router2(config)#interface serial 0    

/*Description permet de decrier rapidement*/

Router2(config-if)#description Laison vers R1

/*Configuration IP*/                                           

Router2(config-if)#ip address 192.168.13.2 255.255.255.0  

/*activation */                                           

 Router2(config-if)#no shutdown                                                   



Router2(config-if)#exit

Router2(config)#exit

 /*Validation et enregistrement */                                       

Router2#copy running-config startup-config                                       

Nous venons de configurer le Routeur R2. Maintenant il nous reste plus qu’à configurer le PC2 et la table de routage de PC1.

C. Configuration de PC2

Le PC2 étant sous Windows nous le configurons avec l’interface graphique comme illustré en Figure 13.

Le PC2 n’ayant qu’un port réseau, le port Ethernet tous les paquets seront implicitement redirigés vers ce port. Donc nous n’avons pas eu à configurer la table de routage.

FIGURE 18-CONFIGURAITON PC2

E. Configuration des tables de Routage

Notre objectif initial est de configuré notre réseau de  façon à ce que PC1 et PC2 puissent communiquer entre eux.

D’après le plan d’adressage de la  Figure 16 :

PC1 fait partie du réseau 192.168.12.0 et PC2 appartient au réseaux 192.168.14.0. Pour faire communiquer PC1 et PC2 par l’intermédiaire des routeurs R1 et R2 nous devons faire les étapes suivantes :

•    Configurer les table de routage des deux routeurs ;

•    Configurer la table de routage de PC1.

1.Configuration de la table de routage des routeurs :

Nous avons choisi d’utiliser le routage statique mais cependant si il y avait un grand réseau à gérer le routage dynamique serais plus adapté. 

Pour le routeur R1 :

Router1# ip route 192.168.14.0 255.255.255.0 192.168.13.2

Nous indiquons que pour communiquer avec le réseau 192.168.14.0/24 il faut passer par 192.168.13.2 c'est-à-dire l’interface serial du routeur R1.

Nous pouvons vérifier que l’entrée est bien prise en compte avec la commande suivante :

Router1# show ip route

C 192.168.12.0/24 is directly connected, FastEthernet0

C 192.168.13.0/24 is directly connected, Serial0

S 192.168.14.0/24 [1/0] via 192.168.13.2

Pour le routeur R2 :

Nous devons indiquer que pour joindre le réseau 192.168.12.0/24  nous devons passer par l’interface serial à l’adresse 192.168.13.1.

Router2# ip route 192.168.12.0 255.255.255.0 192.168.13.1

Nous pouvons vérifier que l’entrée à été bien enregistrée :

Router1# show ip route

S 192.168.12.0/24 [1/0] via 192.168.13.1

C 192.168.13.0/24 is directly connected, Serial0

C 192.168.14.0/24 is directly connected, FastEthernet0

2.Configuration de la table de routage de PC1

PC1 ayant plusieurs interfaces il nous faut indiquer quel chemin les paquets devront prendre. Pour ce faire nous configurons la table de routage via les interfaces.

Nous devons indiquer comment atteindre le réseau 192.168.1.13 /24 et 192.168.1.14.0/24 afin de communiquer avec PC2.

#route add -net 192.168.13.0 netmask 255.255.255.0 dev eth1 

#route add -net 192.168.14.0 netmask 255.255.255.0 dev eth1

La commande ci-dessous indique que pour atteindre les réseaux 192.168.13.0 et 192.168.14.0 nous passerons par l’interface eth1. Bien sûr nous aurions pu faire avec la commande suivante ou nous indiquons que pour atteindre les réseaux nous passerons par la passerelle 192.168.12.1 :

# route add -net 192.168.13.0/24 gw 192.168.12.1

# route add -net 192.168.14.0/24 gw 192.168.12.1

Nous vérifions la table de Routage de PC1 :

#route

Destination Passerelle              Genmask         Indic Metric Ref    Use Iface

192.168.14.0 192.168.12.1         255.255.255.0   U     0      0        0 eth1

192.168.13.0 192.168.12.1         255.255.255.0   U     0      0        0 eth1

192.168.12.0    0.0.0.0               255.255.255.0   U 0      0        0 eth1

Maintenant l’ensemble de notre réseau est configuré nous pouvons passer à une phase de test généraux. Dans la réalité nous avons fait les tests au fur et à mesure des différentes configurations.

F. Test du bon fonctionnement du réseau

Vérifions la synthèse de la configuration des routeurs :

Routeur 2 :

Router2#show ip interface brief

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0 192.168.14.1    YES manual up                    up    

Serial0 192.168.13.2    YES manual up                    up       

Les interfaces ont bien la configuration faite précédemment et sont up. La configuration à l’air OK.

Routeur 1 :

Router1#show ip interface brief 

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0 192.168.12.1    YES manual up                    up      

Serial0 192.168.13.1    YES manual up                    up      

Même observation que pour le routeur 2.

Ping de PC1 vers PC2 :

# ping 192.168.14.1

PING 192.168.14.1 (192.168.14.1) 56(84) bytes of data.

64 bytes from 192.168.14.1: icmp_seq=1 ttl=254 time=27.4 ms

64 bytes from 192.168.14.1: icmp_seq=2 ttl=254 time=24.3 ms

64 bytes from 192.168.14.1: icmp_seq=3 ttl=254 time=24.2 ms

Le Ping est concluant  La communication est OK, notre réseau à l’air d’être bien configuré. Pour valider l’observation nous faisons un ping de PC2 vers PC1.

Le Ping est Ok donc après toutes ces étapes notre réseau est bien configuré !

VIII.    SYNTHESE

Nous téléchargeons l’exo 7 sur notre poste de travail et ensuite nous l’ouvrons avec Packet Tracer :

# wget

A.Câblage du réseau :

Les routeurs sont reliés entre eux par des câbles DCE. Tous les autres équipement sont reliés par des câbles Ethernet.

B. Application d'une configuration fondamentale aux périphériques

1.Configuration du Routeur HQ :

Changement de nom :

Router>enable

Router# conf t 

Router(config)#hostname HQ

Mot de passe de connexion en mode console

HQ#conf t

HQ(config)#lin con 0

HQ(config-line)#password cisco

HQ(config-line)#

Mot de passe telnet :

HQ#conf t

HQ(config)#line vty 0 4

HQ(config-line)#password cisco

HQ(config-line)#login

Interfaces FA0/0 :

HQ(config)# interface FA0/0

HQ(config-if)#description Liaison vers Lan 192.168.65.0/24

HQ(config-if)#ip address 192.168.64.1 255.255.255.0 HQ(config-if)#no shutdown

Interface FA0/1:

HQ(config)# interface FA0/1

HQ(config-if)#description Liaison vers Lan 192.168.65.0/24

HQ(config-if)#ip address 192.168.65.1 255.255.255.0 HQ(config-if)#no shutdown

Interface S0/0/0:

Vérification que l’interface est bien DCE

HQ#show controllers S0/0/0

Interface Serial0/0/0

Hardware is PowerQUICC MPC860

DCE V.35, no clock

L’interface est bien DCE, il faudra configurer la clock rate.

HQ # conf t

 HQ(config)#

HQ(config)#interface serial0/0/0    

HQ(config-if)#description Liaison vers B1

HQ(config-if)# ip address 10.0.0.1 255.255.255.252

 HQ(config-if)# clock rate 64000

HQ(config-if)#no shutdown                                                   

HQ(config-if)#exit

HQ(config)#exit

HQ#

Interface S0/0/1:

Vérification que l’interface est bien DCE :

HQ#show controllers S0/0/1

Interface Serial0/0/0

Hardware is PowerQUICC MPC860

DCE V.35, no clock

HQ # conf t

 HQ(config)#

HQ(config)#interface serial0/0/1

HQ(config-if)#description Liaison vers B2

HQ(config-if)# ip address 10.0.0.5 255.255.255.252

HQ(config-if)# clock rate 64000

HQ(config-if)#no shutdown                                                   

HQ(config-if)#exit

HQ(config)#exit

HQ#

Sauvegarde de la configuration :

HQ#copy run start

2.Configuration du Routeur B1:

Changement de nom :

Router>enable

Router# conf t 

Router(config)#hostname B1

Mot de passe de connexion en mode console :

B1#conf t

B1(config)#lin con 0

B1(config-line)#password cisco

B1(config-line)#login

Mot de passe Telnet :

B1#conf t

B1(config)#line vty 0 4

B1(config-line)#password cisco

B1(config-line)#login

Interfaces FA0/0 :

B1(config)# interface FA0/0

B1(config-if)# ip address 172.24.0.1 255.255.0.0

B1(config-if)#no shutdown

Interface FA0/1:

B1(config)# interface FA0/1

B1(config-if)# ip address 172.25.0.1 255.255.0.0

B1(config-if)#no shutdown

Interface FA1/0:

B1(config)# interface FA0/1

B1(config-if)# ip address 172.26.0.1 255.255.0.0

B1(config-if)#no shutdown

Interface FA1/1:

B1(config)# interface FA0/1

B1(config-if)# ip address 172.27.0.1 255.255.0.0

B1(config-if)#no shutdown

Interface S0/0/0:

Vérification que l’interface est bien DTE

B1#show controllers S0/0/0

Interface Serial0/0/0

DTE V.35, no clock

L’interface est bien DTE , il faudra configurer la clock rate.

B1 # conf t

 B1(config)#

B1(config)#interface serial0/0/0    

B1(config-if)#description Liaison vers HQ

B1(config-if)#ip address 10.0.0.2 255.255.255.252

B1(config-if)#no clock rate

B1(config-if)#no shutdown                                                   

B1(config-if)#exit

B1(config)#exit B1#                                        

Sauvegarde de la configuration :

B1#copy run start

3.Configuration du Routeur B2:

Changement de nom :

Router>enable

Router# conf t 

Router(config)#hostname B2

Mot de passe de connexion en mode console:

B2#conf t

B2(config)#line con 0

B2(config-line)#password cisco

B2(config-line)#login

Mot de passe telnet:

B2#conf t

B2(config)#line vty 0 4

B2(config-line)#password cisco

B2(config-line)#login

Interfaces FA0/0:

B2(config)# interface FA0/0

B2(config-if)# ip address 192.168.0.1 255.255.255.0

B2(config-if)#no shutdown

Interface FA0/1:

B2(config)# interface FA0/1

B2(config-if)# ip address 192.168.1.1 255.255.255.0

B2(config-if)#no shutdown

Interface FA1/0:

B2(config)# interface FA0/1

B2(config-if)# ip address 192.168.2.1 255.255.255.0

B2(config-if)#no shutdown

Interface FA1/1:

B2(config)# interface FA0/1

B2(config-if)# ip address 192.168.3.1 255.255.255.0

B2(config-if)#no shutdown

Interface S0/0/0:

Vérification que l’interface est bien DTE

B2#show controllers S0/0/0

Interface Serial0/0/0

DTE V.35, no clock

L’interface est bien DTE, il faudra configurer la clock rate.

B2 # conf t

 B2(config)#

B2(config)#interface serial0/0/0    

B2(config-if)#description Liaison vers HQ

B2(config-if)# ip address 10.0.0.6 255.255.255.252

B2(config-if)#no clock rate

B2(config-if)#no shutdown                                                   

B2(config-if)#exit

B2(config)#exit B2#                                        

Sauvegarde de la configuration :

B2#copy run start

4.Configuration des PC :

              Pour configurer nous utilisons nous utilisons l’outil graphique comme l’illustre la figure ci-dessous : 

IP

Masque

Passerelle

PC1

172.24.0.1

255.255.0.0

172.24.0.1

PC2

172.25.0.1

255.255.0.0

172.25.0.1

PC3

172.26.0.1

255.255.0.0

172.26.0.1

PC4

172.27.0.1

255.255.0.0

172.27.0.1

PC5

192.168.64.10

255.255.255.0

192.3168.64.1

PC6

192.168.65.10

255.255.255.0

192.3168.65.1

PC7

192.168.0.10

255.255.255.0

192.168.0.1

PC8

192.168.1.10

255.255.255.0

192.168.1.1

PC9

192.168.2.10

255.255.255.0

192.168.2.1

PC10

192.168.3.10

255.255.255.0

192.168.3.1

C. Configuration d'un routage statique et par défaut

1.Routeur HQ :

HQ dois communiquer avec les réseaux de B1 c'est-à-dire de 172.24.0.0 à 172.27.0.255. Donc nous devons choisir un masque qui englobe les c’est réseaux. 

•    Après un petit calcule nous mettons le masque 255.252.0.0, qui permet d’englober les réseaux de B1.

HQ dois communiquer avec les réseaux de B2 c'est-à-dire de 192.168.0.0  à 192.168.3.255. Donc nous devons choisir un masque qui englobe les c’est réseaux. 

•    Après un petit calcul nous mettons le masque 255.255.252.0, qui permet d’englober les réseaux de B2.

HQ # 

HQ#ip route 172.24.0.0 255.252.0.0 Serial0/0/0

HQ# ip route 192.168.0.0 255.255.252.0 Serial0/0/1 HQ#copy run start

2.  Routeur B1 :

Nous mettons la route par default sur la sortie S0/0/0

B1 # 

B1# ip route 0.0.0.0 0.0.0.0 Serial0/0/0  B1#copy run start

3.  Routeur B2:

Nous mettons la route par default sur la sortie S0/0/0

B2 # 

B2# ip route 0.0.0.0 0.0.0.0 Serial0/0/0

B2#copy run start

D.Check result:

A.Test des connexions:   

1.Tests de communication

Afin d’effectuer des tests de connexion nous allons réaliser des ping entre les différents équipements du réseau. Le réseau étant constitué de beaucoup d’équipements nous n’en illustrerons que les plus importants.

B2 vers B1 FA/0/0 :

B1#ping 192.168.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 47/69/109 ms

B1#

Le ping est concluant.

Ping PC8 vers PC5 :

PC>ping 192.168.64.10

Pinging 192.168.64.10 with 32 bytes of data:

Reply from 192.168.64.10: bytes=32 time=96ms TTL=126

Reply from 192.168.64.10: bytes=32 time=110ms TTL=126

Reply from 192.168.64.10: bytes=32 time=156ms TTL=126

Reply from 192.168.64.10: bytes=32 time=109ms TTL=126

Ping statistics for 192.168.64.10:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds:

    Minimum = 96ms, Maximum = 156ms, Average = 117ms

           Ping PC3 vers PC6:

PC>ping 192.168.65.10

Pinging 192.168.65.10 with 32 bytes of data:

Reply from 192.168.65.10: bytes=32 time=109ms TTL=126

Reply from 192.168.65.10: bytes=32 time=125ms TTL=126

Reply from 192.168.65.10: bytes=32 time=90ms TTL=126

Reply from 192.168.65.10: bytes=32 time=141ms TTL=126

Pendant la configuration de la maquette, tous les équipements ont communiqués entres eux de bout en bout.

2.Examinez la configuration.

Routeur HQ :

HQ#show ip interface brief

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 192.168.64.1    YES manual up                    up

FastEthernet0/1 192.168.65.1    YES manual up                    up

Serial0/0/0 10.0.0.1        YES manual up                    up

Serial0/0/1 10.0.0.5        YES manual up                    up

La table de routage :

HQ#show ip route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 2 subnets

C 10.0.0.0 is directly connected, Serial0/0/0

C 10.0.0.4 is directly connected, Serial0/0/1

S 172.24.0.0/14 is directly connected, Serial0/0/0

S 192.168.0.0/22 is directly connected, Serial0/0/1

C 192.168.64.0/24 is directly connected, FastEthernet0/0

C 192.168.65.0/24 is directly connected, FastEthernet0/1

La configuration générale (raccourcie par soucis de lisibilité) :

HQ#show run

!

hostname HQ

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0 enable password cisco

!

ip ssh version 1

!

!

interface FastEthernet0/0  description vers Lan 192.168.64.0/24  ip address 192.168.64.1 255.255.255.0  duplex auto  speed auto

!

interface FastEthernet0/1  description vers lan 192.168.65.0/24  ip address 192.168.65.1 255.255.255.0  duplex auto  speed auto

!

interface Serial0/0/0  description Liaison vers B1  ip address 10.0.0.1 255.255.255.252  clock rate 64000

!

interface Serial0/0/1 description Liaison vers B2  ip address 10.0.0.5 255.255.255.252  clock rate 64000

!

!

ip classless ip route 172.24.0.0 255.252.0.0 Serial0/0/0  ip route 192.168.0.0 255.255.252.0 Serial0/0/1 

!

!

!

!

!

line con 0

 password cisco  login

line vty 0 4  password cisco  login

!

!

end

Le routeur B1 :

Table de routage :

B1#show ip route

Gateway of last resort is 10.0.0.1 to network 0.0.0.0

10.0.0.0/30 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, Serial0/0/0

C 172.24.0.0/16 is directly connected, FastEthernet0/0

C 172.25.0.0/16 is directly connected, FastEthernet0/1

C 172.26.0.0/16 is directly connected, FastEthernet1/0

C 172.27.0.0/16 is directly connected, FastEthernet1/1

S* 0.0.0.0/0 [1/0] via 10.0.0.1

is directly connected, Serial0/0/0

La configuration des adresses IP :

B1#show ip interface brief

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 172.24.0.1      YES manual up                    up

FastEthernet0/1 172.25.0.1      YES manual up                    up

Serial0/0/0 10.0.0.2        YES manual up                    up

Serial0/0/1 unassigned      YES manual administratively down down

FastEthernet1/0 172.26.0.1      YES manual up                    up

FastEthernet1/1 172.27.0.1      YES manual up                    up

La configuration générale :

B1#show run

Building configuration

Current configuration : 849 bytes

!

version 12.3

no service password-encryption

!

hostname B1

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0 ip address 172.24.0.1 255.255.0.0  duplex auto  speed auto

!

interface FastEthernet0/1 ip address 172.25.0.1 255.255.0.0  duplex auto  speed auto

!

interface Serial0/0/0  description Liaison vers HQ  ip address 10.0.0.2 255.255.255.252

!

interface Serial0/0/1  no ip address

 shutdown

!

interface FastEthernet1/0 ip address 172.26.0.1 255.255.0.0  duplex auto  speed auto

!

interface FastEthernet1/1 ip address 172.27.0.1 255.255.0.0  duplex auto  speed auto

!

interface Vlan1  no ip address

 shutdown

!

ip classless ip route 0.0.0.0 0.0.0.0 10.0.0.1  ip route 0.0.0.0 0.0.0.0 Serial0/0/0 

!

!

!

!

!

line con 0

 password cisco  login

line vty 0 4

 password cisco  login

!

!

end

Le routeur B2 :

Configuration des adresses IP :

B2#show ip interface brief

Interface IP-Address      OK? Method Status                Protocol

FastEthernet0/0 192.168.0.1     YES manual up                    up

FastEthernet0/1 192.168.1.1     YES manual up                    up

Serial0/0/0 10.0.0.6        YES manual up                    up

Serial0/0/1 unassigned      YES manual administratively down down

FastEthernet1/0       192.168.2.1     YES manual up                    up

FastEthernet1/1 192.168.3.1     YES manual up                    up

Table de routage :

B2#show ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/30 is subnetted, 1 subnets

C 10.0.0.4 is directly connected, Serial0/0/0

C 192.168.0.0/24 is directly connected, FastEthernet0/0

C 192.168.1.0/24 is directly connected, FastEthernet0/1

C 192.168.2.0/24 is directly connected, FastEthernet1/0

C 192.168.3.0/24 is directly connected, FastEthernet1/1

S* 0.0.0.0/0 is directly connected, Serial0/0/0

Configuration générale :

B2#show run

Building configuration

Current configuration : 819 bytes

!

version 12.3 no service password-encryption

!

hostname B2

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

enable password cisco

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0 ip address 192.168.0.1 255.255.255.0  duplex auto  speed auto

!

interface FastEthernet0/1

 ip address 192.168.1.1 255.255.255.0  duplex auto  speed auto

!

interface Serial0/0/0  ip address 10.0.0.6 255.255.255.252

!

interface Serial0/0/1  no ip address

 shutdown

!

interface FastEthernet1/0

 ip address 192.168.2.1 255.255.255.0  duplex auto  speed auto

!

interface FastEthernet1/1 ip address 192.168.3.1 255.255.255.0  duplex auto  speed auto

!

interface Vlan1  no ip address

 shutdown

!

ip classless ip route 0.0.0.0 0.0.0.0 Serial0/0/0 

!

!

!

!

!

line con 0  password cisco  login

line vty 0 4

 password cisco  login

!

!

end



6534