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Working better with Excel
1 Basics

1.1 Right click menus

Using the ‘Right click’ to select the menu is the fastest way to work with a spreadsheet. This
approach is not confined to just Excel but to all office products. The right click always brings up
context sensitive menus. Thus choice is narrowed to the possible actions that can be applied to
the object. You will observe that navigating to different sections of the worksheet and using the
right click always brings up different menus that are relevant to your current selection.

1.2 Navigation / key actions

Use short cut navigation keys to move around the worksheet quickly. The functionalities of the
keys are given below:

N L

Ctrl + {arrow} or

Cursor will move to the last entry in the direction of the arrow

[End], {arrow} key

Ctrl + Home Select cell Al

Ctrl + End Selects bottom right of the worksheet
Ctrl + ¢ Copy

Ctrl + X Cut

Ctrl+p Paste

Ctrl + s Save

Ctrl + W Close sheet

Ctrl + o File open

Ctrl + p Print

1.3 Newin XP

1.3.1 Task Pane

This is new feature of XP which is quite handy. The task pane contains the possible actions
relevant to the context. In earlier versions of Excel this was handled by dialog boxes. A dialog
box has to be closed before you can resume the work. The task pane on the contrary can be
invoked when required and does not obstruct work. It can also be closed when not required.

If the Task Pane is not visible, Click View->Task Pane to display. Click ‘x’ on the Task Pane to

close. Reposition the task pane by dragging it.

1.3.2 Smart Tags

The Smart Tags appear whenever you complete an action. It presents options that can be
applied to that action. The list displayed consists of relevant options. For e.g. after you copy and
paste, the Smart Tag displays the following options:

Keep source formatting

Match destination formatting
Values and number formatting
Keep source column width
Formatting only
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e Link cells

The choices above are obvious. Smart Tags make it easy for us to extend the work. In effect this
gives another option to modify the action.

1.3.3 Function arguments

Whenever a function is to be used, as soon as you type the function, the function arguments are
displayed automatically. The earlier version displayed the function argument only when we called
for this by typing ‘Ctrl+Shift+A’. While this was a help, the down side was that the function
arguments were typed in the formula bar and each of the argument had to be replaced with
value. XP just displays the function argument separately without actually getting in the way.

1.4 Customizing the Toolbar

The tool bar on view can be customized by adding new buttons to it. A new toolbar can also be
created. You can also load the necessary toolbars by calling the tool bars. From the View menu,
click on Toolbars and select the tool bars required.

Steps in customizing

1.4.1 Displaying new toolbars

In the View menu, choose Toolbar and customize. The dialog box shows the option with Toolbar.
The first tab marked Toolbars lists all the available toolbars. Click on the toolbars you want to
use. These are immediately loaded. Move the toolbars around by clicking at the left extreme.
Once you drag it into the menu area, the will automatically align.

1.4.2 Adding new buttons to tool bars

The second tab marked as Commands gives the list of buttons and action settings. Whatever
buttons are required, drag them over to the menu or within a toolbar and drop them there. They
become part of the toolbar for future use. In some cases there are no buttons associated with a
menu like ‘Save Workspace'. If this is included in the menu, the entire text is displayed as part of
menu. A few of these commands will occupy sizeable space. It is possible to substitute a button
instead of the text. Once the ‘Save Workspace' is placed in the toolbar, right click on the newly
added button to display the associated menu. In the name box the name ‘Save &Workspace’ is
shown. It can be substituted with any text. The Character next to the ‘& * will be underlined in
the menu and the button can be called through the key board short cut by typing that letter with
ALT key held down. Click on the Change button image to give a button face to the menu and
choose ‘Text Only' (in menus)’ to eliminate the text description and show only the buttons. Click
Close. You will notice that the new button in included in the toolbar and once you take your
mouse over the button, the description is displayed.

1.4.3 Adding new tool bars

From the View, Toolbar and Customize, click on new to create a new tool bar. Give this an
appropriate name and as described above, proceed to place it in the menu and add button to it.

1.5 File handling
Excel offers number of file handling possibilities. Here we will review some of the features:
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1.5.1 File open

Open not only Excel files but files of other popular spreadsheet applications also. The list of type
of files that Excel will open will appear when you click the *File of type’ list in the file open
dialogue. If the file format clearly defines the field positions, Excel will immediately open the file.

1.5.2 Opening text files

In the case of text file where this is not so, Excel will guide you through a ‘Text Import Wizard'.
Select the text file you want to open. You can start by select specifying the type of file in the ‘File
Name' drop down. The following are the steps involved:

1.5.2.1 Steplof3

Specify if the file type is Delimited or Fixed width. Delimited type is where the fields are
separated through a field marker. Select fixed width if no specific delimiters have been used. It is
common practice to specify a character like ‘Tab’, *:",”;’ as field separators. These characters will
be added at the end of each field to mark the end of the field content.

1.5.2.2 Step2of3

The screen displayed will be depending upon the selection in earlier screen. If the file type is
delimited, then the list of field markers will be displayed. Click the appropriate field marker and
Excel will automatically cut fields at the location of field markers. If the file type is fixed width,
then Excel will allow you to specify the field width. Simply click in the data preview window and
the field will be cut at that point. The click acts as a toggle. To remove the field cut, click again
on that. You can also click the line where a field is being cut and move it to a required location.
Browse through the data and mark fields where required.

1.5.2.3 Step3o0of3

This lets you select the format applicable for the columns. You can also mark the columns as to
be skipped. These will not be imported.

Once you click Finish, the data will be converted to Excel format.

Work

Try opening the text files ‘Employee.txt’ and ‘Invoice.txt’. ‘Employee.txt’ does not contain a field
delimiter and ‘Invoice.txt’ is a tab delimited file.

1.5.3 File search

Use this facility to search for files by specifying multiple criteria. When you are in the File Open
dialogue, click Tools and select ‘Search’. Excel will display a dialog with tabs as ‘Basic’ and
‘Advanced’. Use the Basic to find file name containing specific characters. Specify the file name
in the ‘Search text’ box. To search for all Excel files you can type “*.xlIs” and the system will
display all files with *xIs" extensions. Specify the location in the ‘Search in’ drop down. This
determines the directories which will be searched.

The *‘Advanced’ option helps us to locate the file based on file contents and file properties. When
you click *Advanced’ tab you find that the ‘Text of property’ as the default selection in the
‘Property’ drop down. In case you wish to search for files containing specific text such as ‘Budget
for Feb 2003’, then enter the text. The search will list all files containing this text. You can also
search based on the other criteria in the ‘property’ drop down.
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1.5.4 Workspace

There may a situation in which multiple files have to be opened together. This requirement
depends on the values being shared across multiple files. By saving the related files as a
workspace, you can open all the files together by just opening the workspace. To achieve this
first open all the related files and ensure that only the required files are opened and other un-
related files have been closed. Click File > Save Workspace and in the dialogue specify the name
and location. If you want to open all the related files together click File - Open and in the type
of files list choose workspaces. Excel will list all available workspace definitions. Select the
workspace to open.

1.5.5 Files based on templates

Templates are files, which have certain definitions and formatting. Typical example will be an
invoice layout file. Whenever you wish to print an invoice you may want the new file to be
created to be based on a template. To attach a file to a template while creating a new file click
File > New, a dialogue will appear. The general tab will display the templates you have defined.
Choose the applicable template. The file loaded will be similar to the template file.

1.6 Cell referencing
There are two types of cell referencing:

e Relative
e Absolute

1.6.1 Relative reference

The relative referencing is fundamental to Excel and without which the worksheet will be
unworkable. We refer to the cell by using Column and row co-ordinates. Letters A, B, C, ... IV
are used to denote the 256 columns and numbers 1 to 65536 are used to denote the rows. In a
typical formula whenever we want to refer to the cell contents we use the cell address as a
combination of column and row reference to point to a cell. Let us assume that a formula is
entered in cell F10 as '‘=A10". If this formula is copied to other columns the column reference is
adjusted. If the formula is copied to cell H10, the formula will now read as '‘=C10’. The column
reference A has been substituted with C. Similarly if the formula is copied down then the
reference will be adjusted for rows. If the formula from F10 is copied to F15 then the new
formula in cell F15 will read *=A15". If the formula is copied both across and down, then the both
column and row references will be adjusted suitably. For e.g. If the formula in cell F10 is copied
to cell H15, the new formula in cell H15 will read as *=C15".

1.6.2 Absolute reference

In the case of absolute reference, the references to the original row and/or column references do
not change and always point to original row/column reference. Whenever a ‘'$’ sign is added to
the column/row reference, the reference is made absolute. For e.g. in cell F10 if we have a
formula as ‘=$A$10’, there will be now change in the formula if we copy this to cell H15. The
new formula in cell H15 will still read as *‘=$a$10’ as the references have been frozen. There are
three possibilities here:

e Both row and column references are absolute ($A$10)
¢ Only column reference is absolute and row reference will vary ($A10)
e Only the row reference is absolute and column reference will vary (A$10)

If the cell F10 contains a formula as $A10, if it is copied to other columns, the column reference
will point to A only. However the row reference will change relatively. Similarly if the formula is
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'=A$10, then the row reference will always be 10, but the column reference will change
relatively.

1.6.3 Using names

The complexity is using cell references especially where we have to use a combination of row
and column absolute reference can be easily overcome by using names. Range names will
automatically use relative or absolute reference according to the context.

1.7 Range Names

1.7.1 What are Range Names

Range names are a very important idea within Excel. A single cell or a group of cells can be
defined as a name and referred to by that name within that worksheet, workbook and also across
workbooks. Broadly a range name can be classified into two categories:

¢ Name defined for a single cell
¢ Name defined for a group of cells

While name given to a single cell can be compared to a variable defined within a program, a
range name containing a group of cells can be compared to a ‘mini database’. These also lend
themselves to be exploited by most of the functions within Excel. It is perfectly possible to work
without any range names, but this could become cumbersome when a worksheet gets sizeable
and contains a number of formulas.

The list of hames defined could be found by clicking on the name box at the left of the formula
bar. You can also use the Go To command by using F5 key and enter the name to go the name
area.

1.7.2 How to define Range Names

Select a single cell or a range of cells for which a name is to be assigned. Then from the Insert
menu, select Names and Define. In the dialog box enter the name for the range. The insert name
dialog box displays the existing hames defined. Enter the name and click on Add button. Note
that this refers to the box pointing to the cell or range of cells from where you called the Insert
Name command and also that the reference is absolute. This means that the name is not
dependent on the cursor position and will always refer to the particular location. However by
allowing the reference to be relative we can define ranges which are dynamic and the area
selected will be dependent on the position of the cursor. We will review the use of dynamic
ranges in conjunction with OFFSET function.

1.7.3 Why use Range Names

1.7.3.1 Readability
The worksheets become readable. It is always easier to understand a formula, Production * Rate
rather than B6*D5.

1.7.3.2 Range names are intelligent

Range names have the ability to apply the names as a variable according to the context. Let us
assume that you have given a range name ‘Production’ to quantity of production from Year 1
through Year 5. (E.g. C in worksheet) The value is to be derived by multiplying these values by a
single rate what we will define as SaleRate. When we apply the formula Production * SaleRate
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for the first year and copy it across the years 2 through 5, the formula remains the same but the
value is correctly arrived at. When it comes to the second year, the second element within the
range production has correctly been used.

The same principle is also at work when we perform additions of elements within a range name.
(E.g. B in worksheet). Here East, West, North and South are range names. Each of these names
contains a column of value and when addition is performed, the right element within the name is
applied. If we try to add say East + West in a location like J31, Value error will be returned, as
the correct context is not available to the function.

1.7.3.3 Useful within functions

When functions are used within Excel, the range names will become the standard way. The
functions can become a little complicated and use of names is necessary to easily understand the
model we are building. We can also capitalise on the ability of the names to convert them in to
absolute or relative reference depending on the context.

1.7.4 Type of Range Names
Range names can be either global or local

1.7.4.1 Global Names

Names as default will be global. This means that the names declared from within any worksheet
are available to the whole of the workbook.

1.7.4.2 Local names

Names can also be declared specifically for the sheet. In such cases the names will not be
available outside that sheet unless also used with the sheet prefix. While defining a name just
prefix the name with the sheet name. E.g. If you want to define cell A15 within sheet Sum as a
local name ‘Approach2’ then the name will be defined as ‘Sum!Approach2’. The name Approach2
will be available only to sheet Sum. It can be referred to from other sheets as ‘Sum!Approach2’
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Examples of range name in use

Simple naming of variables

S| No Name Salary
1 Ramesh 3500
2 Suresh 3000
3 Mahesh 5000
4 Saravanan 2500
5 Lalitha 3000
6 Jose Thoma 7000

24000 ——» Range "Total Salary”
Range "Salary"
Formula; =Sum(Salary)

Annual Salary 288000—— Formula; =TotalSalary
Bonus Rate 20% * Year
Bonus Amount 57600 =AnnualSalary*Bonus
Rate
A B C D E F G
22
23 Range Names in use in multiplication
24 Year 1 Year 2 Year 3 Year 4
25 Production (in units) 500 600 700 800
26 Rate 50
27 Total value 25000 30000 35000 40000
Range "Productiop
Range "SaleRate"
Formula; =Production*SaleRate
Work

Open 'Basics.xls” and select ‘RangeName’ tab. Click the name box drop down and select ‘ExA’,
‘ExBC’ or ‘ExD’ to view some hames in use.

1.8 Formatting

Excel offers a number of different formatting options for us. Formatting can be defined as the
action applied on the underlying cell value to display it in a specific manner on the screen. Even
after the formatting the underlying value remains unchanged. Excel allows some advanced
formatting options where it is possible to display a numeric value as text or as combination of the
numeric value and text. Always take note of only the underlying value and not the value
displayed as only the underlying value is used in all calculations. Let us see some of the simple
formatting options
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1.8.1 Number

The options under the Number tab in format cells dialog give us a choice of simple formatting
such as number, date, text, percentage etc. Once you select the type of format a sample of the
display is also shown.

1.8.2 Alignment

This offers choices on how the text will be justified. In this ‘Wrap text’ allow us to fold the text in
the cell so that lengthy column headers can be folded and displayed in the same cell instead of
breaking these down over a few cells. The ‘Merge cells’ allow us to merge multiple cells in to one.
Excel then uses the top/left cell’s reference with the merged cell in all calculations.

1.8.3 Custom formatting

Under the Number tab we also find a custom format option. Using this it is possible to look at the
type of data in the cell and apply a specific format according to the type. We can enter up to four
specific format options for positive, negative, zero and text values. These formats have to be
separated by a semi colon. The linked Excel file gives an illustration of these techniques.

1.8.4 Conditional formatting

The format options above allow us to present the underlying call value the way we want. This
includes displaying a numeric value denoting Rupees as ‘Rs.5000’. The value in the cell is only
5000. The conditional format on the other hand display the underlying value as it is but allows us
to display it in different format and background colour. The objective is to identify critical data in
our worksheet and this facilitates review easier. Whenever we want to set alerts we can resort to
conditional formatting as this will display the data in specific formatting style so that it catches
our attention.

Click *Format’ in the menu and choose ‘Conditional formatting’. This allows us to use up to three
conditions.
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Using wrap text

Particulars Op WDV| Additions| Sales Cl WDV| Depreciation Depreciation| Net value| Net Value
of assets for the]~_ upto PY for CY| CcY PY
year| N
\1Headers written in multiple cells |
Particulars of | Op WDV| Additions| Sales Cl WDV| Depreciation Depreciation upto CY| Net value| Net Value
assets for the upto PY CY PY
year|
|Headers written in single cell |
Custom format
Value Value after Format text
entered formatting
Text formatting 1500 USD 1500 "UsD" 0
Scaling numbers 125123456 125,123 #,##0,
Vaidation 123 123.00 0.00;"Positive only!"
-123 Positive only! 0.00;"Positive only!"
0 0.00 0.00;"Positive only!"
123 123.00 [Blue]0.00;[Red](0.00);[Blue]-0-
Multiple formatting ;[Yellow]General
-123 (123.00) [Green]0.00;[Red](0.00);[Blue]-0-
;[Yellow]General
0 -0- [Green]0.00;[Red](0.00);[Black]-0-
;[Yellow]General
Text Text [Green]0.00;[Red](0.00);[Blue]-0-

Telephone numbers

448254060 (44)-825 4060
431704547
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Example of conditional formatting

Summarised Income and expenditure

Income 35300 36100 29800 33800 39500
Expenditure 25625 28200 24300 24000 32000
Operating profit 9675 7900 5500 9800 7500
Ratio 41% 88% 8.46% 8.99% 8.99%
Ratio > 25% Ratio > 20% & <25%

/

Ratio < 20%

Work

Open the 'Basics.xls’ file and select ‘Formatting’ tab. Click the name box drop down and select
‘ExA’, '‘ExB’, '‘ExXC" and ‘ExD’ to view different formatting options.

1.9 Cut, Copy and Paste

1.9.1 Fast copy

These are commonly used facilities within Excel. Let’s review some of the useful facilities. While
copying a formula use the *Fill handle’ to quickly copy to multiple rows. As you move your mouse
to the bottom right of the cell over the dark square, the cursor shape changes to that of the
crosshair. This is the fill handle. Drag the fill handle in the direction in which you wish to copy the
formulas. Alternatively, double click the fill handle and Excel will respond by copying the formulas
all the way down. The number of rows to which the data will be copied will depend on the data
content in the column to the left of the cell being copied. If the column to the left contains data
for 100 rows, the formula will also be copied for 100 rows.

1.9.2 Links to other office module

The paste special option allows a humber of options to copy by maintaining the link to the source
module. Let us say that you wish to copy the contents of the Excel sheet into a Word document
and you wish to update the Word document whenever changes are made to the sheet in Excel,
this can be accomplished using the paste special. Copy the content from Excel sheet and after
selecting Word, click Edit in menu and choose Paste special. The dialog displays two options
Paste or Paste line. Choose Paste line and choose the type for display. All of these options will
maintain the link to the source data and whenever source data changes you have the option to
update the target file. Whenever you open the target file, the data will be updated for the latest
data in the source file.
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2 Functions

Functions can be defined as Excel program returning a value of specific type. Most functions
accept arguments which are use in its calculation. The argument list can contain absolute values
or references to cells containing values.

To view the examples under functions open 'Functions.xls’. The workbook contains various sheets
for the functions covered. Click the appropriate tab to view examples.

2.1 Sum

Function which aggregates a set of values contained within the argument list. The argument can
also include multiple cell lists separated by commas.

2.2 Round Functions

Round function round off the digits to the number of digit specified in the function argument. Use
of this function is often necessary to avoid certain apparent ‘mistakes’ appearing in the total. The
variants of Round are RoundUp and RoundDown function, which perform as the name implies.
Round is natural function and rounding off to higher or lower depending on the digit value.

The round functions round off the value to the nearest digits when the second argument, the
number of digits is positive. When this number if negative, the round functions round off to the
nearest tens and hundreds. *-1" will cause the round off function to round off to the nearest tens
and -2 will cause the round off function to round off to the nearest hundred.

Round function in use
B (o D E F G
Using Round function D7

A
3
4
5 Details of Other Expenses
6
7
8

Printing and stationery 4400.4 4400 4400
Postage and telephone 9200.4 9200 9200\
9
10 Total 13600.8 13601 13600 |=ROUND(D7.0)
11 / /
12
13 =SUM(E7:E8) =SUM(F7:F8)
14
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2.3 Average

The average function calculates the average value of the list of values given as arguments. The
syntax is

=AVERAGE (numberl, [numberl], ...)

Example of average function

A B C D E F G H
Date Units

3 generated

4 01-Jan-99 500 Average of units generated for each month

5 02-Jan-99 973

6 03-Jan-99 934 Jan 533

7 04-Jan-99 354 Feb 509

8 05-Jan-99 554 March 468

9 06-Jan-99 693

10 07-Jan-99 100

11 08-Jan-99 250 |=ROUND(AVERAG E(C4:C34),0) |

12 09-Jan-99 527

13 10-Jan-99 565

14 11-Jan-99 335

15 12-Jan-99 956

16 13-Jan-99 381

17 14-Jan-99 952

18 15-Jan-99 366

19 16-Jan-99 365

20 17-Jan-99 627

21 18-Jan-99 383

22 19-Jan-99 27

23 20-Jan-99 400

24 21-Jan-99 761

25 22-Jan-99 556

26 23-Jan-99 487

27 24-Jan-99 918

28 25-Jan-99 721

29 26-Jan-99 947

30 27-Jan-99 784

31 28-Jan-99 339

32 29-Jan-99 239

33 30-Jan-99 443

34 31-Jan-99 75
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2.4 Date Functions
Excel supports several date and related functions and few of which are given below:

Function Syntax Explanation

=DATE(year, month, day) @ Accepts year, month and date as arguments
and returns date value

=YEAR(serial_number) Returns the year of a date value.
=MONTH(serial_number) Returns the month of date value.

=DAY(serial_number) Returns the day of the month

With Date functions, it is possible to calculate the difference between two date values. The Year,
Month and Day functions accept serial number of the date as argument. Remember that the date
value is actually a number formatted as date. The value 1 corresponds to the first date of 1900.

2.4.1 Now
The Now function returns the current date with time

2.4.2 Today
The Today function returns the current date

2.4.3 EOMONTH (current_date, months)

This function returns the month end date. The calculation is based on the current date which is
the first argument. The second argument specifies the number of months to be offset from the
month of the current date. EOMONTH (1/1/2003, 0) will return 31-01-2003. If the month is
changed to 1 the month end date of the next month is returned.

Example of Date functions

Simple date entry N
»1/20/2003 |

20-Jan-03 01-Jan-03
21-Jan-03
22-Jan-03
23-Jan-03

—»(=DATE(2003,1,1) |

Page 16/49



SEMINAR ON “EXCEL AS AUDIT TOOL”

A B C D E F G H |
10 Related Date functions

1 O/v1=DA\((E;1 5) |
12 20-Jan-03 Day of date 2

13 21-Jan-03

14 22-Jan-03 Month of date f——>[=MONTH(B17) |
15 23-Jan-03

16 24-Jan-03 Year of date 2003—>|=YEAR(B19) |
17 25-Jan-03

18 26-Jan-03

19

20 Due date 31-Jan-03

21 Current date 15-Jan-03

22

23 No of days remaining 16——»|=F23-F24

Page 17/49



SEMINAR ON “EXCEL AS AUDIT TOOL”

2.5 Character Functions

There are a number of useful character functions by which we can put together character strings
in different cells and also split the strings. The character functions are described below:

=CONCATENATE(textl This function ‘adds’ the values found in the argument
, [text2], ...) list together

=LEFT(text, [num of In a given string, number of characters from left of
chars]) string

=RIGHT(text, [num of  In a given string, number of characters from right of
chars]) string

=Mid(text, start num, , In a given string, anchors at the character specified as
num of chars) the start number and displays the next number of
characters in the string.

Instead of using the concatenate function, the ‘&” can also be used to add strings together. For
E.g. '=A1&B1&C1’ would put together the values in cells A1, B1 and Cl1.

Example of Character Functions

A B C D E F G H

4 This is a sample  text /M his is a sample text

5 his is a sample text

6

7 There are 5 boxes There are 5 boxes

8

9

10 Length of the first string 2*1\

11

12 Left 5 characters This =LEN(G4

13

14 Right 5 characters text

15

16 5 Character starting from 6th position is a\
=MID(G4,6,5

=CONCATENATE(B4," ",C4," ",D4," ",E4) |
[-B48&" "&C48" "&D4&" "&E4 |

=RIGHT(G4,5

=LEFT(G4,5)
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2.6 Logical Functions

The logical functions include AND and OR. These return a TRUE or FALSE value depending on the
test. In the case of AND function, TRUE value will be returned only if all the conditions are true
and in the case of OR function any one of the conditions being true.

=AND (logicall, [logicall], ...)
= OR (logicall, [logicall], ...)
Example of AND / OR Function

4 B C D E F G

5 Sale of products across regions

6

7 Zones

8 East West North South|  Totall
9 Product A 825 750 500 1200 3275
10 Product B 250 300 125 400 1075
11 Spares 25 30 30 40 125
12 Maintenance 300 300 200 400 1200
13 1400 1380 855 2040 5675
14

15

((MFormulaentered | Result _
17

18 =AND(C13>=1500,G13>=5500) FALSE
19

20 =AND(C13>=1400,G13>=5500) TRUE
21

22 =OR(C13>=1500,G13>=5800) FALSE
23

24 =OR(C13>=1400,G13>=5500) TRUE
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2.7 If

If, Then, Else evaluates a condition and based on True or False proceeds to execute the set of
arguments. If the condition is met, the first set of arguments is executed and if not the second
set of arguments is executed. It is also possible to construct a nested if condition. After the first

of test is performed and if the condition is not met, the second set of arguments will be

executed. This second set of arguments can also be another if condition. If can also be used in

conjunction with other functions

The syntax for IF functions is

=IF (logical test, [value if true], [value if false])

=IF (logical test, value if true, If (logical test, value if true, value if false))

Example of If function

A B C D E F G
3 Simple if condition statement
4
5 Sales across regions
6 Zones
7 East West North  South
8 Product A 825 750 500 1200 3275
9 Product B 250 300 125 400 1075
10 Spares 25 30 30 40 125
11 Maintenance 300 300 200 400 1200
12 1400 1380 855 2040 5675
13
14 Budget 1500 1200 900 2000
15 ___——»{=IF(C12>=C14,"OK","Deficit")
16 Status Deficit OK Deficit OK
A B C D E F G
20 Multiple if condition statement
21
22 Sales across regions
23
24 Zones
25 East West North  South
26 Product A 825 750 500 1200 3275
27 Product B 250 300 125 400 1075
28 Spares 25 30 30 40 125
29 Maintenance 100 300 200 400 1000
30 1200 1380 855 2040 5475
31
32 Budget 1500 1200 900 2000
33

Status Over 10% OK Up to 10% OK

shortfall shortfall

34

AW

[<IF(C29>=C31,"0K" IF((C29/G31)>=0.9,"Up to 10% shortfall","Over 10% shortfall'))
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2.8 Count

The count functions count the number of records in a given range. The function has variants and
counts cells containing numeric, blanks and non-blanks. The functions are as below:

=COUNT(valuel, Returns the number of cells containing numeric value
[value2], ...) in the argument list and date is considered as a
numeric value.
=COUNTA(valuel, Returns the count of cells which are not blank in the
[value2], ...) argument list
=COUNTBLANK(range) Returns the number of cells which contain blank in
the range
Example Count function in use
A B C D E F G H | J K L
4 List B List A List B List A List B
5
6 45 3 45 3 45 3
7 92 92 92
8 ABC 28 ABC 28 ABC 28
9 10-Jan-96 0 10-Jan-96 0 10-Jan-96 0
10 200 #DIV/0! 200 #DIV/0! 200 #DIV/0!
11
12 Count CountA CountBlank
13 4 3 5 4 0 1
14
15
16

17(=COUNT(B6:B10)

| [=COUNTA(F6:F10) | |[=COUNTBLANK(J6:J10) |

2.9 Lookup

The popular lookup functions are VLOOKUP and HLOOKUP. These functions lookup as the name
indicates a list for a matching value and returns the column or row value. The syntax for the

functions is:

2.9.1 VLOOKUP

=VLOOKUP(lookup value, table array, column index number, [range lookup])

Lookup value

table array

The lookup value which will be matched against the
table array for selecting the first matching record

The area which holds the data that the viookup
function will return. The left most column of the table
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array is where the value will be searched
column index number | The column no in which the value is residing

[range lookup] This can be TRUE or FALSE. If the fourth condition is
not specified defaults to TRUE.

The function searches the range given for the criteria in the left most column and once a match
is found, returns the value in the column no specified. For E.g. the function =VLOOKUP (A1,
RateChart, 3) will search the First column of range RateChart for value in cell Al and if the value
is found return the value in 3 column of that record. The fourth argument in the above will be
treated as TRUE.

The TRUE argument will cause the search to identify the value either equal to the input value or
if it is not found for the next value which is less than the input value. Thus if a search is made for
10-Jan-99 in a column and if this is not found, then the next value which is less than this value
will be considered. If the column contains 8-Jan-99, then this will be accepted. In other words
the highest value equal to or less than the search value will be accepted. If the TRUE argument
is used, the List should be sorted in ascending order or else the results will be erratic.

The FALSE argument will cause the function to look for exact match rather than the nearest
match and if not found will return #NA value. If the FALSE argument is used, it is not necessary
that the list should be in any order.

Example of Vertical Look Up

A B C D E F G H
Date Units Week No

4 generated

5 01-Jan-03 500 1 Date 10-Jan-03

6 02-Jan-03 856 1 Unit Generated 703

7 03-Jan-03 127 1

8 04-Jan-03 558 1

9 05-Jan-03 797 1 =VLOOKUP(G5,UnitsDB,2,False)

10 06-Jan-03 797 1

11 07-Jan-03 263 1

12 08-Jan-03 157 2

13 09-Jan-03 526 2

14 10-Jan-03 703 2

15 11-Jan-03 526 2

16 12-Jan-03 716 2

17 13-Jan-03 732 2

18 14-Jan-03 604 2

19 15-Jan-03 626 3
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2.9.2 HLOOKUP
=HLOOKUP(lookup value, table array, row index humber, [range lookup])

Lookup value The lookup value which will be matched against the
table array for selecting the first matching record

table array The area which holds the data that the hlookup
function will return. The top most row of the table
array is where the value will be searched

row index number The row no in which the value is residing

[range lookup This can be TRUE or FALSE. If the fourth condition is
not specified defaults to TRUE.

The functionality is very similar to that of VLOOKUP with the essential difference that the look up
is performed horizontally and not vertically. Whenever HLOOKUP is in use, it may be necessary to
add the fourth argument as FALSE as the normal construction of a data list is vertical and not
horizontal and we not expect the columns to be in sorted order from left to right.

Example Horizontal Look Up

A B © D E F G H | J

4 Sales Jan Feb Mar Apr May Jun
5 Product A 815 236 909 535 52 999
6 Product B 351 95 415 665 709 197
7 Product C 773 325 815 648 665 658
8 Product D 505 86 358 957 792 703
9 Product E 871 349 574 960 925 943
10 Product F 166 74 244 269 164 43
11 Product G 178 309 835 137 463 346
12

13

14 Sales for the Month of Jan

15 Sales of Product B 351

\

=HLOOKUP(F14,HLookUp!SalesData,3,FALSE) |

2.9.3 Match and Index

Lookup can also be performed by using a combination of Match and Index functions. Let us
review the Match and Index functions now:

The process of lookup is done through two steps. First we determine the relative position of the
value we are searching for in the criteria range.

=MATCH(lookup value, lookup array, [match type])

Lookup value The lookup value which will be matched against the
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lookup array for obtaining the position of the record

Lookup array The range in which the search will be made

Match type The type of match to be performed. It can be:

Closest value higher (indicated by 1)
Closest value lower (indicated by —1)
Exact match (indicated by 0)

The default value for the match type will be 1 if not specified. For this the lookup array has to be
in ascending order. If the search is for closest value lower, the criteria range should be in
descending order. To carry out the exact match the data can be in any order.

The result will give the row number in which the data we are looking for is found.

The next step is to use this row position to get the cell value by using the Index function. Let us
see review the index function now:

The syntax for the Index function is as below:

=INDEX(array, row number, [column number])

Array The range where the data is residing. It can be either a
single row, single column or a range consisting of rows
and columns

row number The row number within the data range where the data

we need resides

column number The column number within the data range where the
data we need resides

Where the range consists of a column or a row, a single parameter is sufficient. It will be
automatically substituted as a row or column position as the case may be.
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Example of Lookup(Match and Index functions used)
A B C D E F G H
Date Units Week No
4 generated
5 01-Jan-03 500 1 Date 04-Jan-03
6 02-Jan-03 856 1 Position of match 4
7 03-Jan-03 127 1 Value 558
8 04-Jan-03 558 1
9 05-Jan-03 797 1
10 06-Jan-03 797 1 [=MATCH(G5,Match_Ind
11 07-Jan-03 263 1 ex!Date,O)
12 08-Jan-03 157 2
13 09-Jan-03 526 2
14 10-Jan-03 703 2 =INDEX(Match_Index!Unit
15 11-Jan-03 526 2 s,G6)
16 12-Jan-03 716 2
17 13-Jan-03 732 2
18 14-Jan-03 604 2
19 15-Jan-03 626 3
20 16-Jan-03 838 3
21 17-Jan-03 754 3
22 18-Jan-03 446 3
23 19-Jan-03 958 3
24 20-Jan-03 892 3
25 21-Jan-03 963 3
26 22-Jan-03 166 4
27 23-Jan-03 590 4
28 24-Jan-03 432 4
29 25-Jan-03 266 4
30 26-Jan-03 454 4
31 27-Jan-03 965 4
32 28-Jan-03 703 4
2.10 SumIf

Sumlf is one of the most

powerful functions within Excel used extensively in List management. It

enables preparation of a summary and allows the file to be maintained as a list. SumIf performs
a sum function of selected values within a list for a specified condition. The syntax for SumlIf is as

follows:

=SUMIF(range, criteria, [sum range])

Range

Criteria

sum range

Contains the list of criteria we will be searching for

The criteria which will be matched against the criteria
range for selecting matching records

The values in the value range will be summed where
the criteria is matched
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The SUMIF function not only runs on a vertical data list but also on a horizontal data list.

If the third argument is dropped, the values in the range will be summed.

Conventional approach
D
WeekNo

A B (&

Date Units

generated

3
4 01-Jan-03 500
5 02-Jan-03 856
6 03-Jan-03 127
7 04-Jan-03 558
8 05-Jan-03 797
9 06-Jan-03 797
10 07-Jan-03 263
11 3898
12
13 08-Jan-03 157
14 09-Jan-03 526
15 10-Jan-03 703
16 11-Jan-03 526
17 12-Jan-03 716
18 13-Jan-03 732
19 14-Jan-03 604
20 3964
21
22 15-Jan-03 626
23 16-Jan-03 838
24 17-Jan-03 754
25 18-Jan-03 446
26 19-Jan-03 958
27 20-Jan-03 892
28 21-Jan-03 963
29 5477
30
31 22-Jan-03 166
32 23-Jan-03 590
33 24-Jan-03 432
34 25-Jan-03 266
35 26-Jan-03 454
36 27-Jan-03 965
37 28-Jan-03 703
38 3576

WWWWwWwww [ASIN \CRN \C RN \C BN \O R \C I \V] . a2 g

A DA DMD

E F G
Approach A
Summary
Week 1 3898

Week 2 3964
Week 3 5477
3576
16915
[=C11 | /
[=SUM(G5:G8) |
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Date

01-Jan-03
02-Jan-03
03-Jan-03
04-Jan-03
05-Jan-03
06-Jan-03
07-Jan-03
08-Jan-03
09-Jan-03
10-Jan-03
11-Jan-03
12-Jan-03
13-Jan-03
14-Jan-03
15-Jan-03
16-Jan-03
17-Jan-03
18-Jan-03
19-Jan-03
20-Jan-03
21-Jan-03
22-Jan-03
23-Jan-03
24-Jan-03
25-Jan-03
26-Jan-03
27-Jan-03
28-Jan-03

K

Example of Sumif

L

Units Week No

generated

500
856
127
558
797
797
263
157
526

526
716
732
604
626
838
754
446
958
892
963
166
590
432
266
454
965
703

WWWwwwmMNdNND PNMDMNON = = 2 a g

AP BABRADMDAMPA®

M N

(o) P

Approach B - using Sumif

Summary

Week 1 389

Week 2 3964

Week 3 5477

Week 4 3576
16915

=SUMIF(Sumlf!Week,1,
SumlflUnitsGenerated)

SumlflUnitsGenerated)

SumlflWeek |
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2.11 Subtotal

The subtotal function performs a number of functions including sum of range of values. Subtotals
can be used to prepare grand totals without having to call the individual group totals into
summary. The syntax for the subtotal is given below:

=subtotal (function number, refl, [ref2], ...)

The first argument decides the type of function to use and the second argument is the values
which will be used by the function. Subtotal function will ignore previous subtotals and will
include only data values in its calculation. The following table gives the details of the function the
subtotal function uses:

Function
E.
AVERAGE
COUNT
COUNTA
MAX
MIN
PRODUCT
STDEV
STDEVP
SUM
VAR
VARP

== OUoONOOOUIDWNER

= O
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Example of Subtotal

3898 3 -SUBTOTAL(9,C4:C10)

3964 ——  » =SUBTOTAL(9,C13:C19)

A B C
Date Units WeekNo

3 generated

4 01-Jan-03 500 1
5 02-Jan-03 856 1
6 03-Jan-03 127 1
7 04-Jan-03 558 1
8 05-Jan-03 797 1
9 06-Jan-03 797 1
10 07-Jan-03 263 1
11

12

13 08-Jan-03 157 2
14 09-Jan-03 526 2
15 10-Jan-03 703 2
16 11-Jan-03 526 2
17 12-Jan-03 716 2
18 13-Jan-03 732 2
19 14-Jan-03 604 2
20

21

22 15-Jan-03 626 3
23 16-Jan-03 838 3
24 17-Jan-03 754 3
25 18-Jan-03 446 3
26 19-Jan-03 958 3
27 20-Jan-03 892 3
28 21-Jan-03 963 3
29 5477

30

31 22-Jan-03 166 4
32 23-Jan-03 590 4
33 24-Jan-03 432 4
34 25-Jan-03 266 4
35 26-Jan-03 454 4
36 27-Jan-03 965 4
37 28-Jan-03 703 4
38 3576

Grand Total 16915

|  =SUBTOTAL(9,C4:C38)
2.12 Choose

Choose function chooses a value from the list. The syntax for the function is as below:
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=CHOOSE(index_num, valuel, [value2], ...)

Index_num The reference by which the value from the list will be
selected. This has to be an integer.

Value The list of values will be entered separated by comma.
The first value is required and rest are optional

The function will choose the value from the list of values based on the first argument.

Example of Choose function
2 » index_num

20 =CHOOSE(index_num,10,20,30,40,50,60)
Feb =CHOOSE(index_num,"Jan","Feb","Mar","Apr","May","Jun")

=CHOOSE(index_num,Choose!Range1,Choose!Range2,Choose!Range3,Choose!Range4)

Selected Rangel Range2 Range3 Range4

10 1 10 100 1000
20 2 20 200 2000
30 3 30 300 3000
40 4 40 400 4000
50 5 50 500 5000

This returns a name from the list
based on the value in cell A2
(Index_num). For e.g. 3 will return
Range3 and this is captured into
range name 'Selected’

2.13 Offset

Offset is powerful function helps in defining a range dynamically. Offset basically performs two
acts depending on the type of input given. It allows the user the place the cursor at a particular
cell from the present location. From there either the value of the new cell can be picked up or a
new range starting from that point can be defined. The syntax for the OFFSET function is as
below:

=OFFSET(reference, rows, cols, [height], [width])

Reference Reference is the cell where the cursor will be positioned
initially. Anchor can either be a cell of a range name.

Rows The number of rows by which the cursor will be moved
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The number of columns by which the cursor will be

This is applicable only if the Anchor is a name and not
a cell. This denotes the height in number of rows for
the new range from the new cursor position as
determined by rows and columns

down
Columns

moved right
Height
Width

Width is the number of columns to be included in the
new range. Like Height, this is also applicable only if
the Anchor is a range name and not a cell.

Offset is a very flexible function and the movement is not limited to the range name given. It
simply determines a new point within the boundaries of the worksheet. Negative values can also
be used as arguments and in which case the cursor will up and left. If the reference causes a
movement outside the boundaries of the sheet, #REF error will be returned. Offset can be used

along with any of the aggregate functions.

2.14

Example of Offset

B Cc

Employee details

Employees 1993
Sales 19
Marketing 4
Administration 5
Technical 19
Total 47

D E F G H
1994 1995 1996 1997 1998
23 24 31 28 35
9 16 12 16 18
7 11 12 15
31 25 34 42 49
70 73 88 98 117

[Range name :Corner |

NoRows 2 |[Range Name :Employees
NoCols 4

Formula Value
=OFFSET(B3,1,3) 24
=OFFSET(Employees,4,NoCols,1,1) 98
=OFFSET(Corner,-1,0) 1993
=AVERAGE(OFFSET(Employees,3,0,1)) 33.33333
=SUM(OFFSET(Employees,0,2,,1)) 73
=OFFSET(Employees,3,1) #VALUE!

Array formulas

The array formulas apply to a group of cell collectively. They are indicated by the braces at the
beginning and end of the function. ({}). These are inserted by the system automatically. Array
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formulas behave in a different way than the regulars functions. An Array formula once applied to
the group of cells can be modified only when all cells are selected. The formula in an individual
cell cannot be either edited or modified. For e.g. if you enter a formula for calculating bonus as
Salary multiplied by 20% and you wish that the formulas in any individual cells should not be
modified, then you can enter this as an array formula. First select the group of cells in which the
formulas should reside and enter the formula. Terminate the formula by holding down the
‘Shift+Ctrl’ keys while pressing ‘Enter’ key. Excel will copy the formula in all the cells. Let’s
assume that you wish to enter the formula in cells D2 to D20 and each of these cells should be a
product of B2 which holds Salary and C2 which holds the rate. If you want to enter a normal
formula you will type in cell D2 the following:

=B2*C2

However if you wish to enter an array formula you should first select cells D2 to D20 and type
the following:

= (B2:B20)*(C2:C20)

Terminate the formula as described above and you will see that the formula is displayed as
below:

{= (B2:B20)*(C2:C20)}

In order to select the all the formula cells for modification, select any cell and press ‘Ctrl+/’. After
modifying remember to terminate the formula by ‘Shift+Ctrl+Enter’. Otherwise it will be saved
back as an ordinary formula.

Example of Array function

A B C D E I K L
2

3 3 450 80| 36000\  ={(C3:C18)*(D3:D18)}
4 6 300 60 18000

5 5 350 40 14000

6 2 300 10 3000

7 9 500 90 45000

8 2 400 80 32000

9 7 400 10 4000

10 9 200 80 16000 >

11 5 50 30 1500

12 6 350 90 31500

13 9 50 10 500

14 3 100 30 3000

15 2 400 20 8000

16 1 300 90 27000

17 7 100 20 2000

18 3 50 70 3500/

19 245000

20
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3 List Management

7o view the examples under functions open 'List management.xis’. The workbook contains
various sheets for the functions covered. Click the appropriate tab to view examples.

3.1 Sort

Sort enables a quick sort of a single column or does a multiple column sort. Some of the sort
criteria are listed below:

¢ Blanks are always pushed to the last
e Generally sort is not case sensitive unless specifically set

¢ Numbers sorted from smallest negative to largest positive

Even though sort gives you option to sort up to 3 columns, you can go beyond that by
concatenating columns and perform a sort based on the combined column. Usually the column
sort will meet the normal requirements.

Besides ascending and descending Sort is also possible based on a custom list. To define a
custom list Click Tools > Options and in the dialogue box select Custom Lists. Click Add and
enter the series. Separate each field with a comma. While sorting the list, when you are in the
sort dialogue, click Options and select the sort order from the drop down list.

Sort can also act on columns by sorting them left to right or right to left. When you are within the
sort dialogue click Options and choose Sort left to right. A second dialogue box will appear which
will ask you value in which row is to be used for sorting. Row 1 will be the header. You can
choose the appropriate row.

The data list in sort has to obey some rules. The values in rows if defined through formulas then
sort will corrupt the data. Let us say that your list has data from cell Al to E50. If a cell in row 45
(B20) if referring to a value in cell B100 which is outside the list or E20 which is within the list,
then after sorting you will note that the formula defined have changed and it is now displaying
junk value. This is so because the sort function after sorting the data is trying copy the formula
to a its new location and in that process applies its rule of maintaining relative reference. In the
example shown above cell B20 is referring to the cell B100 and in other words the cell is referring
to 80 rows below it in the same column. Now after sort if the record has been moved to 2™ want
the cell to always refer to B100. Such situations these formulas should be defined using absolute
reference.

Example of sort

Data sorted on Year (ascending) and invoice value (descending)
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inv_no year_no inv_date customer_no line_no product_no quantity rate inv_value net_price
48 2003 13-Apr-02 8 4 2 192 100 19200 100
12 2003 03-Apr-02 30 5 2 190 100 19000 100
45 2003 12-Apr-02 16 1 2 190 100 19000 100
96 2003 28-Apr-02 15 2 2 186 100 18600 100
42 2003 10-Apr-02 28 1 2 185 100 18500 100
38 2003 09-Apr-02 4 2 2 178 100 17800 100
78 2003 22-Apr-02 23 4 2 175 100 17500 100
11 2003 02-Apr-02 4 1 2 174 100 17400 100
74 2003 20-Apr-02 14 1 2 174 100 17400 100
79 2003 22-Apr-02 25 1 2 174 100 17400 100
10 2003 02-Apr-02 3 2 2 169 100 16900 100
99 2003 29-Apr-02 27 3 2 163 100 16300 100
26 2003 06-Apr-02 20 3 6 183 89 16287 89
14 2003 03-Apr-02 11 1 1 198 80 15840 80
95 2003 28-Apr-02 16 3 6 177 89 15753 89
100 2003 29-Apr-02 11 1 12 183 85 15555 85
15 2003 04-Apr-02 30 2 2 155 100 15500 100
72 2003 20-Apr-02 22 3 11 200 77 15400 77
33 2003 08-Apr-02 8 4 11 191 77 14707 77

3.2 Filters

Filters can be applied to a list so as to extract specific data. There are two types of filters. These
are:

e Auto filter

e Advanced filters

Filters are very easy to set up and use. Once the cursor is within the data area, click Data >
Filter > AutoFilter. Excel will immediately sense the boundary of the data list and in the first row
which is the header row applies the filter button. Click on the button to view the list of unique
items in the column. If you select any item from the list, the data list will be displayed showing
only the selected item. The filtered column will also be indicated separately. The filter button will
be shown in blue colour.

Multiple columns can be filtered by using the same approach.

One of the features of the filters is that the subtotal function can be used effectively with that.
After filtering a column move to the end of the column and click ‘Y’ on the standard toolbar. A
subtotal function will be inserted selecting all the values in the column including the hidden rows.
However the total will be only for the displayed values. If you employ different criteria for listing
the column, which results in different set of records, the sub total function will display the
appropriate total for the selected rows.

It will be interesting to note that if you move to the end of a column containing values
continuously without applying filter and click ‘Y. the function inserted will be sum and not
subtotal

3.3 Options available
Filter gives the following options:

3.3.1 Display top 10

You can choose to display the top n number of items. This is applicable to numeric columns.
Even though the menu says ‘Display top 10’, you can display top 5 or bottom 20 values. Click the
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filter and select ‘top 10 values’. A dialogue box will be displayed through which you can choose to
view Top or Bottom values and the number of items to be viewed.

3.3.2 Custom

This option allows you to view the values based on certain criteria. You can set a range of values
to be included.

imr_rl-l ',rear_rl‘l inv_da‘il custnmer_rl‘l Iine_rl‘l pruduct_rl‘l quanti‘ﬂ ra‘ﬂ iny_wah L_l net J:II‘iEI

2 2003 01-Apr-02 25 1 15 132 30 4560 30
2 2002 01-Apr-02 23 2 2 135 100 13500 104
2 2003 01-Apr-02 23 £ ) 138 25 3400 23
2 2002 01-Apr-02 23 4 15 167 30 S010 20
3 2003 01-Apr-02 29 4 3 21 35 1785 35
3 2003 01-Apr-02 29 3 8 62 35 2170 35
3 2002 01-Apr-02 29 £ 15 127 30 2810 20
3 2003 01-Apr-02 249 2 7 97 14 1358 14
3 2002 01-Apr-02 29 1 2 10 100 1000 104
9 2003 02-Apr-02 27 2 7 193 14 2772 14
=] 2003 0Z-Apr-02 27 3 13 193 29 5597 29
9 2003 02-Apr-02 27 4 11 119 77 9163 77
9 2003 02-Apr-02 27 3 12 162 85 13770 85
=] 2002 02-Apr-02 27 1 12 134 29 4466 29
12 2003 03-Apr-02 30 1 13 g3 30 2640 30
12 2002 03-Apr-02 20 2 2 137 35 4795 35
12 2003 03-Apr-02 30 5 £ 142 15 2130 13
12 2003 03-Apr-02 20 4 ] 88 89 7832 g9
12 2003 03-Apr-02 30 ) 2 190 100 19000 104
13 2003 04-Apr-02 30 1 13 26 30 780 30
15 2002 04-Apr-02 20 2 2 135 100 15500 104
15 2003 04-Apr-02 30 5 10 63 47 3196 47
15 2003 04-Apr-02 30 4 3 32 15 780 15
15 2003 04-Apr-02 30 ) ) e 25 2725 25
17 2003 04-Apr-02 22 1 13 169 29 4901 29
17 2002 04-Apr-02 22 2 4 40 &7 2680 &7
17 2003 04-Apr-02 22 £ B 97 89 8633 g9
17 2003 04-Apr-02 22 4 2 146 35 5110 35
13 2003 04-Apr-02 24 5 4 191 &7 12797 67
18 2003 04-Apr-02 24 4 7 119 14 1666 14
13 2003 04-Apr-02 24 1 13 121 29 3509 29
1= 2003 04-Apr-02 24 ) 2 44 100 4400 100
12 2002 04-Apr-02 24 2 5] 20 89 4450 29

Filter conditions applied
Year = 2003; Invoice date <= 07-Apr-2002; Customer no >=25

3.4 Advanced filters

Advanced filters are required where the filtering criterion becomes complex and it is not possible
for the Auto Filter to handle the requirements. Click Data - Filter - Advanced Filter and Excel
display a dialogue asking you to fill in the following:

3.4.1 Listrange

Excel would have pre-selected the data list. If the data list shown is not correct, define the data
list
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3.4.2 Criteria range

Enter the column captions in a separate area of the worksheet. Specify the values based on
which you wish to filter below the columns. The values mentioned in the same row will be used
as logical ‘AND’ and the values mentioned in different rows will be used as logical ‘OR’

Advanced Filter also gives an option to filter the values either in place or in a separate area in the
worksheet.

Example of advanced filter

Filter condition
inv_no year_no inv_date customer_no line_no product_no quantity rate inv_value net_price

1 2004
02-Apr-03
Filter result
inv_no year_no inv_date customer_no line_no product_no quantity rate inv_value net_price
1 2004 01-Apr-03 6 1 4.00 174 84 14616 71
1 2004 01-Apr-03 6 2 6.00 117 100 11700 92
1 2004 01-Apr-03 6 3 15.00 55 26 1430 23
7 2004 02-Apr-03 29 1 11.00 3 83 249 79
7 2004 02-Apr-03 29 3 14.00 106 40 4240 36
7 2004 02-Apr-03 29 2 13.00 219 31 6789 30
8 2004 02-Apr-03 5 1 7.00 90 16 1440 14
8 2004 02-Apr-03 5 2 8.00 128 37 4736 36
8 2004 02-Apr-03 5 3 10.00 71 57 4047 48
8 2004 02-Apr-03 5 4 12.00 51 105 5355 96
9 2004 02-Apr-03 27 1 2.00 4 101 404 93
9 2004 02-Apr-03 27 5 13.00 230 31 7130 30
9 2004 02-Apr-03 27 4 12.00 79 105 8295 96
9 2004 02-Apr-03 27 2 3.00 206 14 2884 13
9 2004 02-Apr-03 27 3 4.00 158 84 13272 71
10 2004 02-Apr-03 2 1 1.00 2 87 174 86
10 2004 02-Apr-03 2 2 10.00 173 57 9861 48
10 2004 02-Apr-03 2 3 12.00 170 105 17850 96
11 2004 02-Apr-03 24 2 6.00 178 105 18690 92
11 2004 02-Apr-03 24 1 2.00 219 101 22119 93
11 2004 02-Apr-03 24 4 9.00 114 34 3876 29
11 2004 02-Apr-03 24 3 8.00 206 37 7622 36
3.5 Form

Form is used for entering data that is arranged in rows so that we may find it easier for data
entry.

Define headings for the columns in the first row of the data entry range.
Choose Data-->Form, Excel will ask whether to use the row for header. Choose OK.

Excel then displays a dialogue box as shown in the example.
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3.6 Pivot Table

Pivot table is a very powerful data analysis facility and has got great dynamic capabilities. The
features of the pivot table report are described below:

3.6.1 Setting up a Pivot Table

Keep the cursor within the data list and click Data - Pivot table report. Excel display the Pivot
table wizard which will guide you through the steps in defining a Pivot table report

3.6.1.1 Step1of3
The data source is decided at this stage. The data list can be any of the following:

Excel list

e External data base

e Multiple Excel lists

e Another pivot tale report

Excel would have selected the Excel list as default but this can be changed

3.6.1.2 Step2of 3
Select the data area here. Excel will display the current data list as the default area.

3.6.1.3 Step3of3

This displays the options to choose the location where the Pivot table will be drawn. Also gives
the option to design the layout of the pivot table. Click ‘Layout’ to proceed with the design.
Alternatively click ‘Finish’ to complete the report which displays a dummy report with outlines
which could be customised.

3.6.2 Managing a Pivot table

A Pivot table has basically four aspects. ‘Data’, which is summarized, is at the centre of the Pivot
Table. Drag the columns, which required to be summarized and drop them in the data area.
Besides ‘sum’ other aggregate functions like ‘count’, ‘average’ etc. The data is analyzed through
fields, which contain the record parameters. Multiple fields can be used in which case the
summary is made available for each of these fields. The way this information is viewed can be
through placing a field in a Row and another in a Column. It is also possible to keep more than
one field as a Row or as a Column. The fourth aspect is the ‘Page’. The Row/Column summary is
viewed for each item in a third field when this item is defined as a Page.

When you are in the wizard screen of the Pivot table, the list of available fields will be listed in
the right. The Pivot Table will also show a layout showing placeholders for Data, Row, Column
and Page fields. Drab the fields for which you want construct a summary in to the data area. In
the worksheet attached these columns will be Salary, Bonus, Commission and Gross. Drag the
fields based on which you wish to analyze and drop them on to Row, Column or Page areas.

If you wish to change the Row, Column or Page fields simply click and drag the fields to the
required area. This can be done from within the Pivot table report itself. As you click the field and
drag it, the layout location currently associated with it will be shown in the mouse tip. As you
drag it in to new location say from Column to field, the mouse tip will change to indicate that the
orientation has changed.

Example of a Pivot table
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Organised by LT. Committee, ICAL ... ... .. .. Hosted by Baroda Branch of WIRC of ICAI
[year no [2004 |
Sum of inv_value |product_no
customer_no 1 2 3 4 5|Grand Total
1 31146 16380 6825 54351
2 21228 24846 4452 4165 54691
3 15051 11716 2674 19488 4585 53514
4 10560 19800 238 12936 3010 46544
5 7134 2478 12348 21960
6 34776 12390 47166
7 9494 2170 1344 700 13708
8 13659 1036 8085 22780
9 12221 2604 3360 18185
10 20184 22321 1022 30828 74355
11 8568 8568
12 30502 1904 7392 4725 44523
14 4368 4368
15 17487 11918 9996 1435 40836
16 6230 6230
17 9831 909 504 6048 1925 19217
18 3486 3486
19 1176 1176
20 10403 10403
Grand Total 146280 154130 18116 170100 57435 546061

Chart showing sum of invoice value for customer/product combination for year 2004

Sum of inv_value |year_no
customer_no 2003 2004|Grand Total
1 42170 54351 96521
2 10710 54691 65401
3 48362 53514 101876
4 40694 46544 87238
5 12998 21960 34958
6 16845 47166 64011
7 20730 13708 34438
8 61749 22780 84529
9 2475 18185 20660
10 1530 74355 75885
11 65299 8568 73867
12 10560 44523 55083
13 300 300
14 23553 4368 27921
15 19990 40836 60826
16 38180 6230 44410
17 34196 19217 53413
18 13520 3486 17006
19 7510 1176 8686
20 10535 10403 20938
Grand Total 481906 546061 1027967

Chart showing invoice value for customer 1 to 20 for years 2003 & 2004
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3.6.3 Formatting

Excel also offers option to choose from multiple pre-set format styles. Choose Format-
>AutoFormat and apply a format. In order to format the cells first check the Preserve formatting
Check box in Table options. The context sensitive menus are available on the right click once the
cursor is within the pivot table area. Alternatively invoke the Pivot table toolbar.

Select a cell amongst the group of cells to be formatted and on right click select Field setting to
display the ‘Pivot Table Field’ dialog. Click *‘Number’ and specify the format option. This will
ensure that the format is retained even when the pivot table is redrawn when rows/column fields
are changed. If the format is done by choosing the Format from the menu, then if the table is
redrawn, all previous formatting will be lost.

3.6.4 Grouping

The information in a Pivot Table is presented as a summary. Typically the table lists information
for each item in a field. It is possible to create groups out of these items. Some of these items
can be consolidated in to a group. This technique is relevant where data fields are involved. Let
us say that a date field is used as a row. The Pivot table will list the date grouped under each
date found in the list. But we may want to summaries the data based on months. In such case it
is easy to view the month summary by creating a group for the date field.

The grouped fields then in turn can be used as if these are regular fields

3.6.5 Hide fields

In a column or row, each unique data item of the fields will be listed and the data area will
contain the summarized information for these items. It is possible to temporarily remove some
items from view. To hide an item from view when you are within the Pivot table choose the row
or column header. Excel will respond by selecting the row or column labels. Move the cursor
within the area and use right click to display the menu. From the menu choose Field. Excel will
display the Pivot table Field dialogue. Click the fields to be hidden and click OK. To display the
hidden field, use the same approach to list the dialogue and click the field market as hidden to
display it.

3.6.6 Calculated field and items

3.6.6.1 Calculated field

Through calculated fields, we can introduce additional calculations based on existing data fields.
Data fields are those on which the aggregate functions are performed. For example the data list
contains information on Gross salary for an employee but not the eligible amount of loan. If we
wanted to look at possible loan amounts, which are related to the gross salary, then this can be
defined as a formula.

Once you are within the Pivot table click the Pivot table drop down in the Pivot table tool bar and
from the menu select Formula - Calculated field. A dialogue will be displayed. In the name field
enter the name for new field; in the formula field enter the formula. If you wish the formula to
refer to data fields, drag the fields in to formula bar and set the appropriate equation. After you
click OK, Pivot Table will introduce a new calculated field.

3.6.6.2 Calculated item

Through Calculated items you can define additional data groups. If the calculated fields primarily
work on the data items, which are used in aggregation, the calculated items work on the fields,
which are used to analyze, and in another words fields containing parameters for data. For e.g. if
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a company is trying to set up a new product line and expects the revenues be studied in relation
to an existing product, then this can be done through a calculated item.

Once you are within the Pivot table click the Pivot table drop down in the Pivot table tool bar and
from the menu select Formula - Calculated item and Excel will display a dialogue. In the Name
field enter the name for the new item; in the formula fields enter the formula for the item. You
will note that the field from which you called the menu is selected and the items belonging to
that field are displayed in the item box. Only the items belonging to a single field can be used in
the calculation at a time. Drag the fields and items in to the formula field and set the appropriate
equation.

Calculated fields and calculated items can be used in conjunction with each other. These can also
be grouped.

Data

product no |year_no |Sum of inv_value Sum of quantity Sum of Avg Rate
1 2003 178720 2234 80.0

2004 208050 2402 86.6

1 Total 386770 4636 83.4
2 2003 391400 3914 100.0

2004 293914 2912 100.9

2 Total 685314 6826 100.4
3 2003 24390 1626 15.0

2004 32998 2357 14.0

3 Total 57388 3983 14.4
4 2003 133330 1990 67.0

2004 260316 3111 83.7

4 Total 393646 5101 77.2
5 2003 59225 2369 25.0

2004 72625 2134 34.0

5 Total 131850 4503 29.3

‘Sum of Avg Rate’ is a calculated field by pivot table report.
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Sum of inv_value |year_no
customer_no 2003 2004 Variation
16 113039 18461 -94578
14 89164 6443 -82721
8 135554 65099 -70455
11 123511 54506 -69005
19 70797 11870 -58927
13 45481 -45481
17 80588 44163 -36425
18 66715 35380 -31335
4 92522 66522 -26000
15 74548 60512 -14036
20 77524 69782 -7742
7 86473 83767 -2706
6 36383 87801 51418
1 70453 122567 52114
9 12310 71019 58709
12 15124 82509 67385
10 16715 124154 107439
5 25059 136381 111322
2 53194 167005 113811
3 72025 190338 118313
Grand Total 1357179 1498279 141100

‘Variation’ is a ‘Calculated item’ of pivot table which represents difference between two analysis
fields 2004 and 2003.

3.6.7 Type of summary values

The data summarized can be of two types. In can be summarized using any of the summary
functions like sum, count average etc. here we will review the type of summary. We can view the
data item or view it in different forms like running total, deviation from a base amount, % of
row/column total etc.

Once you are within the Pivot table select the data column and right click. From the menu click
Field - Options to display the full dialogue for the field. In the show data as field, choose the
data expression form from the drop down list.

3.6.8 Options

Pivot table has facility to customize the report. When you are within the Pivot table report on
right click choose options. We will review some of the item under options:

3.6.9 Preserve formatting

Check this option to retain the format applied to a field or row. Without this the format will be
lost when data is manipulated afresh.

3.6.10 Save data with layout

This is what gives the Pivot table speed. It saves a copy of data with itself. Of course this is
hidden from us. Even if you delete the source table, the Pivot table will still work as it has a local
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copy of the data but we can no longer view the data in raw form. You will also notice that if you
attempt to create a second pivot table on the same data Excel issues a caution asking your
preference to use the earlier pivot table itself or create a new one. It will also report that you
prefer to create afresh it will use up more memory. This is because it will be saving a second
copy of data with the report.

3.7 Form

Form is used for entering data that is arranged in rows so that we may find it easier for data
entry.

Define headings for the columns in the first row of the data entry range.

Choose Data-->Form, Excel will ask whether to use the row for header. Choose OK.

3.8 External data

Click Data->Import External Data and select New Database Query. Excel displays a wizard and
guides you through the process of importing data.

3.8.1 Import data

3.8.1.1 Stepl

Excel displays ‘Choose Data Source’ dialog. This contains the drivers defined for data sources.
There are two ways by which you can proceed. Choose a generic driver type based on the type
of database you want to link to or create a specific driver. The following are the steps in creating
a specific driver:

Select New Data Source and click ‘OK’

3.8.1.2 Step 2

In the next dialog give a name for the driver, choose the generic database driver for your type of
data source and click *Connect’ to specify the specific data source you want to link. This will
define a new data source name. If you choose a generic driver you have to identify the data
source every time you want to connect to the same data source. Defining a specific driver will
always point to the particular data source you define.

After you select the driver, the dialog displayed will depend upon the type of driver. If you had
selected a generic driver, Excel will prompt you to choose the data source also. If you select the
specific driver defined by you it will list all the tables in the data source.

3.8.1.3 Step 3

Choose the tables and fields from the list. If you choose more than one table, if the relationship
is defined between these tables Excel will automatically allow you to choose all the fields from
both the tables. If you choose two or more table which does not have a common field amongst
them Excel will ask you to specify the join condition in the database before proceeding with the
selection.

3.8.1.4 Step4

Choose to apply filters and also specify a sort order. Excel will pull down the data from the data
source. It will also maintain a dynamic link to the data.
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3.8.2 Refresh

Select any cell within the data list. Right click gives a list of context sensitive menu. Choose
‘refresh’ to refresh data

3.8.3 Options

On right click choose ‘Data Range properties’ to brig up the dialog. Specify appropriate settings
applicable. If you wish to enter some formulas on the data pulled in and wish to apply the same
formula every time the link I refreshed check the *Fill down formulas in columns adjacent to
data’.

3.9 Subtotal

The subtotal function drives automatic totalling based on the change in fields. Using these multi
level subtotals can be quickly done. Click Data - Subtotal and Excel displays a dialogue box. The
information required by subtotal utility is as follows:

3.9.1 Index column

Select the column, which will be used as index. Subtotal will be made for each change in the
column value.

3.9.2 Function to be used
Select the type of aggregate function to be used from the drop down list.

3.9.2.1 Apply subtotal to
Select the columns for which subtotal are required. Check the applicable columns.

Option is also available to specify whether the subtotal should be below the data or above the
data.

To get a subtotal for multiple columns repeat the above step and choose the index column.
Remember not to check the ‘Replace the current subtotal’ option.

Subtotal on Customer

inv_no year_no inv_date customer_no line_no product_no quantity rate inv_value net_price

1 Total 3449 193020
2 Total 3844 220199
3 Total 4139 262363
4 Total 2229 159044
5 Total 2817 161440
6 Total 2376 124184
7 Total 4080 170240
8 Total 3992 200653
9 Total 1607 83329
10 Total 2371 140869
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Subtotal on Product within Customer

inv_no year_no inv_date customer_no line_no product_no quantity rate inv_value net_price

1 Total 516 43786
2 Total 247 24700
3 Total 72 1080
4 Total 195 16380
5 Total 345 10575
6 Total 234 24570
7 Total 167 2672
8 Total 757 27611
9 Total 21 714
10 Total 160 9120
12 Total 135 11475
13 Total 256 7892
14 Total 344 12445
1 Total 3449 193020

inv_no year_no inv_date customer_no line_no product_no quantity rate inv_value net_price

70 2003 20-Apr-02 1 3 1 158 80 12640 80

39 2004 10-Apr-03 1 1 1 227 87 19749 86

95 2004 28-Apr-03 1 1 1 97 87 8439 86

85 2004 25-Apr-03 1 1 1 34 87 2958 86
1 Total 516 43786

46 2003 12-Apr-02 1 3 2 103 100 10300 100

47 2003 12-Apr-02 1 2 2 73 100 7300 100

46 2003 12-Apr-02 1 2 2 71 100 7100 100
2 Total 247 24700

47 2003 12-Apr-02 1 1 3 72 15 1080 15
3 Total 72 1080

39 2004 10-Apr-03 1 2 4 78 84 6552 71

78 2004 22-Apr-03 1 1 4 70 84 5880 71

79 2004 22-Apr-03 1 1 4 47 84 3948 71
4 Total 195 16380

46 2003 12-Apr-02 1 1 5 150 25 3750 25

39 2004 10-Apr-03 1 3 5 195 35 6825 32
5 Total 345 10575

3.10 Data Validation

The data validation option is used to perform validating the data at the time of entry in to cell.
Validation is often essential and may even become critical when functions are used in list
management. A case is where we are employing a sum if function on a list. It must be ensured
that the final list of criteria on which data is summed must be present exactly as found in the
summary. Any unwanted space within the criteria within the list will cause SUMIF function to
overlook such rows and the final sum will be inaccurate. However while the Pivot Table detects
such values, for e.g. ‘CMP’ and ‘CMP ‘(the second CMP has a trailing space) are counted as
different entities. But the Filter function will not detect this and will still consider both as same.
The data validation assumes importance in this background.

The common data validations are

e Restricting a number
e Restricting dates
e Entry of codes based on list
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4 Tools & utilities

To view the examples under functions open 'Tool.xis". The workbook contains various sheets for
the functions covered. Click the appropriate tab to view examples.

4.1 Goal seek

Goal seek enable us to find what should be the value of a source cell given the value of the
target cell where the source and target cells are related in a calculation. The goal seek utility will
substitute multiple values in the source cell and see if the value of the target cell matches the
required value. Click Tools->Goal seek to bring up the Goal seek dialog

4.2 Scenario

4.2,1 Add

Define scenarios to quickly view the results in a ‘what-if’ situation. Click Tools->Scenarios to bring
up the scenario dialog. Click to Add a scenario. In the ‘Scenario name’ enter a suitable name.
Give a single or list of cell in the ‘Changing cells’ box. Separate multiple cells by commas and click
‘OK’ to add the scenario.

4.2,.2 View

To view a scenario click Tool->Scenario and select the predefined scenario. The results for the
scenario will be displayed.

4.2.3 Summary report

Click Tools->scenario->Summary to bring up the summary dialog. Choose the results cell that
you wish to see and Excel inserts a new sheet with the results displayed for each of the scenario
defined,

4.3 Solver

Solver solves where multiple constrains have to be optimized. Typical example of where solver is
used is in a transportation and problem where multiple manufacturing units ship to multiple
markets. The important issue while working with the solver is setting up the problem.

Refer to the attached worksheet for the solver problem

In the above, the three units ship materials to the 8 markets listed. The net realization in each
market after the unit to market freight chares is given in Rates. The objective is to maximize the
sales. The following are the constraints:

Each unit cannot produce more than the capacity

For each market there are minimum and maximum levels. Irrespective of the price the supply has
to be maintained at least at minimum level and cannot exceed maximum level. The following
steps are involved in solving this problem:

Click Tools->Solver to bring up the Solver dialog
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% In'Set Target Cell’ refer to the cell containing the final value we are interested and
choose Minimum or Maximum. Also set a specific value as target.

< In the ‘By changing cells’ specify the cells whose value has to be substituted by solver.
% In the ‘Subject to Constraints’ enter the list of constraints

Click ‘Solve’ to solve the problem.

4.3.1 Options

Customise the solver problem by using the solver options. Form the Solver dialog click ‘Options’
to display the Solver Options dialog.

4.3.1.1 Precision
Lower the precision level for a faster solution

4.3.1.2 Convergence

This will determine when the solver should stop looking to better the solution. When each of the
5 successive solutions is not better than the previous by the convergence level, the solver will
stop processing.

4.3.1.3 Assume non negative
Solver will not try with any negative values in the ‘By changing cell’ area.

4.3.1.4 Show iteration results
Solver will display the result of each iteration and wait for confirmation to proceed.

Example of a solver problem
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Solver example for solving distribution model

Markets
Market 1
Market 2
Market 3
Market 4
Market 5
Market 6
Market 7
Market 8

Capacity

Market 1
Market 2
Market 3
Market 4
Market 5
Market 6
Market 7
Market 8

180000 0
10000 0
88000 0

0 160000
0 90000
0 50000
2000 0

120000 0

400000 300000

400000 300000

Rates

21 17
18 10
15 12
10 19
12 18
14 15
13 12
17 13

Current distribution

MELCEN  Unit1 _ Unit2 __ Unit 3|

Market 1
Market 2
Market 3
Market 4
Market 5
Market 6
Market 7
Market 8

180000
120000
100000

0

0
0
0

400000

4.4 Form control

These are controls that can be drawn on the worksheet and can be used to update values in a
cell or trigger macros. Some of the form controls are:

5

%

o,
o

List box

o,
o

5

%

Spinner

5

%

Combo box

Scroll bar

0

0

0
160000
90000
50000

0
300000

Command button

Quantity

0 180000 2500 180000 3780000
110000 120000 5000 120000 2490000
0 88000 3500 140000 1320000
0 160000 2500 160000 3040000
0 90000 7500 90000 1620000
90000 140000 4000 140000 2460000
0 2000 2000 180000 26000
0 120000 3000 120000 2040000
2000000 900000 30000 1130000 16776000

200000

14

21

13

18

10

19

14

17
|__Unitl  Unit2 _ Unit 3] Total Value|
0 21 17 14 3780000
18 10 21 2160000
0 15 12 13 1500000
0 10 19 18 3040000
0 12 18 10 1620000
14 15 19 750000
180000 13 12 14 2520000
20000 17 13 17 340000
200000 15710000
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% Check box

% Option button
These controls are available in the ‘Forms’ toolbar. Select the required control and draw it on the
sheet. Right click on the control’s border and choose ‘Format control’ to customize the control.
Each of these controls can be customized to send value to a cell. This will be the cell link of the
control. Some of the controls like List Box and Combo Box will accept to range of input cells and
send the out put to the linked cell.

4.5 Custom view

Define a custom view to view the sheet based on a specific setting. Click Views->Custom views
to bring up the custom view dialog. Click ‘Add’ to define views. This is useful where the
worksheet contains a number of columns and we need to view only a few columns most of the
time according to the context. Hide unwanted columns and rows and create a view. When the
view is called up, the display will be according to the view definition.

4.6 Protection
Excel offers different type of protection. These are

Protect cells
Protect sheet
Protect work book

Each of these protection functionalities works in conjunction with the other. Let us review these.

4.6.1 Cell protection

By default all the cells are locked. But the locking of the cell has no effect unless the sheet is
protected. Similar to locking the cell formulas can also be hidden. In ‘Format cells’ click Protection
and check the Locked and Hidden check boxes.

4.6.2 Protect sheet

Click Tools->Protection and Protect sheet. The protect sheet dialog displays a number of options.
Check the required options and click Ok to protect the worksheet. Once the sheet is protected
the locked cells cannot be edited. Before calling up the protection first select the cell of data
entry and using format cell remove locking. Only values of these cells can be modified.

4.6.3 Protect workbook

Choose the kind of protection required. The options available are structure and widows. The
structure protection will prevent the user from inserting or deleting the sheets. The windows
option will cause the worksheet position in the screen to be locked at the same position.

4.6.4 Allow users to edit a range

This is a new facility in XP. Define a range of cells which will be editable when the worksheet is
protected.

4.7 Sharing

Excel allows sharing of workbook amongst a group of users. This is useful where a list is being
updated by several people in an organization. Click Tools->Share workbook and check the ‘Allow
changes by more than one user’ check box. The file will be marked as ‘Shared’. The other users
then can open the file and work on. After a second user adds some data and saves the file, the
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changes will be visible in the file where the shared file is saved. The owner of the file will have
the option to accept or reject changes by calling up Accept or Reject changes within Track
changes in Tools menu.

Page 49/49



