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WORKBOOKS, CELLS AND FORMULAS. 

GET STARTED. 

 WHAT IS EXCEL? 

With Excel on your PC, Mac, or mobile device, you can:  

 Streamline data entry with AutoFill.  

 Spot trends and patterns with data bars, sparklines, color coding, and icons. 

 Get chart and PivotTable recommendations based on your data, and create 

them with one click. 

 Share your work from within Excel, using OneDrive. 

 Edit spreadsheets with others, wherever they are. 

 

 CREATE A WORK BOOK. 

A workbook is a file that contains one or more worksheets, to help you organize your 

data. You can create a workbook from a blank workbook or a template. 

 

 Create a workbook  
1. Select File > New. 

2. Select Blank workbook. 

Tip: Press CTRL+N to quickly create a new workbook. 

 

 Create a workbook using a template  
1. Select File > New. 

2. Do one of the following: 

o Select a template from the available list of templates, and then select 

Create. 

o From Suggested searches, select a category (such as Business, 

Personal, or Industry), select a template, and then select Create. 

 

 ADD, DELETE OR RENAME SHEET. 

By default, Excel gives you one worksheet in a workbook, but you can add more 

worksheets, rename them, or delete them, as needed. 

 

 Insert a worksheet  
1. Do one of the following: 

o On the Sheet tab, select   . A new worksheet will be added to the 

right of the current sheet. 

 
o Select Home > Insert > Insert Sheet. 

o Right-click a sheet, click Insert, and in the Insert box, click 

Worksheet, and then click OK. 
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 Rename a worksheet  
1. On the Sheet tab, right-click the worksheet you want to rename, and then click 

Rename. 

2. Type a new name for the Sheet, and then press Enter. 

Tip: Double-click the sheet name on the Sheet tab to quickly rename it. 

 

 Remove a worksheet  
1. On the Sheet tab, right -click the sheet you want to delete. 

2. Click Delete . 

3. If the sheet is empty, it will be Deleted, but if there is data on the sheet, then a 

pop-up message will appear. Select Delete to confirm the deletion. 

 

 Hide a worksheet  
1. On the Sheet tab, right -click the sheet you want to hide. 

2. Click Hide. 
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DESIGN WORKBOOKS. 

 HIDE OR UNHIDE COLUMNS. 

Hide or unhide columns in your spreadsheet to show just the data that you need to see 

or print. 

 

 Hide columns  
1. Select one or more columns, and then press Ctrl to select additional columns 

that aren't adjacent. 

2. Right-click the selected columns, and then select Hide. 

Note: The double line between two columns is an indicator that you've hidden 

a column. 

 

 Unhide columns  
1. Select the adjacent columns for the hidden columns. 

2. Right-click the selected columns, and then select Unhide. 

Or double-click the double line between the two columns where hidden columns 

exist. 

 

 FREEZE TOP AND LEFT PANES. 

Freeze rows and columns to keep specific areas visible when you scroll in a 

worksheet.  

 Freeze the first column  

 Select View > Freeze Panes > Freeze First Column. 

Note: The faint line that appears between Columns A and B indicates that 

your first column is frozen. 

 

 Unfreeze rows and columns  

 Select View > Freeze Panes > Unfreeze Panes. 

 

 Freeze rows and columns  
1. Select the cell below the rows and to the right of the columns you want to keep 

visible when you scroll. 

2. Select View > Freeze Panes > Freeze Panes. 

 

 MOVE OR COPY WORKSHEET. 

You can move or copy a worksheet in the same workbook, or copy a worksheet to 

another workbook. 

 

 Move a worksheet within a workbook  

 Select the worksheet tab, and drag it to where you want it. 

Note: Be aware that calculations or charts that are based on worksheet data 

might become inaccurate if you move the worksheet. 
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 Copy a worksheet to a new workbook  
1. Right-click the worksheet tab and select Move or Copy. 

2. Check Create a copy. 

3. Under To book, select (new book) or another workbook you have open. 

4. Select OK. 

5. Press CTRL + TAB to go back to the other workbook. 

 

 Copy a worksheet in the same workbook  
1. Press CTRL and drag the worksheet tab to the tab location you want, or right-

click the worksheet tab and select Move or Copy. 

2. Select the Create a copy checkbox. 

3. Under Before sheet, select where you want to place the copy. 

4. Select OK. 

 

 Rename a worksheet tab  
1. Double-click the worksheet tab. 

2. Type a new name. 

 

 APPLY THEMES TO CHANGE THE LOOK OF A WORKBOOK. 

Use or customize a theme in your Excel workbook to make your data stand out.  

1. Select Page Layout > Themes. 

2. Select a theme you want to use from the available list. 

Note: You will see theme previews in your worksheet as you hover over 

different themes. 
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ADD TEXT AND DATA. 

 ADD AND EDIT DATA. 

Explore the basics of adding and editing data in Excel.  

 Add data  
1. To add data in a cell, place the mouse cursor in a cell and select it or use the 

arrow keys on a keyboard to navigate to the correct cell. 

Note: The address of the selected cell displays in the top left part of the screen 

above the worksheet and the selected cell now has a border to visually indicate 

it is the active cell.  

 
2. After you have selected a cell: 

o Type in the active cell. 

o Select Formula Bar located above the worksheet, and then type in the 

data. 

 
o Double-click the cell, and then enter data. 

o Press F2 and then enter data. 

 

 Edit data  
o Select a cell to display the data in Formula Bar, and then select Formula Bar 

to edit the data. 

o Double-click a cell and then edit the data. 

o Select a cell in the worksheet, and then start typing to replace the cell content 

with new data. 

 

 Change active cell  
o Press Tab to change the location of the active cell to the cell in the next 

column. 

o Press Enter to change the location of the active cell to the cell in the next row. 

o Use the mouse cursor to choose another cell. 

 

 RESIZE AND MERGE CELLS AND ALIGN DATA. 

You can change the way data appears in a cell by merging cells, and aligning, 

wrapping, or rotating text.  

 

 Align cell data  
1. Select a cell or cell range in your worksheet. 

2. On the Home tab select a text alignment option. You can align text at the top, 

middle, or bottom of the cell, and to the left, center, or right of the cell. 

Note: You may not be able to change the alignment, based on the format of 

the cell. 

 

 Add a line break within a cell  
1. Select the cell. 

2. Type the text you want on the first line. 
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3. On the keyboard, press Alt + Enter to add a line break. 

4. Type the next you want on the next line. 

5. Press Enter. 

 

 Make a cell taller or wider  
1. Place the cursor on the line between the cell and next cell.  

2. Drag the line to the height or width you want. 

 

 Wrap Text  
1. Select a cell or cell range. 

2. Select Home > Wrap Text. 

 

 Merge cells  
1. Select the cells you want to merge. 

2. Select Home > Merge & Center. 

Note:  To later unmerge cells, select Unmerge Cells from the Merge & 

Center drop-down. 

 

 Rotate cell data  
1. Select a cell or cell range. 

2. Select Home > Alignment Settings . 

3. In Orientation, edit the degree of rotation the cell data. 

4. Select OK.  

Note: Note: You can also select Home > Orientation and select an option 

from the drop-down. 

 

 FORMAT NUMBERS IN CELLS. 

In Excel, you can display number formats as currency, percentages, decimals, dates, 

phone numbers, or social security numbers.  

 

 Number format  
1. Select a cell or a cell range. 

2. On the Home tab, select Number from the drop-down. 

 
Or, you can choose one of these options: 

o Press Ctrl + 1 and select Number. 

o Right-click the cell or cell range, select Format Cells… , and select 

Number. 

o Select the dialog box launcher next to Number and then 

select Number. 

 

 Currency  
1. Select a cell or a cell range that has numeric value. 

2. Select Home > Currency . 



 

 

9 

 Decimal  
1. Select a cell or a cell range that has numeric value. 

2. Select Home > Increase Decimal or Home > Decrease Decimal . 

 

 Date  
1. Select a cell or a cell range. 

2. On the Home tab, select Number Format . 

3. Select Date, and then select the Type. 

4. Select OK. 

 

 Phone number or social security number  
1. Right-click a cell or a cell range, and then select Format Cells… 

2. Select Special. 

3. For Type, select either Phone Number or Social Security Number. 

4. Select OK. 

 

 CHANGE THE LOOK OF CELLS. 

Format cells to make them stand out using fonts, font size, color, and borders.  

 

 Cell styles  
1. Select a cell or cell range in the worksheet. 

2. Select Home > Cell Style . 

3. Select the cell style that you want to apply. 

 

 Select a font, font size, font color, and border  
1. Select a cell or cell range. 

2. On the Home tab, select a Font and Font Size from the drop-down. 

3. To change the font color, select Font Color and select a color from the 

drop-down. to change the text color. 

Note: If you want to see more colors, select More Colors from the drop-

down, and select a color from the Standard or Custom tab. 

4. To change the font style, select Bold, Italic, or Underline. 

5. To change the Border, select a border from the drop-down. 

 

 COPPY CELL FORMATTING. 

Copy cell formatting in your worksheet using copy and paste options, Format Painter, 

and dragging techniques. 

 

Copy cell formatting  

Method 1  

1. Select the cells that have the formatting you want to copy. 
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2. Copy the cells, using Ctrl+C.  

Or, right-click the cells, and then select Copy. 

3. Select the cells where you want to use the copied format. 

4. Right-click the cells, and in Paste Options, select Formatting (R). 

 

Method 2  

1. Select the cells that have the formatting you want to copy. 

2. Copy the cells, using Ctrl+C.  

Or, right-click the cells, and then select Copy. 

3. Select the top cell where you want to use the copied format. 

4. Press Ctrl+Alt+V. 

5. In the Paste Special box, in Paste, select Formats, and then select OK. 

Method 3  

1. Select the cells that have the formatting you want to copy. 

2. Select Home > Format Painter, and then select the cells where you want to use the 

format. 

Copy formatting to multiple cells  

1. Select the cells that have the formatting you want to copy. 

2. Select Home > Format Painter, and then select the top cell to paste the format. 

Copy formatting on non-adjacent cells  

1. Select the cells that have the formatting you want to copy. 

2. Select Home > Format Painter, and then select cells to paste the format. 

3. Press Esc on the keyboard to deactivate the paint brush. 

Copy formatting by dragging  

1. Select the column that contains the formatting you want to copy. 

2. Hold the right mouse button, drag the right edge of the column, and then select Copy 

Here as Formats Only. 

Copy formatting by dragging down the column  
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1. Select the cell that contains the formatting you want to copy. 

2. Place the mouse cursor on the lower-right corner of the cell (pointing towards the Fill 

handle), hold the right mouse button, and then drag downwards. 

3. Select Fill Formatting Only when you release the right mouse button. 

 

 SELECT CELL CONTENTS. 

In Excel, select cell contents to help manage your work efficiently across a workbook.  

Select a cell  

 You can select a cell using a mouse or by navigating to that cell using the arrow keys 

on your keyboard. 

Select a cell range  

 Select a cell, hold the right bottom edge of the cell and drag over the cell range you 

want to select. 

 Or to select a range using the keyboard, hold the Shift key while navigating across the 

cell range using the arrow keys. 

Select a row, column, or worksheet  

 Use one of the following methods to select a column: 

 If you don’t want to select the title of the column, select the cell below the 

title, press Shift, and then double-click the bottom edge of that cell. 

 To select the entire column, select any cell in that column (for e.g., A2), and 

then press Ctrl + Space. 

 To select the entire row, select any cell in that row (for e.g., A2), and then press Shift 

+ Space. 

 To select a list, select any cell in that list, and then press Ctrl + A. 

 To select the entire worksheet, select any cell and press Ctrl + A + A. 

 To select a table without the heading or title of the table, select any cell and then press 

Ctrl + A. 

 To select a table with heading or title of the table, select any cell in that table and then 

press Ctrl + A + A. 

 To select the entire worksheet which is in table format, select any cell and then press 

Ctrl + A + A. 

 Select the letter at the top of a column to select the entire column. 

 You can also select the Select All button at the top left corner of the worksheet to 

select the entire worksheet. 

Select non-adjacent columns  

 Hold Ctrl while selecting the column headings of the non-adjacent columns. For 

example, hold Ctrl and select A, C, E, G, H, I, K. 

Select non-contiguous cells or ranges  
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 Hold Ctrl while selecting non-contiguous cells or ranges. 

Type data in non-contiguous cells at once  

1. Select non-contiguous cells. 

2. Start typing data. 

3. Press Ctrl + Enter. 

Hide columns  

1. Select a column. 

2. Right-click and select Hide. 

Hide non-contiguous columns  

1. Select non-contiguous column ranges. 

2. Right-click one of the selected column ranges and select Hide. 

Copy only visible columns  

1. Select a cell range with hidden columns. 

2. Press Alt + ; and then Ctrl + C to copy only visible columns. 

3. You can paste them in any worksheet in your workbook by simply pressing Ctrl + V. 

 

 MOVE OR COPY CELL CONTENTS. 

You can use the Cut, Copy, and Paste commands to move or copy cells or their contents. 

Move cells  

1. Select a cell or a cell range. 

2. Select Home > Cut or press Ctrl + X. 

3. Select a cell where you want to move the data. 

4. Select Home > Paste or press Ctrl + V. 

Copy cells  

1. Select a cell or a cell range. 

2. Select Home > Copy or press Ctrl + C. 

3. Select a cell where you want to copy the data. 

4. Select Home > Paste or press Ctrl + V. 

By default, drag-and-drop editing is turned on so that you can use the mouse to move 

and copy cells.  
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1. Select the cells or range of cells that you want to move or copy. 

2. Do one of the following: 

o To move a cell or range of cells, point to the border of the selection. When the 

pointer becomes a move pointer , drag the cell or range of cells to 

another location. 

o To copy a cell or range of cells, hold down Ctrl while you point to the border 

of the selection. When the pointer becomes a copy pointer , drag the cell 

or range of cells to another location. 

Move cells between existing cells  

1. Select a cell range. 

2. Hold Shift and when the pointer becomes a move pointer , drag the cell range to 

the new location between existing cells. 

 

 INSERT OR DELETE ROWS OR COLUMNS. 

Small changes in the layout of your worksheet can give you big improvements in readability. 

Insert and delete rows, columns, and cells to organize your worksheet. 

Insert a column  

1. Select the letter at the top of a column to select the column. 

2. Select Home > Insert > Insert Sheet Columns 

Or, right-click the top of the column, and then select Insert. 

Note: Excels inserts a new column to the left. 

Delete a column  

1. Select the column. 

2. Select Home > Delete > Delete Sheet Columns. 

Or, right-click the top of the column, and then select Delete. 

Insert a row  

1. Select the row number to select a row. 

2. Select Home > Insert > Insert Sheet Rows. 

 
Or, right-click the selected row, and then select Insert. 
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Note: A new row is inserted above the selected row. 

Delete a row  

1. Select the row. 

2. SelectHome > Delete > Delete Sheet Rows. 

Or, right-click the selected row, and then select Delete. 

Insert a cell  

1. Select a cell or a cell range. 

2. Right-click the selected cells, and then select Insert. 

3. In the Insert box, select an option: 

 
o Shift cells right – shifts cells right to make space for the new cell(s). 

o Shift cells down – shifts cells down to make space for the new cell(s). 

o Entire row – inserts a new row. 

o Entire column – inserts a new column. 

4. Select OK. 

 

 RESIZE ROWS OR COLUMNS. 

You can manually adjust the column width or row height by dragging the cell boundaries, or 

automatically resize columns and rows to fit the data. 

Note: The boundary is the line between cells, columns, and rows. If a column is too narrow 

to display the data, you will see ### in the cell. 

Resize columns  

1. Select a column or a range of columns. 

2. Place the pointer on the boundary between the column headers. 

 
3. Drag the boundary to change the width. This resizes all of the selected columns to the 

same width. 

Resize rows  
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1. Select a row or a range of rows. 

2. Place the pointer on the boundary between row numbers. 

3. Drag the boundary to change the height. 

Automatically resize columns or rows to fit the data  

1. Select columns or rows with data. 

2. Double-click a boundary. All columns or rows resize to fit the data. 

Note: If only one column is selected, double-click the right boundary of the column 

header. If only one row is selected, double-click the lower boundary of the row. 

Automatically resize all columns and rows to fit the data  

1. Select the Select All button at the top of the worksheet, to select all columns and 

rows. 

2. Double-click a boundary. All columns or rows resize to fit the data. 

 

 AUTOFILL TIME SPANS. 

With the AutoFill feature, you can automatically fill cells with data that follow a pattern or 

series.  

1. Select a cell and type the first word of a series (e.g. type "January" for a 12-month 

series). 

2. Select the fill handle   at the lower-right corner of the cell, hold down, 

and drag to fill the rest of the series. Fill handles can be dragged up, down, or across a 

spreadsheet. 

 

Note: If you only enter a three-letter abbreviation (e.g. "Jan") in the cell, AutoFill will 

automatically fill in the rest of the  
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 SPLIT AND COMBINE DATA. 

With Flash Fill, you can automatically fill data in a specific pattern across multiple columns.  

1. Select a cell and then enter data from a specific pattern. 

2. Press Enter. 

3. In the next cell, enter data. Excel will begin to automatically fill data in cells from a 

set pattern.  

 

4. To use Flash Fill, select Data > Data Tools > Flash Fill or press Ctrl + E. 

 

 BUILD CUSTOM NUMERIC FORMATS. 

Excel has many built-in numeric formats you can use, or you can build your own.  

1. Right-click the column header, and then select Format Cells.  

Or, select a column, and then select Home > Number. 

 

The Format Cells dialog box opens, with the Number tab selected by default. 

Note: You can also press Ctrl + 1 to open the Format Cells dialog box. 
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2. In Category, select Custom. 

 
3. In Type, select an existing format.  

Or, type a new format in the Type box, to create one. 

4. Select OK. 

 

 VALIDATE CELL DATA. 

When you create worksheets that will be used by others, it’s important to make sure they can 

only enter valid data. Use Excel’s data validation features to make rules to restrict the type of 

data or values that others can enter into a cell. 

1. Select the cell(s) you want to create a rule for. 

2. Select Data >Data Validation. 

 
3. On the Settings tab, under Allow, select an option: 

o Whole Number - to restrict the column to accept only whole numbers. 

o Decimal - to accept decimal numbers. 
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o List - to pick data from the drop-down list. 

o Date - to restrict the cell to accept only date. 

o Time - to restrict the cell to accept only time. 

o Text Length - to restrict the length of the text. 

o Custom – for custom formula. 

4. Under Data, select a condition: 

o between  

o not between  

o equal to  

o not equal to  

o greater than  

o less than  

o greater than or equal to  

o less than or equal to  
5. On the Settings tab, under Allow, select an option: 

6. Set the other required values, based on what you chose for Allow and Data. 

For example, if you select between, then select the Minimum: and Maximum: 

values for the cell(s). 

7. Select the Ignore blank checkbox if you want to ignore blank spaces. 

8. If you want to add a Title and message for your rule, select the Input Message tab, 

and then type a title and input message. 

9. Select the Show input message when cell is selected checkbox to display the 

message when the user selects or hovers over the selected cell(s). 

10. Select OK. 

Now, if the user tries to enter a value that is not valid, a pop-up appears with the 

message, “This value doesn’t match the data validation restrictions for this cell.” 

 

 CREATE REUSABLE LISTS. 

For lists that you use often, you can create a reusable list, so you don't have to type the list 

every time you need it. 

Create a custom list  

1. Select the cells within the list that you want to reuse. 

2. Select File > Options. 
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3. Select Advanced, scroll-down, and in the General section, select Edit Custom Lists. 

 
4. Select Import, and then select OK. 

 

Tip: You can also create a custom list by typing the list into List entries. 

5. Select OK to exit the Excel Options dialog box. 

Use a custom list  

 Type any data in a cell from the custom list, and then drag the fill handle across cells. 
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Sort by custom list  

1. Select a cell in the column you want to sort. 

2. Select Data > Sort. 

3. For Sort by, select the column you want to sort. 

4. For Sort on, select Values. 

5. For Order, select Custom list. 

6. In Custom lists, select the custom list. 

7. Click OK to close the Custom Lists dialog box. 

8. Click OK to close the Sort dialog box. 

 

 

USE FORMULAS AND FUNCTIONS. 

 CREATE FORMULAS. 

Get started on how to create formulas and use built-in functions to perform calculations and 

solve problems.  

Formula bar  

 When a formula is entered into a cell, it also appears in the Formula bar. 

 

Create a formula that refers to values in other cells  

1. Select a cell. 

 
2. Type the equal sign =. 

Note: Formulas in Excel always begin with the equal sign. 

3. Select a cell or type its address in the selected cell. 

 
4. Enter an operator. For example, – for subtraction. 

5. Select the next cell, or type its address in the selected cell. 
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6. Press Enter. The result of the calculation appears in the cell with the formula. 

To see a formula  

1. Select a cell, and see the formula in the formula bar.  

 

Enter a formula that contains a built-in function  

1. Select an empty cell. 

2. Type an equal sign = and then type a function. For example, =SUM for getting the 

total sales. 

3. Type an opening parenthesis (. 

4. Select the range of cells, and then type a closing parenthesis). 

 
5. Press Enter to get the result. 

Relative references  

 A relative cell reference in a formula, such as B2:G2, is based on the relative position 

of the cell that contains the formula, such as H2. If the position of the cell that 

contains the formula changes, the reference is changed. If you copy or fill a formula 

across rows or down columns, the reference automatically adjusts. By default, new 

formulas use relative references. For example, if the formula in H2 is copied to H3, it 

automatically adjusts from =SUM (B2:G2) to =SUM (B3:G3). 

Absolute references  

 An absolute cell reference, like $B$2, in a formula always refers to a cell in a specific 

location. The formula in H2 with absolute references would be =SUM ($B$2: $G$2). 

If the position of the cell that contains the formula changes, the absolute reference 

remains the same. For example, if the formula in H2 with absolute reference is copied 

to H3, H2 and H3 will have the same formula =SUM ($B$2: $G$2). 

 

 NAMES CELLS AND RANGES. 

In Excel, you can name cells and cell ranges, and use those names in formulas. This is a 

useful feature that makes the formulas easier to understand and maintain. 

Name a cell or cell range  

1. Select a cell or a cell range. 

2. In the Name Box, type a name.  
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You can click the drop-down arrow to see the list of existing range names, if any. 

Names: 

o Cannot begin with a number. 

o Cannot contain spaces. 

o Can contain Upper and lowercase letters. 

o Can include underscores. 

Press F3 to use the name  

1. Select a cell. 

2. Press the F3 function key. 

3. In the Paste Name box, select the name, and then select OK. 

Use names in formulas  

1. Select a cell and enter a formula. 

2. Place the cursor where you want to use the name in that formula. 

3. Type the first letter of the name, and select the name from the list that appears. 

4. Press Enter. 

Delete a name  

1. Select Formulas > Name Manager. 

2. Or, press Ctrl + F3. 

Note:  With Name Manager, you can create New names, Edit names, or Delete 

names. 

3. Select the name, and then select Delete. 

Note: If you delete a name that is used in formulas on your worksheet, it will create 

errors in your worksheet. 

4. Select Close. 

View and paste all names into your workbook  

1. Select an empty cell. 

2. Select Formulas > Use in Formula. 

 
3. Select Paste Names from the drop-down. 

This pastes the names, sheet name, and cells in that range, into your workbook. 

 

 USE TRACE TO FIX FORMULA ERRORS. 
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Checking formulas for accuracy and finding the source of an error is hard when the formula 

uses precedent or dependent cells. To help, use Trace Dependents and Trace Precedents to 

graphically show the relationships between these cells and formulas with tracer arrows.  

 Dependent cells contain formulas that refer to other cells. 

For example, if cell D10 contains the formula =B5, cell D10 is a dependent of cell B5. 

 Precedent cells are referred to by a formula in another cell. 

For example, if cell D10 contains the formula =B5, cell B5 is a precedent to cell D10. 

Trace cells that reference a cell (dependents)  

1. Select the cell for which the dependent cells need to be identified. 

2. On the Formulas tab, select Trace Dependents to display a tracer arrow to each cell 

that is dependent on the active cell. 

 
o Blue arrows - show cells with no errors. 

o Red arrows - show cells that cause errors. 

o Black arrows - if the selected cell is referenced by a cell on another worksheet 

or workbook, a black arrow points from the selected cell to a worksheet icon 

. The other workbook must be open before Excel can trace these 

dependencies. 

3. Select Trace Dependents again to identify the next level of cells that depend on the 

active cell.  

Note: At some point, a beep will be heard, otherwise the arrows will stop appearing. 

4. To remove tracer arrows one level at a time, starting with the dependent cell furthest 

to the active cell, select the arrow next to Remove Arrows on the Formulas tab, and 

then select Remove Dependent Arrows. 

5. To remove another level of tracer arrows, select Remove Dependent Arrows again. 

Note: You can use Ctrl + Shift + ] to highlight all the dependents of a cell. 

Trace cells that provide data to a formula (precendents)  

1. Select the cell for which the precedent cells need to be identified. 
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2. Select Formulas > Trace Precedents to display a tracer arrow to each cell that 

directly provides data to the active cell. 

 
o Blue arrows - show cells with no errors. 

o Red arrows - show cells that cause errors. 

o Black arrows - if the selected cell is referenced by a cell on another worksheet 

or workbook, a black arrow points from the selected cell to a worksheet icon 

. The other workbook must be open before Excel can trace these 

dependencies. 

3. Select Trace Precedents again to identify the next level of cells that provide data to 

the active cell. 

Note: At some point, a beep will be heard, otherwise the arrows will stop appearing. 

4. To remove tracer arrows one level at a time, starting with the precedent cell furthest to 

the active cell, select the arrow next to Remove Arrows on the Formulas tab, and 

then select Remove Precedent Arrows. 

5. To remove another level of tracer arrows, select Remove Precedent Arrows again. 

 

 LOCATE FUNCTIONS. 

Excel groups functions into many categories and you can use help to understand what each 

function does. 

Find functions and categories of functions  

1. Select Formulas. 

2. The Function library group displays categories of functions that are available. 

 
3. If the function you are looking for is unlikely to be in the categories listed, select 

More Functions. 

Use help to get more information about functions  

1. Select Formulas. 

2. Select a category of function, and then hover the mouse cursor over the function. 

3. Select Tell me more. 
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 CALCULATIONS USING FUNCTIONS. 

Excel provides a vast number of built-in functions to perform simple or complex calculations.  

Use functions  

1. Select a cell in the worksheet. 

2. Select Formulas, and then select a function from a category in the Function Library 

group. 

 
3. Specify data in the Function Arguments box for a range of cells. 

4. Press Enter, or select OK. 

By default, the resulting value appears in the selected cell, and the formula is 

displayed in the formula bar. 

Use Insert function  

1. Select a cell in the worksheet. 

2. Select Formulas and then select Insert Function. 

3. Type the function name in the Search for a function box, or select the category of 

the function. 

4. Select a function, and then select OK. 

5. Specify data in the Function Arguments box for a range of cells. 

6. Press Enter, or select OK. 

To insert a function, type equal sign = and the likely function name in the cell. A list 

will be visible. Select a function from the list. For example, =SUM. 

 

TABLES, CHARTS AND ANALYSIS. 

ADD AND FORMAT TABLES. 

 CREATE AND FORMAT TABLES. 

You can create and format a table, to visually group and analyze data. 

Shortcuts  

1. To create a table, select the data and select Home > Format as Table. 

Tip:  You can also press CTRL + T or CTRL + L. 
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2. To make sure there are no empty columns or rows in the data, select a cell within the 

data, press CTRL + A, then press CTRL + . a few times to move around the data. 

Create a table  

1. Select a cell or range of cells to include in the table. 

2. Select Insert > Table . 

3. A Create Table box appears with the cells to include in the table. Edit if needed. 

4. If your table has a header, check the My table has headers checkbox 

5. Select OK. A Design tab appears in the Ribbon. 

Format a table  

1. Select a cell within the table. 

2. On the Design tab, select a Table Style.  

3. In the Table Style Options group, you can check and uncheck different boxes to get 

the look you want, for example Banded Rows or Banded Columns.  

Note: If a new row or column is added in the table, it will be automatically added 

with the table style. Formulas are applied as you add new rows, or create a formula 

within a column. 

 

 SORT DATA IN A TABLE. 

Sorting is one of the most common tools for data management. In Excel, you can sort your 

table by one or more columns, by ascending or descending order, or do a custom sort. 

Before sorting a table:  

1. Make sure that there are no empty rows or columns in the table. 

2. Get table headers into one row across the top. 

3. Make sure there is at least one empty column between the table you want to sort, and 

other information on the worksheet not in that table. 

Check for empty rows or columns  

1. Select a cell within the data and press CTRL + A. 

2. Press CTRL + . a few times to move the active cell around the corners, and check for 

empty cells. 

Sort the table  

1. Select a cell within the data. 
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2. Select Home > Sort & Filter. 

 
Or, select Data > Sort. 

 
3. Select an option: 

o Sort A to Z - sorts the selected column in an ascending order. 

o Sort Z to A - sorts the selected column in a descending order. 

o Custom Sort - sorts data in multiple columns by applying different sort 

criteria. 

For a Custom Sort:  

1. Select Custom Sort. 

2. Select Add Level. 

 
3. For Column, select the column you want to Sort by from the drop-down, and then 

select the second column you Then by want to sort. For example, Sort by 

Department and Then by Status. 

4. For Sort On, select Values. 

5. For Order, select an option, like A to Z, Smallest to Largest, or Largest to 

Smallest. 

6. For each additional column that you want to sort by, repeat steps 2-5. 

Note: To delete a level, select Delete Level. 

7. Check the My data has headers checkbox, if your data has a header row. 

8. Select OK. 

 

 FILTER DATA IN A TABLE. 
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Filters provide a quick way to find and work with a subset of data in a range or table. When 

you filter a list, you temporarily hide some of the data, so you can focus on the data you want.  

Filter data  

1. Select a cell within the data that you want to filter. 

Note: Before you filter your data, make sure there are no empty rows or columns. 

2. Select Home > Sort & Filter > Filter. 

Or, select Data > Filter. 

3. Select the filter drop arrow of the column you want to filter. 

 
4. Uncheck Select All, and check the filters you want. 

 

5. Select OK. The filter drop arrow changes to a filter to show the column is filtered. 

The Blue row numbers show which rows are included in the filtered data. 

6. To remove the filter, select Clear. All data displays.  

 

Note: To apply filters on multiple columns, select the first column, apply the filter, 

and then select the next column and apply a filter on one. 
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Apply a custom filter  

1. Select the filter drop arrow and then select: 

o Text Filters - available when the column Contains text or a mix of text and 

numbers: Equals, Does Not Equal, BeginsWith, EndsWith, or Contains. 

o Number Filters - available when the column contains only numbers: Equals, 

Does Not Equal, Greater Than, LessThan, or Between. 

o Date Filters - available when the column contains only dates: Last Week, 

Next Month, This Month, and Last Month. 

o Clear Filter from ‘Column’ - available when the column is already filtered. 

Select this option to clear the filter. 

o Select And if both conditions must be true. 

o Select Or if only one of the conditions needs to be true. 

2. Enter the filtering conditions. 

3. For example, to view the numbers greater than a specific number, select Number 

Filters > Greater Than Or Equal To and then enter the specific number. 

 
4. To filter results by two conditions, enter the filter conditions in both boxes. 

5. To change the order of the filter results, select the filter drop-down, and then select 

either Sort Largest to Smallest or Sort Smallest to Largest. 

 

 ADD A TOTAL ROW TO A TABLE. 

You can add totals to a table by selecting the Total Row checkbox on the Design tab. You 

can also add a function from the total row drop-down. 

1. Select a cell in a table. 

2. Select Design > Total Row. 
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3. The Total row is added to the bottom of the table. 

 

Note: To add a new row, uncheck the Total Row checkbox, add the row, and then 

recheck the Total Row checkbox. 

4. From the total row drop-down, you can select a function, like Average, Count, 

Count Numbers, Max, Min, Sum, StdDev, Var, and more. 

 

 

 FILTER DATA WITH SLICERS. 
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When working with large amounts of data, you can use slicers in your table, to filter and view 

your data. 

Convert data into a table  

1. There are four ways to convert data into a table: 

Note: In order to use a slicer, you must convert your data into a table first. 

o Press Ctrl + t. 

o Press Ctrl + l. 

o Select Home > Format as Table. 

o Select Insert > Table. 

2. Select OK. 

Use a slicer to filter data  

1. Select Insert > Slicer. 

 
2. Select the fields you'd like to filter. 

3. Select OK and adjust your slicer preferences, such as Columns, under Options. 

Note: To select more than one item, hold Ctrl, and then select the items that you want 

to show. Select and hold the corner of a slicer to adjust and resize it. 

4. Select Clear Filter to clear the slicer filter. 

 

ADD AND FORMAT CHARTS. 

 CREATE CHARTS. 

Charts help you visualize your data in a way that creates maximum impact on your audience. 

Learn to create a chart and delete a chart.  

Create a chart  

1. Select the data for your chart. 

2. Select Insert > Recommended Charts. 

3. Select a chart on the Recommended Charts tab, to preview the chart. 

Note: You can select the data you want in your chart and press ALT + F1 to create a 

chart immediately, but it might not be the best chart for the data. If you don’t see a 

chart you like, select the All Charts tab to see all chart types. 

4. Select a chart. 

5. Select OK. 
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Delete a chart  

1. Select the chart. 

2. Press Delete. 

 

 ADD SPARKLINE CHARTS. 

Sparklines are mini-charts placed in single cells, to show visual data trends. You can quickly 

add and format a Sparkline chart in your worksheet.  

Add a Sparkline chart  

1. Select the data for your Sparkline chart. 

2. Select Quick Analysis in the lower-right corner of the selected data. 

 
3. Select SparkLines and then select Line, Column, or Win/Loss.  

 

Format a Sparkline chart  

1. Select the Sparkline chart. 
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2. Select Design and then select an option: 

 
o Select Line, Column, or Win/Loss to change the chart type. 

o Check Markers to highlight individual values in the Sparkline chart. 

o Select a Style for the Sparkline. 

o Select Sparkline Color and the color. 

o Select Sparkline Color > Weight to select the width of the Sparkline. 

o Select Marker Color to change the color of the markers. 

o If the data has positive and negative values, select Axis to show the axis. 

 

 FORMAT CHARTS. 

To customize the looks of your chart, use Excel’s formatting options to change the title, 

layout, chart style and theme color. 

Create a Chart  

1. Select a range of cells. 

2. Select Insert > Recommended Charts. 

3. Select Recommended Charts, and then select a chart of your choice. 

4. Select OK. 

A chart consists of various sections such as the Chart Title, Plot Area, Vertical 

(Value) Axis Title, Horizontal (Category) Axis Title, and Legends. 

 

Add a chart title  
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1. Select Chart Title and type a title. 

Or, to pick up the title from data in a cell, select the Chart Title, type = cell (for 

example, =D1) in the formula bar, and press ENTER. 

2. To format the title, use the Font options on the Home tab to: 

o Select a Font and Font Size 

o Make the font Bold, Italic, or Underline 

o Change the Font Color: 

Note:  You can use these options to format the Axis Titles as well. 

Change the chart layout  

1. Select the chart. 

2. Under Chart Tools, select Design > Quick Layout. 

3. Hover over the options to see a preview, then select a layout. 

 

Change the chart style  

1. SelectDesign and select the drop-down arrow to see all the options. 

2. Select a chart style. 

 

Select a theme style to add color  

1. In the chart, select the Plot Area, the inner area that shows the plotted data. 

2. Under Chart Tools, select Format. 
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3. Select a Theme Styles. 

 
The selected style will be applied to the Plot Area. 

 

 ADD TRENDLINES AND DROP LINES. 

In Excel, you can add trendlines and drop lines to your charts to forecast data and show visual 

data trends.  

Add a trendline  

1. Select a chart. 

2. Select a point in the data series (e.g. line chart, column chart, or bar chart). 

3. Right-click and select Add Trendline. 

Format a trendline  
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1. In the Format Trendline pane, select a Trendline Option to choose the trendline 

you want for your chart. Formatting a trendline is a statistical way to measure data: 

 
2. Set a value in the Forward and Backward fields to project your data into the future. 

Add drop lines  

1. Select the chart in which you want to add drop lines. 

2. Select Design > Add Chart Element > Lines > Drop Lines. 

 

ANALYZE AND CHART DATA. 

 QUICK ANALYSIS OF DATA. 
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Excel's Quick Analysis button lets you instantly create different types of charts, like 

clustered, stacked, and scattered charts. 

1. Select a range of cells. 

2. Select Quick Analysis, a button that appears at the bottom right corner of the selected 

range. 

Or, press Ctrl + Q. 

 

3. Select Charts.  

 
4. Hover over the chart types to get a preview, and then select the chart you want. 

 

PIVOT TABLES, COLLABORATION AND MAC. 
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CREATE AND FORMAT PIVOT TABLES AND PIVOT CHARTS. 

 CREATE PIVOT TABLES. 

A PivotTable is a powerful tool to calculate, summarize, and analyze data that lets you see 

comparisons, patterns, and trends in your data. 

Create a PivotTable  

1. Select the cells you want to create a PivotTable from.  

Note: Your data shouldn't have any empty rows or columns. It must have only a 

single-row heading. 

2. Select Insert > PivotTable.  

 

 
3. Under Choose the data that you want to analyze, select Select a table or range. 

 
4. In Table/Range, verify the cell range. 

5. Under Choose where you want the PivotTable report to be placed, select 

Newworksheet to place the PivotTable in a new worksheet. 

6. Select OK. 

Building out your PivotTable  

1. To add a field to your PivotTable, select the field name checkbox in the PivotTables 

Fields pane.  
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Note: Selected fields are added to their default areas: non-numeric fields are added to 

Rows, date and time hierarchies are added to Columns, and numeric fields are added 

to Values. 

 

2. To move a field from one area to another, drag the field to the target area. 

 

 WORK WITH PIVOT TABLES. 

When you have a large amount of data, you may want to rearrange the data in your 

PivotTable to make it easier to work with. You can also add or change the fields in a 

PivotTable. 

Rearrange fields  

1. Select a cell anywhere in the PivotTable. 
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2. Select Analyze > Field List. 

3. In the PivotTable Fields pane, select the fields you want to show in your PivotTable. 

 
Typically, non-numeric fields are added to Rows, numeric fields are added to Values, 

and Online Analytical Processing (OLAP) date and time hierarchies are added to 

Columns. 

4. To rearrange fields, drag the fields to the areas you want them to be. 

o Filters are the top-level report filters, above the PivotTable. 

o Columns are shown at the top of the PivotTable. 

Note:  Depending on the hierarchy of the fields, columns may be nested inside 

higher-level columns. 

o Rows are shown on the left side of the PivotTable. 

Note: Depending on the hierarchy of the fields, rows may be nested inside 

higher-level rows. 

o Values are the summarized numeric values in the PivotTable. 



 

 

41 

Note:  If you have more than one field in an area, you can rearrange their 

order by dragging them. To delete a field from the PivotTable, drag the field 

out of its area. Any changes to the data in the PivotTable do not change the 

source data. 

To update the PivotTable with the latest source data:  

1. Select any cell on the PivotTable. 

2. Select Analyze > Refresh.  

Or, press Alt + F5. 

 

 GROUP DATA IN PIVOT TABLES. 

PivotTables are a great way to summarize, analyze, explore, and present your data. You can 

even group the data in a PivotTable to enhance the layout and format of your PivotTable 

reports. 

Group data  

1. In the PivotTable, right-click a cell with a date in it, and then select Group. 

2. In the Grouping box, select the Starting at and Ending at checkboxes, and type or 

edit the start and end date, if needed. 

 
3. Under By, select one or more options to group the dates. 

4. Select OK. 

 

 FILTER DATA WITH SLICERS IN PIVOT TABLES. 
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Slicers are a quick and effective way to filter large amounts of data in your PivotTable. 

Slicers are buttons you can click to filter the data. They stay visible, so you always know 

what fields are shown or hidden in the filtered PivotTable. 

Insert slicers  

1. Select a PivotTable. 

2. Select Analyze > Insert Slicer . 

3. In the Insert Slicers box, select the fields you want to create slicers for. 

Note:  You can select fields in the PivotTable, as well as fields in the source data that 

are not part of the PivotTable. 

4. Select OK. 

5. Select a slicer and do one of the following: 

o Drag the slicer where you want. 

o Resize the slicer. 

o Select a color or style in Options > Slicer Styles. 

o Change the number of Columns in the slicer in Options > Columns.  

 
6. In each slicer, select an item to view results in the PivotTable. 

To select more than one item, hold the Ctrl key, and then select the items that you 

want to view in the PivotTable. 

7. To clear a Filter, select the X on the Filter icon in the slicer. 

 

 CREATE PIVOT CHARTS. 

PivotCharts help you make sense of large amounts of complex data. While a PivotChart 

shows data series, categories, and chart axes the same way a standard chart does, it also gives 

you interactive filtering and zoom controls right on the chart, so you can quickly analyze a 

subset of your data, and see comparisons, patterns, and trends. 

Create a PivotChart on a new worksheet  

1. Select a range of cells or a table. 

2. Select Insert > PivotChart .  

3. In the Create PivotChart box, under Choose the data that you want to analyze, 

choose Select a table or range, and then in Table/Range, verify the cell range. 
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4. Under Choose where you want the PivotChart to be placed, select 

Newworksheet to place the PivotChart in a new worksheet.  

Or, select Existing worksheet, and then select the Location. 

5. Select OK.  

A new worksheet opens, with a PivotTable placeholder, PivotChart placeholder, and 

PivotChart Fields pane. 

6. In the PivotChart Fields pane, select the fields you want to include in your 

PivotChart. 

7. Drag the items you want from the field list into the LEGEND (SERIES) area. 

Note: You can also drag the items from the LEGEND (SERIES) area into the AXIS 

(CATEGORIES) area. 

 
Think of the LEGEND area like COLUMNS in the PivotTable Fields box, and 

AXIS like ROWS. 

The PivotChart and PivotTable are created simultaneously. Any changes to one are 

reflected in the other. 

Change PivotChart style  

1. Select a PivotChart. 

2. Select Design > Chart styles. 

 

COLLABORATE WITH OTHERS. 

 SHARE WORKBOOKS. 

Share a workbook with others, right within Excel. You can let them edit the workbook or just 

view it. 

Share a workbook  

1. Create or open the workbook that you want to share. 
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2. Select Share in the top-right corner of Excel. 

 

3. Under Invite people, enter the email address of the person you'd like to share your 

workbook with.  

 

Tip: If you have the person's contact info stored in your contacts, just enter their 

name. 

4. Select Share. 

5. If asked, choose where to upload a copy of your workbook. 

 

 ADD AND REVIEW COMMENTS. 

Add comments to cells to explain what the cells contain. 

Add a comment  

1. Right-click a cell and click Insert Comment. 

2. In the comment box, type your comment.  

3. Click outside the comment box.  

The comment box disappears, but a red comment indicator remains. To see the 

comment, hover over the cell.  

Tip: To format your comment, highlight the text you want to change, right-click on 

the comment and choose Format Comment. 
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Review comments  

 Select the Review tab, and click Next or Previous to see each comment in sequence. 

See all comments at once  

 Select Review > Show All Comments to show or hide comments. 

You may need to move or resize overlapping comments.  

Note: Select Review > Show/Hide Comment to show or hide individual comments. 

Move a comment  

 Drag the border of the comment box.  

Resize a comment  

 Drag one of the handles on the sides or corners of the comment box.  

 

PASSWORD – PROTECT WORKBOOKS. 

 PASSORD – PROTECT WORKBOOKS. 

Protect a workbook with a password to prevent others from adding, moving, deleting, hiding, 

or renaming the worksheets in the workbook.  

Require a password to open an Excel file  

1. Select File > Save As, or press F12. 

2. In the Save As box, select Tools, and then select General Options. 

3. Enter a password in the Password to open box, and then select OK. 

4. Re-enter the password in the Confirm Password box, and then select OK. 

5. Select Save, and then select Yes If you wish to replace the existing file. 

Require a password to modify an Excel file  

1. Select File > Save As, or press F12. 

2. In the Save As box, select Tools, and then select General Options. 

3. Enter password in the Password to modify box, and then select OK. 

4. Re-enter the password in the Confirm Password box, and then select OK. 

5. Select Save, and then select Yes If you wish to replace the existing file. 

Require separate passwords to open and modify an Excel file.  

1. Select File > Save As, or press F12. 

2. In the Save As box, select Tools, and then select General Options. 
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3. Enter different passwords in the Password to modify and Password to open boxes, 

and then select OK. 

4. In the Confirm Password box, re-enter the password in the Reenter password to 

proceed field and then select OK. 

5. In the Confirm Password box, re-enter the password in the Reenter password to 

modify field and then select OK. 

6. Select Save, and then select Yes If you wish to replace the existing file. 

 

EXCEL FOR MAC TIPS. 

 CREATE CHARTS ON A MAC. 

Charts help you visualize your data in a way that creates the most impact on your audience.  

Create a chart  

1. Select the data you want to represent in a chart. 

Tip: You can hold down the Command key to select non-contiguous ranges.  

2. Select Insert. 

3. Select from among the chart choices listed. 

4. To delete an unwanted chart, select the chart, and press Delete. 

 

 CREATE REUSABLE LISTS ON A MAC. 

Creating a custom list is useful if you have a list that you frequently need in your worksheets. 

For example, you could have a list of all your products stored as a custom list. Every time 

you need the list in a spreadsheet, you just need to type in one item from the list, usually the 

first item, and then drag the + sign in the lower right-hand corner of the cell to automatically 

fill in the rest of the list. 

Create a custom list  

1. Select Excel > Preferences. 

2. Select Custom Lists. 

3. Select Import list from cells. 

4. Select and drag through the cells containing the list. 

5. Select Import, and close the dialog box. 

Using a custom list  

1. Select a cell 

2. Type the first word of the custom list that you created. 

3. Drag the + sign in the lower right-hand corner of the cell and drag it downward. 



 

 

47 

Note: Sometimes, you might want to type a word and drag the + sign in the lower 

right-hand corner of the cell to repeat it a few times. However, if that word is a part of 

a custom list, you'll get the other entries from the custom list. To avoid that, hold 

down the Option key, and then drag the + sign in the lower right-hand corner of the 

cell to repeat it a few times. 

Sort data using a custom list  

1. Select Sort.  

Note: As always, with sorting, make sure your list has no empty rows or columns 

within it. 

2. In the Sort pop-up box, under Order, select Custom List. 

3. Select the custom list entry of your choice. 

4. Select OK > OK. 

 

 HIDE OR UNHIDE COLUMNS ON A MAC. 

You can hide or unhide rows or columns in your spreadsheet to show only the data you want. 

Hide columns  

1. Select the column or columns that you want to hide. 

Tip: To select non-adjacent columns, hold the Command key and select the columns. 

2. Control + click any selected column, and then select Hide. 

Unhide columns  

1. Select the columns around the columns that you want to unhide. 

2. Control + click any selected column, and select Unhide. 

Or, double-click the boundary between the selected columns. 

Tip: To unhide all hidden columns, select the upper left-hand corner to select the 

entire worksheet, right-click any column, and select Unhide. 

 


