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1 Basics & Beyond.. 

1.1 Introduction 
Microsoft Excel is a spreadsheet program that is designed to record and analyze numbers 
and data. Excel is very widely used for accounting and financial purposes. 
 
The files created in Excel are known as workbooks. In turn, each workbook can contain 
one or more worksheets. An Excel worksheet is laid out like a grid with horizontal rows 
and vertical columns. Columns are labeled with alphabets (A, B, C, etc.) while rows are 
given numbers (1, 2, 3, etc.). The intersection of a row and a column is called a cell. A 
cell is referred by a combination of column alphabet and row number (A1, A2, etc.). A 
cell is a primary unit of measure in Excel and all the information is stored in cells. . A 
range is a collection of contiguous cells (which form a rectangular block) on which the 
user wants to perform similar type of calculations. A range is referred to by a 
combination of the cell addresses of the diagonally opposite cells separated by a colon 
(A1:D6) 
 

1.2 The EXCEL Screen 
On loading MS-EXCEL (either through the shortcut menu, or icon on desktop or through 
the Start Menu), the following screen appears: 

 



 
The various components of the EXCEL Screen are explained in brief below: 

Sr. Contains Remarks 
1 Title Bar Contains the name of the File currently open and also has 

the window control buttons to either close or minimize the 
program0 

2 Menu Bar Contains the list of various commands that can be 
performed in MS-EXCEL. It can be invoked either by a 
mouse click or the Alt Key from the keyboard 

3 Tool Bars Contain buttons for some commonly performed tasks. The 
commands can be activated by a mere mouse-click 

4 Formula Bar Displays the content of the active cell. The left hand side of 
this bar includes the name box which contains the list of all 
the range names and thereby facilitates quicker worksheet 
navigation 

5 Column Labels Contains the headings of the columns. Can be used for 
column-wide operations like increasing column width, 
hiding columns, formatting entire columns, etc. 

6 Row Labels Contains the headings of the rows. Can be used for row-
wide operations like increasing row height, hiding rows, 
formatting entire rows, etc. 

7 Sheet Area The place where the actual data is entered. The Active Cell 
is surrounded by a dark rectangle. 

8 Sheet Tab Gives reference to the sheet which is currently active. One 
can quickly navigate through different sheets from here 

9 Additional Tool 
Bars 

Some additional toolbars 

10 Status Bar Includes the various information sent by EXCEL. Of 
particular use is the QuickSum Feature in the status bar 
which automatically displays the totals of the selected cells 

11 Scroll Bars & 
Split Indicator 

The Scroll Bars can be used for quick movement within a 
worksheet. The extreme top of the vertical scroll bar and 
the extreme right of the horizontal scroll bar contain a split 
indicator which permits the user to divide the sheet into 
two parts. 

12 Application 
Control Buttons 

These buttons are used to minimize or control the size of a 
particular file. 

 
The cell A1 is surrounded with dark rectangular block. It is the active cell. Any entry of 
data is made into the active cell.  

1.3 Moving Around 
A worksheet can contain upto 65,536 rows and 256 columns whereas the visibility of the 
information on the screen is restricted to the size of the screen (generally 18-20 rows and 
8-10 columns are visible at a time). Therefore, one may need to move around different 



sections of a worksheet. There are various ways in which one can move around very 
efficiently. 

1.3.1 Keyboard Shortcuts 
The most widely used option is of course a wheel-mouse but at times, the keyboard is 
very handy. For example, to reach the last entered cell in a worksheet one just uses the 
<Ctrl>+<End> combination. Similarly, <Ctrl>+<Home> takes one to the first cell of the 
worksheet (which is always A1). Using <Home> takes one to the first cell of the 
particular row. <End> can be used with the combination of the arrow keys to reach at the 
end of the list in the particular direction. A complete list of keyboard shortcuts is 
provided in Annexure “A” 

1.3.2 Range Names 
Sometimes it is convenient to use a descriptive name to name a cell or a range of cells.  
Named ranges can also be used in formulas and functions.  To name a range: 

1. Select the range to be named. 
2. Click the Name box on the left side of the formula bar 
3. Type the range name (up to 255 characters).  Valid names cannot use spaces 

and the first character must not be a number.  Also, the name cannot look like 
a cell address such as B14. 

4. Press Enter. 
OR 
1. Select the range 
2. Select Insert/Name 
3. Choose Define 
4. Type the name of the range. 
 
Once a particular range has been named, reaching that particular cell is very easy. Just 
choose the range name from the Name Box and you are taken there. 

 

1.3.3 Window Split & Freeze 
Many a times, one wants to refer to two different sections of a worksheet. For example, 
in case of a long list, the headings might scroll up. In that event, one can consider to split 
the window into two parts. One can split the windows by dragging the split handle which 
appears at the extreme top of the vertical scroll bar and the extreme right of the horizontal 
scroll bar. In the alternative, one can position the cell pointer to the cell where one desires 
a split and choose the command Split from the Window Menu. To remove the split, either 
re-drag the split bar or choose Window->Unsplit. 
 
While the movement of the split windows is synchronized, none of them is fixed. 
Therefore, it is possible to loose track of the titles if the mouse movements are not 
properly handled. To avoid such a situation, one can choose Window->Freeze Panes. 
To reverse the process, choose Window->Unfreeze Panes. 
 



1.3.4 Multiple Windows 
Windows Split does not permit asynchronous viewing. For such a purpose, one can 
consider opening multiple windows of the same file. To do this, choose Window-> New 
Window. Re-size both the windows using the mouse pointer. Of course, multiple 
windows of the same file are at times confusing to handle. 



2 Data Entry 
Information entered into a cell is understood either as a text entry, a value or a formula. 
Functions are also treated equivalent to formulae. Dates, time and percentages are stored 
as numbers (values). It is important that a particular information is stored in the correct 
format.  

2.1 Text 
Text entries or labels can contain any combination of letters, numbers and spaces. A label 
which is too long for the width of a cell floats across the cells to its right / left / both 
(depending on the alignment of the cell) as long as those cells do not contain any 
information. If the cells aren’t empty, the label is truncated or cut-off. By default, labels 
are left-justified. 
 

2.2 Number (including date, time, percent) 
Numbers and text are treated differently. The default alignment for text is left whereas for 
numbers, it is right. Secondly, if a value is too large to fit in the current cell width, Excel 
displays a series of # characters as a error signal. A list of various error signals and what 
they denote is enclosed as Annexure “C”. Values are displayed in the General Number 
Format. This display can be customized using the Format Cells command. 
 

2.3 Formulae 
 
A cell can also derive the value though a formula. The building of a formula is intuitive 
and can be easily mastered through practice. For example, if Cell A1 contains 3000 being 
the tax payable and you want to calculate the surcharge, go to Cell A2 and type the 
formula +A1*5% (as the surcharge rate is 5%) and Excel does the calculation for you. To 
get the gross tax liability, go to Cell A3 and say +A1+A2 (as gross tax includes tax and 
surcharge). The formula can also be built by pointing to the dependent cells instead of 
typing the cell address.  Excel evaluates a formula in a particular order of precedence. 
The operators used in a formula and precedence accorded by EXCEL are as under: 

Operator Description Precedence 
: Range of Cells 1 
, Union of Cells 2 
% Percentage 3 
^ Exponentiation 4 
* Multiplication 5 
/ Division 6 
+ Addition 7 
- Subtraction 8 
& Concatenation 9 
= < > Comparison Operators 10 

 



If the order of evaluation is to be changed, parenthesis should be used to group 
expressions within a formula. If more than one pair of parenthesis is present in a formula, 
Excel evaluates the expression in the innermost parenthesis first. 

2.4 Functions 
A cell can also derive its value through functions. Functions are processes, which have 
been defined and standardized by Excel. A complete list of functions can be found at 
Insert -> Function. A list of commonly used functions is enclosed as “Annexure B”. Few 
more common functions include the SUM function (which totals all the numbers in a 
particular range – of course, EXCEL also has the QuickSum Feature which displays the 
sum of the selected range in the bottom pane) and the IF function used to manage 
alternate calculations in varying situations (it is very simple to use and can be nested, but 
take care to use the brackets appropriately otherwise the results can be disastrous!). A 
very common example of the use of IF function is to calculate the tax payable by an 
individual. For example, if cell B3 contains the net taxable income of an individual, the 
tax payable by him (excluding surcharge) can be calculated using a nested IF function as 
stated: =IF(B3>150000,(+B3-150000)*0.3+19000,IF(B3>60000,(B3-60000)*0.2+1000, 
IF(B3>50000,(B3-50000)*0.1,0))) 

2.4.1 Using the Function Builder 
A function takes in certain standard arguments, undertakes the evaluation process and 
returns a particular result. In case one is unaware of the arguments, one can type the 
function name along with the opening parenthesis and click on the = sign on the Formula 
Bar. The Function Wizard presents the list of arguments and the brief description of the 
arguments. In such a fashion, one can build a formula through a Wizard and 
simultaneously learn the function itself. For example, the Function Builder Dialog Box in 
the case of PMT function is shown below: 

 

2.5 AutoComplete 
Manual data entry into a range of cells can be made faster with the assistance of 
AutoComplete - a feature which suggests the current cell entry based on the existing list. 
It should however be noted that AutoComplete has certain limitations – it does not work 



if there is a blank cell in the list, it works only when a unique combination consisting of 
at least one alphabet is met in the list. In case of multiple similar entries, a better option is 
the Pick from List which appears in the right-click shortcut of the mouse. 

2.6 AutoCorrect 
The AutoCorrect feature automatically corrects common typing errors as you type. For 
this purpose, Excel uses a database of commonly misspelled words. This database can be 
customized from the Tools -> AutoCorrect Menu. The following screen comes up: 

 
 
One can use the AutoCorrect feature to quickly type some normal text which is regularly 
used in an organization. For example, the organization name can be made a subject 
matter of AutoCorrect to speeden up data entry. 

2.7 AutoFill 
AutoFill is an in-built feature whereby one can fill up a particular range of cells based on 
some pre-determined series. For example, if one cell contains January and the next one 
contains February, one can just use the fill handle to automatically complete the entire 
range with the month names. One can create custom lists pertaining to one’s organization 
(for example, plant locations) from Tools -> Options -> Custom Lists. The following 
screen appears where one can either type in the required items or pick from a range of 
cells 



 
 

2.8 Data Validation 
At times, there may be a need to restrict the content that is being typed into a particular 
cell. For example, one may want the residential status to be either “Resident” or 
“Resident but Not Ordinarily Resident” or “Non Resident”. In such a case, the entry into 
a particular cell can be validated through the “Data Validation” Feature. The steps for 
data validation feature are explained below: 
 

1. Select the cell/range for which validation is to be applied 
 
2. Choose Data -> Validation from the menu. The following screen appears 

 



 
 

 
 
3. This feature validates only Keyboard Input that too in cases where the 

entry is made after the validations are set and hence may have limitations 
 
4. The user can choose the type of data and the range of data (which may be 

open-ended from one side). Alternatively, the user can specify a pre-

defined list to choose from 

 
5. The user can also specify the action to be taken in case the data entered is 

invalid 
¾ ”STOP” does not permit entry of invalid Data 
¾ “WARNING” allows alteration to invalid data. The user may still 

continue with the invalid data 
¾ “INFORMATION” just informs about the invalid data 
¾ Unchecking the “CHECK BOX” on the top allows entry of invalid 

data without any disturbance 
 
6. The Auditing Toolbar (Tools -> Auditing -> Show Auditing Toolbar) 

contains icon which enables the circling of invalid data for attention 
(second last icon on the toolbar) 

 
 
 



3 Totals & More.. 
Totalling is one of the basis requirement of any spreadsheet application. Consider the 
situation wherein the information of daily sales is entered in column B from rows 2 to 8. 
We are interested in calculating the weekly sales.  

3.1 + + + ,…. why not? 
One of the ways to calculate the weekly sales would be to use the formula 
+B2+B3…+B8.  This however is not the ideal means for multiple reasons: 
1. The length of the formula can become prohibitive 
2. If one of the cells is later deleted, the result would display an error message 
3. If an additional cell is later inserted, the value therein would not figure in the total 

3.2 SUM() Function 
 
The ideal way to total a particular range of numbers is therefore to use the SUM() 
function. The standard usage of the SUM function has already been considered. Of 
importance to note is the fact that one can total multiple non-contiguous ranges using a 
single SUM function. Just separate the range addresses by a comma. One can also use 
range names instead of the cell attributes to make the function more meaningful for the 
users. 

3.3 QuickSum 
Many a times, one just wants to refer to the total of a particular range of cells. For this 
purpose, one need not insert the SUM function and delete it thereafter. MS-EXCEL 
presents built-in totals on selection of a range at the status bar which appears at the 
bottom of the sheet. Even the Quicksum feature can be customized to show either the 
total or the maximum, minimum, average, count, numeric counts and so on. To customize 
the Quicksum feature, rightclick at the place where the sum is displayed and the 
following options appear: 

 
 
Choose the relevant option. For example, if I am interested in finding the maximum value 
in a particular range, I shall choose Max. 
 



3.4 SUBTOTAL() Function 
In case there are nested totals, the SUM function can create havoc as there would be 
multiple totals. In such a situation one can consider the use of SUBTOTAL() function. 
This function avoids the cascading effect of the SUM function by recognizing the multi-
layered totaling feature. Accordingly, a subtotal function ignores the value of another 
subtotal function in the selected range of cells. The subtotal function is not restricted 
merely to the summation but can also be used for counts, etc. Accordingly, the 
SUBTOTAL() Function requires an additional argument which is the function number. 
The various function numbers and the action performed by them are tabulated below: 

Function Number Action 
1 AVERAGE 
2 COUNT 
3 COUNTA 
4 MAX 
5 MIN 
6 PRODUCT 
7 STDEV 
8 STDEVP 
9 SUM 
10 VAR 
11 VARP 

 
Accordingly, to get a subtotal of the cells in A2 to A9, one will use the function 
=SUBTOTAL(9,A2:A9) 

3.5 SUMIF() Function 
There might be situations wherein one wants to total only particular values within a list. 
In such a scenario, one can use the SUMIF() Function. This function evaluates the values 
for a specific condition and accordingly includes them for summation. The arguments for 
the SUMIF Function are: 
Criteria Range: The range specifying the parameter or the condition 
Criteria:  The exact condition 
Sum Range:  The values to total 
 
A cousin of SUMIF() Function is the COUNTIF() Function which counts the number of 
cells satisfying a particular criteria. In fact, the COUNTIF() Function can be combined 
with the Data Validation Feature to effectively stop the input of duplicate entries within a 
range of cells. 

3.6 Sorting Data  
In case a list of data is typed, one may need the data arranged in a particular fashion. For 
example, you may want your client details either alphabetically or based on the client 
codes. This is where sorting is useful and the same is very simple. Choose the relevant 
command from the Data Menu and the Sort Wizard takes you through the rest of the 
process. Remember, sorted data is always advantageous from three counts: firstly, it 



improves readability, secondly, it permits effective lookups and lastly, it lays down the 
foundation for data grouping and sub-totalling. 
 
 
¾ Sorting is a permanent process as compared to filtering which is a temporary process 
 
¾ Choose any cell in the data range and Select Data -> Sort 
 
¾ Choose successive sort keys and sort order 
 
 

 
 
On a brief review of the above screen, one understands that the sort function permits 
sorting only upto three levels of data. If sorting is required for multiple levels of data, 
then one will have to use the sort function more than once. Sort first based on keys of 
least significance and move to keys of higher significance. 

3.7 Sub-Totals 
At times, there is a need to not only have grand totals but also subtotals – would you not 
like to have group-wise outstanding as well as total outstanding? For this purpose, one 
can use the Subtotals Function in the Data Menu. The Function is versatile and permits to 
have multiple levels of subtotals (for having such multiple levels, do not replace the 
current subtotals). Only care required is to sort the list in the same order of subtotalling 
before using the subtotals command otherwise you might end up in a mess. One can also 
consider the use of page-break option if you want individual reports for individual 
groups. And if things appear messy, just remove all subtotals and Start Afresh! 
 
To subtotal data in a spreadsheet follow these steps: 

1. Decide upon the column you wish to use for the subtotal. 
2. Sort the data using the criterion you selected in step 1. 



3. Select Data/Subtotal.  Complete the subtotal window that appears and click 
OK. 

4. Subtotals will now appear in the spreadsheet.  Subtotals can be isolated from 
raw data using the gray view bar to the left.  Clicking the (-) boxes will reduce 
data, clicking the (+) box will restore data. 

5. Clicking the small 1,2,3, boxes in the upper left corner will reduce or expand 
all categories of data simultaneously. 

6. To remove subtotals select Data/Subtotal and click on the “Remove All” 
button. 

 

3.8 Conditional Sum Add-In 
The SUM function is too simplistic in the sense that it does not permit multiple layering 
nor does it accept conditions. The SUBTOTALS feature permits multiple layering but is 
highly inflexible in approach. To incorporate complicated and specialised tasks, 
Microsoft Excel ships with certain add-ins. Each add-in performs certain tasks and has to 
be loaded specifically before it can be used. A complete list of add-ins is given in  
Annexure “D”. The process of loading an add-in is simple. For conditionally totalling a 
particular list, consider the use of the Conditional Sum Wizard Add-in. The Wizard is too 
simple to be true! 
 
 
¾ Choose Tools -> Wizard -> Conditional Sum 
 
¾ Select the list as the range, select the value to sum and specify criteria 
 
¾ To make the function dynamic, copy both the formula and condition 
 
 



4 Queries in Lists 

4.1 AutoFilter 
In case of multiple records and large databases, there may be a need to restrict the report 
to certain types of transactions. For example, if you are maintaining your sale details in 
MS-EXCEL, you may be interested in a quick list of all the sales made to a particular 
customer. This requirement is known as a query. Again, Excel has an excel-lent (!) 
feature to do this. One just needs to use it to believe it. Yes, we are talking of AutoFilter – 
the feature which displays a subset of data without actually sorting or moving data. Once 
you select the AutoFilter command from the Data Menu, Excel inserts drop down arrows 
next to column headings in the list. Selecting an item from a drop down list hides all rows 
except rows that contain the selected value. One can edit and format the cells which are 
visible. 
 
 
¾ Choose any cell in the data range and Select Data -> Filter -> AutoFilter 
 
¾ Use the drop down lists to specify criteria. Criteria can be 
 
1. Particular Value 
2. Top/Bottom (no of items) in terms of value or percentage 
3. Range through Custom Criteria 
4. Blanks/ Non-Blanks 
 
¾ Various criteria in differing columns are cumulative (AND) condition 
 
¾ Remove criteria in specific column by choosing “All” from the drop down list 
 
¾ Remove criteria in all columns by choosing Data -> Filter -> Show All 
 
 

4.2 Advanced Filter 
The filtered data can also be copied into another area by the simple process of copy-paste. 
One limitation of AutoFilter is that one can have multiple alternative criteria (OR 
condition to be more specific) for a single field, one can also have cumulative multiple 
criteria (AND condition) across multiple fields but one cannot have alternative multiple 
criteria across various fields. To cover such complex searches, one has to take recourse to 
the Advanced Filter Option. Here, one specifies the conditions in a separate range known 
as the criterion range. The results can be filtered in the original list or in another range of 
cells. 
 
 
¾ Useful for specifying criteria which are alternative in nature (OR) condition 



 
¾ Make use of a “criteria range” 
 
¾ Select Data -> Filter -> Advanced Filter 
 
¾ The filtered data may be copied to another range for subsequent analysis 
 
¾ Revert back to original data by choosing Data -> Filter -> Show All 
 
 
The Advanced Filter can also be used to delete duplicate records in Microsoft Excel. For 
this one needs to filter for unique records and then use the resulting rows to overwrite the 
source cells. The entire procedure is summarized in the table given below: 
 
 
1. In the list you want to filter, select the column or click a cell.  
 
2. On the Data menu, point to Filter, and then click Advanced Filter.  
 
3. In the Advanced Filter dialog box, click Copy to another location.  
 
4. In the Copy to box, type a cell reference.  
 
5. Select the Unique records only check box, and then click OK.  
 
6. Select the data returned by the filter, and then click Cut on the toolbar.  
 
7. Select the source data, and then click Paste on the toolbar.  
 
 



5 Functions 

5.1 Lookup Functions 
The value of a cell can also be derived from (looked up from) a pre-defined list. In this 
regard, it is important that the list to be looked up from should be in the same worksheet 
and should be sorted. Consider creating a list of status codes applicable to an assessee. 
The list of status codes and the description is entered in a separate area of the worksheet 
(ideally the record section should be reasonably far from the data section – for easy 
navigation, the record section may be appropriately named using a descriptive range 
name.) On selection of an appropriate status code, Excel can look up the status 
description from the list. There could be many instances where the lookup facility can be 
put to practical use – referring the client particulars from the client database, etc. In this 
regard, one may use the built-in functions of HLOOKUP or  VLOOKUP or one may 
choose to build the function through the use of the Lookup Wizard, an Add-in which 
ships with MS-EXCEL. But to repeat, remember to sort the record section before you use 
the lookup functions. (For sorting records, refer to Data -> Sort) 
 
1. =VLOOKUP() can be used for columnar search and =HLOOKUP() can be used 

for a row-wise search The arguments are: 
¾ The Lookup Value 
¾ The table range 
¾ The particular number of row or column in the table range 
 

2. =INDEX() in its simplified version finds the intersection of a particular row and 
column references. The arguments include: table range, row number & column 
number. However, the row and column numbers can be made dynamic through 
the use of =MATCH() command and this gives the functionality to the INDEX() 
function. Such process is inbuilt in the Lookup Wizard 

3. One can also build the function through the Lookup Wizard. Follow these simple 
instructions:- 

a. Select Tools -> Wizard -> Lookup 
b. Follow the instructions in choosing the row, column and the range 
c. To make the lookup dynamic, copy both the formula and lookup 

parameters 
 

5.2 Date Functions 
EXCEL stores dates as numbers. (also known as date serial number) Conceptually a date 
is stored as the number of days elapsed since 1st January 1900. To check this out, open a 
blank sheet and type 1 in one of the cells. Format that number as a date (Format->Cells-
>Date). The resultant display is “01-01-00” which represents 1st January 1900. When a 
date is directly entered into a cell, EXCEL automatically applies the date format and 
stores the date serial number. Enter a date like 07-08-02 in one of the blank cells. Now 
change the format of the cell as number (Format -> Cells -> Number). The display 



changes to 37475. If it doesn’t the date is entered in text format. Check the display 
orientation. Most probably, it will be left aligned! 
 
How is this mode of internal storage of any relevance to us? It is, because it helps us 
appreciate the limitations faced by EXCEL while manipulating dates. The first limitation 
of EXCEL is that since dates are not stored as dates but as numbers, certain calculations 
based on months and years have to be derived through formulae and cannot be in-built. 
You would like to automatically calculate the rebate available for senior citizens based on 
the date of birth. Let us say the date of birth is 17th March 1938 and we are interested in 
knowing whether the person is senior citizen (age > 65 years) as on 31st March 2003. Let 
us assume that the date of birth is entered in cell C3 and the year end date i.e. 31-03-2003 
is entered in cell C2. I want to calculate the age. So I enter a formula +C2-C3 in cell C4. 
To my dismay, I get a number 23755. What does this number represent? It represents the 
number of days between C2 & C3. It is the age in days but I want the age in years. Can I 
directly divide the answer by 365? Remember the calculations would be in-exact as there 
would be leap years as well.  
 
To move further, let us explore three important date functions YEAR (), MONTH () & 
DAY (). The notations of these functions are self-explanatory and they are used to split a 
date into its constituent components. For example, YEAR (“17-03-38”) will return 1938; 
MONTH (“17-03-38”) will return 3 while DAY (“17-03-38”) will return 17. Armed with 
these newly learned functions, I enter the formula +YEAR (C2)-YEAR (C3) in cell C4. 
Voila! I get the answer as 65 and am delighted. 
 
Note that the above formula is not fool-proof . Consider the date of birth to be 19th April 
1938. While he had still not completed 65 years of age as on 31st March 2003, the above 
formula treats him as a senior citizen. What was missing? I could make out that in the 
transitory year, the above formula will not work as the months are not compared at all! 
Using the IF function, the above formula can be modified as 
+IF(MONTH(C2)>MONTH(C3),+YEAR(C2)-YEAR(C3),+YEAR(C2)-YEAR(C3)-1) 
 
In effect, the above formula compares the month component of the date of birth to 
determine whether the year has completed by the end of the previous year. If it has, it 
simply calculates the difference in the year components else, it reduces the difference in 
the year components by 1 
 
In certain cases, one is interested in the difference in months (need not be completed 
months). To calculate the number of months of delay, one uses the following formula: 
 
+MONTH(C7)-MONTH(C2)+(YEAR(C7)-YEAR(C2))*12 
 
The formula calculates the difference in months components of the dates. It also 
considers the difference in the years components by taking the same into account and 
multiplying the same by 12 to convert it into months.  
 



Not too interested in using long and complicated formulae? If you have Analysis 
Toolpack installed, there is a DATEDIF function which can do the job in a minute. So, to 
calculate the completed years, I just enter the formula +DATEDIF(C3,C2,“y”). The “y” 
refers to the completed years. Similarly, +DATEDIF(C2,C7,“m”) gives me the completed 
months of delay which turns up to 13! But in certain cases, one would also like to include 
partially completed months. In effect, one would like to advance the date to the end of the 
month. This is where the EOMONTH() function is useful. So I modify my formula to say 
+DATEDIF(C2,EOMONTH(C7,0),“m”). The answer is 14! 
 

5.3 Numeric Functions 
Various built-in functions can be used for manipulating numbers. A complete list of 
functions is provided in Annexure “B”. Such functions can be used for rounding numbers 
[ ROUND(), ROUNDDOWN(), ROUNDUP(), MROUND(), CEILING(), FLOOR() ] , 
counting the cells containing values [ COUNT(), COUNTA(), COUNTIF(), 
COUNTBLANK() ] , identifying specific values within the list [ MAX(), MIN(), 
LARGE(), SMALL() ] or converting the values into some other format [ ROMAN(), 
TEXT() ] . The functions dealing with the totaling of numbers have already been covered 
in detail earlier. 
 

5.4 Text Functions 
Text functions aim at either case conversion [UPPER(), LOWER(), PROPER()] , 
extraction of part of the text [LEFT(), RIGHT(), MID() ], identification and replacement 
of particular alphabets within a text [ FIND(), SEARCH(), REPLACE(), 
SUBSTITUTE()] or conversion into some other values [ VALUE(), DOLLAR() ] 

5.5 Financial Functions 
 
Function Description 
PMT() Calculates the payment for a loan based on constant 

payments and a constant interest rate. 
PPMT() Returns the payment on the principal for a given period for 

an investment based on periodic, constant payments and a 
constant interest rate. 

IPMT() Returns the interest payment for a given period for an 
investment based on periodic, constant payments and a 
constant interest rate 

NPER() Returns the number of periods for an investment based on 
periodic, constant payments and a constant interest rate 

RATE() Returns the interest rate per period of an annuity. 
PV() Returns the present value of an investment. The present 

value is the total amount that a series of future payments is 
worth now. 

FV() Returns the future value of an investment based on 
periodic, constant payments and a constant interest rate 



NPV()  
CUMIPMT() Returns the cumulative interest paid on a loan during a 

particular period 
CUMPRINC() Returns the cumulative principal paid on a loan during a 

particular period 
FVSCHEDULE() Returns the future value of an initial principal after 

applying a series of compound interest rates. 
NOMINAL() Returns the nominal annual interest rate, given the effective 

rate and the number of compounding periods per year 
EFFECT() Returns the effective annual interest rate, given the nominal 

annual interest rate and the number of compounding 
periods per year 

ACCRINT() Returns the accrued interest for a security that pays 
periodic interest 

PRICE() Returns the price per $100 face value of a security that pays 
periodic interest. 

YIELD() Returns the yield on a security that pays periodic interest. 
Use YIELD to calculate bond yield. 

IRR() Returns the internal rate of return for a series of cash flows 
represented by the numbers in values. These cash flows do 
not have to be even, as they would be for an annuity. 
However, the cash flows must occur at regular intervals, 
such as monthly or annually. 

XIRR() Returns the internal rate of return for a schedule of cash 
flows that is not necessarily periodic. 

 

5.6 Some more functions 
In addition to the normal functions discussed above, there is a set of financial functions. 
The same is dealt in a later module. Some more relevant functions are discussed below: 
 

IF() 
 
An IF function is made up of three parts: the condition, the true part, and the false part.  
Select cell B6, type =IF(B2>10000,B2*D4,B2*E4) , and press Enter.  The condition is 
B2>10000; if true, the program will compute B2*D4, or if false the program will 
compute B2*E4. 
 
It is possible to replace one part of an IF statement with another IF statement; this is 
called a nested IF.  Select cell B6, edit the formula to read 
=IF(B2>10000,B2*D4,IF(B8>4,B2*D4,B2*E4)) , and press Enter.  This shows that if the 
value in B2 is not greater than 10000, then a second condition, B8>4, will be considered. 

It is also possible to combine conditions using logic functions like AND and OR.  
Replace the formula in cell B6 with =IF(AND(B2>10000,B8>4),B2*D4,B2*E4).  The 



function AND shows that both conditions, B2>10000 and B8>4, must be met.  Replacing 
the AND with OR would result in either condition being met, the same accomplishment 
as the nested IF. 

CHOOSE() 
The Choose function uses an index value to return a value from the list of values. It can 
accommodate upto 29 alternative values 

ISERROR() 
The ISERROR function returns a True if a particular cell contains an error and can be 
very useful in trapping errors and calculating further values based on the error position 

CELL() 
The CELL() function can be used to return useful information relating to a particular cell 
or file. 
 



6 The Look & Feel of Output 

6.1 Formatting 

6.1.1 Sheet 
It is possible to add a picture to the background of the entire sheet. This should however 
be done with caution. 
 

6.1.2 Cells (or Range) 
Various formatting features can be done on a single cell or a group of cells. To invoke the 
formatting features, choose the Format Cells Command (Ctrl+1 / Right Click / Format -> 
Cells). The following screen appears 

The various tabs are analysed in the subsequent paragraphs 
 

6.1.3 The Look of Data 
This appears in the Numbers Tab The default tab is the Numbers tab.  This is the one the 
user will work with to format the type of number displayed. The options available 
include: General, Number, Currency, Accounting, Date, Time, Percentage, Fraction,  
Scientific, Text, Special, and Custom. 
 



6.1.4 Alignment & Text Control 
The text can be left aligned, centred or right aligned. It can even be rotated within a cell. 
Often, a user wishes to have little more control over the text than is allowed within the 
standard cell borders.  Some available options are:  Merge Cells which allows more than 
one cell to be merged into one (accomplished by highlighting the ones the user wishes to 
merge), Shrink to Fit which will reduce the apparent size of characters within selected 
cells so that they will fit within the column and Wrap Text which wraps text into multiple 
lines in a cell. 
 

6.1.5 Fonts, Borders & Patterns 
In order for grid lines (or any other formatting) to be present, the user must apply the 
appropriate options. To apply borders right click on the active cell(s) then choose Format 
Cells from the menu that appears.  From the tabbed Formatting Window, left click on the                                
Borders tab to select it.  There are parameter locations for the borders to be applied                                         
top, bottom, left, right, etc.), as well as a list of line styles and a drop down menu of                                        
color choices.  The user can left click on the desired options.  Left click the OK button to                                
apply the selections and continue. 
 

6.1.6 Indented Text 
In case one intends to indent the text within a particular cell, one can use the indent icons 
on the standard toolbar. 
 

6.1.7 Hiding Information 
 
It is possible to hide entire sheets, rows or columns within a particular workbook. To hide 
a sheet, Choose Format -> Sheet -> Hide. To hide a particular row or column, select the 
row or column, right click and choose Hide. It is however not possible to hide the 
contents of individual cells. The work-around solution is to format the cell contents to 
display the same font color and cell background so that effectively the information gets 
hidden. 
 

6.2 Styles.. 
 
Styles represent standardized sets of formats. To initiate the styles, Choose the same from 
the Format Menu. The following screen appears 



 
One can choose from the existing styles or create a new one. The new style can be based 
on an existing style. Since styles are workbook specific, one may need to use the merge 
button to merge styles from existing workbooks. To create styles which are available 
across all workbooks, create the same in the Personal.xls workbook 
 

6.3 Conditional Formatting 
Conditional formatting permits the user to apply special formatting settings that take 
effect when the contents of the cell meet specified conditions. For instance, if there is a 
loss under a particular head, you intend to colour it red so that it immediately catches 
your attention. Similarly, you may like to colour your balance sheet totals to blue if they 
do not tally. One very practical tip is to combine the ISERROR function with the 
Conditional Formatting feature to hide errors. What is effectively done is that the font 
and the background is set to the same color if the cell contains an error. 
 
 
¾ Select the range of cells for which the formatting is desired 
 
¾ Choose Format -> Conditional Formatting 
 
¾ Allows different forms of formatting based on the cell contents 
 
¾ Maximum of 3 different conditions can be specified 
 
¾ To suppress errors, choose Formula is =ISERROR() and then choose same colour 

font as the background colour 
 
 

6.4 Custom Views.. 
The Custom View feature is available from the View Menu. It ensures that one need not 
set up the sheet each time one wants to print a particular sheet. The user first sets up the 



entire sheet in the way desired for storage (including column & row widths, hidden rows, 
autofilters, printer settings, etc.) He then initiates the Custom View Feature and allots a 
descriptive name to the View. Later on, even if the print settings, etc. are altered, the user 
can go back to the same view by selecting that specific view. 

6.5 Printing 
Before beginning the actual task of printing, it is necessary to orient the worksheet to the 
specifics of a printer. This is done through the page setup command. The page setup 
screen comes up which has four tabs: page (wherein paper size, orientation, compression 
mode, etc. are specified), margins (to specify the margins on top, bottom, right, left), 
header/footer (self explanatory) & sheet (which has some useful options – rows to repeat 
at top, gridlines, etc.). One can also consider the use of Report Manager add-in which 
permits multiple sheets or print areas to be synchronized as one print job (so as to 
facilitate continuous page numbering) Additionally a Report Manager can work on 
alternate views and scenarios within a single synchronised report. 
 

6.6 Saying it with Charts.. 
It is said that an ounce of image is worth a pound of performance. A chart is a graphic 
representation of worksheet data. Before understanding the creation of a chart, one needs 
to be clear of the basic elements of a chart which include the X & Y Axes, X & Y Axis 
Values, chart title, legend, data markers, tick marks, gridlines, data labels, etc. 
 
To invoke charts Choose Chart from Insert Menu. The Chart Wizard takes you through 
the rest of the process. 
 
Excel provides for a wide variety of chart types. In case one is interested in depicting the 
trend in a particular value, one should select a linear chart like Bar, Column, Line, etc. If 
one is keen on looking at the constitution of various elements into a total, consider 
Contribution charts like Stacked Charts, Pie, Doughnut, etc. Then there are specialized 
charts like HLC Chart for analyzing stock trends, radar charts, scatter diagrams, etc. 
 



7 Copying & Moving 
One of the most common utilities of any Windows program is the cut/paste and the 
copy/paste features. Needless to mention, the same are available in MS-EXCEL also. To 
summarise, select a range of cells (it can be a set of non contiguous cells also), press 
Ctrl+C to activate the Copy command from the keyboard after selecting the cells. Ctrl+X 
is the keyboard command to cut the cells. You paste the cells from the keyboard by 
pressing Ctrl+V. One can copy/move data across cells by using the mouse and the drag-
and-drop technique. Simply drag-drop would imply a move, whereas holding the Control 
key while dragging-dropping will imply a copy. 
 
While copying values across poses no problems, one has to be careful while copying 
formulae. When a formula containing a cell reference is entered into a cell, Excel keeps 
track of that formula in two ways: one is relative referencing whereby the relative 
position of the addressed cell and not the cell position itself is stored in the formula (this 
is the default and is quite handy most of the times). For example, if A3 contains the 
formula +A1+A2 and the same is copied to B3, the formula in B3 changes to +B1+B2. 
While this is mostly beneficial, in some cases, one may want to freeze the cell position 
referred and may not want the same to be changed in case of subsequent copying of data. 
For this purpose, one needs to use the absolute referencing. Here, the exact cell position 
of the addressed cell is stored in the formula. The absolute referencing is identified by the 
use of the $ sign in the cell address. Thus $A$7 implies that the cell address A7 is 
absolutely stored in the formula. One may also consider the use of mixed referencing 
whereby either the row or the column remains constant. To make only the column or row 
portion of a cell address absolute, press F4 key. Each time you press the F4 key, the $ 
moves to a different co-ordinate of the cell address. To summarise this issue, when you 
copy a formula, relative addressing will change the cells that are referenced by the 
formula. If you need any of the cells to remain constant, make sure that absolute 
referencing has been added to the original formula before you copy it. 
 
 
¾ By default, Excel uses relative referencing.  
 
¾ To make either the column or the row referencing (or both) absolute, the column or 

row number has to be preceded by a $ sign 
 
¾ The user can circle between the various options by using F4 Function key while in the 

edit mode of the formula 
 
 



7.1 Paste Special 

Instead of copying entire cells, it is possible to copy specified contents from the cells — 
for example, one can copy the resulting value of a formula without copying the formula 
itself. To copy only partially a cell, follow these steps: 

1. Select the cells you want to copy.  
2. Click Copy. 
3. Select the upper-left cell of the paste area.  
4. On the Edit menu, click Paste Special. 
5. Click an option under Paste, and then click OK.  

– Various options to paste! 
There are various options to paste special. The options are summarized in the screen-shot 
below: 

 



8 Saving Work & Protecting It 
Once the sheet is prepared for data entry purposes which includes data validations, 
lookups, conditional formatting, etc., one  may like to ensure that none of such 
validations/formulae are accidentally overwritten by the person entering the data. One 
may therefore look at worksheet protection. To protect a particular sheet, choose Tools -> 
Protection -> Sheet. One may provide a password if required. Similarly, to protect the 
entire workbook, one chooses Tools -> Protection – Workbook. Once a sheet/book is 
protected, no alterations are permitted in the sheet/workbook.  
 
Many a times, the need may be to protect the sheet but at the same time permit data entry 
in particular cells. To achieve such a dual purpose, one first unlocks the cells wherein the 
data entry is to be permitted (Choose Format -> Cells -> Protection) and then follows up 
the same with the sheet/workbook protection as outlined above. In such a scenario, entry 
is permitted only into unlocked cells. 
 
Worksheet protection still permits the viewing of the formulae. In many cases, the user 
may not want the other person to know the formula. In that case, the cell formula can be 
hidden (Choose Format -> Cells -> Protection). The contents of the cell are of course 
displayed. It should be noted that hiding a cell has no effect unless the worksheet is itself 
protected. 
 
Protecting cells helps prevent accidental corruption of a spreadsheet.  To protect cells: 

1. All cells in a spreadsheet are automatically “locked” when the spreadsheet is 
created.  But this is inconsequential unless the sheet is protected. 

2. Unlock only cells you may want to edit.  To unlock a cell, select the cell, click 
the right mouse button, select Format Cell (or choose Format/Cells), select the 
Protection tab in the box that appears, click on the locked box to remove the 
check that is there, this unlocks the cell. 

3. To protect the spreadsheet, select Tools/Protection/Protect Sheet.  In the 
dialog box that appears, click OK.  You may also apply a password but if you 
forget it you cannot unprotect the sheet! 

4. Once the sheet is protected, only unlocked cells can be edited. 
 

8.1 File-Level Protection 
One can password-protect the entire file. To do this, after creating the document, Choose 
“Save As” from the File Menu. Select the general options from the Tools Tab and the 
following screen appears: 
 



 
 
In the file sharing options, specify the passwords. You can specify two types of 
passwords, one authorising the user to open the file, another permitting him to modify the 
same.  In case you would just like to warn the user about the importance of the file 
without introducing the hassles of passwords, you can select the “read-only 
recommended” option. 



9 Analysing Data 

9.1 Data Tables 
One may also consider the use of MS-EXCEL to perform what is commonly known as a 
what-if analysis. What if analysis examines how sensitively a situation will react to 
changes in factors that influence the situation. Let us take the example of a person 
availing of a housing loan. The EMI payable would depend both on the interest rate and 
the period of repayment (assuming that the loan amount is ascertained). Let us calculate 
the EMI for a housing loan of Rs. 7.5 lakhs taken @ 11% per annum for a period of 15 
years. I enter each of these basic data in separate cells A1 = 750000, A2 = 11%, A3 = 15 
I enter the formula for calculation of EMI in Cell A4 as =PMT(A2/12,A3*12,-A1) {Note 
that the EMI calculations in Excel are denominated in months and also that reverse cash 
flows are indicated by negative numbers}. Now the person might be interested in 
knowing the effect on the EMI for each change of 0.25% in the interest rate. Such a 
sensitivity is known as what-if analysis. In Excel, what-if analysis is performed through 
the use of data tables. A data table is a range of cells that shows the results of substituting 
different values in one or more formulas. The Data Table command performs calculations 
using a series of different input values and hence is an efficient alternative to creating 
formulas in individual cells and editing or copying the formula when a value changes. To 
initiate the process, choose the Table Command from the Data Menu.  
 
A data-table can be either a one-variable table or a two variable table. In a one-variable 
data table, the alternative values are entered as row labels and the resulting formulae are 
specified as column labels. As such, it is possible to specify multiple formulae. Such a 
table is known as column oriented data table. In case of a two variable table, the resulting 
formula is entered at the intersection of the row and column labels (each of which 
contains alternative values). As such, in case of two variable data table, one can specify 
just one formula. 
 
 
¾ Useful for what-if analysis 
 
¾ Type the formulae in the columns & possible range of values in the rows 
 
¾ Select the range and Choose Data -> Table 
 
¾ Select the variable cell as the column input 
 
¾ For two variable data table, specify formula at the intersection of the row and column 
 
 



9.2 Scenarios 
The limitations of the data tables feature are but obvious! Time to introduce the Scenarios 
feature. This feature enables you to analyse your data to see how changing one or more 
values in a worksheet affects the other cells in the worksheet. Effectively using this 
feature is a two step process: one is to create a scenario and the other step is to view the 
results as a summary. The entire process is simple and self explanatory 
 
 
¾ What-if analysis on multiple criteria (pre-defined situations) 
 
¾ Choose Tools -> Scenario 
 
1. Define a Scenario by “ADD” 
 
2. Alter a Scenario by “DELETE” / “EDIT” 
 
3. Concept of Changing Cells & Resultant Cells 
 
¾ View Results 
 
¾ Scenario Summaries 
  
 

9.3 Goal Seek 
Goal Seek is another useful feature which can be used to achieve a certain value in a cell 
that contains a formula. The way this is done is to adjust the value of another cell that has 
a direct effect on the original cell. After all, the valuation of closing stock has a direct 
effect on the net profit!  
 
¾ Concept of working reverse way 
 
¾ Select Tools -> Goal Seek 
 
 

9.4 Solver 
Again, Goal Seek is an elementary function which may at times supply absurd results. 
For example, it may let stocks be over-drawn. For a more sophisticated approach, choose 
the Solver Add-in (cozily sitting on the Tools menu) which not only allows you to 
specify constraints (so that stocks don’t get overdrawn or sales don’t exceed the 
production capacity) but also permits multiple varying cells. The reports generated by the 
add-in can help solve simple problems in linear programming. 
 



¾ Select Tools -> Solver 
 
¾ Concept of Target Cells, Changing Cells & Constraints 
 
¾ Utility of Answer Reports & Sensitivity Reports 
 
¾ Saving the solution as a scenario 
 
 



10  PivotTables 
 
PivotTable is a very powerful analysis tool built into MS-EXCEL. It helps in analyzing &  
summarizing large collections of data. Such data can be derived from various sources. 
The most common choice is to however create a pivot table from an Excel list. For the 
purpose of understanding, the following Excel list consisting of time sheet records of a 
professional firm is analysed using PivotTables 
 

 

10.1 Creating a Pivot Table 
 
For creating a PivotTable, choose the PivotTable command from the Data menu. The 
PivotTable wizard appears and takes you through the process of creating a PivotTable 
 



 
 
 
Step1 Specify the Data Source:  Here we specify either an existing Excel list or an 
external source of data. We also specify whether we want to create a PivotTable or a 
PivotChart report. The default choices are generally Excel list and PivotTable. Choose 
Next to specify the data range. 
 

 
 
Step 2 Define the Data Range: Ensure that the correct range of cells has been included. 
Click the next button to specify the location of the PivotTable 
 

 
 
Step 3 Choose the location of the PivotTable. Select New worksheet and click Finish 
 



10.2 Layout of the PivotTable 
 
At this stage, it is necessary to understand certain terms relevant for the purposes of 
PivotTables. For effective analysis, PivotTable uses the concepts of row & column fields 
for summarizing and grouping data. The page field could be used to filter out the data on 
a particular item. The data field contains the summary information. To create the 
analysis, drag the desired item from the  PivotTable Field list and drop it in the relevant 
section of the main table. 

 
 

10.3 Some Examples: 
 
To obtain a report containing the gross amounts billed 
for a particular client, drag the client field as row field 
and “Bill Amount” field as the data field. The report is 
ready! 
 
On analyzing the report, I find that the firm earns 
maximum revenues from Fast Limited. 
 
Similarly, I could analyse the gross revenues earned by 
a particular employee (remove the client field by 
dragging it back to the pivottable field list and drag the 

“resource name” field list to the row field area) or also get a report of segment-wise 
revenue (drag the “work done” field to the row field area). 
 



It is also possible to drill down to 
the details of the above report by 
clicking on a particular client and 
choosing the field on which 
detail is required (say resource 
name) Further levels of data can 
be selected by clicking 
successive items. Similarly, it is 
also possible to expand or 
collapse the levels of data 
displayed either by double-
clicking or by choosing the 
relevant command from the 
PivotTable Toolbar. To view the 
complete details of a particular 
summarized amount, click on that amount to create a new sheet which displays only the 
records that were included in that summarized amount.  
 
 
 
Now suppose I want a cross dimensional analysis of data in terms of client-wise revenue 
as well as segment-wise revenue. I position the client as row field and “work done” as the 
column field. The data item of course continues to be gross amount. The resultant report 
looks as under: 

 
 
Now I divert my attention from the revenues generated to the time spent. I choose 
“resource name” as the row field, “work done” as the column field and “time hours” as 
the data field. I double click on the data field in the pivottable. A new screen pops up to 
provide various options for displaying the data  



 
 
The first list in the said screen (Summarize by) provides for alternative ways of 
summarizing information. While the default is the sum of the data item, it is also possible 
to choose either the average, maximum, minimum, number of occurrences, etc.  
 
The second list in the said screen (Show data as) allows different methods of displaying 
the summary data. I choose “% of row” and click OK to change the format of the chart. 
The resulting chart helps me analyse the work specialities of specific employees.  
 

 
 
Similarly, if I choose “% of column” Format for displaying data, I can analyse whether 
the organization is dependent on a particular employee for a particular segment of work. 
 

 
 
I could now replace the “work done” column field for the “client” column field and go 
ahead to analyse the client-employee affiliations if any.  
 



 
 
The possibilities are endless and the reports are displayed at the flash of a moment. The 
only requirement for an effective analysis therefore is the quality of the data list 
maintained. 
 



11 Auditing Tools 

11.1 Auditing Toolbar 
Auditing is a means of finding errors and tracing the logic of a complex spreadsheet. 
 

1. Select the cell you wish to audit. 
2. Select Tools/Auditing 

a. Trace Precedents shows what goes into the cells calculation 
b. Trace Dependents shows where the audited cell is used 
c. Trace Errors shows where an error statement arises 
d. Remove all arrows removes the arrows when you are finished. 
e. Show Auditing Toolbar is useful if you have a lot of auditing to do 

 
The auditing tools can help in detecting problems in worksheet formulae. Excel supplies 
an Auditing Toolbar which helps in finding errors on the worksheet. Using an auditing 
toolbar can also help one to understand the relationships amongst cell references, 
formulas and data. While the Auditing Toolbar is a great help, of complementary nature 
is the Goto Special Command. One activates the Goto Special Command by checking the 
Special Tab on the Goto Command appearing on the Edit Menu. The following screen 
appears: 

 
 

11.2 Documenting a Sheet  
Many a times, we wish to document a worksheet so that the same can be analysed for 
logical errors if any. Also, one may want to keep a permanent record for the subsequent 
user and hence documenting a sheet will help the cause of auditing as well. In this 
regards, there is a very powerful add-in available at www.spreadsheetinnovations.com 



The add-in is known as “Spreadsheet Professional”. The Add-In has to be downloaded 
from the web-site mentioned above. The program is available in two versions. A demo 
version is available which works with sheets upto 100 rows only. A full fledged version 
is available for purchase. The users may try out the demo version before deciding to 
purchase the product. Having downloaded the software, the add-in has to be loaded in 
MS-EXCEL. Just Click Tools Menu -> Add-ins-> Browse in MS-EXCEL. Choose the 
directory where the software is downloaded and the add-in by the name “SPRDprof” gets 
installed. On installation, the Spreadsheet Toolbar appears below the existing toolbars. 
there are various options available under the add-in. Under the Build option, there is an 
important option that enables the translation bar to appear at the bottom of the sheet. In 
this bar, one can view the translation of the formula in the active cell. Therefore, one can 
check his logic as he keeps typing in the formulae. Also, another option of spreadsheet 
painter attempts at dividing the cells into headings, input values, formulae, etc. and uses a 
separate color for filing the background for each category of cells.  
 
Similarly, there is a spreadsheet formula tracer which gives a graphical presentation of 
the formulae and permits click and expand facility to correlate the output cells with the 
input cells. One just needs to try this out to understand the formulae on the sheet. 
 
Similarly, one can test the formulae using the “Test” option from the Toolbar. If a 
workbook contains two or more worksheets which are more or less similar, the 
differences can be viewed from the option available in the Use Menu. All these results 
can be summarized in a workbook by choosing the documentation option. The resultant 
workbook contains the following worksheets: 
1. Summary Sheet which includes the details about the file and the number and 

name of the sheets within that file 
2. Range Names and external links includes all the named ranges with the references 

to the cell addresses of the ranges to which they refer. Also, a list of external links 
to other workbooks 

3. A map for each worksheet which includes a reference to whether the cell contains 
a text (L), numeric value (N), formula or function (F) or a lookup (^) 

4. A formula translation sheet for each worksheet which attempts to translate the 
formula step-wise into text entries associated with the formulae. 

5. A blank input form for each worksheet containing a summary of all the cells 
wherein some value has been entered 

6. A completed form for each worksheet which contains the summary of all the cells 
including their current values 

7. A list of potential errors within each worksheet. The potential errors are grouped 
into different categories like Unused Input Value (meaning the value has not been 
referenced elsewhere even though it should have been), Unused Calculation (the 
result of a formula has not been referenced elsewhere even though it should have 
been), references to blank cells (!), forward column references (denotes poor 
worksheet building), unprotected calculations(someone else may over-write the 
formula built with a lot of care), etc.  

 



The use of this tool makes us aware of the basic spreadsheet building skills and potential 
error situations which could be taken care of. Also, one can consider detailed auditing of 
the formulae through this tool. 

11.3 Migrating Data from Other Software 
Many a times, we are constrained by the reports generated by the accounting software 
and would love to have detailed analysis of the data. In such a case, we may consider 
applying some of the above features to the accounting data so that we could perform our 
audit in a more meaningful fashion. One can look at this proposition from two 
perspectives. If the accounting software is ODBC compliant (it means that the accounting 
software permits its database for reading by other software), one can set up an EXCEL 
sheet which is linked with the Accounting Software and can generate real time reports. 
How to do this? Invoke the query by selecting Data -> Get External Data -> New 
Database Query. The Query Wizard takes you through the rest of the steps. The 
advantage of linking data in this fashion is that you can refresh the data at the click of a 
mouse (you may even automate this!) 
 
Of course, many accounting software may not be ODBC compliant. In that scenario, one 
may need to explore the options available in the package for exporting data. Most recent 
packages permit an export into MS-EXCEL. In that case, the dinner is ready for you! But 
if the package does not permit an Excel export but permits a text export (which all 
packages provide for), then one may need to import that text file into MS-EXCEL by 
selecting the Import Text File Option. 

11.4 Common Audit Techniques 
Having imported the accounting data in MS-EXCEL, it is upto the imagination of the 
auditor to use his creativity in quickly analyzing records through the features provided in 
MS-EXCEL. For example, to search duplicate records and identify gaps, one can adopt 
the following procedure 
1. Convert the tested field (say invoice number) to numeric 
2. Sort the records based on the tested field 
3. Find the difference between the first and the second record in the tested field in an 

adjoining column (which should ideally be 1) 
4. Copy down the formula throughout the record range 
5. AutoFilter the records for finding values which do not evaluate to 1 (0 will imply 

a duplicate record, a value more than 1 will imply a gap) 
 
Similarly, in case of a single product entry, one can consider the extent to which discount 
is permitted by using the Data Analysis Toolpak to find the correlation between quantity 
and the billed amounts. 
 
One can also draw random samples from the population by using the Sampling Tool. 
Also consider the need for stratification of data through AutoFilter  
 



12 Automating MS-EXCEL 

12.1 Open EXCEL each time computer starts 
Most of the finance executives heavily use MS-EXCEL. If the computer has limited 
hardware resources and a lot of add-ins, MS-EXCEL may take time to load itself. In such 
cases, one may venture into loading MS-EXCEL every time Windows is started. One 
achieves this by placing a shortcut to MS-EXCEL program in the Startup Folder of the 
Program Menu. (In fact, one can load any program by placing it in the Startup Folder) 
 

12.2 Open a particular file each time EXCEL starts 
There may also be a need to load a particular EXCEL file (or may be files) every time 
MS-EXCEL is started. This can be done by placing a shortcut of that file in the XLStart 
Folder. 
 

12.3 Create a new file based on a template each time computer 
starts 

One may also consider the use of workbook template in case each file is expected to 
follow some common pattern. The file should be saved as a template (xlt). To use the 
template as the default for all new workbooks, save the template in the XLStart Folder. 
 
To create a default sheet template, create a single sheet file as a template and save the 
same in the XLStart Folder (The file should be named as Sheet.xlt) 
 
Any macro by the name Auto_Open() runs automatically (subject to the security settings) 
each time the workbook is loaded.  Similarly, a macro by the name Auto_Close() runs 
automatically each time the workbook is closed.    
 

12.4 Specifying the Defaults in EXCEL 
 
One can configure the appearance of the menu and the toolbars by choosing Tools – 
Customise and dragging and dropping the relevant icons/commands. One can also set up 
certain defaults including the default folder for saving files, default font, etc. by choosing 
Tools-> Options. One useful option is to set Precision to displayed (Accordingly, the 
printout will not contain apparent errors (For example, if the format is set to display 0 
decimals and two cells contain values 3.4 and 2.4 and the third cell contains the total of 
these two formulae, normally it would be displayed as 3, 2 & 6 (as total is 5.8). Now this 
does not appear correct on reading. If Precision is set to “as displayed” one sees 3, 2 & 5. 



12.5 Customizing Menus & Toolbars.. 
Excel offers several toolbars to save you time in choosing commands. The Standard and 
the Formatting Toolbar appear at the top of the screen. Certain other toolbars also appear 
depending on the command that is being executed. 
 
To show or hide a toolbar, choose View, Toolbars. On the Toolbar Menu, a check mark 
appears next to the toolbar that is displayed. To show or hide a toolbar, click a toolbar 
name in the menu. Excel displays or hides the toolbar in the Excel window. 
 
Once a toolbar is displayed, one can position it in a place most convenient. Toolbars can 
be placed at any place of the display screen by the simple drag-and-drop technique. 
 
It is also possible to dock a particular toolbar at any of the extreme positions of the 
screen. However, if the toolbar contains a drop-down list, it is not advisable to dock it to 
the left or right extremes. 
 

12.5.1 Adding new toolbar 
One can create a custom toolbar that  provides all the options needed to perform tasks in 
Excel with ease. To create a custom toolbar, follow the steps outlined below: 

1. Choose View, Toolbars, Customise 
2. Click the Toolbars Tab 
3. Click the New Button 
4. In the Toolbar Name Box, give a descriptive name to the toolbar 
5. Click OK 
6. Click the Commands Tab 
7. From the commands that appear, drag the required commands to the customized 

toolbar 
8. When done, click the Close button to close the Customise Window. 

12.5.2 Adding new menu 
One can even create a custom menu item that  provides all the options needed to perform 
tasks in Excel with equal ease. To create a custom menu, follow the steps outlined below: 

1. Choose View, Toolbars, Customise 
2. Click the Command Tab 
3. Click the New Menu Option and drag and drop to the main menu bar. 
4. Right Click the dropped menu and give a descriptive name to the menu 
5. Click OK 
6. Click the Commands Tab 
7. From the commands that appear, drag the required commands to the customized 

menu 
8. When done, click the Close button to close the Customise Window. 



12.6 Customization Options 
In the customized menu options, there are a few important commands. The most 
important is the command which disables the recently used commands. Also one may 
consider disabling the preview of the fonts in the font list. 
 

12.7 Templates 
A template is a workbook that you create and then use it as the basis for other similar 
workbooks. For e.g.- Format of a Schedule VI Balance sheet. You can create a complete 
format of a Schedule VI Balance Sheet (without typing out the Company Name and 
amounts, of course!) and save it as a template. To save it as a template, Click <File> Æ 
<Save As..>. In the [Save As] dialogue box that appears, select (Template *.xlt) in the 
<Save as type> drop down down box (See Picture). 

 
By default, the template is saved in the folder C:\windows\Application 
Data\Microsoft\Templates. If you wish to see a preview of the first page of your template 
in the preview box when you click <File> Æ <New>, click <File> Æ <Properties> and 
in the <Summary> tab check out the <Save preview picture> checkbox.  The next time 
you wish to prepare a Balance Sheet in Schedule VI format just click on <File> Æ 
<New> and select this template. A fresh blank format of schedule VI Balance sheet is 
ready in front of you. Just go ahead and fill the Company name, amounts, etc. and you 
are ready for a print out. This feature can be used to prepare bills, vouchers, forms, etc. 
 
Default File Template 
 
Every time you start MS Excel, a blank workbook opens by itself. This workbook can be 
customised in terms of formatting, repeated text, data, graphics and formulas and custom 
buttons and toolbar settings. The formatting customisation includes 1. Cell and sheet 
formats you set by using the commands on the Format menu. 2. Page formats and print 
area settings for each sheet. 3. Cell styles. 4. The number and type of sheets in a 
workbook. 5. Protected and hidden areas of the workbook; for example, you can hide 
sheets, rows, and columns and prevent changes to worksheet cells. To customise the 
default workbook, format a new workbook the way you want in terms of the above 
mentioned parameters and save it as a template by the name book.xlt in the folder 
C:\Application Data\Microsoft\Excel\XLStart. Now what will happen is that every time 



you start Excel, Excel will look for the workbook template book.xlt in the folder XLStart 
and will open a fresh workbook based on this template. Thus all new workbooks that you 
create will be formatted based on the settings that you have specified in the template 
book.xlt. 
 
Sheet Template 
 
Whenever you insert a new worksheet in any workbook, you may require it to have some 
customised formatting and other settings. To do this, open a fresh workbook. Keep only 
one worksheet in it by deleting all other worksheets. Format this worksheet the way you 
wish all new worksheet be formatted. Now save this workbook as a template by the name 
sheet.xlt in the folder C:\Application Data\Microsoft\Excel\XLStart. Now, all new 
worksheets that you insert in any of the workbooks will be formatted based on the 
settings that you have specified in the template sheet.xlt. 

12.8 Workspaces.. 

One can open a group of workbooks in a single step by creating a workspace file. A 
workspace file saves information about all open workbooks, such as their locations, 
window sizes, and screen positions. When you open a workspace file by using the Open 
command (File menu), Microsoft Excel opens each workbook saved in the workspace. 
The workspace file does not contain the workbooks themselves, and you must continue to 
save changes you make to the individual workbooks.  

1. Open the workbooks you want to open as a group. 
2. Size and position the workbook windows as you want them to appear the next 

time you use the workbooks. 
3. On the File menu, click Save Workspace. 
4. In the File name box, enter a name for the workspace file.  

12.9  Talking with Other Software 
In case a hyperlink is inserted into a specific file, the contents of the file are not copied 
but only the reference thereto is copied. In such a situation, there are no concerns of static 
data. However, both the files have to be transported as a package.  

OLE (Object linking and embedding) makes another file a part of the first file and hence 
there may not be a need to transport the original file along with the other file. Linked 
objects are updated whereas embedded objects are static. 



13 Introduction to Macros 
If you perform a task repeatedly in Microsoft Excel, you can automate the task with a 
macro. A macro is a series of commands and functions that are stored in a Visual Basic 
module and can be run whenever you need to perform the task. When you record a 
macro, Excel stores information about each step you take as you perform a series of 
commands. You then run the macro to repeat, or "play back," the commands. 
 
Macros are very useful but potentially dangerous as they can contain viruses. Viruses are 
programs that are written by individuals, usually with the intent to destroy or corrupt 
data. When you open an affected workbook or perform an action that triggers a macro 
virus, the virus can become active, be transmitted to your computer, and be stored in 
Personal.xls, a hidden workbook, or some other undetectable location. From that point 
on, every workbook you save can be "infected" automatically with the virus. If other 
people open infected workbooks, the virus can be transmitted to their computers as well. 
 

Microsoft Excel offers three levels of security to reduce macro virus infections. The three 
security levels are:  

• High   You can run only macros that have been digitally signed and that you 
confirm are from a trusted source. Before trusting a source, confirm that the 
source is responsible and uses a virus scanner before signing macros. Unsigned 
macros are automatically disabled and the workbook opens automatically. 

• Medium   Excel displays a warning whenever it encounters a macro from a source 
that is not on your list of trusted sources. You can choose whether to enable or 
disable the macros when you open the workbook. If the workbook might contain a 
virus, you should choose to disable macros. 

• Low   If you are sure that all of the workbooks and add-in programs that you open 
are safe, you can select this security level, which turns off macro virus protection. 
At this level, macros are always enabled when you open workbooks.  

If you set the security level to Medium or High, you can maintain a list of trusted macro 
sources. When you open a workbook or load an add-in that contains macros developed by 
any of these sources, the macros are automatically enabled. 
 
One can customise the security level through the following steps 

1. On the Tools menu, point to Macro, and then click Security. 
2. Click the Security Level tab.  
3. Click Low.  

13.1 Global Macros vs. Individual Macros 
If you want a macro to be available whenever you use Excel, store the macro in the 
Personal Macro Workbook in the Excel Startup folder. In such a case, the macro is 



available for use across all workbooks. If the macro is desired to be used in an individual 
workbook, save the macro in that workbook. 
 

13.2 Use of Macro Recorder 
One can use the Macro Recorder to create macros by intuition. The Macro Recorder 
records the Visual Basic command equivalents as the commands are being executed in 
the fore-front. To record a macro using a recorder, follow the following steps: 
1. On the Tools menu, point to Macro, and then click Record New Macro. 
2. In the Macro name box, enter a name for the macro. 
3. To run the macro by pressing a keyboard shortcut key, enter a letter in the Shortcut 

key box 
4. In the Store macro in box, click the location where you want to store the macro. 
5. Click OK. 
6. If you select cells while running a macro, the macro will select the same cells 

regardless of which cell is first selected because it records absolute cell references. If 
you want a macro to select cells considering the position of the active cell when you 
run the macro, set the macro recorder to record relative cell references. 

7. Carry out the actions you want to record. 
8. On the Stop Recording toolbar, click Stop Recording  
 

13.3 Running Macros 
After you record a macro, you will usually run it in Microsoft Excel. To interrupt the 
macro before it completes the actions you recorded, press ESC. There are numerous ways 
in which a macro can be run. 
 
From VB Environment 
 
1. On the Tools menu, point to Macro, and then click Macros 
2. In the Macro name box, enter the name of the macro you want to run. 
3. Click Run 
 
Through a Shortcut key 
1. On the Tools menu, point to Macro, and then click Macros. 
2. In the Macro name box, enter the name of the macro you want to assign to a keyboard 

shortcut 
3. Click Options. 
4. Enter a letter in the Shortcut key box 
5. Click OK. 
6. To run the macro, press Ctrl and the Shortcut Key 
 
From the Toolbar 
1. On the Tools menu, click Customize. 



 
 
2. Click the Commands tab, and then click Macros in the Categories list. In the 

Commands list, drag the Custom button onto a toolbar. A button has now been added 
to the toolbar. 

 
 
3. Right-click the toolbar button, and then click Assign Macro on the shortcut menu. 
 

 
 
4. In the Macro name box, enter the name of the macro. Now you have assigned a macro 

to the Custom button.  Run the macro by clicking on the Custom button. 
 



5. If required, customize the button image. The name and image of the button can be 
customized by right clicking on your mouse and selecting the “edit” button option.   

 

13.4 Basics of VB Programming 

13.4.1 Objects  
An object represents an element of an application, such as a worksheet, a cell, a chart, a 
form, or a report. In Visual Basic code, you must identify an object before you can apply 
one of the object’s methods or change the value of one of its properties. Objects are 
collection of data or cells, etc on which some operation can be performed. There are 
various object collections available in MS-EXCEL. Some of them are listed below for 
quick reference: 
¾ Workbooks 
¾ Worksheets 
¾ Range 
¾ Column 
¾ Row 
¾ Selection 
¾ Windows 
¾ Charts 
 

13.4.2 Methods  
Methods refer to action that has to be taken on the object by the computer. Some 
common methods are listed below 
¾ Activate 
¾ Select 
¾ Add 
¾ Clear 
¾ Close 
¾ Copy 
¾ Cut 
¾ Insert 
¾ Move 
¾ Open 
¾ Printout 
¾ Quit 
¾ Save 
¾ Select 

13.4.3 Properties  

A property is an attribute of an object that defines one of the object's characteristics, such 
as size, color, or screen location, or an aspect of its behavior, such as whether it is 



enabled or visible. To change the characteristics of an object, you change the values of its 
properties. 

To set the value of a property, follow the reference to an object with a period, the 
property name, an equal sign (=), and the new property value. 

13.4.4 Some Examples 

 

13.4.5 Understanding VB Statements 
Sub .. End Sub Denotes the start and end of a macro 
With .. End With If a set of commands are to be performed on a single 

object, choose the With.. EndWith combination 
If…Then…Else…End If Executes commands in a macro based on certain 

conditions 
Select Case ... Case… End Select More useful in case of a menu selection 
Do While … Loop Performs a set of commands until a certain condition 

is met 
For … Next Performs a set of commands for a particular number 

of items 
For Each… Next Performs a set of commands on each object in a 

collection  
 

13.4.6 Interactive VB Statements 
InputBox() Asks for some information from the user 
MsgBox() Returns some information to the user 
 

ANNEXURES 
 

Copies the contents of Cell A5 to 
Cell A9

Range("A5").Copy 
Destination:=Range("A9")

Sets the height of the 14th row to 20 
units

Rows("14:14").RowHeight = 
20

Selects columns D & EColumns(“D:E”).Select
Prints the specified range of cellsRange(“A1:H8”).PrintOut
Deletes Sheet3Worksheets(“Sheet3”).Delete
Closes all the open workbooksWorkbooks.Close

Copies the contents of Cell A5 to 
Cell A9

Range("A5").Copy 
Destination:=Range("A9")

Sets the height of the 14th row to 20 
units

Rows("14:14").RowHeight = 
20

Selects columns D & EColumns(“D:E”).Select
Prints the specified range of cellsRange(“A1:H8”).PrintOut
Deletes Sheet3Worksheets(“Sheet3”).Delete
Closes all the open workbooksWorkbooks.Close



1 ANNEXURE A: KEYBOARD SHORTCUTS 
Key Alone Shift Ctrl Alt 
F1 Help What's This Help   Insert Chart Sheet 
F2 Edit Mode Edit Comment   Save As 
F3 Paste Name Formula Paste Function Define Name   
F4 Repeat Action Find Again Close Window Exit 
F5 Goto Find Restore Window Size  
F6 Next Pane Prev Pane Next Workbook  
F7 Spell Check   Move Window   
F8 Extend Selection Add To Selection Resize Window Macro List 
F9 Calculate All Calculate Worksheet Minimize Workbook   

F10 Activate Menu Context Menu Restore Workbook  
F11 New Chart New Worksheet New Macro Sheet VB Editor 
F12 Save As Save Open  
A     Select All    
B     Bold   
C     Copy   
D   Fill Down Data Menu 
E    Edit Menu 
F   Find File Menu 
G     Goto   
H     Replace Help Menu 
I     Italics Insert Menu 
J     
K   Insert  Hyperlink  
L     
M         
N     New Workbook   
O     Open Workbook Format Menu 
P   Print  
Q     
R   Fill Right  
S     Save   
T       Tools Menu 
U     Underline   
V   Paste  
W   Close Workbook Window Menu 
X   Cut  
Y     Repeat Active   
Z     Undo   

` (~)     Toggle Formula View   
1 (!)   Cell Format  

2 (@)     
3 (#)     
4 ($)         
5 (%)     Strkethru   



Key Alone Shift Ctrl Alt 
6 (^)         
7 (&)     
8 (*)   Outline  
9 (()   Hide Rows  
0 ())     Hide Columns   

-     Delete Selection   
= (+) Formula     Auto Sum 

[   Direct Dependents  
]   All Dependents  

; (semicolon)   Insert Date  
' (apostrophe)       Style 

: (colon)     Insert Time   
/     Select Array   
\   Select Differences  

Insert Insert Mode    
Delete Clear  Delete To End Of Line  
Home Begin Row   Start Of Worksheet   
End End Row   End Of Worksheet   

Page Up Page Up   Previous Worksheet Left 1 screen 
Page Down Page Down  Next Worksheet Right 1 screen 
Left Arrow Move Left Select Left   

Right Arrow Move Right Select Right   
Up Arrow Move Up Select Up     

Down Arrow Move Down Select Down     
Space Bar Space Select Row Select Column Control Box 

Tab Move Right Move Left Next Window Next Application 
BackSpace     Goto Active Cell   

Enter Next Cell Previous Cell Fill Entire Selection Next Line in Same Cell 
 



2 ANNEXURE “B” IMPORTANT EXCEL FUNCTIONS 
 
Name Description 
ABS Returns the absolute value of a number 
ACCRINT Returns the accrued interest for a security that pays periodic 

interest 
ACCRINTM Returns the accrued interest for a security that pays interest at 

maturity 
ADDRESS Creates a cell address as text based on given row and column 

numbers 
AVERAGE Returns the average (arithmetic mean) 
CEILING Rounds a number (away from zero) to the nearest integer or to the 

nearest multiple of significance 
CELL Returns information about the formatting , location or contents of 

the cell or upper left cell of the reference 
CHOOSE Uses a specified index number to select one from up to 29 

specified values 
CLEAN Removes all nonprintable characters from text 
COMBIN Returns the number of combinations for a given number of objects 
CONCATENATE Joins several text items into one text item 
COUNT Counts the number of cells that contain numbers and also numbers 

within the list of arguments 
COUNTBLANK Counts the number of non-empty cells and the values within the 

list of arguments 
COUNTIF Counts the number of cells that meet the criteria specified in the 

argument 
CUMIPMT Returns the cumulative interest paid between two periods 
CUMPRINC Returns the cumulative principal paid on a loan between two 

periods 
DATE Returns the sequential Excel date / time serial number that 

represents a particular date 
DATEDIF Calculates differences between two dates in terms of specified 

units and assumptions 
DAY Converts an Excel date / time serial number to the day of a month 
EDATE Returns the Excel date / time serial number of the date that is the 

indicated number of months before or after the specified number 
of months from the start date 

EFFECT Returns the effective annual interest rate of a given nominal rate 
with its compounding frequency 

EOMONTH Returns the Excel date / time serial number of the last day of the 
month before or after a specified number of months from start date 

EVEN Rounds a number away from zero to the nearest even integer 
EXACT Checks to see whether two text values are identical 
FIND Finds one text value within another (case sensitive) 



Name Description 
FIXED Formats a number as text with a fixed number of decimals 
FLOOR Rounds a number down towards 0 to the nearest integer or to the 

nearest multiple of significance 
FV Returns the future value of an investment 
FVSCHEDULE Returns the future value of an initial principal after applying a 

series of compound interest rates 
GCD Returns the greatest common divisor  
GETPIVOTDATA Returns data stored in a pivot table 
HLOOKUP Looks in the top row of a table or array and returns the value of the 

indicated cell 
IF Returns one value if the specified condition evaluates to TRUE 

and another value if it evaluates to FALSE 
INDEX Returns a value from a table of values based on references to rows 

and columns. 
INDIRECT Returns a reference indicated by a value provided as text 
INT Rounds a number away from 0 to the nearest integer 
IPMT Returns the amount of the interest element in a payment for an 

investment for a given period 
IRR Returns the internal rate of return for a series of cash flows 
LCM Returns the least common multiple  
LEFT Returns the left most characters from a text value 
LEN Returns the number of characters in a text string 
LOOKUP Looks up values in a one row or column range and returns a value 

in a second one row or column range.  
LOWER Converts text to lowercase 
MAX Returns the maximum value in a list of arguments ignoring logical 

values and text 
MID Returns a specific number of characters from a string starting at a 

specified position 
MIN Returns the minimum value in a list of arguments ignoring logical 

values and text 
MINUTE Converts an Excel date / time serial number to a minute 
MOD Returns the remainder from division with the result having the 

same sign as the divisor 
MONTH Converts an Excel date / time serial number to a month number 
MROUND Returns a number rounded to the desired multiple. Midway points 

are rounded away from 0 
NOMINAL Returns the nominal rate equivalent to a given annual effective 

with a given compounding frequency for the nominal rate 
NOW Returns the Excel date / time serial number of the current date and 

time 
NPER Returns the number of periods for an investment 
NPV Returns the net present value of an investment based upon a series 

of periodic cash flows and a discount rate where the first cash flow 



Name Description 
is received at the end of the first period 

PERMUT Returns the number of permutations for a given number of objects 
that can be selected from a number of objects without replacement 

PMT Returns the periodic payment for an annuity 
PPMT Returns the amount of principal element in a payment for an 

investment for a given period 
PRODUCT Multiplies together 1 - 30 numbers 
PROPER Capitalizes the first letter in each word of a text value 
PV Returns the present value of an investment 
QUOTIENT Returns the integer portion of a division 
RAND Returns an evenly distributed random number greater than or equal 

to 0 and less than 1 
RANDBETWEEN Returns a random number between (and inclusive of) two specified 

numbers 
RATE Returns the interest rate per period of an annuity 
REPLACE Replaces characters within text 
REPT Repeats text a given number of times 
RIGHT Returns the rightmost characters from a text value 
ROMAN Converts an arabic number to Roman, as text 
ROUND Rounds a number to a specified number of digits to the left (-) or 

right (+) of the decimal point. The midway digit 5 is rounded away 
from 0. 

ROUNDDOWN Rounds a number down towards 0 to a specified number of digits 
to the left (-) or right (+) of the decimal point 

ROUNDUP Round a number up away from 0 to a specified number of digits to 
the left (-) or right (+) of the decimal point 

SEARCH Finds one text value within another (not case sensitive) and returns 
the number of the starting position 

SQRT Returns a positive square root 
SUBSTITUTE Substitutes new text for old text in a text string 
SUBTOTAL Returns the sutotal in a list or database 
SUM Adds its arguments 
SUMIF Add the cells specified by a given criteria 
TODAY Returns the Excel date / time serial number of today's date 
TRANSPOSE Returns the transpose of an array 
TRIM Removes all spaces from text except single spaces between words 
UPPER Converts text to uppercase 
VLOOKUP Locates a specified value in the leftmost column of a specified 

table, and returns the value in the same row from a specified 
column in the table 

WEEKDAY Converts an Excel date / time serial number to the number of the 
day of the week based upon counting system of return_type 

YEAR Converts an Excel date / time serial number to a year 
YEARFRAC Returns the difference between start_date and end_date expressed 



Name Description 
as a number of years including decimal fraction of a year. 

 



3 ANNEXURE “C”: COMMON ERROR CODES 
 
Error Type Possible Causes Recommended Solutions 

Column is not wide enough 
to display the content (text 
entries however overflow or 
get truncated without 
displaying this error 
message) 

1) Increase the width 
of the column 

2) Shrink the contents 
to fit the column 

3) Apply a different 
number format 

####### 

Dates and times are 
negative numbers 

Check the formulae. 

#NULL Use of incorrect range 
operator 

1) Use colon (:) to refer 
to a contiguous range of 
cells 

2) Use comma (,) to 
refer to two ranges of 
cells which do not 
intersect 

Missing Data Replace with data 
Inappropriate Value in the 
lookup function 

Use a single cell as the 
lookup value and not a 
range of cells  

Lookup an unsorted table Sort the table first 
Omitting a required 
argument from a function 

Check the function syntax 
and supply all the necessary 
arguments 

#N/A 

Using a customised 
function which is not 
available 

Make sure the workbook 
containing the customised 
function is open 

Using a range name which 
does not exist 

Define the range name or 
check the spelling 

Using labels in formula Turn on the feature (Tools, 
Options, Calculation Tab) 

Mis-spelling the name of a 
function 

Correct the spelling 

Entering text in formula 
without double quotation 
marks 

Surround the text with 
double quotation marks 

Omitting a colon in a range 
reference 

Select the range by pointing 

#NAME? 

Reference to another sheet 
not enclosed in single 
quotation marks 

Select the range by pointing 



Error Type Possible Causes Recommended Solutions 
Using non-numeric 
argument for a function 
which requires numeric 
arguments 

Check the function syntax 
and supply all the necessary 
arguments 

#NUM! 

Function cannot derive a 
value (IRR or RATE 
functions) 

Check the values provided 
for logical mistakes.  

#REF! Cell reference is not valid If cell was deleted, correct 
the formula or restore the 
deleted cell 
 

#VALUE! Range is supplied where a 
single value is required 

Check the arguments 

#DIV/0! A cell reference which 
contains either a zero or a 
blank value is used as a 
divisor  

1) Enter a value other 
than zero as the divisor 

2) Prevent the error by 
using the IF function 
with the formula 

3) Enter #N/A as the 
divisor cell reference to 
display #N/A in 
preference to #DIV/0! 

 



4 ANNEXURE “D” LIST OF ADD-INS PROVIDED WITH 
MS-EXCEL 

 
Add In Utility 
Access Links Provides Microsoft Access forms and reports for use with Excel 

data lists 
Analysis 
ToolPak 

Gives several worksheet functions and macro functions for 
financial and scientific data analysis for use in a workbook 

AutoSave  Automatically saves your workbook at specified intervals 
Conditional 
Sum 

Assists you in summing data in lists 

HTML Helps in HTML functions 
Internet 
Assistant 
VBA 

Allows developers to publish Excel data to the Web by using 
Excel 97 Internet Assistant Syntax 

Lookup 
Wizard 

Allows creation of formulas to find data in Excel tables 

MS Query Converts external data ranges in Microsoft Excel 97/2000 format 
to Excel 95 format. Also allows the use of macros created in VBA 
in previous versions of Excel 

ODBC Add in Provides drivers for working with SQL based data sources 
Report 
Manager 

Lets you format information in worksheets, workbooks and 
scenarios into organized, uniform reports by combining 
spreadsheet views with data scenarios 

Solver  Lets you determine the answers to complex what if questions or 
equations by analyzing cells and determining the optimum value 
adjustments required to arrive at the desired result 

Template 
Utilities 

Provides utilities that are automatically used by the Excel’s built 
in templates 

Update Add 
In Links 

Updates the links to Excel add in functions to access the built in 
functionality in higher versions 

 
 


