This Course Covers:

- Spreadsheet fundamentals: How to open, create, and work with a spreadsheet
- How to enhance spreadsheets using formatting techniques
- How to create and work with charts
- How to create formulas to perform a variety of calculations
- How to manage workbooks and advanced printing options
- How to analyze data using Excel’s list features
Table of Contents

Introduction ................................................................................................................... 7

Chapter One: The Fundamentals.............................................................................. 11
Lesson 1-1: Starting Excel............................................................................................ 12
Lesson 1-3: Understanding the Excel Program Screen ........................................... 16
Lesson 1-4: Using Menus ......................................................................................... 18
Lesson 1-5: Using Toolbars and Creating a New Workbook ............................... 20
Lesson 1-6: Filling Out Dialog Boxes ....................................................................... 22
Lesson 1-7: Keystroke and Right Mouse Button Shortcuts .................................... 24
Lesson 1-8: Opening a Workbook ......................................................................... 26
Lesson 1-9: Saving a Workbook ............................................................................. 28
Lesson 1-10: Moving the Cell Pointer ...................................................................... 30
Lesson 1-11: Navigating a Worksheet .................................................................... 32
Lesson 1-12: Entering Labels in a Worksheet ......................................................... 34
Lesson 1-14: Calculating Value Totals with AutoSum ........................................... 38
Lesson 1-15: Entering Formulas ............................................................................ 40
Lesson 1-16: Using AutoFill ................................................................................... 42
Lesson 1-17: Previewing and Printing a Worksheet ............................................... 44
Lesson 1-18: Getting Help from the Office Assistant ............................................. 46
Lesson 1-19: Changing the Office Assistant and Using the “What’s This” Button 48
Lesson 1-20: Closing a Workbook and Exiting Excel ........................................ 50
Chapter One Review ............................................................................................... 52

Chapter Two: Editing a Workbook.......................................................................... 59
Lesson 2-1: Entering Date Values and using AutoComplete .................................. 60
Lesson 2-2: Editing, Clearing, and Replacing Cell Contents .................................. 62
Lesson 2-3: Cutting, Copying, and Pasting Cells .................................................... 64
Lesson 2-4: Moving and Copying Cells with Drag and Drop .............................. 66
Lesson 2-5: Collecting and Pasting Multiple Items ............................................... 68
Lesson 2-6: Working with Absolute and Relative Cell References .................... 70
Lesson 2-7: Using the Paste Special Command ..................................................... 72
Lesson 2-8: Inserting and Deleting Cells, Rows, and Columns ............................ 74
Lesson 2-9: Using Undo, Redo, and Repeat ......................................................... 76
Lesson 2-10: Checking Your Spelling .................................................................... 78
Lesson 2-11: Finding and Replacing Information .................................................. 80
Lesson 2-12: Advanced Printing Options .............................................................. 82
Lesson 2-13: File Management ............................................................................. 84
Lesson 2-14: Inserting Cell Comments .................................................................. 86
Lesson 2-15: Understanding Smart Tags ............................................................... 88
Lesson 2-16: Recovering Your Workbooks .................................................................90
Chapter Two Review ....................................................................................................92

Chapter Three: Formatting a Worksheet .....................................................................99
Lesson 3-1: Formatting Fonts with the Formatting Toolbar ........................................100
Lesson 3-2: Formatting Values ....................................................................................102
Lesson 3-3: Adjusting Row Height and Column Width .................................................104
Lesson 3-4: Changing Cell Alignment .........................................................................106
Lesson 3-5: Adding Borders .......................................................................................108
Lesson 3-6: Applying Colors and Patterns ..................................................................110
Lesson 3-7: Using the Format Painter .........................................................................112
Lesson 3-8: Using AutoFormat ...................................................................................114
Lesson 3-9: Creating a Custom Number Format .........................................................116
Lesson 3-10: Creating, Applying, and Modifying a Style ............................................118
Lesson 3-11: Formatting Cells with Conditional Formatting .........................................120
Lesson 3-12: Merging Cells, Rotating Text, and using AutoFit .....................................122
Lesson 3-13: Finding and Replacing Formatting .........................................................124
Chapter Three Review ...............................................................................................126

Chapter Four: Creating and Working with Charts ....................................................133
Lesson 4-1: Creating a Chart ......................................................................................134
Lesson 4-2: Moving and Resizing a Chart ..................................................................136
Lesson 4-3: Formatting and Editing Objects in a Chart ..............................................138
Lesson 4-4: Changing a Chart’s Source Data .............................................................140
Lesson 4-5: Changing a Chart Type and Working with Pie Charts ..............................142
Lesson 4-6: Adding Titles, Gridlines, and a Data Table ..............................................144
Lesson 4-7: Formatting a Data Series and Chart Axis ...............................................146
Lesson 4-8: Annotating a Chart .................................................................................148
Lesson 4-9: Working with 3-D Charts .......................................................................150
Lesson 4-10: Selecting and Saving a Custom Chart ....................................................152
Lesson 4-11: Using Fill Effects ...................................................................................154
Lesson 4-12: Mapping Data .......................................................................................156
Lesson 4-13: Modifying a Map ...................................................................................158
Chapter Four Review ..................................................................................................160

Chapter Five: Managing Your Workbooks ...............................................................167
Lesson 5-1: Switching Between Sheets in a Workbook ..............................................168
Lesson 5-2: Inserting and Deleting Worksheets .........................................................170
Lesson 5-3: Renaming and Moving Worksheets .........................................................172
Lesson 5-4: Working with Several Workbooks and Windows ....................................174
Lesson 5-5: Splitting and Freezing a Window .............................................................176
Lesson 5-6: Referencing External Data .......................................................................178
Lesson 5-7: Creating Headers, Footers, and Page Numbers ......................................180
Lesson 5-8: Specifying a Print Area and Controlling Page Breaks ...............................182
Lesson 5-9: Adjusting Page Margins and Orientation ................................................184
Lesson 5-10: Adding Print Titles and Gridlines ..........................................................186
Lesson 5-11: Changing the Paper Size and Print Scale ..............................................188
Lesson 5-12: Protecting and Hiding a Worksheet .......................................................190
Lesson 5-13: Viewing a Worksheet and Saving a Custom View ..................................192
Lesson 5-14: Working with Templates ......................................................................194
Lesson 5-15: Consolidating Worksheets ....................................................................196
Chapter Five Review ..................................................................................................198

Chapter Six: More Functions and Formulas ..............................................................205
Lesson 6-1: Formulas with Several Operators and Cell Ranges ..................................206
Lesson 6-2: Using the Insert Function Feature ............................................................208
Lesson 6-3: Creating and Using Range Names ............................................................210
Lesson 6-4: Selecting Nonadjacent Ranges and Using AutoCalculate
Lesson 6-5: Using the IF Function to Create Conditional Formulas
Lesson 6-6: Using the PMT Function
Lesson 6-7: Displaying and Printing Formulas
Lesson 6-8: Fixing Formula Errors
Mathematical Functions
Financial Functions
Date and Time Functions
Statistical Functions
Database Functions
Chapter Six Review

Chapter Seven: Working with Lists
Lesson 7-1: Creating a List
Lesson 7-2: Using the Data Form to Add Records
Lesson 7-3: Finding Records
Lesson 7-4: Deleting Records
Lesson 7-5: Sorting a List
Lesson 7-6: Filtering a List with the AutoFilter
Lesson 7-7: Creating a Custom AutoFilter
Lesson 7-8: Filtering a List with an Advanced Filter
Lesson 7-9: Copying Filtered Records
Lesson 7-10: Using Data Validation
Chapter Seven Review

Chapter Eight: Automating Tasks with Macros
Lesson 8-1: Recording a Macro
Lesson 8-2: Playing a Macro and Assigning a Macro a Shortcut Key
Lesson 8-3: Adding a Macro to a Toolbar
Lesson 8-4: Editing a Macro’s Visual Basic Code
Lesson 8-5: Inserting Code in an Existing Macro
Lesson 8-6: Declaring Variables and Adding Remarks to VBA Code
Lesson 8-7: Prompting for User Input
Lesson 8-8: Using the If…Then…Else Statement
Chapter Eight Review

Chapter Nine: Working with Other Programs
Lesson 9-1: Inserting an Excel Worksheet into a Word Document
Lesson 9-2: Modifying an Inserted Excel Worksheet
Lesson 9-3: Inserting a Linked Excel Chart in a Word Document
Lesson 9-4: Inserting a Graphic into a Worksheet
Lesson 9-5: Opening and Saving Files in Different Formats
Chapter Nine Review

Chapter Ten: Using Excel with the Internet
Lesson 10-1: Adding and Working with Hyperlinks
Lesson 10-2: Browsing Hyperlinks and using the Web Toolbar
Lesson 10-3: Saving a Workbook as a Non-Interactive Web Page
Lesson 10-4: Saving a Workbook as an Interactive Web Page
Lesson 10-5: Using Queries to Retrieve Information from the Web
Chapter Ten Review

Chapter Eleven: Data Analysis and PivotTables
Lesson 11-1: Creating a PivotTable
Lesson 11-2: Specifying the Data a PivotTable Analyzes
Lesson 11-3: Modifying a PivotTable’s Structure
Lesson 11-4: Selecting What Appears in a PivotTable
Lesson 11-5: Grouping Dates in a PivotTable ................................................................. 316
Lesson 11-6: Updating a PivotTable ............................................................................. 317
Lesson 11-7: Formatting and Charting a PivotTable ..................................................... 318
Lesson 11-8: Creating Subtotals .................................................................................. 320
Lesson 11-9: Using Database Functions ..................................................................... 322
Lesson 11-10: Using Lookup Functions ...................................................................... 324
Lesson 11-11: Grouping and Outlining a Worksheet .................................................. 326
Chapter Eleven Review ............................................................................................... 328

Chapter Twelve: What-If Analysis .............................................................................. 333
Lesson 12-1: Defining a Scenario ................................................................................. 334
Lesson 12-2: Creating a Scenario Summary Report ..................................................... 336
Lesson 12-3: Using a One and Two-Input Data Table ............................................... 338
Lesson 12-4: Understanding Goal Seek ...................................................................... 340
Lesson 12-5: Using Solver .......................................................................................... 342
Chapter Twelve Review ............................................................................................... 344

Chapter Thirteen: Advanced Topics ........................................................................... 349
Lesson 13-1: Hiding, Displaying, and Moving Toolbars .............................................. 350
Lesson 13-2: Customizing Excel’s Toolbars ............................................................... 352
Lesson 13-3: Creating a Custom AutoFill List ........................................................... 354
Lesson 13-4: Changing Excel’s Options ................................................................... 356
Lesson 13-5: Password Protecting a Workbook ....................................................... 358
Lesson 13-6: File Properties and Finding a File .......................................................... 360
Lesson 13-7: Sharing a Workbook and Tracking Changes ......................................... 362
Lesson 13-8: Merging and Revising a Shared Workbook ......................................... 364
Lesson 13-9: Using Detect and Repair ...................................................................... 366
Chapter Thirteen Review ............................................................................................ 368

Index ........................................................................................................................... 373
Introduction

Welcome to CustomGuide: Microsoft Excel 2002! CustomGuide is a unique product that allows organizations to create and print customized learning references. Each CustomGuide contains specific lessons, chosen by the instructor, on exactly what you need to know. In other words, this book was designed and printed just for you!

Unlike most other computer training courseware, CustomGuides are designed to be versatile. Because of their unique design, each CustomGuide is like getting three books in one! Step-by-step instructions make your CustomGuide great for use in an instructor-led classroom or as an individual, self-paced tutorial. Detailed descriptions, illustrated diagrams, informative tables, and an index make your CustomGuide suitable as a reference guide when you want to learn more about a topic or process. The handy Quick Reference box, found on the second page of each lesson, is great for when you need to know how to do something fast.

This CustomGuide is written in a down-to-earth, non-technical writing style that is easy to understand and read.

This CustomGuide is a set of lessons that teach you everything you need to know about Microsoft Excel 2002. It’s designed for new users who are just starting to learn how to use Microsoft Excel for the first time and for more experienced users who want to learn more advanced features.

Here’s how your CustomGuide is organized:

**Chapters**

This book is divided into several chapters. Each chapter covers a set of topics that are related in some way to each other. Aren’t sure if you are ready for a chapter? Look at the prerequisites that appear at the beginning of each chapter. They will tell you what you should know before you start the chapter.

**Lessons**

Each chapter contains several lessons. These lessons are what will teach you Microsoft Excel 2002. Each lesson explains a new skill or topic and contains a step-by-step exercise for you to follow to give you hands-on-experience.

**Chapter Summaries**

To help you absorb and retain all that you have learned, you will find a chapter summary at the end of each chapter that contains a brief recap of everything you have covered in the chapter’s lessons, a quiz to assess how much you’ve learned (and which lessons you might want to look over again), and a humorous homework assignment where you can put your new skills into practice. If you’re having problems with a homework exercise, you can always refer back to the lessons in the chapter to get help.
How to Use the Lessons

Every topic is presented on two facing pages, so that you can concentrate on the lesson without having to worry about turning the page. Since this is a hands-on course, each lesson contains an exercise with step-by-step instructions for you to follow.

To make learning Excel easier every exercise follows certain conventions:

- Anything you’re supposed to click, drag, or press appears **like this**.
- Whenever you’re supposed to type something, it is appears **like this**.
- This book never assumes you know where (or what) something is. The first time you’re told to click something, a picture of what you’re supposed to click appears either in the margin next to the step, or in the illustrations at the beginning of the lesson.

Illustrations show what your screen should look like as you follow the lesson and describe controls, dialog boxes, and processes.

An easy to understand introduction explains the task or topic covered in the lesson and what you’ll be doing in the exercise.

Tips and traps appear in the margin.

Icons and pictures appear in the margin, showing you what to click or look for.

Clear step-by-step instructions guide you through the exercise. When you need to click something, it appears **like this**.

---

**Lesson 4-2: Formatting Values**

In this lesson, you will learn how to apply number formats. Applying number formatting changes how values are displayed—it doesn’t change the actual information in any way. Excel is often smart enough to apply some number formatting automatically. For example, if you use a dollar sign to indicate currency (such as $548.67), Excel will automatically apply the currency number format for you.

The Formatting toolbar has five buttons (Currency, Percent, Comma, Increase Decimal, and Decrease Decimal) you can use to quickly apply common number formats. If none of these buttons has what you’re looking for, you need to use the Format Cells dialog box by selecting Format → Cells from the menu and clicking the Number tab. Formatting numbers with the Format Cells Dialog box isn’t as fast as using the toolbar, but it gives you more precision and formatting options. We’ll use both methods in this lesson.

1. Select the cell range D5:D17 and click the **Comma Style button on the Formatting toolbar**.

Excel adds a hundreds separator (the comma) and two decimal places to the selected cell range.
2. Click cell A4 and type Annual Sales.
The numbers in this column should be formatted as currency.

3. Press <Enter> to confirm your entry and overwrite the existing information.

4. Select the cell range G5:G17 and click the Currency Style button on the Formatting toolbar.
A dollar sign and two decimal places are added to the values in the selected cell range.

5. Select the cell range F5:F17 and click the Percent Style button on the Formatting toolbar.
Excel applies percentage style number formatting to the information in the Tax column.

6. With the Tax cell range still selected, click the Increase Decimal button on the Formatting toolbar.
Excel adds one decimal place to the information in the tax rate column.

Next, you want to change the date format in the date column. There isn’t a “Format Date” button on the Formatting toolbar, so you will have to format the date column using the Format Cells dialog box.
The Formatting toolbar is great for quickly applying the most common formatting options to cells, but it doesn’t offer every available formatting option. To see and/or use every possible character formatting option you have to use the Format Cells dialog box. You can open the Format Cells dialog box by either selecting Format → Cells from the menu or right-clicking and selecting Format Cells from the shortcut menu.

7. With the Date cell range still selected, select Format → Cells from the menu, select 4-Mar-97 from the Type list box and click OK.
That’s all there is to formatting values—not as difficult as you thought it would be, was it? The following table lists the five buttons on the Formatting toolbar you can use to apply number formatting to the values in your worksheets.

### Table 4-2: Number Formatting Buttons on the Formatting Toolbar

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency</td>
<td>$1,000.00</td>
<td>Adds a dollar sign, comma, and two decimal places.</td>
</tr>
<tr>
<td>Percent</td>
<td>100%</td>
<td>Displays the value as a percentage with no decimal places.</td>
</tr>
<tr>
<td>Comma</td>
<td>1,000</td>
<td>Separates thousands with a comma.</td>
</tr>
<tr>
<td>Increase Decimal</td>
<td>1000.00</td>
<td>Increases the number of digits after the decimal point by one.</td>
</tr>
<tr>
<td>Decrease Decimal</td>
<td>1000.00</td>
<td>Decreases the number of digits after the decimal point by one.</td>
</tr>
</tbody>
</table>

### Formatting a Worksheet

- When you see a keyboard instruction like “press <Ctrl> + <B>” you should press and hold the first key (Ctrl in this example) while you press the second key (B in this example). Then after you’ve pressed both keys you can release them.
- There is usually more than one way to do something in Excel. The exercise explains the most common method of doing something, while the alternate methods appear in the margin. Use whatever approach feels most comfortable for you.
- Important terms appear in italics the first time they’re presented.
- Whenever something is especially difficult or can easily go wrong, you’ll see a:

  **NOTE:** immediately after the step, warning you of pitfalls that you could encounter if you’re not careful.
- Our exclusive Quick Reference box appears at the end of every lesson. You can use it to review the skills you’ve learned in the lesson, and as a handy reference—when you need to know how to do something fast and don’t need to step through the sample exercises.

### Important Points

- Tables provide summaries of the terms, toolbar buttons, or shortcuts covered in the lesson.
- CustomGuide’s exclusive Quick Reference is great for when you need to know how to do something fast. It also lets you review what you’ve learned in the lesson.
Welcome to your first lesson of Microsoft Excel 2002. Excel is a powerful spreadsheet software program that allows you to make quick and accurate numerical calculations. Entering data onto a spreadsheet (or worksheet as they are called in Excel) is quick and easy. Once data has been entered in a worksheet, Excel can instantly perform any type of calculation on it. Excel can also make your information look sharp and professional. The uses for Excel are limitless: businesses use Excel for creating financial reports, scientists use Excel for statistical analysis, families use Excel to help manage their investment portfolios. Microsoft Excel is by far the most widely used and, according to most reviews, the most powerful and user-friendly spreadsheet program available. You’ve made a great choice by deciding to learn Microsoft Excel 2002.

This chapter will introduce you to the Excel ‘basics’—what you need to know to create, print, and save a worksheet. If you’ve already seen the Microsoft Excel program screen before, you know that it is filled with cryptic-looking buttons, menus, and icons. By the time you have finished this chapter, you will know what most of those buttons, menus, and icons are used for.
Lesson 1-1: Starting Excel

Before starting Microsoft Excel 2002 you have to make sure your computer is on—if it’s not, turn it on! You start Excel 2002 the same as you would start any other Windows program on your computer—with the Start button. Because every computer is setup differently (some people like to rearrange and reorder their program menu) the procedure for starting Excel on your computer may be slightly different from the one listed here.

1. **Make sure your computer is on and the Windows desktop is open.**
   Your computer screen should look similar to the one shown in Figure 1-1.

2. **Use your mouse to point to and click the Start Button, located at the bottom-left corner of the screen.**
   The Windows Start menu pops ups.

3. **Use the mouse to move the pointer over the word Programs.**
   A menu similar to the one show in Figure 1-2 pop-outs to the right of Programs. The programs and menus listed will depend on the programs installed on your computer, so your menu will probably look somewhat different from the illustration.
4. On the Programs menu, point to and click Microsoft Excel.

Depending on how many programs are installed on your computer and how they are organized, it might be a little difficult to find the Microsoft Excel program. Once you click the Microsoft Excel program, your computer’s hard drive will whir for a moment while it loads Excel. The Excel program screen appears, as shown in Figure 1-3.

That’s it! You are ready to start creating spreadsheets with Microsoft Excel. In the next lesson, you will learn what all those funny-looking objects on your screen are.

Quick Reference

To Start the Microsoft Excel Program:
1. Click the Windows Start button.
2. Select Programs → Microsoft Excel.
Lesson 1-2: What's New in Excel 2002?

If you’re upgrading from Excel 97 or 2000 to Excel 2002 you’re in luck—in most respects Excel 2002 looks and works almost the same as your trusty version of Excel 97. Here’s what’s new in Excel 2002:

Table 1-1: What’s New

<table>
<thead>
<tr>
<th>New Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Streamlined User Interface</td>
<td>Office XP has a new look and feel that improves the user’s Office experience. This includes removing visually competing elements, visually prioritizing items on a page, increasing letter spacing and word spacing for better readability, and defining foreground and background color to bring the most important elements to the front.</td>
</tr>
<tr>
<td>Smart Tags</td>
<td>Perhaps the biggest new feature in Excel 2002, context-sensitive smart tags are a set of buttons that provide speedy access to relevant information by alerting you to important actions—such as formatting options for pasted information, formula error correction, and more.</td>
</tr>
<tr>
<td>Task Panes</td>
<td>The Task Pane appears on the right side of the screen and lets you quickly perform searches, open or start a new workbook, and view the contents of the clipboard.</td>
</tr>
<tr>
<td>Speech</td>
<td>Office XP increases user productivity with voice commands. Users can dictate text, make direct formatting changes, and navigate menus using speech and voice commands.</td>
</tr>
<tr>
<td>New Feature</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Speech Playback</td>
<td>An option to have a computer voice play back data after every cell entry or after a range of cells has been entered makes verifying data entry convenient and practical. You can even choose the voice the computer uses to read back your data.</td>
</tr>
<tr>
<td>Expanded AutoSum functionality</td>
<td>The practical functionality of AutoSum has expanded to include a drop-down list of the most common functions. For example, you can click Average from the list to calculate the average of a selected range, or connect to the Function Wizard for more options.</td>
</tr>
<tr>
<td>Recommended functions in the Function Wizard</td>
<td>Type a natural language query, such as &quot;How do I determine the monthly payment for a car loan&quot;, and the Function Wizard returns a list of recommended functions you can use to accomplish your task.</td>
</tr>
<tr>
<td>Formula error checking</td>
<td>Like a grammar or spell checker, Excel uses certain rules to check for problems in formulas. These rules can help find common mistakes. You can turn these rules on or off individually.</td>
</tr>
<tr>
<td>Personalized Menus</td>
<td>Office 2000 displays only the commands that you use most often on new personalized menus and toolbars. A menu’s more advanced commands are hidden from view, although you can easily expand a menu to reveal all of its commands. After you click a command, it appears on your personalized menu.</td>
</tr>
<tr>
<td>Multiple Cut, Copy, and Paste Clipboard</td>
<td>An improved Office XP clipboard lets you copy up to 24 pieces of information at once across all the Office applications or the Web and store them on the Task Pane. The Task Pane gives you a visual representation of the copied data and a sample of the text, so you can easily distinguish between items as they transfer them to other documents</td>
</tr>
<tr>
<td>See What You Have Open</td>
<td>Use the Windows taskbar to switch between open Office documents—each document appears as an icon on the taskbar.</td>
</tr>
<tr>
<td>Improved Office Assistant</td>
<td>The Assistant uses less space on your screen, while still providing you with all the help you need. If the Office Assistant can’t answer your question, it can take you to the Web for more information.</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Finding and replacing data in Excel includes new options to match formatting and search an entire workbook or worksheets.</td>
</tr>
<tr>
<td>Create Web Pages</td>
<td>Support for the Internet has been greatly improved in all Office XP programs. You can easily save your Excel workbooks as Web pages, and even create interactive Web pages, which have basic spreadsheet functionality and allow users to add, change, calculate, and analyze data.</td>
</tr>
<tr>
<td>Improved PivotTable Reports</td>
<td>PivotTable have been completely revamped in Excel 2000. Instead of using a non-intuitive diagram to create a PivotTable report, you can now use drop and drag to lay out a PivotTable directly on the worksheet. PivotTable reports can now easily be formatted with the AutoFormat command. Finally, row, column, and page fields now have drop-down arrows, which you can use to show or hide items in the fields.</td>
</tr>
</tbody>
</table>
Lesson 1-3: Understanding the Excel Program Screen

You might find the Excel 2002 program screen a bit confusing and overwhelming the first time you see it. What are all those buttons, icons, menus, and arrows for? This lesson will help you become familiar with the Excel program screen. There are no step-by-step instructions in this lesson—all you have to do is look at Figure 1-5 then refer to Table 1-1: The Excel Program Screen, to see what everything you’re looking at means. And, most of all, relax! This lesson is only meant to help you get aquatinted with the Excel screen—you don’t have to memorize anything.
## Table 1-1: The Excel Program Screen

<table>
<thead>
<tr>
<th>Element</th>
<th>What it's Used For</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>Displays the name of the program you are currently using (in this case, Microsoft Excel) and the name of the workbook you are working on. The title bar appears at the top of all Windows programs.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Displays a list of menus you use to give commands to Excel. Clicking a menu name displays a list of commands—for example, clicking the Format menu name displays different formatting commands.</td>
</tr>
<tr>
<td>Standard toolbar</td>
<td>Toolbars are shortcuts—they contain buttons for the most commonly used commands (instead of having to wade through several menus). The Standard toolbar contains buttons for the Excel commands you use the most, such as saving, opening, and printing workbooks.</td>
</tr>
<tr>
<td>Formatting toolbar</td>
<td>Contains buttons for the most commonly used formatting commands, such as making text bold or italicized.</td>
</tr>
<tr>
<td>Task pane</td>
<td>New in Office XP, the task pane lists commands that are relevant to whatever you’re doing in Excel. You can easily hide the task pane if you want to have more room to view a workbook: Simply click the close button in the upper-right corner of the task pane.</td>
</tr>
<tr>
<td>Worksheet window</td>
<td>This is where you enter data and work on your worksheets. You can have more than one worksheet window open at a time.</td>
</tr>
<tr>
<td>Cell Pointer and</td>
<td>Highlights the cell you are working on. The current cell in Figure 1-5 is located at A1. To make another cell active just click the cell with the mouse or press the arrow keys on the keyboard to move the cell pointer to a new location.</td>
</tr>
<tr>
<td>Active Cell</td>
<td></td>
</tr>
<tr>
<td>Formula Bar</td>
<td>Allows you view, enter, and edit data in the current cell. The Formula bar displays any formulas a cell might contain.</td>
</tr>
<tr>
<td>Name Box</td>
<td>Displays the active cell address. In Figure 1-5 “A1” appears in the name box, indicating that the active cell is A1.</td>
</tr>
<tr>
<td>Worksheet Tabs</td>
<td>You can keep multiple worksheets together in a group called a workbook. You can move quickly from one worksheet to another by clicking the worksheet tabs. You can give worksheets your own meaningful names, such as “Budget” instead of “Sheet1.” Excel workbooks contain 3 worksheets by default.</td>
</tr>
<tr>
<td>Scroll bars</td>
<td>There are both vertical and horizontal scroll bars—you use them to view and move around your spreadsheet. The scroll box shows where you are in the workbook—for example, if the scroll box is near the top of the scroll bar you’re at the beginning of a workbook.</td>
</tr>
<tr>
<td>Status bar</td>
<td>Displays messages and feedback.</td>
</tr>
</tbody>
</table>

Don’t worry if you find some of these elements of the Excel program screen confusing at first—they will make more sense after you’ve actually used them—which you will get a chance to do in the next lesson.
Lesson 1-4: Using Menus

This lesson explains the one of the most ways to give commands to Excel—by using the menus. Menus for all Windows programs can be found at the top of a window, just beneath the program’s title bar. In Figure 1-6 notice the words File, Edit, View, Insert, Tools, Data, Window, and Help. The next steps will show you why they’re there.

1. **Click the word File on the menu bar.**
   A menu drops down from the word File, as shown in Figure 1-6. The File menu contains a list of file-related commands, such as New, which creates a new file, Open, which opens or loads a saved file, Save, which saves the currently opened file, and Close, which closes the currently opened file. Move on to the next step to try selecting a command from the File menu.

2. **Click the word Close in the File menu.**
   The workbook window disappears—you have just closed the current workbook. Notice each of the words in the menu has an underlined letter somewhere in it. For example, the F in the File menu is underlined. Holding down the <Alt> key and pressing the underlined letter in a menu does the same thing as clicking it. For example, pressing the <Alt> key and then the <F> key would open the File menu. Move on to the next step and try it for yourself.

3. **Press the <Alt> key then press the <F> key.**
   The File menu appears. Once you open a menu you can navigate through the different menus using either the mouse or the <Alt> key and the letter that is underlined in the menu name.

4. **Press the Right Arrow Key <→>.**
   The next menu to the right, the Edit menu, appears. If you open a menu and then change your mind, it’s easy to close it without selecting any commands. Just click anywhere outside the menu or press the <Esc> key.

5. **Click anywhere outside the menu to close the menu without issuing any commands.**

**NOTE:** The procedure for using menus and the general order/layout of the menu is the same for most Windows programs. So once you master Excel’s menus, you can handle just about any Windows-based program!
Chapter One: The Fundamentals

The menus in Excel 2002 work quite a bit differently than in other Windows programs—even than previous versions of Excel! Microsoft Excel 2002 displays its menu commands on the screen in three different ways:

- By displaying every command possible, just like most Windows programs, including earlier versions of Excel.
- By hiding the commands you don’t use as frequently (the more advanced commands) from view.
- By displaying the hidden commands by clicking the downward-pointing arrows (▼) at the bottom of the menu or after waiting a couple of seconds.

6. **Click the word **Tools** in the menu.**

The most common menu commands appear in the Tools menu. Some people feel intimidated by being confronted with so many menu options, so the menus in Office 2002 don’t display the more advanced commands at first. To display a menu’s advanced commands either click the downward-pointing (▼) at the bottom of the menu else keep the menu open a few seconds.

7. **Click the downward-pointing arrow (▼) at the bottom of the Tools menu.**

The more advanced commands appear shaded on the Tools menu. If you’re accustomed to working with earlier versions of Microsoft Office you may find that hiding the more advanced commands is disconcerting. If so, you can easily change how Excel’s menus work. Here’s how:

8. **Select View → Toolbars → Customize from the menu.**

The Customize dialog box appears, as shown in Figure 1-7. This is where you can change how Excel’s menus work. There are two check boxes here that are important:

- **Menus Show Recently Used Commands First:** Clear this check box if you want to show all the commands on the menus, instead of hiding the advanced commands.
- **Show Full Menus After a Short Delay:** If checked, this option waits a few seconds before displaying the more advanced commands on a menu.

9. **Click Close.**

<table>
<thead>
<tr>
<th><strong>Table 1-2: Menus found in Microsoft Excel</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
</tr>
<tr>
<td>---</td>
</tr>
<tr>
<td>File</td>
</tr>
<tr>
<td>Edit</td>
</tr>
<tr>
<td>View</td>
</tr>
<tr>
<td>Insert</td>
</tr>
<tr>
<td>Format</td>
</tr>
<tr>
<td>Tools</td>
</tr>
<tr>
<td>Data</td>
</tr>
<tr>
<td>Window</td>
</tr>
<tr>
<td>Help</td>
</tr>
</tbody>
</table>
Lesson 1-5: Using Toolbars and Creating a New Workbook

In this lesson, we move on to another common way of giving commands to Excel—using toolbars. Toolbars are shortcuts—they contain buttons for the most commonly used commands. Instead of wading through several menus to access a command, you can click a single button on a toolbar. Two toolbars appear when you start Excel by default:

- **Standard toolbar**: Located either to the left or on the top, the Standard toolbar contains buttons for the commands you’ll use most frequently in Excel, such as Save and Print.
- **Formatting toolbar**: Located either to the right of or below the Standard toolbar, the Formatting toolbar contains buttons for quickly formatting fonts and paragraphs.

1. **Position the mouse pointer over the New button on the Standard toolbar (but don’t click the mouse yet!)**
   A Screen Tip appears over the button briefly identifying what the button is, in this case “New”. If you don’t know what a button on a toolbar does, simply move the pointer over it, wait a second, and a ScreenTip will appear over the button, telling you what it does.
2. **Click the New button on the Standard toolbar.**
   A new, blank workbook appears—not only have you learned how to use Microsoft Excel’s toolbars, but you’ve also learned how to create a new, blank workbook.

   Excel’s toolbars also have “show more” arrows, just like menus do. When click a button, it displays a drop-down menu or a list of the remaining buttons on the toolbar, as well as several toolbar related-options.

3. **Click the button on the far-left side of the Standard toolbar.**
   A list of the remaining buttons on the Standard toolbar appear, as shown in Figure 1-10. Just like personalized menus, Excel remembers which toolbar buttons you use most often, and displays them in a more prominent position on the toolbar.

4. **Click anywhere outside the toolbar list to close the list without selecting any of its options.**
   Today, many computers have larger monitors, so Microsoft decided to save space on the screen in Office XP and squished both the Standard and Formatting toolbars together on the same bar, as shown in Figure 1-8. While squishing two toolbars together on the same bar gives you more space on the screen, it also makes the two toolbars look confusing—especially if you’re used to working with a previous version of Microsoft Office. If you find both toolbars sharing the same bar confusing, you can “un-squish” the Standard and Formatting toolbars and stack them on top of each other, as illustrated in Figure 1-9. Here’s how…

5. **Click the button on either the Standard or Formatting toolbar.**
   A list of more buttons appear and options, as shown in Figure 1-10. To stack the Standard and Formatting toolbars on top of one another select the Show Buttons on Two Rows option.

6. **Select Show Buttons on Two Rows from the list.**
   Microsoft Excel displays the Standard and Formatting toolbars on two separate rows. You can display the Standard and Formatting toolbars on the same row using the same procedure.

7. **Click the button on either the Standard or Formatting toolbar and select Show Buttons on One Row from the list.**
   Excel once again displays the Standard and Formatting toolbars on the same row. So should you display the Standard and Formatting toolbars on the same row or should you give each toolbar its own row? That’s a question that depends on the size and resolution of your computer’s display and your own personal preference. If you have a large 17-inch monitor, you might want to display both toolbars on the same row. On the other hand, if you have a smaller monitor or are constantly clicking the buttons to access hidden toolbar buttons you may want to consider display the Standard and Formatting toolbar on separate rows.

---

**Quick Reference**

**To Use a Toolbar Button:**
- Click the button you want to use.

**To Display a Toolbar Button’s Description:**
- Position the pointer over the toolbar button and wait a second. A ScreenTip will appear above the button.

**To Create a New Workbook:**
- Click the New button on the Standard toolbar.
  Or…
- Select **File → New** from the menu.

**To Stack the Standard and Formatting toolbars in Two Separate Rows:**
- Click the button on either toolbar and select **Show Buttons on Two Rows** from the list.
Lesson 1-6: Filling Out Dialog Boxes

Some commands are more complicated than others are. Saving a file is a simple process—just select File → Save from the menu or click the Save button on the Standard toolbar. Other commands are more complex—for example, suppose you want to change the top margin of the current workbook to a half-inch? Whenever you want to do something relatively complicated, you must fill out a dialog box. Filling out a dialog box is usually quite easy—if you’ve worked at all with Windows, you’ve undoubtedly filled out hundreds of dialog boxes. Dialog boxes usually contain several types of controls, including:

- Text boxes
- List boxes
- Check boxes
- Combo boxes (also called drop down lists)

It’s important that you know the names of these controls, because this book will refer to them in just about every lesson. This lesson gives you a tour of a dialog box, and explains each of these controls, so you will know what they are and know how to use them.

1. **Click the word Format from the menu.**
   
The Format menu appears. Notice the items listed in the Format menu are followed by ellipses (...). The ellipses indicate there is a dialog box behind the menu.

2. **Select Cells from the Format menu.**
   
The Format Cells dialog box appears. The Format Cells dialog box is actually one of the most complex dialog boxes in Microsoft Excel, and contains several different types of components you can fill out.
First let's look at the tabs in the Format Cells dialog box. Some dialog boxes have so many options that they all can’t fit on the same screen. When this happens, Windows divides the dialog box into several related \textit{Tabs} or sections. To view a different tab, simply click it.

3. \textbf{Click the Alignment tab.}
   The Alignment tab appears in front.

4. \textbf{Click the Font tab.}
   The Font tab of the Format Cells dialog box appears, as shown in Figure 1-11. Remember: the purpose of this lesson is to learn about dialog boxes, not how to format fonts (we’ll cover that later.) The next destination on our dialog box tour is the text box.

   Look at the Font text box, located in the upper left corner of the dialog box. Text boxes are the most common component of a dialog box, and are nothing more than the old fill-in-the-blank you’re already familiar with if you’ve filled out any type of form. To use a text box, click the text box or press the \texttt{<Tab>} key until the insertion point appears in the text box, then simply type what you want to appear into the text box.

5. \textbf{Make sure the Font text box is selected and type Arial.}
   You’ve just filled out the text box—nothing to it. The next stop in our dialog box tour is the \textit{list box}. There’s a list box located directly below the Font text box you just typed in. A list box is a way of listing several (or many) options into a small box. Sometimes list boxes contain so many options that they can’t all be displayed at once, and you must use the list boxes \textit{scroll bar}, as shown in Figure 1-12, to move up or down the list.

6. \textbf{Click and hold the Font list box's Scroll Down button until Times New Roman appears in the list, then click the Times New Roman option to select it.}
   Our next destination is the \textit{combo box}. The combo box is the cousin of the list box—it also displays a list of options. The only difference is you must click the combo box’s downward pointing arrow to display its options.

7. \textbf{Click the Underline combo box down arrow.}
   A list of underlining options appears below the combo box.

8. \textbf{Select Single from the combo box.}
   Sometimes you need to select more than one item from a dialog box. For example, what if you want to add Shadow formatting and Small Caps formatting to the selected font? You use the check box control when you’re presented with multiple choices.

9. \textbf{In the Effect section click the Strikethrough check box and click the Superscript check box.}
   The last destination on our dialog box tour is the \textit{button}. Buttons found in dialog boxes are used to execute or cancel commands. Two buttons are in just about every dialog box:
   
   \begin{itemize}
   \item \textbf{OK}: Applies and saves any changes you have made and then closes this dialog box. Pressing the \texttt{<Enter>} key is usually the same as clicking the OK button.
   \item \textbf{Cancel}: Closes the dialog box without applying and saving any changes. Pressing the \texttt{<Esc>} key is the same as clicking the cancel button.
   \end{itemize}

10. \textbf{Click the Cancel button to cancel the changes and close the dialog box.}
Lesson 1-7: Keystroke and Right Mouse Button Shortcuts

You are probably starting to realize that there are several methods to do the same thing in Excel. For example, to save a file, you can use the menu (select File → Save) or the toolbar (click the Save button). This lesson introduces you to two more methods of executing commands: Right mouse button shortcut menus and keystroke shortcuts.

You know that the left mouse button is the primary mouse button, used for clicking and double-clicking, and it’s the mouse button you will use over 95 percent of the time when you work with Excel. So what’s the right mouse button for? Whenever you right-click something, it brings up a shortcut menu that lists everything you can do to the object. Whenever you’re unsure or curious about what you can do with an object, click it with the right mouse button. A shortcut menu will appear with a list of commands related to the object or area you right-clicked.

Right mouse button shortcut menus are a great way to give commands to Excel, because you don’t have to wade through several levels of unfamiliar menus when you want to do something.

1. **Click the right mouse button while the cursor is anywhere inside the workbook window.**

   A shortcut menu appears where you clicked the mouse. Notice one of the items listed on the shortcut menu is Format Cells. This is the same Format Cells command you can select from the menu (clicking Format → Format Cells). Using the right mouse button shortcut method is slightly faster and usually easier to remember than Excel’s menus. If you open a shortcut menu and then change your mind, you can close it without selecting anything. Here’s how:
2. Move the mouse button anywhere outside the menu and click the left mouse button to close the shortcut menu.
Remember that the options listed in the shortcut menu will be different, depending on what or where you right-clicked.

3. Position the pointer over either the Standard or Formatting toolbar and click the right mouse button.
A shortcut menu appears listing all the toolbars you can view, as shown in Figure 1-14.

4. Move the mouse button anywhere outside the menu in the workbook window and click the left mouse button to close the shortcut menu.
On to keystroke shortcuts. Without a doubt, keystroke shortcuts are the fastest way to give commands to Excel, even if they are a little hard to remember. They’re great timesavers for issuing common commands that you do all the time. To issue a keystroke-shortcut press and hold the <Ctrl> key, press the shortcut key, and release both buttons.

5. Press <Ctrl> + <I> (the Ctrl and I keys at the same time.)
This is the keystroke shortcut for Italics. Note that the Italics button on the Formatting toolbar becomes depressed.

6. Type Italics.
The text appears in Italics formatting.

NOTE: Although we won’t discuss it in this lesson, Excel’s default keystroke shortcuts can be changed or remapped to execute other commands.

Table 1-3: Common Keystroke Shortcuts lists the shortcut keystrokes you’re likely to use the most in Excel.

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Ctrl&gt; + &lt;B&gt;</td>
<td>Toggles bold font formatting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;I&gt;</td>
<td>Toggles italics font formatting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;U&gt;</td>
<td>Toggles underline font formatting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Spacebar&gt;</td>
<td>Returns the font formatting to the default setting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;O&gt;</td>
<td>Opens a workbook</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;S&gt;</td>
<td>Saves the current workbook</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;P&gt;</td>
<td>Prints the current workbook to the default printer</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;C&gt;</td>
<td>Copies the selected text or object to the Windows clipboard</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;X&gt;</td>
<td>Cuts the selected text or object from its current location to the Windows clipboard</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;V&gt;</td>
<td>Pastes any copied or cut text or object in the Windows clipboard to the current location</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Home&gt;</td>
<td>Moves the insertion point to the beginning of the workbook</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;End&gt;</td>
<td>Moves the insertion point to the end of the workbook.</td>
</tr>
</tbody>
</table>

Quick Reference

To Open a Context-Sensitive Shortcut Menu:
• Right-click the object.

To Use a Keystroke Shortcut:
• Press <Ctrl> + the letter of the keystroke shortcut you want to execute.
Lesson 1-8: Opening a Workbook

When you work with Excel you will sometimes need to create a new workbook from scratch (something you hopefully learned how to do when we talked about toolbars in a previous lesson) but more often you’ll want to work on an existing workbook that you or someone else has previously saved. This lesson explains how to open, or retrieve a saved workbook.

1. **Click the Open button** on the Standard toolbar.

   The Open dialog appears, as shown in Figure 1-15.

2. **Navigate to and open your practice folder or floppy disk.**

   Your computer stores information in files and folders, just like you store information in a filing cabinet. To open a file, you must first find and open the folder where it’s saved. Normally new files are saved in a folder named “My Documents” but sometimes you will want to save or open files in another folder.

![Image of the Open dialog box](image1.png)

**Figure 1-15**

The Open dialog box.

**Figure 1-16**

The Lesson 1 workbook appears in the Excel program.
Chapter One: The Fundamentals

The Open and Save dialog boxes both have their own toolbars that make it easy to browse through your computer’s drives and folders. Two controls on this toolbar are particularly helpful:

- **Look In List**: Click to lists the drives on your computer and the current folder, select the drive and/or folder whose contents you want to display.

- **Up One Level button**: Click to move up one folder.

If necessary, follow your instructor’s directions to select the appropriate drive and folder where your practice files are located.

3. **Click the document named Lesson 1 in the file list box and click Open.** Excel opens the Lesson 1 workbook and displays it in the window, as shown in Figure 1-16.

---

Table 1-4: Special Folders in the Open and Save As Dialog Boxes

<table>
<thead>
<tr>
<th>Heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>History</td>
<td>Displays a list of files that you’re recently worked on.</td>
</tr>
<tr>
<td>My Documents</td>
<td>Displays all the files in the My Document folder—the default location where Microsoft Office programs save their files.</td>
</tr>
<tr>
<td>Desktop</td>
<td>Temporarily minimizes or hides all you programs so that you can see the Windows desktop.</td>
</tr>
<tr>
<td>Favorites</td>
<td>Display a list of your “Favorite” folders, although these are often used to organize your favorite Web pages.</td>
</tr>
<tr>
<td>My Network Places</td>
<td>Lets you browse through the computers in your workgroup and the computers on the network.</td>
</tr>
</tbody>
</table>
Lesson 1-9: Saving a Workbook

After you’ve created a worksheet, you need to save it if you intend on using it ever again. Saving a worksheet stores it in a file on your computer’s hard disk—similar to putting a file away in a filing cabinet so you can later retrieve it. Once you have saved a worksheet the first time, it’s a good idea to save it again from time to time as you work on it. You don’t want to lose all your work if the power suddenly goes out or if your computer crashes! In this lesson, you will learn how to save an existing workbook with a different name without changing the original workbook. It’s often easier and more efficient to create a workbook by modifying one that already exists, instead of having to retype a lot of information.

You want to use the information in the Lesson 1 workbook that we opened in the previous lesson to create a new workbook. Since you don’t want to modify the original workbook, Lesson 1, save it as a new workbook named Income and Expenses.

1. Select File → Save As from the menu.
   The Save As dialog box appears. Here is where you can save the workbook with a new, different name. If you only want to save any changes you’ve made to a workbook—instead saving them in a new file—click the Save button on the Standard toolbar, or select File → Save from the menu, or press <Ctrl> + <S>.
   First you have to tell Excel where to save your workbook.

2. If necessary, navigate to and open your practice folder or floppy disk.
   Next you need to specify a new name that you want to save the document under.

3. In the File name text box, type Income and Expenses and click Save.
   The Lesson 1 workbook is saved with the new name, Income and Expenses. Now you can work on our new workbook, Income and Expenses, without changing the original workbook, Lesson 1.
   When you make changes to your workbook, you simply save your changes in the same file. Go ahead and try it.

4. Type Income and press the <Enter> key.
   Now save your changes.
5. **Click the Save button on the Standard toolbar.**

Excel saves the changes you’ve made to the Income and Expenses workbook.

Congratulations! You’ve just saved your first Excel workbook.

---

**Quick Reference**

**To Save a Workbook:**
- Click the **Save button** on the Standard toolbar.
- Or…
  - Select **File** → **Save** from the menu.
  - Or…
  - Press **<Ctrl> + <S>**.

**To Save a Workbook in a New File with a Different Name:**
1. Select **File** → **Save As** from the menu.
2. Type a new name for the worksheet and click **Save**.
Lesson 1-10: Moving the Cell Pointer

Before you start entering data into a worksheet, you need to learn one very important task: how to move around in a worksheet. This lesson will teach you how to do just that. You must first make a cell active before you can enter information in it. You can make a cell active using:

- **The Mouse:** You can click any cell with the white cross pointer ( ).
- **The Keyboard:** You can move the cell pointer using the keyboard’s arrow keys.

Worksheets can be confusing places for many people—to help you know where you are in a worksheet, Excel displays row headings, indentified by numbers, on the left side of the worksheet, and column headings, identified with letters on the top of the workbook (see Figure 1-18.) Each cell in a worksheet is given its own unique **cell address** made from its column letter and row number, such as cell A1, A2, B1, B2, etc. You can immediately find an address of a cell by looking at the **name box**, which shows the current cell address.

1. **Click cell C3 (located in column C and Row 3) with the pointer to make it active.**
   Once you click C3 it becomes the active cell, and its cell address (C3) appears in the name box.

2. **Make cell E9 active by clicking it.**
   Now that you’re familiar with moving the cell pointer with the mouse, try using keyboard.
3. **Make cell D5 active moving the cell pointer by pressing the \(<→>\) arrow key once and the \(<↑>\) arrow key four times.**
   As you press the arrow keys, watch the name box. Notice it is updated to display the current cell address.

4. **Press the \(<\text{Enter}>\) key once.**
   Pressing \(<\text{Enter}>\) causes the cell pointer to move down to the next cell, D6. The Enter key is a real time-saver when you’re entering data.

5. **Press the \(<\text{Tab}>\) key twice.**
   Pressing \(<\text{Tab}>\) causes the cell pointer to move to the right, the same as pressing the \(<→>\) key.

6. **Press and hold the \(<\text{Shift}>\) key as you press the \(<\text{Tab}>\) key.**
   Pressing the \(<\text{Shift}>\) and \(<\text{Tab}>\) keys at the same time is the same as pressing the \(<→>\) key. This may seem like an unusual, hard-to-remember keystroke, but it is actually is used in many other Windows-based programs.

   You have probably already guessed that the worksheet is larger than what you can currently see in the worksheet window. Actually, it *is* much, much larger: there are 256 columns and 16,384 rows in a worksheet! To view the portions of the worksheet that are currently located off-screen you can use the horizontal and vertical scroll bars, which are located at the bottom and far right of the worksheet screen.

7. **Click and hold the right-arrow scroll button on the horizontal scroll bar, until you can see columns X, Y, Z, and AA on your screen.**
   If you accidently go too far you can easily move back by clicking the left-arrow scroll button.

   When you arrive at the AA column, notice that the cell pointer is not currently located on this screen—you left it way back in cell D8. Let’s see if you remember how to make cell Z4 the active cell.

8. **Make cell Z4 active by clicking it with the mouse.**
   Scrolling up and down in a worksheet is just as easy as scrolling to the right and left. Try it!

9. **Click the down-arrow scroll button on the vertical scroll bar several times.**
   You don’t have to use the scroll button to move to worksheet areas that are hidden off-screen—you can do the same thing with the keyboard.

10. **Press and hold down the \(<→>\) key until you reach cell A4.**
    Congratulations! In one brief lesson you’ve become familiar with moving the cell pointer around in a worksheet. Turn the page to go on to the next lesson where you will learn how to become an expert on getting around in Excel.

---

**Quick Reference**

**To Move the Cell Pointer:**
- Click any cell with the crosshair pointer (\(\text{微软雅黑}\)) to make it active.
- Use the arrows keys to move the active cell and to navigate the worksheet.
- Pressing \(<\text{Enter}>\) moves the active cell down.
- Pressing \(<\text{Tab}>\) moves the active cell to the right.
- Pressing \(<\text{Shift}> + <\text{Tab}>\) moves the active cell to the left.

**To Scroll the Worksheet:**
- Click the left and right scroll button arrows on the horizontal scroll bar to scroll the worksheet to the left or right.
- Click the up and down scroll button arrows on the vertical scroll bar to scroll the worksheet up or down.
Lesson 1-11: Navigating a Worksheet

The previous lesson introduced you to the basics of getting around in an Excel worksheet. As workbooks get larger it gets more difficult to find your way around in them. In large worksheets, the simple navigation commands you learned in the previous lesson may take you longer to get to a destination than you would like. This lesson covers the more advanced methods of getting around in Excel.

1. **Click cell C15.**
   
   You can quickly move up to the first occupied cell in the table by pressing `<End>` and then the `<↑>`.  

2. **Press and hold the `<Ctrl>` key, press the `<↑↑↑↑>` key, and release both buttons.**

   The cell pointer moves to the first cell that contains information—C11. Try another shortcut navigation keystroke—the `<Home>` key, which moves to column A of the current row.

3. **Press `<Home>`.

   Viola! You’re in the A column in the current row.

Table 1-5: *Keyboard Shortcuts for Moving Around in a Worksheet* displays all the more advanced navigational keystrokes you can use to quickly get around a worksheet.

**NOTE:** When you refer to the shortcuts in the following table, remember the plus (+) sign between two keys (e.g., `<Ctrl> + `<Home>`) means you press both keys at the same time. A comma (,) between two keys (e.g., `<End>, `<→>`) means you must first press and release one key, then press and release the other key.
# Table 1-5: Keyboard Shortcuts for Moving Around in a Worksheet

<table>
<thead>
<tr>
<th>Press</th>
<th>To Move</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;→→&gt; or &lt;Tab&gt;</td>
<td>One cell to the right</td>
</tr>
<tr>
<td>&lt;←←&gt; or &lt;Shift&gt; + &lt;Tab&gt;</td>
<td>One cell to the left</td>
</tr>
<tr>
<td>&lt;↑&gt;</td>
<td>Up one row</td>
</tr>
<tr>
<td>&lt;↓&gt;</td>
<td>Down one row</td>
</tr>
<tr>
<td>&lt;Home&gt;</td>
<td>To cell in column A in the current row</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Home&gt;</td>
<td>To the first cell (A1) in the worksheet</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;End&gt;</td>
<td>To the last cell with data in a worksheet</td>
</tr>
<tr>
<td>&lt;Page Up&gt;</td>
<td>Up one screen</td>
</tr>
<tr>
<td>&lt;Page Down&gt;</td>
<td>Down one screen</td>
</tr>
<tr>
<td>&lt;F5&gt;</td>
<td>Opens the Go To dialog box where you can go to a specified cell address.</td>
</tr>
<tr>
<td>&lt;End&gt;, &lt;→→&gt; or &lt;Ctrl&gt; + &lt;→→&gt;</td>
<td>First occupied cell to the right that is either preceded or followed by a blank cell.</td>
</tr>
<tr>
<td>&lt;End&gt;, &lt;←←&gt; or &lt;Ctrl&gt; + &lt;←←&gt;</td>
<td>First occupied cell to the left that is either preceded or followed by a blank cell.</td>
</tr>
<tr>
<td>&lt;End&gt;, &lt;↑&gt; or &lt;Ctrl&gt; + &lt;↑&gt;</td>
<td>First occupied cell to the right that is either preceded or followed by a blank cell.</td>
</tr>
<tr>
<td>&lt;End&gt;, &lt;↓↓&gt; or &lt;Ctrl&gt; + &lt;↓↓&gt;</td>
<td>First occupied cell to the left that is either preceded or followed by a blank cell.</td>
</tr>
</tbody>
</table>

### Quick Reference

To Use Keystroke Shortcuts to Navigate in a Worksheet:
- Refer to Table 1-5: Keyboard Shortcuts for Moving Around in a Worksheet.
Lesson 1-12: Entering Labels in a Worksheet

Now that you are an expert on getting around in Excel, you’re ready to start entering data. There are two basic types of information you can enter in a cell:

- **Labels:** Any type of text or information not used in any calculations.
- **Values:** Any type of numerical data: numbers, percentages, fractions, currencies, dates, times, usually used in formulas or calculations.

This lesson focuses on labels. Labels are used for worksheet headings and make your worksheets easy to read and understand. Labels usually contain text, but can also consist of numerical information not used in any calculations, such as serial numbers and dates. Excel treats information beginning with a letter as a label and automatically left-aligns it in the cell.

1. **Click cell A1 to make it the active cell.**
   
   This is where you want to add a title for your worksheet. Don’t worry if the cell already contains text—anything you type will replace the old cell contents.

2. **Type Income and Expenses.**
   
   If you make a mistake while you’re typing a cell entry you can press the <Backspace> key to delete any characters, one at a time.

   Notice as you start typing, that the text appears in both the cell and in formula bar. Also, look at the formula bar—three new buttons have appeared: the Cancel button (the red X), the Enter button (the green check mark), and the Edit Formula button (the = sign), as shown in Figure 1-22. You can click the Enter button when you’ve finished typing to confirm the cell entry or the Cancel button to cancel the entry and return the cell to its previous state.
3. **Click the Enter button** on the Formula bar (see Figure 1-22 if you can’t find it.)

Clicking the Enter button on the Formula bar confirms the cell entry. There are several other, more efficient methods for entering and confirming data—we’ll take a look at these methods in the next steps. Notice the text label is too large to fit in the current cell and the text spills into the empty adjacent cells to the right. Excel will use adjacent cells to display labels that are too long to fit in a single cell, so long as they are empty. If the adjacent cells aren’t empty, Excel truncates the text—everything’s still there, but you just can’t see all of it!

Next, you need to add some labels to make the worksheet more meaningful.

4. **Click cell A7 to make it the active cell.**

The series of numbers located directly to the right of the current cell are the basic monthly expenses for North Shore Travel. Go ahead and enter the labels for the expenses.

5. **Type Advertising and press the <Enter> key.**

Excel confirms your entry and moves down to the next cell, A8. You can also complete an entry by pressing any of the arrow keys, <Tab>, or as you’ve already learned, by clicking the Enter button on the formula toolbar. Notice the label Advertising doesn’t quite fit into the cell. Add the remaining expense labels.

6. **Type Office and press <Enter>.**

The cell pointer moves down to the next cell, A9. This row contains the monthly payroll expenses.

7. **Type Payroll but don’t press <Enter> this time.**

You decide you would rather use the label “Salary” instead of “Payroll” so cancel the change and return the cell to its empty state.

8. **Click the Cancel button on the Formula bar.**

The Payroll label disappears from both the Formula bar and the current cell. Go on to the next step to enter the new correct label, for this cell and the remaining labels.

9. **Type Salary and press <Enter>, type Rent and press <Enter>, and then type Totals and press <Enter>.**

**NOTE:** Excel normally treats any information beginning with a letter as a label and any information beginning with a number as a value. If you want to create a label that starts with a number, to prevent Excel from recognizing it as a value type an ’ (apostrophe) before typing the number.

Congratulations! You’ve finished entering the expense labels for the worksheet, making it much easier to read and understand. Compare your worksheet with the one in Figure 1-22, and then go on to the next lesson to enter some values into the worksheet.
Lesson 1-13: Entering Values in a Worksheet and Selecting a Cell Range

In the previous lesson, you learned how to enter labels in a worksheet. In this lesson, you will be working with the other basic type of worksheet information: values. Values are the numbers, dates, and other numerical information in a worksheet that are usually used in calculations. A value can be any type of numerical data: numbers, percentages, fractions, currencies, dates, and times. Excel treats information that contains numbers, dates or times, and certain numerical punctuation as a value and automatically right-aligns it in the cell. Values don’t have to contain only numbers. You can also use numerical punctuation including: the period (.) for a decimal point, the hyphen (-) for negative values, the dollar sign ($) for currencies, the percent sign (%) for percentages, and the comma (,) for separating numbers like 1,000.

Entering values in a worksheet works is no different from entering labels: you simply type the value and confirm the entry by clicking the Enter button or pressing <Enter>, <Tab>, or any of the arrow keys. One more important thing to know about entering values: You can use the numeric keypad on your keyboard to key in values, which for most people is a very fast method to enter data once you’re familiar with it.
Chapter One: The Fundamentals

1. Click cell E7 to make it the active cell, type 2500, and press <Enter> to complete the entry and move the cell pointer to cell E8.

2. Type 400, press <Enter>, type 7000, press <Enter>, type 3000, and press <Enter>.
   Up until now, you have only worked with a single cell. In order to be proficient at Excel you need to know how to select and work with multiple cells.

3. Move the pointer over cell F7, click and hold down the mouse button, drag the pointer over cell G10, then release the mouse button.
   You have just selected a range of cells. A range consists of two or more selected cells and is identified by the first and last cells in the range, for example F7:G10. To select a range all you have to do is position the pointer over the first cell, click and hold the mouse button, drag the pointer to the last cell you want in range, and release the mouse button.

   Whenever you see that you’re going to have to enter data in a block or range of cells, it is sometimes a good idea to select the range to make data entry easier and faster. Selecting a range of cells restricts the cell pointer so it can only move inside the selected range.

4. Type 1500, press <Enter>, type 400, press <Enter>, type 7000, press <Enter>, and then type 3000. Do not press <Enter> after typing 3000.
   By now, you know that pressing <Enter> normally completes the cell entry and moves the cell pointer down to the next cell. Remember, however, that right now you are working in a selected cell range. Go on to the next step and see what happens when you press the <Enter> key.

5. Press <Enter>.
   Instead of moving down to the next cell, F11, the cell pointer moves to the next cell in the selected range, cell G7. By selecting a range, you restrict where the cell pointer can move and can concentrate on your data entry instead of worrying about where the cell pointer is. Go ahead and enter the remaining numbers.

6. Enter the following numbers, making sure to press <Enter> after you enter each number, except the last number, 3000. Do not press <Enter> after typing 3000.
   1200
   500
   7000
   3000
   You’re at G10, the last cell in the selected range. So, what will happen if you press the <Enter> key now? Go on to the next step and find out.

7. Press <Enter>.
   The cell pointer moves back to the first cell in the selected range, F7. Once you’re finished working on a selected range you can deselect the range by clicking any cell in the worksheet.

8. Click any cell in the worksheet to deselect the range.
   Compare your worksheet with the one in Figure 1-23 when you have finished.
This lesson introduces what spreadsheet programs are really all about: formulas. A formula performs calculations, such as adding, subtracting, and multiplying. Formulas are actually a type of value, like the numerical values you worked with in the previously lesson. Unlike the values in the previous lesson that contained only numbers, formulas contain information to perform a numerical calculation, such as adding, subtracting, multiplying, or even finding an average. A cell with the formula =5+3 will display the result of the calculation: 8.

All formulas must start with an equal sign (=). The equal sign tells Excel you want to perform a calculation. Once you have entered an equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Formulas can contain explicit values, such as the numbers 5 or 8, but more often will reference the values contained in other cells. For example, the formula =A5+A6 would add together whatever values were in the cells A5 and A6. You're already familiar with some of the arithmetic operators used in Excel formulas: they include math symbols such as the plus sign (+) to perform addition between values and the minus sign (-) to perform subtraction. Functions are used in formulas to perform calculations that are more complicated. For example, the SUM function adds together a range of cells, and the PMT function calculates the loan payments based on an interest rate, the length of the loan, and the principal amount of the loan. In this lesson, you will learn how to use one of the most commonly used functions in Excel, the SUM function, which finds the total of a block of cells.

Formulas may sound terribly confusing, but they are usually not much more difficult to work with than a calculator.
1. **Click cell B11 to make it the active cell.**

   This is where you want to enter a formula to total the expenses in B column. The easiest way to add together several numbers values in a cell range is to use the AutoSum button. The AutoSum button inserts the SUM function (which adds all the values in a range of cells) and selects the range of cells Excel thinks you want totaled.

2. **Click the AutoSum button on the Standard toolbar.**

   Excel enters =SUM(B7:B10) in cell B11. Notice that the cells included in the formula range—B7, B8, B9, and B10—are surrounded by what looks like a line of marching ants. The AutoSum function is quite good at guessing which cells you want to total, but sometimes you will want to modify the cell selection. In our case, AutoSum has corrected selected the cells.

   **NOTE:** Excel is usually smart enough to determine which cells you want to total, however if the suggested range is incorrect, select the range you want using the technique you learned in the previous lesson and press <Enter>.

3. **Click the Enter button on the Formula bar.**

   Excel instantly calculates the totals of the values in the cell range B7:B10 and displays the result, 11700, in the cell. Look at the formula bar—notice the formula =SUM(B7:B10), appears instead of the result of the calculation.

4. **Click cell B7, enter 2000, and press <Enter>.**

   You’ve just made two very important discoveries! The first is that entering data in a cell replaces or overwrites whatever information was currently there. The second discovery is what is more relevant to this lesson: look at cell B11, where you just entered the SUM formula. Cell B11 now reads 12500—it has automatically recalculated the total for the cell range. Go ahead and find the total for the expenses in the C column.

5. **Click cell C11, click the AutoSum button, and press <Enter>.**

   Excel totals the expenses in the C column. Finish entering totals for the remaining expense columns.

6. **Repeat Step 6 and enter SUM formulas for the remaining columns (D through G).** Compare your worksheet with the one in Figure 1-24 when you’re finished.
Lesson 1-15: Entering Formulas

The previous lesson introduced you to formulas and how you can use the AutoSum button to total a cell range. This lesson takes a closer look at formulas, and instead using the AutoSum function, you’ll get a chance to enter a formula yourself.

Before you start the exercise, let’s review. A formula is a value and performs calculations, such as adding, subtracting, and multiplying. Formulas start with the equal sign (=), which tells Excel you want to perform a calculation. After the equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Formulas can contain explicit values, such as the numbers 4 or 5, but more often will reference the values contained in other cells. For example, the formula =A3+A4 would add together whatever values were in the cells A3 and A4. Look at Table 1-6: Examples of Operators, References, and Formulas to see a variety of formulas that contain different operators, references, and values.

1. **Click cell A13, type Net Income, and press <Tab>.**
   - This row will contain the net income, which you can find by subtracting the total expense values from the sales value.

2. **Type = (the equal sign) in cell B13.**
   - Typing an equal sign at the beginning of a cell entry tells Excel you want to enter a formula rather than a value or label.

3. **Type B4-B11.**
   - This will subtract the value in cell b11 (12,500) from the value in b4 (12,000).

4. **Press <Enter>.**
   - Excel displays the result of the formula, -500, in cell B13. Notice, however, that the cell’s formula still appears in the formula bar. Instead of manually typing cell references, like you did in Step 3, you can specify cell references in a formula by clicking and selecting the cell or cell ranges with the mouse.
5. **Click cell C13.**
   This is where you will enter the formula to find the net income for the C column.

6. **Type =.**
   Excel is now ready to accept the formula for this cell. Instead of typing in the cell references this time, enter them using the mouse.

7. **Click cell C4.**
   A line of marching ants appears around the cell C4, indicating the cell range. Look back at cell C13. Notice Excel inserts the cell reference C4 in the formula. The next step is entering the arithmetic operator to the formula.

8. **Type – (the minus sign or hyphen.)**
   To complete the formula you must specify the cell reference for the total expenses, C11.

9. **Click cell C11.**
   Excel enters the cell reference, C11 in the formula.

10. **Press <Enter> to complete the formula.**
    The result of the formula (3,900) appears in cell C13.

Use Table 1-6: Examples of Operators, References, and Formulas as a reference when you start creating your own formulas. Not only does it contain examples of formulas, but also the most common operators and functions used in formulas.

<table>
<thead>
<tr>
<th>Operator or Function Name</th>
<th>Purpose</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>All formulas must start with an equal sign</td>
<td></td>
</tr>
<tr>
<td>+</td>
<td>Performs addition between values</td>
<td>=4+3</td>
</tr>
<tr>
<td>-</td>
<td>Performs subtraction between values</td>
<td>=A1-B1</td>
</tr>
<tr>
<td>*</td>
<td>Performs multiplication between values</td>
<td>=B1*2</td>
</tr>
<tr>
<td>/</td>
<td>Performs division between values</td>
<td>=A1/C2</td>
</tr>
<tr>
<td>SUM</td>
<td>Adds all the numbers in a range</td>
<td>=SUM(A1:A3)</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>Calculates the average of all the numbers in a range</td>
<td>=AVERAGE(A2,B1,C3)</td>
</tr>
<tr>
<td>COUNT</td>
<td>Counts the number of items in a range</td>
<td>=COUNT(A2:C3)</td>
</tr>
</tbody>
</table>

Quick Reference

**To Enter a Formula:**
1. Click the cell where you want to insert the formula.
2. Press = (the equals sign) to begin any formula.
3. Enter the formula.
4. Press <Enter>.

**To Reference a Cell in a Formula:**
- Type the cell reference— for example A3.
  Or...
- Click the cell you want to reference.
Lesson 1-16: Using AutoFill

AutoFill is the best timesaving feature for data entry in Excel. AutoFill automatically enters a series of values in any cells you select. For example, imagine you’re entering all twelve months as labels in a worksheet. With AutoFill you only have to enter a couple of months and let AutoFill enter the rest for you! Excel can’t read your mind (Microsoft’s still a few versions away from that feature), so the first cell or cells you select must contain the values and increment you want AutoFill to use when it automatically enters values. AutoFill makes a lot more sense when you see it in action, so let’s start this lesson…

1. Click cell B3, type January and then click the Enter button on the formula bar.

Here’s how to use the AutoFill feature:
2. With the cell pointer still in cell B3, position the mouse pointer over the fill handle—the tiny box in the cell’s lower-right corner, until the pointer changes to a +.

3. Click and hold the fill handle and drag the mouse pointer to the right until the cell range is extended to include cell G3, then release the mouse button.

When you release the mouse button, Excel enters the months February through June in cells C3 through G3.

If you’re working with a more complex data series, such as one that increases by increments other than one (such as every other day or month), you need to enter both the first and second entries to show Excel what increments to use when filling the data series.

4. Click cell C3, type March, and press <Enter>.

5. Select the cell range B3:C3, as shown in Figure 1-26.

By selecting the cell range B3:C3 you show Excel how you want to increment the data series. Now that Excel knows how you want to increment the data series, use AutoFill to recreate the series.

6. With the cell range B3:C3 still selected, click and drag the fill handle to the right until you select cell G3 and then release the mouse button.

When you release the mouse button, Excel follows your selected example and completes the data series with cell entries that contain every other month. AutoFill has another very useful purpose: you can use it to quickly copy data (labels, values, or formulas) from one cell to other cells. You are going to use AutoFill to copy the net income formula in you created in the previous lesson cell C13 to the remaining cells in the worksheet.

7. Click cell C13 to make it active.

Cell C13 contains the formula you want to copy.

8. Drag the fill handle to the right until you reach cell G13, then release the mouse button.

When you release the mouse button, Excel copies the formula in cell C13 to the cells D13, E13, F13, and G13.

---

**Table 1-7: Examples of AutoFill**

<table>
<thead>
<tr>
<th>First Cell Entry</th>
<th>AutoFill Entries Created in the Next Three Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>February, March, April</td>
</tr>
<tr>
<td>Jan</td>
<td>Feb, Mar, Apr</td>
</tr>
<tr>
<td>1/10/98</td>
<td>1/11/98, 1/12/98, 1/13/98</td>
</tr>
<tr>
<td>5:00</td>
<td>6:00, 7:00, 8:00</td>
</tr>
<tr>
<td>Quarter 1</td>
<td>Quarter 2, Quarter 3, Quarter 4</td>
</tr>
<tr>
<td>Project 1</td>
<td>Project 2, Project 3, Project 4</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Use AutoFill to Enter a Series of Incremental Values:

1. Enter at least two values into adjacent cells.
2. Select the cells you used in Step 1.
3. Click and drag the fill handle to complete the series in the cells you select.
Lesson 1-17: Previewing and Printing a Worksheet

Once you have created a worksheet, you can create a printed copy of it (if your computer is connected to a printer.) Sometimes, it is a good idea to preview a document on screen to see if something needs to be changed before sending it to the printer. You can preview a document by using Excel’s Print Preview feature.

1. **Click the Print Preview button** on the Standard toolbar.
   The worksheet is previewed on the screen, as shown in Figure 1-27. You can enlarge the spreadsheet by clicking the area of the worksheet you want to magnify with the 🔎 pointer.

2. **Move the 🔎 pointer over an area of the spreadsheet that contains data and click the mouse button.**
   Excel magnifies the selected area. Once you have seen an enlarged area, you can zoom back out to see the overall page again.
3. Move the mouse pointer over any area of the spreadsheet and click the mouse button.
   Excel returns to the previous preview size. Your worksheet looks O.K. so you can go ahead and print it from the Print Preview window.

4. Click Print.
   The Print Dialog box appears, as shown in Figure 1-28. The Print Dialog box allows you to specify printing options such as which pages to print and the number of copies you want printed. You don’t need to worry about any printing options for now—you just want to print the worksheet so…

5. Click OK.
   Excel prints the worksheet to the default printer connected to your computer.
   **NOTE:** If you weren’t in Print Preview mode you could also print by clicking the Print button on the Standard toolbar, by selecting File → Print from the menu, or by pressing <Ctrl> + <P>. (Actually, this is the method you’ll usually use to print something.)
Lesson 1-18: Getting Help from the Office Assistant

When you don’t know how to do something in Windows or a Windows based program, don’t panic—ask the Office Assistant for help. The Office Assistant is a cute animated character (a paperclip by default) that can answer your questions, offer tips, and provide help for all of Excel’s features. Many Excel users don’t use the Office Assistant because they think that it’s nothing more than an amusing distraction—something to keep them entertained when they pound out boring budget number with Excel. This is sad, because the Office Assistant knows more about Excel than most Excel books do!

Whenever you use Excel, you can make the Office Assistant appear by pressing the <F1> key. Then all you have to do is ask the Office Assistant your question in normal English. This
lesson will show you how you can get help by asking the Office Assistant a question about an Excel feature in normal English.

1. **Press the <F1> key.**
The Office Assistant appears and asks what you would like to do, as shown in Figure 1-29.

2. **Type How do I create a formula? in the Office Assistant’s speech balloon, as shown in Figure 1-29.**
   You can ask the Office Assistant questions about Excel in normal English, just as if you were asking a person instead of a computer. No, the Office Assistant doesn’t really understand the English language—computers have a ways to go before they can do that. The Office Assistant actually looks for key words and phrases in your questions like “create” and “formula”.

3. **Click Search.**
The Office Assistant presents you with a list of topics it thinks may be relevant for your question, as shown in Figure 1-30. You have to select the help topic that you’re looking for.

4. **Click the Enter a formula to calculate a value help topic.**
   More help subtopics to choose from appear, as shown in Figure 1-31. Again, you have to select the most appropriate help topic.

5. **Click the Enter a formula help topic.**
   Excel display information on how to enter a formula. Notice the help window has a row of buttons, or toolbar, that look vaguely like some of the buttons you might have seen on a Web browser. Microsoft redesigned the Help system in Office XP so that you can navigate through help topics just like you would browse the Web. The buttons you seen on top

6. **Click the Help window’s Close button (×) to close the help window.**
The Help window closes, however Office Assistant remains on-screen and will remain there, annoying you with its animated antics unless you close it as well.

<table>
<thead>
<tr>
<th><strong>Table 1-8: Help Buttons</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td>![Show/Hide Help Topics]</td>
</tr>
<tr>
<td>![Previous]</td>
</tr>
<tr>
<td>![Next]</td>
</tr>
<tr>
<td>![Print]</td>
</tr>
<tr>
<td>![Options]</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Get Help from the Office Assistant:
1. Press the <F1> key.
2. Type your question in the Office Assistant’s speech balloon and click Search or press <Enter>.
3. Click the help topic that best matches what you’re looking for (repeat as this step as necessary.)
Lesson 1-19: Changing the Office Assistant and Using the “What's This” Button

If you find that Clippit’s (the cartoon paperclip) antics are getting old, you can choose a different Office Assistant at anytime. People have different tastes and personalities, and that’s why Microsoft allows you to select from eight different Office Assistants (see Table 1-9: Office Assistants) to guide you through Excel. Of course, if you really hate the Office Assistant, you can always completely shut it off too.

The other topic covered in this lesson is how to use the “What’s This” button. During your journey with Excel you will undoubtedly come across a dialog box or two with a number of confusing controls and options. To help you find out what the various controls and options in a dialog box are there for, many dialog boxes contain a “What’s This” button that explains the purpose of each of the dialog box’s controls. This lesson will show you how to use the “What’s This” button, but first, let’s start taming the Office Assistant.

1. If necessary, select Help → Show the Office Assistant from the menu.
   The Office Assistant appears.

2. Right-click the Office Assistant and select Choose Assistant from the shortcut menu.
   The Office Assistant dialog box appears.
3. **Click the Back or Next button to see the available Office Assistants.**
   
   The Office Assistant you select is completely up to you. They all work the same—they just look and act different.

4. **Click OK when you find an Office Assistant you like.**
   
   If you find the Office Assistant annoying (a lot of people do) and want to get rid of it altogether here’s how:

5. **Right-click the Office Assistant**
   
   A shortcut menu appears.

6. **Select Hide from the shortcut menu.**
   
   You can always bring the Office Assistant back whenever you require it’s help by pressing the <F1> key. Now let’s move on to how to use the “What’s This” button to discover the purpose of confusing dialog box controls.

7. **Select Format → Cells from the menu and click the Font tab.**
   
   The Format cells dialog box appears. Notice the “What’s This” button located in the dialog box’s title bar just to the left of the dialog box’s close button?

8. **Click the “What’s This” button (†).**
   
   The mouse pointer changes to a †, indicating you can point to anything on the dialog box to find out what it does. The Normal Font check box is rather confusing it’s it? Move on to the next step and we’ll find out what it’s there for.

9. **Click the Normal Font check box with the † pointer.**
   
   A brief description of the Normal Font check box appears as shown in Figure 1-34.

10. **Close the Format Cells dialog box.**

---

**Table 1-9: Office Assistants**

<table>
<thead>
<tr>
<th>Office Assistant</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Clippit" /></td>
<td>Though nothing more than a thin metal wire, Clippit will help you find what you need and keep it together. Clippit is the default Office Assistant.</td>
</tr>
<tr>
<td><img src="image" alt="The Dot" /></td>
<td>Need a guide on the electronic frontier? Able to transform into any shape, the Dot will always point you in the right direction.</td>
</tr>
<tr>
<td><img src="image" alt="F1" /></td>
<td>F1 is the first of the 300/M series, built to serve. This robot is fully optimized for Office use.</td>
</tr>
<tr>
<td><img src="image" alt="The Genius" /></td>
<td>The mind of the Genius works at the speed of light. Harness his power of thought to save yourself time and energy.</td>
</tr>
<tr>
<td><img src="image" alt="Office Logo" /></td>
<td>The Office Logo gives you help accompanied by a simple spin of its colored pieces. It won’t distract you as you’re taking care of business.</td>
</tr>
<tr>
<td><img src="image" alt="Mother Nature" /></td>
<td>Transforming into images from nature, such as the dove, the volcano, and the flower, Mother Nature provides gentle help and guidance.</td>
</tr>
<tr>
<td><img src="image" alt="Links" /></td>
<td>If you’re on the prowl for answers in Windows, Links can chase them down for you.</td>
</tr>
<tr>
<td><img src="image" alt="Rocky" /></td>
<td>If you fall into a ravine, call Lassie. If you need help in Office, call Rocky.</td>
</tr>
</tbody>
</table>

---

Lesson 1-20: Closing a Workbook and Exiting Excel

Because the tasks covered in this lesson are so simple—closing a workbook and exiting the Excel program—this is one of the briefest lessons in the book. Before you close a workbook or exit Excel, you should always make sure you save any changes you’ve made to the active workbook.

1. Save the Income and Expenses worksheet by clicking the **Save button** on the Standard toolbar.
   
   You disk drive whirs as it saves the changes you’ve made to the worksheet. Once the worksheet is saved you can close it.

2. **Click the workbook Close button. (Make sure you click the worksheet Close button, not the Excel Program Close button.)**
   
   You will probably see two close buttons on your screen—make sure you click the lower close button. The close button located in the far upper-right hand corner of the screen would close the Excel program. The current worksheet closes, but the Excel program does not. You can close a worksheet when you’re finished working on it but still want to remain in the Excel program—perhaps to open and work on another worksheet. You’ve finished both this lesson and this chapter, so now you want to exit, or close the Excel program.

3. **Click the Close button on the Microsoft Excel Title Bar.**
   
   This time, click the Close button in the very far upper-right hand corner of the screen to close Excel. The Excel Program window closes and you return back to the Windows desktop.

---

**Figure 1-35**
Excel without any opened workbooks.

**Figure 1-36**
The Program and Workbook close buttons.

---

**Save button**
Other Ways to Save:
- Select **File → Save** from the menu.
- Press **<Ctrl> + <S>**.

**Close button**
Other Ways to Close a Workbook:
- Select **File → Close** from the menu.
That’s it! You’ve just completed your first chapter and are well on your way towards mastering Microsoft Excel. You’ve already learned some very important things: how to start Excel; enter values, labels, and formulas, create, preview, print, and save a worksheet; select and work with cell ranges, and use the AutoFill feature. You will use these skills all the time in your long career with Microsoft Excel.
Chapter One Review

Lesson Summary

Starting Excel
- Start Excel by clicking the Start button, selecting Programs, and selecting Microsoft Excel.

Understanding the Excel Screen
- Be able to identify the main components of the Excel program screen.

Using Menus
- To Use a Menu: Either click the menu name with the mouse pointer or press the <Alt> key and the letter that is underlined in the menu name.
- Word 2002’s new personalized menus hide more advanced commands from view. To display a menu’s hidden commands click the downward-pointing arrow (▼) at the bottom of the menu, or open the menu and wait a few seconds.
- To Change How Menus Work: Select View → Toolbars → Customize from the menu, check or clear either the Menus Show Recently Used Commands First and/or Show Full Menus After a Short Delay options, then click Close.

Using Toolbars and Creating a New Workbook
- To Use Excel’s Toolbars: Simply click the toolbar button you want to use. Leave the pointer over the button to display a screen tip of what the buttons does.
- To Stack the Standard and Formatting toolbars in Two Separate Rows: Click the button on either toolbar and select Show Buttons on Two Rows from the list.
- To Create a New Document: Click the New button on the Standard toolbar or select File → New from the menu.

Filling Out Dialog Boxes
- Be able to identify and use text boxes, list boxes, combo boxes, check boxes, and sheet tabs.

Keystroke and Right-Mouse Button Shortcuts
- Keystroke shortcuts: Press <Ctrl> and the letter that corresponds to the shortcut command at the same time.
- Right-mouse Button shortcut menus: Whenever you’re unsure or curious about what you can do with an object, click it with the right mouse button to display a list of commands related to the object.
Opening a Workbook

• **To Open a Workbook:** Click the [Open button](#) on the Standard toolbar, or select File → Open from the menu, or press \(<\text{Ctrl} > + <O>\).

• **To Save a Workbook:** Click the [Save button](#) on the Standard toolbar, or select File → Save from the menu, or press \(<\text{Ctrl} > + <S>\).

• **To Save a Workbook with a Different Name:** Select File → Save As from the menu and enter a different name for the workbook.

Saving a Workbook

• **To Save a Workbook:** Click the [Save button](#) on the Standard toolbar, or select File → Save from the menu, or press \(<\text{Ctrl} > + <S>\).

• **To Save a Workbook with a Different Name:** Select File → Save As from the menu and enter a different name for the workbook.

Moving the Cell Pointer

• **Using the mouse:** Select the cell you want to edit by clicking it with the mouse pointer or by using the keyboard arrow keys.

• **Using the keyboard:** Move the cell pointer by pressing the keyboard arrow key that corresponds to the direction you want to move.

• Pressing \(<\text{Enter} >\) moves the cell pointer down, \(<\text{Tab} >\) moves the cell pointer to the right, and \(<\text{Shift} > + <\text{Tab} >\) moves the cell pointer to the left.

• Use the horizontal and vertical scroll bars and buttons to view portions of the worksheet that are located off-screen.

Navigating a Worksheet

• \(<\text{Page Up} >\) moves up one screen, \(<\text{Page Down} >\) moves down one screen.

• \(<\text{Ctrl} > + <\text{Home} >\) moves to the first cell (A1) in a worksheet.

• \(<\text{Ctrl} > + <\text{End} >\) moves to the last cell with data in a worksheet.

• \(<\text{F5} >\) opens the Go To dialog box, where you can specify a cell address to jump to.

Entering Labels in a Worksheet

• Labels are used for worksheet heading and (usually) text. Excel treats information beginning with a letter as a label, and left-aligns it in the cell.

Entering Values in a Worksheet and Selecting a Cell Range

• Values are the numerical information in a worksheet that are usually used in calculations. Excel treats numbers, dates, and times as values and automatically right-aligns it in the cell.

• **To Select a Cell Range:** (Using the mouse) Click the first cell or the range and drag the mouse pointer to the last cell of the range. (Using the keyboard) Make sure the active cell is the first cell of the cell range, then press and hold down the \(<\text{Shift} >\) key while using the arrow keys to move the mouse pointer to the last cell of the range.
Calculating Value Totals with AutoSum

- 1) Click the cell where you want to insert the total, 2) Click the AutoSum button on the Standard toolbar, 3) Verify that the cell range selected is correct—if it isn’t select the cell range you want to total, 4) Press <Enter>.

Entering Formulas

- Every formula must start with the equal symbol (=).
- To Enter a Formula: 1) Select the cell where you want to insert the formula, 2) Press = (the equals sign), 3) Enter the formula, using values, cell references, operators, and functions, 4) Press <Enter>.
- To Reference a Cell in a Formula: Type the cell reference, for example B5, or simply click the cell you want to reference.

Using AutoFill

- 1) Enter at least two values into adjacent cells, 2) Select those cells, 3) Click and drag the cell pointer’s fill handle to complete the series in the cells you select.

Previewing and Printing a Worksheet

- To Print a Worksheet: Click the Print button on the Standard toolbar, or select File → Print from the menu, or press <Ctrl> + <P>.
- To Preview a Worksheet: Click the Print Preview button on the Standard toolbar, or select File → Print Preview from the menu.

Getting Help from the Office Assistant

- You can ask the Office Assistant (the cute animated character) your help questions in conversational English. This is the easiest and most common method of getting help.
- Press <F1> to open the Office Assistant, type your question in normal English, and click Search.

Changing the Office Assistant and Using the “What’s This” Button

- To Change Office Assistants: If necessary, select Help → Show the Office Assistant from the menu. Right-click the Office Assistant and select Choose Assistant from the shortcut menu. Click the Next or Back buttons until you find an Office Assistant you like, then click OK.
- To Hide the Office Assistant: Right-click the Office Assistant and select Hide from the shortcut menu.
- To See what a Control in a Dialog Box Does: Click the Dialog box “What’s This” button (located right next to the close button) and click the control you want more information on with the pointer.

Closing a Workbook and Exiting Excel

- To Close a Workbook: Click the workbook window’s close button or select File → Close from the menu.
- To Exit Microsoft Excel: Click the Excel program close button or select File → Exit from the menu.
Quiz

1. Right-clicking something in Excel:
   A. Deletes the object.
   B. Opens a shortcut menu listing everything you can do to the object.
   C. Selects the object.
   D. Nothing—the right mouse button is there for left-handed people.

2. Which of the following is NOT a way to complete a cell entry?
   A. Clicking the Enter button on the Formula bar.
   B. Pressing any arrow key on the keyboard.
   C. Pressing <Enter>.
   D. Pressing <Spacebar>.

3. Which of the following formulas is NOT entered correctly?
   A. =B7+14
   B. =B7*B1
   C. 10+50
   D. =10+50

4. Which of the following is NOT an example of a value?
   A. May 10, 2001
   B. Serial Number 50671
   C. 57%
   D. 350

5. Which symbol do formulas begin with?
   A. =
   B. @
   C. +
   D. ( 

6. You can reference cells in a formula by: (Select all that apply.)
   A. Typing the cell reference; for example B10.
   B. Clicking the cell(s) you want to reference with the mouse.
   C. Selecting Edit → Reference from the menu and type the cell reference.
   D. Clicking the Enter button on the Formula bar and clicking the cell with the mouse.

7. Cell ranges consist of two or more cells and are identified by the first and last cell in the range, such as F7:G10 (True or False?)

8. To save a workbook you: (Select all that apply)
   A. Press <Ctrl> +<F5>
   B. Select File → Save from the menu.
   C. Click the Save button on the Standard toolbar.
   D. Click Save on the Windows Start button.
9. You enter “300 Orders” in cell A1 and “250 Orders” in cell A2. You then select both cells and drag the fill handle down to cell A3. When you release the mouse button, which value will appear in cell A3?

A. 250 Orders  
B. 250  
C. 200 Orders  
D. 200

10. What symbol is used before a number to make it a label?

A. =  
B. ’ (apostrophe)  
C. " (quote)  
D. _ (underscore)

11. Without using the mouse or the arrow keys, what is the fastest way of getting to cell A1 in a spreadsheet?

A. Press <Home>.  
B. Press <Shift> + <Home>.  
C. Press <Ctrl> + <Home>.  
D. Press <Alt> + <Home>.

12. Which button do you click to add up a series of numbers?

A. The AutoSum button.  
B. The Formula button.  
C. The Total button.  
D. The QuickTotal button.

13. How do you select an entire column?

A. Select Edit → Select → Column from the menu.  
B. Click the column heading letter.  
C. Hold down the <Ctrl> key as you click anywhere in the column.  
D. Hold down the <Shift> key as you click anywhere in the column.

14. You want to manually spell check a workbook. You open the Tools menu but can't find the Spelling command. What's wrong?

A. The Spelling command is in the Edit menu silly!  
B. You need to display all the options in the Tools menu by clicking the downward-pointing arrow at the bottom of the menu.  
C. There isn’t a Spelling command.  
D. You need to display all the options in the Tools menu by pressing <F2>.

15. What key can you press to get help in any Windows-based program?

A. <F12>.  
B. <Esc>.  
C. <Scroll Lock>.  
D. <F1>. 
Chapter One: The Fundamentals

Homework

1. Find cell AA75 in any worksheet.

2. Using the skills you’ve learned in this chapter, create a worksheet similar to the one shown here (you can fill it in using your own numbers if you want.)

3. Create a Total row in row 10. Use the AutoSum function to find the totals for each quarter.

4. Preview and print your worksheet, and then save it as “Homework One” on your practice disk.

5. Make a silent vow that from this moment forward you will use Excel anytime you need to add together more than 8 numbers instead of a calculator.

Quiz Answers

1. B. Right-clicking an object displays a shortcut menu for the object.

2. D. There are a lot of ways to complete a cell entry, but pressing the <Spacebar> isn’t one of them.

3. C. 10+50 is missing the equal sign. It should be “=10+50”.

4. B. “Serial No. 50671” contains a number, but since it starts with letters Excel treats it as a label.

5. A. All formulas in Excel must begin with an equal sign (=). There’s no exception to this rule.

6. A and B. You can reference cells by typing their cell reference or clicking the cell or cell range you want to reference.

7. True. Cells ranges are identified by the first and last cell in the range, such as A1:B10.

8. B and C.

9. C.
10. B. Type an ' (apostrophe) before a number to make it a label.
11. C. Press <Ctrl> + <Home> to move the cell pointer to cell A1.
12. A. Click the AutoSum button.
13. B. Click the column heading letter of the column you want to select.
14. B. You need to display all the options in the Tools menu by clicking the downward-pointing arrow at the bottom of the menu.
15. D. The <F1> key brings up help in every Windows program.
Chapter Two: Editing a Workbook

Chapter Objectives:

- Enter and work with date values
- Edit, clear, and replace cell contents
- Cut, copy, paste, and move cells
- Work with and understand Absolute and Relatives cell references
- Insert and delete cells, rows, and columns
- Use Undo and Redo
- Check the spelling of your worksheets
- Use advanced print options
- Basic file management
- Insert cell comments

Chapter Task: Edit a mileage reimbursement report

Now that you have the Microsoft Excel basics down, this chapter will show you how to become a sophisticated Excel user. This chapter explains how to enter date values, cut, copy and paste information in your workbook, how to insert and delete columns and rows, undo any mistakes you might make, and even correct your spelling errors.

Prerequisites

- How to start Excel.
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- Move the cell pointer.
Lesson 2-1: Entering Date Values and using AutoComplete

Normally Excel treats dates in your worksheets as values rather than labels. The reason for this is simple—so you can perform calculations and formulas on them. For example, you can subtract one date from another to find how many days are between them. You can enter dates in using many different types of date formats, as shown in Table 2-1: Examples of Valid Date and Time Entries.

1. Start the Microsoft Excel Program.
2. Click the **Open button** on the Standard toolbar.
   The Open dialog box appears.
3. **Navigate to your Practice folder or disk.**
   The Open dialog box displays the Excel files in your Practice folder or disk.
4. Click the workbook named **Lesson 2A** in the file list box to select it and click **Open**.
   The workbook Lesson 2A opens and appears in the worksheet window. You don’t want to modify the original Lesson 2A workbook, so save it as a new workbook file with a different name—“Mileage Reimbursement”.
5. **Select File → Save As from the menu, type Mileage Reimbursement in the File name box and click Save.**
   Excel saves the workbook with the new name, Mileage Reimbursement, and closes the original document, Lesson 2A. Now you can work on the new workbook, Mileage Reimbursement, without modifying the original workbook, Lesson 2.
6. Click cell A11 to make it active.

7. Type 2/24 and press <Enter>.

   Notice that Excel completes the date entry by automatically inserting the current year for you. Excel will always assume that dates are from the current year, unless you specify otherwise.

   **NOTE:** Excel 2002 is Year 2000 compliant, which means you shouldn’t have to worry much about the dreaded year 2000 bug that plagues so many computers and applications. You should be aware, however, of how Excel evaluates two digit years, such as when you type 01/01/99 instead of 01/01/1999.

   Excel assumes any two-digit years entered between 01/01/30 and 12/31/99 are in the 20th century, so when you enter 10/3/54 Excel assumes you mean October 10, 1954. Excel assumes any two-digit years entered between 01/01/00 and 12/31/29 are in the 21st century, so when you enter 10/3/15 Excel assumes you mean October 10, 2015.

   You don’t have to enter your dates using a 10/5/98 format. Excel understands a variety of date formats. Try entering a date using a different format.

8. Type Feb 27 and press <Enter>.

   You can change how dates are formatted, so that 10/10/98 is displayed as October 10, 1998, but that’s in another upcoming lesson.

   Excel’s **AutoComplete** feature helps speed up data entry, especially if you’re using repetitive information.

9. Click cell B11 type Ma.

   As soon as you type the “Ma” in “Mankato” Excel cleverly recognizes what you’re typing from the cells in the B column, and displays the label “Mankato”. If you want to accept “Mankato” simply press <Enter> to confirm the cell entry. If you’re entering different word, such as “Manitoba” simply ignore Excel’s suggestion and finish typing “Manitoba”.

10. Press <Enter>.

    You can also use Excel’s **PickList** to help you enter labels in your worksheet. The PickList is a list of labels you’ve used and helps keep your information consistent. Here’s how to use the PickList:

11. Right-click cell B12 and select **Pick from List** from the shortcut menu.

    A list containing all the labels in the column appears—simply click the entry you want to use.

12. Select **Duluth** from the PickList.

### Table 2-1: Examples of Valid Date and Time Entries

<table>
<thead>
<tr>
<th>Date Entries</th>
<th>Time Entries</th>
</tr>
</thead>
<tbody>
<tr>
<td>October 17, 1995</td>
<td>5:45 PM</td>
</tr>
<tr>
<td>10/17/95</td>
<td>5:45 AM</td>
</tr>
<tr>
<td>10-17-95</td>
<td>5:45 (Excel assumes that it’s 5:45 AM)</td>
</tr>
<tr>
<td>17-Oct-95</td>
<td>17:45 (5:45 PM on a 24-hour clock)</td>
</tr>
<tr>
<td>Oct-17</td>
<td>(Excel assumes that it’s the current year.) 17:45:20 (5:45 PM and 20 seconds)</td>
</tr>
</tbody>
</table>
Lesson 2-2: Editing, Clearing, and Replacing Cell Contents

You can change or clear the contents of your cells anytime. To clear a cell entry simply select the cell or cell range you want to delete and press the <Delete> key. You don’t have to clear a cell entry if you want to replace it altogether—just select the cell and enter the new entry on top of the old entry.

There are a couple methods you can use to edit the contents of a cell. One method is to select the cell you want to edit, click the formula bar, and then edit the cell contents in the formula bar. Another method is to double-click the cell you want to edit and then editing the cell contents directly in the cell. Either method causes Excel go to Edit mode, and the Cancel and Enter buttons appear on the formula bar. In Edit mode the arrow keys move from character to character in the cell instead of from cell to cell. While Excel is in Edit mode you can also move the insertion point by clicking the I-beam pointer (I) where you want to insert text.

1. Click cell B3 to make it active.
2. Press <Delete> to clear the contents of the active cell.
3. Type Destination and press <Enter>.
4. Select the cell range G3:G10 by clicking cell G3 and holding down the mouse button and dragging it to cell G10.
5. Press the <Delete> key.

You can change or clear the contents of your cells anytime. To clear a cell entry simply select the cell or cell range you want to delete and press the <Delete> key. You don’t have to clear a cell entry if you want to replace it altogether—just select the cell and enter the new entry on top of the old entry.

There are a couple methods you can use to edit the contents of a cell. One method is to select the cell you want to edit, click the formula bar, and then edit the cell contents in the formula bar. Another method is to double-click the cell you want to edit and then editing the cell contents directly in the cell. Either method causes Excel go to Edit mode, and the Cancel and Enter buttons appear on the formula bar. In Edit mode the arrow keys move from character to character in the cell instead of from cell to cell. While Excel is in Edit mode you can also move the insertion point by clicking the I-beam pointer (I) where you want to insert text.

1. Click cell B3 to make it active.
2. Press <Delete> to clear the contents of the active cell.
3. Type Destination and press <Enter>.
4. Select the cell range G3:G10 by clicking cell G3 and holding down the mouse button and dragging it to cell G10.
5. Press the <Delete> key.

The contents of the cells in the selected range are deleted.
You don’t have to clear a cell’s contents before replacing them—just type in the new entry for the cell.

6. **Click cell A1 to make it active, then type Reimbursable Mileage Report and press <Enter>**.
   The original contents of the cell, the label “Mileage” are replaced with the new label “Reimbursable Mileage Report” as shown in Figure 2-3.

7. **Click cell C3**.
   This cell label needs to be changed from “Starting” to “Beginning.” There are several different methods you can use to edit the contents of a cell. The first is to select the cell you want to edit and then clicking the formula bar.

8. **Click anywhere in the formula bar**.
   Notice the status bar at the bottom of the Excel screen changes from “Ready” to “Edit” indicating Excel is in Edit mode. The blinking vertical line (|) that appears in the Formula bar is called the insertion point. Once Excel is in Edit mode you can move the insertion point in the formula bar to edit any area by either pressing the arrow keys or by moving the I-beam pointer (I) where you want to place the insertion point and clicking.

9. **Press the <Backspace> key**.
   Excel deletes one letter to the left of the insertion point.

10. **Press and hold the <Backspace> key to delete the word “Starting”, then type Beginning, and press <Enter>**.
    Another method you can use to edit a cell entry is to edit inside of the cell instead of in the Formula bar, by double-clicking the cell.

11. **Double-click cell D3**.
    The insertion point appears directly in the cell so that you can edit the cell’s entry.

12. **Type ing, so the cell reads “Ending” and press <Enter>**.
    You can edit cells that contain values and formulas just like cell entries with labels.

13. **Click cell E2, type Cost Per Mile, press <Tab> or <→> to move to cell F2, type .32, and then press <Enter>**.

14. **Click cell F4, click anywhere in the formula bar or double-click cell F4 to enter Edit mode**.
    You want to edit the formula in this cell so that it references whatever value is in cell F2 rather than the fixed value of .30, currently used in the formula.

15. **Press the <Backspace> three times to delete the 0.3**.
    Now that you’ve deleted the explicit, fixed value used in the formula, create a reference to cell F2.

16. **Click cell F2**.
    Excel automatically enters the cell reference, F2, to the formula in cell F4. The formula should now read =E4*F2.

17. **Press <Enter> to confirm the cell entry**.

18. **Click the Save button on the Standard toolbar**.
Lesson 2-3: Cutting, Copying, and Pasting Cells

You already know how to select a cell and ranges of cells using the mouse or keyboard. Once you have selected a cell or cell range, you can cut it, removing it from its original location, and then paste it in another location in the worksheet. Copying is similar to cutting, except the cells are copied instead of removed. Whenever you cut or copy something, it is placed in a temporary storage area called the Clipboard. The Clipboard is available to any Windows program, so you can cut and paste between different programs.

Cutting and copying cell entries is one of the more common tasks you’re likely to use in Excel (and in many other programs too!) This lesson will give you some practice cutting, copying and pasting in Excel.

If you are continuing from the previous Editing and Clearing Cell Contents lesson you can skip the first step of this exercise, otherwise you will need to open the Lesson 2B file…

1. If necessary, open the workbook named Lesson 2B on your Practice disk or in your Practice folder then save it as Mileage Report.
   First you need to select the cell or cell range you want to copy…

2. Click cell B5 to make it active.
   You want to copy this cell to the clipboard so you can paste it in a different location in the worksheet. There are several different methods of copying something—we’ll look at all of them. Try out each method and then use the method you prefer.

3. Click the Copy button on the Standard toolbar.
   A line of marching ants appears around the selected cell and the message “Select destination and press ENTER or choose Paste” appears on the status bar. Now you must move the cell pointer to the location where you want to paste the copied cell.

4. Select cell B11.
   This is where you want to paste the cell you copied. There are several methods you can use to paste what you copied or cut to the Windows clipboard.

Figure 2-4
Selecting and cutting a range of cells.

Figure 2-5
Pasting the selected cells in a new location in the workbook.
Chapter Two: Editing a Workbook

5. **Click the **Paste button **on the Standard toolbar.**
   The contents you copied from cell B5 are pasted into the active cell, B11, replacing its original contents. When you use the Paste command, Excel still keeps the copied cells in the Clipboard so that you can paste them again in other locations. Try pasting the copied cell in another location.

6. **Select cell B12 and repeat Step 5 to paste the copied cell again.**
   The copied cell is inserted in the active cell.
   Now that you’re familiar with copying, let’s try cutting several cells. You can cut (or copy) several cells at once by selecting the cells you want to cut (or copy.)

7. **Select the cell range A3:F12.**
   By now, you should know how to select a cell range.

8. **Click the **Cut button **on the Standard toolbar.**
   A line of marching ants appears around the selected cells and the message “Select destination and press ENTER or choose Paste” appears on the status bar. When you select a destination to paste a range of cells you only have to designate the first cell where you want to paste the cell range.

9. **Select cell A13.**
   This is where you want to paste the selected cell range.

10. **Click the **Paste button **on the Standard toolbar to paste the cut cell range.**
    Excel removes or “cuts” the selected cells from their original location and inserts them at the new location that begins with the active cell.

11. **Save the document by clicking the **Save button **on the Standard toolbar.**
    You can also copy, cut, and paste text between two different Windows programs—for example, you could copy information from an Excel worksheet and paste it in a Word document. The cut, copy, and paste commands (the toolbar buttons, menus, and/or keyboard shortcuts) you learned in Excel will work with most Windows applications.
Lesson 2-4: Moving and Copying Cells with Drag and Drop

Figure 2-6
Using drag-and-drop to move a range of cells to a new destination in a worksheet.

Figure 2-7
The worksheet after moving the cell range.

Figure 2-8
Confirmation to replace occupied cell contents.

In the previous lesson, you learned how to cut, copy, and paste cells. This lesson will show you another way to move or copy cells to different parts of a worksheet: using the drag-and-drop method. Drag-and-drop allows you to pick up a cell or cell range and place it in a new location on the worksheet—all without using any menus, toolbar buttons, or keystrokes!

In this lesson, you use drag-and-drop to move the block of text you cut and pasted in the previous lesson back to its original location.

1. **Select the cell range A13:F22.**
   
   You may have to scroll down the worksheet in order to see the cell range A13:F22. Once you have selected the cell range, you can move it using drag-and-drop.

2. **Position the pointer over any of the edges of the selected range, until it changes to a \( \downarrow \), then click and hold the mouse button, drag the selected range to cell A3 and release the mouse button.**

   As you drag the mouse, an outline of the cell range moves with the pointer, as shown in Figure 2-6. A tip box also appears while you drag the cell range, which displays the current position of the selected cell range as you move it. The selected cell range is dropped in the location, beginning with cell A3.

   **NOTE:** Dragging-and-dropping can be a bit tricky for some people, especially if they’re still new to using a mouse. It may take you several tries before you get dragging and dropping right. If you make a mistake and accidentally drop the
cell range in the wrong place click the Undo button (undo) on the Standard toolbar and then try it again.

You can also copy cells and cell ranges using the drag-and-drop method. The procedure is almost exactly the same, except you hold down the <Ctrl> key as you drag the cell or cell range.

3. **Select the cell range E2:F2.**

Now that you have selected the cells you want to copy, copy them to a new destination in the worksheet using drop-and-drag.

4. **Hold down the <Ctrl> key to copy the selected cell range and repeat Step 2 to copy the cell range to cell E1. Release the <Ctrl> key when you’re finished.**

Excel copies the selected cells to the new location.

5. **Select the cell Range E1:F1.**

If you drag-and-drop into occupied cells, Excel will ask you if you want to replace the existing cells, as shown in Figure 2-8.

6. **Using the drag-and-drop technique you’ve learned, drag and drop the selected cell range to cell A1.**

Since this cell is already occupied, Excel asks whether you want to replace the contents of the destination cells.

7. **Click Cancel.**

Excel cancels the drag-and-drop procedure. You might have noticed the label “Cost Per Mile” and the value “.32” appear twice in the worksheet. You don’t need this information to appear twice, so delete one of the entries.

8. **Select the cell Range E1:F1 and press <Delete> to clear the cell contents.**

Now you can save the changes you’ve made to the workbook.

9. **Save your work by clicking the Save button on the Standard toolbar.**

If you’ve made it through the last two lessons consider yourself an expert on moving and copying cells in Microsoft Excel. Actually, you can consider yourself an expert on copying and moving things in general because the techniques you’ve learned in the last two lessons—cutting, copying, pasting, and dragging-and-dropping—will work with almost any Windows program!

---

**Quick Reference**

**To Move Cells with Drop and Drag:**

1. Select the cell or the cell range you want to move.
2. Move the pointer to the border of the cell or cell range, click and hold down the mouse button and drag the cell or cell range to the upper-left cell of the area where you want to move the data.
3. Release the mouse button.

**To Copy Cells with Drop and Drag:**

- Follow the above procedure, only hold down the <Ctrl> key while you drag and drop the cell(s).
Lesson 2-5: Collecting and Pasting Multiple Items

If you do a lot of cutting, copying, and pasting you will probably appreciate Excel XP’s new and improved clip Office clipboard, which holds not one but twenty-four cut or copied objects.

You can use the Office Clipboard to collect and paste multiple items. For example, you can information in a Microsoft Excel workbook, switch to Microsoft Word and copy some text, switch to PowerPoint and copy a bulleted list, switch to Access and copy a datasheet and then switch back to Excel and paste the collection of copied items.

1. Select View → Task Pane the menu.
   The task pane appears in the left side of the Excel window. Next you need to display the Clipboard task pane.

To display the Clipboard:
1. Select View → Task Pane from the menu…
2. … then click the arrow in the task pane and select Clipboard
2. Click the Other Task Panes arrow in the task pane window and select Clipboard.
   Anything you cut or copy (up to 24 items) will appear in the Clipboard.

3. Select the cell range A6:D6 and click the Copy button on the Standard toolbar.
   You’ve just added the contents of the cell range A6:D6 to the Office clipboard.

4. Select the cell range A10:D10 and click the Copy button on the Standard toolbar.
   Excel adds the copied cell range to the Office XP clipboard as shown in Figure 2-9.
   Several Excel icons appear on the Clipboard toolbar—these represent everything you
   have cut or copied recently in any Office XP program. If any additional icons appear in
   the clipboard it’s because you’re already cut or copied some information earlier.
   Let’s add one more item to the clipboard.

5. Select the cell range A12:D12 and click the Copy button on the Standard toolbar.
   Another Excel icon appears on the clipboard task pane. The type of clipboard icon
   indicates which program the object was collected from, as described in Table 2-2:
   Icons in the Clipboard Toolbar.
   To paste an object from the Office clipboard simply click the object you want to paste.
   Or, you can paste all the objects in the clipboard by clicking the Paste All button in the
   clipboard task pane.

6. Click cell A13 and click the Paste All button in the task pane.
   Excel pastes all the contents of the Office clipboard. Let’s see if you remember how to
   clear cell contents…

7. Select the range of pasted cells (it should be A11:F15) and press the <Delete> key.

### Table 2-2: Icons in the Clipboard Toolbar

<table>
<thead>
<tr>
<th>Clipboard Icon</th>
<th>Description Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Object cut or copied from a Microsoft Access database</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Object cut or copied from a Microsoft Excel workbook</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Object cut or copied from a Microsoft PowerPoint presentation</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Object cut or copied from a Microsoft Word document</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Web page contents cut or copied from Microsoft Internet Explorer</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Cut or copied graphic object</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Object cut or copied from a program other than Microsoft Office XP</td>
</tr>
</tbody>
</table>
Lesson 2-6: Working with Absolute and Relative Cell References

One of the more difficult Excel concepts you need to understand is the difference between relative and absolute cell references. You should already know that a cell reference identifies a cell or a range of cells on a worksheet and tells Microsoft Excel where to look for values you want to use in a formula. Here then, is the description and differences between absolute and relative cell references:

- **Relative**: Relative references tell Excel how to find another cell starting from the cell that contains the formula. Using a relative reference is a lot like giving someone directions that explain where to go from where the person is currently standing. When a formula containing relative references is moved, it will reference new cells based on their location to the formula. Relative references are the default type of references used in Excel.

- **Absolute**: Absolute references always refer to the same cell address, even if the cell is moved to a new location.

If you’re continuing from the previous Copying and Pasting lessons you can skip the first step of this exercise, otherwise you will need to open the Lesson 2B file…

1. **If necessary, open the workbook named Lesson 2B on your Practice disk or in your Practice folder then save it as Mileage Report.**
   
   First we need to create a simple formula…

2. **Click cell E5, type the formula =D5-C5 and press <Enter>.**
   
   You’ve just created a simple formula that finds out the number of miles driven to a location by subtracting the ending mileage from the beginning mileage. Instead of retyping the total miles formula for every one of the destinations, you can copy the formula using any of the copy and paste methods you’ve already learned. The easiest and fastest way of copying the formula to the other cells is using the AutoFill function.
3. **Click cell E5 and position the pointer over the fill handle of cell E5, until it changes to a †, click and hold the mouse and drag the fill handle down to cell E12 and release the mouse button, as shown in Figure 2-11.**

   Poof! AutoFill copies the formula you entered in cell E5 to the cells you selected, saving you a lot of time if you manually entered the formulas yourself. Now let’s take a look at what is meant by a **relative cell reference**.

4. **Click cell F5 to make it active.**

   Look at the formula bar. The formula that Excel copied to this cell isn’t exactly the one you entered in cell E5. Instead of the original formula you entered, =D5-C5, this cell contains the formula =D6-C6. Do you see what happened? Excel copied the formula, but substituted new cell references so that although the location of the cell has changed, its relationship with the cells in the formula hasn’t. This is an example of **relative cell addresses**—they are based on their position relative to the cell that contains the formula.

   Relative cell addresses are almost always the best way to reference other cells in formulas, which is why they are the default way Excel uses to reference cells. Sometimes, however, you might want a cell reference to always refer to a particular cell address. In this case, you would use an **absolute cell reference**, which always refers to a specific cell address, even if you move the formula to a new location. Create another formula to see how to use an absolute cell reference.

5. **Select cell F5, type =, click cell E5 (the total miles), type * (the multiplication operator), click cell F2 (the cost per mile), and complete the formula by pressing <Enter>.**

   Great! You’ve just created a formula that multiplies the totals miles driven by the cost per mile, currently .32. Now use AutoFill to copy the formula to the other cells.

6. **Position the pointer over the fill handle of cell F5, until it changes to a †, click and hold the mouse and drag the fill handle down to cell F12 and release the mouse button.**

   Excel copies the formula, but what went wrong? Let’s take a look.

7. **Click cell F6 to make it active.**

   Look at the formula bar. The formula, =E6*F3, that Excel copied to this cell is not correct. Look at cell F3—there’s nothing there to multiply (unless you consider the text label), hence the #VALUE! error message. You need to use an **absolute reference** so the formula always refers to cell F2, even if a formula is moved or copied.

8. **Click cell F5 to make it active and click anywhere in the Formula bar to change to Edit mode.**

9. **Verify the insertion point is touching the F2 in the formula and press the <F4> key.**

   Dollar signs appear, changing the F2 reference to $F$2—indicating it is an absolute reference. You can create an absolute reference to a cell by placing a dollar sign ($) before the parts of the reference that do not change. To create an absolute reference to cell A1, for example, add dollar signs to the formula: $A$1. Pressing <F4> changes a relative cell reference to an absolute cell reference.

10. **Press <Enter> and repeat Step 6 to copy the formula to the other cells.**

    This time the formula is copied correctly. The first cell reference in the formula is relative and changes based on the formula’s location. The second cell reference in the formula, ($F$2), on the other hand, is an absolute cell reference and always points to cell F2, regardless of the formula’s location.
Lesson 2-7: Using the Paste Special Command

Excel’s *Paste Special* command lets you specify exactly want to copy. For example, you can use the Paste Special command to copy the resulting value of a formula without copying the formula itself, or to copy the values of a range of cells without any of the cell’s formatting options.

If you’re continuing from the previous Absolute and Relative Address lesson you can skip the first step of this exercise, otherwise you will need to open the Lesson 2C file...

1. If necessary, open the workbook named *Lesson 2C* on your Practice disk or in your Practice folder then save it as *Mileage Report*.
   First we need to copy something...
2. Select the cell range E4:E12 and click the *Copy button* on the Standard toolbar (or use the keyboard shortcut: `<Ctrl>` + `<C>`).
The cell range is copied to the clipboard.
3. **Select cell E14 and click the Paste button on the Standard toolbar (or use the keyboard shortcut: <Ctrl>+<V>).**

Excel pastes the contents of the copied cells, as shown in Figure 2-13. Notice, however, that the resulting values from the copied formulas are all 0. Instead of copying the cell formulas, you wanted to copy the cell values. You can do this with the Paste Special command. Notice the Paste Options button that appears next to the pasted information. You can use this button to specify how you want information pasted.

4. **Position the pointer over the Paste Options button.**

A drop-down arrow appears on the Paste Options button. Click this arrow to display a list of various options for how information is pasted into your document.

5. **Click the Paste Options button arrow and select Values from the list.**

Excel pastes the resulting values from the copied cell range formulas instead of pasting the formulas themselves. The Paste Options button contains the most common paste commands – but not all of them. To see every available paste command (most of which you will never use) you need to use the Edit → Paste Special command.

6. **Select cell G4, type 1.25 and press <Enter>.**

7. **Select cell G4, copy the cell’s contents by clicking the Copy button on the Standard toolbar, select the cell range E4:E12, and then select Edit → Paste Special from the menu.**

The Paste Special dialog box reappears. This time you will use an operation to multiply the value of the copied cell with the values in the selected cell range.

8. **Select the Multiply option under the Operations section and click OK.**

The dialog box closes and the selected cell range is multiplied by the value of cell G5.

Table 2-3: Paste Special Options describes the options in the Paste Special dialog box.

<table>
<thead>
<tr>
<th>Paste Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Pastes all cell contents and formatting. Same as the Paste command.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Pastes only the formulas as entered in the formula bar.</td>
</tr>
<tr>
<td>Values</td>
<td>Pastes only the values as displayed in the cells (very useful!)</td>
</tr>
<tr>
<td>Formats</td>
<td>Pastes only cell formatting. Same as using the Format Painter button.</td>
</tr>
<tr>
<td>Comments</td>
<td>Pastes only comments attached to the cell.</td>
</tr>
<tr>
<td>Validation</td>
<td>Pastes data validation rules for the copied cells to the paste area.</td>
</tr>
<tr>
<td>All except borders</td>
<td>Pastes all cell contents and formatting applied to the copied cell except borders.</td>
</tr>
<tr>
<td>Operations</td>
<td>Specifies which mathematical operation, if any, you want to apply to the copied data. For example, you could multiply the pasted data by 5.</td>
</tr>
<tr>
<td>Skip Blanks</td>
<td>Avoids replacing values in your paste area when blank cells occur in the copy area.</td>
</tr>
<tr>
<td>Transpose</td>
<td>Changes columns of copied data to rows, and vice versa.</td>
</tr>
<tr>
<td>Link</td>
<td>Links the pasted data to the source data.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Use the Paste Special Command:

1. Cut or copy a cell or cell range using standard cut and copy procedures.
2. Click the Paste button on the Standard toolbar to paste the information.
3. Position the pointer over the Paste Options button that appears, click the Paste Options button arrow and select the desired paste option. Or...

Select Edit → Paste Special from the menu.
Lesson 2-8: Inserting and Deleting Cells, Rows, and Columns

While working on a worksheet, you may need to insert new cells, columns, or rows into your worksheet. Other times you may need to delete existing cells, columns, or rows from the worksheet. When you insert cells, you must shift any existing cells down or to the right to make room from the new cells. Likewise, when you delete cells (which is not the same as clearing the cell contents) you must shift any existing cells to fill the space left by the deletion.

In this lesson, you will get some practice inserting and deleting cells, rows, and columns. If you're continuing from the previous Absolute and Relative Address lesson you can skip the first step of this exercise, otherwise you will need to open the Lesson 2C file...

1. If necessary, open the workbook named Lesson 2C on your Practice disk or in your Practice folder then save it as Mileage Report.
   First you need to specify where you want to insert the new cells...

2. Select the cell range A2:F2.
   This is where you want to insert the new cells.

3. Select Insert → Cells from the menu.
   The Insert dialog box appears, as shown in Figure 2-15. You can choose to shift the existing cells to the right or down, or you can insert an entire row or entire column. The Shift cells down option is selected by default. This is the option you want to use. You’re going to be inserting a new row of cells.

4. Click OK.
   Excel inserts six new cells and shifts the cells below down one row.
You can also insert entire columns and rows using a couple different methods:

- **Menu:** Select the column or row heading where you want to insert the new column or row and select `Insert → Rows → Columns` from the menu.
- **Shortcut Menu:** Right-click the selected row or column heading(s) and select `Insert` from the shortcut menu.

5. **Select the second and third rows by clicking the 2 row heading and dragging the pointer to the 3 row heading** and then releasing the mouse button.

You’ve selected both the sixth and seventh row.

6. **Right-click either of the selected row headings and select **Insert** from the shortcut menu.**

Excel inserts two new rows. Inserting a column is almost the same as inserting a row.

7. **Select the cell range F3:F15 and select **Insert → Cells** from the menu.**

The Insert dialog box reappears. This time you want to shift the existing cells to the right. Based on the selected cell range, Excel recognizes this is the most likely option, so the Shift cells right option is selected by default.

8. **Click OK.**

Excel inserts the new cells and shifts the selected cell range to the right.

Deleting cells, cell ranges, columns, and rows is just as easy and straightforward as inserting them.

9. **Repeat the procedure you learn in Step 5 to select the second, third, and fourth rows.**

10. **Select **Edit → Delete** from the menu.**

The selected rows are deleted. You can also delete cells using the shortcut menu method:

11. **Right-click the F column heading and select **Delete** from the shortcut menu.**

Excel deletes the entire F column.

That’s it! You’ve learned how to insert and delete cells, columns, and rows to and from your worksheets.

---

**Quick Reference**

**To Insert a Row or Column:**

1. Select the row or column headings where you want to insert the column or row.

2. Right-click the selected row or column heading(s) and select `Insert` from the shortcut menu.

Or...

Select `Edit → Insert Columns` or `Insert Rows` from the menu.

**To Delete a Row or Column:**

1. Select the row or column heading(s) you want to delete.

2. Right-click the selected row or column heading(s) and select `Delete` from the shortcut menu.

Or...

Select `Edit → Delete` from the menu.

**To Delete a Cell Range:**

1. Select cell range you want to delete.

2. Right-click the selection and select `Delete` from the shortcut menu. Or select `Edit → Delete` from the menu.

3. Specify how you want adjacent cells shifted.
Lesson 2-9: Using Undo, Redo, and Repeat

You may not want to admit this, but you're going to make mistakes when you use Excel. You might accidentally delete a column or row you didn't mean to delete, or paste something you didn't mean to paste. Fortunately, Excel has a wonderful feature called undo that does just that—undoes your mistakes and actions, making them as though they never happened. Excel can undo up to 16 of your last actions or mistakes. This lesson explains how you can undo both single and multiple mistakes, and how to redo your actions in case you change your mind.

1. Select cell A1 to make it active and press the <Delete> key to delete the worksheet's title.

The worksheet's title, “Reimbursable Mileage Report”, disappears. Whoops! You didn’t really want to delete that! Watch how you can undo your “mistake.”
2. **Click the Undo button.**
   
   Poof! The deleted title “Reimbursable Mileage Report” is back again. Hmmm… maybe you did want to erase the worksheet title after all. Anything that can be undone can be redone if you change your mind or want to “undo an undo.” Here’s how you can redo the previous clear command.

3. **Click the Redo button.**
   
   The contents of cell A1, the worksheet title, disappear again.
   
   Often you will probably make not one, but several mistakes, and it may be a minute or two before you’ve even realized you’ve made them. Fortunately, the programmers at Microsoft thought of this when they developed Excel, because the undo feature is multileveled—meaning you can undo up to 16 of the last things you did. The next few stops will show you how you can undo multiple errors.

4. **Select cell F2 to make it active, type .35, and press <Enter>.**
   
   There’s your second mistake (the first was deleting the worksheet title in cell A1.)

5. **Select the fourth and fifth rows in the worksheet by clicking the 4 row heading, holding down the mouse button and dragging the pointer over the 5 row heading and releasing the mouse button.**
   
   Now that you have selected the fourth and fifth rows, you can delete them.

6. **Right-click the selected 4 or 5 row heading and select Delete from the shortcut menu.**
   
   The fourth and fifth rows are deleted from the worksheet. Mistake number three. You’ve made enough mistakes now to see how multilevel undo works. Here’s how to undo all of your mistakes.

7. **Click the downward pointing arrow to the right of the undo button.**
   
   A list of your recent actions appear beneath the Undo button. Notice that there are more actions listed than just your three recent “mistakes.” If you wanted you could undo the last sixteen actions. You don’t want to undo the sixteen actions—just the last three mistakes.

8. **Select the word Clear from the undo list (it should be the third one on the list.)**
   
   The last three changes you made to the workbook—deleting two rows, typing .35 in cell F2, and clearing the worksheet’s title—are all undone.
   
   The opposite of the Undo command is the Repeat command, which repeats your last command or action, if possible. Here’s how to use it.

9. **Select the cell range A3:A12, right-click the selection, select Delete from the shortcut menu and click OK.**
   
   You’ve just deleted the Date column. Now let’s see how you can repeat your last command…

10. **Select the cell range D3:D12 and press <Ctrl> + <Y>.**
    
    Excel repeats your last command and deletes the Total Miles range.

11. **Click the Undo button on the Standard toolbar twice to undo your deletions, and then save your work.**
Lesson 2-10: Checking Your Spelling

Spell check used to be a feature only available in word processing programs—but no more! You can use Excel’s spell checker to find and correct any spelling errors that you might have made in your workbooks. Excel’s spell checker is shared and used by the other programs in the Microsoft Office suite. Any words you add to the custom spelling dictionary in one Microsoft Office program will be available in all the other programs. Worksheets are not the same as documents created by word processors and may contain abbreviations that the spell checker may not recognize. When this happens click either Ignore to ignore the abbreviation, or Add to add the abbreviation to the custom spelling dictionary.

1. **Press** `<Ctrl>` + `<Home>` **to move to the first cell in the worksheet, A1.**
   Excel starts checking the spelling of the words in a worksheet at the active cell and stops whenever it encounters a word that is not found in its dictionary.

2. **Click the Spelling button on the Standard toolbar.**
   The Spelling dialog box appears; as shown in Figure 2-20, with the misspelled word “Amuont” listed as the first misspelled word in the worksheet. Excel lists several possible suggestions for the correct spelling of the word.

3. **Click Amount in the Suggestions list and click Change.**
   Excel makes the spelling correction for you. The spell checker moves on and selects the word “Cloquet” as the next misspelled word in the worksheet. Excel couldn’t find the word “Cloquet” in its dictionary, but since it is the name of a city and is spelled correctly you can ignore it.

**Spelling button**
Other Ways to Spell Check:
- Select **Tools → Spelling** from the menu.
- Press `<F7>`.
4. **Click Ignore All** to ignore all occurrences of the word “Cloquet” in the worksheet.
   
   When the spell checker can’t find any more incorrectly spelled words, Excel will indicate the spelling check is complete by displaying the dialog box shown in Figure 2-22.

5. **Click the Save button** on the Standard toolbar to save the changes you’ve made to the worksheet.

   No doubt about it, the spell checker is a great tool to assist you in creating accurate worksheets. It’s important to note, however, that Excel won’t catch all of your spelling errors. For example, if you mistakenly type the word “Repeat” when you meant to type “Report” Excel won’t catch the mistake because it because “Repeat” is a correctly spelled word.

---

**Quick Reference**

To Check the Spelling in a Worksheet:
- Click the **Spelling button** on the Standard toolbar.

Or...
- Select **Tools → Spelling** from the menu.

Or...
- Press `<F7>`.
Lesson 2-11: Finding and Replacing Information

Imagine you are working on a huge worksheet that tracks the feeding patterns of various squirrels. You’re almost finished with the worksheet when you realize that you’ve mistakenly referred to one of the species of squirrels you’re tracking—flying squirrels—not by their proper scientific name “Sciuridae Glaucomys” but by the scientific name for the common gray squirrel “Sciuridae Sciurus.” Yikes! It will take hours to go back and find every instance of “Sciuridae Sciurus” and replace it with “Sciuridae Glaucomys.” It could… or it could take you less than a minute if you use Excel’s find and replace function.

This lesson explains how to find specific words, phrases, and values in your workbooks, and how you can automatically replace those words, phrases, and values.

1. Press <Ctrl> + <Home> to move to the beginning of the worksheet, cell A1.

2. Select Edit → Find from the menu.

   The Find dialog box appears, as shown in Figure 2-23.

3. In the Find what box type Minneapolis.

   You want to find every occurrence of the phrase “Minneapolis” in the worksheet.

4. Click the Find Next button.

   Excel jumps to the first occurrence of the word “Minneapolis” it finds in the worksheet.

5. Click the Find Next button.

   Excel jumps to the next occurrence of the word “Minneapolis” in the worksheet.

6. Click Close to close the Find dialog box.

   The Find dialog box closes. You can also replace information in a worksheet.

7. Select Edit → Replace from the menu.

   The Replace dialog box appears, as shown in Figure 2-24.
8. In the **Find what box** text box type **Mankato**.
   You want to replace every occurrence of the word “Mankato” with the word “St. Peter.”

9. Select the **Replace with box** by clicking it or by pressing the `<Tab>` key and type **St. Peter**.

10. **Click Replace All**.
    Excel finds all the occurrences of the word “Mankato” in the worksheet and replaces them with the word “St Peter.”

    **NOTE:** Think before you use the Replace All button—you might not want it to replace every instance of a label or value! You can find and replace each individual occurrence of a label or value by clicking Find Next and then Replace.

11. **Click Close**.
    The Replace dialog box disappears and you’re back to your worksheet. Notice how all the occurrences of the word “Mankato” have been replaced by “St. Peter.”

---

**Quick Reference**

**To Find Information in a Workbook:**
1. Select **Edit → Find** from the menu.
   Or…
   Press **<Ctrl> + <F>**.
2. Enter the text you want to search for in the Find what box.
3. Click the **Find next** button.
4. Repeat Step 3 until you find the text you’re looking for.

**To Find and Replace Information:**
1. Select **Edit → Replace** from the menu.
   Or…
   Press **<Ctrl> + <H>**.
2. Enter the text you want to search for in the Find what box.
3. Enter the text you want to replace that text with in the Replace with box.
4. Click the **Find next** button.
5. Click the **Replace** button to replace the text.
6. Repeat Steps 4 and 5 if there is more than one occurrence that you want to replace.
   Or…
   Click **Replace All** to search and replace every occurrence of text in the workbook.
Lesson 2-12: Advanced Printing Options

You already know how to print, in this lesson you will become an expert at printing. This lesson explains how to print more than one copy of a document, send a document to a different printer, and print specific pages of a document.

1. **Click File → Print from the menu.**
   The Print dialog box opens, as shown in Figure 2-26. The Print dialog box is where you can specify printing options when you print your workbook. Several commonly used print options you might specify would be: how many pages to print, specific pages to print, or to which printer to print (if your computer is attached to more than one printer.) See Table 2-4: Print Dialog Box Options for a description of what print options are available.

2. **In the Number of copies box, type 2.**

3. **Click OK.**
   The Print dialog box closes, and Excel prints two copies of your worksheet (if your computer is attached to a printer.)

Table 2-4: Print Dialog Box Options on the following page explains some of the other print options you can use when printing a worksheet—how to print a specific page or a range of pages, for example.
### Table 2-4: Print Dialog Box Options

<table>
<thead>
<tr>
<th>Print option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Used to select which printer to send your workbook to when it prints (if you are connected to more than one printer.) The currently selected printer is displayed.</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays a dialog box with options available for your specific printer such as what paper size you’re using, if your document should be printed in color or black and white, etc.</td>
</tr>
<tr>
<td>Print to file</td>
<td>Prints the workbook to a file instead of sending to the printer.</td>
</tr>
<tr>
<td>Page range</td>
<td>Allow you to specify what pages you want printed. There are several options here:</td>
</tr>
<tr>
<td></td>
<td><strong>All:</strong> Prints the entire document</td>
</tr>
<tr>
<td></td>
<td><strong>Current page:</strong> Prints only the page of the workbook you’re currently on.</td>
</tr>
<tr>
<td></td>
<td><strong>Selection:</strong> Prints only selected cells.</td>
</tr>
<tr>
<td></td>
<td><strong>Pages:</strong> Prints only the pages of the workbook you specify. Select a range of pages with a hyphen (like 5-8) and separate single pages with a comma (like 3,7).</td>
</tr>
<tr>
<td>Number of copies</td>
<td>Specify the number of copies you want to print.</td>
</tr>
<tr>
<td>Print what</td>
<td>Allow you to select what is printed: the currently selected cells, the active sheet(s), or the entire workbook.</td>
</tr>
<tr>
<td>Options</td>
<td>Lets you specify other printing options, such as printing a document in reverse order (from the last page to the first.)</td>
</tr>
</tbody>
</table>
Lesson 2-13: File Management

File management includes moving, copying, deleting, and renaming the files you’ve created. Although it’s a little easier to work with and organize your files using Windows Explorer or My Computer you can also perform a surprising number of file management chores right from inside Microsoft Excel XP—especially with its new and improved Open and Save dialog boxes.

1. Click the Open button on the Standard toolbar.

The Open dialog appears. The Open dialog box is normally used to open files, but you can also use it to perform several file management functions. There are two different ways to access file management commands from inside the Open or Save As dialog boxes:
   - Select a file and then select the command you want from the dialog box’s Tools menu.
   - Right-click a file and select the command you want from a shortcut menu.

2. Right-click the Rename Me file.

A shortcut menu appears with a list of available file management commands for the selected file.

3. Select Rename from the shortcut menu, type Home Budget and press <Enter>.

You have just changed the name of the selected file from “Rename Me” to “Home Budget”. Instead of right-clicking the file, you could have selected it and then selected Rename from the Tools menu. Move on to the next step to learn how to delete a file.

4. Click the Home Budget file to select it and press the <Delete> key.

A dialog box appears, asking you to confirm the deletion of the Home Budget file.
5. **Click Yes.**

The Home Budget file is deleted. If you work with and create numerous files, you may find it difficult to remember what you named a file. To find the file(s) you’re looking for, it can help to preview your files without opening them.

6. **Click the View button arrow and select Preview.**

The Open dialog changes the display of Excel files on the Practice disk from List View to Preview View. To see the contents of a file, select it in the file list on the left side of the dialog box and it will appear in the Preview area to the right side of the dialog box. Try previewing the contents of a file without opening it now.

**NOTE:** You must save Excel workbooks with a Picture Preview in order to display a preview in the Open dialog box. To do this, before saving any file select File → Properties, click the Summary tab, and verify that the Save picture preview check box is checked.

7. **Click the Lesson 1 file.**

The Lesson 1 file is selected and a preview of its contents appear in the Preview section. Change back to List mode to display as many files in the window as possible.

8. **Click the View button arrow, select List to display the files in list view, then close the dialog box by clicking Cancel.**

### Table 2-5: File Shortcut Menu Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Opens the selected file.</td>
</tr>
<tr>
<td>Open Read-Only</td>
<td>Opens the selected file so that it can be read but not changed.</td>
</tr>
<tr>
<td>Open as Copy</td>
<td>Creates a copy of the selected file with the name “Copy of” and the name of</td>
</tr>
<tr>
<td></td>
<td>the original file, and then opens the new, copied file.</td>
</tr>
<tr>
<td>Print</td>
<td>Sends the selected file to the default printer.</td>
</tr>
<tr>
<td>Quick View</td>
<td>Displays the contents of the selected file without opening the file.</td>
</tr>
<tr>
<td>Send To</td>
<td>Depending on how your computer is setup, it lets you send the selected file</td>
</tr>
<tr>
<td></td>
<td>to a printer, to an email recipient, to a fax, or to a floppy drive.</td>
</tr>
<tr>
<td>Cut</td>
<td>Used in conjunction with the Paste command to move files. Cuts, or removes</td>
</tr>
<tr>
<td></td>
<td>the selected file from its current folder or location.</td>
</tr>
<tr>
<td>Copy</td>
<td>Used in conjunction with the Paste command to copy files. Copies the</td>
</tr>
<tr>
<td></td>
<td>selected file.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes a cut or copied file or files.</td>
</tr>
<tr>
<td>Create Shortcut</td>
<td>Creates a shortcut—a quick way to a file or folder without having to go to</td>
</tr>
<tr>
<td></td>
<td>its permanent location—to the file</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected file or files.</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the selected files</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays the properties of the selected file, such as when the file was</td>
</tr>
<tr>
<td></td>
<td>created or last modified, or how large the file is.</td>
</tr>
</tbody>
</table>

### Quick Reference

**Basic File Management in the Open Dialog box:**

1. Open the Open or Save As dialog boxes by selecting Open or Save As from the File menu.

2. Right-click the file and refer to Table 2-5: File Shortcut Menu Commands for a list things you can do to the selected file or select the file and select a command from the Tools menu.

**To Change How Files are Displayed:**

- Click the View button arrow and select a view.
Lesson 2-14: Inserting Cell Comments

Sometimes you may need to add notes to your workbook to document complicated formulas, questionable values, or leave a comment to another user. Excel’s cell comments command helps you document your worksheets and make them easier to understand. Think of cell comments as Post-It Notes that you can attach to any cell. Cell comments appear whenever you point at the cell they’re attached to.

1. **Right-click cell B12.**
   A shortcut menu appears.

2. **Select Insert Comment from the shortcut menu.**
   A comment box appears by the cell, as shown in Figure 2-29. Notice a name appears at the beginning of the comment—this is the user name, which can be found by selecting Tools → Options from the menu and clicking the General tab. The user name appears on the comment so that other users will know who added the comment. You can add a note to the comment box by just typing.

3. **Type This date may be incorrect.**
   Now that you’ve finished writing the note, you can close the comment box.

4. **Click anywhere outside the comment box to close it.**
   The comment box closes. Notice a small red triangle now appears in the upper-right corner of cell B12. This triangle indicates that there is a comment attached to the cell. Displaying a comment is very, very easy.
5. **Position the pointer over cell B12.**
   The comment appears next to the cell whenever the pointer is positioned over it. Here’s how to edit a comment:

6. **Right-click cell B12.**
   A shortcut menu appears.

7. **Select **Edit Comment** from the shortcut menu.**
   An insertion point ( ) appears at the end of the text in the comment box, indicating you can edit the text in the comment box. Add some more text to the comment box.

8. **Press the `<Spacebar>`, then type** *Could you check my receipts to verify this?*
   You can also change the size and position of a comment box while in edit mode. Notice the white boxes that appear at the corners and sides of the comment box, as shown in Figure 2-29? These are sizing handles, which you can use to change the size of the box.

9. **Position the pointer over the lower-right sizing handle, until the pointer changes to a , then click and hold the left mouse button and drag the mouse diagonally up and to the left about a half-inch, then release the mouse button.**
   The comment is resized, and the text is wrapped accordingly. You can also move a comment to a different location on the screen.

10. **Position the pointer over the border of the comment box, until it changes to a , click and drag the comment down an inch, then release the mouse button to drop the comment.**
    You’ve just moved the comment to a new position on the worksheet. Now delete the comment.

11. **Right-click cell B12 and select **Delete Comment** from the shortcut menu.**

---

**Quick Reference**

**To Insert a Comment:**
1. Right-click the cell you want to attach a comment to.
2. Select **Insert Comment** from the shortcut menu.
3. Type the comment.
4. Click anywhere outside the comment area when you’re finished.

**To Edit a Comment:**
1. Right-click the cell that contains the comment you want to edit.
2. Select **Edit Comment** from the shortcut menu.
3. Edit the comment.
4. Click anywhere outside the comment area when you’re finished.

**To Delete a Comment:**
1. Right-click the cell that contains the comment you want to edit.
2. Select **Delete Comment** from the shortcut menu.
Lesson 2-15: Understanding Smart Tags

Smart tags are one of the biggest additions to Microsoft Office XP—and they make working with Excel a lot easier. Smart tags are similar to right-mouse button shortcuts—you click smart tags to perform actions on various items. Smart tags appear when Excel XP will recognize certain types of information, such as the name of a person in your Address Book. Excel marks these items with a purple triangle and a smart tag indicator. Clicking a smart tag indicator displays a list of things that you can do to the smart tag, such finding the current stock price for a financial symbol. Other smart tag-like buttons appear when you paste information and make a mistake in a formula. Clicking these buttons specifies how Excel pastes or corrects information.

In this lesson you will learn what smart tags look like and how to use them. First, we need to ensure that all the Smart Tag options are active. Here’s how to view Excel’s Smart Tag options:

1. Select Tools → AutoCorrect Options from the menu and click the Smart Tags tab.

The AutoCorrect Options dialog box appears.

Figure 2-30
Smart tags appear when you perform a particular task or when Word recognizes certain types of information.

Figure 2-31
Figure 2

You can change the Smart Tag options by selecting Tools → AutoCorrect Options from the menu and clicking the Smart Tag tab.
2. **Ensure that the Label data with smart tags box is checked.**
   Selecting this option will tell Microsoft Excel to mark certain types of information with smart tags.

3. **Click OK.**
   The AutoCorrect Options dialog box closes. Let’s see how Office XP’s new Smart Tags work…

4. **Click any blank cell, type MSFT and press <Enter>.**
   In case you’re not a stockbroker, MSFT is the stock ticker symbol for Microsoft. Shortly after you press <Enter>, Microsoft Excel recognizes the MSFT stock ticker symbol and marks it with a smart tag—a purple triangle in the bottom of the cell.

5. **Position the pointer over the MSFT cell.**
   A Smart Tag button appears next to the MSFT. Click this button to specify what actions you can perform on the MSFT information.

6. **Click the Smart Tag button arrow and select Stock quote on MSN MoneyCentral from the list.**
   If you are connected to the Internet, your computer’s Web browser will open and display the current stock price for Microsoft (how are they doing today?)

7. **Close your Web browser.**

### Table 2-6: Smart Tags and Buttons

<table>
<thead>
<tr>
<th>Smart Tag Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Smart Tag" /></td>
<td>When Excel recognizes certain types of data, such as a stock ticker symbol, the data is marked with a purple dotted underline. To find out what actions you can take with a smart tag, move the insertion point over the text with a smart tag indicator until the smart tag button appears. Click the button to see a menu of actions.</td>
</tr>
<tr>
<td><img src="image" alt="Paste Options" /></td>
<td>The Paste Options button appears after you paste something. Click the Paste Options button to specify how information is pasted into your workbook. The available options depend on the type of content you are pasting and the program you are pasting from.</td>
</tr>
<tr>
<td><img src="image" alt="Formula Error" /></td>
<td>The Formula Error button appears when Excel formula checker detects an error in a formula, such as a division by zero problem.</td>
</tr>
</tbody>
</table>

### Quick Reference

**Understanding Smart Tags:**
- As you enter information in a document, smart tag buttons will appear. Click these buttons to do something to the specified information.

**To Use a Smart Tag:**
- Click the Smart Tag arrow select the desired action or option.

**To View/Change Smart Tag Options:**
- Select **Tools → AutoCorrect Options** from the menu and clicking the Smart Tag tab.
Lesson 2-16: Recovering Your Workbooks

If you haven’t found this out already, sooner or later you’re going to discover that computers don’t always work the way they’re supposed to. Nothing is more frustrating than when a program, for no apparent reason, decides to take a quick nap, locks up, and stops responding to your commands—especially if you lose the precious workbook that you’re working on!

Fortunately, after more than ten years and roughly nine software versions, Microsoft has finally realized that people might want to recover their workbooks if Microsoft Excel locks up or stops responding. If Excel 2002 encounters a problem and stops responding, after you finish swearing and hitting your computer’s monitor, you can restart Microsoft Excel or your computer and try to recover your lost workbooks. Sometimes Excel will display a dialog box similar to the one shown in Figure 2-32 and automatically restart itself.

In this lesson, you will learn how to use Microsoft Excel’s new document recovery features, should disaster strike.
Chapter Two: Editing a Workbook

1. **If necessary, restart your computer and/or Microsoft Excel.**
   
   You may not need to restart your computer or Excel at all—often Excel will display the dialog box shown in Figure 2-32 and automatically restart itself when it encounters a problem.
   
   When you have restarted Microsoft Excel hopefully the Document Recovery pane will appear, as shown in Figure 2-33. If the Document Recovery pane doesn’t appear you’re out of luck—Excel didn’t recover any of your workbooks. Hope you made a backup!
   
   Sometimes Excel will display several recovered workbooks in the Document Recovery task pane, such as the original workbook that was based on the last manual save and a recovered workbook that was automatically saved during an AutoRecover save processes. You can see the status of any recovered workbook by simply pointing at the recovered workbook for a second or two.

2. **To view details about any recovered workbook simply point at the workbook in the Document Recovery task pane for a few seconds.**
   
   Hopefully you will find a version of your workbook—either original or recovered—that isn’t missing too much of your work.
   
   Here’s how to select and then save a recovered workbook…

3. **Click the desired recovered workbook from the task pane.**
   
   The workbook appears in Excel’s worksheet window.

4. **Select File → Save As from the menu and save the workbook.**
   
   You can further protect your work by using the AutoRecover feature to periodically save a temporary copy of the workbook you’re working on. To recover work after a power failure or similar problem, you must have turned on the AutoRecover feature before the problem occurred. You can set the AutoRecover save interval to occur more frequently than every 10 minutes (its default setting). For example, if you set it to save every 5 minutes, you’ll recover more information than if you set it to save every 10 minutes. Here’s how to change the AutoRecover save interval…

5. **Select Tools → Options from the menu and click the Save tab.**
   
   The Save tab of the Options dialog box appears.

6. **Ensure that the Save AutoRecovery info every box is checked and specify the desired interval, in minutes, in the minutes box. Click OK when you’re finished.**
   
   Even with Microsoft Office XP’s new document recovery features, the best way to ensure that you don’t lose much information if your computer freezes up is to save your work regularly.

---

**Quick Reference**

**To Recover a Document:**
1. Restart Microsoft Word (if it doesn’t restart by itself).
2. Find and then click the best recovered document in the Document Recovery task pane.
3. Save the document by doing a File → Save As from the menu.

**To Change the AutoRecovery Settings:**
1. Select Tools → Options from the menu and click the Save tab.
2. Ensure that the Save AutoRecovery info every box is checked and specify the desired interval, in minutes, in the minutes box. Click OK when you’re finished.

---

**Table 2-7: Status Indicators in the Document Recovery Task Pane**

<table>
<thead>
<tr>
<th>Status Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Original</td>
<td>Original file based on last manual save.</td>
</tr>
<tr>
<td>Recovered</td>
<td>File recovered during recovery process or file saved during an AutoRecover save process.</td>
</tr>
<tr>
<td>Repaired</td>
<td>Excel encountered problems while recovering the workbook and has attempted to repair them. Make sure that you double-check your workbook to make sure that there isn’t any corruption.</td>
</tr>
</tbody>
</table>
Chapter Two Review

Lesson Summary

Entering Data Values and Using AutoComplete

- Excel treats dates and times as values.
- You can enter dates in cells using almost any type of date format: 1/1/99, 1-1-99, January 1, 1999, etc.
- To Use AutoComplete: Type the first few characters of a label; Excel displays the label, if it appears previously in the column. Press <Enter> to accept the entry or resume typing to ignore the suggestion.
- To Use the PickList: Right-click the cell where you want to enter a label, select Pick from List from the shortcut menu, and select the entry from the list.

Editing, Clearing, and Replacing Cell Contents

- To clear cell contents: Select the cell or cell range and press the <Delete> key.
- Entering information into a cell replaces its previous contents.
- To edit a cell's contents: Select the cell, click the Formula bar and edit the cell contents and press <Enter> when you're finished.
- To edit a cell in-place: Double-click the cell you want to edit, edit the cell contents in-place, and press <Enter> when you're finished.

Cutting, Copying, and Pasting Cells

- Cut cells or cell ranges by selecting the cell or cell range and using one of four methods to cut:
  1) Click the Cut button on the Standard toolbar.
  2) Select Edit → Cut from the menu.
  3) Press <Ctrl> + <T>
  4) Right-click and select Cut from the shortcut menu.
- Select the cell where you want to paste the cut cell(s) and press <Enter>.
- Copy cell or cell ranges by selecting the cell or cell range and using one of four methods to cut:
  1) Click the Copy button on the Standard toolbar.
  2) Select Edit → Copy from the menu.
  3) Press <Ctrl> + <C>
  4) Right-click and select Copy from the shortcut menu.
- Paste copied cells by selecting the cell where you want to paste the copied cell(s) and using one of four methods:
  1) Click the Paste button on the Standard toolbar.
  2) Select Edit → Paste from the menu.
  3) Press <Ctrl> + <P>
  4) Right-click and select Paste from the shortcut menu.
Moving Cells with Drag and Drop

- Select the cell or cell range you want to move, drag the selection by its outside border to the upper-left cell of the area where you want to move the cells, and release the mouse button.

Collecting and Pasting Multiple Items

- To Display the Clipboard Task Pane: Select View → Task Pane from the menu, click the arrow on the task pane and select Clipboard from the menu.
- To Add Items to the Office Clipboard: Copy and/or cut the items as you would normally.
- To Paste from the Office Clipboard: If necessary, display the Clipboard task pane, then click the item you want to paste. Click the Paste All button to paste all collected items.

Working with Absolute and Relative Cell References

- Relative cell references are based on their position relative to the cell that contains the formula. The cell references change if the cell is moved to a new location.
- Absolute cell references are preceded by $ signs and always refer to a particular cell address. They do not change if the cell is moved to a new location.
- Press <F4> while selecting a cell range to make it an absolute reference.

Using the Paste Special Command

- To Use the Paste Special Command: Cut or copy a cell or cell range using standard cut and copy procedures. Click the Click the Paste button on the Standard toolbar to paste the information. Position the pointer over the Paste Options button that appears, click the Paste Options button arrow and select the desired paste option.

Inserting and Deleting Cells, Rows, and Columns

- To insert a row or column: Select the row or column headings where you to insert the column or row, right-click the selected row or column heading(s) and select Insert from the shortcut menu. Or select the row or column headings where you want the row or column to be inserted, and select Insert → Columns or Rows from the menu.
- To Delete a Row or Column: Select the row or column heading(s) you want to delete and either right-click the selected row or column heading(s) and select Delete from the shortcut menu or select Edit → Delete from the menu.
- To Delete a Cell Range: Select the cell range you want to delete, either right-click the selection and select Delete from the shortcut menu, or select Edit → Delete from the menu, and then specify how you want adjacent cells shifted.

Using Undo and Redo

- Undo: Undo your mistake or last action by clicking the Undo button on the Standard toolbar, or by selecting Edit → Undo from the menu, or pressing <Ctrl> + <Z>.
- Redo: Redo an undone action by clicking the Redo button on the Standard toolbar, or by selecting Edit → Redo from the menu, or by pressing <Ctrl> + <Y>.
- Multilevel Undo/Redo: Click the arrows on the Undo or Redo buttons on the Standard toolbar to undo or redo several actions at once.
• **Repeat:** Repeat your last command by pressing <Ctrl> + <Y> or by selecting **Edit → Repeat** from the menu.

### Checking Your Spelling

• **To Check for Spelling Errors:** Click the **Spelling button** on the Standard toolbar or select **Tools → Spelling** from the menu.

### Finding and Replacing Information

• **To Find Information:** Select **Edit → Find** from the menu or press <Ctrl> + <F>. Enter the text you want to search for in the Find what box, and click the **Find next** button. You can click the **Find next** button if there is more than one occurrence until you find the text you’re looking for.

• **To Replace Information:** Select **Edit → Replace** from the menu or press <Ctrl> + <H>. Enter the text you want to search for in the Find what box and text you want to replace it with in the Replace with box. Click the **Find next** button to find the text and the **Replace** button to replace the text. Click **Replace All** to replace every occurrence of the text in the workbook.

### Advanced Printing Options

• Open the Print Dialog box by selecting **File → Print** from the menu. You can specify the number of copies and which pages to print.

### File Management

• You can perform most file management functions, such as delete, rename, and copy, from the Open File or Save As dialog boxes. Right-click a file and select a file command from the shortcut menu or select the file and select a command from the **Tools** menu.

• **To Change How Files are Displayed:** Click the **View button** arrow and select a view.

### Inserting Cell Comments

• **To Insert a Comment:** Right-click the cell you want to attach a comment to and select **Insert Comment** from the shortcut menu. Enter the comment and click anywhere outside the comment area when you’re finished.

• **To Edit a Comment:** Right-click the cell that contains the comment you want to edit and select **Edit Comment** from the shortcut menu. Edit the comment and click anywhere outside the comment area when you’re finished adding to the comment.

• **To Delete a Comment:** Right-click the cell that contains the comment you want to edit and select **Delete Comment** from the shortcut menu.

### Understanding Smart Tags

• As you enter information in a document, smart tag buttons will appear. Click these buttons to do something to the specified information.

• **To Use a Smart Tag:** Click the **Smart Tag arrow** select the desired action or option.

• **To View/Change Smart Tag Options:** Select **Tools → AutoCorrect Options** from the menu and clicking the **Smart Tag tab**.
Recovering Your Workbooks

- **To Recover a Document:** Restart Microsoft Excel (if it doesn’t restart by itself). Find and then click the best recovered workbook in the Document Recovery task pane. Save the workbook by doing a `File → Save As` from the menu.

- **To Change the AutoRecovery Settings:** Select `Tools → Options` from the menu and click the `Save tab`. Ensure that the `Save AutoRecovery info every box` is checked and specify the desired interval, in minutes, in the `minutes box`. Click `OK` when you’re finished.

---

**Quiz**

1. You’re going to the bank on Monday and somehow lose the daily receipts that you’re supposed to deposit at the end of every day. When you complete the daily receipts summary worksheet on Friday how can you add a note to the Monday cell to explain what happened to your boss?
   
   A. Who cares about adding a note? You better start brushing up your resume.
   B. Print out the worksheet and add a Post-It note by the Monday receipt cell.
   C. Select the Monday receipt cell and select `Insert → Comment from the menu to add a comment.
   D. Don’t add a note—just guess what the amount of the deposit would be and enter that. Let your boss figure it out when she gets the bank statement.

2. Which is the fastest method of replacing the contents of a cell?
   
   A. Press `<Delete>` to clear the cell’s contents and enter the new contents.
   B. Enter the new contents—they will replace the old contents.
   C. Click the formula bar to edit the cell contents, press `<Backspace>` to erase the old contents, and enter the new contents.
   D. Double-click the cell to edit it in-place, press `<Backspace>` to erase the old contents, and enter the new contents.

3. Which of the following will NOT cut information?
   
   A. Clicking the Cut button on the Standard toolbar.
   B. Pressing `<Ctrl> + <C>`.
   C. Pressing `<Ctrl> + <X>`.
   D. Selecting `Edit → Cut` from the menu.

4. **Relative references always refer to a particular cell address. They don’t change if they are moved to a new location (True or False?)**

5. **The Paste Special command lets you copy and paste:** (Select all that apply)
   
   A. The resulting values of a formula instead of the actual formula.
   B. Formatting options.
   C. Cell comments.
   D. Multiply the selection by a copied value.
6. Which of the following statements is NOT true?
   A. You can spell check your worksheets by clicking the Spelling button on the Standard toolbar.
   B. To find information in a worksheet select Edit → Find from the menu.
   C. The Undo function can only undo the most recent action you performed.
   D. When you delete a cell range, row, or column, you must shift any existing cell to take the place of the deleted cells.

7. You can edit a cell by: (Select all that apply.)
   A. Double-clicking the cell to edit it in-place.
   B. Selecting Edit → Edit Workbook → Edit Worksheet → Edit Cell from the menu.
   C. You can’t—you’re just going to have to retype all that information over again.
   D. Clicking the Formula bar.

8. The spell checker always marks your name as a spelling error. How can you get Excel to stop saying your name is spelled incorrectly?
   A. Select Tools → Spelling from the menu and click Add when your name appears.
   B. Right-click your name and select Add from the shortcut menu.
   C. Select Tools → Spelling and Grammar from the menu and click Add to Dictionary.
   D. You can’t do anything about it.

9. How can you print three copies of a workbook?
   A. Select File → Print from the menu and type 3 in the Number of copies text box.
   B. Press <Ctrl> + <P> + <3>.
   C. Select File → Properties from the menu and type 3 in the Copies to print text box.
   D. Click the Print button on the Standard toolbar to print the document then take it to Kinko’s and have 2 more copies made.

10. You discover you’ve made minor calculation error in a worksheet. How can you replace every instance of the word “profit” in your worksheet with the word “loss”?
    A. Select Edit → Replace from the menu, type “profit” in the Find what box, type “loss” in the Replace with box and click Replace All.
    B. There isn’t any easy way – you’ll have to go through your novel and replace the words yourself.
    C. Click the Find and Replace button on the Standard toolbar, then follow the Find and Replace Wizard’s on-screen instructions to replace the word.
    D. Select Tools → Replace from the menu, type “profit” in the Find what box, type “loss” in the Replace with box and click Replace All.

11. Which of following is an absolute cell reference?
    A. A1.
    B. #A#1.
    C. !A!1.
    D. $A$1.
12. You can use the Copy button on the Standard toolbar to copy a worksheet's values but not its formulas. (True or False?)

13. **How do you insert a row? (Select all that apply.)**
   A. Right-click the row heading where you want to insert the new row and select Insert from the shortcut menu.
   B. Select the row heading where you want to insert the new row and select Edit → Insert Row from the menu.
   C. Select the row heading where you want to insert the new row and click the Insert Row button on the Standard toolbar.
   D. Select the row heading where you want to insert the new row and select Insert → Row from the menu.

14. **How do you delete a column? (Select all that apply.)**
   A. Right-click the column heading you want to delete and select Delete from the shortcut menu.
   B. Select the column heading you want to delete and select Edit → Delete from the menu.
   C. Select the column heading you want to delete and select the Delete Row button on the Standard toolbar.
   D. Select the column heading you want to delete and select Insert → Delete from the menu.

**Homework**

1. Open the Lesson 2B workbook and save it as “Doodads”.

2. Change the worksheet title in cell A1 to “2000 Manufacturing Summary”.

3. Create a formula that finds the profit per unit in cell D4 (hint: you’ll have to subtract cell C4 from cell B4.)

4. Copy the formula you created in cell D4 to the remaining cells under the Profit Per Unit heading (the cell range D5:D7).

5. Copy the labels in cell range A4:A7 to the cell range A11:A14.
6. Use AutoFill to add the remaining months in row 10.
7. Check the worksheet for spelling errors.

**Extra Credit:** Create a formula in cell B15 that totals the September column, then multiplies by the value in cell D4. Only make the reference to the D column an *absolute reference*. Copy the formula to the remaining cells in the Sales Forecast table.

Can’t figure out the formula? OK, it’s =SUM(B11:B14)*$D4.

**Quiz Answers**

1. C. Selecting Insert → Comment attaches a note to the current cell.
2. B. Typing replaces the previous contents of a cell. The other methods also work—they’re just no nearly as fast.
3. B. <Ctrl> + <C> copies information instead of cutting it.
4. False. Relative references reference cells based on their position from the cell that contains the formula, and change if the cell that contains the formula is moved.
5. A, B, C, and D. You can use the Paste Special command to copy and paste all of these items.
6. C. The Undo function can undo up to 16 of your last actions.
7. A and D. You can edit the contents of a cell by clicking the formula bar or by double-clicking the cell.
8. A. Add your name to the dictionary by selecting Tools → Spelling from the menu and clicking Add when your name appears.
9. A. You need to open the Print dialog box and specify the number of copies you want to print.
10. A. Select Edit → Replace from the menu, type “profit” in the Find what box, type “loss” in the Replace with box and click Replace All.
11. D. Absolute cell references have $ (dollar signs) before the column and/or number cell indicator.
12. False. The Copy button on the Standard toolbar can copy both values and formulas.
13. A and D. Either of these procedures will insert a new row.
14. A and B. Either of these procedures will delete a column.
Chapter Three: Formatting a Worksheet

Chapter Objectives:

• Format fonts with the Formatting toolbar and menus
• Format values
• Adjust row height and column width
• Align a cell's contents
• Add borders, colors, and patterns to cells
• Use the format painter to copy formatting
• Create a custom number format
• Create, apply, and modify a Style
• Use conditional formatting
• Merge cells

Chapter Task: Format an Expense Report

You probably have several colleagues at work that dazzle everyone at meetings with their sharp-looking spreadsheets that use colorful fonts and neat-looking borders. This chapter explains how to format your worksheet to make it more visually attractive and easier to read. You will learn how to change the appearance, size, and color of fonts and how to align text inside a cell. You will also learn how to increase the height of a row and the width of a column. This chapter also describes how you can make your worksheets more organized and professional looking by adding borders and shading.

Prerequisites

• How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
• How to select cell ranges.
Lesson 3-1: Formatting Fonts with the Formatting Toolbar

You can emphasize text in a worksheet by making the text darker and heavier (bold), slanted (italics), or larger in a different typeface (or font.) The Formatting toolbar makes it easy to apply character formatting. The Formatting toolbar includes buttons for applying the most common character and paragraph formatting options.

1. Start Microsoft Excel, open the document named Lesson 3A and save it as Expense Report.

Excel saves the worksheet in a new file with the name “Expense Report.” The first thing you need to do is make the title “Expense Report” stand out from the rest of the worksheet.

2. Click cell A1 to make it active.

Once you have selected a cell or cell range you can format it.

3. Click the Font list arrow (▼) on the Formatting toolbar, then scroll to and select Times New Roman from the list of fonts.

The contents of the active cell, the title “Expense Report,” appear in Times New Roman font. Arial and Times New Roman are two of the most commonly used fonts in Windows.

4. With cell A1 still selected, click the Font size list arrow (▼) and select 16, as shown in Figure 3-2.

The label “Expense Report” appears in a larger font size (16 point type instead of the previous 12 point type.) Wow! That font formatting really makes the title stand out from the rest of the worksheet doesn’t it? Font sizes are measured in points (pt.), which are 1/72 of an inch. The larger the number of points, the larger the font.
Chapter Three: Formatting a Worksheet

5. Select the cell range A4:G4 and click the **Bold button** on the Formatting toolbar.
   The cells in the selected range—the column headings for the worksheet—appear in bold.

6. **Click the Italic button** on the Formatting toolbar.
   The text in the selected cells is formatted with italics. Notice that both the Bold and Italic buttons are pushed down on the Formatting toolbar, indicating the selected cells are formatted with Bold and Italic formatting.
   Another way you can format fonts is by changing their color:

7. **Click cell A1 to make it active.**

8. **Click the Font Color arrow** (on the formatting toolbar and select the **Dark Red color** from the color palette.
   The text in the selected cell changes from black to dark red.
   So far, you have been formatting all the fonts in a cell at once. What if you want to use different font formatting in the same cell—is that possible? Yes it is—go to the next step to find out how.

9. **Click cell G2 to make it active.**
   Here you only want the words “Submitted By:” in bold and leave the rest of the text, “Bill Smith,” formatted the way it is.

10. **Position the pointer at the very beginning of the formula bar, immediately before the word Submitted.**
    The insertion point, the blinking vertical bar ( ), appears at the beginning of the formula bar.

11. **Click and hold down the mouse button and drag the between the words Submitted By:.** When you’re finished (the words should be highlighted), **release the left mouse button.**
    Another way to select text is to hold down the <Shift> key, move the insertion point with the arrow keys, and release the <Shift> key when you’re finished. Now you can format the selected text.

12. **Click the Bold button** on the Formatting toolbar.
    Only the selected text “Submitted By:” is formatted with Bold. The remaining text in the cell is left unchanged.

13. **Click the Save button** on the Standard toolbar to save your work.

---

**Table 3-1: Examples of Common Font Types and Sizes**

<table>
<thead>
<tr>
<th>Common Font Types</th>
<th>Common Font Sizes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
<td>Arial 8 point</td>
</tr>
<tr>
<td>Comic Sans MS</td>
<td>Arial 10 point</td>
</tr>
<tr>
<td>Courier New</td>
<td>Arial 12 point</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Arial 14 point</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Bold Text:
- Click the Bold button on the Formatting toolbar or press <Ctrl> + <B>.

To Italic Text:
- Click the Italic button on the Formatting toolbar or press <Ctrl> + <I>.

To Underline Text:
- Click the Underline button on the Formatting toolbar or press <Ctrl> + <U>.

To Change Font Size:
- Select the pt. size from the Font Size list on the Formatting toolbar.

To Change Font Type:
- Select the font form the Font list on the Formatting toolbar.
Lesson 3-2: Formatting Values

In this lesson, you will learn how to apply number formats. Applying **number formatting** changes how values are displayed—it doesn’t change the actual information in any way. Excel is often smart enough to apply some number formatting automatically. For example, if you use a dollar sign to indicate currency (such as $548.67), Excel will automatically apply the currency number format for you.

The Formatting toolbar has five buttons (Currency, Percent, Comma, Increase Decimal, and Decrease Decimal) you can use to quickly apply common number formats. If none of these buttons has what you’re looking for, you need to use the Format Cells dialog box by selecting **Format → Cells** from the menu and clicking the **Number** tab. Formatting numbers with the Format Cells dialog box isn’t as fast as using the toolbar, but it gives you more precision and more formatting options. We’ll use both methods in this lesson.

1. **Select the cell range D5:D17 and click the Currency Style button on the Formatting toolbar.**
   A dollar sign and two decimal places are added to the values in the selected cell range.

2. **Select the cell range G5:G17 and click the Comma Style button on the Formatting toolbar.**
   Excel adds a comma and two decimal places to the selected cell range.
3. **Select the cell range F5:F17 and click the Percent Style button on the Formatting toolbar.**

   Excel applies percentage style number formatting to the information in the Tax column. Notice there isn’t a decimal place—Excel rounds any decimal places to the nearest whole number. That isn’t suitable here—you want to include a decimal place to accurately show the exact tax rate.

4. **With the Tax cell range still selected, click the Increase Decimal button on the Formatting toolbar.**

   Excel adds one decimal place to the information in the tax rate column.

   Next, you want to change the date format in the date column. There isn’t a “Format Date” button on the Formatting toolbar, so you will have to format the date column using the Format Cells dialog box.

   The Formatting toolbar is great for quickly applying the most common formatting options to cells, but it doesn’t offer every available formatting option. To see and/or use every possible character formatting option, you have to use the Format Cells dialog box. You can open the Format Cells dialog box by either selecting Format → Cells from the menu or right-clicking and selecting Format Cells from the shortcut menu.

5. **Select the cell range A5:A17 and select Format → Cells from the menu and click the Number tab if necessary.**

   The Format Cells dialog box appears with the Number tab in front and Date format category selected, as shown in Figure 3-3. You can also use the Number tab of the Format Cells dialog box to format cells with any type of number option: percentages, currencies, dates, and, as you can see in the Category list, many more.

6. **From the Category list, select Date and then select the format 14-Mar from the Type list box and click OK.**

   The Format Cells dialog box closes and the selected cell range is formatted with the date format you selected. Try using another data format.

7. **With the Date cell range still selected, select Format → Cells from the menu.**

   The Format Cells dialog box reappears.

8. **Select 14-Mar-01 from the Type list box and click OK.**

   The dates are now formatted to display the year.

9. **Save your work.**

<table>
<thead>
<tr>
<th>Table 3-2: Number Formatting Buttons on the Formatting Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button Name</strong></td>
</tr>
<tr>
<td>Currency</td>
</tr>
<tr>
<td>Percent</td>
</tr>
<tr>
<td>Comma</td>
</tr>
<tr>
<td>Increase Decimal</td>
</tr>
<tr>
<td>Decrease Decimal</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Apply Number Formatting:
- Select the cell or cell range you want to format and click the appropriate number formatting button(s) on the Formatting toolbar.

Or...
- Select the cell or cell range you want to format, select Format → Cells from the menu, click the Number tab, and specify the number formatting you want to apply.

Or...
- Select the cell or cell range you want to format, right-click the cell or cell range and select Format Cells from the shortcut menu, click the Number tab, and specify the number formatting you want to apply.
Lesson 3-3: Adjusting Row Height and Column Width

When you start working on a worksheet, all the rows and columns are the same size. As you enter information into the worksheet, you will quickly discover that some of the columns or rows are not large enough to display the information they contain. This lesson explains how to change the width of a column and the height of a row.

1. Carefully position the pointer over the line between the B and C in the column header area, until it changes to a 

   Once the pointer is positioned over the column line and appears as a 
   , you can adjust the column width to make it smaller or wider.

2. Click and hold the mouse button and drag the line to the right until Column B is wide enough to see all of the Type labels, as shown in Figure 3-6.

   Notice that while you are dragging the column line, a tip box appears displaying the current width of the column.

3. Position the pointer over the line between the D and E in the column header area, until it changes to a 

   Excel automatically adjusts the width of the selected column so that it can hold the widest cell entry. This neat feature is called AutoFit. You can also use AutoFit by selecting Format → Column (or Row) → AutoFit from the menu.

The procedure for adjusting the height of a row is almost the same as adjusting the width of a column:
4. Carefully position the pointer over the line between the 4 and 5 in the row header area, until it changes to a ✐.
   Once the pointer is positioned over the column line and appears as a ✐, you can adjust the row height to make it smaller or wider.

5. Click and hold the mouse button and drag the line down until the height of Row 4 is doubled, as shown in Figure 3-7.
   Notice that while you are dragging the column, a tip box appears displaying the current height of the row.
   In most instances, using the mouse is the fastest and easiest method to adjust the height of a row or the width of a column. There are times, however, when you may want to adjust the height of a row or the width of a column by using a dialog box. For example, you can select and adjust the width of several columns at the same time with a dialog box.

6. Click the Select All button (the gray rectangle in the upper-left corner of the worksheet where the row and column headings meet) to select the entire worksheet.
   Excel selects all the cells in the worksheet.

7. Select Format → Row → Height from the menu.
   The Row Height dialog box appears, as shown in Figure 3-8. Here you can enter an exact measurement to adjust the row height. The default row height is 12.75.

8. Type 14 in the Row Height text box and click OK.
   The height of all the rows in the worksheet changes to 14. Notice, however that the new row height is not sufficient to accommodate the worksheet’s title, so you will need to adjust the height of row A. You can use the AutoFit feature to automatically adjust the height of row 1.

9. Deselect the entire worksheet by clicking any cell in the worksheet.
   The entire worksheet is no longer selected.

10. Double-click the line between the 1 and 2 in the row header area.
    Excel automatically adjusts the height of the first row so the title Expense Report fits in the row. A faster way to open either the Row Height or the Column Width dialog box is to use the right mouse button shortcut menu.

11. Right-click the A column header.
    A shortcut menu containing the most commonly used commands used with columns appears. Had you right-clicked a row heading, a shortcut menu with the most commonly used Row commands would have appeared.

12. Select Column Width from the shortcut menu.
    The Column Width dialog box appears, as shown in Figure 3-9. Here you can enter an exact measurement to adjust the column width. The default column width is 8.43.

13. Type 10 in the Column Width box and click OK.
    The width of the selected column, column A, changes to 10.

14. Save your work.
    Splendid! In just one lesson you’ve learned how to adjust the width of columns and height of rows using several different methods.

Quick Reference

To Adjust the Width of a Column:
- Drag the column header’s right border to the left or right.

Or...
- Right-click the column header(s), select Column Width from the shortcut menu and enter the column width.

Or...
- Select the column header(s), select Format → Column → Width from menu and enter the column width.

To Adjust the Height of a Row:
- Drag the row header’s bottom border up or down.

Or...
- Right-click the row header(s), select Row Height from the shortcut menu and enter the row height.

Or...
- Select the row header(s), select Format → Row → Height from menu and enter the row height.

To Automatically Adjust the Width of a Column or Row (AutoFit):
- Double-click the right border of the column or bottom border of a row.

Or...
- Click the column heading to select the column and select Format → Column → AutoFit from the menu.
Lesson 3-4: Changing Cell Alignment

By default, the contents of a cell appear at the bottom of the cell, with values (numbers) aligned to the right and labels (text) aligned to the left. This lesson explains how you can take control of how data is aligned in a cell using the Formatting toolbar and the Format Cells dialog box.

1. **Select the cell range A4:G4 and click the Center button on the Formatting toolbar.**
   Excel centers the selected headings inside the cells. Notice the Center button on the Formatting toolbar is depressed, indicating the cells are center aligned.

2. **Select the cell range A5:A17 and click the Center button on the Formatting toolbar.**
   The dates in the A column are centered.
3. Select cell G2, then click the Align Right button on the Formatting toolbar.
Excel aligns the label to the right side of the cell. Notice the text spills over into the
cells to the left of the cells, since they are currently unoccupied.

4. Select the cell range A1:G1 and click the Merge and Center button on the Formatting toolbar.
Excel merges, or combines, the seven selected cells into a single larger cell that spans
across seven columns, and centers the text inside the single merged cell. A merged cell
is a single cell created by combining two or more selected cells. The cell reference for
a merged cell is the upper-left cell in the original selected range.

5. Select the cell range E19:G21.
You want to combine all the cells in the selected range into a single merged cell.

6. Select Format → Cells from the menu and click the Alignment tab.
The Format Cells dialog box appears with the Alignment tab in front, as shown in
Figure 3-12. Here you can specify more advanced cell alignment options.

7. Select the Merge cells checkbox and click OK.
The Format Cells dialog box closes and the selected cell range is merged into a single
cell. Hey! The new merged cell is large enough to hold all of the notes text, so why is
only a single line of text displayed? To display multiple lines of text in a cell you must
select the Wrap Text option on the Alignment tab of the Format Cells dialog box.

8. With the merged cell still selected, select Format → Cells from the
menu.
The Format Cells dialog box reappears with the Alignment tab in front.

9. Select the Wrap text checkbox and click OK.
The notes wrap on multiple lines so that all the text fits inside the merged cell.
Sometimes you might want to indent the contents of several cells to make a worksheet
appear more organized and easy to read.

10. Select the cell range B5:B17 and click the Increase Indent button on
the Formatting toolbar.
The labels in the selected cells are indented one space to the right.

11. With the same cell range selected, click the Decrease Indent button on
the Formatting toolbar, then save your work.

Table 3-3: Alignment Formatting Buttons on the Formatting Toolbar

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Left</td>
<td>Left</td>
<td>Aligns the cell contents to the left side of the cell.</td>
</tr>
<tr>
<td>Center</td>
<td>Center</td>
<td>Centers the cell contents in the cell.</td>
</tr>
<tr>
<td>Merge and Center</td>
<td>Center</td>
<td>Merges the selected cells and centers the cell contents.</td>
</tr>
<tr>
<td>Align Right</td>
<td>Right</td>
<td>Aligns the cell contents to the right side of the cell.</td>
</tr>
<tr>
<td>Increase Indent</td>
<td>Indent</td>
<td>Indents the cell contents by one character.</td>
</tr>
<tr>
<td>Decrease Indent</td>
<td>Indent</td>
<td>Decreases indented cell contents by one character.</td>
</tr>
</tbody>
</table>
Lesson 3-5: Adding Borders

Borders make worksheets more visually attractive. Adding borders to ranges of similar cells also makes them more organized and easier to read. Just like any other formatting attributes, you can add a variety of borders to the cells in your worksheet using the Formatting toolbar (specifically, the Border button) or the Format cells dialog box. Just like the previous formatting lessons, we’ll cover both methods of adding borders in this lesson.

Although it isn’t absolutely necessary, removing the gridlines in the worksheet makes it easier to see any borders.

1. **Select Tools → Options from the menu and click the View tab.**
   The Options dialog box appears with the View tab selected, as shown in Figure 3-13. Here you can change how the worksheet is displayed. You’re only interested in one view option here: you want to remove the cell gridlines in this worksheet so you can more easily see the borders you will be adding in this lesson.

2. **Click the Gridlines checkbox to remove the checkmark and click OK.**
   The dialog box closes and the cell gridlines no longer appear on the worksheet. Don’t worry—the worksheet works exactly the same with or without the gridlines. Gridlines are only a visual aid to help you determine which column and row a cell is in.
3. Select the cell range A4:G4, click the Border button arrow on the Formatting toolbar, and select the single bottom border (located in the second column of the first row.)

A single, thin border appears at the bottom of the selected cells. You can choose from several different border styles. Try using a different border style in the next step.

4. Select the cell G17, click the Border button arrow on the Formatting toolbar and select the double bottom border (located in the first column, second row.)

Excel adds a double-lined border to the bottom of the selected cell. The Border button is usually the fastest and easiest way to add borders to your worksheets, but you can also add borders using the Borders tab of the Format Cells dialog box.

5. Select the cell range A5:G17, select Format → Cells from the menu and click the Border tab.

The Format Cells dialog box appears with the Border tab selected, as shown in Figure 3-15. The Border tab of the Format Cells dialog box gives you more options for adding borders than the Borders button on the Formatting toolbar does.

6. Select the thickest line style in the Style list (the second to the last option in the second column.) Click the Color list arrow and select a dark blue color, then click the Outline button to apply the specified border style to the outside of the selected cell range.

This will add a thick, dark blue border around the outside of the selected cell range.

7. Click OK.

The Format Cells dialog box closes and the borders you specified are added to the selected cell range. Let’s add a different border style inside the cell range.

8. With the cell range A5:G17 still selected, select Format → Cells from the menu.

The Format Cells dialog box appears.

9. Select the thinnest solid line style (the last option in the first column.) Click the Color list arrow and select Automatic, then click the Inside button to apply the specified border style to the inside of the selected cell range.

Notice a preview of how your borders will look appears in the Border section of the dialog box.

10. Click OK.

The Format Cells dialog box closes and the borders you specified are added to the selected cell range, as shown in Figure 3-15.

11. Select the cell range E19:G19 (the merged notes cell), click the Border button arrow, and select the thick outline border option (located in the last column and last row) and click OK.

Excel adds a thick border around the outside of the selected cells. You decide you want to remove the border. It is just as easy to remove a border as it is to add it.

12. With the cell range E19:G19 selected, click the Border button arrow and select the No Border option (located in the first column and first row.)

The border is removed from the selected cell range. Before we finish this lesson we must once again display the worksheet gridlines.

13. Select Tools → Options from the menu, click the View tab, check the Gridlines checkbox and click OK.
Lesson 3-6: Applying Colors and Patterns

In the last lesson, you learned how to add borders to the cells in your worksheet. In this lesson, you will see how you can change the background colors and patterns of cells. Applying colors and patterns to cells is actually a very, very easy procedure, so let’s get started!

1. Click cell E19 (the merged cell that contains the notes) to make it active, click the Fill Color button arrow on the Formatting toolbar and select the Yellow color from the color palette.

   The background of the selected cell changes to the yellow. Like all other formatting options in Excel, you can also change the background color of cells with the Format Cells dialog box.

2. Select the range A5:G17, select Format → Cells from the menu and click the Patterns tab.

   The Format Cells dialog appears with the Patterns tab selected, as shown in Figure 3-16. Here you can add both colors and patterns to the background of cells.

3. Select the light blue color and click OK.

   The dialog box closes and the selected pattern, the thin vertical stripe, is applied to the background of the cell.

4. Click cell A1 to make it active and select Format → Cells from the menu.

   The Format Cells dialog appears with the Patterns tab selected.

5. Click the Pattern List Arrow, select the Thin Vertical Stripe option and click OK.

   The Format Cells dialog box closes and the selected pattern, the thin vertical stripe, is applied to the background of the cell.
NOTE: If you intend on printing a worksheet, be careful which colors and patterns you use, especially if you don’t have a color printer. Some colors may look great on the computer screen, but not when printed. Some background colors and patterns can even cause the cell information to be illegible when printed. You are usually better off if you use lighter background colors and patterns, such as yellow, light gray, or light blue.

6. Save your work.

Quick Reference

To Apply Background Colors and Patterns:
1. Select the cell or cell range you want to format.
2. Click the Fill Color list arrow on the Formatting toolbar and select the color you want.

Or…

Either right-click the selection and select Format Cells from the shortcut menu, or select Format → Cells from the menu. Click the Patterns tab and select the color or pattern you want to use.
Lesson 3-7: Using the Format Painter

If you find yourself applying exactly the same formatting to cells repeatedly, the Format Painter is the tool for you. The Format Painter allows you to copy the formatting attributes from a cell or cell range and apply them elsewhere. Sound confusing? It won’t once you have finished this lesson.

1. **Select the cell range D5:D17 and select Format → Cells from the menu.**

The Format Cell dialog box appears. You want to change several of the formatting options for the selected cell range. Start by changing the number format.
2. Select the **Number tab**, select **Currency** under the Category list, and select the fourth option in the Negative numbers list (the **($1234.10)** option.)

   The next formatting option you need to change for the selected cell range is the font formatting.

3. Select the **Font tab**, select **Courier New** from the Font list, and then select a **dark red color** from the color list.

   The last two formatting options you want to modify are the borders and shading options.

4. Select the **Border tab** and click the **None button**, then select the **Patterns tab**, select the **yellow color** and click **OK**.

   The Format Cells dialog box closes and the selected cell range is formatted with all the various formatting options you specified. It took a lot of work to do all of that formatting, didn’t it? Now imagine you want to format the cell range G5:G17 (the Totals column) with exactly the same formatting options. Instead of doing all those steps again, you can use the Format Painter tool to copy the formatting from the Price Per Unit cells and then paste, or apply, the copied formatting to the Totals column. First, you need to select the cell or cell range that contain the formatting you want to copy.

5. With the cell range (D5:D17) still selected, click the **Format Painter** button on the Standard toolbar.

   Notice the pointer changes to a ![Paint Brush](https://example.com/paint-brush.png). Next, you need to paste, or apply the copied formatting.

6. Select the cell range G5:G17 with the **Format Painter** tool.

   Like other mouse-intense operations, this can be a little tricky for some people the first time they try it. Once you have selected the cell range, the cell formatting from the Price Per Unit cell range is applied to the Total cell range, saving you a lot of time and work if you had you manually formatted the cells. Notice cell G8 displays a series of ####’s. That’s because the G column is no longer wide enough to display the contents of cell G8. To fix this problem you merely have to adjust the column width.

7. Adjust the width of the G column so that you can see the contents of cell G8.

   Remember how to adjust the width of a column? Move the pointer to the column header area and drag the column’s right edge with the mouse to adjust its width. The G column will correctly display the contents of all its cells when it’s wide enough.

8. Save your work.
Lesson 3-8: Using AutoFormat

Congratulations! You’re just about finished with the chapter. This lesson explains how Excel can automatically format your worksheets with the AutoFormat command. AutoFormat is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to a cell range or entire worksheet. AutoFormat lets you select from 16 different preset formats. AutoFormat is a great feature if you want your worksheet to look sharp and professional but don’t have the time to format it yourself.

1. Place the cell pointer anywhere in the table (the cell range A4:G17).
   Excel will automatically determine the table’s boundaries. You can also manually select the cell range.

2. Select Format → AutoFormat from the menu.
   The AutoFormat dialog box appears, as shown in Figure 3-19. The 16 present formats are listed in the Table format list. You can see what a present format looks like by selecting it and looking at the sample area of the dialog box.
3. **Click the Options button.**
   The AutoFormat dialog box expands to show six check boxes. You can control the type of formatting that is applied by checking or unchecking any of the boxes. If you want AutoFormat to skip one of the formatting categories, simply uncheck the appropriate box.

4. **Select the Colorful 2 option from the Table format list and click OK.**
   The dialog box closes and the selected cell range is formatted with the Colorful 2 formatting options, as shown in Figure 3-20.

5. **Save your work.**

---

**Quick Reference**

**To Format a Table Using AutoFormat:**

1. Place the cell pointer anywhere within a table you want to format, or else select the cell range you want to format.

2. Select **Format → AutoFormat** from the menu.

3. Select one of the 16 AutoFormats from the list and click **OK.**
Lesson 3-9: Creating a Custom Number Format

You learned how to format values (numbers) in a previous lesson in this chapter. Excel comes with a huge number of predefined number formats you can use. With so many available number formats, it is unlikely that you will ever need to create your own custom number but if you do, this lesson explains how to do it.

1. Select cell A19 to make it active, type 6125555555 and press <Enter>.
   This cell contains the employee’s telephone number. To make the phone number easier to read, you can apply special number formatting to the cell.

2. Select cell A19 again, select Format → Cells from the menu, then click the Number tab.
   The Format Cells dialog box appears with the Numbers tab selected.

3. Select Special under the Category list and select Phone Number under the Type list.
   This will add area code parenthesis and a prefix separator (hyphen) format to the number, making it easy to recognize as a telephone number. A preview of how the number will look with the selected formatting appears in the Sample area of the dialog box.

4. Click OK.
   The Format Cells dialog box closes and the Phone Number format is applied to the active cell. Whoops! You’re going to have to widen the A column in order to see the newly formatted number.

5. Double-click the right border of the A column heading.
   Excel automatically adjusts the width of the A column. There’s the phone number!
If you find that none of the formatting options is satisfactory, here’s how to create your own:

5. **Enter 521876 into cell A20.**
   The number you just entered is the employee ID. This number should be displayed like 52-1827. Since there isn’t a number format like this you’ll have to create your own.

6. **Make sure cell A20 is the active cell and select Format → Cells from the menu and click the Number tab.**
   The Format Cells dialog box appears.

7. **Select Custom under the Category list.**
   This is where you can create your own number formats. You create a custom number format by specifying format codes that describe how you want to display a number, date, time, or text. Table 3-4: Format Codes for Numbers and Dates gives some examples of how to use these codes when creating custom number formats.

8. **In the Type box replace the word “General” with ##-#### and click OK.**
   The dialog box closes and Excel formats cell A20 with the custom number format you created.

   NOTE: The sample area of the number dialog box becomes very important when you’re creating custom number formats. Watch the sample area carefully to see how the custom number format you create will be displayed.

9. **Verify that cell A20 is selected, select Format → Cells from the menu and click the Number tab.**
   Now create a new custom number format.

10. **Select Custom under the Category list, type “Employee ID: ##-####” in the Type field and click OK.**
    The dialog box closes and the new custom number format is applied to the cell, as shown in Figure 3-22.

You can create custom number formats by entering format codes that describe how you want to display a number, date, time, or text. Table 3-4: Format Codes for Numbers and Dates shows several examples which demonstrate how you can use number codes to create your own custom number formats.

<table>
<thead>
<tr>
<th>Table 3-4: Format Codes for Numbers and Dates</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Numbers</strong></td>
</tr>
<tr>
<td><strong>To Display</strong></td>
</tr>
<tr>
<td>1234.59 as 1234.6</td>
</tr>
<tr>
<td>12499 as 12,499</td>
</tr>
<tr>
<td>12499 as 12,499.00</td>
</tr>
<tr>
<td>1489 as $1,489.00</td>
</tr>
<tr>
<td>.5 as 50%</td>
</tr>
<tr>
<td>.055 as 5.5%</td>
</tr>
<tr>
<td>Hide value</td>
</tr>
</tbody>
</table>

---

Quick Reference

To Create a Custom Number Format:
1. Select the cell or cell range you want to format.
2. Select Format → Cells from the menu and click the Number tab.
3. Select the Custom category and type a number format in the Type box using the format codes shown in Table 3-4: Format Codes for Numbers and Dates.
Lesson 3-10: Creating, Applying, and Modifying a Style

If you find yourself applying the same formatting options repeatedly, you could probably save a lot of time by using a style. A style is a collection of formats—such as font size, color, patterns, and alignment—that you can define and save as a group. Once you have defined and saved a style, you can apply all of the formatting elements at once.

A style can contain any (or all) of the following formatting attributes:

- Number
- Font (type, size, and color)
- Borders
- Alignment
- Pattern
- Protection (locked and hidden)

In this lesson, you will learn how to create, apply, and modify a style. The easiest way to create a style is by example. This means you have to format a cell or cell range and then create a style based on that cell or cell range. Here’s how:

1. Select the cell range D5:D17 and select Format → Cells from the menu.

   The Format Cells dialog box appears. Specify how you want to format the selected cell range.
2. Click the **Number tab**, select **Currency** from the Category list, and select the first option, **-$1,234.00**, from the Negative numbers list.
   The next formatting option you want to change is the font formatting.

3. Click the **Font tab**, select **Times New Roman** from the Font list, select **Regular** from the Font style list, click the **Font color list arrow** and select the **blue color**.
   The last formatting option you want to change is the pattern.

4. **Click the Patterns tab**, select **No Color**, and then click **OK**.
   The Format Cells dialog box closes and the formatting options you specified are applied to the selected cell range.
   Instead of applying the same formatting options to other cells by repeating steps 2-4, you can create a Style based on the cells you just formatted.

5. **Verify the cell range D5:D17 is selected and select **Format → Style** from the menu**.
   The Style dialog box appears, as shown in Figure 3-24. Here you can create, define, or apply a style. You want to create a new style named **Money** based on the selected cell range.

6. **Type Money in the Style name text box and click **OK**.**
   You’ve just created a new Style named money. Try applying the Money style to a new cell range in the worksheet.

7. **Select the cell range G5:G17, select **Format → Style** from the menu, select Money from the Style name list and click **OK**.**
   The dialog box closes and the selected cell range is formatted with the Money style, as shown in Figure 3-25. See how quickly and easily you can apply cell formatting to using styles?
   Now that you know how to create and apply styles, we can move on to what’s really neat about styles—modifying them. You can modify the formatting options for a style just like you would modify the formatting for a cell or cell range. However, when you modify a style, *every cell formatted with that style is updated to reflect the formatting changes*. Here is how to modify a style:

8. **Select **Format → Style** from the menu, select Money from the Style list and click **Modify**.**
   The Format Cells dialog box appears.

9. **Click the **Font tab**, select **Arial** from the Font list. Click **OK** to close the Format Cells dialog box, then click **OK** again to close the Style dialog box.**
   The dialog box closes and every cell formatted with the Money style is updated to reflect the change in fonts.
   You can delete the Money style, since you will no longer be using it—here’s how…

10. **Select **Format → Style** from the menu, select Money from the Style list and click **Delete**.**
    Excel deletes the Money style.

    Look how much time you just saved by modifying the Money style. If you hadn’t used a style, you would have had to go and change the font formatting manually—plus there is always the chance that you might miss reformatting something.
Lesson 3-11: Formatting Cells with Conditional Formatting

You already know how to format most attributes of a cell: color, font and font size, and borders, to name only a few. In this lesson, you will learn how to use **conditional formatting**.

Conditional formatting formats cells only if a specified condition is true. For example, you could use conditional formatting to display weekly sales totals that exceeded $50,000 in bright red boldface formatting and in bright blue italics formatting if the sales totals were under $20,000. If the value of the cell changes and no longer meets the specified condition, the cell returns to its original formatting.

1. Select the cell range G5:G17.

You want to apply conditional formatting to the Totals column to highlight any values that meet a certain condition.
2. **Select Format → Conditional Formatting from the menu.**
   The Conditional Formatting dialog box appears, as shown in Figure 3-26. This is where you can add conditional formatting options to the selected cell range.
   You want to conditionally format the selected cell range, the Totals column, so that any values over 100 are formatted in a red, bold italics font.

3. **Click the Operator list arrow (the second field) and select greater than or equal to.**
   Next, you need to specify what value the cell must be equal or greater to apply the conditional formatting.

4. **Click the Value text box (the third field) and type 100.**
   Next, you must specify how you want the cells to be formatted if the condition is met (if the cell value is equal to or greater than 100.)

5. **Click the Format button.**
   The Format Cells dialog box appears, as shown in Figure 3-27.

6. **Select Bold Italic from the Style list, click the Color list arrow, select a Green color and click OK.**
   You return to the Conditional Formatting dialog box. You have finished entering a conditional format for the selected cell range. You are not limited to adding a single conditional format—you can specify up to three.
   Here’s how to add another conditional formatting option:

7. **Click the Add button.**
   The Conditional Formatting dialog box expands to display a second condition.

8. **Click the Condition 2 Operator list arrow, select less than, click the Value text box, type 5, and click OK.**
   Make sure you’re selecting the Condition 2 options and not the Condition 1 options!
   Now specify how you want the cell to be formatted if its value is less than 5.

9. **Click the Format button, select Bold from the Style list, click the Color list arrow, select Blue (sixth column, second row), and then click OK.**
   You return to the Conditional Formatting dialog box. Since you’ve finished entering your conditional formatting options for the selected cell range, you can close the dialog box.

10. **Click OK.**
    The dialog box closes and the cells are conditionally formatted according to their values, as shown in Figure 3-28.
    You can easily delete conditional formatting from a cell if you decide you no longer need it.

11. **With the cell range G5:G17 still selected, select Format → Conditional Formatting from the menu, then click the Delete button.**
    The Delete Conditional Format dialog box appears, as shown in Figure 3-29.

12. **Click both the Condition 1 and Condition 2 check boxes, click OK, then click OK again to close the Conditional Formatting dialog box.**
    The conditional formatting for the selected cells is removed.
Lesson 3-12: Merging Cells, Rotating Text, and using AutoFit

We’ve got a lot of ground to cover in this short lesson! This lesson briefly examines a variety of different formatting options not covered in the previous lessons. In this lesson, you’ll learn how to merge several cells together into a single, larger cell, how to rotate text within a cell, and how to automatically adjust the width of a column to fit the column’s widest entry.

1. Select the cell range A4:A17, select Insert → Cells from the menu and click OK.
   Excel inserts a cell range, shifting the other cells in the worksheet to the right.

2. Select the cell range A5:A12.
   You want to merge the cells in the selected cell range.

3. Select Format → Cells from the menu and click the Alignment tab.
   The Format Cells dialog box appears with alignment tab in front, as shown in Figure 3-30. The text control section of the Alignment tab has three options:
   - **Wrap text**: Wraps text into multiple lines in a cell. The number of wrapped lines depends on how wide the column is and how much text is in the cell.
• **Shrink to fit:** Automatically reduces the displayed font size of a cell so that all data fits within the cell.
• **Merge cells:** Combines two or more selected cells into a single cell. The reference for a merged cell is the upper-left side of the cell.

Try merging the selected cell range into a single cell.

4. **Click the Merge cells checkbox, and then click OK.**

The dialog box closes, and the selected cells are merged into a single, larger cell.

5. **With cell A5 still selected (the merged cell) type Boston Trip and click the Enter button on the Formula bar.**

You already know how to change the horizontal alignment of text in a cell. Now you’ll learn how to change a cell’s vertical alignment.

6. **Select Format → Cells from the menu, drag the text rotation tool in the Orientation section to a 45-degree angle and click OK.**

The dialog box closes and the text in cell A5 is aligned at a 45-degree angle.

7. **With cell A5 still selected (the merged cell), Select Format → Cells from the menu, drag the text rotation tool in the Orientation section to a 90-degree angle, click the Vertical list arrow and select Center.**

This will align the text at a 90-degree angle in the cell and center the text vertically. Add a colored background to the cell to make it stand out.

8. **Click the Patterns tab, select the light blue color and click OK.**

The dialog box closes and cell A5 is formatted with the selected background color and vertical alignment formatting options. To finish the lesson, reduce the width of column A using AutoFit.

9. **Position the pointer on the right border of the A column heading until it changes to a ‹. Then resize the column to match the size of the A column shown in Figure 3-31.**

10. **Save your work and exit Microsoft Excel.**

Congratulations! You’ve worked your way through a long and rather difficult chapter! The next time you’re called on to create a worksheet, make sure you use some of the formatting techniques you’ve learned to impress your colleagues with what a computer whiz you are.
Lesson 3-13: Finding and Replacing Formatting

After seeing a printed copy of your annual snowfall workbook, you realize that your “clever” scheme of formatting the workbook using white fonts on a white background maybe isn’t such a great idea. Now you’ll have to go back to your snowfall workbook, find every white colored font and replace it with a slightly more visible font. Good luck!

Actually this task will be much easier than it sounds. Find and Replace has been greatly enhanced in Microsoft Excel 2002. Find and Replace can now find and/or replace formatting in addition to text and information. So you can use Find and Replace to replace every white-colored font in a workbook with a black-colored font.

In this lesson you will learn how to use Find and Replace to find specific formatting in a workbook and how to easily change that formatting.

1. **Open the workbook Lesson 3B and save it as Find Formatting.**
   Here’s your snowfall workbook. You need to change all the white colored text to black. Since don’t even know where all the white colored text is (how did you create this workbook anyway?!?) you will use Find and Replace to automatically find all the white colored text and change it to black.

2. **Select Edit → Replace from the menu.**
   The Find and Replace dialog box appears. You need to click the Options button to display more advanced find and replace controls.
3. **Click Options.**
   The Find and Replace dialog box expands and displays more advanced options, as shown in Figure 3-33. Notice two Format buttons appear after clicking the Options button. You use the top Format button to specify the cell formatting you want to find and the bottom Format button to specify that cell formatting you want to replace it with.

4. **Click the top Format button.**
   The Find Format dialog box appears. This is where you specify the cell formatting you want to look for.

5. **Click the Font tab.**
   You want to search for white colored fonts.

6. **Click the Color list arrow and select a white color.**
   That’s the only formatting option you want to look for, so you can close the Find Format dialog box.

7. **Click OK.**
   The Find Format dialog box closes. Next you need to specify the cell formatting you want to replace the white colored fonts with.

8. **Click the bottom Format button.**
   The Replace Format dialog box appears.

9. **If necessary, click the Font tab, then click the Color list arrow and select Automatic.**
   Move on to the next step and close the Replace Format dialog box.

10. **Click OK.**
    The Replace Format dialog box closes. Now that you’ve specified the cell formatting you want to look for and the cell formatting you want to replace it with you can actually start finding and replacing the formatting. Just like finding and replacing text, you can review and selectively replace each occurrence of formatting or you can automatically replace all occurrences at once.

11. **Click Replace All.**
    Excel replaces all the white colored text formatting with black colored text formatting.

12. **Click OK then Close.** Close Microsoft Excel without saving any changes.

### Table 3-5: Find and Replace Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace All</td>
<td>Replaces all occurrences of the search criteria in your worksheet. If you want to review and selectively replace each occurrence, click Replace instead of Replace All.</td>
</tr>
<tr>
<td>Replace</td>
<td>Replaces the selected occurrence of the criteria in the Find what box, finds the next occurrence, and then stops. If you want to automatically replace all occurrences of the search criteria in your document, click Replace All.</td>
</tr>
<tr>
<td>Find All</td>
<td>Finds all occurrences of the search criteria in your document. If you want to find and review each occurrence separately, click Find Next instead of Find All.</td>
</tr>
<tr>
<td>Find Next</td>
<td>Searches for the next occurrence of the characters specified in the Find what box. To find the previous occurrence, hold down SHIFT and click Find Next.</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Find and Replace Cell Formatting:**
1. Select **Edit → Replace** from the menu.
2. Click **Options**.
3. Click the **top Format button**, specify the formatting options you want to search for and click **OK**.
4. Click the **bottom Format button**, specify the new formatting options and click **OK**.
5. Click **Find Next** to find each occurrence of cell formatting and **Replace** to replace the cell formatting.
   Or…
   Click **Replace All** to replace all occurrences of the cell formatting.
Chapter Three Review

Lesson Summary

Formatting Fonts with the Formatting Toolbar
- Change the style of text by clicking the **Bold button**, **Italics button**, or **Underline button** on the Formatting toolbar.
- Change the font type by selecting a font from the **Font list** on the Formatting toolbar.
- Change the font size by selecting the pt. size from the **Font Size list**.

Formatting Values
- **To Apply Number Formatting using the Formatting Toolbar**: Select the cell or cell range you want to format, and click the appropriate number formatting button(s) on the Formatting toolbar.
- The Number Formatting Buttons on the Formatting toolbar include: **Currency**, **Percent**, **Comma**, **Increase Decimal**, and **Decrease Decimal**.
- **To Apply Number Formatting using the Format Cells Dialog Box**: Select the cell or cell range you want to format, right-click the cell or cell range and select **Format Cells** from the shortcut menu, click the **Number tab**, and specify the number formatting you want to apply.

Adjusting Row Height and Column Width
- **To Adjust the Width of a Column**: There are three methods:
  1.) Drag the column header’s right border to the left or right.
  2.) Right-click the column header, select **Column Width** from the shortcut menu and enter the column width.
  3.) Select the column header(s), select **Format → Column → Width** from menu and enter the column width.
- **To Adjust the Height of a Row**: There are three methods:
  1.) Drag the row header’s bottom border up or down.
  2.) Right-click the row header(s), select **Row Height** from the shortcut menu and enter the row height.
  3.) Select the row header(s), select **Format → Row → Height** from menu and enter the row height.
- **To Automatically Adjust the Width of a Column or Row (AutoFit)**: Double-click the right border of the column or click the column heading to select the column and select **Format → Column → AutoFit** from the menu.

Changing Cell Alignment
- **Using the Formatting Toolbar**: Select the cell or cell range and click the appropriate alignment button (**Left**, **Center**, **Right**, or **Merge and Center**) on the Formatting toolbar.
Chapter Three: Formatting a Worksheet

- **Using the Format Cells Dialog Box**: Select the cell or cell range and either right-click the selection and select **Format Cells** from the shortcut menu or select **Format → Cells** from the menu. Click the **Alignment tab** and select the desired alignment option.

Adding Borders

- **Using the Formatting Toolbar**: Select the cell or cell range you want to add a border(s) to and click the **Border Style list arrow** on the Formatting toolbar and select the border you want.

- **Using the Format Cells Dialog Box**: Either right-click the selection and select **Format Cells** from the shortcut menu or select **Format → Cells** from the menu. Click the **Border tab** and select the border(s) you want to add.

Applying Colors and Patterns

- **Using the Formatting Toolbar**: Select the cell or cell range and click the **Fill Color list arrow** on the Formatting toolbar and select the color you want.

- **Using the Format Cells Dialog Box**: Either right-click the selection and select **Format Cells** from the shortcut menu, or select **Format → Cells** from the menu. Click the **Patterns tab** and select the color or pattern you want to use.

Using the Format Painter

- The Format Painter lets you copy the formatting of a cell or cell range formatting attributes and apply or paste the formatting to other cells.

- **To Use the Format Painter**: Select the cells with the formatting options you want to copy, click the **Format Painter button** on the Standard toolbar, and select the cell range where you want to apply the copied formatting.

- Double-click the **Format Painter button** to apply formatting to several locations. Click the **Format Painter button** again when you’re finished.

Using AutoFormat

- AutoFormat automatically formats your worksheets using one of sixteen 16 preset formatting schemes.

- Select **Format → AutoFormat** from the menu and select one of the 16 AutoFormats from the list.

Creating a Custom Number Format

- **To Create a Custom Number Format**: Select the cell or cell range you want to format, select **Format → Cells** from the menu and click the **Number tab**, and select the **Custom category**. Type a number format in the **Type box** using the appropriate format codes.

Creating, Applying, and Modifying a Style

- A style is a collection of formats (Number, Font, Borders, Alignment, Pattern, and Protection) you can define and save as a group so you can apply all of the formatting elements at once.

- **To Create a Style by Example**: Select a cell or cell range and apply the formatting you want to use in the style. Once the cell or cell range is formatted, select it and select **Format → Style** from the menu. Enter a name for the style in the Style name box.

- **To Apply a Style**: Select a cell or cell range you want to format, Select **Format → Style** from the menu, select the style from the Style list and click **OK**.
To Modify a Style: Select Format → Style from the menu, select the style you want to modify from the Style list and click Modify. Modify any of the styles formatting attributes and click OK when you're finished. Every cell formatted using that style will be updated.

Formatting Cells with Conditional Formatting

• Conditional formatting is a format, such as cell shading or font color, that Excel automatically applies to cells if a specified condition is true.

• To Conditionally Format a Cell or Cell Range: Select the cell or cell range you want to format conditionally and select Format → Conditional Formatting from the menu. Enter the condition (for example Cell Value is greater than 10), click the Format button and specify the formatting you want to use if the condition is true. If you want to specify additional conditions for the selected cells, click the Add button, otherwise click OK.

Merging Cells, Rotating Text, and using AutoFit

• To Merge Cells: Select the cells that you want to merge, select Format → Cells from the menu, click the Alignment tab, select the Merge cells checkbox and click OK.

• To Rotate Text in a Cell: Select the cell or cell range, select Format → Cells from the menu and click the Alignment tab. Select one of the options in the Orientation section or adjust the angle by dragging the text rotation tool.

Finding and Replacing Formatting

• To Find and Replace Cell Formatting: Select Edit → Replace from the menu and click Options. Click the top Format button, specify the formatting options you want to search for and click OK. Click the bottom Format button, specify the new formatting options and click OK. Click Find Next to find each occurrence of cell formatting and Replace to replace the cell formatting or click Replace All to replace all occurrences of the cell formatting.

Quiz

1. Which of the following procedures changes the font size? (Select all that apply.)
   A. Select the text and choose a point size from the Font list on the Formatting toolbar.
   B. Select the cell(s) and right-click the selection, select Format Cells from the shortcut menu, click the Font tab, select the font size, and click OK.
   C. Select the cell(s), select Format → Cells from the menu, click the Font tab, select the font size, and click OK.
   D. All of the above.

2. Which is NOT a method for applying boldface to a selected cell range?
   A. Select Format → Cells from the menu, click the Font tab, and select Bold from the Font style list.
   B. Press <Ctrl> + <B>.
   C. Right-click the text and select Boldface from the shortcut menu.
   D. Click the Bold button on the Formatting toolbar.
3. To copy formatting from one cell in a worksheet and apply it to another cell you would use:
   A. The Edit → Copy Format and Edit → Paste Format commands from the menu.
   B. The Format Painter button on the Standard toolbar.
   C. There is no way to copy and apply formatting in Excel—you would have to do it manually.
   D. The Copy and Apply Formatting dialog box, located under the Format → Copy and Apply menu.

4. The numbers in your worksheet look like this: 1000. You want them to look like this: $1,000.00. How can you accomplish this?
   A. Click the Currency Style button on the Formatting toolbar.
   B. Select Format → Money from the menu.
   C. You have to retype everything and manually add the dollar signs, commas, and decimals.
   D. None of the above.

5. A date is considered a value, and therefore you can change how it is displayed. For example, 5/12/99 could be reformatted to May 12, 1999 (True or False?)

6. Which of the following is NOT a method for adjusting the width of a column?
   A. Drag the column header’s right border to the left or right.
   B. Double-click the column header’s right border.
   C. Select the column header and click the Column Width button on the Standard toolbar.
   D. Right-click the column header, select Column Width from the shortcut menu, and enter the column’s width.

7. Which of the following statements is NOT true:
   A. Clicking the Center button centers the text or numbers inside the cell.
   B. The Merge and Center button merges several cells into a single larger cell and centers the contents inside the cell.
   C. You can change cell alignment by clicking Format → Cells from the menu and clicking the Alignment tab.
   D. Cells can only display one line of text—they can’t wrap text inside the cell.

8. What is the procedure(s) for adding a border above and below a selected cell range? (Select all that apply)
   A. Select Format → Cells from the menu, click the Borders tab, click the top and bottom lines in the border preview diagram, and click OK.
   B. Type several underscore (_) characters cells above and below the cell range.
   C. Click the Border button arrow on the Formatting toolbar, and select the appropriate border formatting from the list.
   D. Click the Underline button on the Formatting toolbar.

9. AutoFormat automatically formats your worksheet using one of sixteen present formatting styles (True or False?)
10. How can you make a certain cell yellow?
   A. Click the Highlight button on the Standard toolbar.
   B. Click the Fill button arrow on the Formatting toolbar and click the yellow color.
   C. Select Format → Color → Yellow from the menu.
   D. Click the Borders button arrow on the Formatting toolbar and click the yellow color.

11. You have four cells that you want to combine into one. How can you do this?
   A. Select the cells and click the Merge Cells button on the Formatting toolbar.
   B. Select the cells and select Tools → Merge Wizard from the menu.
   C. Select the cells and click the Merge and Center button on the Formatting toolbar.
   D. Select the cells and select Edit → Merge Cells from the menu.

12. You want to use the Format Painter to apply formatting to several cells in a worksheet that are not next to each other. How can you do this?
   A. Click the Format Painter button on the Standard toolbar.
   B. Double-click the Format Painter button on the Standard toolbar.
   C. This isn’t possible.
   D. Open the Copy and Apply Formatting dialog box by selecting Format → Copy Formatting from the menu.

13. How can you rotate text in a cell?
   A. Select Format → Cells from the menu and click the Alignment tab.
   B. Click the Alignment button arrow from the Formatting toolbar and select the desired alignment.
   C. Select Format → Text Direction from the menu.
   D. Right-click the cell and select Text Direction from the shortcut menu.

14. You want to change the dates in a worksheet so that they appear as October 15, 2001 instead of 10/15/01. How can you do this?
   A. Select the cells and click the Long Date button on the Formatting toolbar.
   B. You will have retype all the dates, as there is no way to reformat them.
   C. Select the cells and select Format → Cells from the menu, click the Number tab, select Date from the Number list and select the date format you want.
   D. You will need to call your system administrator have him or her install the Microsoft Long Date patch for you.

Homework

1. Open the Homework 3 workbook and save it as “Formatting Practice”.
2. Resize the A column so that you can completely see all the tour packages.
3. Change the font of the worksheet title to Times New Roman.
4. Make the worksheet title bold, change its color to dark blue, and its size to 14 pt.
5. Change the tour package sales amounts to currency formatting.
6. Center the column headings (Qtr 1 to Total) and apply bold formatting to them.
7. Add a bottom border to cell range B7:F7.
8. Merge the cell range A1:F1 into a single cell that spans the worksheet.

**Quiz Answers**

1. D. All of these procedures change the font size.
2. C. There is not a Boldface option in the shortcut menu.
3. B. The Format Painter copies formatting from one area of a worksheet and applies it to another area.
4. A. The currency button on the Formatting toolbar applies the currency number formatting.
5. True. Date value can be displayed in a number of ways—but they’re still the same date.
6. C. There isn’t a Column Width button on the Standard toolbar.
7. D. Cell can display multiple lines of text. Select Format → Cells, click the Alignment tab, and check the Wrap Text check box.
8. A and C. You can add a border to a select cell range by selecting a border from the Border button on the Formatting toolbar or by selecting Format → Cells from the menu and clicking the Borders tab.
9. True. AutoFormat automatically applies one of sixteen formatting styles to your worksheet.
10. B. You can make a cell yellow by clicking the Fill button arrow on the Formatting toolbar and selecting a yellow color.
11. C. You can merge several selected cells into a single cell by clicking the Merge and Center button on the Formatting toolbar.

12. B. Double-click the Format Painter button on the Standard toolbar to apply formatting to several non-adjacent cells in a worksheet. Click the Format Painter button when you’re finished applying the formatting.

13. A. You can rotate text in a cell by selecting Format → Cells from the menu and clicking the Alignment tab.

14. C. You can format date values by selecting Format → Cells from the menu, clicking the Number tab, select Date from the Number list and selecting the date format.
Chapter Objectives:
- Create a chart
- Move and resize a chart
- Format objects in a chart
- Change a chart’s source data
- Change a chart type
- Add titles, gridlines, annotations, and a data table to a chart
- Work with a 3-D chart
- Create and work with a custom chart
- Plot data on a map

Chapter Task: Create a chart that plots survey data

You already know what a chart is—charts illustrate data, relationships, or trends graphically. Like the saying “a picture is worth a thousand words” charts are often better at presenting information than hard to read numbers in a table or spreadsheet.

In this chapter, you will learn just about everything there is to know about charts—how to create dynamic-looking charts, edit and format charts, and work with different types of charts. Creating and working with charts in Excel is easier than you might think and actually is quite fun. The dazzling charts you will be able to create after you finish this chapter will amaze both you and your colleagues.
Lesson 4-1: Creating a Chart

You can plot most of the information in a worksheet on a chart—and that’s what this lesson is about! This lesson will give you practice creating a chart based on data that’s already been entered in a worksheet. The most common (and by far the easiest method) of creating a chart is to use the ChartWizard. Get that image of mysterious old bearded men wearing purple robes, and pointy hats with stars and moons on them out of your mind—the ChartWizard is a feature that walks you through the process of creating a chart.

1. Start Excel, open the workbook named Lesson 4A and save it as Survey Results.

The first step in creating a chart is to select the cells that contain both the values and labels you want to chart.
2. **Select the cell range A4:E7 then click the Chart Wizard button on the Standard toolbar.**
   
The Chart Wizard opens, as shown in Figure 4-1. The first step in creating a chart is selecting the type of chart you want to create from the Chart type list. You can preview how your data will appear in each type of chart by selecting the chart type and then clicking the Press and hold to view sample button. You want to create a Column chart, and since the Column chart type is already selected you can move on to the next step.

3. **Click Next to accept the Column chart type and move to the second step in the Chart Wizard.**
   
The second step in the Chart Wizard lets you select the cell range you want to chart. You also have to specify if the data series (the information you’re plotting in your chart) is from the rows or columns of the worksheet. You want to use the rows option so your chart will be plotted by destination. Since this is the current selection you don’t need to change anything. The cell range A4:E7 appears in the Data range text box because you have already selected the cell range before starting the Chart Wizard. Since the chart options here are correct, you can move to on to the next step.

4. **Click Next to move to the third step in the Chart Wizard.**
   
The third step in the Chart Wizard presents you with a sample of your chart, as shown in Figure 4-2. Here you can add titles to the chart and axis’s, a legend, data labels, gridlines, and a data table.

5. **Click the Chart title box and type Travel Purpose Survey Results.**
   
The Chart title appears in the Sample Chart.

6. **Click Next to move to the fourth step in the Chart Wizard.**
   
The forth and final step in the Chart Wizard is to determine the chart’s location. There are two options:
   - **As new sheet:** The chart will be placed on a separate, new sheet in the workbook. You can enter a name for this new sheet, or accept Excel’s default sheet name.
   - **As object in:** The chart will be placed on the same sheet as the data.

   You want to place your chart on the current worksheet, which is already selected, so you can finish the Chart Wizard.

7. **Click Finish to complete the Chart Wizard.**
   
The Chart Wizard dialog box closes, and the column chart appears in the active worksheet, as shown in Figure 4-3. Your chart may be covering a large portion of the worksheet data—don’t worry about it. You’ll learn how to move and resize a chart in the next lesson.

8. **Save your work.**
   
Congratulations! You’ve just created your first chart. Turn the page to learn how you can move a resize the chart.

---

**Quick Reference**

**To Create a Chart with the ChartWizard:**

1. Select the cell range that contains the data you want to chart and click the Chart Wizard button on the Standard toolbar.

Or...

Select the cell range and select Insert → Chart from the menu.

2. (Step 1 of 4) Select the chart type and click Next.

3. (Step 2 of 4) Verify (or change) the cell range used in the chart and click Next.

4. (Step 3 of 4) Adjust the chart options by clicking the categorized tabs and selecting any options then click Next.

5. (Step 4 of 4) Specify where you want to place the chart (as an embedded object or on a new sheet) and click Finish.
Lesson 4-2: Moving and Resizing a Chart

More often than not, initially charts are not the size you want them to be. In this lesson, you will learn how to resize a chart to make it larger or smaller. You will also learn how to move a chart to a new location in the worksheet.

1. **Make sure the chart is selected.**
   
   If the chart isn’t selected, all you have to do is click it to select it. Six boxes, called *sizing handles*, appear along the edges of a chart any time it is selected. Sizing handles are used to change the size of charts and other objects.

2. **Click and hold the blank area just before the border of the chart. Drag the chart down and to the left about an inch and release the mouse button.**
   
   The pointer changes to a + , and a dotted outline of the chart appears as you are moving the chart to a new location.
You can resize a chart by clicking and dragging any of its *sizing handles*, located along the border of any selected chart.

3. **Position the pointer over the lower-right sizing handle**, until the pointer changes to a ↘, then drag the mouse diagonally down and to the right, until the chart is about 25% larger.
   
   The chart is resized. You can also make a chart or object smaller by dragging the sizing handles up and to the left. You can also move and resize objects in a chart using the same procedures.

4. **Click the chart legend to select it.**
   
   Selection handles appear around the legend. Once you have selected an object you can move or resize it.

5. **Drag the legend to the lower-right corner of the chart, so that it is at the same level as the destination titles.**
   
   The chart legend is moved to the new location.

6. **Click anywhere outside the chart to deselect the legend and the chart.**

7. **Save your work.**

   The skills you’ve just learned, moving and resizing objects, are especially important because you can use them to move and resize just about any type of object. You can even use these skills to move and resize objects in other programs, such as Microsoft Word or PowerPoint.
Lesson 4-3: Formatting and Editing Objects in a Chart

Here’s an important fact you need to know: you can select, format, and edit every object in a chart. For example, you can change the style, size, and color of any of the fonts used in a chart, or the background color of the chart. After you’ve completed this lesson you’ll be a pro at formatting anything and everything in a chart. Some items that can be formatted and edited in a chart include:

- Chart Title
- Any Data Series
- Chart’s Gridlines
- Chart Legend
- Chart Background Area
- Chart Plot Area
- Data tables
- Category Axis

There are two methods you can use to select a chart object. The first method is to simply click an object to select it. Sometimes when selecting a chart object it can be tricky to know exactly where or what to click (for example, what would you click to select the chart’s plot area?) In these cases it is easier to use the second method: select the object from the Chart Object list on the Chart toolbar.

The Chart Object list

Other Ways to Select an Object:
- Click the object.
1. **Click the chart to select it.**
   The first object you want to format on the chart is the Pleasure Data series. Of course, you must first select the Pleasure Data series before you can format it. You can select the Pleasure Data series from the Chart Object list on the Chart toolbar.

2. **Click the Chart Objects list arrow on the Chart toolbar and select Series "Pleasure" from the list.**
   
   **NOTE:** If the Chart toolbar doesn’t appear on your screen, you can display it by selecting View → Toolbars → Chart from the menu.

   Selection boxes appear on the three columns of the Pleasure data series in the chart. Now that you’ve selected the Pleasure series, you can format it.

3. **Click the Format Object button on the Chart toolbar and click the Patterns tab if necessary.**
   The Format Data Series dialog box appears, as shown in Figure 4-7. You are presented with a variety of different formatting options that you can apply to the selected data series. We’ll take a closer look at how to format a data series in an upcoming lesson—for now, just change the color of the data series.

4. **Click a green color from the color palette in the Area section and click OK.**
   The dialog box closes and the color of the Pleasure data series changes to green. Next, try formatting the chart’s legend so you can place it in a better location on the chart.

5. **Double-click the chart’s legend to format it and select the Placement tab.**
   The Format Legend dialog box appears, as shown in Figure 4-8.

6. **Select the Bottom option and click OK.**
   The dialog box closes and the legend appears at the bottom of the chart.

7. **Double-click the Chart’s title (Travel Purpose Survey Results) to format it, and click the Font tab.**
   The Format Chart Title dialog box appears, as shown in Figure 4-9. Change the font of the chart’s title as follows:

8. **Select Bold Italic from the Font Style list, click the Color list arrow and select a Blue color, then click OK.**
   The dialog box closes and the chart title is formatted with the font options you selected.

9. **Compare your chart to the one in Figure 4-10 and save your work.**
   There are so many different types of chart objects, each with their own individual formatting options, that it would take days to go through all of them. Instead, this lesson has given you a general guideline to follow to select and format any type of chart object you encounter.
Lesson 4-4: Changing a Chart's Source Data

Once you create a chart, you may decide to change which worksheet cells contain the values and labels you want to plot in the chart. For example, you might add a new column or row to a worksheet and then want to include it in an existing chart. Or you might want to remove some cells that you no longer want to be plotted in a chart. This lesson shows you how to change a chart’s source data, or which worksheet cells that contain the values and labels the chart is based on.

1. Click cell B5, type 100 and press <Enter>.
   Notice that the chart is updated, reflecting the change in value. You decide to add another column to display the total purposes for traveling for all the destinations. First, you need to add a column heading.

2. Click cell F4, click the Bold button and the Center button on the Formatting toolbar, type Total and press <Enter>.
   Next, total the purposes for traveling for all of the destinations.
3. **Make sure cell F5 is the active cell, click the AutoSum button on the Standard toolbar (note that Excel automatically selects the correct cell range, B5:E5) and click the Enter button on the Formula bar.**

   Excel totals all the values in the Business row. Use AutoFill to copy the formula you just created to the remaining cells.

4. **Copy the formula in cell F5 to the cell range F6:F8.**

   You can copy the formula using AutoFill (the fastest and easiest method) or by copying and pasting. Next, you want to modify the chart so it displays only the data from the Total column you just added.

5. **Click the chart to select it.**

   Selection handles appear at the corners and sides of the chart and the Chart toolbar appears. Now you need to change the source data for the chart.

6. **Select Chart → Source Data from the menu and click the Data Range tab.**

   The Source Data dialog box appears, as shown in Figure 4-11. This is where you can change the chart’s source data. Notice the Data range box currently contains =Sheet1!$A$4:$E$7—the cell range for the chart’s current data source. You want the data source to be the labels from the Purpose column—A4:A7, and the values from the Total column—F4:F7.

7. **Select the cell range A4:A7.**

   If the dialog box is in the way, you can temporarily hide it by clicking the data range box’s Collapse dialog button. OK, you’ve got the A (Purpose) column selected. So how can you select the F (Total) column since the two columns are not next to each other? Move on to the next step to find out.

8. **Press and hold the <Ctrl> key, select the cell range F4:F7, release the <Ctrl> key and press <Enter>.**

   Pressing and holding the <Ctrl> key lets you select cells that are not next to each other. The chart plots the new cells you specified as a data source. We have one more thing to look at while the Source Data dialog box is still open.

9. **Click the Series tab.**

   The Series tab of the Source Data dialog box appears, as shown in Figure 4-12. You don’t have to touch anything here—we just want to take a quick look at this screen. Once you have selected the source data for the chart, you can add, change, and delete the data series and name series used here, on the Data Range tab.

10. **Click OK.**

    Compare your chart with the one in Figure 4-13.

---

**Quick Reference**

**To Change a Chart’s Data Source:**

1. Select the chart, select Chart → Source Data from the menu and click the Data Range tab.

2. Click in the Data Range box and select the cell range you want to base the chart on (click the Collapse Dialog box button if necessary.)

3. Click **OK.**

**To Use Non-Adjacent Cell Ranges in a Chart:**

- Select the first cell range, then press and hold the <Ctrl> key as you select the remaining non-adjacent ranges.
Lesson 4-5: Changing a Chart Type and Working with Pie Charts

Just as some lures are better than others for catching certain types of fish, different types of charts are better than others for presenting different types of information. So far, you have been working on a column chart, which is great for comparing values for different items, but not so great for illustrating trends or relationships. In this lesson, you will learn how and when to use different types of charts. You will also learn a valuable tip when working with pie charts—how to pull a slice of the pie away from the chart.

1. **Click the chart to select it.**
2. **Click the Chart Type List arrow from the Chart toolbar and select the Pie Chart.**
   The chart changes to a pie chart, as shown in Figure 4-14. What happened? Why is there only one piece of the pie instead of three? It’s because Excel is still plotting the data by rows (destinations) instead of by columns (purpose).

   **NOTE:** Sometimes when you change chart types, the formatting options for one chart type may not be appropriate for another chart type. An improperly formatted chart appears cluttered and difficult to read. To solve this problem: 1.) Select Chart → Chart Type from the menu 2.) Select the chart type and sub-type you want to use 3.) Select the Default formatting checkbox and click OK.

3. **Click the By Column button on the Chart toolbar.**
   Excel changes the data series for the chart from rows to columns and properly displays the chart. You decide you want to pull the business slice of the pie away from the pie chart to emphasize it.
5. Click the actual **chart plot area** to enter edit mode.
   The chart plot area is the actual chart, in this case, the circular pie chart. Sizing handles appear on the business slice.

6. Click the **business slice** of the pie to select it (selection handles should appear on the slice) and then click and drag it away from the chart about a half-inch.

   **NOTE:** Make sure you click the slice of the pie you want to pull away from a chart before you drag it. You will pull all the pieces of a pie chart away if you simply drag-and-drop a piece without clicking and selecting it first.

Because Excel offers so many different types of charts and graphs, you should have a general idea which type of chart to use in which circumstances. **Table 4-6: Types of Charts and Graphs** shows some of the more commonly used charts and graphs and gives explanations on how and when they are used.

### Table 4-6: Types of Charts and Graphs

<table>
<thead>
<tr>
<th>Chart or Graph Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Column</strong></td>
<td>Column charts are used when you want to compare different values vertically side-by-side. Each value is represented in the chart by a vertical bar. If there are several series, each series is represented by a different color.</td>
</tr>
<tr>
<td><strong>Bar</strong></td>
<td>Bar charts are just like column charts, except they display information in horizontal bars rather than in vertical columns.</td>
</tr>
<tr>
<td><strong>Line</strong></td>
<td>Line charts are used to illustrate trends. Each value is plotted as a point on the chart and is connected to other values by a line. Multiple items are plotted using different lines.</td>
</tr>
<tr>
<td><strong>Area</strong></td>
<td>Area charts are the same as line charts, except the area beneath the lines is filled with color.</td>
</tr>
<tr>
<td><strong>Pie</strong></td>
<td>Pie charts are useful for showing values as a percentage of a whole. The values for each item are represented by different colors.</td>
</tr>
<tr>
<td><strong>Scatter</strong></td>
<td>Scatter charts are used to plot clusters of values using single points. Multiple items can be plotted by using different colored points or different point symbols.</td>
</tr>
<tr>
<td><strong>Combination</strong></td>
<td>Combination charts combine two different types of charts together. For example, a combination chart might contain both a column chart and a line chart.</td>
</tr>
</tbody>
</table>
Lesson 4-6: Adding Titles, Gridlines, and a Data Table

There are a lot of ways you can make a chart easier to read and understand. You can add titles to the chart’s X- (horizontal) axis or Y- (vertical) axis, add gridlines, and a legend. This lesson explains how to add and modify these items, and how you can enhance your charts to make them easier to understand.

1. **Make sure the chart is selected, then select Chart → Chart Type from the menu, select the Column chart type from the Chart type list, click the Default formatting checkbox and click OK.**
   
The chart is changed from a pie chart to a column chart. Selecting the default formatting checkbox removes any previous formatting you’ve applied to the chart type and returns the chart to the default appearance. The selected chart changes from a pie chart to a column chart. Next, you need to change the data source for the chart.

2. **Select Chart → Source Data from the menu, select the cell range A4:E7 (click the Collapse dialog button if you need to) and press <Enter>.**
   
The column chart is updated to reflect the changes in the data source.

3. **Select Chart → Chart Options from the menu and click the Titles tab.**
   
The Titles tab of the Chart dialog box appears, as shown in Figure 4-17. The chart title was removed when you applied the default formatting to the chart, so you will have to reenter it.
4. Click the **Chart Title** text box and type **Survey Results**.

Now add titles to the X and Y-axis.

5. Click the **Category (X) axis** textbox and type **Purpose**, then click the **Category (Y) axis** textbox and type **Reservations**.

Next, add some data labels to the data series.

6. Click the **Data Labels tab** and click the **Show value option** in the **Data labels section**.

The chart preview area displays a sample chart with the added data labels.

7. Click the **Data Table tab**, check both the **Show data table** and **Show legend keys** check boxes.

A data table displays the numbers the chart is based on. Since you’re working with an embedded chart (instead of a chart on a separate sheet) this information is already displayed in the worksheet, so you don’t really need a data sheet. But, for practice’s sake, try adding a data sheet.

8. Click **OK**.

The Chart Options dialog box closes and the chart is updated to reflect the changes you made to it. You can remove the data table since you don’t need it.

9. Click the **Data Table button** on the Chart toolbar.

The data table disappears from the chart. Next, see how the chart will look if you add some gridlines.

10. Select **Chart → Chart Options** from the menu, click the **Gridlines tab**, make sure the **Major Gridlines checkbox for the (Y) Axis** and the **Major Gridlines checkbox for the (X) Axis** are both checked.

11. Click **OK**.

The Chart Options dialog box closes, and the chart reflects the changes you made, as shown in Figure 4-19.

---

**Quick Reference**

To Add or Remove Gridlines from a Chart:
1. Select the chart, select **Chart → Chart Options** from the menu, and click the **Gridlines tab**.
2. Check or uncheck the check the appropriate gridline check boxes.

To Add or Change Titles to a Chart:
1. Select the chart, select **Chart → Chart Options** from the menu, and click the **Titles tab**.
2. Enter or modify the text in the text boxes that correspond to the desired chart titles.

To Add or Remove a Data Table:
- Click the **Data Table button** on the Chart toolbar.

Or…
1. Select the chart, select **Chart → Chart Options** from the menu, and click the **Data Table tab**.
2. Check or uncheck the appropriate check boxes to hide or display a data table.
3. Select one of the placement options for the legend.

To Add or Remove Chart Data Labels:
1. Select the chart, select **Chart → Chart Options** from the menu, and click the **Data Labels tab**.
2. Check or uncheck the check the appropriate check boxes to display or hide data labels.
Lesson 4-7: Formatting a Data Series and Chart Axis

You’ve already learned how to select and format objects in a chart—this lesson explores how to format two of the more tricky objects: a chart’s data series and axis.

First, what exactly is a data series? A data series is a group on a chart that comes from the same row or column on a worksheet. Each data series in a chart has its own unique color or pattern. Most chart types can plot more than one data series in a chart at a time—such as the current column chart does, with the Business, Pleasure, and Other data series. One exception is pie charts, which can only plot a single data series.

OK then, what is a chart axis? An axis is the line at the side of a chart that provides a scale of measurement or comparison in a chart. For most charts, data values are plotted along the value vertical (y) axis and categories are plotted along the horizontal category (x) axis.

Now that you (hopefully) understand what a data series and axis are, move to Step 1 to learn how to format them.

1. Make sure the chart is selected, click the Chart Objects list arrow on the Chart toolbar and select Series “Eastern U.S..”
   Remember, if the Chart toolbar doesn’t appear on your screen you can display it by selecting View → Toolbars → Chart from the menu.
   Selection handles appear around each of the Eastern U.S. columns, indicating the series is selected. Once you select a chart element you can format and change the element’s settings.

2. Click the Format Object button on the Chart toolbar. Then click the Patterns tab.
   The Format Data Series dialog box appears with the Patterns tab in front. Here you can change the color, texture, border and other options of the selected data series.
3. Select a dark blue color.
   This will format the columns in the Eastern U.S. data series with a dark blue color. You could also change the border or line color, style, and weight for the data series—or remove it all together.

4. Click the Data Labels tab, select the Show label option and click OK.
   This option will display a label above the data series. The Format Data Series dialog box closes and the changes are made to the Eastern data series.
   Here's how to format a chart's axis.

5. Click the Chart Objects list arrow on the Chart toolbar and select the Value Axis.
   Now format the Y-axis.

6. Click the Format Object button and click the Scale tab.
   When you create a chart, Excel automatically creates the scale of the chart. Ninety percent of the time you won't need to change a chart's default scale. For that other ten percent of time, here's how you can enter your own values for the chart's scale:

7. Click the Major unit textbox, type 25, click the Maximum box and type 90.
   This will adjust the scale of the chart, so the maximum value on the scale will be 90 instead of 120, and the increment scale will be 25 instead of 20.

8. Click OK.
   The Format Axis dialog box closes and the changes are made to the Y-axis.

Since we only looked at a couple tabs in the Data Series dialog box, refer to Table 4-7: The Data Series Dialog Box Tabs to see what those other tabs do.

### Table 4-7: The Data Series Dialog Box Tabs

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Patterns</td>
<td>Changes a data series' colors, borders, and fill effects.</td>
</tr>
<tr>
<td>Axis</td>
<td>Allows you to plot the selected data series on a secondary axis—often used in combination charts.</td>
</tr>
<tr>
<td>Y Error Bars</td>
<td>Adds graphic bars that express the potential error (or degree of uncertainty) for each data marker in a series.</td>
</tr>
<tr>
<td>Data Labels</td>
<td>Adds value or data labels to the selected data series.</td>
</tr>
<tr>
<td>Series Order</td>
<td>Changes the order of the selected data series in the chart.</td>
</tr>
<tr>
<td>Options</td>
<td>Changes the width of all the data series in a chart, and if the data series should overlap one another.</td>
</tr>
</tbody>
</table>

The Fill Effects button in the Format Data Series dialog box lets you add dramatic effects to selected data series—you can even use a picture to fill or color a data series!

Quick Reference

**To Add Labels to a Data Series:**

1. Double-click the data series.
   Or...
   Right-click the data series and select **Selected Object** from the shortcut menu.

2. Click the Data Labels tab and select the appropriate option.

**To Change the Scale of a Chart:**

1. Double-click the axis.
   Or...
   Right-click the axis and select **Format Axis** from the shortcut menu.

2. Click the Scale tab and make the changes to the scale.
Lesson 4-8: Annotating a Chart

One of the best new features in Excel is the greatly improved drawing capabilities. You can easily annotate your charts and worksheets by adding lines, arrows, text boxes, and a huge variety of shapes. To use Excel’s drawing capabilities, you need to use the Drawing toolbar, which contains many tools for drawing shapes, lines, and arrows, and for formatting graphic objects with different coloring, shadow, and 3-D effect options.

Although we’ll be using Excel’s drawing features to annotate a chart in this lesson, you can also draw on worksheets to enhance them with arrows, text, and shapes.

1. **Click the Drawing button on the Standard toolbar.**
   The Drawing toolbar appears, as shown in Figure 4-22. The Drawing toolbar gives you several tools you can use to add text, lines, and graphics to charts and worksheets.

2. **Click the Text Box button on the Drawing toolbar.**
   The pointer changes to a text box, indicating you can click and enter a caption or callout in the chart or worksheet.

3. **Click to the right and slightly below the chart title with the text box pointer and type End of Promotion, as shown in Figure 4-23.**
   Go to the next step to add an arrow to the annotation.

4. **Click the Arrow button on the Drawing toolbar.**
   This time the pointer changes to an arrow.
5. Move the pointer to the left of the End of Promotion text, click and hold down the mouse button, drag the line to the Pleasure columns, and release the mouse button.

   Compare your chart with the one in Figure 4-23. You won’t need the drawing toolbar any more in this chapter, so here’s how to get rid of it.

6. Click the Drawing button on the Standard toolbar.

   The Drawing toolbar disappears.

7. Save your work.

   Although we didn’t cover every tool on the Drawing toolbar, the procedure for using each of them is the same. Remember that you can use the Drawing toolbar to add lines, arrows, shapes, and text boxes to both your charts and worksheet.

   Quick Reference

   To View the Drawing Toolbar:
   • Click the Drawing button on the Standard toolbar.
   Or...
   • Select View → Toolbars → Drawing from the menu.

   To Draw an Object:
   1. Click the object you want to draw on the drawing toolbar (such as a line or circle).
   2. Drag the crosshair pointer to draw the object.

   To Resize an Object:
   1. Click the object to select it.
   2. Drag the object’s sizing handles to resize it.
Lesson 4-9: Working with 3-D Charts

Three-dimensional (3-D) charts are some of the coolest-looking types of charts, but they don’t always display their information correctly. The data in 3-D charts is often obscured by another data series. This lesson explains how you can rotate and elevate a 3-D chart to make sure everything is visible. There are two methods you can use to change the rotation and elevation of a 3-D chart:

- **Using the 3-D View Dialog box:** Using the 3-D View dialog box (which you can find by selecting Chart → 3-D View from the menu) lets you rotate a 3-D chart with a high degree of precision.

- **Using the Mouse:** Using the mouse is a quick method of rotating a 3-D chart—but it can be tricky and requires a lot of ‘mouse dexterity.’

This lesson explains how to rotate a 3-D chart using both methods.

Figure 4-24
Selecting a 3-D column chart in the Chart Type dialog box.

Figure 4-25
The steps in rotating a chart.

Figure 4-26
The 3-D View dialog box.
Chapter Four: Creating and Working with Charts

1. Make sure the chart is selected and select Chart → Chart Type from the menu.
   The Chart Type dialog box appears, as shown in Figure 4-24.

2. Select the Clustered column with a 3-D visual effect, as shown in Figure 4-24, click the Default formatting checkbox to select it.
   The Default formatting checkbox will remove any formatting you’ve applied to the chart and will return the chart to the default appearance.

3. Click OK.
   The chart type is changed to a 3-D clustered column. Here’s how to rotate the chart using the mouse:

4. Click the Chart Object list arrow on the Chart toolbar and select Corners.
   Selection handles appear on the corner of the chart. Now you can rotate the 3-D chart by clicking and dragging any of the selection handles.

5. Position the pointer over the lower-right corner selection handle of the chart, click and hold the left mouse button, drag the chart down and to the right an inch, as shown in Figure 4-25, then release the mouse button.
   Compare your chart with the one in Figure 4-25. Another way to rotate 3-D charts is with the 3-D View command on the Chart menu.

6. Select Chart → 3-D View from the menu.
   The 3-D View dialog box appears, as shown in Figure 4-26. The 3-D View dialog box lets you rotate a 3-D chart with a high degree of precision. Before you rotate the chart, however, return it to its original position.

7. Click Default.
   The chart is reset to its original position.

8. Click the Increase Elevation button 4 times, until the Elevation textbox reads 35.
   This will change the elevation of the chart. Notice how the preview section displays how the chart will look in the new position.

9. Click the Increase Rotation button 2 times, until the Rotate textbox reads 40, then click Apply.
   The charted is formatted with the new rotation and elevation settings.

10. Click Close and save your work.

Quick Reference

To Rotate a 3-D Chart:
1. Select the chart and select Chart → 3-D View from the menu.
2. Make the rotation and perspective changes in the 3-D View dialog by clicking the appropriate controls and click OK.
   Or...
   1. Select the chart.
   2. Drag the chart’s selection handles.
Lesson 4-10: Selecting and Saving a Custom Chart

So far in this chapter, you have worked with standard charts. You can also create and work with custom charts. Here are the basic differences between the two:

- **Standard Chart Type:** Standard charts include standard, bare bones formatting and chart options. You must add additional formatting and chart options, such as data labels and colors that you want to appear in your chart. You can’t save your own standard chart types.

- **Custom Chart Type:** A Custom chart is similar to a template or style, and contains additional formatting and chart options, such a legend, gridlines, data labels, colors, and patterns for various chart items. You can save custom charts, so you can create new charts based on a custom chart’s formatting and options, saving a lot of time.

This lesson will give you practice creating and saving a custom chart type.

1. Make sure the chart is selected, then select **Chart → Chart Type** from the menu and then click the **Custom Types tab**.

   The Custom Types tab of the Chart Type dialog box appears, as shown in Figure 4-27.

![Figure 4-27](image)

Use the settings from the selected chart as the default settings for new charts.

![Figure 4-28](image)

![Figure 4-29](image)

![Figure 4-30](image)

![Figure 4-27](image)

![Figure 4-28](image)

![Figure 4-29](image)

![Figure 4-30](image)
2. Scroll down the Chart types list and select **Outdoor Bars**, as shown in Figure 4-27 and click **OK**.

   The chart is updated with the Outdoor Bars custom chart settings. The green color of the chart is difficult to read, so you decide to change it.

3. **Click the Chart Objects List Arrow** on the Chart toolbar and select the **Chart Area**.

   Now you can format the chart area.

4. **Click the Format button** on the Chart toolbar, under the **Area section** select the **light yellow color**, as shown in Figure 4-28, and click **OK**.

   The chart area is reformatted with the light yellow color you selected. Next, remove the green coloring from the chart's legend.

5. **Double-click the Chart’s Legend**.

6. In the **Area section**, select **None** and click **OK**.

   The green fill color for the legend disappears.

7. **Click the Chart Objects List Arrow** on the Chart toolbar, select the **Chart Area**, and click the **Format button** on the Chart toolbar.

   You can also double-click the chart area to format it—it’s just sometimes tricky to know where exactly to double-click for some chart objects.

8. **Click the Fonts tab**, make sure **Regular** is selected from the Font style list and click **OK**.

   The bold font formatting disappears from the chart title. Compare your chart with the one in Figure 4-29. You can save the current chart as a custom chart type, so you can quickly apply the formatting and options used in the current chart to other charts.

9. **Select Chart → Chart Type** from the menu, click the **Custom Types tab**, click the **User-defined option** under the Select from section, and click **Add**.

   The Add Custom Chart Type dialog box appears, as shown in Figure 4-30. You must give your custom chart type a name, and if you want, a description.

10. In the **Name textbox**, type **Modified Outdoor Bars** and click **OK**.

    You return to the Chart Type dialog box. The formatting and options for the current chart have been saved as a user-defined custom chart named Modified Outdoor Bars. You can format a chart using the Modified Outdoor Bars settings by: 1.) Selecting Chart → Chart Type from the menu. 2.) Clicking the Custom Types tab and selecting the User-defined option under the Select from section. 3.) Clicking the Custom Chart button. 4.) Clicking OK.

11. **Click OK**.

    The Chart Type dialog box closes.

    You can easily delete any custom charts you no longer need.

12. **Select Chart → Chart Type** from the menu, click the **Custom Types tab**, click the **User-defined option** under the Select from section.

13. **Select the Modified Outdoor Bars custom chart and click Delete**.

    If you normally use a different type of chart than Excel’s default 2-D column chart, you can change the default chart type. Just select the chart you want to use as the default chart, select Chart → Chart Type from the menu, and click the **Set as default chart button**.
Lesson 4-11: Using Fill Effects

You can change the fill pattern used in chart objects to produce dramatic and eye-catching effects. You can change the fill patterns for the Chart Area, the Plot Area, and any columns, bars, or similar plot areas in a chart. This lesson explains how to do just that.

1. Make sure the chart is selected, click the Chart Objects List Arrow on the Chart toolbar and select the Chart Area.
   You can also double-click the chart area (if you know what it is!) to modify it. Now that you have selected the chart area, you can format it.

2. Click the Format button on the Chart toolbar and click the Patterns tab. The Format Chart Area dialog box appears with the Patterns tab in front. Notice the area section contains a color palette that you can use to fill the selected object. When you want to use more dramatic fill effects to color an object than an ordinary color, you click the Fill Effects button.

3. Click the Fill Effects and click the Gradient tab if necessary. The Fill Effects dialog box opens with the Gradient tab in front, as shown in Figure 4-31.
4. **Click the Two colors option in the Colors section.**
   This indicates that you want to fill the background of the chart using a two-color gradient. You need to select the two colors you want to use in the fill pattern.

5. **Click the Color 1 list arrow, select a Bright Green color then click the Color 2 list and click the Light Green color, as shown in Figure 4-31.**
   Next, you need to select a shading style.

6. **Select the Horizontal option under the Shading Styles section.**
   Notice the sample area in the lower right side of the dialog box previews how your gradient options will look.

7. **Click OK to close the Fill Effect dialog box, then click OK to close the Format Chart Area dialog box.**
   The chart area is formatted with the two-color gradient you selected. Move on to the next step and format the Europe data series with another custom fill effect.

8. **Click the Chart Objects List Arrow on the Chart toolbar, select the “Series Europe” and click the Format button on the Chart toolbar.**
   **Click the Fill Effects button, then click the Picture tab.**
   The Fill Effects dialog box opens, with the Picture tab in front, as shown in Figure 4-33. The Picture tab lets you use a picture or graphic as the fill for the selected object.

9. **Click Select Picture.**
   The Select Picture dialog box appears. You must specify the location and name of the picture or graphic you want to use to fill the data series.

10. **Navigate to your practice folder or disk, select the Triangles file and click OK.**
    This will insert the Triangles graphic file as the fill object for the Europe data series. Notice the sample area in the lower right side of the dialog box, which previews what the picture or graphic looks like.

11. **Under the Format section select Stack and click OK to close the Fill Effect dialog box, then click OK again to close the Format Chart Area dialog box.**
    The Europe data series is formatted with the Triangle pictures as the fill.

12. **Save your changes and close the workbook.**
    Believe it or not, by learning how to use fill patterns, you’ve learned a formatting trick that probably less than five percent of all Excel users know. You should feel proud of yourself.

### Table 4-8: Types of Fill Patterns

<table>
<thead>
<tr>
<th>Fill Pattern Tab</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gradient</td>
<td><img src="gradient.png" alt="Gradient" /></td>
<td>Fills objects with a two-color gradient.</td>
</tr>
<tr>
<td>Texture</td>
<td><img src="texture.png" alt="Texture" /></td>
<td>Fills objects with a texture.</td>
</tr>
<tr>
<td>Pattern</td>
<td><img src="pattern.png" alt="Pattern" /></td>
<td>Fills objects with a pattern.</td>
</tr>
<tr>
<td>Picture</td>
<td><img src="picture.png" alt="Picture" /></td>
<td>Fills objects with a graphic or picture file.</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Add Fill Effects:
1. Double-click the chart object.
   Or...
   Select the object and click the Format button on the Chart toolbar.
2. Click the Patterns tab and click the Fill Effects button.
3. Select one of the four tabs, select a fill effect, and click OK.
Lesson 4-12: Mapping Data

If you’re working with data that is categorized geographically, you can use Microsoft’s Map feature to plot the information.

1. Open the workbook named Lesson 4B and save it as Flight Map. This worksheet contains information on how many airline tickets North Shore Travel sold to various states for the past year. You want to plot this information on a map.

2. Select the cell range A4:A52. The A column contains the names of the states and the B column contains the number of flights to each particular state. Whenever you map data from a worksheet, one column must contain geographic data, such as the names of countries or states.

3. Click the Map button on the Standard toolbar. The mouse pointer changes to a ‖, indicating you must drag a rectangle where you want the map to appear on the worksheet.
4. **Making sure you keep the cell range A4:A52 selected, scroll up until you can see cell D38. Move the + pointer to the upper left corner of cell D38, click and hold the left mouse button and drag the pointer to the lower right corner of cell I52 and release the mouse button.**

   The outline for the map appears on the worksheet and the Multiple Maps Available dialog box appears, indicating that there are several maps you can use to plot your information on. Since all of the states listed on the worksheet are in the continental United States, you can select the United States in North America map option.

5. **Select the United States in North America option and click OK.**

   The Multiple Maps Available dialog box closes, the flight information is plotted on the map, and the Microsoft Map Control dialog box appears. Notice that the menu and toolbars are different than the ones you normally use in Excel. That’s because you’re actually working with a separate program, called Microsoft Map, from inside Excel.

6. **Drag the Dot Density button in the Microsoft Map Control dialog box over the top of the Value Shading button in the box, as shown in Figure 4-35.**

   The map display changes, plotting the information as dots instead as shading. Notice the legend, which indicates that one dot equals fifty flights.

7. **Double-click the North America title, select the existing text by dragging the mouse pointer across it, type Flights by State, and press <Enter>.**

   The new title replaces the old selected title.

8. **Compare your map to the one in Figure 4-36, then save your work.**

   The following table lists the map formats you can use in Microsoft Map and their descriptions.

<table>
<thead>
<tr>
<th>Format Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value Shading</td>
<td>Map regions shaded based on the value of its data.</td>
</tr>
<tr>
<td>Category Shading</td>
<td>Each data value has a unique color, which are used to shade map regions.</td>
</tr>
<tr>
<td>Dot Density</td>
<td>Data is displayed as a series of dots. Larger values = more dots.</td>
</tr>
<tr>
<td>Graduated Symbol</td>
<td>Data is displayed as a symbol. Larger values = larger symbol size.</td>
</tr>
<tr>
<td>Pie Chart</td>
<td>(Requires 2 data values) Displays a pie chart inside each map region.</td>
</tr>
<tr>
<td>Column Chart</td>
<td>(Requires 2 data values) Displays a column chart inside each map region.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Create a Map:**

1. Select the worksheet data you want to use in the map.
2. Select Insert → Map from the menu.

Or...

1. Click the Map button on the Standard toolbar.
2. Click and drag in the worksheet to specify the chart’s location and size.
3. If more than one map is available, select the map you want.

**To Select or Remove a Map Format:**

1. Double-click the map to edit it.
2. Click the Show/Hide Map Control button on the Map toolbar if the Map Control dialog box isn’t visible.
3. Drag the Map Format you want into the box to add a map format, drag the map format from the box to remove a map format.
Lesson 4-13: Modifying a Map

Now that you know how to create a map from worksheet data, this lesson explains how you can modify a map by adding labels and features to the map.

1. Make sure the map object is selected (double-click the map if it isn’t) and select **Map → Features** from the menu.
   The Map Features dialog box appears, as shown in Figure 4-37. Here you can change which features, such as highways and major cities, appear on the map. You can also change the color of these features.

2. Select the **United States** from the list (if it isn’t already selected), click the **Custom option**, click the **Custom list arrow**, select the **gray color** and click **OK**.
   The color of the United States portion of the map changes to gray. Here’s how you can add labels to a map:

3. Select **Tools → Labeler** from the menu.
   The Map Labels dialog box appears, as shown in Figure 4-38. You can create two different types of map labels:
   - **Map feature names**: Creates labels that show the names of map features, such as the names of the states.

Double-click a map to edit it.

© 2001 CustomGuide.com
4. Select the Values from option and click OK.
   The Map Labels dialog box closes and the mouse pointer changes to a ♦.
5. Click the state of Minnesota with the + pointer.
   A value label, 2,015, is added to the state of MN.
6. Repeat Step 5, adding value labels to the states of California, Texas, and New York.
   You can also add your own custom labels, or “pins” to your maps. You can do this by creating a Pin Map.
7. Click the Custom Pin Map button on the Map toolbar.
   The Custom Pin Map dialog box opens, as shown in Figure 4-39. Here you can create a custom pin map—a set of related pins that overlays the map, or you can open an existing pin map.
8. Type New Offices and click OK.
   “New Offices” is the name of your pin map. The pointer changes to a ♦, indicating you can add pins to the map. You will be adding pins indicating where and when North Shore Travel will open new branch offices.
9. Click the state of California with the ♦ pointer, type Open 1st Qtr and press <Enter>.
10. Click the state of Florida with the ♦ pointer, type Open 3rd Qtr, and press <Enter>.
11. Save your work, and then exit Excel.

The following table lists the maps and features that you can use with the Map Feature.

<table>
<thead>
<tr>
<th>Map</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Airports, Cities, Highways, Major Cities</td>
</tr>
<tr>
<td>Canada</td>
<td>Airports, Cities, Highways, Lakes, Major Cities</td>
</tr>
<tr>
<td>Europe</td>
<td>Airports, Cities, Highways, Major Cities</td>
</tr>
<tr>
<td>Mexico</td>
<td>Cities, Highways, Major Cities</td>
</tr>
<tr>
<td>UK</td>
<td>2-Digit Post Codes, Airports, Cities, Highways, Major Cities, Standard Regions</td>
</tr>
<tr>
<td>US (North America)</td>
<td>5-Digit Post Codes, Highways, Major Cities, Great Lakes</td>
</tr>
<tr>
<td>US (AK &amp; HI)</td>
<td>Airport, Cities, Major Cities</td>
</tr>
<tr>
<td>World</td>
<td>Capitals, Countries, Lines of Latitude &amp; Longitude, Oceans</td>
</tr>
</tbody>
</table>
Chapter Four Review

Lesson Summary

Creating a Chart

- **To Create a Chart with the ChartWizard:** 1) Select the cell range that contains the data you want to chart and click the Chart Wizard button on the Standard toolbar or select **Insert → Chart** from the menu. 2) Select the chart type and click **Next**. 3) Verify (or change) the cell range used in the chart and click **Next**. 4) Adjust the chart options by clicking the categorized tabs and selecting any options then click **Next**. 5) Specify where you want to place the chart (as an embedded object or on a new sheet) and click **Finish**.

Moving and Resizing a Chart

- **To Resize a Chart:** Click the chart to select it, then drag its sizing handles (located along the edges of the chart) until the chart is the size you want.

- **To Move a Chart:** Click and hold down the mouse button on the blank area around a chart, drag the picture to a new location in the workbook, then release the mouse button.

Formatting Objects in a Chart

- **To Select a Chart Object:** Click the object or click the Chart Objects list arrow on the Chart toolbar and select the object.

- **To Format a Chart Object:** Double-click the object or select the object and click the Format Object button on the Chart toolbar. You can also format a chart object by right-clicking the object and selecting Format Object from the shortcut menu.

Changing a Chart’s Source Data

- **To Change a Chart’s Data Source:** Select **Chart → Source Data** from the menu and click the Data Range tab. Click in the Data Range box and select the cell range you want to base the chart on (click the Collapse Dialog box button if necessary.)

  - The Collapse Dialog button temporarily shrinks and moves the dialog box so that you enter a cell range by selecting cells in the worksheet. When you finish, you can click the button again or press <Enter> to display the entire dialog box.

  - Select non-adjacent cell ranges by pressing and holding the <Ctrl> key while you select additional cells.

Changing a Chart Type and Working with Pie Charts

- The most common types of charts are column, bar, line, area, pie, and scatter.

- **To Change the Chart Type:** Click the Chart Type list arrow on the Chart toolbar or select **Chart → Chart Type** from the menu.
Chapter Four: Creating and Working with Charts

- **To Chart by Rows or Columns:** Click either the By Columns button or the By Rows button on the Chart toolbar.
- **To Drag a Piece from a Pie Chart:** Click the chart to select it, click the piece of the chart you want to move to select it, drag the piece away from the rest of the chart.

### Adding Titles, Gridlines, and a Data Table

- **To Add or Remove Gridlines from a Chart:** Select Chart → Chart Options from the menu, and click the Gridlines tab. Check or uncheck the appropriate grid line check boxes.
- **To Add or Change Titles to a Chart:** Select Chart → Chart Options from the menu, and click the Titles tab. Enter or modify the text in the text boxes that correspond to the desired chart titles.
- **To Add or Remove a Data Table:** Click the Data Table button on the Chart toolbar.
- **To Add or Remove Chart Data Labels:** Select Chart → Chart Options from the menu, and click the Data Labels tab. Check or uncheck the appropriate check boxes to display or the chart hide data labels.

### Formatting a Data Series and a Chart Axis

- A data series is a group on a chart that comes from a row or column on a worksheet. An axis is a line that borders one side of a chart that provides a scale of measurement or comparison in a chart. For most charts, data values are plotted along the value (y) axis, which is usually vertical, and categories are plotted along the category (x) axis, which is usually horizontal.
- **To Add Labels to a Data Series:** Double-click the data series or select the data series and select Format → Selected Object from the menu. Click the Data Labels tab and select the appropriate option.
- **To Change the Scale of a Chart:** Double-click the axis, or right-click the axis and select Format Axis from the shortcut menu, or select the axis and select Format → Selected Object from the menu. Click the Scale tab and make the changes to the scale.

### Annotating a Chart

- **To View the Drawing Toolbar:** Click the Drawing button on the Standard toolbar or select View → Toolbars → Drawing from the menu.
- **To Draw an Object:** Click the object you want to draw on the drawing toolbar (such as a line or circle) and drag the crosshair pointer to draw the object.
- **Resize a drawing object by selecting it and dragging its sizing handles.**

### Working with 3-D Charts

- **To Rotate a 3-D Chart:** Select the chart and select Chart → 3-D View from the menu. Make the rotation and perspective changes in the 3-D View dialog by clicking the appropriate controls and click OK.

### Selecting and Saving a Custom Chart

- A Custom chart contains formatting and options you specify, such as a legend, gridlines, data labels, and formatting options. You can save custom charts, so you can create new charts based on a custom chart’s formatting and options.
To Create a Custom Chart: Either create or open a chart that is formatted and customized the way you want. Select the chart, select Chart → Chart Type from the menu, and click the Custom tab. Click the User-defined option and click Add to create a custom chart based on the current chart. Enter a name and description for the custom chart and click OK.

Using Fill Effects

To Add Fill Effects: Double-click the chart object or select the object and click the Format button on the Chart toolbar. Click the Patterns tab and click the Fill Effects button. Select one of the four tabs, select a fill effect, and click OK.

Mapping Data

Your data must contain geographical information and values to plot it on a map.

To Create a Map: Select the worksheet data you want to use in the map, click the Map button on the Standard toolbar or select Insert → Map from the menu. Click and drag in the worksheet to specify the chart’s location and size.

To Select or Remove a Map Format: Double-click the map to edit it, click the Show/Hide Map Control button on the Map toolbar if the Map Control dialog box isn’t visible. Drag the Map Format you want into the box to add a map format, drag the map format from the box to remove a map format.

Modifying a Map

To Add or Remove Map Features: Double-click the map to edit it and select Map → Features from the menu. Add or remove a map feature to a map by adding or removing the checkmark next to it.

To Add a Label or Data Value to a Map: Double-click the map to edit it and either click the Label button on the Map toolbar or select Tools → Labeler from the menu. Select either the Map feature names option or the Values from option and click OK. Click where you want to place the label or data value with the pointer.

Quiz

1. All of the following statements about charts are true except...
   A. You can place a chart on the same sheets as the data or on a new worksheet.
   B. To create a chart, select Tools → Chart from the menu.
   C. You can move a chart by clicking it and dragging it by the blank area around the chart to its new location.
   D. You can resize a chart by clicking it and dragging its sizing handles.

2. You want to track the progress of the stock market on a daily basis. Which type of chart should you use?
   A. Line chart.
   B. Column chart.
   C. Row chart.
   D. Pie chart.
3. All of the following are methods to edit or format a chart object except…
   A. Double-click the object
   B. Right-click the object and select Format from the shortcut menu.
   C. Select the object from the Chart Object list on the Chart toolbar and click the Format Object button.
   D. Select Chart → Format from the menu, select the object from the Object list and click Format.

4. Which of the following statements is NOT true?
   A. You can change the cells that are plotted in a chart by selecting the new cells and clicking the Chart Wizard button on the Standard toolbar.
   B. When you change the chart type, all its formatting options will always transfer perfectly to the new type of chart.
   C. Holding down the <Ctrl> lets you select cell ranges that are not next to each other.
   D. You can change the cells that are plotted in a chart by selecting Chart → Source Data from the menu and selecting the new cells.

5. The Drawing toolbar can only be used to annotate charts (True or False?)

6. All of the following statements are true except…
   A. You can change the perspective of 3-D charts by selecting Chart → 3-D View from the menu.
   B. A Standard chart lets you save your chart formatting and settings, so you can create new charts using the same settings.
   C. To add or remove a legend from a chart, click the Legend button on the Chart toolbar.
   D. Many Excel dialog boxes have several Collapse Dialog box buttons, which you can use to temporarily shrink the dialog box to select cells.

7. The categories at the bottom of a chart are also called the…
   A. X-axis.
   B. Y-axis.
   C. Z-axis.
   D. Category axis.

8. Charts cannot be moved or resized once they have been created. (True or False?)

9. How can you open the Chart Options dialog box?
   A. Click the Chart Options button on the Standard toolbar.
   B. Quadruple-click any chart.
   C. Select Chart → Chart Options from the menu.
   D. Select Tools → Chart Options from the menu.

10. Which of the following are objects that you can add to an Excel chart? (Select all that apply.)
    A. A legend.
    B. A data table.
    C. An category or x-axis title.
    D. Data labels.
Homework

1. Open the Homework 4 workbook and save it as “Chart Practice”.
2. What type of chart do you think would work best to present the information in this worksheet?
3. Use the Chart Wizard to create a chart that plots the cell range A3:E7. Give the chart the Chart Title “Package Sales” and place the chart in a separate sheet.
4. Click the legend to select it, and change the font size used in the legend to 12 pt.
5. Make the legend taller by about ½”, and drag it to the bottom right of the chart.
6. Change the chart type to a 3-D Bar chart.
7. Change the color of the Vancouver color series to light green.
8. Use the drawing toolbar to add an arrow that points to the largest number in the chart (Montreal in the fourth quarter) and add a textbox at the other end of the arrow that says “Wow!”
9. Change the chart’s data source so that only the totals for each tour (cell range F4:F7) are plotted in the chart.

Quiz Answers

1. B. Create a chart by clicking the Chart Wizard button on the Standard toolbar or by selecting Insert → Chart from the menu.
2. A. Line charts are used to illustrate trends. If you used the other three chart types to track the stock market, there would be too many data points.
3. A. You change the data source for a chart by selecting Chart → Source Data from the menu and selecting the new cells.
4. A. To change a chart’s source data, select the chart and select Chart → Source Data from the menu.
5. True. You can annotate charts and worksheet with the Drawing toolbar.

6. B. Custom charts, not Standard charts, allow you to save your chart formatting and settings, so you can create new charts using the same settings.

7. A. The categories at the bottom of a chart are also known as the x-axis.

8. False. You can easily move or resize any chart in Excel.

9. C. Select Chart → Chart Options from the menu to open the Chart Options dialog box.

10. A, B, C, and D. All of these are types of objects that you can add to an Excel chart.
Chapter Five: Managing Your Workbooks

Chapter Objectives:

- Navigate between the sheets in a workbook
- Insert, delete, rename, and move worksheets
- Work with several worksheets and workbooks
- Split and freeze a window
- Add headers, footers, and page numbers to a worksheet
- Specify what gets printed and where the page breaks
- Adjust the margins, page size and orientation, and print scale
- Protect and hide a worksheet
- Create and use a template
- Consolidate multiple worksheets

Chapter Task: Work with a weekly summary report

Financial and numeric information often does not fit on a single page. For example, a business’s financial statement usually has several pages—an expense page, an income page, a cash-flow page, and so on. Similarly, Excel’s workbooks contain several worksheets. New workbooks contain three blank worksheets, and you can easily add more.

Up until now, you have only worked with a single worksheet. In this chapter, you will learn how to work with and manage workbooks. You’ll learn how to move between the worksheets, add, rename, move, and delete worksheets, and how to create formulas that reference information from several different worksheets. Along the way, you’ll learn a lot more about printing.

Prerequisites:

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- Open and save workbooks.
- How to enter values and labels.
- How to reference cells.
Lesson 5-1: Switching Between Sheets in a Workbook

This lesson covers the basics of working with worksheets—namely how to move between them. Each worksheet has a tab that appears near the bottom of the workbook window. To switch to a different sheet, all you have to do is click its tab. Easy huh? When there are too many tabs in a workbook to display them all, you can scroll through the worksheet tabs by clicking the scroll tab buttons, located at the bottom of the screen, near the worksheet tabs.

1. Start Microsoft Excel.
2. Open the Lesson 5 workbook and save it as Weekly Reservations.

Excel saves the worksheet in a new file with the name “Weekly Reservations.” This workbook contains several worksheets. It’s easy to switch between the various worksheets in a workbook—simply click the worksheet’s sheet tab. Move on to the next step and try it!
3. Click the **Friday tab**.
   The Friday worksheet appears in front. You can tell the Friday worksheet is active because its sheet tab appears white. Once a worksheet is active, you can edit it using any of the techniques you already know.

4. **Practice viewing the various worksheets in the workbook by clicking the worksheet tabs.**
   You may have noticed by now that there is not enough room to display all of the sheet tabs. Whenever this happens, you must use the tab scrolling buttons to scroll through the sheet tabs until the tab you want appears. Figure 5-1 describes the function of the various Tab Scrolling buttons.

5. Click the **Next Tab Scroll button** until the **Summary tab** appears.

6. **Click the Summary tab.**
   The Summary sheet tab becomes active and its sheet tab changes from gray to white.

7. **Click the First Tab Scroll button to move to the first sheet tab (Tuesday) in the workbook.**
   You can also switch between worksheets by using a right mouse button shortcut menu.

8. **Right-click any of the Tab Scroll buttons.**
   Excel displays a shortcut menu listing the sheets in the current workbook, as shown in Figure 5-2.

9. **Select Wednesday from the shortcut menu.**

---

**Quick Reference**

To **Activate a Worksheet:**
- Click the sheet tab at the bottom of the screen.
  - Or...
  - Right-click the sheet tab scroll buttons and select the worksheet from the shortcut menu.

To **Scroll through Worksheets in a Workbook:**
- Click the corresponding scroll sheet tabs at the bottom of the screen.
Lesson 5-2: Inserting and Deleting Worksheets

An Excel workbook contains three blank worksheets by default. You can easily add and delete worksheets to and from a workbook—and you’ll learn how to do it in this lesson.

1. **Right-click the Comments tab.**
   A shortcut menu appears with commands to insert, delete, rename, move or copy, select all sheets, or view the Visual Basic code in a workbook, as shown in Figure 5-3.

2. **Select Delete from the shortcut menu.**
   A dialog box appears warning you that the selected sheet will be permanently deleted, as shown in Figure 5-4.
3. **Click OK to confirm the worksheet deletion.**
   The Comments worksheet is deleted from the workbook.

4. **Delete the Foreign, Domestic, Receipts, and Summary sheets from the workbook.**
   There are several worksheets that you need to add to the Weekly Reservations workbook—a worksheet for Monday’s reservations and another to summarize the entire week. Inserting a new worksheet to a workbook is just as easy as deleting one.

5. **Select Insert → Worksheet from the menu.**
   Excel inserts a new worksheet tab labeled Sheet1 to the left of the selected sheet. You can also insert worksheets using a right mouse button shortcut menu.

4. **Right-click any of the sheet tabs and select Insert from the shortcut menu.**
   The Insert dialog box appears, as shown in Figure 5-3.

5. **Verify that the Worksheet option is selected and click OK.**
   Excel inserts another worksheet tab labeled Sheet2 to the left of the Sheet1.

6. **Save your work.**

---

**Quick Reference**

**To Add a New Worksheet:**
- Right-click on a sheet tab, select **Insert** from the shortcut menu, and select **Worksheet** from the Insert dialog box.
  
  Or...
  
  - Select **Insert → Worksheet** from the menu.

**To Delete a Worksheet:**
- Right-click on the sheet tab and select **Delete** from the shortcut menu.
  
  Or...
  
  - Select **Edit → Delete Sheet** from the menu.
Lesson 5-3: Renaming and Moving Worksheets

Worksheets are given the rather boring and meaningless default names Sheet1, Sheet2, Sheet3, and so on. By the end of this lesson, you will know how to change a sheet’s name to something more meaningful, such as “Budget” instead of “Sheet3”.

Another important worksheet skill you’ll learn in this lesson is how to move worksheets, so you can rearrange the order of worksheets in a workbook. Let’s get started!

1. **Double-click the Sheet1 tab.**
   The Sheet1 text is selected; indicating you can rename the worksheet. Worksheet names can contain up to 31 characters, including punctuation and spacing.

2. **Type Monday and press <Enter>.**
   The name of the selected worksheet tab changes from Sheet1 to Monday. Move on to the next step to rename Sheet2.

3. **Rename the Sheet2 tab Summary.**
   You have probably already noticed that the sheets in this workbook book are out of order. Rearranging the order of sheets in a workbook is very easy and straightforward: simply drag and drop the sheets to a new location.

4. **Click and drag the Wednesday tab after the Tuesday tab.**
   As you drag the Wednesday sheet, notice the mouse pointer indicates where the sheet will be relocated, as shown in Figure 5-6.
5. Drag the **Summary sheet** after the **Friday sheet**.
   Great! You’ve just learned how to move worksheet.

6. **Save your work.**

   One more thing: instead of moving a worksheet, you can also copy it by pressing the `<Ctrl>` key as you drag the worksheet tab. How are you doing? Working with worksheets is really quite easy isn’t it?

---

**Quick Reference**

### To Rename a Worksheet:
- Right-click the sheet tab, select *Rename* from the shortcut menu, and enter a new name for the worksheet.
- Or...
  - Double-click the sheet tab and enter a new name for the worksheet.
- Or...
  - Select **Format → Sheet → Rename** from the menu, and enter a new name for the worksheet.

### To Move a Worksheet:
- Click and drag the sheet tab to the desired location.
- Or...
  - Select **Edit → Move or Copy Sheet** from the menu, then select the workbook and location where you want to move the worksheet.

### To Copy a Worksheet:
- Hold down the `<Ctrl>` key while you click and drag the sheet tab to its desired location.
- Or...
  - Select **Edit → Move or Copy Sheet** from the menu, then select the workbook and location where you want to move the worksheet.

---
Lesson 5-4: Working with Several Workbooks and Windows

One of the benefits of Excel (and many other Windows programs) is that you can open and work with several files at once. Each workbook you open in Excel gets its own window. This lesson explains how to open and work with more than one workbook at a time. You will also learn some tricks on sizing and arranging windows.

1. **Open the Monday Reservations workbook.**
   The workbook Monday Reservations appears. The Weekly Reservations workbooks is also open, you just can’t see it because the Monday Reservations workbook occupies the entire worksheet window area. To move back to the Weekly Reservations workbook you use the Window menu command. Before you return to the Weekly Reservations workbook, move on to Step 2 to copy the reservation information for Monday.
2. **Click the Select All button** on Sheet1 to select the entire sheet, then click the **Copy button** on the Standard toolbar (or use any of the other copy methods you’ve learned) to copy the entire worksheet.

Now that the entire worksheet is copied, you need to move back to the Weekly Reservations file to paste the information.

3. **Select Window from the menu.**

The Window menu appears, as shown in Figure 5-7. The Window menu contains a list of all the currently open workbooks, as well as several viewing commands.

4. **Select Weekly Reservations.xls from the Window menu.**

You’re back in the Weekly Reservations workbook. Now you can paste the information you copied from the Monday Reservations workbook.

**NOTE:** Don’t confuse working with several Excel workbooks with working with several worksheets. Workbooks are the Excel files you open and save. Workbooks contain several worksheets within the same file.

5. **Click the Monday tab, click cell A1 to make it active and click the Paste button** on the Standard toolbar (or use any of the other paste methods you’ve learned) to paste the copied information.

The information you copied from Sheet1 of the Monday Reservations workbook is pasted into the Monday sheet of the Weekly Reservations workbook.

When you’re working with two or more files, sometimes it’s useful to view both workbooks at the same time.

6. **Select Window → Arrange from the menu.**

The Arrange dialog box opens as shown in Figure 5-8, inquiring how you want to view the windows.

7. **Select Horizontal and click OK.**

Excel displays both of the open files in two horizontally aligned windows, as shown in Figure 5-9. You need to copy a little more information from the Monday Reservations workbook into the Weekly Reservations workbook.

8. **Click the Sheet2 tab in the Monday Reservations window, click cell A1, and click the Copy button** on the Standard toolbar.

Now paste the copied label into the Weekly Reservations workbook.

9. **Click the Summary tab in the Weekly Reservations window, click cell A1, and click the Paste button** on the Standard toolbar.

The copied label is pasted into the Summary sheet of the Weekly Reservations workbook. You’re finished gathering information from the Monday Reservations workbook, so close the file.

10. **Close the Monday Reservations window by clicking its Close button.**

The Monday Reservations workbook closes. Since you’re only working with the Weekly Reservations workbook, you can maximize its window.

11. **Click the Weekly Reservations window’s Maximize button.**

The Weekly Reservations window maximizes to occupy the entire Excel worksheet window area.

12. **Save your work.**

Working with multiple files and windows is another of those procedures that work in other Windows programs. For example, if you use Microsoft Word, you can work with and display several documents using the methods described in this lesson.
Lesson 5-5: Splitting and Freezing a Window

It doesn’t take long to fill up a worksheet with so much data that it won’t all fit on the same screen. When this happens, you have to scroll through the worksheet to add, delete, modify, and view information—a skill you learned in a previous chapter. The problem with scrolling and viewing information in a large worksheet is that it can be confusing without the row or column labels.

To overcome this problem, you can split a window into two or four panes, which let you view multiple parts of the same worksheet. Once you create a pane, you can freeze it so it stays in the same place while you scroll around the rest of the worksheet.

Figure 5-10
Splitting a window into two panes.

Figure 5-11
Use the Window → Split or Freeze Panes command to split the window above and to the right of the active cell.

Figure 5-12
Freezing a window.

Figure 5-10
Splitting a window into two panes.

Figure 5-11
Click and drag the vertical split box to split a worksheet window.

Figure 5-12
The window is vertically frozen here.

The window is horizontally frozen here.

Information in the frozen panes remains on the screen as you scroll and move through a worksheet.
Chapter Five: Managing Your Workbooks

1. Move the pointer over the **vertical split box**, located at the top of the vertical scroll bar. When the pointer changes to a \( \frac{1}{2} \), drag the split box down directly beneath **row 4**, as shown in Figure 5-10.

   Excel splits the worksheet window vertically into two separate panes. **Panes** are used to view different areas of a large worksheet at the same time. You can split a window into two panes either horizontally (as you’ve done) or vertically. Notice each of the panes contains its own vertical scroll bar, enabling you to scroll the pane to a different area of the worksheet.

2. **Scroll down the worksheet in the lower pane until you reach row 60**.

   **NOTE:** Each pane has its own set of scroll boxes. Make sure you scroll down using the vertical scroll bar in the lower pane and not the upper pane.

   Notice that the worksheet scrolls down **only in the lower pane**. The upper pane stays in the same location in the worksheet, independent of the lower pane.

3. Move the pointer over the **horizontal split box**, located at the far right of the horizontal scroll bar. When the pointer changes to a \( \frac{1}{2} \), drag the split box to the left, immediately after **column B**.

   Excel splits the worksheet window vertically, so it now contains four panes. Once you have split a window into several panes, you can **freeze** the panes so they stay in place.

4. Select **Window \( \rightarrow \) Freeze Panes** from the menu.

   Thin lines appear between the B and C column, and the fourth and fifth rows, as shown in Figure 5-12. When you **freeze** a window, data in the frozen panes (the left and/or top panes) will not scroll and remains visible as you move through the rest of the worksheet. Try scrolling the worksheet window to see for yourself.

5. **Scroll the worksheet vertically and horizontally to view the data**.

   Notice how the frozen panes—column A through B, and rows 1 through 4, stay on the screen as you scroll the worksheet, allowing you to see the row and column labels.

   Now you’re ready to unfreeze the panes.

6. Select **Window \( \rightarrow \) Unfreeze Panes** from the menu.

   The panes are now unfrozen. You can once more navigate in any of the four panes to view different areas of the worksheet at the same time. Since the exercise is almost over, you want to view the window in a single pane instead of four.

7. Select **Window \( \rightarrow \) Remove Split** from the menu.

   You are returned to a single pane view of the worksheet window.

   Another way you can split and freeze panes is to place the active cell below the row you want to freeze and to the right of the column you want to freeze, as shown in Figure 5-11, and select **Window \( \rightarrow \) Split or Freeze Panes** from the menu.

---

**Quick Reference**

**To Split Panes:**
- Drag either the vertical or horizontal split bar.

Or...
- Move the cell pointer to the cell below the row you want to split and select **Window \( \rightarrow \) Split** from the menu.

**To Freeze Panes:**
1. Follow the previous instructions to split the window into panes.
2. Select **Window \( \rightarrow \) Freeze Panes** from the menu.
Lesson 5-6: Referencing External Data

You already how to create references to cells in the same worksheet—this lesson explains how you can create references to cells in other worksheets, and even to cells in other workbook files altogether! References to cells or cell ranges on other sheets are called external references or 3-D references. One of the most common reasons for using external references is to create a worksheet that summarizes the totals from other worksheets. For example, a workbook might contain twelve worksheets—one for each month—and an annual summary worksheet that references and totals the data from each monthly worksheet.

1. Click the **Summary tab**.

2. Click cell **A3**, click the **Bold button** and the **Center button** on the Formatting toolbar, type **Monday**, and then click the **Enter button** on the formula bar.

   You need to need to add column headings for the remaining business days. Use the AutoFill feature to accomplish this task faster.

3. Position the pointer over the fill handle of cell **A3**, until it changes to a +, click and hold the mouse button, and drag the fill handle to select the cell range **A3:E3**.

   The AutoFill function automatically fills the cell range with the days of the week. Now it’s time to create a reference to a cell on another sheet in the workbook. To refer to a cell in another sheet: 1.) Type = (equal sign) or entering a formula 2.) Click the sheet tab that contains the cell or cell range you want to use 3.) Click the cell or cell range you want to reference, and 4.) Complete the entry by pressing <Enter>.

---

**Figure 5-13**
Referencing data in another sheet in the same workbook.

**Figure 5-14**
An example of an external cell reference.

**Figure 5-15**
The Summary sheet with references to data in other sheets and in another workbook file.
4. **Click cell A4, type “=,” click the Monday sheet tab, click cell D61 (you will probably have to scroll the worksheet down), and press <Tab>**.

   Excel completes the entry and creates a reference to cell D61 on the Monday sheet, as shown in Figure 5-13. The Formula bar reads =Monday!D63. The *Monday* refers to the Monday sheet. The ! (examination point) is an external reference indicator—it means that the referenced cell is located outside the active sheet. D63 is the cell reference inside the external sheet.

5. **Repeat Step 4, adding external references to the Total formula in cell D61 on the Tuesday, Wednesday, Thursday, and Friday sheets.**

   You can also reference data between different workbook files, just as you can reference data between sheets. This process of referencing data between different workbooks is called linking. Linking is dynamic, meaning that any changes made in one workbook are reflected in the other workbook. Try referencing a cell in a different workbook now—the first thing you’ll need to do is open the workbook file that contains the data you want to reference.

6. **Open the workbook Internet Reservations from your Practice disk.**

   To create a reference to a cell in this workbook you first need to return to the Weekly Reservations workbook because it will contain the reference.

7. **Select *Window* → Weekly Reservations.xls from the menu.**

   You return to the Summary sheet of the Weekly Reservations workbook.

8. **Click cell F3, type Internet, click the Bold button and the Center button on the Formatting toolbar. Press <Enter> to move to cell F4, type “=” (equal sign) to start creating the external reference.**

   Now you need to select the cell that contains the data you want to reference, or link.

9. **Select *Window* → Internet Reservations.xls from the menu.**

   You’re back to the Internet Reservations workbook. All you need to do is click the cell containing the data you want to reference and complete the entry.

10. **Click cell B8 and press <Enter>.**

    **NOTE:** There is one major problem with referencing data in other workbooks. If the workbook file you referenced or linked moves or is deleted, you will get an error in the reference. Many people, especially those who email their workbooks, choose not to create references to data in other workbook files.

    Complete the Summary sheet by totaling the information from the various external sources.

11. **Click cell G3, click the Bold button and Center button on the Formatting toolbar, type “Total,” and press <Enter> to complete the entry and move to cell G4.**

12. **Click the AutoSum button on the Standard toolbar, notice that the cell range is correct (A4:G4), then press <Enter>.**

    Excel totals the cell range (A4:G4) containing the externally referenced data. Compare your worksheet with the one in Figure 5-15.

13. **Save your work.**
Lesson 5-7: Creating Headers, Footers, and Page Numbers

Worksheets that are several pages long often have information such as the page number, the worksheet’s title, or the date, located at the top or bottom of every page. Text that appears at the top of every page in a document is called a header, while text appearing at the bottom of each page is called footer. In this lesson, you will learn how to use both headers and footers.

1. **Click the Monday sheet tab** to make the Monday worksheet active.
   You need to specify the header and footer for the Monday worksheet.

2. **Select File → Page Setup from the menu and click the Header/Footer tab.**
   The Header/Footer tab of the Page Setup dialog box appears, as shown in Figure 5-16. You can add a header and/or footer by selecting one of the preset headers and footers from the Header or Footer list, or you can create your own. The next few steps explain how to create a custom header.

3. **Click the Custom Header button.**
   The Header dialog box appears, as shown in Figure 5-17. The Header dialog box lets you customize the header for the worksheet.
Chapter Five: Managing Your Workbooks

4. Click the **Center section box**.
   Any text typed in the Center section box will appear centered across the top of the worksheet. You can format the text that appears in the header and footer by clicking the Font button.

5. Click the Font button, select **Bold** from the Font Style list, and click **OK**.
   Now that you have formatted the header’s font, type the text for the header in the Center section box.

6. Type **Monday Reservations** and click **OK**.
   You return to the Header/Footer tab of the Page Setup dialog box. Notice the header appears in the header preview area. Next, add a footer to the worksheet.

7. Click the **Custom Footer button**.
   The Footer dialog box appears. You want to add the name of the workbook file in the left side of the footer.

8. Click the **Left Section box** and click the **File Name button** to insert the filename code.
   Excel inserts the filename code, &{File}. This cryptic-looking code will display the name of the file, Weekly Reservations.xls, in the footer. Since the filename code is in the Left Section box, it will appear left-aligned on the worksheet’s footer. Now you want to add the date to the right side of the footer.

9. Click the **Right Section box**, type **Page**, press the **<Spacebar>**, click the **Page Number button** to insert the page number code, and click **OK** to close the Footer dialog box.
   You’re back to the Header/Footer tab. Notice how the footer appears in the footer box.

10. Click **Print Preview** to preview your worksheet, then save it.

---

### Table 5-11: Header and Footer buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Font button]</td>
<td>Formats the font for the header and footer.</td>
</tr>
<tr>
<td>![Page Number]</td>
<td>Inserts the current page number.</td>
</tr>
<tr>
<td>![Total Pages]</td>
<td>Inserts the total number of pages in the workbook.</td>
</tr>
<tr>
<td>![Date]</td>
<td>Inserts the current date.</td>
</tr>
<tr>
<td>![Time]</td>
<td>Inserts the current time.</td>
</tr>
<tr>
<td>![File Name]</td>
<td>Inserts the workbook file name.</td>
</tr>
<tr>
<td>![Sheet Name]</td>
<td>Inserts the worksheet name.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Add or Change the Header or Footer:
1. Select **File → Page Setup** from the menu and click the **Header/Footer tab**.
2. Select one of the preset headers or footers from the **Header** or **Footer** drop-down list.

To Add a Custom Header or Footer:
1. Select the **File → Page Setup** from the menu and click the **Header/Footer tab**.
2. Click the **Custom Header** or **Custom Footer button**.
3. Enter the header or footer in any or all of the three sections. Refer to Table 5-11: Header and Footer buttons to enter special information.
Lesson 5-8: Specifying a Print Area and Controlling Page Breaks

Sometimes you may want to print only a particular area of a worksheet, instead of all of it. You can specify an area of a worksheet to print using the File → Print Area → Set Print Area menu command. The Set Print Area command is especially useful when you're working with a huge worksheet. Instead of taking dozens of pages to print everything, you can use the Set Print Area command to print what is important, such as the worksheet totals.

Another topic covered in this lesson is how to force the page to break where you want it to when you print out a worksheet.

1. **Press <Ctrl> + <Home> to move the beginning of the worksheet.**

2. **Select the cell range A1:E61.**

   Yes, this is a very large cell range. You must hold down the mouse button and move the pointer down, below the Excel worksheet window to scroll down all select the cells. If you have trouble selecting this cell range using the mouse, click cell A1, press and hold down the <Shift> key, scroll down and click cell E61 and release the <Shift> key. The cell range you just selected is the part of the worksheet you want to print.

3. **Select File → Print Area → Set Print Area from the menu.**

   Excel sets the currently selected cell range, A1:E61, as the print area. Unless you remove this print area, Excel will only print this cell range whenever you print the worksheet. Removing a print area is even easier than setting one.
4. Select **File → Print Area → Clear Print Area** from the menu.
   The print area you selected, A1:E61, is cleared and Excel will now print the entire worksheet whenever you send it to the printer. For this exercise, however, you need to keep using the print range A1:E61, so undo the previous Clear Print Area command.

5. Click the **Undo button** on the Standard toolbar.
   Excel undoes the Clear Print Area command.
   When you print your worksheets, sometimes the page will break where you don’t want it to. You can adjust where the page breaks with Excel’s Page Break Preview feature.

6. Select **View → Page Break Preview** from the menu.
   Excel changes the worksheet’s window view from Normal to Page Break Preview mode, as shown in Figure 5-18. Page Break Preview mode shows you where the worksheet’s pages will break when printed, as indicated by a dark blue line. The areas of the worksheet that are not included in the current print area appear in dark gray. You can adjust where the page breaks simply by clicking and dragging the dark blue page break indicator line to where you want the page to break.

7. Scroll down the worksheet, and click and drag the **Page Break Indicator line** until it appears immediately after row 40, as shown in Figure 5-18.
   When you print the Monday worksheet, the page will break immediately after row 40. You’re finished using Page Break Preview mode, so change the view back to normal mode.

8. Select **View → Normal** from the menu.
   You return to the Normal view of the workbook. Notice a dotted line appears at the edge of the print area and after row 40. This dotted line indicates where the page will break when the worksheet is printed. Normally Excel automatically inserts a page break when the worksheet won’t fit on the page, but you can manually insert your own page breaks as well.

9. Click cell A17 then select **Insert → Page Break** from the menu.
   A dashed page break indicator line appears between rows 17 and 18, indicating a horizontal page break.

### Table 5-12: Inserting Page Breaks

<table>
<thead>
<tr>
<th>To Break the Page This Way</th>
<th>Position the Cell Pointer Here</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontally</td>
<td>Select the cell in column A that is below where you want the page break.</td>
</tr>
<tr>
<td>Vertically</td>
<td>Select the cell in row 1 that is to the right of where you want the page break.</td>
</tr>
<tr>
<td>Both Horizontally and Vertically</td>
<td>Select the cell below and to the right of where you want the page breaks.</td>
</tr>
</tbody>
</table>
Lesson 5-9: Adjusting Page Margins and Orientation

You’re probably already aware that margins are the empty space between the text and the left, right, top, and bottom edges of a printed page. Excel’s default margins are 1 inch at the top and bottom and .75 inch to the left and right. There are many reasons to change the margins for a document: to make more room for text information on a page, to add some extra space if you’re binding a document, or to leave a blank space to write in notes. If you don’t already know how to adjust a page’s margins, you will after this lesson.

This lesson also explains how to change the page orientation. Everything you print uses one of two different types of paper orientations: Portrait and Landscape. In Portrait orientation, the paper is taller than it is wide—like a painting of a person’s portrait. In Landscape orientation, the paper is wider than it is tall—like a painting of a landscape. Portrait orientation is the default setting for printing worksheets, but there are many, many times when you will want to use landscape orientation instead.
1. Click File → Page Setup from the menu and click the Margins tab if it is not already in front.

The Margins tab of the Page Setup dialog box appears, as shown in Figure 5-19. Here you can view and adjust the margin sizes for the current worksheet. Notice there are margins settings in the Top, Left, Right, header, and footer boxes.

2. Click the Top Margin box down arrow until .5 appears in the box.

This will change the size of the top margin from 1.0” to 0.5”. Notice that the Preview area of the Page Setup dialog box displays where the new margins for the worksheet will be.

3. Click the Bottom Margin box down arrow until .5” appears in the box.

In the same manner, you could adjust the left and right margins, and how far you want the worksheet’s header and footer to print from the edge of the page. You can also specify if you want to center the worksheet horizontally or vertically on the page.

4. Click the Horizontally and Vertically checkboxes in the Center on page section.

This will vertically and horizontally center the worksheet page when it is printed.

Do you think you have a handle on changing the margins of a worksheet? Good, because without further ado, we’ll move on to page orientation.

5. Click the Page tab.

The Page tab appears, as shown in Figure 5-22.

6. In the Orientation area, click the Landscape option button.

This will change the worksheet’s orientation to Landscape when it is printed.

7. Click OK.

The Page setup dialog box closes, and the worksheet’s margins and page orientation settings are changed.

8. Click the Print Preview button on the Standard toolbar to preview the Monday worksheet.

A print preview of the Monday worksheet appears on the screen. Unless you have eyes like a hawk (or a very large monitor) you probably won’t notice the small changes you made to the worksheet’s margins, but you can certainly tell that the page is using landscape orientation.

9. Click Close and save your work.
Lesson 5-10: Adding Print Titles and Gridlines

If a worksheet requires more than one page to print, it can be confusing to read any subsequent pages because the column and row labels won’t be printed. You can fix this problem by selecting File → Page Setup from the menu, clicking the Sheet tab, and telling Excel which row and column titles you want to appear at the top and/or left of every printed page.

This lesson will also show you how to make sure your worksheet’s column and row labels appear on every printed page, and how to turn on and off the worksheet’s gridlines when printing.

1. Click the Print Preview button on the Standard toolbar.
   Excel displays how the Monday worksheet will look when printed. Notice the status bar displays 1 of 3, indicating the worksheet spreads across three pages.

2. Click Next to move to the next page and click near the top of the page with the pointer.
   Notice the cells on page 2 don’t have column labels (First, Last, Number of Bookings, etc.), making the data on the second and third page difficult to read and understand.
   You want the column labels on the first page to appear at the top of every page.

3. Click Close to close the Print Preview window.

4. Select File → Page Setup from the menu and click the Sheet tab.
   The Sheet tab of the Page Setup dialog box is where you can specify which parts of the worksheet are printed. Notice the print area—the cell range A1:E61—appears in the Print area text box. You need to specify what rows you want to repeat at the top of every page. Move on to the next step to find out how to do this.
5. Click the **Rows to repeat at top box** and click any cell in **Row 4**.  
   You may have to click the Collapse Dialog button if the dialog box is in the way. When you click any cell in row 4, Excel inserts a reference to Row 4 in the Rows to repeat at top text box. You aren’t limited to repeating a single row across the top of a page—you can also select several rows. You can also specify that you want a column(s) to repeat to the right side of every page.  
   By default, Excel does not print the horizontal and vertical cell gridlines on worksheets, however you can elect to print a worksheet’s gridlines. Printing a worksheet’s gridlines can sometimes make them easier to read.  

6. **Click the Gridlines checkbox.**  
   Now when you print the worksheet, the horizontal and vertical cell gridlines will also be printed.  

7. **Click Print Preview to display how the changes you’ve made to the worksheet will appear when printed.**  

8. **Click Next to move to the next page and click near the top of the page with the 🖼 pointer.**  
   Notice that the heading row now appears at the top of every page, and that gridlines appear on the worksheet.  

9. **Save your work.**

---

**Quick Reference**

**To Print or Suppress Gridlines:**
1. Select **File → Page Setup** from the menu can click the **Sheet tab.**
2. Add or remove the check mark in the **Gridlines** check box.  

**To Print Row or Column Titles:**
1. Select **File → Page Setup** from the menu can click the **Sheet tab.**
2. Specify which row(s) or column(s) should appear at the top and/or left of every page in the appropriate boxes under the **Title section.**

---

The **Collapse Dialog button** temporarily shrinks and moves the dialog box so that you enter a cell range by selecting cells in the worksheet. When you finish, you can click the button again or press <Enter> to display the entire dialog box.
Lesson 5-11: Changing the Paper Size and Print Scale

1. Select **File → Page Setup** from the menu and click the **Page tab**. The Page tab of the Page Setup dialog box appears, as shown in Figure 5-24. You want to scale the Monday worksheet so that it fits on a single page. Notice under the Scaling section that there are two different ways you can scale a worksheet:
   - **Adjust to:** This option lets you scale a worksheet by a percentage. For example, you could scale a worksheet so that it is 80% of its normal size.
   - **Fit to:** This option lets you scale the worksheet so that it fits on the number of pages you specify. You must specify how many pages wide by tall you want the worksheet to be printed on. This is usually the easiest and best way to scale a worksheet.

2. Click the **Fit to option** under the Scaling section, click the **pages wide down arrow** to select 1 and click the **pages tall down arrow** to select 1.

3. Click **Print Preview** to see how the newly scaled worksheet will look when printed.

   Yikes! The data in the worksheet has become so small that it’s almost unreadable.

4. Click **Close** to close the Print Preview window.

   You return to the worksheet window. You decide using a larger sheet of paper—legal sized—may help fit the entire worksheet on a single page.

This lesson covers two important printing options: how to reduce the size of the printed worksheet so that it fits on a specified number of pages, and how to print on different paper sizes. Most people normally print on standard Letter-sized (8½ × 11) paper, but Excel can also print on other paper sizes, such as Legal-sized (8½ × 14) and most other custom sized paper.
5. Select **File → Page Setup** from the menu.
   Now change the paper size from letter (the default setting) to legal.

6. **Click the Paper size arrow and select Legal (8.5 x 14 in.) from the paper size list.**
   Preview the worksheet to see how it will look if it is printed on legal sized paper.

7. **Click Print Preview to see how the worksheet will look when printed.**
   **Click Close when you’re finished.**

8. **Save your work.**

---

**Quick Reference**

**To Change the Print Scale:**

1. Select **File → Page Setup** from the menu and click the **Page tab**.
2. Enter percent number in the % Normal Size text box or enter the number of pages you want the worksheet to fit on.

**To Change the Paper Size:**

1. Select **File → Page Setup** from the menu and click the **Page tab**.
2. Click the **Paper size list** to select the paper size.
Lesson 5-12: Protecting and Hiding a Worksheet

Sometimes you may want to prevent other users from changing some of the contents in a worksheet. For example, you might want to allow users to enter information in a particular cell range, without being able to alter the labels or formulas in another cell range in the same worksheet. You can protect selected cells so that their contents cannot be altered, while still allowing the contents of unprotected cells in the same worksheet to be changed. You can protect cells by locking them on the Protection tab of the Format Cells dialog box.

Using a protected worksheet is useful if you want another user to enter or modify data in the worksheet without altering or damaging the worksheet’s formulas and design. In this lesson, you will learn all about locking and unlocking cells, protecting and unprotecting worksheets, and how to hide sensitive formulas from viewers.

1. Select the cell range D5:E60, select Format → Cells from the menu and click the Protection tab.

   The Protection tab of the Format Cells dialog box appears, as shown in Figure 5-25. There are only two options on this tab. There are:
   - **Locked**: Which prevents selected cells from being changed, moved, resized, or deleted. Notice the Locked box is checked—Excel locks all cells by default.
   - **Hidden**: Which hides a formula in a cell so that it does not appear in the formula bar when the cell is selected.

Cells are protected by default.
Neither of these options has any effect unless the sheet is protected—which you’ll learn how to do in a minute. Since you want users to be able to modify the cells in the selected cell range you need to unlock them.

2. **Click the Locked checkbox to remove the checkmark and click OK.**
   The Format Cells dialog box closes and you return to the worksheet. At first, nothing appears to have changed. You need to protect the worksheet in order to see how cell protection works.

   **NOTE:** By default, all cells are locked. Before you protect a worksheet, you would unlock the cells where you want information a user to be able to enter or modify information.

3. **Select Tools → Protection → Protect Sheet from the menu.**
   The Protect Sheet dialog box appears, as shown in Figure 5-26. You can specify which parts of the worksheet you want to protect and you can assign a password that users must enter in order to unprotect the worksheet, once it has been protected.

4. **Click OK.**
   The Protection Sheet dialog box closes and you return to the worksheet. Move on to the next step to see how the protected worksheet works.

5. **Click cell A8 and press the <Delete> key.**
   When you try to delete or modify a locked cell, Excel displays a message informing you that the cell is protected, as shown in Figure 5-27. Now try modifying an unprotected cell.

6. **Click cell D8 and press the <Delete> key.**
   Since you unlocked this cell in a previous step, Excel lets you clear its contents. Now that you have an understanding of cell protection, you can unprotect the worksheet.

7. **Select Tools → Protection → Unprotect Sheet from the menu.**
   Excel unprotects the Monday sheet. You can now modify all of the cells in the worksheet, whether they are locked or not.

   Another way you can prevent unauthorized users from viewing or modifying restricted or confidential areas of your workbooks is to hide them. You can hide rows, columns, and entire worksheets. To prevent others from displaying hidden rows or columns you can then protect the workbook, as shown in Step 3.

8. **Right-click the Column F heading and select Hide from the column shortcut menu.**
   The I column disappears from the worksheet. It’s not deleted, merely hidden from view. Notice how the column headings now go from E to G, skipping the F column. Here’s how to unhide a column:

9. **Select the E and G columns by clicking and dragging the pointer across the column headings. Once the column headings are selected, right-click either of the column headings and select Unhide from the shortcut menu.**
   The F column reappears. You can also hide and unhide other columns in the same manner.

10. **Save your work.**

---

**Quick Reference**

**To Lock or Hide a Cell or Cell Range:**
1. Select the cell or cell range you want to protect or hide.

2. Select **Format → Cells from the menu and click the Protection tab.**

   Or…

   Right-click the selected cell or cell range and select **Format Cells from the shortcut menu.**

3. Add or remove check marks in the **Locked and Hidden** check boxes to specify if the cell or cell range should be locked or hidden.

**To Protect a Worksheet:**
1. Select **Tools → Protection → Protect Sheet from the menu.**

2. Select the appropriate options for what you want to protect.

3. (Optional) enter a password.

**To Unprotect a Worksheet:**
- Select **Tools → Protection → Unprotect Sheet from the menu.**
Lesson 5-13: Viewing a Worksheet and Saving a Custom View

Changing the print settings, zoom level, and workbook appearance every time you view or print a workbook can get old. By creating a custom view, you can save the view and print settings so you don’t have to manually change them. A custom view saves the following settings:

- Any print settings, including the print area, scale level, paper size and orientation.
- Any view settings, including the zoom level, if gridlines should be displayed, and any hidden worksheets, rows, or columns.
- Any filters and filter settings.

This lesson explains how to create and work with a custom view, and zoom in (magnify) and out of a worksheet, and how to view a worksheet in Full Screen mode.

1. **Click the Zoom list arrow on the Standard toolbar and select 75%**.
   The worksheet appears on-screen at a magnification of 75%, allowing you to see more of the worksheet on screen. The reduced magnification makes the worksheet a bit more difficult to read, however.

2. **Click the Zoom list arrow on the Standard toolbar and select 100%**.
   The worksheet returns to the normal level of magnification. You can also see more of a worksheet by dedicating 100% of the screen to the worksheet in full screen mode.

3. **Select View → Full Screen from the menu**.
   All the familiar title bars, menus, and toolbars disappear and the worksheet appears in full screen mode. Full screen mode is useful because it devotes 100% of the screen real estate to viewing a worksheet. The disadvantage of full screen mode is all the Excel tools—the toolbars, status bar, etc. are not as readily available. You can still access the menus, although you can no longer see them, by clicking the mouse at the very top of the screen.
4. **Click the Close Full Screen button floating over the worksheet.**
   The full screen view closes and you are returned to the previous view. Next, save the current view and a custom view—here’s how:

5. **Select View → Custom Views from the menu.**
   The Custom Views dialog box appears, as shown in Figure 5-27. Any saved views for the current worksheet are listed here. You want to save the current, generic view of the Monday worksheet.

6. **Click Add.**
   The Add View dialog box appears, as shown in Figure 5-28. You must enter a name for the current view, and select if you want to include the worksheet’s print settings and/or any hidden rows, columns and filter settings.

7. **Type Normal in the Name box and click OK.**
   Excel saves the custom view and closes the dialog box. Now you want to create another view of the worksheet—one that uses Portrait orientation and hides the Commissions column.

8. **Right-click the Column I heading and select Hide from the shortcut menu.**
   Excel hides the I column.

9. **Select File → Page Setup from the menu, click the Page tab, select the Portrait option under the Orientation section, and click OK.**
   Save the settings you made to the worksheet in a custom view.

10. **Select View → Custom Views from the menu.**
    The Custom Views dialog box appears.

11. **Click Add, type No Commission in the Name box and click OK.**
    Excel saves the custom view and returns you to the worksheet. Now try retrieving one of your custom views.

12. **Select View → Custom Views from the menu, select Normal, and click Show.**
    Excel displays the worksheet using the Normal custom view—notice the commission column is no longer hidden.

13. **Click the Print Preview button on the Standard toolbar to preview the worksheet.**
    Excel displays a preview of the Monday worksheet. Notice the worksheet is landscape oriented—the orientation setting you saved in the Normal custom view.

14. **Save and close the current workbook.**

---

**Quick Reference**

**To Create a Custom View:**
1. Setup the worksheet’s appearance and print settings.
2. Select View → Custom Views from the menu.
3. Click Add and give the view a name.

**To Use a Custom View:**
- Select View → Custom Views from the menu, select the view you want to use and click Show.
Lesson 5-14: Working with Templates

If you find yourself recreating the same type of workbook over and over, you can probably save yourself some time by using a template. A template is a workbook that contains standard data such as labels, formulas, formatting, and macros you use frequently. Once you have created a template, you can use it to create new workbooks, which saves you time, since you don’t have to enter the same information again and again. Creating a template is easy—you simply create the template, just like you would any other workbook, and then tell Excel you want to save the workbook as a template instead of as a standard workbook. To create a workbook from a template, you just select File → New from the menu and select the template you want to use. Excel comes with several built-in templates for common purposes such as invoices and expense reports.

In this lesson you will learn how to create a template and how to create a new workbook based on a template.
1. **Open the Time Card Form workbook.**
   
   This worksheet tracks and totals the number of hours employees work in a week. You will be saving this worksheet as a template. First though, you have to remove the information in the worksheet that will change—the hours.

2. **Clear the information in the cell range B6:H10.**
   
   (Select the cell range B6:H11 and press the <Delete> key.) Now you’re ready to save the worksheet as a template.

3. **Select File → Save As from the menu.**
   
   The Save As dialog box appears. Here you must specify that you want to save the current workbook as a template. Excel templates are stored with an .XLT extension instead of the normal .XLS extension (used for Excel workbooks.)

4. **Click the Save as type list arrow and select Template from the list, as shown in Figure 5-30.**
   
   Templates are normally kept in a special template folder (usually C:\ProgramFiles\Microsoft Office\Templates). When you select the Template file format, Excel automatically changes the file location to save the template in this folder. The file list window is updated to show the contents of the Template folder.

   **NOTE:** If the file location doesn’t change when you select the Template file type, you’ll have to move the Template folder manually.

5. **In the File Name box type Time Card and click the Save button.**
   
   Excel saves the workbook as a template.

6. **Close all open workbooks.**
   
   Now that you have created a template, you can use the template to create a new workbook. Try it!

7. **Select File → New from the menu.**
   
   The New Workbook task pane appears as shown in Figure 5-31.

8. **Select General Template from the New Workbook task pane.**
   
   Here you can select the template you want to use to create your new workbook.

9. **Select the Time Card template and click OK.**
   
   A new workbook based on the Time Card template appears in the document window.

10. **Fill out the time card worksheet by entering various hours for the employees (use your imagination.)**
    
   Once you have finished filling out the timecard, you can save it as a normal workbook file.

11. **Click the Save button on the Standard toolbar.**
    
   The Save As dialog box appears.

12. **Save the workbook as Week 1 Timecard.**
    
   The workbook is saved as a normal Excel workbook.

13. **Close the Week 1 Timecard worksheet.**
    
   You don’t want to leave the Time Card template on this computer, so delete it.

14. **Select File → New from the menu, right-click the Time Card template and select Delete from the shortcut menu. Close the New dialog box when you’re finished.**
Lesson 5-15: Consolidating Worksheets

Earlier in this chapter, you manually created a summary worksheet that summarized information on other worksheets. You can have Excel automatically summarize or consolidate information from up to 255 worksheets into a single master worksheet using the Data → Consolidate command. This lesson will give you some practice consolidating data.

1. Open the Lesson 5 workbook.
   You should remember this workbook—it’s the one you’ve already worked on that contains worksheets for each weekday. The first step in consolidating several worksheets is to select the destination area—the worksheet and cells where the consolidated data will go.

2. Activate the Summary worksheet by clicking the Summary tab, and then click cell A2.
   Cell A2 is the first cell in the destination range—where the consolidated information will go.

3. Select Data → Consolidate from the menu.
   The Consolidate dialog box appears, as shown in Figure 5-32. You can consolidate data in two ways:

   - Select the function Excel will use to consolidate data
   - Specify the cell range you want to consolidate with the cell ranges listed in the All references box
   - Lists all the cell references that will be consolidated
   - Select to update the consolidation data automatically whenever the data changes in any of the source areas
   - Open other workbook files that contain data you want to consolidate.
   - Adds the selected cell range to the All references list
   - Deletes the selected cell range from the All references list
   - Uses labels from the selected cell range to consolidate by category
   - Adds the selected cell range to the All references list
   - Deletes the selected cell range from the All references list
Chapter Five: Managing Your Workbooks

- **By Position**: In which data is gathered and summarized from the same cell location in each worksheet.

- **By Category**: In which data is gathered and summarized by its column or row headings. For example, if your January column is column A in one worksheet and column C in another, you can still gather and summarize the January when you consolidate by category. Make sure the Top row and/or Left column check boxes in the Use labels in section of the Consolidate dialog box are selected to consolidate by category.

For this exercise, you will consolidate by category.

4. **Make sure the insertion point is in the Reference text box, then click the Tuesday tab and select the cell range A4:I60.**

   The absolute reference Tuesday!$A$4:$I$60 appears in the reference text box. Now you need to add the selected cell range to the list of information you want to consolidate.

5. **Click Add to add the selected cell range to the All references list.**

   The selected cell reference, Monday!$A$4:$I$60, appears in the All references list. Next, you have to add the next cell range or worksheet you want to consolidate.

6. **Click the Wednesday tab.**

   When you click the Wednesday tab, Excel assumes the cell range for this worksheet will be the same as the previously selected Tuesday worksheet, and enters the absolute Tuesday!$A$4:$I$60 in the reference text box for you. Excel has guessed correctly—this is the information you want to add to the consolidation list, so you can click the Add button.

7. **Click Add to add the selected cell range to the All references list.**

   Now that you know how to add references to the All references list, you can finish adding the remaining worksheets.

8. **Finish adding the remaining worksheets (Thursday, and Friday) to the All references list by repeating Steps 6 and 7.**

   Once you’ve finished adding the cell ranges that contain the information you want to consolidate, you need to tell Excel you want to consolidate by category.

9. **Add checkmarks to both the Top row and Left column check boxes to consolidate by category.**

   If these check boxes were empty, Excel would consolidate the information by position. There’s just one more thing to do before you consolidate the selected information.

10. **Add a checkmark to the Create links to source data check box.**

    This will link the consolidated data, ensuring that it is updated automatically if the data changes in any of the source areas.

11. **Click OK to consolidate the information from the selected worksheets.**

    The dialog box closes and Excel consolidates the information, totaling the sales for all the worksheets. You will probably have to adjust the width of any columns that display #######’s so they properly display their contents. Notice Excel also now displays the outline symbols to the left of the worksheet, as shown in Figure 5-33. We’ll explain outlining for another lesson.

12. **Exit Excel without saving your work to finish the lesson.**

    For more on consolidating and summarizing information see the chapter on Data Analysis and PivotTables.

---

**Quick Reference**

**To Consolidate Data:**

1. If possible, start with a new workbook and select a cell in that workbook as the destination for the consolidated information.

2. Select **Data → Consolidate** from the menu.

3. Select a consolidation function (SUM is the most commonly used function).

4. Select the cell range for the first worksheet (click the Browse button if you want to reference another workbook file) and click **Add**.

5. Repeat **Step 4** for each worksheet you want to consolidate.

6. Select the **Left Column** and/or **Top Row** check boxes to consolidate by category. Leave these check boxes blank to consolidate by position.

7. Select the **Create links to source data** check box if you want the consolidated data to be updated.

8. Click **OK**.
Chapter Five Review

Lesson Summary

Switching Between Sheets in a Workbook
- Switch to a worksheet by clicking its sheet tab at the bottom of the screen.
- Right-clicking the sheet tab scroll buttons lists all the worksheets in a shortcut menu.
- The sheet scroll tab buttons, located at the bottom of the screen, scroll the worksheets tabs in a workbook.

Inserting and Deleting Worksheets
- **To Add a New Worksheet:** Select Insert → Worksheet from the menu or right-click on a sheet tab, select Insert from the shortcut menu, and select Worksheet from the Insert dialog box.
- **To Delete a Worksheet:** Select Edit → Delete Sheet from the menu or right-click on the sheet tab and select Delete from the shortcut menu.

Renaming and Moving Worksheets
- By default, worksheets are named Sheet1, Sheet2, Sheet3, and so on.
- **To Rename a Worksheet:** There are three methods:
  1) Double-click the sheet tab and enter a new name for the worksheet
  2) Right-click the sheet tab, select Rename from the shortcut menu, and enter a new name for the worksheet
  3) Select Format → Sheet → Rename from the menu, and enter a new name for the worksheet.
- Move a worksheet by dragging its sheet tab to the desired location.
- Copy a worksheet by holding down the <Ctrl> key while dragging the worksheet’s tab to a new location.

Working with Several Workbooks and Windows
- Click the Select All button to select all the cells in a worksheet.
- Switch between open windows by selecting Window from the menu and selecting the name of the workbook you want to view.
- Select Window → Arrange All to view multiple windows at the same time.
- Click a window’s Maximize button to maximize a window, and click the window’s Restore button to return the window to its original size.
- **To Manually Resize a Window:** Restore the window, then drag the edge of the window until the window is the size you want.
- **To Move a Window:** Drag the window by its title bar to the location where you want to position the window.
Splitting and Freezing a Window

- **To Split Panes:** Drag either the vertical or horizontal split bar or move the cell pointer to the cell below the row and to the right of the column you want to split and select **Window → Split** from the menu.

- **To Freeze Panes:** Split the window into panes, then select **Window → Freeze Panes** from the menu.

Referencing External Data

- You can include references to values in other worksheets and workbooks by simply selecting the worksheet or workbook (open it if necessary) and clicking the cell that you want to reference.

Creating Headers, Footers, and Page Numbers

- Add headers and footers to your worksheet by selecting **File → Page Setup** from the menu and clicking the **Header/Footer tab**. Select a preset header or footer from the **Header or Footer drop-down list** or create your own by clicking the **Custom Header** or **Custom Footer** button.

Specifying a Print Area and Controlling Page Breaks

- **To Select a Print Area:** Select the cell range you want to print and select **File → Print Area → Set Print Area** from the menu.

- **To Clear a Print Area:** Select **File → Print Area → Clear Print Area** from the menu.

- You can insert a manual page break by moving the cell pointer to the cell where the page should start and selecting **Insert → Page Break** from the menu.

- **To Adjust Where the Page Breaks:** Select **View → Page Break Preview** from the menu, drag the **Page Break Indicator line** to where you want the page break to occur. Select **View → Normal** from the menu when you’re finished.

Adjusting Page Margins and Orientation

- **To Adjust Margins:** Select **File → Page Setup** from the menu and click the **Margins tab**. Adjust the appropriate margins.

- **To Change a Page’s Orientation:** Select **File → Page Setup** from the menu, and click the **Page tab**. In the Orientation section, select either the Portrait or Landscape option.

Adding Print Titles and Gridlines

- **To Print or Suppress Gridlines:** Select **File → Page Setup** from the menu can click the **Sheet tab**. Add or remove the check mark in the **Gridlines check box**.

- **To Print Row or Column Titles:** Select **File → Page Setup** from the menu can click the **Sheet tab**. Specify which row(s) or column(s) should appear at the top and/or left of every page in the appropriate boxes under the Title section.

Changing the Paper Size and Print Scale

- **To Change the Print Scale:** Select **File → Page Setup** from the menu and click the **Page tab**. Enter percent number in the % Normal Size text box or enter the number of pages you want the worksheet to fit on.
To Change the Paper Size: Select File → Page Setup from the menu and click the Page tab. Click the Paper size list to select the paper size.

Protecting and Hiding a Worksheet

To Protect a Cell or Cell Range: Select the cell or cell range you want to protect, select Format → Cells from the menu and click the Protection tab. Check the Locked check box.

By default, all cells are locked.

You must protect a worksheet to prevent changes to be made to any locked cells. Protect a worksheet by selecting Tools → Protection → Protect Sheet from the menu and specifying the areas you want protected.

Select Tools → Protection → Unprotect Sheet from the menu to unprotect a worksheet.

Viewing a Worksheet and Saving a Custom View

A custom view saves the current appearance of a workbook so that you don't have to change the settings every time you view or print the workbook.

To Create a Custom View: Setup the worksheet’s appearance and print settings, select View → Custom Views from the menu.

To Use a Custom View: Select View → Custom Views from the menu, select the view you want to use, and click Show.

Working with Templates

To Create a Template: Create a new workbook or open an existing workbook you want to use for the template, select File → Save As from the menu. Select Template from the Save as type list, give the template a name, and click OK to save the template.

To Create a Workbook based on a Template: Select File → New from the menu and select the template you want to use.

Templates are kept in a special template folder (usually C:\ProgramFiles\Microsoft Office\Templates).

Consolidating Worksheets

You can summarize or consolidate information from multiple worksheets into a single master sheet with the Data → Consolidate command.

To Consolidate Data: If possible, start with a new workbook and select a cell in that workbook as the destination for the consolidated information. Select Data → Consolidate from the menu and select a consolidation function (SUM is the most commonly used function). Select the cell range for the first worksheet (click the Browse button if you want to reference another workbook file) and click Add. Select the other worksheets you want to consolidate, clicking Add after each one. Select the Create links to source data check box if you want the consolidated data to be updated.
Quiz

1. All of the following statements are true except…
   A. You can change the order of worksheets in a workbook by dragging their sheet tabs to new positions.
   B. You can rename a sheet by double-clicking its sheet tab.
   C. You can switch between worksheets by selecting Window from the menu and selecting the name of the sheet from the Window menu.
   D. You can add and delete worksheets from the workbook.

2. How can you switch between worksheets when there isn’t enough room on the screen to display all the sheet tabs? (Select all that apply)
   A. Click the Sheet Tab Scroll buttons until the sheet tab you want appears, then click that sheet tab.
   B. Select Window from the menu and select the name of the sheet from the Window menu.
   C. Right-click any sheet tab and select the name of the sheet from the shortcut menu.
   D. Press <Ctrl> + ← or <Ctrl> + → to move between the sheets.

3. Formulas can contain references to cells in other worksheets and even in other workbooks. (True or False?)

4. Which of the following statements is NOT true?
   A. You can delete a sheet by right-clicking its sheet tab and selecting Delete from the shortcut menu.
   B. The Select All button, located to in the upper-left corner of the worksheet window, selects the entire worksheet.
   C. You can split a window into several panes by clicking the Panes button on the Standard toolbar.
   D. You can freeze a pane so that it stays in place.

5. You’re trying to print a worksheet that has just a few columns that won’t fit on a single page. Which of the following methods is the easiest way to get this worksheet to fit on a single page?
   A. Open the Print dialog box (File → Page Setup), click the Page tab, select the Fit to option and specify that you want the worksheet to fit on 1 page wide by 1 page tall.
   B. Open the Print dialog box (File → Page Setup), click the Margins tab, and adjust the worksheet’s margins.
   C. Click the Preview button on the Standard toolbar and click the Shrink to Fit button.
   D. Adjust the size of the fonts and the width of the columns in the worksheet.

6. Cells in a worksheet are unlocked by default (True or False?)
7. Which of the following statements is NOT true?
   A. You must protect a document to prevent changes being made to any locked cell.
   B. You can lock or unlock a cell or cell range by clicking the Lock button on the Standard toolbar.
   C. You can switch between open workbooks by selecting Window from the menu and selecting the name of the workbook from the Window menu.
   D. Excel normally prints the column and row heading labels on every page of worksheet.

8. Which of the following options is NOT located in the Page Setup dialog box?
   A. Page Orientation.
   B. Margins.
   C. Headers and Footers.
   D. Page Break Preview.

9. How do you add a new worksheet to a workbook?
   A. Click the New Worksheet button on the Standard toolbar.
   B. New worksheets must be purchased from Microsoft for $.25 a piece.
   C. Right-click any worksheet tab and select Insert from the shortcut menu.
   D. Select New \(\rightarrow\) Worksheet from the menu.

10. How do you set a print area, so that Excel only prints part of a worksheet?
    A. Select area you want to print and select File \(\rightarrow\) Print Area \(\rightarrow\) Set Print Area from the menu.
    B. Select area you want to print and click the Print Preview button on the Standard toolbar.
    C. Select area you want to print and click the Print button on the Standard toolbar.
    D. There’s isn’t a way of doing this.

11. How can you view and/or add a page header to a worksheet?
    A. Click the Header button on the Formatting toolbar.
    B. Select File \(\rightarrow\) Page Setup from the menu and click the Header/Footer tab.
    C. Select area you want to print and click the Print button on the Standard toolbar.
    D. There’s isn’t a way of doing this.

12. The page isn’t breaking where you want it to when you print a worksheet. How can you change this?
    A. Click the Break Page button on the Standard toolbar, and then click where you want the page to break several times with the little hammer icon.
    B. Click the cell where you want the page to break and select Window \(\rightarrow\) Freeze Panes from the menu.
    C. Click the Print Preview button on the Standard toolbar and click the Fit to Print button on the toolbar.
    D. Select View \(\rightarrow\) Page Break Preview from the menu and drag the page break indicator line to where you want the page to break.
13. How can you hide a row or column?

A. Right-click the row or column heading and select Hide from the shortcut menu.
B. Select the row or column heading and select Tools → Hide from the menu.
C. Cover the row or column with a piece of masking table.
D. Select the row or column heading and click the Hide button on the Formatting toolbar.

14. You want to print a worksheet on legal-sized paper. How can you do this?

A. Select Format → Paper from the menu and select Legal from the Paper Size list.
B. Right-click the Select All button on the worksheet and select Legal Size from the shortcut menu.
C. Select File → Page Setup from the menu, click the Paper Size tab and select Legal from the Paper Size list.
D. You need to purchase a legal sized printer and the legal version of Microsoft Excel.

Homework

1. Open the Homework 5A workbook and save it as “Regional Expenses”.

2. Move the Boston sheet tab in front of the Minneapolis tab.

3. Rename the “Minneapolis” tab “Twin Cities”.

4. Insert two new worksheets with the names “Dallas” and “Totals”.

5. Open the Homework 5B workbook. Copy its information to the Dallas worksheet in your Regional Expenses workbook. Close the Homework 5B workbook when you’re finished.

6. Go to the Totals worksheet and create a worksheet that summarizes the monthly expenses for all four regional offices. (Hint: You’ll have to create external references to do this).

7. Go to the Twin Cities worksheet, select the range A3:C11 and set it as a Print Area.

8. Add a header to the worksheet that says “Regional Expenses, First Quarter”.

9. Split any worksheet into two panes, freeze the panes, and then remove the split.
Quiz Answers

1. C. You switch to a worksheet by clicking its sheet tab. You switch between open workbooks by selecting them from the Window menu.

2. A and C. Clicking the Sheet Tab Scroll buttons displays new sheet tabs, which you can then click. Right-clicking a sheet tab displays a shortcut menu that lists all the worksheets in a workbook.

3. True. You can create references to cells in other worksheets and other workbooks by viewing the worksheet or workbook and selecting the cell(s) you want to reference.

4. C. There isn’t a Panes button on the Standard toolbar.

5. A. Using the Fit to scaling option is by far the easiest method to force the worksheet to fit on a single page. B and D might work—but they take a lot more time and effort.

6. False. Cells are locked by default—you must unlock them by selecting Format → Cells from the menu, clicking the Protection tab and removing the check from the Locked check box.

7. B. There isn’t a Lock button on the Standard toolbar (although adding a Lock button might not be a bad idea)


9. C. To add a new worksheet to a workbook right-click any worksheet tab and select Insert from the shortcut menu.

10. A. To set a print area select area you want to print and select File → Print Area → Set Print Area from the menu.

11. B. You can add and/or view the page header by selecting File → Page Setup from the menu and clicking the Header/Footer tab.

12. D. You can change where the page breaks by selecting View → Page Break Preview from the menu and dragging the page break indicator line to where you want the page to break.

13. A. You can hide a row or column by right-clicking the row or column heading and selecting Hide from the shortcut menu.

14. C. To print on legal-sized paper select File → Page Setup from the menu, click the Paper Size tab and select Legal from the Paper Size list.
Chapter Six: More Functions and Formulas

Chapter Objectives:

- Create a formula with several operators and cell ranges
- Use the Insert Function feature to enter and edit formulas
- Create and use range names
- Select nonadjacent cell ranges
- Use the AutoCalculate feature
- Create a conditional formula with the IF function
- Use the PMT function
- Display and print formulas in a worksheet
- Identify and fix formula errors

Chapter Task: Create payroll and mortgage worksheets

Formulas are the heart and soul of a spreadsheet. Without formulas, Excel would be nothing more than a grid you could use to enter numbers and text. As you will see in this chapter, formulas can do a lot more than just adding, subtracting, multiplying, and dividing. Excel has hundreds of different formulas you can use to create complex statistical, financial, and scientific calculations. The most expensive calculator in the world couldn’t come close to matching all the functions Excel has.

This chapter is somewhat different from the others in this book—it’s broken into two different parts. In the first part of this chapter, you will become an expert at creating formulas and using different types of functions. The second part of this chapter is a reference of the most commonly used functions, organized by category.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to select cell ranges.
- How to enter values, labels, and formulas into a cell.
- How to reference cells.
Lesson 6-1: Formulas with Several Operators and Cell Ranges

We’ll start this chapter by creating some more complicated formulas. First let’s review: Formulas can contain several values, such as 81 and 3.5; cell references, such as B5 and C1:D11; operators, such as * (multiplication) + (addition); and functions, such as SUM and AVERAGE. When you combine several operations and functions into a single formula, Excel performs the operations in the order shown in Table 6-1: Order in Which Excel Performs Operations in Formulas. When a formula contains several operators with the same precedence Excel calculates the formula from left to right. You can change the order Excel calculates a formula by enclosing the part of the formula you want Excel to calculate first in parentheses.

You’ll get some practice creating formulas with several references and operators in this lesson by creating formulas to compute employee 401(K) contributions and net pay.

1. Start Microsoft Excel if necessary, open the workbook Lesson 6A and save it as Time Card.
   This time card calculates the employees weekly payroll for the Duluth North Shore Travel office. All the information and almost all of the formulas are already here—you just need to add a few more formulas to complete the timecard workbook. First, you need to create a formula to calculate how much to deposit to each employee’s 401K account. North Shore Travel matches any 401K contributions made by their employees.

   2. Click cell B16 and type =.
      Typing an equal sign tells Excel that you want to enter a formula.

   3. Click cell B14, type * and click cell B15 (or you can type B14*B15). Don’t Press <Enter> after entering the formula!
      This part of the formula multiples gross pay (in cell B14) with the percentage the employees want to deduct for their 401K contribution (in cell B15.) You’re not finished with the formula yet—remember North Shore Travel matches any 401K contributions made by their employees.

   4. Type *2 and press <Enter>.
      Excel calculates the total 401K amount, $50. Copy the formula you just created to the rest of the row.

Remember: All formulas in Excel must begin with an equal sign (=).
Chapter Six: More Functions and Formulas

5. **Copy the formula in cell B16 to the cell range C16:H16.**
   The worksheet needs one more formula: one to calculate the net pay.

6. **Click cell B19, type =, click cell B14, and type – (minus sign).**
   Here’s where the formula gets tricky. You can’t directly subtract the 401K amount from cell B16, since it includes both the employee and company contribution. You will have to calculate the amount of the employee’s 401K contribution and then subtract it from the gross pay.

7. **Click cell B14 (that’s right – click cell B14 again) type * click cell B15 and press <Enter>.**
   The formula subtracts the amount of the employee deduction (5% of $500, or $25) from the gross pay. The formula isn’t finished yet—you have to go back and subtract the Federal Income Tax and Social Security amounts.

8. **Click cell B19 and click the formula bar and type –B17-B18 at the end of the formula. The complete formula should now read =B14-B14*B15-B17-B18. Complete the formula by pressing <Enter>.**
   Your formula is finished and Excel calculates the net pay for the employee. Wow! There’s not much money left over, is there?

9. **Copy the formula in cell B19 to the cell range C19:H19.**
   Compare your worksheet with the one in Figure 6-2.

When you use several operators in a formula, Excel performs the operations in the order shown in the following table. When a formula contains operators with the same precedence—for example, if a formula contains both a multiplication and division operator—Excel calculates them from left to right. To change the order of evaluation, enclose the part of the formula to be calculated first in parentheses. For example, the formula =10-5+(4/2) would subtract 5 from 10, then divide 4 by 2, and then add the results.

### Table 6-1: Order in Which Excel Performs Operations in Formulas

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
</table>
| ( )     | Parentheses change the order of evaluation. For example: 
  
  =(20+5) / (10-5) would add 20 and 5 (25), subtract 10 by 5 (5) and then divide the results to equal 5. 
  
  But...
  
  =20+5/10-5 would divide 5 by 10 (0.5), add the result to 20 (20.5) and then subtract 5 to equal 15.5. |
| :      | Reference Operator |
| %     | Percent |
| ^     | Exponentiation |
| * and / | Multiplication and division |
| + and - | Addition and subtraction |
| = <= >= | Comparison |

### Quick Reference

**To Change the Order in which Excel Performs Operations in Formulas:**
- Enclose the part of the formula you want to calculate first in parentheses.
Lesson 6-2: Using the Insert Function Feature

There are several hundred functions available in Excel. Some functions are rather easy to enter, such as the SUM function, while others are much more difficult. For example, the syntax for the DB function, which is used do depreciate an asset, is DB(cost,salvage,life,period,month). Yikes! How are you supposed to remember that? Luckily, if you use Excel’s Insert Function feature you don’t have to. The Insert Function feature helps you select, enter, and edit worksheet functions. To use the Insert Function feature all you have to do is click the Insert Function button on the formula bar.

In this lesson, you will use the Insert Function feature to create a simple AVERAGE formula.

1. **Click cell A21, click the Bold button on the Formatting toolbar, type Average Net Pay and press <Enter>.**
   In cell A22 you will use the Insert Function button to help you create a formula that calculates the average Net Pay.

2. **Click the Insert Function button on the formula bar.**
   The Function Arguments dialog box appears, as shown in Figure 6-3. Simply type a brief description of what you want a function to do, then click Go. Excel will display a list of functions likely to fit your needs.

3. **In the Search for a function box type average and click Go.**
   Excel displays a list of functions that are some how related to the world “average.”
Chapter Six: More Functions and Formulas

4. Select **AVERAGE** from the Function list.
   Notice the bottom of the Function Arguments dialog box displays a description and the syntax of the selected function.

5. Click **OK**.
   The Function Arguments dialog box closes, and the Function Arguments dialog box appears, as shown in Figure 6-4. The AVERAGE function is actually a very simple function—the only arguments (parts or values of a formula) it requires are the numbers you that you want to average.

6. Select the cell range **B19:H19**.
   This range contains the Net Pay for all the employees.
   **NOTE:** If the Function Arguments dialog box is in the way when you want to select a cell or cell range, you can click any text box’s Collapse Dialog button to collapse the function palette and select the cell or cell range.

7. Press `<Enter>`.
   The Function palette completes the formula for you and closes. Cell B22 calculates and displays the average Net Pay amount.

8. Save your work.
   The Insertion Function dialog box organizes formulas by categories. **Table 6-2: Function Categories** lists and describes the different types of function categories that are available.

### Table 6-2: Function Categories

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Most Recently Used</td>
<td>Lists the functions you’ve used most recently.</td>
</tr>
<tr>
<td>All</td>
<td>Lists every function available in Excel.</td>
</tr>
<tr>
<td>Financial</td>
<td>Lists financial functions to calculate interest, payments, loans, etc.</td>
</tr>
<tr>
<td>Date &amp; Time</td>
<td>Lists functions to calculate date and times values.</td>
</tr>
<tr>
<td>Math &amp; Trig</td>
<td>Lists math and trigonometry functions, such as SUM, COS, and TAN.</td>
</tr>
<tr>
<td>Statistical</td>
<td>Lists statistical functions, to calculate averages, standard deviations, etc.</td>
</tr>
<tr>
<td>Lookup &amp; Reference</td>
<td>Lists functions that lookup or reference values.</td>
</tr>
<tr>
<td>Database</td>
<td>Lists functions that lookup or calculate values in a list or database.</td>
</tr>
<tr>
<td>Text</td>
<td>List functions that can be used with text or labels.</td>
</tr>
<tr>
<td>Logical</td>
<td>List IF...THEN functions.</td>
</tr>
<tr>
<td>Information</td>
<td>List functions that return information about values and the worksheet itself.</td>
</tr>
<tr>
<td>User Defined</td>
<td>Lists custom functions that you (or another use) have created.</td>
</tr>
</tbody>
</table>

The **Collapse Dialog** button temporarily shrinks and moves the dialog box so that you enter a cell range by selecting cells in the worksheet. When you finish, you can click the button again or press `<Enter>` to display the entire dialog box.

### Quick Reference

**To Use the Insert Function button to Enter or Edit a Formula:**

1. Select the cell where you want to enter or edit a formula and click the **Insert Function** button on the formula bar.
2. Type a brief description of the function or formula you want to create and click **Go**.
3. Select the function you want to use from the Function list and click **OK**.
Lesson 6-3: Creating and Using Range Names

References for cells and cell ranges can sometimes be difficult to read and remember. Quick—in the current workbook what does the cell range B16:H16 refer to? It’s the cell range that contains the total 401K contributions (both the employee’s and employer’s) for each employee. Assigning a name to a cell or cell range makes it easier to read, remember, and use in formulas. So instead of totaling the 401K contributions with the formula, =SUM(B16:H16), you could use a range name to create the more legible formula, =SUM(Retirement).

This lesson will show you how to create range names and use them in your formulas. This lesson also explains how to use column and row heading labels in your formulas, and how Excel can automatically create range names for you.

1. Select the cell range B16:H16.
   The selected cell range contains the employer and employee contributions to each employee’s 401K account. Here’s how to give the selected cell range a meaningful name, instead of referring to it as B16:H16.

2. With the cell range B16:H16 still selected, click the Name box in the formula bar, type Retirement and press <Enter>.
   Now when you need to reference the 401(K) amounts, you can use the Range Name “Retirement” instead of the obscure and hard-to-remember cell reference B16:H16.

3. Click cell A22, click the Bold button on the Formatting toolbar, type Total 401K and press <Tab>.

4. In cell B22, type =SUM(Retirement) and press <Enter>.
   Excel calculates the sum of the Retirement range, B16:H16.

© 2001 CustomGuide.com
Once you create a Named Range you can quickly select it by picking it from the Name box in the Formula bar.

5. **Click the Name box arrow and select Retirement.**
   Excel selects the Retirement range. You don’t have to manually create names—you can have Excel automatically create them for you.

6. **Select the cell range A5:H11, and select Insert → Name from the menu.**
   Here’s a brief summary of what each of the items in the Name submenu does:
   - **Define:** Creates a name for a cell, a cell range, or constant or computed value that you can use to refer to the cell, range, or value. (This is the same as typing it directly in the Name box.) You can also delete any existing names.
   - **Paste:** Inserts the selected name into the formula bar. If the formula bar is active and you begin a formula by typing an equal sign (=), clicking Paste will paste the selected name at the insertion point. If the formula bar is not active, double-clicking a name in the Paste Name box pastes an equal sign (=) followed by the selected name into the formula bar.
   - **Create:** Creates names by using labels in a selected range.
   - **Apply:** Searches formulas in the selected cells and replaces references with names defined for them, if they exist.
   - **Label:** Creates names for formulas by using text labels from the rows or columns of a selected range.

7. **Select Create from the Name menu.**
   The Create Names dialog box appears, as shown in Figure 6-6. The Create Names will automatically create range names, based on the current selection.

8. **Verify that the Top row and Left column check boxes are checked and click OK.**
   The Create Names dialog box closes, and Excel automatically creates names for the selected cell range. You can verify that Excel created the correct names by clicking the Name box arrow.

9. **Click the Name Box List arrow.**
   The column heading names should appear in the Name Box list.

10. **Click anywhere in the worksheet window to close the Name Box list.**
    You can also use column and row labels in the worksheet to refer to data in formulas—without having to create any names at all!

11. **Click cell A23, click the Bold button on the Formatting toolbar, type Max Hourly Rate and press <Tab>.**

12. **In cell B23, type =MAX(Hourly Rate) and press <Enter>.**
    Excel returns the maximum value in the Hourly Rate row, 18.50.

13. **Save your work.**
Lesson 6-4: Selecting Nonadjacent Ranges and Using AutoCalculate

This lesson covers two, almost unrelated topics, since both of them are so simple and easy to explain. If you’ve gotten this far in the book you obviously know how to select and use cell ranges in your formulas. But, how do you select cell ranges that aren’t next to each other? That’s the first topic explained in this lesson.

The second topic covered in this lesson is how you can use Excel’s nifty AutoCalculate feature to calculate a total or average of a cell range without entering a formula.

1. Click cell A24, click the Bold button on the Formatting toolbar, type M-W-F and press <Tab>.

Next you want to total the hours from only the Monday, Wednesday, and Friday rows. You can select several nonadjacent cell ranges by holding down the <Ctrl> key when you select the ranges.

2. Make sure cell B24 is active and click the AutoSum button on the Standard toolbar.

Excel selects the closest cell with data in it (B24) as the argument for the SUM function. This is isn’t the cell range you want to use in your formula—you want to find the totals of the Monday, Wednesday, and Friday rows.
3. Select Monday’s cell range, B6:H6, press and hold the <Ctrl> key, select Wednesday’s cell range, B8:H8, and then select Friday’s cell range, B10:H10. Release the <Ctrl> button when you’re finished.

The nonadjacent ranges in the Monday, Wednesday, and Friday rows are all selected, as indicated by the shimmering dotted line around each of the columns. Notice the formula bar displays the cell ranges: =SUM(B6:H6,B8:H8,B10:H10).

4. Press <Enter>.

Excel calculates the total hours for the Monday, Wednesday, and Friday rows.

On to the second topic covered in this lesson—AutoCalculate. Sometimes you may want to calculate the total of several cells without actually creating a formula. Excel’s AutoCalculate makes this incredibly easy—simply select the cell range you want to total, and the calculation is displayed on down on the status bar.

5. Select the cell range B6:H10.

The AutoCalculate area of the status bar displays the total of the selected cell range: Sum=240. You can also use AutoCalculate to do other simple and quick calculations. To change the calculation type, right-click the AutoCalculate area of the status bar.

6. Right-click the AutoCalculate area of the Status bar.

A shortcut menu appears with a list of the AutoCalculate options:

- **None**: Disables AutoCalculate.
- **Average**: Calculates the average of the selected cells.
- **Count**: Counts the number of non-empty cells.
- **Count Nums**: Counts the number of cells that contain numbers.
- **Max**: Returns the largest value in a range of cells.
- **Min**: Returns the smallest value in a range of cells.
- **Sum**: Adds all the numbers in a range of cells (the default setting.)

You want AutoCalculate to display the average of any selected cells.

7. Select **Average** from the AutoCalculate shortcut menu.

AutoCalculate calculates the average for the selected cell range. Return AutoCorrect back to the default Sum setting.

8. Right-click the AutoCalculate area of the Status bar and select **Sum**.

9. Save your work.
Lesson 6-5: Using the IF Function to Create Conditional Formulas

This lesson introduces a very useful function, the *IF* function. The IF function is a *conditional function* or *logical function* because it will evaluate a condition you specify and return one value if the condition is true and another value if the condition is false. For example, you could use the IF function in an invoice to create a formula that would subtract a 5% discount from the invoice if the total was more than $500.00, otherwise it wouldn’t subtract anything.

The IF function contains 3 parts or arguments, as shown in Figure 6-10. Since you can use the Insert Function tool to help you enter it, you really don’t need to memorize the syntax of the IF function.

1. **Click cell B17 and press <Delete> to clear the cell contents.**
   The Federal Income tax rate changes at different income levels. You have determined that employees that earn $500 or more in a week are subject to a 15% tax rate, while employees that earn less than $500 in a week are subject to a 10% tax rate. You can create a formula using the IF function to evaluate the employee’s earnings and then multiply it by the appropriate tax rate. The IF function is a little more difficult than other functions, so use the Insert Function tool to help you enter it.

2. **Click the Insert Function on the Standard toolbar.**
   The Function Arguments dialog box appears.
3. **Select Logical** in the Function category list, select **IF** in the Function name list, and click **OK**.
   The Function Arguments dialog box appears, as shown in Figure 6-9. You’re ready to start entering the IF formula.

4. **Type B14>=500 in the Logical_test text box.**
   You just entered the first argument of the IF function, which evaluates a statement as true or false (see Figure 6-10). Here you want to evaluate if the value in B14 is equal to or greater than $500.

   **NOTE:** Remember, you can also create cell references by clicking the cell or cell range you want to reference. Click the Collapse Dialog button to collapse the function palette and select the cell range if the Function Arguments dialog box is in the way.

   The next step is entering true argument of the IF function—the value the function should enter if the value is equal to or greater than $500.

5. **Select the Value_if_true text box by clicking it or pressing the <Tab> key, and type B14*.15.**
   If the values in B14 is equal to or greater than 500 the IF function will multiple the value in cell B14 by 0.15. Move on to the next step to complete the IF function by entering the Value if false argument—what the function should do if the value is not equal to or greater than $500.

6. **Move to the Value_if_false text box by clicking it or pressing the <Tab> key, and type B14*.1.**
   If the value in B14 is less than $500, the IF function will multiple the value in cell B14 by 0.10. Compare your screen with the one shown in Figure 6-9.

7. **Click OK to complete the formula.**
   The Function Arguments dialog box closes. The IF function in B17 multiplies the Gross Pay by 15%, since it is equal to or greater than $500.

8. **Copy the formula in cell B17 to the remaining cells in row 17.**
   After copying the IF formula, notice that those columns with Gross Pay less than $500 are multiplied by 10% instead of 15%.

9. **Save your work and close the current workbook.**
   The IF function is one of the more difficult functions, but it’s also very powerful and is well worth the effort of learning how to use it.

---

**Quick Reference**

**To Use the IF Function in a Formula:**

- Write the formula using the syntax
  `$=IF(logical_test,value_if_true,value_if_false)`.

Or...

1. Click the **Insert Function button** on the Formula bar to open the Insert Formula dialog box.
2. Select **Logical** in the Function category list, select **IF** in the Function name list, and click **OK**.
3. Enter the required arguments for the IF function.
Lesson 6-6: Using the PMT Function

The PMT function is a very valuable function if you work with real estate, investments, or are considering taking out a loan. The PMT function calculates the payment for a loan based on periodic payments and a constant interest rate. For example, say you want to take out a $10,000 car loan at 8% interest and will pay the loan off in four years. You can use the PMT function to calculate that the monthly payments for such a loan would be $244.13. You can also use the PMT function to determine payments to annuities or investments. For example, if you want to save $50,000 in 20 years by saving the same amount each month, you can use PMT to determine how much you must save.

1. **Open the workbook named Lesson 6B and save it as Mortgage Table.** All of the information you need to find the monthly payments has already been entered—all you have to do use the PMT function to calculate the monthly payment. The PMT function is a little complicated, so use the Insert Function feature to help you enter it.
2. **Click cell D4 and click the Insert Function button on the Formula bar.**
3. **Select Financial from the Function Category list, scroll down the Function list, select PMT and then click OK.**

The Function Arguments dialog box appears, as shown in Figure 6-12. You’re ready to start entering the PMT formula to calculate the monthly mortgage payments. Look at Figure 6-12: the first argument of the PMT function is the interest rate. Since the Function Arguments dialog box is in the way you’ll have to click the Collapse Dialog button to see and reference the cells on the worksheet.
4. Click the Rate Collapse Dialog Box button, click cell C4, and press <Enter>.
   Because you want to calculate monthly payments instead of annual payments, you will need to divide the annual interest rates by 12.

5. Type /12 to divide the annual interest rate.
   C4/12 should appear in the Rate text box. The next argument in the PMT function is the Nper—the total number of payments for the loan.

6. Click the Nper box and type B4*12.
   Again, you want to calculate monthly, not annual payments, so you need to multiple the total number of years by 12. The last step in the PMT formula is entering the Pv—the principal.

7. Click the Pv Collapse Dialog Box button, click cell A4, and press <Enter>.
   You’re finished entering the PMT formula, so you can close the Function Arguments dialog box.

8. Click OK.
   The Function Arguments dialog box closes, and the monthly payment, ($1,162.95), appears in cell D4. Hey! Why does the monthly payment appear as a negative number? It’s because the PMT formula shows the borrower’s point of view, and therefore the payments are calculated as a negative cash flow. You can easily change the formula so that it shows a positive number by editing the formula and placing a minus sign in front of the Pv value.

9. Edit the formula in cell D4 by clicking the Formula bar, and adding a - (minus sign) immediately after the = sign, so that the formula reads =-PMT(C4/12,B4*12,A4), then click the Enter button on the Formula bar.
   The PMT formula now displays the monthly payments as a positive number. Copy the formula to find the monthly payments for the other loans.

10. Copy the formula you just created to the cell range D4:D6.
    The PMT formula is copied. Cell D5 displays a monthly payment of $1,208.39 and cell D6 displays a monthly payment of $1,048.82. Now that you have calculated the monthly payments for each of the three loans, you can easily calculate even more information, such as the total interest paid and total amount paid on each loan.

11. Click cell E4, type =, click cell D4, type *, click cell B4, type *12, so that the formula reads =D4*B4*12, and click the Enter button on the Formula bar.
    Now that you know the total amount of all the loan payments, you can find how much the total interest will be.

12. Click cell F4, type =, click cell E4, type -, click cell A4 and click the Enter button on the Formula bar.
    Wow! That interest really adds up, doesn’t it?

13. Copy the formulas in cells E4:F4 into the cells E5:F7. Compare your workbook with the one in Figure 6-14.

14. Try experimenting with different loan amounts, interest rates, and loan lengths for the different loans, then save your work and close the Mortgage table worksheet.
Lesson 6-7: Displaying and Printing Formulas

Excel normally displays the results of formulas in the worksheet. You have to select a cell and look in the formula bar if you want to see the cell’s formula. You can have Excel display the actual formulas in the worksheet cells instead of their results—and learning how to do that is the topic of this lesson. Once you display a worksheet’s formulas, you can print them for documentation purposes.

1. Select Tools → Options from the menu and click the View tab.
   The View tab of the Options dialog box appears, as shown in Figure 6-15.

2. Under the Windows options section, click the Formulas check box to select it, then click OK.
   The Options dialog box closes. Notice the worksheet columns are widened, and instead of displaying the results of formulas, they now display the actual formulas, as shown in Figure 6-16. Since the worksheet columns are so wide, you will have to scroll the worksheet to see all of the formulas.
3. Scroll the worksheet horizontally, until you can see the F column.
   You can also print the worksheet with the formulas displayed. For the formulas to be
   meaningful when they are printed, however, you need to tell Excel to print the
   worksheet row number and column letter headings.

4. Select File \rightarrow Page Setup from the menu and click the Sheet tab.
   Now specify that you want the row and column headings to be printed.

5. Click the Row and Column Headings check box and click OK.
   Now preview your worksheet to see how it will look when printed.

6. Click the Print Preview button on the Standard toolbar. Use the \( \rightarrow \)
   pointer to zoom in and out of the worksheet.
   The worksheet will be printed with the formulas and row and column headings
   displayed.

7. Click Close.

8. Select Tools \rightarrow Options from the menu, make sure the View tab is
   selected, click the Formulas check box to deselect it, and then click
   OK.
   Excel displays the results of the formulas instead of the formulas themselves.

9. Close the workbook without saving it.

---

Quick Reference

To Display or Hide Worksheet Formulas:
1. Select Tools \rightarrow Options from the menu and click the View tab.
2. Check or uncheck the Formulas check box.
Lesson 6-8: Fixing Formula Errors

1. **Open the workbook Lesson 6C.**

   This workbook, created by a user who is not as proficient in Excel as you are, contains several common errors that you will likely encounter. Notice cells B7, B8, B10, and B12 all have a string of ####’s in them, as shown in Figure 6-17. Technically, this isn’t an error—the numerical information in the cells is just too large to be displayed in the current cell width. To fix the problem you simply need to widen the column.

2. **Double-click the line between the B and C the column headers.**

   Word automatically adjusts the width of the selected column so that it can display the widest cell entry and the ####’s disappear.

3. **Select **Tools → Error Checking** from the menu.**

   The Error Checking dialog box appears, as shown in Figure 6-18. The first error Excel finds is in cell D5. This cell displays #DIV/0!. This error code results when Excel tries to divide a number by zero. The Auditing toolbar can help you track down and correct errors in your formulas. Here’s how to use the new error-checking feature.

4. **Select **Tools → Toolbars → Formula Auditing** from the menu.**

   The Formula Auditing toolbar appears, as shown in Figure 6-17. The Formula Auditing toolbar helps you find cells that have a relationship to a formula, displays formulas affected by changes made to the cell, and tracks down the sources of error values.
4. Click cell D5, and then click the **Trace Error button** on the Formula Auditing toolbar.

An arrow appears from the active cell, D5, to the cells that caused the error. Notice cell B5 contains a value, while cell C5 is blank—the source of the #DIV/0! error in cell D5. To fix the error, you must enter a value in cell C5.

5. Click cell C5, type 1 and press <Enter>. Click the **Remove All Arrows button** on the Formula Auditing toolbar to remove the tracer arrow.

The error value in cell D5 is replaced by the correct calculation of the formula. Next, look at cell B12, the one that calculates the agent’s commission. Hmm… considering the commission rate at North Shore travel is 5% this commission amount seem too large. You can investigate this value by tracing the cell precedents—the cells that are related in some way to the formula.

6. Click cell B12 and click the **Trace Precedents button** on the Formula Auditing toolbar.

Arrows appear from the cell range B4:B10 to cell B12. You can now easily see the source of the problem: the cell range includes both the sales totals and the sum of the sales totals, doubling the value used to calculate commission. Fix the error.

7. Edit the formula in cell B12 so it reads =B10*0.05 and press <Enter>.

The formula now calculates a more reasonable commission amount, $731.70. You can close the Auditing toolbar since you’re finished using it.

8. Click the Formula Auditing toolbar’s close button to close it, close the Error Checking dialog box, and then Exit Excel without saving you changes.

Table 6-3: *Excel Error Values* lists the error values Excel displays when it encounters an error and what these rather cryptic-looking error values mean.

<table>
<thead>
<tr>
<th>Error Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>######</td>
<td>The numeric value is too wide to display within the cell. You can resize the column by dragging the boundary between the column headings.</td>
</tr>
<tr>
<td>#VALUE!</td>
<td>You entered a mathematical formula that references a text entry instead of a numerical entry.</td>
</tr>
<tr>
<td>#DIV/0!</td>
<td>You tried to divide a number by zero. This error often occurs when you create a formula that refers to a blank cell as a divisor.</td>
</tr>
<tr>
<td>#NAME?</td>
<td>You entered text in a formula that Excel doesn’t recognize. You may have misspelled the name or function, or typed a deleted name. You also may have entered text in a formula without enclosing the text in double quotation marks.</td>
</tr>
<tr>
<td>#N/A</td>
<td>This error occurs when a value is not available to a function or a formula. If certain cells on your worksheet contain data that is not yet available, enter #N/A in those cells. Formulas that refer to those cells will then return #N/A instead of attempting to calculate a value.</td>
</tr>
<tr>
<td>#REF!</td>
<td>The #REF! error value occurs when a cell reference is not valid. You probably deleted the cell range referenced to in a formula.</td>
</tr>
<tr>
<td>#NUM!</td>
<td>The #NUM! error value occurs when you used an invalid argument in a worksheet function.</td>
</tr>
<tr>
<td>#NULL!</td>
<td>You specified an intersection of two ranges in a formula that do not intersect.</td>
</tr>
</tbody>
</table>
# Mathematical Functions

You can find any of Excel’s mathematical functions on a typical scientific calculator. If still remember your algebra classes, many of these functions, such as SIN, COS, and LOG should be familiar to you.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS</td>
<td>=ABS(number)</td>
<td>Determines the absolute value of a number. The absolute value of a number is the number without its sign.</td>
</tr>
<tr>
<td>ACOS</td>
<td>=ACOS(number)</td>
<td>Returns the arccosine of an angle. ACOS is the inverse of the COS function.</td>
</tr>
<tr>
<td>ASIN</td>
<td>=ASIN(number)</td>
<td>Returns the arcsine of an angle. ASIN is the inverse of the SIN function.</td>
</tr>
<tr>
<td>COMBIN</td>
<td>=COMBIN(number, number_chosen)</td>
<td>Calculates the number of possible combinations from a given number of items. <strong>Example:</strong> You want to form a two-person team from five candidates, and you want to know how many possible teams can be formed. COMBIN(5, 2) equals 10 teams.</td>
</tr>
<tr>
<td>COS</td>
<td>=COS(number)</td>
<td>Returns the cosine of an angle.</td>
</tr>
<tr>
<td>DEGREES</td>
<td>=DEGREES(angle)</td>
<td>Converts radians into degrees.</td>
</tr>
<tr>
<td>EVEN</td>
<td>=EVEN(number)</td>
<td>Rounds a number up to the nearest even or odd integer.</td>
</tr>
<tr>
<td>ODD</td>
<td>=ODD(number)</td>
<td>Rounds a number up to the nearest even or odd integer.</td>
</tr>
<tr>
<td>EXP</td>
<td>=EXP(number)</td>
<td>Calculates the value of the constant e (approximately 2.71828182845904) raised to the power specified by its argument. <strong>Example:</strong> EXP(2) equals e², or 7.389056</td>
</tr>
<tr>
<td>FACT</td>
<td>=FACT(number)</td>
<td>Calculates the factorial of a number. The factorial of a number is the product of all the positive integers from one up to the specified number. <strong>Example:</strong> FACT(5) equals 1<em>2</em>3<em>4</em>5 equals 120</td>
</tr>
<tr>
<td>LN</td>
<td>=LN(number)</td>
<td>Calculates the natural (base e) logarithm of a positive number.</td>
</tr>
<tr>
<td>LOG</td>
<td>=LOG(number, base)</td>
<td>Calculates the logarithm of a positive number using a specified base.</td>
</tr>
<tr>
<td>LOG10</td>
<td>=LOG(number)</td>
<td>Calculates the base 10 logarithm of a number.</td>
</tr>
<tr>
<td>MOD</td>
<td>=MOD(number, divisor)</td>
<td>Returns the remainder after number is divided by divisor. <strong>Example:</strong> MOD(3, 2) equals 1, the remainder of dividing 3 by 2.</td>
</tr>
<tr>
<td>Function</td>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>PI</td>
<td>=PI()</td>
<td>Returns the value of the constant pi (π), accurate to 14 decimal places.</td>
</tr>
<tr>
<td>POWER</td>
<td>=POWER(number, power)</td>
<td>Raises a number to the specified power.</td>
</tr>
<tr>
<td>PRODUCT</td>
<td>=PRODUCT(number1, number2...)</td>
<td>Multiplies all the numbers in a range of cells.</td>
</tr>
<tr>
<td>RADIANS</td>
<td>=DEGREES(angle)</td>
<td>Converts degrees to radians.</td>
</tr>
<tr>
<td>RAND</td>
<td>=RAND()</td>
<td>Generates a random number between 0 and 1.</td>
</tr>
<tr>
<td>RANDBETWEEN</td>
<td>=RANDBETWEEN(bottom, top)</td>
<td>Generates a random number between the bottom and top arguments.</td>
</tr>
<tr>
<td>ROUND</td>
<td>=ROUND(number, num_digits)</td>
<td>Rounds a number to a specified number of digits. The ROUNDDOWN and ROUNDUP function take the same form as the ROUND function, and as their name implies, always round either up or down.</td>
</tr>
<tr>
<td>ROUNDDOWN</td>
<td>=ROUNDDOWN(number, num_digits)</td>
<td>Rounds a number to a specified number of digits.</td>
</tr>
<tr>
<td>ROUNDUP</td>
<td>=ROUNDUP(number, num_digits)</td>
<td>Rounds a number to a specified number of digits.</td>
</tr>
<tr>
<td>SIGN</td>
<td>=SIGN(number)</td>
<td>Determines the sign of a number. Results in 1 if the number is positive, zero (0) if the number is 0, and -1 if the number is negative.</td>
</tr>
<tr>
<td>SIN</td>
<td>=SIN(number)</td>
<td>Returns the sine of an angle.</td>
</tr>
<tr>
<td>SQRT</td>
<td>=SQRT(number)</td>
<td>Returns a positive square root of a number.</td>
</tr>
<tr>
<td>SUM</td>
<td>=SUM(number1, number2...)</td>
<td>Adds all the numbers in a range of cells. You can enter the SUM function by clicking the AutoSum button on the Standard toolbar.</td>
</tr>
<tr>
<td>TAN</td>
<td>=TAN(number)</td>
<td>Returns the tangent of an angle.</td>
</tr>
</tbody>
</table>
# Financial Functions

Excel’s financial functions are vital if you work with investments or real estate. Financial functions help determine loan payment amounts, calculate the future value of investments, and find rates of return.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
</table>
| **FV**   | =FV(rate, number of periods, payment, present value*, type*) | Calculates the future value of an investment based on periodic, constant payments and a constant interest rate.  
Example: You plan to deposit $2,000 a year for 35 into an IRA, and you expect a 10% average rate of return.  
=FV(10%,35,-2000) equals $542,048.74 |
| **IMPT** | =PMT(rate, period, number of periods, present value, future value*, type*) | Calculates the interest payment for over a specified period of time, with constant periodic payments and a constant interest rate.  
Example: The following formula calculates the interest due in the first month of a three-year $8000 loan at 10 percent annual interest:  
IPMT(0.1/12, 1, 36, 8000) equals -$66.67 |
| **IRR**  | =IRR(values, guess) | Calculates the internal rate of return of investment. The investments do not have to be equal, but they must occur at regular intervals. The internal rate of return is the interest rate received for an investment consisting of payments (negative values) and income (positive values) that occur at regular periods.  
Example: You want to start a business. It will cost $40,000 to start the business, and you expect to net the following income in the first three years: $10,000, $15,000, and $20,000. Enter the four values in the cells A1:A4 of the worksheet, making sure to enter the initial $40,000 investment as a negative value.  
IRR(A1:A4) equals 5% |
| **NPV**  | =NPV(rate, value1, value2, ...) | Calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values). |
| **PMT**  | =PMT(rate, number of periods, present value, future value*, type*) | Calculates the payment for a loan based on constant payments and a constant interest rate.  
Example: The following formula calculates the monthly payment on a $20,000 loan with an annual interest rate of 9% that must be paid in 36-months.  
PMT(9%/12, 36, 20000) equals ($635.99) |
<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PV</td>
<td>=PV(rate, number of periods, payment, future value*, type*)</td>
<td>Returns the present value of an investment. <strong>Example:</strong> An annuity that pays $600 every month for the next 20 years costs $50,000, and the money paid out will earn 7 percent. You want to determine whether this would be a good investment. Using the PV function, you find that the present value of the annuity is: PV(0.07/12, 12*20, 600, , 0) equals ($77,389.50)</td>
</tr>
<tr>
<td>RATE</td>
<td>=RATE(total number of payments, payment, present value)</td>
<td>Determines the interest rate per period of an annuity. <strong>Example:</strong> You want to calculate the rate of a four-year (48 month) $8,000 loan with monthly payments of $200. Using the RATE function you find: RATE(48, -200, 8000) equals 0.77 percent. This is the monthly rate, because the period is monthly. The annual rate is 0.77%*12, which equals 9.24 percent.</td>
</tr>
</tbody>
</table>

* Optional arguments.
Date and Time Functions

You can use dates and time in your formulas just like any other value. For example, if cell A1 contained the entry 5/1/99 you could use the formula =A1+100 to calculate the date 100 days later, which is 8/9/99.

One very important thing to know about working with date and time functions: while Excel can display dates and times using just about any format, it actually stores dates as chronological numbers called *serial values*. So when you think of dates as months, days, and years, such as May 1, 1999, Excel thinks of dates in terms of serial numbers, such as 36281.

**NOTE:** Since the following date and time formulas often return serial number values, you should format any cells with date or time formulas with data and time formats that you can easily understand. You can also create custom number formats to display the results of date formulas. For example, the custom format `dddd` would display only the day, Monday, instead of the entire date, 8/9/99.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE</td>
<td>=DATE(year, month, day)</td>
<td>Enters a date in the cell.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> DATE(99,5,1) equals May 1, 1999.</td>
<td></td>
</tr>
<tr>
<td>TODAY</td>
<td>=TODAY()</td>
<td>A special version of the DATE function. While the DATE function can return the value of any date, the TODAY function always returns the value of the current date.</td>
</tr>
<tr>
<td>TIME</td>
<td>=TIME(hour, minute, second)</td>
<td>Enters a time in the cell. Uses a 24-hour (military) time system.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> TIME(14,30) equals 2:30 PM.</td>
<td></td>
</tr>
<tr>
<td>TODAY</td>
<td>=NOW()</td>
<td>A special version of the TIME function. While the TIME function can return the value of any time, the NOW function always returns the value of the current time.</td>
</tr>
<tr>
<td>WEEKDAY</td>
<td>=WEEKDATE(serial_number, return_type)</td>
<td>Returns a day of the week for a specific date. The serial_number argument is a date value (or reference to one).</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> WEEKDAY(“2/14/90”) equals Wednesday.</td>
<td></td>
</tr>
<tr>
<td>YEAR</td>
<td>=YEAR(serial_number, return_type)</td>
<td>Returns a value of the year for a specific date. The serial_number argument is a date value (or reference to one).</td>
</tr>
<tr>
<td>MONTH</td>
<td>=MONTH(serial_number, return_type)</td>
<td>Returns a value of the month for a specific date. The serial_number argument is a date value (or reference to one).</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong> MONTH(“3/15/1998”) equals 3.</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>--------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| DAY      | =DAY(serial_number, return_type) | Returns a value of the day for a specific date. The serial_number argument is a date value (or reference to one).  
**Example:** DAY("3/15/1998") equals 15. |
| HOUR     | =HOUR (serial_number) | Returns hour value for a specific time. The serial_number argument is a time value (or reference to one). Uses a 24-hour time format.  
**Example:** HOUR("12:15:45") equals 12. |
| MINUTE   | =MINUTE (serial_number) | Returns the minute value for a specific time. The serial_number argument is a time value (or reference to one). Uses a 24-hour time format.  
**Example:** MINUTE("12:15:45") equals 15. |
| SECOND   | =SECOND (serial_number) | Returns a value of a second for a specific time. The serial_number argument is a time value (or reference to one). Uses a 24-hour time format.  
**Example:** SECOND("12:15:45") equals 45. |
| HOUR     | =HOUR(number, number_chosen) | Calculates the number of possible combinations from a given number of items.  
**Example:** You want to form a two-person team from five candidates, and you want to know how many possible teams can be formed.  
COMBIN(5, 2) equals 10 teams. |
| DAYS360  | =DAYS360(start_date, end_date) | Returns the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations.  
**Example:** DAYS360("1/30/93", "2/1/93") equals 1 |
Statistical Functions

Excel offers a large number of functions to help you analyze statistical data. If they’re not enough you can also use the Analysis Toolpak, found under Tools → Data Analysis.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>=AVERAGE(number1, number2…)</td>
<td>Calculates the average, or arithmetic mean, of the numbers in the range or arguments.</td>
</tr>
<tr>
<td>COUNT</td>
<td>=COUNT(number1, number2…)</td>
<td>Counts the number of cells that contain numbers, including dates and formulas. Ignores all blank cells and cells that contain text, or errors.</td>
</tr>
<tr>
<td>COUNTA</td>
<td>=COUNTA(number1, number2…)</td>
<td>Counts the number of all nonblank cells, regardless of what they contain.</td>
</tr>
<tr>
<td>COUNTIF</td>
<td>=COUNTIF(range,criteria, sum_range)</td>
<td>Counts the cells only if they meet the specified criteria. Similar to SUMIF.</td>
</tr>
<tr>
<td>MAX</td>
<td>=MAX(number1, number2…)</td>
<td>Returns the largest value in a range.</td>
</tr>
<tr>
<td>MEDIAN</td>
<td>=MEDIAN(number1, number2…)</td>
<td>Calculates the median of the numbers in the range or arguments. The median is the number in the middle of a set of numbers—half the numbers have values that are greater than the median, and half have values that are less.</td>
</tr>
<tr>
<td>MIN</td>
<td>=MIN(number1, number2…)</td>
<td>Returns the smallest value in a range.</td>
</tr>
<tr>
<td>MODE</td>
<td>=MODE(number1, number2…)</td>
<td>Determines which value occurs most frequently in a set of numbers.</td>
</tr>
<tr>
<td>STDEV</td>
<td>=STDEV(number1, number2…)</td>
<td>Estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are dispersed from the average value.</td>
</tr>
<tr>
<td>STDEVP</td>
<td>=STDEVP(number1, number2…)</td>
<td>Estimates standard deviation based on an entire population.</td>
</tr>
<tr>
<td>SUMIF</td>
<td>=SUMIF(range,criteria, sum_range)</td>
<td>Adds the cells only if they meet the specified criteria. <strong>Example:</strong> You want to total the cell range B1:B5 only if the value in cellA1 is greater than 500. SUMIF(A1,&quot;&gt;500&quot;,B1:B5)</td>
</tr>
<tr>
<td>VAR</td>
<td>=VAR(number1, number2…)</td>
<td>Estimates variance based on a sample.</td>
</tr>
<tr>
<td>VARP</td>
<td>=VARP(number1, number2…)</td>
<td>Estimates variance based on an entire population.</td>
</tr>
</tbody>
</table>
Database Functions

Database functions return results based on filtered criteria. All the database functions use the same basic syntax =Function(database, field, criteria). The arguments include:

- **Database**: The cell range that makes up the list or database.
- **Field**: Indicates which column is used in the function. You can refer to fields by their column label enclosed with double quotation marks, such as "Name" or as a number that represents the position of the column in the list: 1 for the first column, 2 for the second, and so on—not the column heading numbers!
- **Criteria**: Is a reference to the cell or cell range that specifies the criteria for the function. For example, you might only want to total records from a certain region.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVERAGE</td>
<td>=DAVERAGE(database, field, criteria)</td>
<td>Find the average of values in a column in a list or database that match the criteria you specify.</td>
</tr>
<tr>
<td>DCOUNT</td>
<td>=DCOUNT(database, field, criteria)</td>
<td>Counts the number of cells that contain numbers from a list or database that match the criteria you specify.</td>
</tr>
<tr>
<td>DGET</td>
<td>=DGET(database, field, criteria)</td>
<td>Extracts a single record from a database that matches the criteria you specify.</td>
</tr>
<tr>
<td>DMAX</td>
<td>=DMAX(database, field, criteria)</td>
<td>Returns the largest value from a database that matches the criteria you specify.</td>
</tr>
<tr>
<td>DMIN</td>
<td>=DMIN(database, field, criteria)</td>
<td>Returns the smallest value from a database that matches the criteria you specify.</td>
</tr>
<tr>
<td>DSTDEV</td>
<td>=DSTDEV(database, field, criteria)</td>
<td>Estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are dispersed from the average value.</td>
</tr>
<tr>
<td>DSUM</td>
<td>=DSUM(database, field, criteria)</td>
<td>Adds the values in a column in a list or database that match the criteria you specify.</td>
</tr>
<tr>
<td>DVAR</td>
<td>=DVAR(database, field, criteria)</td>
<td>Estimates variance based on a sample from selected list or database entries.</td>
</tr>
</tbody>
</table>

Using this criteria range (A1:A3) in a database function would only calculate records with New York or Boston in the Destination field.
Chapter Six Review

Lesson Summary

Formulas with Several Operators and Cell Ranges

- If you combine several operators in a single formula, Microsoft Excel performs the operations in this order: ( ), %, ^= and /, + and -, = <> <= >=.
- Change the order of precedence by enclosing the part of the formula you want to calculate first in parentheses.

Using Insert Function to Enter and Edit Formulas

- The Insert Function tool assists you select, enter, and edit worksheet functions.
- To Use the Insert Function tool to Enter or Edit a Formula: Select the cell where you want to enter or edit a formula and click the Insert Function button on the Formula bar.

Creating and Using Range Names

- You can create a range name by selecting a cell range and then giving it a name in the Name box in the Formula bar.
- You can refer to names in your formulas. For example, =SUM(Expenses) instead of =SUM(B3:B35). You can also refer to column and row headings in your formulas.
- To Automatically Create Names: Select the cell or cell range you want to name and select Insert → Name → Create from the menu. Change the check boxes in the Create Names dialog box and click OK.
- To Change the Cell Reference of a Name: Select the new cell or cell range you want to use as the reference and Select Insert → Name → Apply from the menu. Select the name you want to use in the selected reference and click OK.

Selecting Nonadjacent Ranges and Using AutoCalculate

- Select cell ranges that aren’t next to each other by selecting the first range, and then pressing and holding the <Ctrl> key while you select additional cells.
- The Status bar displays the total (or other selected calculation) of the selected cell range.
- To Change the AutoCalculate Function: Right-click the AutoCalculate area of the Status bar and select the function you want AutoCalculate to use from the shortcut menu.

Using the IF Function to Create Conditional Formulas

- The IF function evaluates a condition you specify and returns one value if the condition is true and another value if the condition is false.
- The syntax for the IF function is =IF(logical_test,value_if_true,value_if_false). It’s much easier to create IF formulas using the Insert Function tool.
Using the PMT Function

- The PMT function calculates the payment for a loan based on periodic payments and a constant interest rate.
- The syntax for the PMT function is =PMT(rate,nper,pv). It’s much easier to create PMT formulas using the Insert Function tool.

Displaying and Printing Formulas

- To Display or Hide Worksheet Formulas: Select Tools → Options from the menu and click the View tab and Check or uncheck the Formulas check box.

Fixing Errors in Your Formulas

- Be able to identify and correct any error values.
- The Auditing toolbar helps track the cause of an error. Display it by selecting Tools → Auditing → Show Auditing Toolbar.

Quiz

1. Excel always calculates formulas from left to right (True or False?)

2. Which of the following formulas will Excel NOT be able to calculate? (Trick Question!)
   A. =SUM(A1:A5)-10
   B. =SUM(Sales)-A3
   C. =SUM(A1:A5)/(10-10)
   D. =SUM(A1:A5)*.5

3. Which of the following statements is NOT true?
   A. The Insert Function button on the Formula bar helps you select, enter, and edit formulas.
   B. Range names can contain up to 255 characters, including spaces.
   C. You can create a range name by selecting a cell range and entering the range name in the Name box in the Formula bar.
   D. You can refer to range names when you reference cells in your formulas.

4. Which of the following statements is NOT true?
   A. You can select cell ranges that aren’t next to each other by selecting the first cell range, pressing and holding the <Ctrl> key and select any additional cell ranges.
   B. =IF(A4 >10, 0.5, 0) is a example of a properly entered formula using the IF function.
   C. If the Insert Function tool obscures the cells you want to reference in a formula you can click the Collapse Dialog box to temporarily shrink the Insert Function tool.
   D. Excel displays the error value “#!!!!!!” when it doesn’t recognize the text you’ve entered into a formula.
5. **Which is the fastest method to find the total of a cell range?**
   A. Select a blank cell, click the AutoSum button on the Standard toolbar, select the cell range and click <Enter>.
   B. Select a blank cell, type “=SUM”, select the cell range, type “)” and click <Enter>.
   C. Select the cell range and the status bar will display its total.
   D. Select the cell range, click the AutoSum button, and the Name box in the Formula bar will display the total.

6. **What does the error #DIV/0! mean?**
   A. That a number value is too wide to display within the cell.
   B. That a formula is divided by zero or an empty cell.
   C. That a formula is divided by the letter O.
   D. That you won’t be receiving any stock dividends this year.

7. **You are thinking about buying a $250,000 house. What function can help you calculate your monthly payments?**
   A. SUM.
   B. IF.
   C. PMT.
   D. COUNT.

8. **Which of the following statements is NOT true?**
   A. Range names can make it to reference cells. For example, instead of typing (A1:B10) you could refer to the same cell range by its name, Expenses.
   B. You can create a range name by selecting a cell range and then entering its name in the Name box in the Formula bar.
   C. You can’t use range names in a formula.
   D. You can use column and row labels in a worksheet to refer to data in formulas.

9. **Which of the following formulas would find the smallest number in the cell range B10 to E25?**
   A. =COUNT(B10:E25).
   B. =MIN(B10:E25).
   C. =FIND(B10:E25).
   D. =SMALL(B10:E25).

**Homework**

1. Open the Homework 6 workbook and save it as “Commission Bonus.”
2. Add formulas in the Total column and Total row that total the appropriate column or row.
3. Create a formula in cell B10 that calculates the average of the cell range B4:F8.
4. Use AutoCalculate to find the totals sales to W Europe and E Europe (Hint: select cell range B4:C8 and look at the status bar.)
5. In cell B14 create a formula that calculates how much of a commission bonus each agent receives. If an agent’s sales were more than $30,000 they receive a $500 bonus otherwise they receive nothing. (Hint: You’ll have to use the IF function.) Copy the formula to the remaining travel agents when you’re completed the formula.
6. Display the formulas used in the Commission Bonus worksheet instead of their results. Change the display back to results when you’re finished.

7. Create a range name: Select the cell range A14:B18 click in the Name box and type “Commissions”.

**Quiz Answers**

1. False. If you combine several operators in a single formula, Microsoft Excel performs the operations in this order: ( ), %, ^, * and /, + and –, = <> <= >=.

2. C. The (10-10) portion of the formula would result in 0, causing the formula to divide by 0, which if you remember your math classes is impossible.

3. B. Range names cannot have spaces in them.

4. D. The error value “#####” means a numeric value is too wide to display within the cell. You can resize the column by dragging the boundary between the column headings.

5. D. AutoCalculate automatically displays the total of any selected cells and is the fastest and easiest method to find the total of a cell range.

6. B. #DIV/0! is the division by zero error.

7. C. The PMT function calculates the payment for a loan based on periodic payments and a constant interest rate.

8. C. You can use range names in a formula, for example =SUM(Income).

9. B. =MIN(B10:E25) would find the smallest number.
Chapter Seven:
Working with Lists

Chapter Objectives:
• Create a list
• Use the Data Form to add, find, edit, and delete records
• Sort a list
• Use the AutoFilter to filter a list
• Create a custom AutoFilter
• Create and use an advanced filter
• Use data validation when entering records to a list

Chapter Task: Create a list that tracks customers and flights

Another task Excel can perform is keeping track of information in lists or databases. Some examples of things you might track in a list include telephone numbers, clients, and employee rosters. Once you create a list in Excel, you can easily find, organize, and analyze its information with Excel’s rich set of list-management features.

In this chapter, you will learn how to create a list, and then add, modify, delete, and find information in it. You’ll also learn how you can use Excel’s filter commands to display specify information, such as records from a specific zip code.
Lesson 7-1: Creating a List

We’ll start this chapter off by creating a list. Lists are organized by records. Each record contains information about a thing or person, just like an individual listing in a phone book. Records are broken up into fields, which store specific pieces of information. For example, the LastName field would contain people’s last names, and the Phone field would contain their phone numbers. In Excel, the columns contain the list’s fields, and the rows contain the list’s records. See Figure 7-2 for an example of how information is stored in columns and rows.

Creating a list in Excel is easy—almost too easy, and people often create lists without planning and thinking about how they will work with the information in the future. Think ahead when you create a list—it’s often difficult to make changes to the structure of the list once there is information in it. Table 7-1: Guidelines for Creating Lists for some guidance on creating list.

1. Start Microsoft Excel.
   The first step in creating a list is entering the field names for the list. Make sure you always put the field names in the first row of the list.

2. Type First in cell A1 and press the <Tab> key to move to the next cell.

3. Type the remaining field names, each in its own cell, as shown in Figure 7-1.
   Don’t worry if the field names are wider than the cells—the information is there, you just can’t see all of it. Move on to the next step to add a couple records to the list.
4. **Enter the information from Figure 7-2 in the second and third rows. Add an apostrophe (') before you type the Zip Codes (i.e. '55701).**

   The apostrophe enters the Zip Code as a label instead of a value. If you didn’t add an apostrophe, Excel would remove the leading zeros (0) from any Zip Codes beginning (0), such as 01586.

   That’s all there is to creating a list. There are, however a few things you can do to the list to make working with it a little easier. First, make the field headings stand out more by making them bold.

5. **Select the cell range A1:H1 and click the Bold button on the Formatting toolbar.**

   When working with lists (especially longer ones) it is usually also a good idea to split and freeze the worksheet window so the field headings always remain visible when you move through the rest of the worksheet.

6. **Move the pointer over the vertical split box, located at the top of the vertical scroll bar. When the pointer changes to a †, drag the split box down directly beneath row 1.**

   Excel splits the worksheet window vertically into two separate panes.

7. **Select Window → Freeze Panes from the menu.**

   The frozen heading row will always be visible at the top of the worksheet, even if the list contains thousands of records.

---

### Table 7-1: Guidelines for Creating Lists

<table>
<thead>
<tr>
<th>Guideline</th>
<th>Why?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Only have one list on a worksheet</td>
<td>Some list management features, such as filtering, can be used on only one list at a time.</td>
</tr>
<tr>
<td>Leave at least one blank column and one blank row between the list and other data on the worksheet.</td>
<td>Excel can then more easily detect and select the list when you sort, filter, or insert automatic subtotals.</td>
</tr>
<tr>
<td>Avoid putting blank rows and columns in the list.</td>
<td>So that Microsoft Excel can more easily detect and select the list.</td>
</tr>
<tr>
<td>Create column labels in the first row of the list.</td>
<td>Excel uses the labels to create reports and to find and organize data.</td>
</tr>
<tr>
<td>Design the list so that all rows have similar items in the same column.</td>
<td>This makes the list more meaningful and organized.</td>
</tr>
<tr>
<td>Try to break up information as much as possible.</td>
<td>This gives you more power to sort, filter and manipulate the list.</td>
</tr>
<tr>
<td>Each column should contain the same type of information.</td>
<td>This will make the list easier to read and understand.</td>
</tr>
<tr>
<td>Don't use duplicate field names.</td>
<td>Duplicate field names can cause problems when entering and sorting information.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Create a List or Database in Excel:

- Enter the field names as column headers.
- Enter records as rows.
- Refer to Table 7-1: Guidelines for Creating Lists for tips on designing your lists.
Lesson 7-2: Using the Data Form to Add Records

There are two ways to add records to a list: we already covered the first method in the previous lesson—simply by entering them to the rows in the list range. Once you have entered the field names for a list, another way to add records to a list is with Excel’s Data Form dialog box, which you can find under the Data → Form menu. Actually, the Data Form can do a lot of things, including:

- Adding records
- Displaying and scrolling through records
- Editing existing records
- Deleting records
- Finding specific records

This lesson focuses on using the Data Form to display and add records to the current list—we’ll cover some of the other topics in the next few lessons.

1. **Make sure the active cell is located somewhere inside the list (the cell range A1:H3).**
   The active cell must be within the list in order to use the Data Form.

2. **Select Data → Form from the menu.**
   The Data Form dialog box appears, with the first record in the list, John Peters, displayed, as shown in Figure 7-3. One of the benefits of the Data Form is it makes it easy to display and navigate through the various records in a list.

![Figure 7-3](image.png)
3. Click the Find Next button to move to the next record in the list.
   The next record in the list, Mary Smith, appears in the Data Form.

4. Click the Find Prev button to move to the previous record in the list.
   The previous record, John Peters, appears in the Data Form. You can also use the Data Form to add new records.

5. Click the New button.
   A blank data form appears. Notice the text “New Record” appears where the record number counter was, indicating you are adding a new record to the list. The insertion point appears in the first field of the Data Form.

6. Type Susan in the Last box and press <Tab> to move the insertion point to the next field.
   Go ahead and enter the rest of the information for this record, as shown in the next step.

7. Enter the rest of the information for Susan Ratcliff in the fields as follows:
   - First: Susan
   - Last: Ratcliff
   - Address: Rt. 8, Box 109
   - City: Duluth
   - State: MN
   - Zip: 55801
   - Annual Trips: 4
   - Income: $40,000
   Press <Tab> after each entry to move to the next field. Go on to the next step when you’ve finished.

8. Click the New button to open another blank Data Form, and enter a record for Harold Williams using the following information:
   - First: Harold
   - Last: Williams
   - Address: 55 Sugar Lane
   - City: Duluth
   - State: MN
   - Zip: 55701
   - Annual Trips: 2
   - Income: $25,000
   Click Close when you have finished entering the information for Harold Williams.
   The Data Form dialog box closes. Notice the records you added are placed at the end of the list.

9. Save your worksheet as List Practice and then close it.
Lesson 7-3: Finding Records

A task you will undoubtedly want to do if you work with a list is look up or find a specific record or records, such as a record for a particular client. Like so many other procedures in Excel, there are two different ways to search for records in your lists:

- Using the Edit → Find Command
- Using the Data Form dialog box

This lesson examines both methods; plus you’ll also learn how you can find and replace information. For example, if you misspell a city’s name throughout a list, you can use the Find and Replace command to replace every occurrence of the incorrect spelling with the correct spelling.

1. Open the workbook named Lesson 7 and save it as Database List.

   One method of finding a specific record in a list is to use the Data Form.

2. Make sure the active cell is located inside the list and select Data → Form from the menu.

   The Data Form appears, as shown in Figure 7-4.
3. **Click the Criteria button.**
   A blank data form appears. Notice the text Criteria appears where the record number counter was, indicating you are working with a Criteria Data Form. To use the Criteria Data Form, simply type what you want to look for in the appropriate fields and click the Find Next button.

4. **Click the State field, type WI and click Find Next.**
   The Data Form displays the first record it finds in the list that is from WI.

5. **Click Find Next to move to the next record that matches the WI criteria.**
   The Data Form moves to the next record from WI.

6. **Click Close.**
   You can also find information in a list using Excel’s standard Find function, located under Edit → Find. You can also find and replace information. You discover a mistake in the list: the Zip Codes for Chekov, MN 55411 should be 55414. Use Replace to fix the mistake.

7. **Select Edit → Replace from the menu.**
   The Replace dialog box appears, as shown in Figure 7-6. Enter the incorrect Zip Code you want to replace—55411, and the Zip Code you want to replace it with—55414.

8. **In the Find what box, type 55411, then click the Replace with box and type 55414.**
   Now you can replace all the incorrect Zip Codes with the correct Zip Codes.

9. **Click Replace All.**
   The Replace dialog box closes, and all of the 55411 Zip Code are changed to 55414.

   **NOTE:** Think before using the Replace All button—you might not want it to replace every instance of a word or value! You can find and replace each individual occurrence of a word, phrase, or value by clicking Find Next and then Replace.

10. **Save your work.**

### Quick Reference

**To Find Records using the Data Form:**

1. Make sure the active cell is located inside the list and select Data → Form from the menu.
2. Click the Criteria button, enter the information you want to search for in the appropriate fields, and click either the Find Next or Find Prev button.

**Other Ways to Find:**

- Press <Ctrl> + <F>.

**Other Ways to Replace:**

- Press <Ctrl> + <H>.

**To Find and Replace Information:**

1. Select Edit → Replace from the menu.
2. Enter the text you want to search for in the Find what box, and enter the text you want to replace it with in the Replace with box.
3. Click Replace All to search and replace every occurrence of the text or click the Find Next button to verify each replacement.
Lesson 7-4: Deleting Records

Deleting records is another basic list or database skill you need to know. For example, if you used a list to track membership, you keep the list up-to-date by deleting people that are no longer members. There are two ways to delete records:

- **By using the Data Form dialog box.**
- **By deleting the row the record is stored in.**

This lesson will give you some practice using each method.

1. **Make sure the active cell is located inside the list and select Data → Form from the menu.**
   
   You need to delete the record for Nancy Pauls. First, you need to find her record.

2. **Click the Criteria button.**
   
   The Criteria Data Form appears.

3. **In the First field box type Nancy, click the Last field box, type Pauls, and click the Find Next button.**
   
   The record for Nancy Pauls appears in the Data Form.

4. **Click the Delete button.**
   
   A dialog box appears, asking you to confirm the deletion, as shown in Figure 7-8.

5. **Click OK to confirm the deletion of the record.**
   
   The record for Nancy Pauls is deleted, and the next record, Peter Boggins, appears in the data form.

6. **Click Close to return to the worksheet.**

   Notice that there are no blank rows where the previously deleted records were. When you delete a record using the Data Form dialog box, Excel automatically moves the following rows up to replace the deleted record.

   You can also delete records by deleting the record’s row.
7. Right-click the **Row 12 Heading** and select **Delete** from the shortcut menu.

   The entire row is deleted, and the remaining rows move up to replace the deleted row.

You’re doing great! Believe it or not, you’ve already made it halfway through the chapter and are well on your way to learning everything there is to know about lists.
Lesson 7-5: Sorting a List

Normally, when you enter new records to a list, you add them to the end of the list, in the order you receive them. That's fine, but what if you want the list's records to appear in alphabetical order? Another of Excel’s useful functions is its ability to sort information. Excel can sort records alphabetically, numerically, or chronically (by date.) Additionally, Excel can sort information in ascending (A to Z) or descending (Z to A) order. You can sort an entire list or any portion of a list by selecting it. This lesson will show you several techniques you can use to sort information in your lists.

1. **Click cell B1 to make it active.**
   You want to sort the list by the last name, so you have selected the Last field.

2. **Click the Sort Ascending button on the Standard toolbar.**
   Excel sorts this list, ordering the records in ascending (A-Z) order by last name, as shown in Figure 7-10. You can also sort a list in descending (Z-A) order.
3. **Click cell A1 to make it active, then click the Sort Descending button on the Standard toolbar.**
   The list is sorted in descending (Z-A) order by the First field.
   So far, you have sorted the list by a single field. You can sort lists by up to three fields by using the Sort dialog box found under Data → Sort.

4. **Select Data → Sort from the menu.**
   The Sort dialog box appears, as shown in Figure 7-11. You want to sort the list by the last name and then by the first name.

5. **Select Last from the Sort by list arrow and make sure the Ascending option is selected.**
   The list will be sorted in ascending order (A-Z) by the last name. Next, specify the second field you want to sort the list by.

6. **Click the first Then by arrow, select First, and make sure the Ascending option is selected.**
   You’re ready to sort the list.

7. **Click OK.**
   The Sort dialog box closes and the list is sorted in ascending order, first by the last names, and then by first names.

8. **Save your work.**
   The information you sorted in this lesson was in a list, but you can use the same sorting techniques to sort information anywhere in a worksheet, whether it is in a list or not.

<table>
<thead>
<tr>
<th>Table 7-2: Sort Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Order</strong></td>
</tr>
<tr>
<td>Ascending</td>
</tr>
<tr>
<td>Descending</td>
</tr>
</tbody>
</table>

### Quick Reference

To Sort a List by One Field:
1. Move the cell pointer to the column you want to use to sort the list.
2. Click either the Sort Ascending button or Sort Descending button on the Standard toolbar.

To Sort a List by More than One Field:
1. Make sure the cell pointer is located within the list and select Data → Sort from the menu.
2. Select the first field you want to sort by from the drop-down list and specify Ascending or Descending order.
3. Repeat Step 2 for the second and third fields you want to sort by (if desired).
Lesson 7-6: Filtering a List with the AutoFilter

1. Select Data → Filter → AutoFilter from the menu.

   List arrows appear to the right of each of the field names.

2. Click the City list arrow.

   An AutoFilter list containing all the cities in the column appears beneath the City field.

Sometimes you may want to see only certain records in your lists. By filtering a list, you display only the records that meet your criteria, and hide the records that do not. For example, you could filter a client list to display only clients who live in California. There are several ways to filter your lists. In this lesson, you will learn how to use the fastest and easiest way to filter a list with Excel’s nifty AutoFilter feature.
3. **Select Duluth from the AutoFilter list.**

   Excel filters the list so that only records that contain Duluth in the City field are displayed, as shown in Figure 7-13. Notice the status bar indicates the number of records that matched the filter (5 of 17) and that the AutoFilter list arrow for the City field changes colors, indicating it is filtering the worksheet. You can filter a list by more than one field at a time.

4. **Click the Annual Trips list arrow and select 2 from the AutoFilter list.**

   Excel narrows the filter so that only those records that contain *Duluth* in the City field and 2 in the Annual Trips field are displayed. Notice that the colors of the AutoFilter list arrows for both the City field and Annual Trip field are different colors, indicating they are filtering the worksheet. Here’s how to remove the current filter criteria and display all the records.

5. **Select Data → Filter → Show All from the menu.**

   All the records are displayed. You can also completely remove an AutoFilter.

6. **Select Data → Filter → AutoFilter from the menu to deselect it.**

   The AutoFilter is turned off, all the records are listed, and the AutoFilter arrows disappear from the right of the field headings.

The following table describes those other confusing items that appear in a field’s AutoFilter list.

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(All)</td>
<td>Display all rows.</td>
</tr>
<tr>
<td>(Top 10...)</td>
<td>Display all rows that fall within the upper or lower limits you specify, either by item or percentage; for example, the amounts within the top 10 percent of income.</td>
</tr>
<tr>
<td>(Custom...)</td>
<td>Apply two criteria values within the current column, or use comparison operators other than AND (the default operator). See the next lesson for more information on this option.</td>
</tr>
<tr>
<td>(Blanks)</td>
<td>Display only rows that contain a blank cell in the column.</td>
</tr>
<tr>
<td>(NonBlanks)</td>
<td>Display only rows that contain a value in the column.</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Filter a List with AutoFilter:**

1. Move the cell pointer anywhere within the list and select Data → Filter → AutoFilter from the menu.

2. Click one of the drop-down arrows in the field names of the header row and select an item you want to use to filter the list.

**To Remove an AutoFilter:**

- Select Data → Filter → AutoFilter from the menu.
Lesson 7-7: Creating a Custom AutoFilter

In the previous lesson, you learned how to use the AutoFilter feature to filter records by selecting a single value for one or more columns. When you need to filter using more complicated criteria, you have to use a Custom AutoFilter. Custom AutoFilters are more difficult to setup and create than ordinary AutoFilters, but they’re much more flexible and powerful. Custom AutoFilter can filter records based on more than one value, such as clients in a list that live in California or Oregon and can filter records based on ranges, such as clients with an income greater than $40,000.

This lesson explains how to create and use a Custom AutoFilter. First, though, we need to cover one more ordinary AutoFilter topic—how to use the Top 10 option:

1. Select **Data → Filter → AutoFilter** from the menu.
   Lists arrows appear to the right of each of the field names. You can use AutoFilter to filter records with the highest (top) or lowest (bottom) values in a list.

2. **Click the Income list arrow and select (Top 10…) from the AutoFilter list.**
   The Top 10 AutoFilter dialog box appears, as shown in Figure 7-14.

3. **Replace the 10 in the middle box with a 5 and click OK.**
   The records for the clients with the highest five incomes is displayed. Now that you know which clients have the highest incomes, you can remove the filter.

4. **Click the Income list arrow and select (All) from the AutoFilter list.**
   The filter is removed and all the records are displayed.

5. **Click the City list arrow and select (Custom…) from the AutoFilter list.**
   The Custom AutoFilter dialog box appears, as shown in Figure 7-15.
6. **Make sure the equal sign appears in the City list, then click the top comparison list arrow and select Duluth.**
   In the next step, you’ll specify that you also want to filter any records from Two Harbors as well.

7. **Click the Or option, click the bottom City list arrow and select equals, click the bottom comparison list arrow and select Two Harbors.**
   The custom AutoFilter will now display records in which the City field equals Duluth or Two Harbors. This type of search criteria is called a *Logical Condition*. You could also specify the logical condition criteria in a way so that only records from Duluth and that have incomes greater than $30,000 are filtered.

8. **Click OK.**
   The dialog box closes, and only the records from the city of Duluth or Two Harbors are displayed.

9. **Select Data → Filter → AutoFilter from the menu to deselect it.**
   The AutoFilter is turned off and all the records are displayed.

Custom AutoFilters are much more flexible and powerful than ordinary AutoFilters, but they still have some limitations. For example, you can’t filter lists based on more than two values (such as clients from California, Oregon, or Washington.) For really complicated filtering tasks, you’ll need to use an *advanced filter*, which is covered in the next lesson.
Lesson 7-8: Filtering a List with an Advanced Filter

Advanced filtering is by far the most powerful and flexible way to filter your lists. It's also by far the most difficult method, and requires a lot of work to setup and use. Advanced Filters do have several capabilities their simpler AutoFilter cousins lack, including:

- **More complex filtering criteria:** You can filter a list based on as many values in as many columns as you want.
- **The ability to extract the filtered records:** Once you have created an Advanced Filter, you can copy the filtered records to a new location. This is the main reason most people use Advanced Filters.

To create an Advanced Filter you must start by defining a criteria range. A criteria range is a cell range, located at the top of your list, which contains the filter criteria. Figure 7-16 shows an example of a worksheet with a criteria range.

1. **Select rows 1 through 4**, right-click any of the selected row number headings and select *Insert* from the shortcut menu.

   Excel inserts 4 blank rows above the list. These blank rows will be the Criteria Range— the cell range that contains a set of search conditions you will use in your advanced filter. The next step in creating an Advanced Filter is to copy the column labels from the list you want to filter.

2. **Select the cell range A5:H5**, click the *Copy button* on the Standard toolbar, click cell A1, and click the *Paste button* on the Standard toolbar to paste the copied cells.

   Next, you need to specify the criteria for the advanced filter. You want to display only those clients with incomes greater than $30,000 and that have taken more than 5 trips or those clients that have taken more than 7 trips.
3. Click cell G2, type >5, click cell H2, type >30000, and press <Enter>.
   This will filter clients that have taken more than 5 annual trips and have incomes greater than $30,000. Next, you want to add a logical condition so that any clients who have taken more than 7 annual trips are also selected, regardless of their income.

4. Type >7 in cell G3 and press <Enter>.
   Compare your worksheet to the one in Figure 7-16. You’re ready to filter the data.
   **NOTE:** Make sure there is always only blank row between the criteria values and the list. Having more than one blank row or no blank row at all will cause your advanced filter not to work!

5. Click any of the cells in the list range and select Data → Filter → Advanced Filter from the menu.
   The Advanced Filter dialog box appears, as shown in Figure 7-17. Since you opened the Advanced Filter with the active cell in the list, the list range is already selected. You still have to specify what the criteria range is, however.

6. Click the Criteria range box and select the Criteria range—A1:A3.
   You’re ready to apply the advanced filter.
   **NOTE:** Make sure you don’t select the blank row between the criteria range and the list range, or the Advanced Filter won’t work!

7. Verify that the Filter the list, in-place option is selected and click OK.
   The list range is filtered to match the criteria you specified in the criteria range. Notice the Status bar displays how many records were found. You remove Advanced Filters just the same as AutoFilters.

8. Select Data → Filter → Show All from the menu.
   All the records are again displayed.

### Quick Reference

**To Create an Advanced Filter:**

1. Your worksheet should have at least three blank rows that can be used as a criteria range above the list.

2. Copy the column labels from the list and paste them in the first blank row of the criteria range.

3. In the rows below the criteria labels, type the criteria you want to match. Make sure there is at least one blank row between the criteria values and the list.

4. Select Data → Filter → Advanced Filter from the menu.

5. In the Advanced Filter dialog box, specify the list range and the criteria range.

6. Make sure the Filter the list, in-place option is selected and click OK.

### Table 7-1: Comparison operators and Wildcards

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
</tbody>
</table>
| *       | Wildcard—any number of characters in the same position as the asterisk  
  **Example:** *east* finds "Northeast" and "Southeast" |
| ?       | Any single character in the same position as the question mark.  
  **Example:** sm?th finds "smith" and "smyth" |
Lesson 7-9: Copying Filtered Records

When you filter a list, you may want to copy or extract the records that meet your search criteria. You must use an Advanced Filter to copy filtered records to a new location. (Microsoft really should have let you to copy filtered records with the much simpler AutoFilter as well, but they didn’t so there’s no use complaining about it.)

1. Clear the current criteria in the Criteria Range by selecting the cell range G2:H3 and pressing the <Delete> key.
   Since you will only need one row for your criteria you’ll need to delete one of the rows in the criteria range.

2. Right-click the Row 2 heading and select Delete from the shortcut menu.
   Next you need to enter a new set of search criteria. This time you want to find and then extract all the records that are in the 55701 zip code.

3. Click cell F2, type 55701 and press <Enter>.
   You’re ready to filter the list, only this time instead of filtering the list in-place, you want to copy the filtered records to a new location in the workbook.

4. Click any cell in the list range (A5:H27) and select Data → Filter → Advanced Filter from the menu.
   The Advanced Filter dialog box appears, as shown in Figure 7-18. This time, instead of Filtering the list in place you want to copy it to a new location in the worksheet.
5. **Verify the List Range and Criteria Range match what is shown in Figure 7-18, then select the **Copy to another location** option in the Action section.**

The last step in extracting the records from the 55701 zip code is to specify where you want to paste the filtered records.

6. **Click the **Copy to box** and click cell J4.**

This is where the filtered records—those that meet the 55701 zip code criteria you specified in the Advanced Filter—will be copied.

**NOTE:** You can only copy filtered records to the same worksheet when you use the Advanced Filter copy to new location option. If you want to copy the filtered records to a different sheet in the workbook, or to a different workbook altogether, you have to: 1) Copy the filtered records to a location on the current sheet, and 2) Either cut or copy the filtered records to the desired location in a different worksheet or workbook.

7. **Click OK.**

The Advanced Filter dialog box closes and Excel copies the records that meet the search criteria with the 55701 zip code to the new location.

8. **Save your work.**

You deserve a medal if you’ve made it through the last couple lessons in one piece. Creating and working with advanced Filters are one of the most difficult procedures you can perform in Excel.

---

**Quick Reference**

To Copy or Extract Filtered Records:

1. Your worksheet should have at least three blank rows that can be used as a criteria range above the list.
2. Copy the column labels from the list and paste them in the first blank row of the criteria range.
3. In the rows below the criteria labels, type the criteria you want to match. Make sure there is at least one blank row between the criteria values and the list.
4. Select **Data → Filter → Advanced Filter** from the menu.
5. In the Advanced Filter dialog box, specify the list range and the criteria range.
6. Select the **Copy to another location** option.
7. Select **Copy to** box, select the cell where you want to copy the filtered records and click **OK.**
Lesson 7-10: Using Data Validation

You can help users enter accurate and appropriate information into your worksheets with Excel’s Data Validation feature. Data validation restricts the type of information that can be entered in a cell and can provide the user with instructions on entering information in a cell.

1. **Click cell I5 to select it, click the **Bold** button and the **Center** button on the Formatting toolbar,** type **Purpose**, and press **<Enter>**.

   You have just entered a new field heading for your list.

2. **Click the **Column I header** to select the entire column.**

   You want to restrict any entries to the Purpose field to a list of specific options.

3. **Select Data → Validation from the menu and click the **Settings tab** if necessary.**

   The Data Validation dialog box appears, as shown in Figure 7-20. You want to provide the user with a list of entries they can select from for the Purpose.
4. Click the Allow list arrow, select List, then click the Source box and type Business, Pleasure, Other, Not Stated, as shown in Figure 7-20. Make sure the In-cell dropdown checkbox is checked to display the list of valid entries whenever a cell in the Purpose column is selected.

You’re ready to test your data validation rules.

5. Click OK, then click cell I6.

Notice a dropdown list arrow appears to the right of the cell.

6. Click the dropdown list arrow and select Pleasure from the list.

Excel enters the Pleasure option from the list. Move on to the next step to see what happens if you type an invalid entry.

7. Make sure cell I6 is selected, type Unknown, and press <Enter>.

A warning dialog box appears, preventing you from entering invalid information.

A list is just one way of validating data—there are many other ways to restrict data entry. In the next step, you will use the Validation feature to verify that entries made to the State column use two-digit state abbreviations.

8. Click the Column E column header to select the entire column, then select Data → Validation from the menu.

The Data Validation dialog box appears. You must specify that any entries in the selected cells must contain no more or no less than two digits.

9. Click the Allow list arrow, select Text Length, click the Minimum textbox and type 2, and then click the Maximum textbox and type 2.

You can also use the Data Validation dialog box to provide a user filling out your form with help information or feedback.

10. Click the Input Message tab.

The Input Message tab appears, as shown in Figure 7-21.

11. Click the Input Message textbox, type Enter the client’s state of residence and click OK.

The dialog closes. Test out the data validation options for the state column.

12. Click cell E6.

The message “Enter the client’s state of residence” you entered in the Data Validation dialog box appears next to the cell, as shown in Figure 7-23.

13. Save your work and exit Excel.
Chapter Seven Review

Lesson Summary

Creating a List

• To Create a List in Excel: Enter the field names as column headers and records as rows.

Using the Data Form to Add Records

• To Add Records to a List Using the Data Form: Make sure the active cell is located somewhere in the list and select Data → Form from the menu. Click New and enter the information for the record in the appropriate text boxes.

Finding Records

• To Find Records using the Data Form: Make sure the active cell is located inside the list and select Data → Form from the menu. Click the Criteria button, enter the information you want to search for in the appropriate fields, and click either the Find Next or Find Prev button.

• To Find Records using the Edit → Find Command: Select Edit → Find from the menu. Enter the information you want to search for and click the Find Next button.

• To Find and Replace Information: Select Edit → Replace from the menu. Enter the text you want to search for in the Find what box, and enter the text you want to replace it with in the Replace with box. Click Replace All to search and replace every occurrence of the text or click the Find Next.

Deleting Records

• To Delete a Record with the Data Form: Make sure the active cell is located inside the list and select Data → Form from the menu. Find the record you want to delete using the Find Next, Find Prev, or Criteria buttons, click Delete and confirm the deletion of the record.

• To Delete a Record Directly in the Worksheet: Delete the record’s rows or cells.

Sorting a List

• To Sort a List by One Field: Move the cell pointer to the column you want to use to sort the list and click either the Sort Ascending button or Sort Descending button on the Standard toolbar.

• To Sort a List by More than One Field: Make sure the cell pointer is located within the list and select Data → Sort from the menu. Select the first field you want to sort by from the drop-down list and specify Ascending or Descending order. Select the second and third fields you want to sort by (if desired).

Filtering a List with the AutoFilter

• AutoFilter displays only the records that meet your criteria, and hides the records that do not.
• **To Filter a List with AutoFilter:** Move the cell pointer anywhere within the list, select *Data* → *Filter* → *AutoFilter* from the menu, and select the filter criteria from the drop-down arrows in the field names of the header row.

• **To Remove an AutoFilter:** Select *Data* → *Filter* → *AutoFilter* from the menu.

### Creating a Custom AutoFilter

• A Custom AutoFilter allows you to filter records based on more than one value or a range.

• **To Use a Custom AutoFilter:** Move the cell pointer anywhere within the list and select *Data* → *Filter* → *AutoFilter* from the menu, click one of the drop-down arrows in the field names of the header row and select *Custom* from the list. Specify your filter criteria in the Custom AutoFilter dialog box.

### Filtering a List with an Advanced Filter

• Advanced filters are difficult to setup, but they enable you to filter a list based on as many values in as many columns as you want and copy the filtered records to a new location.

• **To Create an Advanced Filter:** Your worksheet should have at least three blank rows that can be used as a criteria range above the list. Copy the column labels from the list and paste them in the first blank row of the criteria range. In the rows below the criteria labels, type the criteria you want to match (make sure there is at least one blank row between the criteria values and the list). Select *Data* → *Filter* → *Advanced Filter* from the menu, specify the list range and the criteria range, make sure the Filter the list, in-place option is selected and click *OK*.

### Copying Filtered Records

• **To Copy or Extract Filtered Records:** Setup an Advanced Filter and enter the filter criteria. Select *Data* → *Filter* → *Advanced Filter* from the menu and specify the list range and the criteria range. Select the *Copy to another location option*, select *Copy to* box, select the cell where you want to copy the filtered records, and click *OK*.

### Using Data Validation

• Data Validation restricts the type of information that is entered in a cell and provides the user with feedback and instructions.

• **To Use Data Validation:** Select the cell or cell range you want to validate and select *Data* → *Validation* from the menu. Click any or all of the tabs (Settings, Input Messages, and Error Alert) and change the settings.

### Quiz

1. **Which of the following statements is NOT true?**

   A. To create a list, you need to enter the field names in the first row.
   B. Each record in a list is stored in a column.
   C. Selecting *Data* → *Form* from the menu opens the Data Form dialog box, which you can use to add, modify, find, and delete list records.
   D. You can add a new record to the database by entering the data as a new row in the worksheet, or by selecting *Data* → *Form* from the menu, clicking the New button, and filling out the New Record form.
2. How can you find specific information in a list? (Select all that apply).
   A. Click the Find button on the Standard toolbar.
   B. Select Edit → Find from the menu.
   C. Select Tools → Finder from the menu.
   D. Select Data → Form from the menu to open the Data Form dialog box and click the Criteria button.

3. How can delete a record? (Select all that apply).
   A. Select Data → Form from the menu to open the Data Form dialog box, find the record and click the Delete button.
   B. Click the Delete button on the Standard toolbar.
   C. Delete the cells or row that contain the record from the worksheet.
   D. Select Data → Delete Record from the menu.

4. Which of the following statements is NOT true?
   A. You can quickly sort a list by placing the cell pointer in the column/field you want to sort by and clicking either the Sort Ascending or Sort Descending button on the Standard toolbar.
   B. You can sort by up to three fields at a time by selecting Data → Sort from the menu.
   C. To display only records that meet your criteria, select Data → AutoFilter from the menu.
   D. To display only records that meet your criteria, click the AutoFilter button on the Standard toolbar.

5. You can extract filtered records from a Custom AutoFilter. (True or False?)

6. Which of the following is NOT a step in creating an Advanced filter?
   A. Add a criteria range above the list. Make sure it contains the list’s column labels.
   B. Add the criteria to the criteria range. Make sure you leave a blank row between the criteria range and the list.
   C. Select Data → Filter from the menu and specify the list and criteria ranges.
   D. Select the data you want to use to filter the list by the field’s drop-down lists.

7. Which of the following statements is NOT true?
   A. You must protect the worksheet in order to use Excel’s data validation feature.
   B. Data Validation lets you restrict which type of information is entered in a cell.
   C. You can provide users with information and feedback using Data Validation.
   D. To use Data Validation, select Data → Validation from the menu.

8. How can you apply an AutoFilter to a list?
   A. Move the cell pointer anywhere within the list and select Data → Filter → AutoFilter from the menu.
   B. Right-click the any column heading in the worksheet and select AutoFilter from the shortcut menu.
   C. Click the AutoFilter button on the Standard toolbar.
   D. Add the formula =AUTOFILTER(LIST) somewhere in the list.
Chapter Seven: Working with Lists

Homework

1. Open the Lesson 11A workbook and save it as “Sales Data”.

2. Use the AutoFilter to display only records that are from the Minneapolis office.

3. Display all the records, then use the AutoFilter to display the top 10 total amounts.

4. Use the Data Form to add a new record with the following information:
   - Date: 5/3/2000
   - Last: Schmidt
   - First: Jamie
   - Office: St. Paul
   - Destination: New York
   - Amount: $700
   - Tickets: 1
   - Commission: Yes

5. Sort the list alphabetically by destination.

6. In the cells in row 2 use Excel’s Data Validation feature to enter helpful Input Messages, such as “Enter your last name” and “Enter the travel agent’s office”. Try selecting the cells when you’re finished and see if your Input Messages appear.

Quiz Answers

1. B. Records in a list are stored in rows, not columns.

2. B and D. You can find information in a list by selecting Edit → Find from the menu or by selecting Data → Form from the menu to open the Data Form dialog box and click the Criteria button.

3. A and C. You can delete a record by selecting Data → Form from the menu to open the Data Form dialog box, find the record and click the Delete button. You can also delete a record by deleting the cells or row that contain the record from the worksheet.

4. D. There isn’t an AutoFilter button on the Standard toolbar (although it would make a nice addition.)

5. False. You can only extract filtered records from an Advanced filter.
6. D. You specify the criteria for an Advanced filter in the criteria range—so there’s no need to select the criteria from drop-down lists.

7. A. You don’t have to protect a worksheet to use data validation.

8. A. To apply an AutoFilter to a list move the cell pointer anywhere within the list and select Data → Filter → AutoFilter from the menu.
Chapter Eight:
Automating Tasks with Macros

Chapter Objectives:
• Record a macro
• Play a macro
• Assign a shortcut key and toolbar button to a macro
• Edit a macro’s Visual Basic code
• Insert code into an existing macro
• Declare variables using the DIM statement
• Prompt for user input
• Use If...Then statements

Chapter Task: Create and edit several macros

If you find yourself doing the same routine task over and over again you might want to consider creating a macro to complete the task for you. A macro helps you perform routine tasks by automating them. Instead of manually performing a series of time-consuming, repetitive actions, you can record a single macro that does the entire task all at once for you.

This entire chapter is devoted to macros. We start with the basics: you learn how to record and play a macro. Next, you will learn how to assign shortcut keys and toolbar buttons to your macros. Finally, you’ll move into some advanced topics—how to write and edit macros using the Visual Basic programming language.

Prerequisites
• How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
• How to enter text and values into cells.
• How to edit, cut, copy, and paste text.
Lesson 8-1: Recording a Macro

A macro is a series of Excel commands and instructions that are grouped together and executed as a single command. Instead of manually performing a series of time-consuming, repetitive actions in Excel yourself, you can create a macro to perform the task for you. There are two ways to create a macro: by recording them or by writing them in Excel’s built-in Visual Basic programming language. This lesson explains the easy way to create a macro—by recording the task(s) you want the macro to execute for you.

When you record a macro, imagine you’re being videotaped: everything is recorded—all your commands, the data you enter, even any mistakes you make! Before you record a macro, you should write down a script that contains all the steps you want the macro to record. Practice or rehearse your script a couple times, to make sure it works, before you actually record it. If you do make a mistake while recording a macro, don’t worry—you can delete the existing macro and try again or you can edit the macro’s Visual Basic source code and fix the mistake (more on that later.) Let’s get started!

1. Open the workbook Lesson 8A and save it as Macro Practice.

   In this exercise, you’ll create a macro that inserts the current date into a cell. You can do this by entering the =TODAY() function (which inserts the current date) into a cell and then copying the formula and using the Paste Special command to paste only the formula’s resulting value, because the =TODAY() function displays whatever the current date is and would keep changing. Writing a formula and using the Paste Special command is a time-consuming process, however, so you decide to record a macro to perform this repetitive task for you.

2. Click cell B3.

   This is where you want to insert the current date. You’re ready to start recording your macro.
3. **Select Tools → Macro → Record New Macro from the menu.**

The Record Macro dialog box opens, as shown in Figure 8-1. You must give your new macro a name, and if you want, assign a shortcut key to it. Notice the store macro list box—you can store macros in one of three locations:

- **Personal Macro Workbook:** If you want a macro to be available whenever you use Microsoft Excel, store the macro in your Personal Macro Workbook.
- **New Workbook:** Stores the macro in a new workbook.
- **This Workbook:** Stores the macro in the active or current workbook.

4. **In the Macro name box, type DateStamp, then in the Description box, type This macro inserts the current date.**

Macro names can be no longer than 25 characters and cannot include spaces.

5. **Click OK.**

The Record Macro dialog disappears and you return to the worksheet. Notice the Macro toolbar appears in the document window, as shown in Figure 8-2. The Macro toolbar indicates that Excel is currently recording everything you type and every command into the DateStamp macro. Do the next several steps very carefully—you don’t want to make a mistake and have it recorded in your macro!

6. **Type =Today() and click the Enter button on the Formula bar.**

The TODAY() function will display the current date in the active cell. That’s OK for today, but not for any day after, when the date changes. You need to copy the formula and then paste the resulting value using the Paste Special command.

7. **Make sure cell B3 is selected and click the Copy button on the Standard toolbar.**

Next, use the Paste Special command to paste the resulting value of the TODAY() formula in the cell.

8. **Make sure cell B3 is selected and select Edit → Paste Special from the menu.**

The Paste Special dialog box appears.

9. **Select the Values option under the Paste section and click OK.**

The Paste Special dialog box closes, and Excel pastes the value of the TODAY() formula in cell B3. Next, format the cell.

10. **Click the Center button and then the Bold button on the Formatting toolbar.**

The active cell is now boldfaced and centered. This is the last step you want in the macro, so you can stop the macro recorder.

11. **Click the Stop button on the Macro Record toolbar.**

The Macro toolbar closes indicating that you are no longer recording a macro.

In the next lesson, you will learn how to play the macro you just recorded.
Lesson 8-2: Playing a Macro and Assigning a Macro a Shortcut Key

In this lesson you get to play the DateStamp macro you recorded in the previous lesson. Once you have created a macro you can assign a keystroke shortcut to it, such as <Ctrl> + <D>, to make it faster and easier to access—something else you’ll learn in this lesson.

1. **Click cell C3.**
   
   You want to enter the current date in this cell. Watch how your DateStamp macro saves you time.

2. **Select Tools → Macro → Macros from the menu.**
   
   The Macro dialog box appears, as shown in Figure 8-3. The Macro dialog box displays the available macros you can run.

3. **Click the DateStamp from the Macro Name list macro and click Run.**
   
   The DateStamp macro you recorded in the previous lesson runs, automatically entering the TODAY() function, then copying it and pasting its resulting value, and finally formatting it.

   If you use a particular macro frequently, you can assign it a keyboard shortcut. For example, instead of selecting Tools → Macro → Macro from the menu, selecting the macro and clicking the Run button you could run the macro by simply pressing a keystroke shortcut, such as <Ctrl> + <D>.

4. **Select Tools → Macro → Macros from the menu.**
   
   The Macro dialog box appears.

5. **Select the DateStamp macro and click the Options button.**
   
   The Macro Options dialog box appears, as shown in Figure 8-4. Here’s how you can assign a shortcut key to the macro:

6. **Click the Shortcut key box, type d, and click OK.**
   
   Close the Macro dialog box and try running the macro using your new <Ctrl> + <D> shortcut key.

7. **Click the Macro dialog box’s close button.**
   
   The Macro dialog box closes.
8. Click cell C4 and press <Ctrl> + <D>.

Excel executes the DateStamp macro and inserts today’s date in the active cell.

Well done! You’ve already learned how to record a macro, how to play a macro, and how to assign a shortcut keystroke to a macro. Not bad for only two lessons.
Lesson 8-3: Adding a Macro to a Toolbar

Another way to make macros fast and easy to access is by adding them as buttons to a toolbar. In this lesson, you will add the DateStamp macro you’ve created to a button on the Standard toolbar.

1. Select View → Toolbars → Customize from the menu and click the Commands tab.

The Customize dialog box appears, as shown in Figure 8-5. The Commands tab lets you select commands and macros you want to add on your toolbars. The commands are organized by categories, just like Excel’s menus.

2. In the Categories list, scroll to and click the Macros category.

Notice the Commands list is updated and lists a custom menu item and a custom button, as shown in Figure 8-5.

Other Ways to Customize a Toolbar:
- Right-click any toolbar or the menu and select Customize from the shortcut menu.
3. Drag the Custom button to the very beginning of the Standard toolbar, as shown in Figure 8-5.

Now you need to assign a macro to the button.

4. With the Customize dialog box still open, right-click the custom button you just added and select Assign Macro from the Shortcut menu.

The Assign Macro dialog box appears, as shown in Figure 8-6.

5. Select the DateStamp macro and click OK.

The DateStamp macro is assigned to the selected button. Follow the next step to give the DateStamp button a more meaningful name and image.

6. With the Customize dialog box still open, right-click the Custom button you just added.

The button shortcut menu appears.

7. Select the Name textbox from the Shortcut menu and replace the text &Custom Button with Date Stamp.

Don’t press <Enter> yet. You still need the shortcut menu open in order to change the image on the button.

8. Select Change Button Image from the Shortcut menu, and select from the list of pictures, as shown in Figure 8-7.

You’re finished adding the DateStamp macro to a button on the Standard toolbar, so you can close the Customize dialog box.

9. Click Close to close the Customize dialog box.

The Customize dialog closes. Now test the new toolbar button.

10. Move the pointer over the Date Stamp button on the Standard toolbar.

After a moment, a tooltip appears by the button with its name—Date Stamp.

11. Click cell E3 and click the Date Stamp button on the Standard toolbar.

Excel executes the DateStamp macro and inserts today’s date in the active cell. Now that you know how to add macros to toolbar buttons, you can remove the Date Stamp button from the Standard toolbar.

12. Select View → Toolbars → Customize from the menu.

Now that the Customize dialog is displayed, you can remove the Date Stamp button from the Standard toolbar.

13. Drag the Date Stamp button off the Standard toolbar.

The Date Stamp button is deleted from the Standard toolbar.

14. Click Close to close the Customize dialog box.
Lesson 8-4: Editing a Macro’s Visual Basic Code

This lesson introduces you to the Visual Basic (also called VB or VBA) programming language. Visual Basic is the code Excel uses to record macros. Okay, you’re probably thinking, “You can’t be serious! I can’t program my VCR!” Relax. This lesson is meant to help you become familiar with the Visual Basic language and the Visual Basic editor so you can make minor changes to your macros once you have recorded them. Just imagine you’re learning several words in a foreign language so when you’re presented with a menu you’ll recognize some of the entrees. Let’s get started, and don’t worry; it’s not going to be nearly as bad as you probably think it will be.

The best way to learn about Visual Basic is to view existing code. In this lesson we’ll view and edit the DateStamp macro.

1. Select **Tools → Macro → Macros** from the menu.
   The Macros dialog box appears.

2. Select the **DateStamp** macro from the Macro Name list and click **Edit**.
   The Microsoft Visual Basic Editor program appears, as shown in Figure 8-8. Yikes! You’re probably thinking, “What is all of that complex programming code doing on my screen?” Those funny-looking words aren’t Hungarian, they’re **Visual Basic**—the code or language the macro you recorded is written in. Whenever you record a macro, Excel writes and saves it in **Visual Basic**.
You don’t have to learn Visual Basic to be proficient at Excel, but knowing the basics can be helpful if you ever want to modify an existing macro. Take a closer look at the code for the DateStamp macro. Some of the procedures should make a little sense to you. For example, the line “Selection.Copy” is the copy procedure and the “Selection.Paste” is the paste procedure.

You decide that you no longer want the DateStamp macro to center and bold the current cell’s contents. Before you move on to the next step, look at the macro’s code and see if you can guess which lines of code apply the bold and center formatting.

3. **Find the line of code that says With Selection.**
   Believe it or not, the portion of code beginning with “With Selection” and ending with “End Selection” (eight lines down) is the part of the macro that centers and boldfaces the current selection. The line of code after End Selection, `Selection.Font.Bold = True` is what applies bold formatting to the current selection. Since you no longer want the macro to format or align the selected cell, you can delete all of this code.

4. **Select the block of code beginning with With Selection and ending with Selection.Font.Bold = True, as shown in Figure 8-8.**
   Delete the selected text.

5. **Press <Delete> to delete the selected code.**
   That’s it! You’ve made the necessary modifications so that the DateStamp macro still enters the current date but will no longer perform any formatting functions.

6. **Click the Save button on the Visual Basic Standard toolbar to save the code.**
   Now that you’ve finished editing the macro’s code, you can close the Visual Basic Editor.

7. **Close the Visual Basic Editor by clicking the close button or selecting File → Close from the menu.**
   The Visual Basic Editor window closes and you return to Excel. Try out your newly modified macro to see if it works.

8. **Click cell A3, then select Tools → Macro → Macros from the menu.**
   The Macro dialog box appears.

9. **In the Macro Name list, click the DateStamp macro, then click Run.**
   The modified DateStamp macro runs, this time entering the current date without formatting the cell.

10. **Save your work.**

---

### Quick Reference

**To Edit a Macro’s Visual Basic Code:**

1. Select Tools → Macro → Macros from the menu.
2. Select the macro and click Edit.
3. When you’re finished editing the macro’s code click the Save button and then close the Visual Basic Editor window.
Lesson 8-5: Inserting Code in an Existing Macro

Let’s face it—unless you’re a programmer, it’s unlikely that you will ever learn any of Visual Basic’s hundreds of functions, statements, and expressions. No matter. You have already learned how you can view and even edit Visual Basic code created by Excel’s macro recorder. A very useful technique you can use to edit and create macros is to insert code that has been copied, or plagiarized, from another macro. This technique lets you add steps to your existing macros by recording the steps you want to add in new macros, copying the appropriate code and inserting it in the existing macro.

1. Open the Lesson 8B workbook and save it as Employee Expenses (leave the current Macro Practice workbook open).

   When you open the Lesson 8B file a frightening-looking dialog box like the one shown in Figure 8-11 appears. Macros are like miniature programs, so there is an almost infinitesimally small chance that a macro in an Excel worksheet could in fact be a virus created by some disgruntled, malicious loser. If you know where the workbook came from, it’s probably safe to enable the macros it contains.

2. Click Enable Macros.

   Imagine this is an employee expense report you have to fill out once a week. Since you enter same information in this workbook on a regular basis, you have recorded a macro to perform some of the repetitive work of filling out the form for you.
3. Select **Tools → Macro → Macros** from the menu.
   The Macro dialog box opens. The name of the macro that fills in the basic, repetitive information is ExpenseFillIn.

4. Select the macro **ExpenseFillIn** and click **Run**.
   The Macro dialog box closes, and Excel runs the ExpenseFillIn macro, which fills in the employee name and number. It would be nice if the ExpenseFillIn macro also added the date you completed the Expense Report. You can do this by copying the procedure from the DateStamp macro you created in the Macro Practice workbook and pasting it in the code of the ExpenseFillIn macro.

5. Select **Tools → Macro → Macros** from the menu.
   The Macro dialog box appears. First, you need to copy the code from the DateStamp macro, located in the Macro Practice workbook.

6. Select the macro **'Macro Practice.xls'!InsertDate** and click **Edit**.
   The Microsoft Visual Basic editor appears with the DateStamp macro code. You need to copy only the portion of code that inserts today’s date into the active cell.

7. Select the block of code beginning with **ActiveCell.FormulaR1C1 = "=TODAY()"** and ending with **Selection.PasteSpecial Paste:=xlValues**, as shown in Figure 8-11, and click the **Copy button** on the Visual Basic toolbar.
   Now that you’ve copied the procedure that inserts the current date, you must insert, or paste it into the appropriate place in the ExpenseFillIn macro.

8. Close the Visual Basic Editor by clicking the close button or selecting **File → Close** from the menu.
   The Visual Basic Editor window closes are you return to Excel.

9. Select **Tools → Macro → Macros** from the menu, select the macro **ExpenseFillIn** and click **Edit**.
   The Microsoft Visual Basic editor appears with code for the ExpenseFillIn macro. You need to paste the copied DateStamp code into the appropriate place in the ExpenseFillInMacro code.

10. Move the insertion point to the end of the line **Range("C5").Select**, press **<Enter>** to add a blank line, then click the **Paste button** on the Visual Basic toolbar.
    The copied code from the DateStamp macro is inserted into the ExpenseFillIn macro. Compare your macro to the one shown in Figure 8-11 (don’t worry if your code is spaced differently and has different tabs.)

11. Close the Visual Basic Editor by clicking the close button or selecting **File → Close** from the menu.
    It’s time to test your macro.

12. Select **Tools → Macro**, and then **Macros** from the menu, select the **ExpenseFillIn** macro and click **Run**.
    Excel runs the ExpenseFillIn macro, which now also adds the current date in cell C5. Clear the information the macro entered and save the workbook to finish this lesson.

13. Select the cell range **A5:C5**, press the **<Delete>** key, and then save the workbook.
Lesson 8-6: Declaring Variables and Adding Remarks to VBA Code

You’ve probably heard that programming is a lot like algebra. In algebra you use variables, like the r in the equation πr². Programming uses variables too. You should always declare any variables when you use them in code. Declaring a variable is like telling Excel “I’m going to be using a variable named ‘r’ in my code.” In Visual Basic, you use the Dim statement to declare variables, using the syntax Dim variablename As datatype, as shown in Figure 8-13. This lesson explains how to declare variables using the Dim statement (you’ll actually get to use the variables you declare in the next lesson.)

Another topic covered in this lesson how to add remarks to your code. Code can be confusing—you can make it easier to understand by adding explanatory remarks to by adding REM statements. A REM statement doesn’t do anything as far as the code is concerned—it’s just a way to add notes explaining the function of the code. You can add a REM statement by typing an apostrophe before the comment. For example: ‘Adds the current date.

1. Make sure the Employee Expenses is the active workbook, then select Tools → Macro → Macros from the menu, select the macro ExpenseFillIn and click Edit.

The Microsoft Visual Basic editor appears with the code for the ExpenseFillIn macro. Since several other users occasionally use this report, you decide you want to edit the macro so it prompts the user for their name and employee number. You’ll learn how to prompt the user for information or Input in the next lesson. For now, you have to declare the variables for the employee name and number.
Chapter Eight: Automating Tasks with Macros

2. Add a blank line immediately above the line `Range("A5").Select`. Place the insertion point in the blank line and type `Dim EmployeeName As String` and press `<Enter>`. Remember, a variable is any piece of information that changes, like the x in an algebra problem: \(x + 3 = 4\). In the case of the ExpenseFillIn macro, the employee’s name will be the variable. Variables must have a name, like the x in the algebra problem. You name a variable a name declaring it with the `Dim` statement. The `Dim` statement must entered in the following syntax: `Dim variableName as datatype`. Here’s what the arguments of the `Dim` statement mean:

- **VariableName**: The name of the variable. Example: EmployeeName.
- **DataType**: The type of data you want to use in the variable, such as a number, date, or text. See Table 8-1: Data Types used in Variables for a list of data types. Make sure you add an `As` between the variable name and the data type. Example: As String.

Since the line of code “`Dim EmployeeName As String`” you just entered is a little confusing, you can add a REM statement after it to explain what it does. Here’s how:

3. Type `'Declares the EmployeeName variable as a text string and press <Enter>.

Next, you’ll need to declare the Employee Number.

4. Type `Dim EmployeeNo as Long` and press `<Enter>.

Notice as you enter code, the Visual Basic editor displays a list of words that can be used in the current statement. To accept a word, select the word from the list and press `<Tab>`. You declare the EmployeeNo as a Long integer, since it will always be a numeric value. Add a remark explaining what the preceding line of code does.

5. Type `'Declares the EmployeeNo variable as an integer and press <Enter>.

Save the updated macro.

6. Click the Save button on the Visual Basic toolbar.

In the next lesson you will get a chance to use the variables you declared with the DIM statement. Table 8-1: Data Types used in Variables lists the more common data types that can be used with the DIM statement.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Size</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Byte</td>
<td>1 byte</td>
<td>0 to 255</td>
</tr>
<tr>
<td>Boolean</td>
<td>2 bytes</td>
<td>True or False</td>
</tr>
<tr>
<td>Integer</td>
<td>2 bytes</td>
<td>-32,768 to 32,767</td>
</tr>
<tr>
<td>Long (Long Integer)</td>
<td>4 bytes</td>
<td>2,147,483,648 to 2,147,483,647</td>
</tr>
<tr>
<td>Date</td>
<td>8 bytes</td>
<td>January 1, 1000 to December 31, 9999</td>
</tr>
<tr>
<td>String (Text)</td>
<td>Varies</td>
<td>Approximately 2 billion characters</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Declare a Variable:
- Add a Dim statement at the beginning of the procedure, using the syntax `Dim VariableName As DataType`.

To Add a Remark to a Procedure:
- Add an apostrophe (`'`) before the remark.
Lesson 8-7: Prompting for User Input

When creating macros and code it is often useful to prompt the user for information. You can then use this information in any number of ways—place it in a cell, use it in a calculation, or print it in a header or footer.

This lesson explains one of the easiest methods of prompting the user for information—using the InputBox function. The InputBox function prompts the user for information by displaying a dialog box like the one shown in Figure 8-14. The syntax for the InputBox function is

```
InputBox(Prompt)
```

where `Prompt` is the message you want to display (usually enclosed in quotation marks "").

1. Make sure the Visual Basic editor is still open and displays the ExpenseFillIn code.

2. Place the insertion point immediately after the 'Declares the EmployeeNo variable as an integer statement, press <Enter>, type

   ```
   EmployeeName = InputBox("Enter the Employee's Name.")
   ```

   and press <Enter>.

   As you type, Visual Basic displays a small window that displays information about the function you’re entering and its parameters. This statement will display an InputBox, as shown in Figure 8-14, which will ask the user to enter the EmployeeName variable.
3. **Type** `EmployeeNo = InputBox("Enter the Employee Number.")` and press `<Enter>`.  
   This will display another dialog box, which will ask the user to enter the EmployeeNumber variable. Once the user has entered the EmployeeName and EmployeeNo variables in the Input Boxes, you can place EmployeeName and EmployeeNo variables in the appropriate cells.

4. **Find the** `ActiveCell.FormulaR1C1 = "Jeff Nelson"` **statement and edit it so it reads** `ActiveCell.FormulaR1C1 = EmployeeName`.  
   Make sure you remove the quotation marks! Now the macro will insert the EmployeeName variable the user enters in the Input Box instead of the name “Jeff Nelson.”

5. **Find the** `ActiveCell.FormulaR1C1 = "45177"` **statement and edit it so it reads** `ActiveCell.FormulaR1C1 = EmployeeNo` **and press** `<Enter>`.  
   You decide to enter the text from the EmployeeName variable in the page footer for the worksheet as well.

   That last statement was a bit confusing—here’s what it does. We’ll start from the end of the code and work our way forward. EmployeeName is the variable you declared and equals whatever the user enters in the InputBox. Before that is the ampersand symbol (&), which combines the EmployeeName variable with the text message “Expense Report for: ”. Note that the text message (or text string) must be enclosed in quotation marks (“”). The first part of the statement, `Worksheets("Sheet1").PageSetup.CenterFooter`, refers to the center footer of the Sheet1 worksheet. So the line of code tells Excel you want the center footer of Sheet1 to equal, or display the message “Expense Report for: EmployeeName variable” or whatever name the user enters in the InputBox.

   You’re ready to test your macro.

7. **Click the** [Save button](https://yourdomain.com) **on the Visual Basic toolbar to save the macro, then close the Visual Basic Editor by clicking the close button or selecting** [File → Close](https://yourdomain.com) **from the menu.**  
   The Visual Basic editor closes and you return to the Excel program screen.

8. **Select** [Tools → Macro](https://yourdomain.com), **and then** [Macros](https://yourdomain.com) **from the menu, select the macro** ExpenseFillIn **and click** Run.  
   An Input Box appears asking you to input the employee’s name, as shown in Figure 8-14.

9. **Type in your name, click OK, type** 7000 **in the second Input Box, and click OK.**  
   The ExpenseFillIn macro fills in the Expense report with the EmployeeName and EmployeeNo variables you entered in the two Input Boxes. Preview the workbook to verify that the EmployeeName also appears in the workbook footer.

10. **Click the** [Print Preview](https://yourdomain.com) **button on the Standard toolbar.**  
    The workbook appears in Print Preview mode. Notice that the ExpenseFillIn macro has entered the employee name at the center footer.

11. **Click** Close **to close the Print Preview window.**  
    Clear the information entered by the ExpenseFillIn macro.

12. **Select the cell range** A5:B5 **and press the** <Delete> **key, then save your work.**

---

**Quick Reference**

To Use the Inputbox Statement:

- Add an Input statement using the syntax `InputBox(Promp)`.  

---

Your Organization's Name Here
Lesson 8-8: Using the If…Then…Else Statement

The If…Then statement takes action based on a certain condition. For example, if an employee’s weekly sales are more than $2,500, then calculate a 5% commission bonus for the employee, else don’t calculate a bonus. The syntax for the If…Then statement is shown in Figure 8-16.

In this lesson you will use the If…Then statement to enter the employee number 45177 if the employee is Jeff Nelson, else the user will have to enter their Employee Number.

1. Make sure the Employee Expenses is the active workbook, select Tools → Macro, and then Macros from the menu, select the macro ExpenseFillIn and click Edit.

The Microsoft Visual Basic editor appears with the ExpenseFillIn macro code. Jeff Nelson is normally the only person that uses the Employee Expense workbook. To save time, you decide to add a conditional statement to the ExpenseFillIn macro, so if the EmployeeName is “Jeff Nelson” the macro will automatically enter Jeff’s Employee Number, otherwise if the EmployeeName is not “Jeff Nelson” the macro will prompt the user to enter their Employee Number.

2. Add a blank line immediately after the statement EmployeeName = InputBox(“Enter the Employee’s Name”), enter the statement If EmployeeName = "Jeff Nelson" THEN and press <Enter>.

This is the beginning of your IF…THEN…ELSE statement. If the EmployeeName equals “Jeff Nelson” THEN you want to set the EmployeeNo variable to equal Jeff’s employee number, 45177.
3. Press <Tab>, type EmployeeNo = 45177 and press <Enter>.
   You don’t have to add a <Tab> before the statement—it just makes it your code easier to read, and is a standard practice in programming. The next step in the IF…THEN…ELSE statement is adding the ELSE statement.

4. Type Else and press <Enter>.
   The next step is entering the ELSE statement—what to do if the EmployeeName does not equal “Jeff Nelson.” If the EmployeeName does not equal “Jeff Nelson,” you want Excel to display the InputBox to prompt the user for their Employee Number. You’ve already written this statement, so you can include it as the ELSE statement.

5. Place the insertion point at the beginning of the statement EmployeeNo = InputBox(“Enter the Employee Number”), press <Tab>, press <End> to move to the end of the line, and press <Enter>.
   Finish the IF…THEN…ELSE statement by adding the closing statement: End If.

6. Type End If.
   Compare your code with the code shown in Figure 8-17. You’re ready to save and test your new macro code.

7. Click the Save button on the Standard toolbar to save the macro, then close the Visual Basic Editor by clicking the close button or selecting File → Close from the menu.
   The Visual Basic editor closes and you return to the Excel program screen.

8. Select Tools → Macro, and then Macros from the menu, select the macro ExpenseFillIn and click Run.

9. Type Jeff Nelson in the InputBox and press <Enter>.
   The macro enters “Jeff Nelson” in cell A5 and his employee number “45177” in cell B5.

10. Select Tools → Macro, and then Macros from the menu, select the macro ExpenseFillIn and click Run.
    See what happens when you enter a name other than “Jeff Nelson.”

11. Enter your own name in the InputBox.
    Since the EmployeeName variable wasn’t “Jeff Nelson” another InputBox appears, asking for the employee number.

12. Type 55555, press <Enter>, save your work and exit Microsoft Excel.
    Give yourself a pat on the back if you’ve gotten this far. You’ve just finished what is arguably the most difficult task in Excel—working with code.
Chapter Eight Review

Lesson Summary

Recording a Macro

- **To Record a Macro**: Select **Tools** → **Macro** → **Record New Macro** from the menu. Enter a name, description, and shortcut keystroke (optional) for the macro. Click **OK** and carefully perform the actions you want to include in your macro. Click the ✗ **Stop button** on the Macro Record toolbar when you're finished recording your macro.

- When you record a macro, everything is recorded—including any mistakes you make. You should create a script that contains the steps you want the macro to record to minimize the amount of mistakes.

Playing a Macro and Assigning a Macro a Shortcut Key

- **To Play a Macro**: Select **Tools** → **Macro** → **Macros** from the menu, select the macro you want to play and click **Run**.

- **To Assign a Shortcut Key to a Macro**: Select **Tools** → **Macro** → **Macros** from the menu, select the macro you want to assign a shortcut keystroke to and click **Options**. Enter the keystroke in **Shortcut key box**.

- **To Delete a Macro**: Select **Tools** → **Macro** → **Macros** from the menu, select the macro you want to delete and click **Delete**.

Adding a Macro to a Toolbar

- **To Add a Macro to a Toolbar**: Select **View** → **Toolbars** → **Customize** from the menu and click the **Commands tab**. Select the **Macros** category from the **Categories list** and drag the **Custom button** to the desired toolbar. Right-click the custom button, select **Assign Macro** from the shortcut menu and select the macro you want to assign.

- **To Remove a Button from a Toolbar**: Select **View** → **Toolbars** → **Customize** from the menu, and drag the button off the toolbar.

Editing a Macro's Visual Basic Code

- **To Edit a Macro's Visual Basic Code**: Select **Tools** → **Macro** → **Macros** from the menu, select the macro and click **Edit**. When you've finished editing the macro's code click the **Save button** and then close the Visual Basic Editor window.

Inserting Code in an Existing Macro

- You can create macros that are more complex by copying sections of code from one macro to another macro.
Declaring Variables and Adding Remarks to VBA Code

- You must declare any variables using the DIM statement, which uses the syntax Dim VariableName As DataType.
- You can add a REM statement or comment to your code by typing an apostrophe before the comment.

Prompting for User Input

- The Input statement prompts the user for information. The syntax for the InputBox statement is InputBox(Prompt).

Using the If...Then...Else Statement

- The If...Then statement takes action based on one condition and another action based on another condition.
- The syntax for the IF...THEN statement is:
  
  ```vba
  If Condition Then
  Statement If True
  Else
  Statement If False
  End If
  ```

Quiz

1. Only menu and toolbar commands are recorded when you record a macro. (True or False?)

2. Which of the following statements is NOT true?
   A. Excel records macros in Visual Basic language.
   B. Macros names can be up to 25 characters long, including spaces.
   C. You start the macro recorder by selecting Tools → Macro → Record New Macro from the menu.
   D. You can assign a keystroke shortcut to a macro to make it quicker to access.

3. Which of the following statements declares a variable?
   A. REM HireDate as Date
   B. InputBox(HireDate) = Date
   C. Dim HireDate as Date
   D. Sub HireDate() = Date

4. Which of the following statements is NOT true?
   A. You can edit a macro’s Visual Basic source code by selecting Tools → Macro → Macros from the menu, selecting the macro and clicking the Edit button.
   B. You can edit, cut, copy, and paste Visual Basic code just like ordinary text.
   C. The InputBox function lets you add remarks to your code.
   D. IF…THEN…ELSE statement takes an action based on a certain condition.
5. **How can you play a macro?**
   A. Select **Tools → Macro → Macros** from the menu and select the macro.
   B. Select **Tools → Play Macro** from the menu and select the macro.
   C. Click the Play Macro button on the toolbar and select the macro.
   D. Take music lessons from a professional macro player to learn how to do this.

6. **You can assign a macro to which of the following? (Select all that apply.)**
   A. The Office Assistant, to punish it for appearing unexpectedly.
   B. A keystroke shortcut, such as `<Ctrl> + <D>`.
   C. A button on any toolbar.
   D. A button on the Status bar.

**Homework**

1. Create a new workbook book and save it as “My Macros.”
2. Select **Tools → Macro → Record New Macro** from the menu. In the Macro name box type “EnterAddress,” click the Store macro in arrow and select **This Workbook**, then click OK to start recording.
3. Type your name, address, and phone number in the following format:
<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Jeff Nelson</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>500 Pine Street, Suite 1001</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Minneapolis, MN 55431</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Tel: (612) 555-1234</td>
<td></td>
</tr>
</tbody>
</table>
4. Click the cell that contains your name and apply bold formatting.
5. Click the Stop button.
6. Clear the address information you just entered and try running your macro.
7. Edit the macro’s Visual Basic code so that it enters the “Nancy Gordon” instead of your name.
8. Assign the shortcut key `<Ctrl> + <E>` to the macro.

**Quiz Answers**

1. False. Everything is recorded—every menu you select, button you click, everything you type—even any mistakes you make!
2. B. Macros can’t have spaces in them.
3. C. The Dim statement declares a variable, so the statement “Dim HireDate as Date” would declare the “HireDate” variable as a date data type variable.
4. C. The InputBox allows you to accept input from a user.
5. A. You can play a macro by selecting **Tools → Macro → Macros** from the menu and selecting the macro.
6. B and C. You can assign a macro to either a keystroke shortcut or to a button on any toolbar.
Chapter Nine: Working with Other Programs

Chapter Objectives:

- Insert an Excel worksheet into a Word document
- Modify an embedded worksheet
- Link an Excel chart into a Word document
- Insert a graphic into a worksheet
- Open and save files in different formats

Chapter Task: Insert information between different programs

One of the great benefits of working with Windows is that you can share information between different programs. This chapter explains how you can use Excel with other programs. You’ll learn how to insert a Excel worksheet and chart into a Microsoft Word document. You’ll also learn the subtle differences between embedding and linking files into other programs. This chapter also explains how to open and save different file formats, such as Lotus 1-2-3 or text files, in Excel.

Finally, this chapter explores how you can publish your Excel worksheets to the Internet. Whew! We have a lot of ground to cover. Turn the page and we’ll get started.
Lesson 9-1: Inserting an Excel Worksheet into a Word Document

Microsoft Word is a powerful word processing program that can create professional-looking documents. Since Word is part of the Microsoft Office 97 Suite, it makes sense that more people use Excel together with Word than any other program. In this lesson, you will learn how to embed an Excel worksheet into a Word document.

1. Start the Microsoft Word program.
2. Open the document named Interoffice Memo.
   The procedure for opening a file in Word is identical to opening a file in Excel. Click the Open button on the Standard toolbar or select File → Open from the menu. The Interoffice Memo document appears in Word’s main document window.
3. Move the insertion point (↓) to the end of the document by pressing the down arrow key ↓, or else clicking to the end of the document with the mouse.
   This is where you want to insert an Excel worksheet.
4. **Select Insert → Object from the menu.**

The Object dialog box appears with the Create New tab in front, as shown in Figure 9-1. You can create and insert new objects with the Create New tab, or you can insert an existing file with the Create from File tab. You have already created and saved a worksheet in Excel, so you need to insert the worksheet from an existing file.

5. **Click the Create from File tab.**

The Create from File tab appears in front, as shown in Figure 9-2. You need to specify the name and location of the file you want to insert into the document.

6. **Click the Browse button.**

The Browse dialog box appears, allowing you to find and locate the file you want to insert into your document.

7. **Navigate to your practice folder or disk and select the Expenses file.**

Notice the icon for the Expenses file indicates that it is a Microsoft Excel file.

8. **Click OK.**

The Browse dialog box closes and you return to the Create from File tab of the Object dialog box. Notice the Expenses file name and location appear in the File name box. There are several other options on this page you should know about:

- **Link to file:** Inserted objects are normally **embedded**, or saved inside the documents they are inserted in. If you check the Link to file option the object will still be inserted in the document, but Word will only create a link to the original file instead of saving a copy of it inside the document. You should use the Link to file when you want to ensure that any changes made in the original file are updated and reflected in the document it is inserted in.

- **Display as icon:** Inserted objects are normally viewable directly from the Word document window. Checking the Display as icon box option causes the inserted objects to appear only as an icon. You must double-click the object in order to view it.

9. **Click OK.**

Word accesses the Excel file and then inserts it into the document at the insertion point.

10. **Compare your document with the one in Figure 9-3.**

11. **Save the changes you’ve made to the Word document by clicking the Save button on the Standard toolbar.**

---

**Quick Reference**

**To Insert an Embedded Excel Worksheet into a Word Document:**

1. Place the insertion point where you want the worksheet to be inserted.
2. Select **Insert → Object** from the menu.
3. Click the Create from File tab to use an existing worksheet file or click the Create New tab to create a new worksheet.
4. Specify the Excel worksheet file you want to insert (if you selected Create from File) or else create the worksheet from scratch (if you selected Create New).
Lesson 9-2: Modifying an Inserted Excel Worksheet

After you insert an Excel worksheet, you can make changes to the worksheet simply by double-clicking it. Double-clicking any embedded or linked object opens the source program the object was created in, or, in the case of this lesson, Microsoft Excel. If the program the object was created with isn’t installed on your computer you can still view and print the object but you can’t make changes to it.

1. Double-click the inserted worksheet object in the document.
   The Excel program opens inside of the Word document, as shown in Figure 9-4. Notice that Excel menus and toolbars replace the Word toolbars and menus. Now you can make changes to the worksheet object.

2. Select cell B5.
   With the cell selected, you can replace the cell’s data simply by typing.

3. Type 515 and press <Tab>.
   The number 515 replaces the number 500 and Excel moves to the next cell.

4. Select the entire Detroit row by clicking the row 6 heading.
   The entire row is selected.

Figure 9-4
Modifying an Excel Worksheet object.

Figure 9-5
The modified worksheet.

Double-click an object to edit or modify it.

<table>
<thead>
<tr>
<th>Show</th>
<th>Booth</th>
<th>Brochures</th>
<th>Per Diem</th>
<th>Misc.</th>
<th>Totals</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chicago</td>
<td>515</td>
<td>175</td>
<td>130</td>
<td>26</td>
<td>848</td>
</tr>
<tr>
<td>Milwaukee</td>
<td>470</td>
<td>135</td>
<td>110</td>
<td>25</td>
<td>710</td>
</tr>
<tr>
<td>Detroit</td>
<td>850</td>
<td>160</td>
<td>115</td>
<td>0</td>
<td>925</td>
</tr>
<tr>
<td>Minneapolis</td>
<td>450</td>
<td>120</td>
<td>45</td>
<td>54</td>
<td>669</td>
</tr>
<tr>
<td>Totals</td>
<td>2085</td>
<td>990</td>
<td>400</td>
<td>107</td>
<td>3182</td>
</tr>
</tbody>
</table>

Figure 9-5
Trade Show Expenses
5. Select **Insert → Rows** from the menu.
   A new row is inserted immediately above the Detroit row. Now enter the data for the new row.

6. Click cell **A6**, type **Milwaukee** and press **<Tab>** to move to the next cell.

7. Type the following, pressing **<Tab>** after making each entry.
   470 135 110 25
   Now that you have entered the data you must calculate the total for the row.

8. **Click** the **AutoSum button** on the **Standard toolbar**.
   Excel makes an educated guess what cells you want to calculate the total for and selects them—in your case, Excel guesses correctly.

9. **Press** **<Enter>** to accept the formula.
   Excel calculates the row total and moves to the next cell. Notice that after you inserted a new row, the bottom total row is no longer displayed. Here’s how to resize the Excel worksheet object so that the entire worksheet is displayed.

10. **Position** the pointer over the **lower-right sizing handle**, until the pointer changes to a **“+”**, then **click and hold** the left mouse button and **drag the mouse down** until you can see the bottom row of the worksheet, then **release** the mouse button.
   The entire worksheet object should be visible in the document window.

11. **Click** anywhere outside the worksheet object to stop modifying the worksheet to and return to Word.
    The standard Word menu and toolbars replace the Excel menu and toolbars. Compare your document to the one in Figure 9-5.

12. **Save** your work.

It can be confusing knowing what the differences are between linked and embedded objects. **Table 9-1: Embedded vs. Linked Objects** compares each of these methods for inserting information created with other programs into Word documents.

| **Table 9-1: Embedded vs. Linked Objects** |
| **Heading** | **Heading** |
| Embedded | An embedded object is actually saved within the file. Files with embedded objects are larger than files with linked objects. The advantage of using embedded objects is because the objects are actually saved inside the file, so you don’t have to worry about any attached files becoming erased or lost. |
| Linked | A linked object is not saved in the file. Instead a link contains information on where to find the source data file. The advantage of using linked objects is the source file is changed, the linked object in the file is automatically updated to reflect the changes. |
Lesson 9-3: Inserting a Linked Excel Chart in a Word Document

So far you have been inserting and working with an embedded Excel worksheet. This lesson mixes things up a bit. You will still be inserting information created in Excel, but in this lesson you will be inserting a linked Excel chart. Remember when you insert an embedded object you are actually storing and saving the object inside the file. A linked file is not stored and saved in a Word document, but is connected to it. So if you make changes to the linked source file it will be automatically updated in the Word document.

1. **Press <Ctrl> + <End> to move to the end of the document.**
   Just like in Excel, <Ctrl> + <End> moves you to the end of a document in Word.

2. **Press <Enter> twice to add 2 blank lines.**
   Now insert the linked chart object.

3. **Select Insert → Object from the menu and click the Create from File tab if it does not appear in front.**
   The Create from File tab appears in front, as shown in Figure 9-6. You need to specify the name and location of the file you want to insert into your document.

4. **Click the Browse button.**
   The Browse dialog box appears, allowing you to find and locate the file you want to insert into your document.

5. **Navigate to your Practice folder or disk and select the Trade Show Chart file.**
   Notice the icon for the Trade Show Chart file indicates that it is a Microsoft Excel file.

6. **Click OK.**
   The Browse dialog box closes and you return to the Create from File tab of the Object dialog box. Notice the “Trade Show Chart” file name and location now appears in the File name text box.
7. **Click the Link to file checkbox.**
   Checking the Link to file checkbox only inserts a link to the specified file in the Word document instead of inserting an embedded copy of the file. You should use Link to file if you want to display any changes made to the original file in your document.

8. **Click OK.**
   Word accesses the Excel chart and then inserts a link to it in the document at the insertion point.

9. **Resize the Chart object so it is similar in size to the one shown in Figure 9-7.**

10. **Save your work.**

11. **Select File → Exit** from the menu to close the Microsoft Word program.
Lesson 9-4: Inserting a Graphic into a Worksheet

1. Start Microsoft Excel, open the Expense workbook and save it as Trade Show Expenses.

2. Click cell A1. This is where you want to insert the graphic.

Pictures, graphics, and illustrations can make your worksheets more professional looking. This lesson explains how to insert clip art and graphics into your worksheets. You can insert graphics and pictures created with graphics programs such as Microsoft Paint (which comes with Windows), scanned pictures, or graphics from a clip art library.
3. Select Insert → Picture → From File from the menu.

The Insert Picture dialog box appears, as shown in Figure 9-8. You need to specify the name and location of the graphic file to be inserted into your Excel worksheet.

4. Navigate to your Practice folder or disk and select the PC Logo file.

Excel displays a preview of the graphic in the left side panel of the Insert Picture dialog box.

5. Click the Insert button to insert the PC Logo graphic.

Excel inserts the picture file PC Logo in the worksheet.

6. Select the picture (if necessary) of the PC Logo by clicking it.

See the six boxes along the edges of the picture? Those are sizing handles and are used to resize or crop objects. Go ahead and resize the picture.

7. Position the pointer over the lower-right sizing handle, until the pointer changes to a †, then click and hold the left mouse button and drag the mouse diagonally down and to the right until the bottom of the picture is flush with the bottom of row 4, then release the mouse button.

8. With the picture still selected, click and hold the left mouse button and drag the picture to the right side of the page, as shown in Figure 9-9. Release the left mouse button to drop the picture.

9. Save your work and close the Trade Show Expenses workbook.

You probably noticed several other options listed under the Insert → Picture menu. Here’s what they are what they do:

<table>
<thead>
<tr>
<th>Insert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clip Art</td>
<td>Opens the Clip Gallery where you can select a clip art image to insert.</td>
</tr>
<tr>
<td>From File</td>
<td>Inserts a graphic file in the active cell.</td>
</tr>
<tr>
<td>AutoShapes</td>
<td>Inserts a ready-made shape, such as a circle, rectangle, star, arrow, etc.</td>
</tr>
<tr>
<td>Organization Chart</td>
<td>Inserts a Microsoft Organization Chart object into worksheet.</td>
</tr>
<tr>
<td>WordArt</td>
<td>Creates spectacular text effects, such as WordArt.</td>
</tr>
<tr>
<td>From Scanner</td>
<td>Scans an image and inserts it at the insertion point.</td>
</tr>
</tbody>
</table>

Quick Reference

To Insert a Graphic:
1. Click the cell where you want to insert the graphic and Select Insert → Picture → From File from the menu.
2. Select the file location and name and click OK.

To Resize an Graphic:
- Click the object to select it, then drag its sizing handles until the object is the size you want.

To Move a Graphic:
- Click the picture and hold mouse button, drag the picture to a new location in the document then release the mouse button.
Lesson 9-5: Opening and Saving Files in Different Formats

People from different countries speak different languages, so naturally computer programs save files in different formats that other programs sometimes can’t read. Fortunately, just like some people can speak several languages, Excel can read and write in other file formats.

This lesson shows how you can open one of the most common file formats in Excel—a tab delimited text file.

1. **Click the Open button** on the Standard toolbar and navigate to your Practice folder or disk and select
   Normally the Open dialog box only displays files created with Microsoft Excel. To open files created with other programs you need to select the file type you want from the Files of type list arrow—in your case Text files.

2. **Click the Files of type list arrow**, select Text Files, select the Europe Expenses file and click Open.
   The Text Import Wizard dialog box appears, as shown in Figure 9-11. You must specify how the information is stored in the text file. There are two options:
• **Delimited:** Tabs, colons, semicolons, or other characters separate items in your text file. This is the most common (and default) option.

• **Fixed Width:** All the items in your text file are the same length.

The Europe Expenses is a *tab delimited* text file, that is, tabs separate its fields, so you don’t need to make any changes and can continue on to the next step.

3. **Click Next.**

The second step of the Text Import Wizard appears. Notice the tab box is selected under Delimiters (what separates the text). No changes needed here.

4. **Click Next.**

The third step of the Text Import Wizard allows specifying formatting options for any of the columns of data. For example, you could specify that a particular column be formatted as a data or number field. It isn’t important to format any of the columns here, however, so you can complete the Text Import Wizard.

5. **Click Finish.**

The Text Import Wizard closes and the imported text file appears in the Excel worksheet window.

Here’s how to save a workbook in a different format:

6. **Select File → Save As from the menu.**

The Save As dialog box appears.

7. **Click the Save as type list arrow, scroll down the list and select WKS (1-2-3).**

This will save the file in Lotus 1-2-3 format.

8. **Click Save to save the Europe Expenses workbook as a Lotus 1-2-3 file, then close it (but leave Microsoft Excel open!)**

### Table 9-3: Importable and Exportable File Formats and Extensions

<table>
<thead>
<tr>
<th>File Format</th>
<th>Extensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Excel 97/2000/2002</td>
<td>.xls, .xlt</td>
</tr>
<tr>
<td>Microsoft Excel 5.0/95</td>
<td>.xls, .xlt</td>
</tr>
<tr>
<td>Microsoft Excel 4.0, 3.0, 2.0</td>
<td>.xls, xlw, wlc, xlm</td>
</tr>
<tr>
<td>Lotus 1-2-3</td>
<td>.wk4, wk3, fm3, fmt, all, wk1, wks</td>
</tr>
<tr>
<td>Quattro Pro</td>
<td>.wb1, .wbi</td>
</tr>
<tr>
<td>Text (Both tab and comma delimited)</td>
<td>.txt, .csv</td>
</tr>
<tr>
<td>Dbase 2, 3, 4</td>
<td>.dbf</td>
</tr>
<tr>
<td>Microsoft Access 2.0, 95, 97</td>
<td>.mdb</td>
</tr>
</tbody>
</table>
Chapter Nine Review

Lesson Summary

Inserting an Excel Worksheet into a Word Document

- To Insert an Embedded Excel Worksheet into a Word Document: Place the insertion point where you want the worksheet to be inserted and select Insert → Object from the menu. Click the Create from File tab to use an existing worksheet file or click the Create New tab to create a new worksheet. Select the worksheet you want to insert (if you selected Create from File) or else create the worksheet from scratch (if you selected Create New).

Modifying an Inserted Excel Worksheet

- Double-click any embedded or linked object to edit it. Click anywhere outside the object when you're finished.
- An embedded object is saved within the file. Files with embedded objects are larger than files with linked objects. The advantage of using embedded objects is because the objects are actually saved inside the file, so you don't have to worry about any attached files becoming erased or lost.
- A linked object is not saved in the file. Instead a link contains information on where to find the source data file. The advantage of using linked objects is if the source file is changed, the linked object in the file is automatically updated to reflect the changes.

Inserting a Linked Excel Chart in a Word Document

- To Insert a Linked Object File: Place the insertion point where you want the worksheet to be inserted and select Insert → Object from the menu and click the Create from File tab. Make sure the Link to File check box is selected and specify the file you want to insert.

Inserting a Graphic into a Worksheet

- To Insert a Graphic: Click the cell where you want to insert the graphic and Select Insert → Picture → From File from the menu. Select the file location and name and click OK.
- Resize an object by dragging its sizing handles until the object is the size you want.
- Move an object by clicking and dragging it to a new location and releasing the mouse button.

Opening and Saving Files in Different Formats

- To Open a Non-Excel File in Excel: Click the Open button on the Standard toolbar, select Click select All Files from the Files of type list. Find and open the file.
- To Save a File in a Different File Format: Select File → Save As from the menu and select the file format from the Save as type list.
Quiz

1. **What is the difference between an embedded and linked object?**
   A. An embedded object is saved within the file, a linked object is a hyperlink to another file.
   B. An embedded object is saved within the file, a linked object is not saved in the file—instead a connection to the file is inserted.
   C. An embedded object can be inserted on the same page as other text or information, a linked file must be placed on its own separate page.
   D. An embedded object is saved in a separate file, a linked object is saved with the file it was inserted in to.

2. **Double-click an embedded or linked object to modify it. (True or False?)**

3. **Which of the following statements is NOT true?**
   A. When you insert an object, you can either insert an existing file or you can create a new file.
   B. Clicking the Link to file check box inserts a link to the file instead of embedding the file.
   C. You can only insert graphics or pictures into Excel charts.
   D. You insert graphics by selecting Insert → Picture → From File from the menu.

Homework

1. Open the workbook Lesson 2 and save it as a .CSV (Comma Delimited) text file named “Mileage.”
2. Create a new workbook, select Insert → Picture → ClipArt form the menu, and insert a picture of a turtle into the workbook.
3. Resize the turtle picture so that it is about 50% of the original size, then move it down about an inch.
4. Open the Lesson 5A workbook and save it as “Web Practice.”
5. Click cell A10 type “Expenses” and press <Enter>. Click cell A10, click the Insert Hyperlink button on the Standard toolbar and create a hyperlink to the Expenses workbook.
6. Exit Microsoft Excel and start Microsoft Word. Type “Here are the results of last month’s survey:” and press <Enter>.
7. Insert the Lesson 5A workbook into the Word document at the insertion point.

Quiz Answers

1. B. An embedded object is saved within a file. A linked object is not actually saved within a file but points to the inserted file.
2. True. Double-clicking an object lets you modify it.
3. C. You can insert graphics or pictures into worksheet as well as into charts.
Chapter Ten: Using Excel with the Internet

Chapter Objectives:

- Add Hyperlinks to a Worksheet
- Browse Hyperlinks and using the Web Toolbar
- Save a Workbook as Non-Interactive a Web Page
- Save a Workbook as an Interactive Web Page
- Retrieve Information from a Web Page

Chapter Task: Publish an Excel worksheet to the Web

In a mere five years, the Internet has changed how most businesses and computers work, so it’s no surprise that the biggest changes and improvements in Excel 2002 have to do with how it works and interacts with the Internet.

Excel’s Internet features let you add hyperlinks to your workbooks to link them to another workbook, a file created in another program, or even a Web page. You can also save your worksheets and charts as a Web page and place them on your corporate Intranet or the World Wide Web so that other users can view them. You can also create interactive Web pages that allow users to add, change, and calculate you worksheet’s information from Microsoft Internet Explorer 4.01 or later. Finally, you can retrieve information stored on a Web page and place it on your worksheets.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- Basic familiarity with the Internet and the World Wide Web.
Lesson 10-1: Adding and Working with Hyperlinks

In this lesson, you will learn how to use hyperlinks in Excel. A hyperlink points to a file, a specific location in a file, or a Web page on the Internet or on an Intranet. Whenever you click on a hyperlink, you jump to the hyperlink’s destination (if it’s available). A hyperlink is usually indicated by colored and underlined text. If you have ever been on the World Wide Web you’ve used hyperlinks all the time to move between different Web pages.

1. **Open the workbook named Lesson 10 and save it as Trade Show Expenses.**
   
   You may need to click the Files of Type list and select Microsoft Excel Files if you can’t find it.

2. **Click cell A10, type Mileage Report and press <Enter>**.
   
   This is the text for the hyperlink. The next step is to create the destination for the hyperlink. A hyperlink’s destination can be any file on your computer, on the network, or even on the Internet.

3. **Click cell A10 and click the Insert Hyperlink button on the Standard toolbar.**
   
   The Insert Hyperlink dialog box appears, as shown in Figure 10-1. Here, you can specify a Web address or name and location of a file you want to add as a hyperlink. If you know the location and name of the file or Web address, you can type it directly in the dialog box; otherwise, you can navigate to the file. There are three different buttons in the Insert Hyperlink dialog box that let you browse for four different types of Hyperlink destinations. These buttons are:

   - **Existing File or Web Page**: Create a link that takes you to another Excel workbook or to a file created in another program, such as a Microsoft Excel worksheet, or to a web page on the Internet.
   - **Place in This Document**: Take you to a bookmark in the same document.
   - **Create New Document**: Creates a new Microsoft Excel workbook and then inserts a hyperlink to it.
   - **E-mail Address**: Creates a clickable e-mail address.
4. **Click the Existing File or Web Page.**
   The Link to File dialog box appears, which displays a list of files that you can use as the destination for your hyperlink.

5. **Select the Lesson 2A workbook file and click OK.**
   The Link to File dialog box closes and the name and location of the Lesson 2 is added to the Link to file or URL text box.

6. **Click OK.**
   The dialog box closes and you return to the worksheet window. Notice the text “Mileage Report” appears blue and underlined, signifying it’s a hyperlink. For now, *don’t click the Mileage Report Hyperlink!* We’ll cover that in the next lesson.
   Once you create a hyperlink, you can easily edit it to change its title or target, copy it, or delete it by clicking by right-clicking the hyperlink. Try it!

7. **Right-click the hyperlink and select Hyperlink from the shortcut menu.**
   A shortcut menu with the most frequently used hyperlink commands appears. Here, you could select Edit Hyperlink to change the hyperlink’s target or Select Hyperlink to edit the hyperlink’s title. Your hyperlink is fine the way it is so close the shortcut menu.

8. **Click anywhere in the worksheet window to close the shortcut menu.**

9. **Save your work.**

In the next lesson, you will get a chance to actually use the hyperlink you just created, and see how you can browse Excel’s files using the Web toolbar.

---

**Quick Reference**

**To Insert a Hyperlink:**

1. Select the cell you want to use for the hyperlink and click the Insert Hyperlink button from the Standard toolbar.

   Or...
   
   Select the text you want to use for the hyperlink and select Insert → Hyperlink from the menu.

2. Either select a file you want (use the browse buttons to help you locate the file) or type a Web address for the hyperlink’s destination and click OK.

**To Edit a Hyperlink:**

- Right-click the hyperlink and select Hyperlink → Edit Hyperlink from the shortcut menu.
Lesson 10-2: Browsing Hyperlinks and using the Web Toolbar

If an Excel workbook contains one or more hyperlinks, you can navigate, or browse between the files connected by the hyperlinks. In this lesson you will test the hyperlinks you created earlier to make sure they work. Chances are this browsing between two files will be nothing new to you—because browsing hyperlinks in Microsoft Excel is no different than browsing the Web.

1. **Click the hyperlink Mileage Report in cell A10.**

   Two things happen whenever you click a hyperlink in Excel: First, you immediately jump to the hyperlink’s destination—in this case the Mileage Report workbook. Second, Excel displays the Web toolbar (if it isn’t there already) so you can easily navigate between your files just like you would if you were surfing the ‘net.

   Move on to the next step, and we’ll create a hyperlink to the back to the first workbook, Trade Show Expenses, so that the user can easily return to it.

2. **Click cell A14, type Return to Trade Show Expenses and press <Enter>.**

   This text will contain the hyperlink to the workbook “Trade Show Expenses.”

3. **Click cell A14 and click the Insert Hyperlink button on the Standard toolbar.**

   The Insert Hyperlink dialog box appears.

4. **Click the Browse button next to the Link to file or URL text box.**

5. **Click the Files of type list arrow and select Workbooks (.xls) from the list to display only Excel workbooks in the window.**

   The Link to File dialog box is updated so that it displays only Excel workbook files.
6. Select the **Trade Show Expenses** workbook file and click OK.
The Link to File dialog box closes and the name and location of the Trade Show Expenses is added to the Link to file or URL text box.

7. Click OK.
The dialog box closes and you return to the worksheet window. Test the new hyperlink by clicking it.

8. Click the hyperlink **Return to Trade Show Expenses** in cell A14.
The Trade Show Expenses workbook appears in the worksheet window. Use the Web toolbar to jump back to the previously viewed document.

9. Click the **Back button** on the Web toolbar.
You’re back to the Lesson 2 workbook. Now jump forward to the Trade Show Expenses workbook.

10. Click the **Forward button** on the Web toolbar.
The Trade Show Expenses workbook appears in the worksheet window. Excel can browse and navigate Web pages on the Internet just as easily as it can browse workbooks. In the next lesson, you’ll learn how to save an Excel workbook as a Web page, so it can be viewed on the Internet.
You don’t need the Web toolbar anymore, so go ahead and close it.

11. Right-click the **Web toolbar** and select **Web** to close the Web toolbar.

---

<table>
<thead>
<tr>
<th><strong>Table 10-4: The Web toolbar buttons</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td>← Back</td>
</tr>
<tr>
<td>→ Forward</td>
</tr>
<tr>
<td>✗ Stop Current Jump</td>
</tr>
<tr>
<td>🔍 Refresh Current Page</td>
</tr>
<tr>
<td>🏛 Start Page</td>
</tr>
<tr>
<td>🌐 Search the Web</td>
</tr>
<tr>
<td>Favorites</td>
</tr>
<tr>
<td>Go</td>
</tr>
<tr>
<td>Shown Only Web Toolbar</td>
</tr>
</tbody>
</table>

---

***Quick Reference***

**To Jump to a Hyperlink's Destination:**
- Click the Hyperlink.

**To Browse Files with Excel:**
- Use the Web toolbar (see Table 10-4: The Web toolbar buttons) to navigate between files just like you would browse the Internet.

**To Hide the Web Toolbar:**
- Right-click the Web toolbar and select **Web**. Or...
- Select **View** → **Toolbars** → **Web** from the menu.
Lesson 10-3: Saving a Workbook as a Non-Interactive Web Page

This lesson explains how you can save your Excel worksheets as Web pages so they can be viewed on the Internet. You can save any existing Excel worksheets as Web pages files (also know as HTML files) by selecting the File → Save as Web Page from the menu.

Saving Excel workbooks as Web pages isn’t anything new—Excel 97 had this feature as well. What is new is Excel 2002 can save workbooks as Interactive Web pages. What this means is users interact with the data on your Web page because they have basic spreadsheet functionality. Interactive Web Pages let your users enter data, format data, calculate data, and sort and filter. There is one major drawback to Interactive Web pages—only users who have Microsoft’s Internet Explorer 4.01 or later Web browsing software (surprise!) can use Office 2002’s Interactive Web pages, so any Netscape Navigator users are left in the dark. If your Web audience includes Netscape Navigator users, you can still save your workbooks as static non-interactive Web pages. Table 10-5: Interactive vs. Non-Interactive Web Pages explains some of the differences between the two.

This lesson explains how to save a non-interactive Web page.
1. Make sure Trade Show Expenses is the active workbook, then select **File → Save as Web Page** from the menu.

   The Save As dialog box appears, as shown in Figure 10-4. You can save an Excel workbook as several different types of Web pages:

   - **Entire Workbook (Non-Interactive):** Saves everything in the workbook—all your worksheets and charts—as non-interactive web pages. To save the entire workbook, check the Entire Workbook check box.
   - **Sheet or Selection (Interactive or Non-Interactive):** Saves a worksheet or selected cell range. To save a sheet or selection, click the Publish button and specify the area of the workbook you want to save. You can add interactivity by checking the Add Interactivity with box and selecting Spreadsheet functionality from the drop down list.
   - **PivotTable (Interactive):** Saves a worksheet or selected cell range as an Interactive PivotTable on the Web, which users can use to pivot, filter, and sort data. To save a sheet or selection as a PivotTable, click the Publish button, specify the area of the workbook you want to save, check the Add Interactivity with box and select PivotTable functionality from the drop-down list.

2. **Click the Publish button.**

   The Publish as Web Page dialog box appears, as shown in Figure 10-5. Here you have to specify which areas of your workbook you want to save and how to save them.

3. **Select Items on Sheet1 from the Choose list, then select Sheet All Contents of Sheet1 from the box under the Choose list.**

4. **Type Trade Web in the File name box add a check to the Open published web page in browser box and click the Publish button.**

   Of course, you can also click the Browse button and Navigate to the drive and folder where you want to save your Web page. Excel saves Sheet1 of the Trade Show Expenses workbook as a non-interactive Web page and then opens the Web page in your computer’s Web browser. Since the Web page isn’t interactive, you can only view its information. We’ll create an interactive Web page in the next lesson.

---

**Table 10-5: Interactive vs. Non-Interactive Web Pages**

<table>
<thead>
<tr>
<th>Web Page Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Interactive Web Pages</strong></td>
<td>Interactive Web pages let users interact with the data on your Web page because they include basic spreadsheet functionality. Interactive Web Pages let your users enter data, format data, calculate data, and sort and filter. Interactive Web Pages require Microsoft Internet Explorer 4.01 or greater so not everyone can use them.</td>
</tr>
<tr>
<td><strong>Non-Interactive Web Pages</strong></td>
<td>Non-interactive Web pages allow users to view worksheet data but not interact with it. Users can view non-interactive Web pages in any Web browser, unlike when they view interactive pages, which requires Microsoft Internet Explorer version 4.01 or later.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Save a Workbook as a Non-Interactive Web Page:

1. Open the workbook and select **File → Save as Web Page** from the menu.
2. Click **Publish**.
3. Specify what you want to publish on your Web page from the **Choose list** and type a name for your Web page file in the **File name box**.
4. Click **Publish**.
Lesson 10-4: Saving a Workbook as an Interactive Web Page

In the previous lesson you learned how to save a workbook as a non-interactive Web page. Non-interactive Web pages are great if you only want to present information and/or if you don’t know which Web browser your audience has. If you’re publishing to a corporate Intranet and/or you know your audience uses Microsoft Internet Explorer 4.01 or later you can save your workbooks as interactive Web pages, which allow users to add, change, sort, filter, and calculate the data presented on a Web page.

1. Make sure Trade Show Expenses is the active workbook, then select **File → Save as Web Page** from the menu.

   The Save As dialog box appears.

2. Click the **Publish** button.

   The Publish as Web Page dialog box appears, as shown in Figure 10-8. First you have to specify which areas of the workbook you want to publish.
Chapter Ten: Using Excel with the Internet

3. Select **Items on Sheet1** from the **Choose list**, then select **Sheet All Contents of Sheet1** from the box under the **Choose list**.

   Next you have to tell Excel that you want to save the Web page with interactivity. When you save a worksheet as a Web page you can add interactivity with:

   - **Spreadsheet functionality**: Enables users to enter, change, and calculate data like they using an Excel worksheet.
   - **PivotTable functionality**: Enables users to pivot, filter, sort, and analyze data like they would using an Excel PivotTable report (see the chapter on Data Analysis and PivotTables if you’re a little unclear about what a PivotTable report is.)

4. Add a check to the **Add Interactivity with** box and verify **Spreadsheet functionality** appears in the drop-down list to the right.

   You can also create or change the title that appears at the top of your Web page—whether or your Web page in interactive or not.

5. **Click the Change button.**

   The Set Title dialog box appears.

6. **Type Trade Show Expenses** in the **Title box** and click **OK**.

   Lastly you have to specify a file name for your Web page and where you want to save it.

7. **Type Interactive Web** in the **File name box** add a check to the **Open published web page in browser** box and click the **Publish** button.

   Excel saves Sheet1 of the Trade Show Expenses workbook as an interactive Web page and opens the Web page in Microsoft Internet Explorer, as shown in Figure 10-7. Let’s test the interactive Web page.

8. **Click cell B5 type 400 and press <Enter>.**

   Wow! The Web page let’s you change the worksheet’s number and recalculates it, just like Microsoft Excel! By no means do Interactive Web pages have all of Excel’s bells and whistle features, but they have enough functionality for you to perform basic calculations. Notice the Web page even has an Excel toolbar, which contains buttons for the basic worksheet functions, such as cut, copy, paste, AutoSum, and sort.

9. **Place the cell pointer anywhere in the A column and click the Sort Ascending button on the toolbar.**

   Excel sorts the information in the Web page alphabetically by ascending order by the contents of the A column.

10. **Close Microsoft Internet Explorer and close all open workbooks in Excel.**


---

**Quick Reference**

To Save a Workbook as an Interactive Web Page:

1. Open the workbook and select **File → Save as Web Page** from the menu.
2. Click **Publish**.
3. Specify what you want to publish on your Web page from the **Choose list** and type a name for your Web page file in the **File name** box.
4. Check the **Add Interactivity with** box.
5. Click **Publish**.
Lesson 10-5: Using Queries to Retrieve Information from the Web

This lesson explains how to use a Web query to get information from a Web on the Internet. More and more companies are putting information on the Web, so it makes sense that Microsoft Excel 2002 has a feature that allows you to retrieve data from a Web page on your company’s intranet or from the World Wide Web. To get data from a Web page, you must have Internet access either through your Intranet or through a modem and an account with an Internet service provider.

1. Create a new workbook.

2. Select Data ➔ Get External Data ➔ New Web Query from the menu.

The New Web Query dialog box appears, as shown in Figure 10-10. There are a couple different ways to get to the Web page that contains the information you want. You can:

- Type the address of the Web page in the text box
- Click the Browse Web button, Navigate to the Web page in your Web Browser, and then return to Microsoft Excel
We’ll be using the first method for our exercise.

3. **Make sure your Practice Disk is inserted in the A: drive and type Office Expenses.htm in the text box.**

   This will retrieve information from the Office Expenses Web pages saved on your Practice Disk. You also need to specify which part of the Web page to extract information from.

4. **Select the Only the tables option.**

   This will return information only from any tables that appear in a Web page. Since Web pages frequently use tables to format and align their information, the Web query may still return some extraneous information that can clean up later. If you will need to retrieve or query the Web page again in the future you can save the Web query by clicking the Save Query button. You’re ready to query the Office Expenses Web page.

5. **Click OK.**

   Excel asks where you want to put the queried information. You can place the data in a location on any existing worksheet or you can place the data on a new worksheet.

6. **Click OK to place the queried data in cell A1 of the current worksheet.**

   Excel retrieves the data from the Office Expenses Web page and puts it in cell A1 of the current worksheet, as shown in Figure 10-12. The External Data toolbar also appears, which you can later use to refresh the data to make sure you have the most recent numbers.

   Excel 2002 also comes with several useful saved Web queries you can use—here’s how to use a saved query. First we have to leave our current query.

7. **Click the Sheet2 tab to go to that sheet.**

   You’re ready to run a saved query.

8. **Select Data → Get External Data → Run Saved Query from the menu.**

    The Run Query dialog box appears with a list of saved queries that you can use to retrieve information about the markets. To use one of these predefined queries just select it and click the Get Data button.

9. **Click Cancel to close the Run Query dialog box.**

    You’ve covered most of Excel’s Internet features, so you can exit the Excel program.

10. **Exit Microsoft Excel without saving any of your work.**

    Well done! You’ve finished another chapter and have learned a new set of skills. Move on to the Chapter review and let’s see how much you’re retained.

---

**Quick Reference**

**To Run a Web Query:**

1. Select Data → Get External Data → Run Saved Query from the menu.
2. Select the query you want to run and click Get Data.
3. Specify where in the workbook you want to insert the results of the query and click OK.

**To Create a Web Query:**

1. Select Data → Get External Data → New Web Query from the menu.
2. Click the Browse button and browse to the Web page that contains the data you want to query (or type the URL of the Web page if you know it.)
3. Select the part of the Web page you want to query (usually only the tables) and click OK.
4. Specify where in the workbook you want to insert the results of the query and click OK.
Chapter Ten Review

Lesson Summary

Adding Hyperlinks to a Worksheet

- A hyperlink is a link that points to a file, a specific location in a file, or a Web page on the Internet or on an intranet.

- **To Insert a Hyperlink:** Select the cell you want to use for the hyperlink and click the Insert Hyperlink button from the Standard toolbar or select Insert → Hyperlink from the menu. Either select a file you want (use the browse button to help you locate the file) or type else type a Web address for the hyperlink's destination and click OK.

- **To Edit a Hyperlink:** Right-click the hyperlink and select Hyperlink → Edit Hyperlink from the shortcut menu.

Browsing Hyperlinks and using the Web Toolbar

- Click a hyperlink to jump to its destination (the file or Website it's linked to.) The Web toolbar will appear whenever you click a hyperlink in Excel.

- **To Browse Files with Excel:** Use the Web toolbar to navigate between files just like you would browse the Internet.

- **To Hide the Web Toolbar:** Right-click the Web toolbar and select Web or select View → Toolbars → Web from the menu.

Saving a Workbook as a Non-Interactive Web Page

- **Non-interactive Web pages** allow users to view worksheet data but not interact with it. Users can view non-interactive Web pages in any Web browser, unlike when they view interactive pages, which requires Microsoft Internet Explorer version 4.01 or later.

- **To Save a Workbook as a Non-Interactive Web Page:** Open the workbook and select File → Save as Web Page from the menu and click Publish. Specify what you want to publish on your Web page from the Choose list, type a name for your Web page file in the File name box and click Publish.

Saving a Workbook as an Interactive Web Page

- **Interactive Web pages** let users interact with the data on your Web page because they include basic spreadsheet functionality. Interactive Web Pages let your users enter data, format data, calculate data, and sort and filter. Interactive Web Pages require Microsoft Internet Explorer 4.01 or greater so not everyone can use them.

- **To Save a Workbook as an Interactive Web Page:** Open the workbook and select File → Save as Web Page from the menu and click Publish. Specify what you want to publish on your Web page from the Choose list and type a name for your Web page file in the File name box, check the Add Interactivity with box and click Publish.
Using Queries to Retrieve Information from the Web

- **To Run a Web Query:** Select Data → Get External Data → Run Saved Query from the menu, select the query you want to run and click Get Data. Specify where in the workbook you want to insert the results of the query and click OK.

- **To Create a Web Query:** Select Data → Get External Data → New Web Query from the menu, click the Browse button and Navigate to the Web page that contains the data you want to query (or type the URL of the Web page if you know it.) Select the part of the Web page you want to query (usually only the tables), click OK, specify where in the workbook you want to insert the results of the query and click OK.

**Quiz**

1. A hyperlink can point to which of the following items? (Select all that apply.)
   A. A location in the same Excel workbook.
   B. A different Excel workbook.
   C. A Microsoft Word document.
   D. A Web page on the Internet.

2. The Web toolbar automatically appears whenever you click a hyperlink in an Excel workbook (True or False?)

3. Which of the following statements is NOT true?
   A. Interactive Web pages allow users to enter, format, calculate, and sort Excel worksheet data using a Web browser.
   B. Non-interactive Web pages allow users to view Excel worksheet data using a Web browser but not change it.
   C. Interactive PivotTables allow users to pivot, filter, and sort an Excel PivotTable using a Web browser.
   D. Users must have version 4.0 or later of Microsoft Internet Explorer or Netscape Navigator in order to work with an Interactive Web page.

4. While browsing the Internet you find a Web page that contains a table whose data you want to import into an Excel worksheet. How can you accomplish this?
   A. Select File → Save As from the Web browser’s menu and specify that you want to save the Web page as an Excel workbook.
   B. Create a Web query in Microsoft Excel by selecting Data → Get External Data → New Web Query from the menu and browsing to the Web page that contains the table you want to import.
   C. Select File → Open from the menu, select HTML from the Files of Type list and enter the URL of the Web page in the File Name box.
   D. There isn’t an automated way to import Web based information—you will have to manually enter the information into Excel.
5. When you save an Excel workbook as a HTML file, some of the workbook’s formatting may be lost. (True or False?)

6. You can edit a hyperlink by right-clicking it and selecting **Hyperlink → Edit Hyperlink** from the shortcut menu. (True or False?)

**Homework**

1. Open the Lesson 4A workbook and save it as “Web Practice.”
2. Click cell A10 type “Expenses” and press <Enter>. Click cell A10, click the Insert Hyperlink button on the Standard toolbar and create a hyperlink to the Expenses workbook.
3. Save the Web Practice workbook as a Web page.
4. Try running several of Excel’s built-in Web queries.

**Quiz Answers**

1. A, B, C, and D. A hyperlink can point to any of these items and more.
2. True. The Web toolbar always appears whenever you click a hyperlink in any Microsoft Office application.
4. B. You can import information on a Web page into Microsoft Excel by using a Web query (although you will probably have to clean up the data after importing it.)
5. True. An HTML file doesn’t have as many formatting options as an Excel worksheet.
6. True. To edit a hyperlink, right-click it and select **Hyperlink → Edit Hyperlink** from the shortcut menu.
Chapter Eleven: Data Analysis and PivotTables

Chapter Objectives:

- Create a PivotTable
- Change or "Pivot" a PivotTable
- Use the Page Field to filter what data is displayed in a PivotTable
- How to group information in a PivotTable by date
- Create and work with subtotals
- Use Database functions (DSUM)
- Use Lookup functions (VLOOKUP)
- Group and outline a worksheet

Chapter Task: Analyze ticket sales

Once you have created a list, there are many ways to analyze its data. You should already know some basic ways to analyze information, such as filtering records. This chapter explains more advanced and powerful methods of analyzing list information.

Creating a PivotTable feature is usually the best way to summarize and analyze list data—which is why we’ll spend more than half of the chapter discussing it. A PivotTable is a way to summarize list information. Peek at Figure 11-1 and Figure 11-2 on the next page to see how much easier it is to make sense of numbers in a list with a PivotTable. This chapter explains the ins and outs of PivotTables—how to create them, modify their structure, and edit the data a PivotTable is based on.

This chapter also includes lessons on several other ways to summarize and analyze worksheet information, such as how use Excel’s subtotal function, how to create database-specific formulas, and how to outline your worksheets.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- Create and work with a list.
- How to enter formulas.
Lesson 11-1: Creating a PivotTable

Creating a PivotTable is remarkably easy. You create PivotTables using the PivotTable Wizard, which asks which fields you want to include in the PivotTable, how you want your PivotTable organized, and which types of calculations your PivotTable should perform. PivotTables may sound confusing, but they will make a lot more sense when you’ve actually created one.
1. **Open the workbook named Lesson 11A and save it as PivotTable.**

This workbook contains figures for ticket sales from a recent promotion. The list contains flight dates, agents, offices which sold the tickets, destinations, sales amounts, and if the agents received a commission or not. It’s difficult to see the bottom line in a large list like this. For example, how many tickets did the Blaine office sell or how many tickets were sold to London? The PivotTable Wizard can help you summarize the list and provide you with meaningful information.

2. **Make sure the cell pointer is located in the list (A1:I200) and select Data → PivotTable and PivotChart Report from the menu.**

The First Step of the PivotTable Wizard dialog box appears. Here you must specify the location of the data you want to use in your PivotTable. There are four options:

- **Microsoft Excel list or database:** Creates a PivotTable from data in columns on your worksheet (the most commonly used option.)
- **External data source:** Creates a PivotTable from data stored in a file or database outside of the current workbook or Microsoft Excel.
- **Multiple consolidation ranges:** Creates one PivotTable from multiple cell ranges in different worksheets.
- **Another PivotTable:** Creates a PivotTable from another PivotTable in the same workbook.

You also have to specify if you want to create a PivotTable Report or a PivotTable Report along with a corresponding PivotChart report.

3. **Verify that the Microsoft Excel list or database and the PivotTable options are both selected and click Next.**

Step Two of the PivotTable Wizard appears. You need to tell the PivotTable Wizard where the data you want to use in the PivotTable is located. Because the cell pointer was located inside the list when you started the PivotTable Wizard, the cell range of the list (A1:I200) is already selected.

4. **Click Next.**

The third and last step of the PivotTable Wizard appears, as shown in Figure 11-4. Here’s where you tell Excel to put your PivotTable report. You can place your PivotTable report in:

- A new worksheet
- Embedded in an existing worksheet.

5. **Verify that the New worksheet option is selected and click Finish.**

The PivotTable Wizard dialog box closes and the PivotTable appears on a new worksheet, as shown in Figure 11-5. Notice the PivotTable is empty—that’s because we haven’t specified the data we want to analyze yet—something you’ll learn in the next lesson.

---

### Quick Reference

**To Create a PivotTable:**

1. Make sure the cell pointer is located in the list.
2. Select Data → PivotTable and PivotChart Report from the menu.
3. Select the location of the data you want to include in your PivotTable report and the type of report (PivotTable report or PivotTable with PivotChart report) and click Next.
4. In Step 2 make sure the list range is selected and click Next.
5. In Step 3, specify a location for the PivotTable (a new worksheet or an existing worksheet.)
6. Click Finish.
Lesson 11-2: Specifying the Data a PivotTable Analyzes

Figure 11-6
Dragging the Office field from the PivotTable toolbar to the Column area of the PivotTable.

Figure 11-7
The PivotTable summarizing the total tickets sold by Destination and Office.

Once you’ve created your PivotTable report, you have to specify the data you want to analyze with the PivotTable. It’s easy to specify which data you want to analyze—simply drag it from the PivotTable toolbar and onto the Row, Column, or Data area on the PivotTable report. You’re not going to understand how to do this unless you try it—so let’s get started!

1. Drag the Destination field button from the PivotTable toolbar to the ROW area of the PivotTable diagram.
   The Destination field appears at the top of the ROW area in the PivotTable. Next, make the Office field the column heading for the PivotTable.

2. Drag the Office field button from the PivotTable toolbar to the COLUMN area of the PivotTable diagram, as shown in Figure 11-6.
   You have selected the Destination field to be the row heading and the Office field to be the column heading for your PivotTable. Now you need to select the field you want to summarize.

3. Drag the Number of Tickets field button from the PivotTable toolbar to the DATA area of the PivotTable diagram.
   Compare your dialog box with the one shown in Figure 11-7.
The neat thing about PivotTables is that their information is *dynamic*. What this means is once you’ve created a PivotTable, you can rearrange or “pivot” it to view its data in different ways. For example, you could rearrange the PivotTable you just created so that it summarizes the amount of the total ticket sales instead of the total number of tickets sold.

4. Drag the **Sum of Tickets** field button (located in cell A3) off the PivotTable diagram.

   The PivotTable will no longer total the number of tickets sold. You can easily summarize another field by dragging it onto the DATA area of the PivotTable diagram.

5. Drag the **Total** field button to the DATA area of the PivotTable diagram.

   You also rearrange a PivotTable’s headings.

6. Drag the **Destination** field button from the ROW area of the PivotTable diagram to the COLUMN area and drag the **Office** field button from the ROW area of the PivotTable diagram to the COLUMN area.

   Hopefully, you’re starting to understand the true power of PivotTables. PivotTables can usually make information stored in even the longest lists easy to understand. And once you make a PivotTable you can change the information it summarized in an instant, simply by dropping and dragging.

---

**Quick Reference**

To Create a PivotTable:

1. Make sure the cell pointer is located in the list.
2. Select **Data → Pivot Table Report** from the menu.
3. Select either the Microsoft Excel List or Database option and click Next.
4. In Step 2, make sure the list range is selected and click Next.
5. In Step 3, drag the field names you want to summarize to the appropriate section of the PivotTable diagram (Page, Column, Row, or Data) and click Next.
6. In Step 4, specify a location for the PivotTable (a new worksheet or an existing worksheet.)
7. (Optional) Click the **Options** button to specify any additional options for the PivotTable.
8. Click Finish.
Lesson 11-3: Modifying a PivotTable’s Structure

In the previous lesson, you learned how to change the data you want included in the PivotTable report. You can also change how a PivotTable summarizes its information. For example, you might want a PivotTable to display averages instead of totals.

1. Click cell B3 and select **Window -> Freeze Panes** from the menu.
   
   Now the column and row headings to the left and above the active cell (B3) will always be visible as you scroll through the worksheet.

2. Scroll down to **row 22**.
   
   The PivotTable has created column totals, which calculates the total number of reservations made at each office.

3. Scroll to the **U column**.

   The PivotTable has also calculated the total number of reservations made to each destination.

4. **Click the PivotTable Field button on the PivotTable toolbar**.

   The PivotTable Field dialog box appears, as shown in Figure 11-8. The PivotTable Field dialog box lets you change how a PivotTable is calculated. For example, instead of totaling the ticket sales made, you could find the average:

5. **Select Average from the Summarize by list and click OK**.

   The PivotTable Field dialog box closes and the PivotTable displays the average ticket sales.
Lesson 11-4: Selecting What Appears in a PivotTable

You can filter which information is summarized in a PivotTable by clicking a row or column field’s drop-down arrows and selecting the items you want to include in the PivotTable report or by adding a page field to the PivotTable. In this lesson, you’ll learn how to filter the information that is included in a PivotTable Report using both methods.

1. **Click the Office field drop-down list located in cell A4.**
   A drop-down list appears beneath the Office field, as shown in Figure 11-12. You can select which values appear in your PivotTable report by making sure they are checked and remove values by removing their checkmark.

2. **Remove the checkmark from the Bloomington, Brainerd, Brooklyn Center, and Duluth boxes.**
   The Bloomington, Brainerd, Brooklyn Center, and Duluth offices no longer appear in the PivotTable report. You can also filter the information that appears in a PivotTable report by adding a Page Field to the PivotTable.

3. **Drag the Commission field button to the PAGE area of the PivotTable diagram.**
   Now you will be able to filter the PivotTable using the commission field and display data for sales with commissions, sales without commissions, or both.

4. **Click the Commission list arrow, located in cell B1 and select Yes.**
   The PivotTable displays only information for commissioned sales.

---

**Quick Reference**

To Add a Page Field to a PivotTable:

1. Make sure the cell pointer is located in the PivotTable and click the PivotTable Wizard button on the PivotTable toolbar.
2. Drag the field name you want to use to filter the PivotTable to the PAGE section of the PivotTable diagram and click Finish.

To Filter a PivotTable’s Summary Information:

- Select what you’d like to see on the PivotTable report from the Row heading, Column heading, or Page Field drop-down list.
Lesson 11-5: Grouping Dates in a PivotTable

PivotTables can usually summarize information without any outside help from you. When you want to summarize a list by dates, however, you will probably need to coach Excel and tell it how you want to group the information in the PivotTable: by days, months, quarters, or years. In this lesson, we’ll rearrange out PivotTable and summarize its information by month. First, you need to rearrange your PivotTable to summarize it by date.

1. Drag the Office field button off the PivotTable diagram and drag the Destination field button from the Column area of the PivotTable to the Row area.

Next, you need to add the Date field to the PivotTable’s Column area.

2. Drag the Date field button to the Column area of the PivotTable.

Now the PivotTable summarizes ticket sales by destination and date as shown in Figure 11-15. The only problem is that the PivotTable summarizes the dates by day—making the summary information rather meaningless. You can make the PivotTable more useful by grouping the days into months using the Group command. First you need to specify what information you want to group by—the dates.

3. Click the Date button located in cell B3 then select Data → Group and Outline → Group from the menu.

The Grouping dialog box appears, as shown in Figure 11-16. You need to select a date increment to group by.

4. Select Months from the By list and click OK.

The Group dialog box closes and the PivotTable groups the dates by month, as shown in Figure 11-17.

Quick Reference

To Group Information by Date or Time:

1. Select the row or column heading that contains the date or time value you want to group by and click the Group button on the PivotTable toolbar.

Or...

Select any row or column heading that contains the date or time value you want to group by and select Data → Group and Outline → Group from the menu.

2. Specify the starting and ending dates and the interval you want to group the dates or time by, then click OK.
Lesson 11-6: Updating a PivotTable

If you modify the source data a PivotTable is based on, the PivotTable isn’t automatically updated. Instead you must manually refresh the PivotTable anytime you change its underlying source data. This lesson explains how to do just that.

1. Click the Promotion Sales tab.

2. Click cell G2, type 100 and press <Enter>.

   Obviously, Antonio Rommero didn’t sell 100 tickets to Boston, but this is a big enough number that you will be able see the changes in the PivotTable’s January column when you update it.

3. Click the Sheet1 tab to return to the PivotTable.

   Look at cell B5, the January column. The PivotTable does not reflect the increased ticket sales you made to the list, as shown in Figure 11-18.

4. Click anywhere in the PivotTable and click the Refresh Data button on the PivotTable toolbar.

   The PivotTable is refreshed and correctly displays the current list data, as shown in Figure 11-19.

5. Save your work and then close the Pivot Table worksheet.

   That’s it—we’re finished working with PivotTables! PivotTables are the most powerful way to summarize information in a list, but they’re not the only method you can use. The remainder of this chapter explores some of the other ways to summarize list information.
Lesson 11-7: Formatting and Charting a PivotTable

This lesson explains how you can quickly format a PivotTable report using the AutoFormat command and how to create a PivotChart—both new features introduced in Excel 2002.

First, let’s discuss how to format your PivotTable with AutoFormat. AutoFormat is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to a PivotTable report. AutoFormat lets you select from 20 different preset formats. AutoFormat is a great feature if you want your PivotTables to look sharp and professional but don’t have the time to format them yourself.

1. **Make sure the cell pointer is located in the PivotTable report and click the Format Report button on the PivotTable toolbar.**
   
The AutoFormat dialog box appears, as shown in Figure 11-20. You can format your PivotTable report using a preset format.

2. **Scroll down the AutoFormat dialog box, select the Table 2 format and click OK.**
   
The PivotTable is formatted with the preset Table 2 formatting settings.
Let’s move on to this lesson’s other topic, create a PivotChart. A PivotChart is similar to an ordinary chart created in Excel, except that it plots a PivotTable’s information. PivotCharts differ from ordinary Excel charts because they are dynamic, just like PivotTables reports. You can change a PivotChart’s structure just like you would with a PivotTable.

3. **Make sure the cell pointer is located in the PivotTable report and click the Chart Wizard button on the PivotTable toolbar.**

Excel creates a chart form the PivotTable and places it on a new sheet tab, labeled Chart1. You can format and work with a PivotChart just like you would with a regular chart. Since there’s so much information in our PivotTable, the PivotChart we just created looks cluttered. As with PivotTables, you can specify what items you want to appear in a PivotChart.

4. **Click the Destination drop-down list located above the chart’s legend and remove the checkmarks from all the destinations except Boston, Cancun, Chicago, and Dallas.**

Only the specified destinations are plotted on the PivotChart. Let’s change the chart type to make our PivotChart easier to understand.

5. **Select Chart → Chart Type from the menu.**

The Chart Type dialog box appears.

6. **Select a Clustered Column Chart from the Chart Sub-Type list and click Finish.**

The chart type is changed to a clustered column chart, as shown in Figure 11-21. Just about everything you can do to a PivotTable report you can do to a PivotChart. For example, you can easily add, change, remove, or rearrange what the PivotChart plots.

7. **Drag the Average of Total field (located in the upper left corner of the chart) from the PivotChart back to the PivotTable toolbar to remove it.**

Since the PivotChart has no data to plot, it displays the message “Drop Data Items Here.”

8. **Drag the Tickets field from the PivotTable toolbar to the empty Data area of the PivotChart.**

The PivotChart now plots the total number of tickets sold to each destination.

9. **Save your work and then close the Pivot Table worksheet.**

That’s it—we’re finished working with PivotTables and PivotCharts! PivotTables are the most powerful way to summarize information in a list, but they’re not the only method you can use. The remainder of this chapter explores some of the other ways to summarize list information.

**Quick Reference**

To Format a PivotTable:
- Make sure the cell pointer is located in the PivotTable report and click the Format Report button on the PivotTable toolbar. Select the formatting you want to apply and click OK.

To Create a PivotChart:
- Place the cell pointer anywhere in a PivotTable report and click the Chart Wizard button on the PivotTable toolbar. You will probably have to change the chart type. Or...
- Create a PivotTable and PivotChart from scratch. See the instructions for creating a PivotTable.

To Modify a PivotChart:
- Modify a PivotChart the same as you would a PivotTable—drag and drop fields to and from the PivotTable toolbar and the PivotChart.
Lesson 11-8: Creating Subtotals

So far in this chapter, we’ve been summarizing information in a list using PivotTables. Another quick and easy way to group and summarize data is to use Excel’s subtotals feature. Usually you create subtotals with the SUM function, but you can also create subtotals using functions such as COUNT, AVERAGE, MAX, and MIN.

1. Open the workbook named Lesson 11B.

   You need to sort the list before you use the Subtotals command. You want to sort the list alphabetically by destination.
2. Click any cell in the E column and click the Sort Ascending button on the Standard toolbar.
   The list is sorted alphabetically by destination. Now that the list is sorted, you can use the Subtotals command.

4. Make sure the active cell is located within the list and select Data \(\rightarrow\) Subtotals from the menu.
   The Subtotal dialog box appears, as shown in Figure 11-22. You want to summarize the list based on the Destination field—the field you sorted in the previous step.

5. Select Destination from the At each change in list, then select Sum from the Use function list.
   This will create subtotals every time the destination changes (which is why you had to sort the list based on destination back in Step 2. Next, you need to specify that you want to add subtotals to the Annual Trips and Annual Cost of Tickets fields.

6. In the Add to subtotal to list, check the Tickets check box, and the Total check box (you may have to scroll up or down to find them.) Make sure the other check boxes in the list aren’t checked.
   This will add subtotals to the Tickets and Total columns.

7. Make sure the Replace current subtotals and Summary below data check boxes are checked.
   Compare your Subtotal dialog box to the one in Figure 11-22.

8. Click OK.
   The dialog box closes and Excel summarizes the list and calculates the subtotals for each time the destination field changes. Notice Excel displays the outline symbols to the left of the worksheet, as shown in Figure 11-23. We’ll save outlining for another lesson. For now, try using the Outline buttons to hide the list details.

9. Click the 2 Column Level Symbol button.
   Excel hides the third level of detail in the list (the employees) and now only displays the totals for each office.

10. Click the 3 Column Level Symbol button.
    All the outline details are again visible. You can turn off the subtotaling now.

11. Make sure the active cell is located within the list and select Data \(\rightarrow\) Subtotals from the menu, then Remove All.
    The subtotals and outlining are removed from the list. You can remove Subtotals from a workbook at any time.

12. Make sure the active cell is located within the list, then select Data \(\rightarrow\) Subtotals from the menu and click Remove All.
    The Subtotals are removed from the worksheet.

13. Close the workbook without saving it.

Knowing how to use the Subtotals command will give you an edge many other Excel users. Most users don’t realize Excel can automatically add subtotals to their worksheets, and as a result they needlessly spend hours manually adding subtotals themselves.

Quick Reference

To Calculate Subtotals:
1. Make sure the list is sorted.
2. Select Data \(\rightarrow\) Subtotals from the menu.
3. Enter the appropriate information in the Subtotal dialog box and click OK.

To Remove Subtotals:
- Make sure the active cell is located within the list, then select Data \(\rightarrow\) Subtotals from the menu and click Remove All.
Lesson 11-9: Using Database Functions

Excel's database functions perform calculations only for records that meet the criteria you specify. For example, you might only want to count tickets that were sold to Boston. All the database functions use the same basic syntax: `=Function(database, field, criteria)`. These arguments (parts) of database functions include:

- **Database**: Is the cell range that makes up the list or database.
- **Field**: Indicates which column is used in the function. You can refer to fields by their column labels as long as you enclose them with double quotation marks, such as "Name". You can also refer to fields as a number that represents the position of the column in the list: 1 for the first column in the list, 2 for the second, and so on. Make sure you refer to their position in the list, and not the column heading numbers!
- **Criteria**: Is a reference to the cell or cell range that specifies the criteria for the function.

**Figure 11-25**
Using the Insert Function tool to create a DSUM formula.

**Figure 11-26**
The syntax of the DSUM function.

**Figure 11-27**
The DSUM function totals only those records that meet your criteria.

```
```

```
Function | Database          | Field            | Criteria
---------|-------------------|------------------|---------
         | the range of      | the name or      | the range of cells that contains the conditions you want to specify
         | cells that make   | number of        |                     |
         | up the list       | the column that  |                     |
         |                   | is used in the   |                     |
         |                   | function         |                     |
```
This lesson explains how to use database functions by creating a formula with the simplest database function—the DSUM function.

1. Open the **Lesson 11B** workbook and save it as **Data Functions**.
   Start by adding a meaningful label for the results of the DSUM formula.

2. Click cell C25 (scroll down if necessary), click the **Bold button** on the Formatting toolbar, type **Purpose** and press **<Enter>**.
   Next, enter the criteria the DSUM function will use (you’ll see how the criteria works later when we actually create a DSUM formula).

3. **Type Business in cell C26**.
   We’ll enter a DSUM formula in cell C27.

4. Make sure the active cell is C27, then click the **Insert Function button** on the Formula bar.
   The Insert Function dialog box appears.

5. Select **Database** from the Function Category list, select **DSUM** from the Function Name list and click **OK**.
   The Function Arguments dialog box appears, as shown in Figure 11-25. You’re ready to start entering the DSUM formula to calculate the total for Annual Trips amounts for only those records that have “Business” in the Purpose column. The first argument in the DSUM function is to define the database—the cell range that makes up the list.

6. **Click the Database text box** and select the entire list—the cell range A1:I23 (you may have to use the Collapse dialog box button) and press **<Enter>**.
   The second argument in the DSUM function is to define the Field—the column that is used in the function. You can enter the Field by typing the column label enclosed between double quotation marks, such as "Annual Trips" or as a number that represents the position of the column in the list: 1 for the first column, 2 for the second column, etc. For example, the column you want to total, Annual Trips, is the seventh column in the list, so you would type either 7 or "Annual Trips" for the Field argument.

7. **Click the Field text box** and type **"Annual Trips"**.
   You also could have typed 7. The last argument in the DSUM function is the Criteria—the range of cells that contains the conditions you want to specify. You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell below the column label for specifying a condition for the column.

8. **Click the Criteria text box** and select the cell range C25:C26.
   The cell range C25:C26 contains both the column label, Purpose, and the criteria, “Business”.

9. **Click OK to close the Function Arguments dialog box**.
   Excel displays the result of the DSUM function in cell C26—42. Try changing the criteria value in C26 to calculate the total number of annual flights for the records that contain “Pleasure” in the Purpose column.

10. **Click cell C26, type Pleasure, and press <Enter>**.
    The DSUM value in cell C26 changes to 19—the total number of annual flights for the records that contain “Pleasure.”

11. **Save your work**.

---

**Quick Reference**

To Use the DSUM Function in a Formula:

- Write the formula using the syntax
  - =DSUM(database, field, criteria).

Or...

1. Click the **Paste Function button** on the Standard toolbar to open the Function arguments dialog box.
2. Select **Database** in the Function category list, select **DSUM** in the Function name list, and click **OK**.
3. Enter the required arguments for the DSUM function.
Lesson 11-10: Using Lookup Functions

The VLOOKUP function looks up information in a worksheet. The VLOOKUP searches vertically down the leftmost column of a cell range until it finds the value you specify. When it finds the specified value, it then looks across the row and returns the value in column you specify. The VLOOKUP function works a lot like looking up a number in a phonebook: first you look down the phonebook until you find the person’s name, then you look across to retrieve the person’s phone number.
Chapter Eleven: Data Analysis and PivotTables

Are you thoroughly confused yet? The VLOOKUP function is almost impossible to explain unless you’ve actually used it—and you’ll use the VLOOKUP function in this lesson.

1. **Click cell D25, click the Bold button on the Formatting toolbar, type Sales By Rep and press <Enter>.**
   Next, enter the lookup value for the VLOOKUP function (you’ll see how the lookup value works when we actually create the VLOOKUP formula).

2. **Type Ronald in cell D26.**
   Before using the VLOOKUP function, you should sort the list by the column that contains the lookup value.

3. **Select any cell that contains data in the A column and click the Sort Ascending button on the Standard toolbar to sort the list.**
   We’ll enter the VLOOKUP formula in cell D27.

4. **Click cell D27 and click the Insert Function button on the Formula bar.**
   The Insert Function dialog box appears.

5. **Select Lookup and Reference from the Function Category list, select VLOOKUP from the Function Name list and click OK.**
   The Function Arguments dialog box appears, as shown in Figure 11-28. You’re ready to start entering the VLOOKUP formula to lookup annual trip costs by the employee’s first name. The first argument in the VLOOKUP function is to specify the value you want to look up in the first column of the cell range. Lookup values can be values, references, or labels. Cell D26 contains the value you want to look up—the client’s first name.

6. **Click the Lookup_value box and click cell D26 (you may need to use the Collapse dialog box button.)**
   The second argument in the VLOOKUP function is to define the Table Array—the cell range that contains the data you want to look up.
   **NOTE:** Remember when you define the Table Array, the VLOOKUP function looks up values from the first column of the specified cell range. So if you wanted to lookup values by City instead of by First Name, you would make sure that the City column was the first column in the selected cell range.

7. **Click the Table_array box and select the entire list—the cell range A1:I23 (you may have to click the Collapse dialog box button.)**
   The third argument in the VLOOKUP function is to specify the Column Index Number—the column number from which the matching value must be returned. For example, the column you want to lookup, Annual Cost of Tickets, is the eighth column in the list, so you would type 8 for the Column Index Number argument.

8. **Click the Col_index_num box, type 8, and click OK.**
   Excel looks up the first value in the First column that matches the Lookup Value in cell D26, “Ronald” and displays the value in the eighth column of that row, 3000. Try changing the Lookup Value in D26 to look up the annual ticket cost for another name.

9. **Click cell D26, type John, and press <Enter>.**
   The VLOOKUP value in cell D26 changes to 1686—the ticket cost for John Peters.

10. **Save your work and close the Database Functions workbook.**

The HLOOKUP function is similar to the VLOOKUP function, except it searches horizontal from left to right across the top row of a cell range until it finds the value you specify. When it finds the specified value it then looks down the column to find the specified value.
Lesson 11-11: Grouping and Outlining a Worksheet

Many spreadsheets are created in a hierarchical style. For example, a worksheet might contain a column for each month, followed by a total column. By outlining your worksheets, you make them easier to understand and read. Instead of sifting through irrelevant information, you can collapse an outline to display each group’s total or bottom line.

There are several ways to outline a workbook:

- **Using the Subtotals Feature:** The Data ➔ Subtotals command calculates subtotal and grand total values for the labeled columns you select. Excel automatically inserts and labels the total rows and outlines the list. We covered creating and working with subtotals earlier in this chapter.

- **Using the Consolidate Feature:** You can consolidate several sheets selecting Data ➔ Consolidate from the menu.

- **Using the Auto Outline Feature:** The Data ➔ Group and Outline ➔ Auto Outline command automatically outlines a selected range of cells or the entire worksheet, based on formulas and the direction of references.

- **Manually Creating an Outline:** You can group rows and columns manually by selecting them and selecting Data ➔ Group and Outline ➔ Group from the menu.

This lesson explains how to use the third and fourth methods and how to work with an outline.

1. **Open the Lesson 11C workbook.**

   We’ll start this lesson by manually grouping the rows for the Blaine office.
2. Select rows 5 and 6 and select Data → Group and Outline → Group from the menu.
Excel groups the selected rows in an outline. Notice the Hide Details button that appears to the left of the worksheet. Clicking a Hide Details button hides, or collapses, its group of records.

3. Click the Hide Details button to the left of the worksheet.
Excel hides the details, rows 5 and 6, for the Blaine office and changes the Hide Details button to a Show Details button, indicating it contains hidden records. Clicking the Show Details button displays, or expands, its group of records.

4. Click the Show Details button to the left of the worksheet.
Excel displays the hidden records. It’s just as easy to ungroup records as it is to group them.

5. Select rows 5 and 6 and select Data → Group and Outline → Ungroup from the menu.
Excel ungroups the records.

Before you manually create an outline by grouping dozens of records, you should see if Excel can automatically create the outline for you. Excel can automatically outline worksheets if they contain formulas that consistently point in the same directions. Excel can automatically group and outline this worksheet since it does contain formulas that all consistently point to the right (the quarterly subtotals) and down (the office subtotals).

6. Select Data → Group and Outline → Auto Outline from the menu.
Excel analyzes the formulas in the worksheet and creates an outline, as shown in Figure 11-31. You can still expand and collapse each group in the outline by clicking the corresponding Show Detail or Hide buttons, but an easier way is to use the Column Level buttons. The Column Level buttons display or hide a specific level in your worksheet. For example, if an outline has three levels, you can hide all the third levels by clicking the button.

7. Click the Row Level 2 button.
Excel displays only the first two levels in the outline—the totals for each office. You can also hide and display columns the same way.

8. Click the Column Level 2 button.
Excel collapses the outline so that only the quarterly and annual totals are displayed. To expand the outline, just click the symbol for the lowest row and column level. For example, if there are three levels, click the button.

9. Expand the outline by clicking the Column Level 3 button and the Row Level 3 button.
It’s easy to remove an outline from a worksheet:

10. Select Data → Group and Outline → Clear Outline from the menu.
The outline is removed from the worksheet.

11. Exit Excel without saving your changes.
Chapter Eleven Review

Lesson Summary

Creating a PivotTable

- A PivotTable summarizes list information dynamically, meaning once you have created a PivotTable, you can rearrange or "pivot" it to view its data in different ways.

- To Create a PivotTable: Make sure the cell pointer is located in the list and select Data → Pivot Table Report from the menu. Follow the on-screen instruction to create the PivotTable.

Modifying a PivotTable’s Structure

- To Rearrange a PivotTable: Make sure the cell pointer is located in the PivotTable, click the PivotTable Wizard button on the PivotTable toolbar, and rearrange the PivotTable by dragging the field names buttons to or from the appropriate section of the PivotTable diagram.

- To Change the Calculation Used in a PivotTable: Make sure the cell pointer is located in the PivotTable and click the PivotTable Field button on the PivotTable toolbar, and select the calculation you want to use.

Adding a Page Field to a PivotTable

- A Page Field lets you filter the information in PivotTable.

- To Add a Page Field to a PivotTable: Make sure the cell pointer is located in the PivotTable and click the PivotTable Wizard button on the PivotTable toolbar. Drag the field name you want to use to filter the PivotTable to the PAGE section of the PivotTable diagram and click Finish.

- Filter a PivotTable by selecting the criteria from the PivotTable’s Page Field.

Grouping Dates in a PivotTable

- You can group information by days, months, quarters, or years.

- To Group Information by Date or Time: Select the row or column heading that contains the date or time value you want to group by and click the Group button on the PivotTable toolbar or select Data → Group and Outline → Group from the menu. Specify the starting and ending dates and the interval you want to group the dates or time by, then click OK.

Updating a PivotTable

- A PivotTable isn’t automatically updated if you modify its source data. You can refresh a PivotTable by clicking the Refresh Data button on the PivotTable toolbar or selecting Data → Refresh Data from the menu.
Formatting and Charting a PivotTable

- **To Format a PivotTable:** Make sure the cell pointer is located in the PivotTable report and click the **Format Report button** on the PivotTable toolbar. Select the formatting you want to apply and click **OK**.
- **To Create a PivotChart:** Place the cell pointer anywhere in a PivotTable report and click the **Chart Wizard button** on the PivotTable toolbar. You will probably have to change the chart type.
- **To Modify a PivotChart:** Modify a PivotChart the same as you would a PivotTable—drag and drop fields to and from the PivotTable toolbar and the PivotChart.

Creating Subtotals

- **To Calculate Subtotals:** Sort the list, select **Data → Subtotals** from the menu, enter the appropriate information in the Subtotal dialog box and click **OK**.
- **To Remove Subtotals:** Make sure the active cell is located within the list, then select **Data → Subtotals** from the menu and click **Remove All**.

Using Database Functions

- Database functions perform calculations only for records that meet the criteria you specify. The syntax for all database functions is =FUNCTION(Database, Field, Criteria).

Using Lookup Functions

- The VLOOKUP function looks up information in a worksheet by searching vertically down the leftmost column of a cell range until it finds the value you specify and then across the row to find the value in column you specify.
- The syntax for the VLOOKUP function is =VLOOKUP(lookup_value,table_array, col_index_num).

Grouping and Outlining a Worksheet

- **To Manually Group/Ungroup Columns or Rows:** Select the columns or rows you want to group and select **Data → Group and Outline → Group** (or Ungroup) from the menu.
- **To Outline a Worksheet Automatically:** Make sure the worksheet contains formulas that consistently point in the same directions, then select **Data → Group and Outline → Auto Outline** from the menu.
- **To Remove an Outline:** Select **Data → Group and Outline → Clear Outline** from the menu.
- You can view the details of a group by clicking its **Show Details button** ( ), and hide the details by clicking its **Hide Details button** ( ).
- You can hide or display a specific level in an outline by clicking its **Row Level** (1, 2, 3) or **Column Level** button.
Quiz

1. Which of the following statements is NOT true?
   A. PivotTables summarize the information in a list.
   B. You can add a PivotTable as an embedded object on a worksheet, or on its own separate worksheet.
   C. The Data → Pivot Table Report command starts the PivotTable Wizard.
   D. You specify which fields you want to summarize in the PivotTable by dragging them to the appropriate areas of the PivotTable diagram.

2. You must create a new PivotTable if you want summarize information from different fields (True or False?)

3. Which of the following statements is NOT true?
   A. You can specify how dates should be grouped in a PivotTable by selecting the field that contains the date information, clicking the Group button on the PivotTable toolbar, and specifying how you want the information summarized (by days, months, quarters, or years.)
   B. PivotTables are automatically updated whenever you change their source data.
   C. Adding a Page Field to a PivotTable lets you filter the information the PivotTable summarizes.
   D. You can modify the structure of a PivotTable by clicking the PivotTable Wizard button on the PivotTable toolbar.

4. You should sort a list before you group and summarize its information using the Subtotals command (True or False?)

5. Which of the following statements is NOT true?
   A. The Subtotals command subtotals a column at each value change.
   B. The Subtotals command displays the worksheet in outline view.
   C. The Subtotals command summarizes the worksheet by creating a PivotTable.
   D. You can add Subtotals to a worksheet by selecting Data → Subtotals from the menu.

6. Excel's database functions perform calculations only for records that meet the criteria you specify (True or False?)

7. Which of the following statements is NOT true?
   A. You should use the Insert Function command to help you enter complicated database functions.
   B. You can hide or display details in an outlined worksheet by clicking the Hide Details button or Show Details button, or by clicking the various Column Level or Row Level buttons.
   C. A worksheet must be sorted in order for Excel to automatically outline it.
   D. You can manually group rows and columns in a worksheet by selecting Data → Group and Outline → Group from the menu.

Homework

1. Open the Homework 11 workbook and save it as “PivotTable Practice.”
2. Select any cell; in the table then select Data → PivotTable Report from the menu.

3. Using the PivotTable Wizard, create a PivotTable report that summarizes the worksheet information like the following illustration:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum of Amount</td>
<td>Type</td>
<td>Lodging</td>
<td>Meals</td>
<td>Mileage</td>
<td>Misc.</td>
<td>Office</td>
</tr>
<tr>
<td>Agent</td>
<td></td>
<td>59</td>
<td>276</td>
<td>59</td>
<td>44</td>
<td>123</td>
</tr>
<tr>
<td>Janet Smith</td>
<td>59</td>
<td>20</td>
<td>61</td>
<td>28</td>
<td>36</td>
<td>219</td>
</tr>
<tr>
<td>Juan Rodriguez</td>
<td>272</td>
<td>111</td>
<td>22</td>
<td>98</td>
<td>0</td>
<td>503</td>
</tr>
<tr>
<td>Mary Olson</td>
<td>93</td>
<td>45</td>
<td>88</td>
<td>62</td>
<td>0</td>
<td>239</td>
</tr>
<tr>
<td>Mitch Holbrook</td>
<td>84</td>
<td>25</td>
<td>24</td>
<td>50</td>
<td>193</td>
<td></td>
</tr>
<tr>
<td>Grand Total</td>
<td>440</td>
<td>547</td>
<td>237</td>
<td>286</td>
<td>211</td>
<td>1710</td>
</tr>
</tbody>
</table>

4. Modify the PivotTable’s structure so that the column summarizes by Date instead of by Type.

5. Click the Date, field and then, click the Group button on the PivotTable toolbar. Group the dates by month.

6. Modify the PivotTable’s structure by adding the Type field as the Page Field.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum of Amount</td>
<td>Type</td>
<td>Feb</td>
<td>Mar</td>
<td>Apr</td>
<td>Grand Total</td>
</tr>
<tr>
<td>Agent</td>
<td></td>
<td>64</td>
<td>256</td>
<td>70</td>
<td>560</td>
</tr>
<tr>
<td>Janet Smith</td>
<td>64</td>
<td>19</td>
<td>24</td>
<td>215</td>
<td></td>
</tr>
<tr>
<td>Juan Rodriguez</td>
<td>212</td>
<td>17</td>
<td>264</td>
<td>20</td>
<td>603</td>
</tr>
<tr>
<td>Mary Olson</td>
<td>93</td>
<td>70</td>
<td>71</td>
<td>77</td>
<td>239</td>
</tr>
<tr>
<td>Mitch Holbrook</td>
<td>15</td>
<td>94</td>
<td>74</td>
<td>193</td>
<td></td>
</tr>
<tr>
<td>Grand Total</td>
<td>535</td>
<td>229</td>
<td>664</td>
<td>191</td>
<td>1710</td>
</tr>
</tbody>
</table>

7. Use the Page Field to filter the information summarized in the PivotTable by the various Types of expenses.

8. Click the Sheet 1 sheet tab and sort the A column alphabetically.

9. Use the Data → Subtotals command to subtotal the worksheet.

10. Practice expanding and collapsing the worksheet while it’s in Outline view.

### Quiz Answers

1. B. PivotTables appear on their own separate worksheets.

2. False. It is incredibly easy to modify which fields a PivotTable summarizes. Just click the PivotTable Wizard button on the PivotTable toolbar and drag the fields you want to summarize to the appropriate areas of the PivotTable diagram.

3. B. PivotTables are NOT automatically updated when you change their source data. You must click the Refresh Data button on the PivotTable toolbar to update the PivotTable.

4. True. Always sort a list before using the Subtotals command.

5. C. The Subtotals command does not summarize information using a PivotTable—that’s what the PivotTable command is for!

6. True. Database functions calculate only those records that match your criteria.

7. C. A worksheet must contain formulas that consistently point in the same direction to use the automatic outline feature. Sorting the worksheet doesn’t make any difference.
Chapter Twelve: What-If Analysis

Chapter Objectives:
- Create a Scenario
- Create a Scenario Summary Report
- Create One and Two-Input Data Tables
- Use Goal Seek
- Set up complex what-if analysis with Solver

Chapter Task: Analyze Different What-If Situations

If you’ve ever used a worksheet to answer the question “what if?” you’ve already performed what-if analysis. For example, what would happen if your advertising budget for your department increased by 40%? If you were considering taking out a home mortgage based on your income, how much money could you borrow for a 20-year mortgage? How much money could you borrow for a 30-year mortgage?

Most people don’t realize Excel has numerous analysis features and instead perform what-if analysis the slow and hard way—by manually inputting different values into their worksheets, looking at the results, and then inputting another set of values. This method is fine for simple what-if scenarios, but doesn’t work well for answering complex what-if questions.

In this chapter, you will learn how to create multiple what-if scenarios using Excel’s Scenario Manager. You will create one-input and two-input data tables to report several different outcomes. You will also use Excel’s Goal Seek and Solver to solve more complex what-if questions.

Prerequisites
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to select cell ranges.
- How to enter values, labels, and formulas into a cell.
- How to reference cells.
Lesson 12-1: Defining a Scenario

A scenario is a set of values you use in what-if analysis. Imagine you are considering taking out a home mortgage and have to determine what type of loan to take out. One scenario you are considering is a 30-year loan with a 7.5% interest rate. Another scenario is a 20-year loan with an 8.5% interest rate. Excel’s scenario manager lets you create and store different scenarios in the same worksheet. Once you have created a scenario, you can select it and display the worksheet using its values.

In this lesson, you will use the scenario manager to perform what-if analysis on a home mortgage. You will create three different scenarios to see how changing the amount and length of the loan will change your monthly payments.

1. Start Microsoft Excel, open the workbook named Lesson 12A and save it as Mortgage What-If.
   This workbook contains information for a mortgage. To help assist you with deciding what type of mortgage to take out, you will use Excel’s Scenario Manager to create several scenarios with different loan amounts and terms. The first step in creating a Scenario is to select the cells that change.

2. Select the cell range A4:C4 and select Tools → Scenarios from the menu.
   The Scenario Manager dialog box appears with the message “No Scenarios defined. Choose Add to add scenarios.” You want to add a new scenario.
3. Click Add.
   The Add Scenario dialog box appears, as shown in Figure 12-1. You must give your
   scenario a name and specify the scenario’s changing cells, if necessary. The cell range
   A4:C4 appears in the changing cells text box because you selected those cells before
   you opened the Scenario Manager. First, create a scenario with the original values.

4. Type Original Quote in the Scenario name box and click OK.
   The Scenario Values dialog box appears, as shown in Figure 12-2 with the existing
   values in the changing cells boxes. Since this is the original quote, you can save the
   scenario without changing the values.

5. Click OK.
   The Scenario Values dialog box closes and you return to the Scenario Manager dialog
   box. Next, create a scenario with a longer loan length—30 years instead of 20.

6. Click Add, type 30 Year Loan in the Scenario name box and click OK.
   The Scenario Values dialog box appears. You need to change the values for this
   scenario.

7. Change the 20 in the second changing cell box ($B$4) to 30 and click Add.
   Excel saves the 30 Year Loan scenario and you return to the Scenario Manager dialog
   box. Create another scenario with a smaller loan amount.

8. Type Smaller Loan in the Scenario name box and click OK.
   The Scenario Values dialog box appears.

9. Change the 150000 in the first changing cell box ($A$4) to 125000 and click OK.
   Excel saves the Smaller Loan scenario and returns you to the Scenario Manager dialog
   box. You’re ready to test your scenarios.

10. Select the 30 Year Loan scenario from the Scenario list and click Show.
    Excel changes the length of the loan in B4 from 20 years to 30 years.

   NOTE: Type your note here. The Scenario Manager dialog box doesn’t close so you
    might need move it out of the way so that you can see the cells.

    Notice the monthly payment decreases from $1,162.95 to $997.95, and the Interest
    paid increases from $129,107.62 to $209,263.35.

11. Select the Smaller Loan scenario from the Scenario list and click Show.
    The length of the loan changes back to 20 years and the amount of the loan changes to
    $125,000. You’re finished working with the Scenario Manager for now.

12. Click Close to close the Scenario Manager and save your work.
    Great! You’ve learned how to use your first What-If Analysis feature.
Lesson 12-2: Creating a Scenario Summary Report

If you’ve defined two or more scenarios, you can summarize them by creating a scenario summary report. A scenario summary report is a single compiled report that summarizes the results from several scenarios. It’s usually much easier to read a single scenario summary report than switching between several different scenarios.

1. Select the cell range A3:F4 and select Insert → Name → Create from the menu.

The Create Names dialog box appears, as shown in Figure 12-4. The Create Names will automatically create range names, based on the current selection. Naming the cells will make them easier to read when you create the Scenario Summary report.

2. Verify the Top row check box is checked and click OK.

The Create Names dialog box closes and Excel automatically creates names for the selected cell range. You can verify that Excel created the correct names by clicking the Name box arrow.

3. Click the Name Box List arrow.

The column heading names should appear in the Name Box list.

4. Click anywhere in the worksheet window to close the Name Box list.

You’re ready to create a Scenario Summary report.
5. Select Tools → Scenarios from the menu and click the Summary button.

The Scenario Summary dialog box appears, as shown in Figure 12-5. You can create two types of reports:

- **Scenario summary**: Creates a report that lists your scenarios with their input values and the resulting cells. Use this report only when your model has one set of changing cells provided by a single user.
- **Scenario PivotTable**: Creates a PivotTable report that gives you an instant what-if analysis of your scenarios. Use this type of report when your model has multiple sets of changing cells provided by more than one user.

You will use the Scenario summary report, and it is the default option.

6. **Verify that the Scenario summary report is selected, double-click the Results cells text box, if necessary, then select the cell range D4:F4.**

The Results Cells (Monthly Payment, Total Payment, and Interest Paid) are the cells that are affected by the Changing Cells (Amount, Term, and Interest.)

7. **Click OK.**

The Scenario Summary dialog box closes, and Excel creates a scenario summary report on a new sheet in the workbook, as shown in Figure 12-6. Excel displays the report in outline mode so that you can show or hide the report details.

8. **Click the Mortgage tab to view the mortgage tab, and then save your work.**

---

**Quick Reference**

To Create a Scenario Summary Report:

1. Make sure you've defined at least two scenarios.
2. Select Tools → Scenarios from the menu.
3. Select the type of report (Scenario summary or Scenario PivotTable.)
4. Specify which cells you want to include in the report.
Lesson 12-3: Using a One and Two-Input Data Table

Another way to get answers to your what-if questions is by using a data table. A data table is a cell range that displays the results of a formula using different values. For example, you could create a data table to calculate loan payments for several interest rates and term lengths. There are two types of data tables:

- **One-input Data Table**: Displays the results of a formula for multiple values of a single input cell. For example, if you have a formula that calculates a loan payment you could create a one-input data table that shows payment amounts for different interest rates.

- **Two-input Data Table**: Displays the results of a formula for multiple values of a two input cell. For example, if you have a formula that calculates a loan payment you could create a two-input data table that shows payment amounts for different interest rates and different term lengths.

We’ll work with both types of data tables in this lesson.

1. **Click cell B7.**
   
The first step in creating a data table is to enter the formula the data table will use. Since you want to calculate the monthly payment of the loan based on different interest rates, you will use the same PMT formula you created in cell D4.
2. Type \(-\text{PMT} \left( \frac{C4}{12}, B4*12, A4 \right)\) and press <Enter>.

Don’t worry about the results of the PMT formula that appear in cell B7. It’s the formula that’s important. Excel will use this formula to calculate values in the data table. The next step in creating your input data table is to enter the inputs (in your case, the interest rates) you want to use in the data table. The cells in this workbook have already been formatted with the correct number formatting, so you can enter the data table inputs.

3. Click cell A8, type 6, press <Enter>, type 6.5, press <Enter>, type 7, press <Enter>, type 7.5, press <Enter>, type 8 and press <Enter>.

You’re ready to have Excel fill in your data table using the different interest rates you just entered in the A column.

4. Select the cell range A7:B12 and select Data → Table from the menu.

The Table dialog box appears, as shown in Figure 12-7. You must specify the location of the input cell in the Row Input Cell or Column Input Cell box. The input cell is the placeholder cell that is referred to in the Table formula—in your case, the Interest rate, which is located in cell C4.

5. Click the Column Input Cell box, click cell C4 (the placeholder for the interest rate in the table formula) and click OK.

Excel fills the table with the results of the table formula with one result for each input value or interest rate.

6. Click cell B8.

Excel has added the formula =TABLE(C4) to the cell. The C4 reference refers to the Input Cell for the formula—in this case, the interest rate. You can also create data tables based on two input variables. For example, you can create a data table that uses the Interest Rate as one input variable (arranged in columns) and the Term as the other input variable (arranged in rows). The structure of a two-input data table is slightly different from that of a one-input data table—the formula has to be where the row and column that contain the input values intersect, in your case, A7. You can’t change a table once it has been created, so you will first have to delete the current table.

7. Select the cell range B8:B12, press <Del> to delete the data table, and then move the formula in B7 to A7 by using either drag and drop or cut and paste.

Now you can enter the different terms as Column Input values.

8. Verify that B7 is the active cell and type 15, <Tab>, 20, <Tab>, 25, <Tab>, 30 and press <Enter>.

Now select the data table range and open the Table dialog box.

9. Select the cell range A7:E12 and select Data → Table from the menu.

The Table dialog box appears. This time you must specify two input cells. The Row Input Cell is placeholder cell that is referred to in the Table formula—in your case, the Term, which is located in cell B4. The Column Input Cell will be the Interest Rate, located in cell C4.

10. Click the Row Input Cell, click cell B4, click the Column Input Cell, click cell C4 and click OK.

Excel computes the table using the Term (B4) as the Row Input Cell and the Interest Rate (C4) as the Column Input cell. Compare your table to the one in Figure 12-9.

11. Save your work.
Lesson 12-4: Understanding Goal Seek

When you know the desired result of a single formula, but not the value the formula needs for the result, you can use the Goal Seek feature. For example, you can afford a $1,200 monthly payment, so how much of a loan can you take out? When goal seeking, Excel plugs in different values into a cell until it finds one that works.

1. Select cell D4.
   You want to know what the maximum 20-year mortgage you can afford if the interest rate is 7% and the maximum monthly payments you can make are $1,200. Cell D4, the Monthly Payment, is the formula cell for the Goal Seek command you will change its value to find a specific goal. You don’t necessarily have to select the formula cell before using the Goal Seek command, but it saves you a step later on.

2. Select Tools → Goal Seek from the menu.
   The Goal Seek dialog box appears, as shown in Figure 12-10. To find any goal you must specify three things:
   - **Set cell**: The cell that contains the formula you want to find a solution for, in your case the monthly payments value, in cell D4.
   - **To Value**: This is the target number you want to solve for, in your case the maximum monthly payment you are able to make, $1,200.
   - **By changing cell**: This is the cell that contains the value you want to change to solve for the target value, in your case the mortgage amount, in cell A4.

3. Verify that D4 appears in the Set cell box.
   Remember that the set cell contains the formula you want to find a solution for—the monthly payments formula. In the next step you’ll enter the goal: the maximum monthly payment you are able to make.

4. Click the To value box and type 1200.
   The last step in using Goal Seek is specifying what cell will change in order to reach the solution: the mortgage amount.
5. Click the **By changing cell** box and click cell **A4**.
   You're ready to use Goal Seek to find what the maximum 20-year, 7% interest rate mortgage you can take out with monthly payments of $1,200.

6. **Click OK**.
   The Goal Seek Status dialog box appears with the message “Goal Seeking with Cell D4 found a solution” and displays the solution in the worksheet window, as shown in Figure 12-11. You discover the maximum mortgage you can afford, based on a 20-year term and 7% interest rate, would be $154,779. You can click OK to accept the new worksheet values found by Goal Seek, or click Cancel to return the original worksheet values. You decide to keep the values Goal Seek found.

7. **Click OK**.
   The Goal Seek dialog box closes and changes the worksheet values.

8. **Save your work and close the current workbook**.
   Super! You’re almost done with the What-If Analysis chapter—just one more lesson…. 

---

**Quick Reference**

**To Use Goal Seek:**

1. Open or create a workbook that uses the formulas you want to use.

2. Select **Tools → Goal Seek** from the menu.

3. Complete the Goal Seek dialog box by specifying which formula cell to change, the value to change it to, and the cell to change.

4. Click **OK**.

5. Click **OK** to replace the original value or click **Cancel** to keep the original value.
Lesson 12-5: Using Solver

Goal Seek works great for problems that have a single variable and an exact target value, but not for complex problems that have several variables and/or a range of values. For these more complex problems, you need to use Excel’s Solver command. The Solver can perform advanced what-if analysis problems with many variable cells. You can also specify constraints, or conditions that must be met to solve the problem.

If the Solver seems especially difficult to you, you’re not alone. The Solver is one of the most advanced and complicated features in Excel.

1. **Open the workbook named Lesson 12B.**
   This worksheet contains the problem you’re faced with. Imagine you’ve been put in charge of a annual mailing campaign for existing clients in five states. Your boss has given you the following budget constraints:
   - Your total budget is $35,000.
   - You must spend at least 50% of the budget on Minnesota mailings.
   - At least 3 mailings must go out in each state.
   Based on this information, your job is to find out how many mailings you can send out to the clients in each state. Yikes! It’s the math problem from hell! Luckily, you can use Excel’s Solver to help you find the answer to this problem.

2. **Select Tools → Solver from the menu.**
   The Solver Parameter dialog box appears, as shown in Figure 12-12. First, you need to specify the goal or target you want to solve. For this lesson, you want to minimize your total mailing cost—the value in cell F7.

3. **Make sure the insertion point is the Set Target Cell box and click cell F7.**
   $F7$ appears in the Set Target Cell box. Next, you want Solver to set the target cell (the total cost) to the lowest value possible.
4. **Click the Min option.**
   For other problems, you might want to find the highest possible value by selecting the Max option. Or you might want Solver to find a solution that makes the target cell equal to a certain value by selecting the Value option and entering the value.
   Next, you need to specify which cells will change in order to reach the solution—the number of mailings per state.

5. **Click the By Changing Cells box, clear any previous contents, and select cells E2:E6.**
   Now you’re ready to specify the constraints Solver has to work with.

6. **Click the Add button.**
   The Add Constraint dialog box appears, as shown in Figure 12-14. Start by adding the constraint that the total mailing cost cannot exceed the $35,000 budget.

7. **Click the Cell Reference box, select cell F7 (the Total Cost cell), select <=, click the Constraint box and type 35000.**
   Compare your Add Constraint dialog box with the one in Figure 12-14. The next constraint you need to add is that 50% of the total amount must be spent in Minnesota.

8. **Click Add, click the Cell Reference box, select cell F2 (Minnesota’s Total Cost), select >=, click the Constraint box and type * .5.**
   $F7*.5 should be displayed in the constraint box. Next, add a constraint so at least 3 mailings must be sent in each state.

9. **Click Add, click the Cell Reference box, select the cell range E2:E6 (the Number of Mailings), select >=, click the Constraint box and type 3.**
   Finally, you need to add a constraint to specify that the number of mailings is restricted to whole numbers (otherwise, Solver will use numbers with decimal places.)

10. **Click Add, click the Cell Reference box, select the cell range E2:E6 (the Number of Mailings) and select int.**
    That’s it! You’ve finished adding all the constraints.

11. **Click OK.**
    The Add Constraint dialog box closes and you return to the Solver Parameter dialog box. Let’s see if the Solver can find a solution for this perplexing problem.

12. **Click Solve.**
    Excel analyzes the problem and plugs trial values into the variable cells, and tests the results. After a moment the Solver Results dialog box appears, indicating that Solver succeeding in finding a solution to how many mailings you can afford to sent out to each state, while meeting all the constraints, as shown in Figure 12-15.
    You have several choices here. You can keep the values from the Solver solutions, you can return the original values, or you can create one of three types of detailed reports on a separate worksheet that summarize Solver’s answer.

13. **Make sure the Keep Solver Solutions option is selected and click OK.**
    The dialog box closes and the solution values appear in the worksheet. You’ve successfully found the best combination of mailings by state using Solver. The settings you entered in Solver will be saved with the workbook, so you can easily come back to them.

14. **Save your work and exit Microsoft Excel.**

You have to be very precise when using the Solver. If you don’t specify the proper constraint, Solver won’t be able to find a solution to your problem (if there indeed is a solution) or else may return invalid data.

---

**Quick Reference**

To Install Solver:
- Solver is an optional Excel add-on. If you can’t find Solver under the Tools menu you can install it by selecting Tools → Add Ins from the menu, selecting the Solver Add-in and clicking OK.

To Use Solver:
1. Open or create a workbook that contains the problem you want to solve, and then select Tools → Solver from the menu.
2. Specify the goal or target you want to solve for in the Set Target Cell box.
3. Specify Max, Min, or Equal to, then specify the cells that need to change to meet your goal in the By Changing Cells box.
4. Add your constraints by clicking Add and then specifying the constraints (repeat for as many constraints as you need).
5. Click Solve.
Chapter Twelve Review

Lesson Summary

Defining a Scenario

- A scenario is a set of values you use in what-if analysis, such as various interest rates, loan amounts, and terms for a mortgage. You can save and then easily display these values once you have saved them in a scenario.

  - **To Create a Scenario:** Create or open a worksheet that contains the results of one or more formulas. Select **Tools → Scenarios** from the menu and click the **Add** button to add a new scenario. Complete the Add Scenario dialog box giving the scenario a name and identifying the “changing cells” (the cells that contain the values you want to change) and click **OK**. Click the **Add** button and enter the name and changing cells for each additional scenario.

  - **To View a Scenario:** Select **Tools → Scenarios** from the menu, select the scenario from the list and click **Show**.

Creating a Scenario Summary Report

- A scenario summary report is a single compiled report that summarizes the results from several scenarios.

  - **To Create a Scenario Summary Report:** Make sure you’ve defined at least two scenarios and select **Tools → Scenarios** from the menu. Select the type of report you want (Scenario summary or Scenario PivotTable) and which cells you want to include in the report.

Using a One and Two-Input Data Table

- A Data Table displays the results of a formula using different values. A One-Input Data Table displays the results of a formula for multiple values of a single input cell, while a Two-Input Data Table displays the results of a formula for multiple values of a two input cells.

  - **To Create a One-Input Table:** Type the list of values you want to substitute in the input cell down one column. Type the formula in the row above the first value and one cell to the left of the column of values. Select the substitute cell range and select **Data → Table** from the menu. Select the worksheet cell you want to use as the input value and click **OK**.

  - **To Create a Two-Input Table:** In a cell on the worksheet, enter the formula that refers to the two input cells. Type one list of input values in the same column, below the formula and type the second list in the same row, to the right of the formula. Select the range of cells that contains the formula and both the row and column of values and select **Data → Table** from the menu. Select the **Row input cell** and the **Column input cell** and click **OK**.

Understanding Goal Seek

- When you know what the result of a single formula should be but not the value the formula needs to determine the result, you can use the Goal Seek feature.
• **To Use Goal Seek:** Open or create a workbook that uses the formulas you want to use and select **Tools → Goal Seek** from the menu. Complete the Goal Seek dialog box by specifying which formula cell to change, the value to change it to, and the cell to change.

**Using Solver**

• Use Solver to find solutions to complex what-if problems that have multiple variables and a range of values.

• Solver is an optional Excel add-on. If you can’t find Solver under the Tools menu you can install it by selecting **Tools → Add Ins** from the menu, selecting the **Solver Add-in** and clicking **OK**.

• **To Use Solver:** Open or create a workbook that contains the problem you want to solve, and then select **Tools → Solver** from the menu. Specify the goal or target you want to solve for in the **Set Target Cell** box, then specify the **Max**, **Min**, or **Equal to**. Open and specify the cells that need to change to meet your goal in the **By Changing Cells** box. Add your constraints by clicking **Add** and then specifying the constraints (repeat for as many constraints as you need.) Click **Solve** when you’ve finished setting up the problem.

**Quiz**

1. **Which of following is NOT one of Excel’s What-If functions?**
   A. Scenario Manager.
   B. Solver.
   C. Goal Seek.
   D. Auto Outline.

2. **Which of the following statements is NOT true?**
   A. The Scenario Manager lets you save several sets of values or scenarios to use in what-if analysis.
   B. You must specify the cells that change in a scenario.
   C. You must specify the target cell in a scenario.
   D. The Scenario Manager is located under **Tools → Scenarios**.

3. **After carefully considering your budget, you decide the maximum monthly payment you can afford is $500 on a three-year loan. Based on this information, which feature would be the fastest and easiest way to determine how much of a loan you can take out?**
   A. Goal Seek.
   B. Solver.
   C. Scenario Manager.
   D. A Two-Input Data Table.
4. Solver can find solutions to problems with multiple variables, constraints, and ranges of values. (True or False?)

5. Which of the following is NOT information you can specify using the Solver? (Select all that apply.)
   A. Target cell.
   B. Changing cells.
   C. Constraints.
   D. Input cells.

Homework

1. Open the Homework 12 workbook and save it as “What-If Practice”.
2. Click the Car Loan sheet tab. Select the cell range B3:B5 (the changing cells) and select Tools → Scenarios from the menu.
3. Click Add and name the scenario “Original Loan Term.” Save the scenario with the original values.
4. Click Add and name the scenario “9 Percent, 36 Months.” Save the scenario with a $25,000 loan amount, .09% interest rate, and 36 months.
5. Practice switching between the two scenarios by selecting Tools → Scenarios from the menu, selecting a scenario, and clicking View.
6. Create a Scenario Summary report for the worksheet.
7. Click cell B11, type =B7 and press <Enter>.
8. Setup a one-input data table as follows:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>$610.32</td>
</tr>
<tr>
<td>12</td>
<td>0.08</td>
</tr>
<tr>
<td>13</td>
<td>0.08</td>
</tr>
<tr>
<td>14</td>
<td>0.09</td>
</tr>
<tr>
<td>15</td>
<td>0.09</td>
</tr>
</tbody>
</table>

8. Select Data → Table from the menu and select cell B4 as the Column input cell. Your results should be:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>$610.32</td>
</tr>
<tr>
<td>12</td>
<td>0.08</td>
</tr>
<tr>
<td>13</td>
<td>0.08</td>
</tr>
<tr>
<td>14</td>
<td>0.09</td>
</tr>
<tr>
<td>15</td>
<td>0.09</td>
</tr>
</tbody>
</table>

9. Click cell B7 and select Tools → Goal Seek from the menu. Use Goal Seek to find the maximum car loan you can take out (cell B3) if you can afford an $800 monthly payment.

Extra Credit: Click the Solver sheet tab. Use Solver to find a solution to the specified problem. The target cells, changing cells, and constraints are all color-coded to make it a little easier for you.
Quiz Answers

1. D. The auto outline feature has nothing to do with what-if analysis.
2. C. Goal Seek and the Solver have target cells, but not scenarios.
3. A. Actually, you could use any of the other methods to eventually find the answer, but Goal Seek would be the fastest and easiest in this instance.
4. True.
5. D. Input Tables require Input cells, not Solver.
Chapter Thirteen: Advanced Topics

Chapter Objectives:

• Add, Remove, and Position Toolbars
• Create a Custom Toolbar
• Create a Custom AutoFill List
• Password Protect a Workbook
• Change Excel's Default Options
• Find a File
• View and Change a File’s Properties
• Share a Workbook for Group Collaboration
• Revise a Shared Workbook

Chapter Task: Learn how to customize Microsoft Excel

You can customize Excel in a number of ways to meet your own individual needs and tastes. This chapter explains how you can tailor Excel to work the way you do. You are already familiar with toolbars and how they make it easy to access frequently used commands. In this chapter, you will get to create your own toolbar and add the commands you use the most frequently to it. This chapter also explains how to create your own custom AutoFill lists.

Another topic covered in this chapter is workbook collaboration. Like it or not, if you’re part of the corporate world, someday you will have to create a workbook as part of a team. For example, you might create a workbook and then have your manager review it and make changes. Then you go back to the workbook, make the changes, and send it off to its final destination. The folks at Microsoft realized that people sometimes work together when they create workbooks, so they included several features that enable several users to collaborate to create and update workbooks. This chapter explains how you can share a workbook so that several users can work on it, and how you can track, review, and then accept or reject any changes made to the shared workbook.
Lesson 13-1: Hiding, Displaying, and Moving Toolbars

When you first start Excel, two toolbars—Standard and Formatting—appear by default. As you work with Excel, you may want to display other toolbars, such as the Drawing toolbar or the Chart toolbar, to help you accomplish your tasks. Soon, your screen is covered with more buttons than NASA’s mission control room. This lesson explains how to remove all that clutter by moving Excel’s toolbars to different positions on the screen or by removing them all together.

1. **Select View → Toolbars from the menu.**
   A list of available toolbars appears, as shown in Figure 13-1. Notice check marks appear next to the Standard and Formatting toolbars: This indicates the toolbars are already selected and appear on the Excel screen.

2. **Select Formatting from the toolbar menu.**
   The Formatting toolbar disappears. You can hide a toolbar if you don’t need to use any of its commands or if you need to make more room available on the screen to view a document.

3. **Select View → Toolbars → Formatting from the menu.**
   The Formatting toolbar reappears. Another way to add and remove toolbars is right-click anywhere on a toolbar or menu.

4. **Right-click either the Standard toolbar or the Formatting toolbar.**
   A shortcut menu appears with the names of available toolbars.

**Other Ways to Hide or Display a Toolbar:**
- Right-click any toolbar and select the toolbar you want to hide or display from the shortcut menu.
5. **Click** Drawing **from the Toolbar shortcut menu.**
   The Drawing toolbar appears along the bottom of the Excel screen (unless someone has previously moved it). You can view as many toolbars as you want; however, the more toolbars you display, the less of the document window you will be able to see.

6. **Move the pointer to the move handle, , at the far left side of the Drawing toolbar. Click and drag the toolbar to the middle of the screen, then release the mouse button.**
   The Drawing toolbar is torn from the bottom of the screen and floats in the middle of the document window. Notice a title bar appears above the Drawing toolbar. You can move a floating toolbar by clicking its title bar and dragging it to a new position. If you drag a floating toolbar to the edge of the program window, it becomes a docked toolbar.

7. **Click the Drawing toolbar’s title bar and drag the toolbar down until it docks with to the bottom of the screen.**
   The Drawing toolbar is reattached to the bottom of the Excel screen.

8. **Right-click any of the toolbars and select Drawing from the Toolbar shortcut menu.**
   The Drawing toolbar disappears.

---

**Quick Reference**

**To View or Hide a Toolbar:**
- Select **View → Toolbars** from the menu and select the toolbar you want to display or hide.

Or...
- Right-click any toolbar or menu and select the toolbar you want to display or hide from the shortcut menu.

**To Move a Toolbar to a New Location:**
- Drag the toolbar by its move handle (if the toolbar is docked) or title bar (if the toolbar is floating) to the desired location.
Lesson 13-2: Customizing Excel’s Toolbars

The purpose of Excel’s toolbars is to provide buttons for the commands you use most frequently. If Excel’s built-in toolbars don’t contain enough of your frequently used commands, you can modify Excel’s toolbars by adding or deleting their buttons. If that weren’t enough, you can even create your own custom toolbar.

In this lesson, you will learn how to modify Excel’s toolbars.
1. **Select View → Toolbars → Customize from the menu.**
   The Customize dialog box appears, as shown in Figure 13-3. You can select toolbars you want to view or create a new custom toolbar in this dialog box.

2. **Click the Commands tab.**
   The Commands tab appears in front of the Customize dialog box, as shown in Figure 13-5. Here you select the buttons and commands you want to appear on your toolbar. The commands are organized by categories just like Excel’s menus.

3. **In the Categories list, scroll to and click the Actions category.**
   Notice the Commands list is updated to display all the available commands in the “Actions” category.

4. **In the Categories list, scroll to and click the Insert category.**
   Notice the Commands list is updated to display all the available commands in the “Insert” category.

5. **In the Commands list, scroll to the WordArt button and drag it to the end of the Standard toolbar, as shown in Figure 13-3.**
   The WordArt button appears in the Standard toolbar.
   It’s easy to change the image or text that appear on any toolbar button. Here’s how:

6. **Right-click the WordArt button on the toolbar and select Change Button Image → as shown in Figure 13-4.**
   You’re finished modifying the toolbar!

7. **Click Close to close the Customize dialog box.**
   Notice the icons appears on the new WordArt button on the Standard toolbar. When you no longer need a toolbar button, you can remove it. Here’s how.

8. **Select View → Toolbars → Customize from the menu.**
   The Customize dialog box appears. To remove a button, simply drag it off the toolbar.

9. **Click and drag the WordArt button off the toolbar.**
   Move on to the next step and close the Customize dialog box.

10. **Click Close to close the Customize dialog box.**
    Adding your frequently used commands to the toolbar is one of the most effective ways you can make Microsoft Excel more enjoyable and faster to use.

---

Quick Reference

**To Add a Button to a Toolbar:**
1. Select View → Toolbars → Customize from the menu.
   Or…
   Right-click any toolbar and select Customize from the shortcut menu.
2. Click the Commands tab.
3. Select the command category from the Categories list, and then find the desired command in the Commands list and drag the command onto the toolbar.

**To Change a Button’s Text or Image:**
1. Select View → Toolbars → Customize from the menu.
   Or…
   Right-click any toolbar and select Customize from the shortcut menu.
2. Right-click the button and modify the text and/or image using the shortcut menu options.
Lesson 13-3: Creating a Custom AutoFill List

You’re already familiar with Excel’s AutoFill feature. It’s the nifty function that automatically enters a series of values. If you find yourself typing the same list of words frequently, you can save yourself a lot of time by creating a custom AutoFill list. Once you have created a custom AutoFill list all you have to do is type the first entry of the list in a cell and the use AutoFill to have Excel complete the rest of the list for you.

1. Click cell A1 and type Monday.
   For a quick refresher, we’ll use AutoFill to enter the remaining days of the week.

2. Position the pointer over the fill handle of cell A1, until it changes to a ⊕, then click and hold the mouse and drag the fill handle down to cell A7, then release the mouse button.
   AutoFill completes the series, entering the days of the week in the selected cell range.

3. Close the current workbook (you don’t need to save it) and open the workbook named Lesson 13A.
   This workbook contains a list you need to type out regularly—the names of the employees in your office. To save time, you decide to add the names to an AutoFill list. To do this you first need to select the information you want to define as an AutoFill list—in this case the employee’s names.
4. Select the cell range A4:A13.
Now that the names are selected, you can add them to a custom AutoFill list.

5. Select Tools → Options from the menu and click the Custom Lists tab.
The Custom Lists tab of the Options dialog box appears, as shown in Figure 13-6. Here you can view or delete the existing AutoFill lists, or add your own. Notice the Import list from cells textbox contains the cell range you selected, A4:A13.

6. Click Import.
The list of employees is added to the Custom lists box, and its contents are displayed in the List entries box. Close the Options dialog box.

7. Click OK.
Test out your new AutoFill list.

8. Click the Sheet2 tab type Brian Smith in cell A1 and then click the Enter button on the Formula bar.

9. Position the pointer over the fill handle of cell A1, until it changes to a †, click and hold the mouse and drag the fill handle down to cell A10 then release the mouse button.
Excel fills the selected range with the list of employees. Now that you know how to create your own custom AutoFill list, you need to delete it.

10. Select Tools → Options, and then click the Custom Lists tab.
The Custom Lists tab of the Options dialog box reappears.

11. Select the list of employees in the Custom lists box and click Delete.
A dialog box appears, asking you to confirm the deletion of the custom list.

12. Click OK to confirm the deletion, then click OK again to close the dialog box.

13. Close the workbook without saving any changes.

Quick Reference
To Create a Custom AutoFill List:
1. Select the cell range that contains the information you want to include in your custom AutoFill list.
2. Select Tools → Options from the menu and click the Custom Lists tab.
3. Click Import and click OK.

To Use an Custom AutoFill List:
1. Enter the first name from the list in a cell.
2. Select the cell you used in Step 1 and click and drag the fill handle to complete the series in the cells you select.
Lesson 13-4: Changing Excel's Options

Microsoft spent a lot of time and research when it decided what the default settings for Excel should be. However, you may find that the default settings don’t always fit your own needs. For example, you might want to change the default folder where Excel saves your workbooks from C:\My Documents to a drive and folder on the network.

This lesson isn’t so much an exercise as it is a reference on how to customize Excel by changing its default settings.

1. **Select Tools → Options from the menu.**
   The Options dialog box appears.

2. **Refer to Table 13-1: The Options Dialog Box Tabs and click each of the tabs shown in the table to familiarize yourself with the Options dialog box. Click OK when you’re finished.**
### Table 13-1: The Options Dialog Box Tabs

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation</td>
<td>Controls how Excel calculates the worksheet—automatically (the default setting) or manually.</td>
</tr>
<tr>
<td>Chart</td>
<td>Determines how Excel plots empty cells in a chart, and if chart tips—names and values—are displayed when you rest the pointer over a data marker.</td>
</tr>
<tr>
<td>Color</td>
<td>Allows you to edit any of the original 56 colors on the color palette to create custom colors.</td>
</tr>
<tr>
<td>Custom Lists</td>
<td>Allows you to view, add, and delete custom AutoFill lists.</td>
</tr>
<tr>
<td>Edit</td>
<td>Allows you to change Excel's editing features, such as whether you can directly edit a cell, where the cell pointer moves when you press &lt;Enter&gt;, and if you want to enable drag and drop or AutoComplete.</td>
</tr>
<tr>
<td>Error Checking</td>
<td>Controls Excel's new background error-checking features.</td>
</tr>
<tr>
<td>General</td>
<td>Allows you to change the default location Excel looks for and saves files, the user name, how many sheets appear in a new workbook, and if the Properties dialog is displayed when saving a workbook.</td>
</tr>
<tr>
<td>International</td>
<td>Allows you to specify international options, such as the currency symbol used in numbers.</td>
</tr>
<tr>
<td>Save</td>
<td>Controls how often Excel automatically saves a workbook recovery file. If your computer hangs (stops responding) or you lose power unexpectedly, Excel opens the AutoRecover file the next time you start Excel.</td>
</tr>
<tr>
<td>Security</td>
<td>Allows you to password protect your workbooks. For you could specify that a user must enter a password to either open or modify a workbook.</td>
</tr>
<tr>
<td>Transition</td>
<td>For users switching to Excel from Lotus 1-2-3. Allows Excel to accept Lotus 1-2-3 commands, navigation keys, and formulas.</td>
</tr>
<tr>
<td>View</td>
<td>Controls whether the Formula bar, Status bar, comments, row and column headers, gridlines, and formulas are displayed.</td>
</tr>
</tbody>
</table>

### Quick Reference

To Change Excel’s Default Options:

- Select **Tools → Options** from the menu, click the appropriate tabs, and make the necessary changes.
Lesson 13-5: Password Protecting a Workbook

If a workbook contains sensitive data you don’t want anyone else to see or modify, you can password protect the workbook, restricting the workbook access to only yourself or those people that know the password. You can assign passwords so that users must enter a password to either open and/or modify a workbook. This lesson will show you how to add a password to a workbook, how to open a password protected workbook, and how to remove a password if you decide a workbook no longer needs to be password protected.

1. **Open the workbook named Lesson 13B and save it as Budget Proposal.**
   
   Here’s how to password protect a workbook.

2. **Select Tools → Options from the menu and click the Security tab.**

   The Options dialog box appears, as shown in Figure 13-12. Here you can assign passwords to your workbook, requiring users to enter a password to either open or modify the workbook. Notice there are two text boxes where you can enter a password:

   - **Password to open:** Adding a password here will require that a user enter the assigned password in order to open the workbook.
   
   - **Password to modify:** Adding a password here will require that a user enter the assigned password in order to modify the workbook.
3. **In the Password to open textbox type flower.**
   Notice the text you type appears as a string of *****’s. This is so someone can’t look over your shoulder and see you type your password.

4. **Click OK.**
   The Confirm Password dialog box appears. You must reenter your password, flower, once more, just in case you mistyped the first time.

5. **Type flower, then click OK.**
   Now you need to save your workbook.

6. **Click the Save button on the Standard toolbar.**
   Excel saves the Budget Proposal workbook.

7. **Close the workbook.**

8. **Select File → 1 Budget Proposal from the recent files list from the menu.**
   The Password dialog box appears, as shown in Figure 13-13. You must enter the correct password, flower, in order to open the workbook. Try entering an incorrect password to see what happens.

9. **Type pencil and then click OK.**
   The Incorrect Password dialog appears. You cannot open a password protected workbook without entering the correct password. A dialog box appears informing you that you have typed an incorrect password.

10. **Click OK to close the Incorrect Password dialog box.**

11. **Select File → 1 Budget Proposal from the recent files list in the menu.**
    The Password dialog box appears. This time enter the correct password.

12. **Type flower and then click OK.**
    The Budget Proposal opens. Removing password protection from a workbook is just as easy as adding it.

    Removing password protection from a workbook is just as easy as adding it.

13. **Select Tools → Options from the menu and click the Security tab.**
    The options dialog box appears.

14. **Delete the ***** in the Password to open textbox, and then click OK.**

15. **Click the Save button on the Standard toolbar.**
    Excel saves the workbook without any password protection.

---

Quick Reference

To Password Protect a Workbook:
1. Select **Tools → Options** from the menu and click the **Security tab**.
2. Type a password in either the **Password to open** or **Password to modify** textbox and click **OK**.

To Remove Password Protection from a Workbook:
- Repeat the above steps, only delete the password from either the **Password to open** or **Password to modify** textbox and click **OK**.
Lesson 13-6: File Properties and Finding a File

We’ll cover two related topics in this lesson. The first topic is File Properties. Information about the size of a workbook, when it was created, when it was last modified, and who created it, can all be found with the File → Properties command. The File Properties dialog box also has custom fields, such as Subject and Category, so you can add your own information to your workbooks. The second topic covered in this lesson is how to find a file. It is just as easy to misplace and lose a file in your computer as it is to misplace your car keys—maybe easier! Luckily, Excel comes with a great Find feature that can track down your lost files. Find can search for a file, even if you can’t remember the its exact name or location.

1. **Verify that the Budget Proposal workbook is open, then select File → Properties from the menu, and click the General tab.**

   The General tab of the Properties dialog box appears. The General tab of the Properties dialog box tracks general information about the file, such as its size, its location, when the file was created, and when it was last accessed or modified.
2. **Click the Summary tab.**
   The Summary tab of the Properties dialog box lets you enter your own information to describe and summarize the file, such as the author, subject, keywords, and category. You can use the information in the Summary tab to help you search for files.

3. **Click the Keywords box, type 1999 Budget Proposal and click OK.**
   Excel saves the summary information and closes the Properties dialog box.

4. **Save your changes and close the workbook.**
   OK let’s move on to how to find a file. Actually the Find feature is part of Windows and can be used to find any type of file—not just those created in Microsoft Excel.

5. **Click the Windows Start button and select Find → Files or Folders.**
   The Find dialog box appears, as shown in Figure 13-16.

6. **Type Budget in the Named box.**
   This will search for any file that contains the word “budget,” such as “1999 Budget Proposal” and “Budget Report.” So, if you only know part of the file name, you can enter the part of the file name that you know.

7. **Navigate to your Practice folder or disk, then click Find Now.**
   A list of files that match the criteria you entered in the File name text box appear in the open dialog box.

8. **Double-click the Budget Proposal file.**
   The Budget Proposal workbook opens in Microsoft Excel.

---

**Quick Reference**

**To View a Workbook’s Properties:**
- Select File → Properties from the menu.

**To Find a Workbook:**
1. Click the Windows Start button and select Find → Files or Folders from the Start menu.
2. Enter the search conditions and where to look on the appropriate tabs: Name & Location, Date, and Advanced.)
3. Click Find Now to start searching for the file(s).
Lesson 13-7: Sharing a Workbook and Tracking Changes

You can share your Excel workbook files with other people, so that you can work on the data collaboratively. Sharing a workbook has several benefits:

- Several people can use the same shared workbook simultaneously.
- Excel keeps track of any changes made to a shared workbook, when they were made, and who made them.
- You can review and accept or reject any changes made to a shared workbook.

This lesson explains how you can share a workbook when you need to collaborate on a project with other people.

1. **Make sure the Budget Proposal workbook is open, select **Tools → Share Workbook from the menu**.**
   The Highlight Changes dialog box appears, as shown in Figure 13-17.

2. **Check the Track changes while editing check box.**
   Checking this checkbox does two things: 1. It shares the workbook, so other users can use it simultaneously, and 2. it tracks any changes made to the workbook.

3. **Click OK.**
   A dialog box appears, informing that Excel must save the workbook in order to share it.
4. **Click OK.**
   Excel saves and shares the Budget Proposal workbook. Notice [Shared] appears after the workbook name in Excel’s title bar, indicating that you are working on a shared workbook.

   That’s all there is to sharing a workbook. If you’re on a network, multiple users can now open and edit the workbook at the same time (normally only one person can open and edit the same file at a time.) Now that the workbook is shared, you or other users can track any changes made to the workbook. The remainder of this lesson and the next lesson will show how you can track changes in a shared workbook. You decide to break up the insurance payment of $5,800 into payments spanning two quarters instead of one. Move on to the next step to make the revisions.

5. **Select cell B7, type 2900, press <Tab> to move to cell C7, type 2900, and press <Enter>.**
   Excel highlights the revisions you made in cell B7 and C7 with tiny blue triangles in the upper left-hand corners of the modified cells, as shown in Figure 13-18. You can review your changes later and accept or reject them.

6. **Move the cell pointer over the revised cell B7.**
   A note appears by the cell listing the revisions made to it.

7. **Click the Save button on the Standard toolbar to save your changes to the shared workbook.**
   You can also make copies of the workbook that you can distribute to reviewers. When you make a copy of a shared workbook, you can later compare, or merge, the copied workbook to the original to review any changes that have been made to the copy. Here’s how you can create a copy of a shared workbook:

8. **Select File → Save As from the menu.**
   The Save As dialog box appears. Save a copy of the shared workbook with a different name.

   **NOTE:** When you make copies of a shared workbook, make sure you give the copies a different name than the original.

9. **Type Revised Budget in the File name text box, and click OK.**
   The “Budget Proposal” workbook is saved with the new name, “Revised Budget,” and the original workbook, “Budget Proposal,” closes. Now that you’re working with a copy of the original workbook (the Revised Budget file) make some revisions to the workbook. You will get a chance to accept or reject the changes in the next lesson.

10. **Click cell B5, type 6000, press <Tab> to move to cell C6, type 6000, and press <Enter>.**
    Remember—now you’re working with the copied workbook “Revised Budget” and not the original “Budget Proposal” workbook. Excel highlights your changes in cell C6.

11. **Click cell A10, type Misc Expenses and press <Enter>.**
    You’re finished making revisions to the Revised Budget workbook, so save your changes and close the workbook.

12. **Save your changes and then close the Revised Budget workbook.**
Lesson 13-8: Merging and Revising a Shared Workbook

Once a shared workbook has been revised, you can review the changes and decide if you want to accept the changes and make them part of the workbook or reject the changes. Revising workbooks using Excel’s revision features can save a lot of time, because you merely have to accept the changes to incorporate them into your workbook instead of manually typing the changes yourself.

You can also compare, or merge, copies made of a shared workbook, and review, accept, and/or reject any changes made.

1. **Open the workbook named Budget Proposal.**
   Budget Proposal is the shared workbook you created in the previous lesson. Display the revisions you made in the previous lesson.

2. **Select Tools → Track changes → Highlight changes from the menu.**
   The Track Changes dialog box appears.
3. Verify that the **When** box is check, then click the **When drop-down list**, select **All** and click **OK**.
   Excel highlights the revisions you made in cells B7 and C7.
   Now that you have the original shared workbook open, you can merge it with the copied workbook, Revised Budget, to review any revisions made to the copy.

4. Select **Tools → Compare and Merge Workbooks** from the menu.
   The Select Files to Merge Into Current Workbook dialog box appears. Here you must select the copy of the shared workbook that you want to compare or merge with the original.

5. Select the **Revised Budget** workbook and click **OK**. Click **OK** if you are prompted to save the shared workbook.
   Excel merges the revisions made into the Revised Budget workbook with the original Budget Proposal workbook, as shown in Figure 13-19.

6. Move the cell pointer over the revised cell **B7**.
   A note appears by the cell with the revisions made to it. To review all the revisions made to a shared workbook and either accept or reject them, select **Tools → Track Changes → Accept or Reject Changes** from the menu.

7. Select **Tools → Track Changes → Accept or Reject Changes** from the menu.
   The Accept or Reject Changes dialog box appears, as shown in Figure 13-20.

8. Make sure the **When** check box is selected and that **Not yet reviewed** appears in the When list box, then click **OK**.
   The Accept or Reject Changes dialog box appears with the first of five changes made to the workbook—changed cell B7 from $5,800.00 to $2,900.00. Accept this change.

9. Click **Accept** to accept the first change, and **Accept** again to accept the second change in the workbook—changed cell C7 from $5,800.00 to $2,900.00.
   After accepting the first two changes made to the workbook, the third change appears—changed cell B5 from $5,000 to $6,000. You decide to reject this change.

10. Click **Reject** to reject the third change, and **Reject** again to reject the fourth change in the workbook—changed cell C5 from $5,000.00 to $6,000.00.
    You decide to accept the fifth change made to the shared workbook—changed cell A10 from “Other Expenses” to Misc. Expenses.”.

11. Click **Accept** to accept the fifth change made to the shared workbook.
    The Accept or Reject Changes dialog box closes, and the revisions you accepted are made to the workbook.

12. Save the Budget Proposal workbook and exit Microsoft Excel.
Lesson 13-9: Using Detect and Repair

It’s a sad fact of life. The more complicated programs get the more that can go wrong with them. Programs sometimes become corrupted and have to be reinstalled in order to make them work right again. Fortunately for you and your network administrator Microsoft has made this process relatively painless with Office XP’s new Detect and Repair feature. Detect and Repair searches for corrupted files and incorrect settings in any Microsoft Office XP applications and then finds and reinstalls the appropriate files.

Should your installation of Microsoft Excel become corrupted or buggy this lesson explains how you can use Detect and Repair to fix the problem.

1. Make sure the Office XP CD is inserted in your computer’s CD-ROM drive or is available through the network.
   If you are connected to a large corporate network hopefully your friendly network administrator will have made the Office XP files available to everyone on the network so that you can use the Office XP detect and repair feature. The only way you can find out if the Office XP installation files are available is to run Detect and Repair.

2. Select Help → Detect and Repair from the menu.
   The Detect and Repair dialog box appears as shown in Figure 13-23. Here we go…

Figure 13-22
Selecting Detect and Repair from the Help menu.

Figure 13-23
The Detect and Repair dialog box.

Figure 13-24
Detect and Repair finds and repairs any errors it finds in the Microsoft Office XP applications.
3. **Click Start.**

If Detect and Repair finds the Office XP installation files it begins looking for and repairing any problems it finds with any Office XP programs. This might be a good time for you to take a coffee break as Detect and Repair takes a long time to fix everything.

Detect and Repair doesn’t only fix problems with Microsoft Word but with all your Microsoft Office XP applications, such as Microsoft Excel and Microsoft PowerPoint.
Chapter Thirteen Review

Lesson Summary

Hiding, Displaying, and Moving Toolbars

- **To View or Hide a Toolbar**: Select View → Toolbars from the menu and select the toolbar you want to display or hide or right-click any toolbar or menu and select the toolbar you want to display or hide from the shortcut menu.

- **To Move a Toolbar to a New Location**: Drag the toolbar by its move handle (if the toolbar is docked) or title bar (if the toolbar is floating) to the desired location.

Customizing Excel's Toolbars

- **To Add a Button to a Toolbar**: Select View → Toolbars → Customize from the menu and click the Commands tab. Select the command category from the Categories list, then find the desired command in the Commands list and drag the command to the toolbar.

- **To Remove a Button from a Toolbar**: Select View → Toolbars → Customize from the menu and drag the button off the toolbar.

Creating a Custom AutoFill List

- **To Create a Custom AutoFill List**: Select the cell range that contains the information you want to include in your custom AutoFill list, select Tools → Options from the menu, click the Custom Lists tab and click Import.

- **To Use an Custom AutoFill List**: Enter the first name from the list in a cell, select that cell, and then click and drag the fill handle to complete the series in the cells you select.

Changing Excel's Options

- You can change Excel's default options by selecting Tools → Options from the menu.

Password Protecting a Workbook

- **To Password Protect a Workbook**: Select Tools → Options from the menu and click the Security tab. Type a password in either the Password to open or Password to modify text box and click OK.

- **To Remove Password Protection from a Workbook**: Repeat the above steps, only delete the password from either the Password to open or Password to modify text box and click OK.

File Properties and Finding a File

- You can view a file's properties (when it was created, by whom, etc.) by selecting File → Properties from the menu.
To Find a Workbook: Click the Start button and select Find → Files or Folders from the Start menu. Enter the search conditions and where to look on the appropriate tabs: Name & Location, Date, and Advanced.) Click Find Now to start searching for the file(s).

Sharing a Workbook and Tracking Changes

- Sharing a workbook allows several users to open and work on it at the same time. It allows you to track, review, and accept or reject any changes made to the workbook.

- To Share a Workbook: Select Tools → Track Changes → Highlight Changes from the menu and click, the Track changes while editing check box.

- If the track changes option is selected, modified cells are highlighted. To view the changes made to a cell position the mouse pointer over cell and wait several seconds.

- You can save copies of a shared workbook by saving the shared workbook with a different name using File → Save As. You can then distribute these copies to other users and later compare or “merge” them with the original to review any changes made to them.

Merging a Revising a Shared Workbook

- To Highlight Changes in a Shared Workbook: Select Tools → Track changes → Highlight changes from the menu, select which changes you want to review (usually Not yet reviewed in the When combo box) and click OK.

- To Accept and/or Reject Revisions: Select Tools → Track Changes → Accept or Reject Changes from the menu, select which changes you want to review (usually Not yet reviewed in the When combo box) and click OK. Click either the Accept Change button or the Reject Change button.

- To Merge Shared Workbooks: Select Tools → Merge Workbooks from the menu and select the file you which to merge with the open workbook.

Using Detect and Repair

- To Use Detect and Repair: Select Help → Detect and Repair from the menu.

Quiz

1. Which of the following statements is NOT true?
   A. You can change the position of a toolbar by dragging it by its move handle (if it’s docked) or title bar (if it’s floating).
   B. You can display a toolbar by selecting View → Toolbars and selecting the toolbar you want to display from the list.
   C. You can display a toolbar by clicking the Toolbar button on the Standard toolbar and selecting the toolbar you want to display from the list.
   D. Toolbars attach or “dock” to the sides of the program window.
2. Which of the following statements is NOT true?
   A. You can customize a toolbar by right-clicking any toolbar or menu and selecting Customize from the shortcut menu.
   B. You can customize a toolbar by selecting View → Toolbars → Customize from the menu.
   C. Once the Customize dialog box is open you can add buttons to a toolbar by double-clicking on the toolbar where you want to insert the button.
   D. The Customize dialog box is open you can add buttons to a toolbar by dragging them from the Commands list onto the toolbar.

3. You can modify Excel’s built-in toolbars, and you can create your own toolbars. (True or False?)

4. To password protect a worksheet, select Tools → Protection and enter the password. (True or False?)

5. Which of the following statements is NOT true?
   A. You can find a workbook by clicking the Windows Start button, selecting Find → Files and folders, entering any part of the workbook’s name in the File name box in the Open dialog box and clicking Find Now.
   B. Selecting File → Properties from the menu displays statistics on a file, such as its size and when it was last saved.
   C. Selecting File → Options from the menu opens the Options dialog box, which contains the default settings for Excel.
   D. You can create your own custom AutoFill lists.

6. Which of the following is NOT an advantage of working with a shared workbook?
   A. Several users can open and work on the workbook simultaneously.
   B. Excel can create a report summarizing all the changes made to the workbook.
   C. You can track, review, accept and/or reject any changes made to the workbook.
   D. You can create a copy of the workbook, distribute it to other users, and then later compare, or merge, the copy with the original to review any changes.

7. How can you track changes made by other users to a workbook?
   A. Select File → Save As from the menu and select Multi-User workbook from the Save as type list.
   B. Select Tools → Track Changes → Highlight Changes from the menu.
   C. Have other users place a Post-It® Note on their monitors by the cells they change.
   D. There’s no way of doing this in Microsoft Excel.

**Homework**

1. Create a new blank workbook.
2. Select Tools → Customize from the menu and click New to create a new toolbar. Name the toolbar “My Commands.”
3. Click the Commands tab, browse through the various Categories and Commands and drag the commands you think you will use frequently onto the new My Commands toolbar.
4. Delete the My Commands toolbar when you’re finished (click the Toolbars tab, select the My Commands toolbar and click Delete).

5. Type some text and numbers into the blank workbook, save it as “Confidential”. Password protect the workbook so that users must enter the password “leaf” to open the workbook.

6. Select Tools → Track Changes → Highlight Changes from the menu.

7. Modify the text and numbers you entered in the workbook—notice how Excel tracks the changes you make.

8. Review the changes you made by selecting Tools → Track Changes → Accept or Reject Changes.

**Quiz Answers**

1. C. There isn’t a toolbar button in Excel.

2. C. Once the Customize dialog box is open you can add buttons to a toolbar by dragging commands from the commands list to the desired location on the toolbar—not by double-clicking.

3. True. You can modify Excel’s existing toolbars and you can create your own custom toolbars.

4. False. Select File → Save As from the menu and click the Options button to password protect a workbook.

5. C. Select Tools → Options from the menu to open the Options dialog box.

6. B. Although you can track any changes made to a shared workbook there isn’t any way of creating a report that summarizes the changes.

7. B. Select Tools → Track Changes → Highlight Changes from the menu to track changes made to a workbook.
Index

A
Access
   exiting ............................................. 55
Access 97, converting from ................... 93
advanced filter ................................... 108
AND criteria ..................................... 80
ascending sort order........................... 102

B
blank
databases ............................................ 68
tables .................................................. 74
blank databases ...................................... 68

C
Caption property ............................... 135
check spelling .................................... 48
close button ....................................... 55
Column Width dialog box ..................... 110
columnar/forms......................................... 83
columns
   adjusting width of .......................... 110
   freezing ......................................... 114
   hiding ........................................... 115
compact, database ............................. 92
converting, Access 97 databases ........... 93
copy
text .................................................... 44
creating
   blank databases ................................ 68
database with the Database Wizard ... 66
creating
   forms using the Form Wizard .......... 82
   queries ......................................... 76
tables ............................................... 70
tables from scratch ......................... 74
criteria .............................................. 106
criteria, examples of .......................... 76
Ctrl key .............................................. 24
cut
text .................................................... 44

D
data entry
   in tables ......................................... 30
data types ....................................... 72, 132
database objects
   managing ........................................ 88
   printing .......................................... 40
Database Wizard .................................. 66
databases
   closing ........................................... 55
   converting ..................................... 93
   creating from scratch ....................... 68
   creating with the Database Wizard ... 66
guidelines for creating ....................... 64
introduction to .................................. 10
objects, description of ...................... 11
opening ............................................. 26
planning ........................................... 64
Datasheet/forms.......................................... 83
Default property ............................... 144
deleting
describing fields in a table ................. 130
records .............................................. 32, 34
descending sort order ......................... 102
Description property ......................... 134
Design View
   for tables ....................................... 72
   queries, creating in ......................... 76
dialog boxes ...................................... 22
drives
displaying properties of ................... 89
properties, displaying ....................... 89
Index

E
editing
records in a table .................................. 32
exit, Axcel program .................................. 55

F
F1 key ................................................... 50
field
Caption property .................................. 135
Description property .......................... 134
properties, description of ......................... 124
Field Size property ............................... 136
fields
adding to a table ................................. 72, 130, 132
AutoNumber ......................................... 73
currency ............................................. 73
data types ........................................... 72, 132
date/time............................................. 73
Default property ................................. 144
deleting from a table .............................. 130
Field Size property ............................... 136
Format property ................................ 138, 140, 142
hyperlink ............................................. 73
indexing .............................................. 126
Input Mask property ............................ 148
lookup lists ......................................... 150
memo .................................................. 73
number ............................................... 73
OLE object .......................................... 73
Required property .............................. 145, 146
text .................................................... 73
Validation Rule property ........................ 146
value lists .......................................... 152
Yes/No.................................................. 73
field management .................................. 90
files
deleting ............................................... 90
renaming ............................................. 90
filter
advanced ............................................. 108
AND/OR criteria .................................. 106
by form ............................................. 106
by selection ........................................ 104
criteria, using .................................... 106
excluding selection ................................ 104
remove ............................................... 104
fonts
formatting in Datasheets ......................... 116
Form Wizard ........................................ 82
format codes ....................................... 140
Format property ................................. 138, 140, 142
formatting
currency fields .................................. 138, 140
date/time fields .................................. 138, 140
fonts in Datasheets ................................ 116
number fields ..................................... 138, 140
text fields ......................................... 142
forms
creating using the Form Wizard .......... 82
data entry ........................................... 34
description of .................................. 34
description of ................................... 114
description of ................................... 114
freezing, columns .................................. 114
g gridlines, formatting ............................ 113
guidelines
for creating a database .......................... 64
H
height, row ............................................. 110
help
Contents tab ........................................ 50
hiding, columns ..................................... 115
I
indexing fields ..................................... 126
Input Mask property ............................ 148
inserting
fields in a table ................................... 130
forms
justified ............................................. 83

J
justified
forms .................................................. 83

K
keyboard ................................................ 24
keystroke shortcuts ............................... 24
Keystroke shortcuts
common shortcuts ............................... 25

L
labels, mailing ...................................... 86
lookup lists
creating ............................................ 150
modifying ......................................... 154

M
macros
description of .................................. 11
magnify
in Print Preview ................................. 40
magnifying
cells and field entries .......................... 54
mailing labels ..................................... 86
managing
database objects .................................. 88
menus
description of ..................................... 17
shortcut menus See shortcut menus

modules
description of ..................................... 11

mouse
right mouse button .............................. 89
right-clicking ..................................... 89

moving
columns ............................................ 112

N
navigation buttons ..................................... 34
new
database from scratch ............................. 68
database, using the Database Wizard .......... 66
table from scratch ..................................... 74
table using the Table Wizard ........................ 70

Office Assistant ..................................... 50
open
database ............................................ 26
reports .................................................... 38
tables .................................................... 30
opening
forms .................................................... 34
queries .................................................... 36

OR criteria ............................................ 80

P
paste
text .................................................... 44
planning
databases ............................................ 64
preview
database objects ..................................... 40
reports .................................................... 38
primary key
setting .................................................... 128
print
advanced options ..................................... 40
database objects ..................................... 40
reports .................................................... 38
Print button ............................................ 41
printing
number of copies ..................................... 41
page range ............................................ 41
properties ............................................ 41
selecting printers ..................................... 41
properties
description of ..................................... 124
Format .................................................... 138, 140, 142
property
Caption .................................................... 135
Default .................................................... 144
Description ............................................ 134
Field Size ............................................ 136
Input Mask ............................................ 148
Required ............................................ 145, 146
Validation Rule ............................................ 146

Q
queries
displaying in Design View ....................... 36
modifying ............................................ 36
queries
AND/OR criteria ..................................... 80
creating ............................................ 76
creating in Design View ............................. 76
criteria .................................................... 76
description of ..................................... 11, 36
modifying ............................................ 78
sorting with ............................................ 79

R
rearranging
columns .................................................... 112
record navigation buttons ......................... 30
records
adding .................................................... 30, 32
deleting .................................................... 32, 34
editing .................................................... 32
navigating ............................................. 30, 34
sorting .................................................... 102
reordering
fields in a table ..................................... 130
repair, database ............................................ 92
report
description ............................................ 11, 27
Report Wizard ............................................ 84
reports
creating using the Report Wizard ............... 84
description of ............................................ 38
opening .................................................... 38
printing .................................................... 38
Required property ..................................... 145, 146
right mouse button ..................................... 89
right-click ............................................. 24
right-clicking ............................................ 89
rows
adjusting height of ..................................... 110

S
screen, Microsoft Access ......................... 16
select
<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>text</td>
<td>42</td>
</tr>
<tr>
<td>select</td>
<td></td>
</tr>
<tr>
<td>records</td>
<td>42</td>
</tr>
<tr>
<td>Selecting</td>
<td></td>
</tr>
<tr>
<td>entire worksheet</td>
<td>110</td>
</tr>
<tr>
<td>shortcut menus</td>
<td>24, 89</td>
</tr>
<tr>
<td>sorting</td>
<td></td>
</tr>
<tr>
<td>queries, using</td>
<td>79</td>
</tr>
<tr>
<td>using queries</td>
<td>79</td>
</tr>
<tr>
<td>using the Sort command</td>
<td>102</td>
</tr>
<tr>
<td>spell check</td>
<td>48</td>
</tr>
<tr>
<td>status bar</td>
<td></td>
</tr>
<tr>
<td>description of</td>
<td>17</td>
</tr>
<tr>
<td>Table Wizard</td>
<td>70</td>
</tr>
<tr>
<td>tables</td>
<td></td>
</tr>
<tr>
<td>creating</td>
<td>70</td>
</tr>
<tr>
<td>creating from scratch</td>
<td>72, 74, 132</td>
</tr>
<tr>
<td>description of</td>
<td>11, 30</td>
</tr>
<tr>
<td>Design View</td>
<td>72</td>
</tr>
<tr>
<td>edit information in</td>
<td></td>
</tr>
<tr>
<td>modifying in Design View</td>
<td>72</td>
</tr>
<tr>
<td>tabular</td>
<td></td>
</tr>
<tr>
<td>forms</td>
<td>83</td>
</tr>
<tr>
<td>text fields</td>
<td></td>
</tr>
<tr>
<td>Format property</td>
<td>142</td>
</tr>
<tr>
<td>title bar</td>
<td></td>
</tr>
<tr>
<td>description of</td>
<td>17</td>
</tr>
<tr>
<td>toolbars</td>
<td></td>
</tr>
<tr>
<td>description of</td>
<td>17</td>
</tr>
<tr>
<td>Toolbars</td>
<td></td>
</tr>
<tr>
<td>adding and removing</td>
<td>21</td>
</tr>
<tr>
<td>moving</td>
<td>21</td>
</tr>
<tr>
<td>undo</td>
<td>46</td>
</tr>
<tr>
<td>Validation Rule property</td>
<td>146</td>
</tr>
<tr>
<td>value lists</td>
<td></td>
</tr>
<tr>
<td>creating</td>
<td>152</td>
</tr>
<tr>
<td>modifying</td>
<td>154</td>
</tr>
<tr>
<td>width, column</td>
<td>110</td>
</tr>
<tr>
<td>windows, working with</td>
<td>28</td>
</tr>
<tr>
<td>Zoom dialog box</td>
<td>54</td>
</tr>
</tbody>
</table>