
Intermediate Microsoft® Excel 2007
Take your Microsoft® Excel skills to the next level! Packed with useful tips on Microsoft Excel for the
intermediate user, this course explains how to get the results you want from Excel formulas and
functions, how to find data more easily with sorts and filters, how to manage multi-sheet workbooks,
how to apply page formatting such as headers and footers, and much more.

Lessons
Microsoft Excel Tutorial: Functions1.
Microsoft Excel offers hundreds of functions; in this lesson, you'll try the most
useful ones and learn how to get help with others you might need. You'll also
explore absolute cell referencing and its role in formula copying.
Microsoft Excel Tutorial: Working with Multiple Worksheets2.
A Microsoft Excel workbook is more than just a single sheet. In this lesson,
you'll go 3-D and learn how to use multiple sheets, name and format sheet tabs,
and create formula and function references to cells on multiple sheets.
Microsoft Excel Tutorial: Finding, Sorting, and Filtering Data3.
Long lists of data can be intimidating, but Microsoft Excel has excellent sorting
and filtering capabilities to help bring that data under control. This Microsoft
Excel tutorial shows you several strategies for finding and organizing data.
Microsoft Excel Tutorial: Advanced Formatting4.
In this lesson, you'll learn powerful formatting skills, such as styles, custom
headers and footers, and conditional formatting, for making your Microsoft Excel
workbooks the best they can be.

Microsoft Excel Tutorial: Functions
Microsoft Excel offers hundreds of functions; in this lesson, you'll try the most useful ones and learn how to get
help with others you might need. You'll also explore absolute cell referencing and its role in formula copying.

 

Welcome to Microsoft Excel 2007!

Welcome! This online training course is suitable for anyone who knows Microsoft®
Excel spreadsheet basics -- especially Microsoft Excel terms and techniques -- and is
ready to learn more. This course will cover key areas like calculation, formatting, data
management, and cell referencing. In this free tutorial, you'll get plenty of training and
tips on Microsoft Excel spreadsheets and pick up some insider techniques not easily
found through Microsoft Excel support channels.

What You Should Already Know

This free tutorial is for anyone who has basic Microsoft Excel skills and a desire to
further his or her education. To do well in this course, you should already know how to
do the following:

Enter and edit text in cells
Add and delete rows, columns, and cells
Change row height and column width
Apply text formatting including different fonts, sizes, and colors
Format cells with borders and shading
Use basic number formatting such as currency and percentage
Create Microsoft Excel formulas and use simple functions like SUM, AVERAGE,
and COUNT

If you don't have these skills, consider taking one or two introductory Excel 2007
classes first. This intermediate course is one in a series of free online courses
designed to help you learn Excel -- from the basics through advanced levels.
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What You'll Learn

This course consists of four lessons with a simple quiz and an assignment for each
lesson. The lessons are as follows:

Lesson 1, "Microsoft Excel Tutorial: Functions": Review the basics of formulas and
functions, learn about absolute referencing, and create several worksheets that
perform useful calculations.
Lesson 2, "Microsoft Excel Tutorial: Working with Multiple Worksheets": Learn how
to work with worksheet names and tabs, manage sheets, create cross-references
between sheets, and protect sheets from changes.
Lesson 3, "Microsoft Excel Tutorial: Finding, Sorting, and Filtering Data": Manage
long lists of data by employing sorting and filtering techniques.
Lesson 4, "Microsoft Excel Tutorial: Advanced Formatting": Learn how to format
"beyond the basics" with formatting styles and themes, conditional formatting,
custom number formats, and custom headers and footers.

Quizzes and assignments are for your learning experience only. Quizzes are
computer-graded, and you may retake a quiz as many times as you like. Assignments
are optional; however, working through the assignments enhances your learning
experience and helps solidify key concepts and techniques for using Microsoft Excel
2007.

Throughout this course, we provide Flash examples. To view these examples, you
need the Adobe Flash Player. Keep an eye out for notes with links that say "See
how to ____" or something similar. Some of these files are very large (10 MB or
so) and may take a while to appear or download if you have a slow connection.

Do I Need Excel 2007?

This course is based on Microsoft Excel 2007, which is very different from earlier
versions in terms of its interface. The Ribbon replaces the traditional menus and
toolbars, so the steps presented in this course won't work for users of earlier Excel
versions. However, the basic concepts are nearly identical; so if you can survive the
interface differences, you can still get some useful information out of the course.

Lesson 1 Overview

This first lesson covers a topic that intimidates a lot of people, but it's an important
topic to know about: formulas and functions. In this lesson, after a brief review of
formula and function basics, you'll learn about date and time functions, absolute
references, named ranges, and the Name Manager. This lesson finishes up by
showing you how to create a checkbook register. Now you can get started.
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Reviewing Formulas and Functions

A formula is an equation that begins with an equal sign. It can include cell references,
fixed numbers, and math operators for addition (+), subtraction ( - ), multiplication (*),
division (/), and exponentiation (^).

Here are some examples of simple formulas:

=B2
=B2+5
=B2/B1

When a formula contains more than one math operator, operations are performed in
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the same order as in regular math. Exponentiation is done first, then multiplication and
division, and finally addition and subtraction. If you want to change that order, put the
parts that should be done first in parentheses. For example:

=(B1+B2)/6
=(B1*B2)^2
=10*((B1+B2) -- (B3+B4))

A function is a math operation (or group of operations) that has a textual name, such
as SUM or AVERAGE. Functions have two main advantages. One advantage is that
they enable Excel to perform complicated math operations more simply. For example,
using the AVERAGE function is much easier than summing all the values, counting
the values, and then dividing the sum by the count. The other advantage is that you
can operate upon ranges of cells, such as the range A1:A100, rather than listing each
cell individually as you must do in a normal formula.

Examples of functions include the following:

=MAX(A1:A100)
=COUNT(B1:B10)
=SUM(K50:K55)

The parameters of a function are called arguments. Each function name is followed by
parentheses, which contain its arguments. Even functions that require no arguments
must still have the parentheses after the name, as in =TODAY().

The examples shown here have one argument per function -- the range on which the
operation should operate. Other functions have multiple arguments. Some are
required, some are optional. When a function has more than one argument, they're
separated within the parentheses by commas.

Examples of functions that have multiple arguments include the following:

=PMT(.05,60,2000)
=ROUNDUP(A2,0)

If you don't know which arguments to use for a particular function, don't panic. In the
next section, you'll learn how to find them.
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Getting Help with Functions

As you get proficient with Excel, you'll start to remember the arguments that each
function needs and the order in which they should appear, so you can type them
directly into the cell. However, until that day comes, you'll find Excel's function help to
be a great benefit.

First, which function do you want? You can browse the available functions by category
from the Function Library on the Formulas tab. Click a category in the Function Library
group to view a drop-down list of functions, as shown in Figure 1-1.
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Figure 1-1: Browse functions by category.

Another way to find the function you want is to open the Insert Function dialog box.
You can do this by clicking the Insert Function button either on the formula bar or on
the Formulas tab. Then type a description of what you want to do and click Go; Excel
suggests a function that'll do it.

To try this out, follow these steps in a blank workbook:

Download the file Int-Practice1.xls, and then open it in Excel. Figure 1-2 shows1.
the practice file.

Figure 1-2: Int-Practice1.xls.

This course uses Microsoft Excel 97-2003 format files, so students using earlier
versions can participate. These files open in Excel 2007 with no problems. To
download a file, click the hyperlink. You might need to respond to a security
warning in your browser. If clicking the hyperlink doesn't work, right-click the
hyperlink and select Save Target As.
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Select cell B6, and then click the Insert Function button, either on the formula1.
bar or on the Formulas tab.
In the Search for a function text box, type payment and click Go. A list of2.
functions involving payments appears, as shown in Figure 1-3.

Figure 1-3: Find a function by typing a description.

On the Select a function list, scroll down and view the functions. Select several1.
functions and read the descriptions that appear below the list.
Select PMT, and then click OK. The Function Arguments dialog box opens.2.
Here's where you can fill in the required and optional arguments for the
function. The required ones are bold; the optional ones are not.
For the Rate, enter D3.3.
For the Nper (number of periods), enter B5.4.
For the Pv (present value), you could enter B4, but try this alternate method as5.
an experiment. Click the button with the small red arrow on it next to the Pv
box. The Function Arguments dialog box collapses, so you can see more of the
sheet. Drag that box out of the way if needed and select cell B4. Then press
Enter to return to the Function Arguments dialog box. Figure 1-4 shows the
dialog box with the fields filled in.

Figure 1-4: Fill in the arguments for the function.

Enlarge image

Click OK. The payment amount, $191.01, shows in cell B6. It's red and in1.
parentheses, meaning it's a negative number.
Save your work. Leave the file open; you'll continue working with it later.2.

Next, you'll learn how Microsoft Excel provides function help even when you're
manually typing a function into a cell, and you'll learn how to nest one function inside
another.

 

Getting Help While Typing a Function
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After you've used Insert Function a few times for a certain function, you'll probably be
able to type the arguments into the cell from memory. However, in case your mind
goes blank as you're typing, Excel provides ScreenTips under the cell to remind you
of the arguments. For example, Figure 1-5 starts the PMT function, and Excel displays
the three required arguments plus two optional ones (bracketed). The bold argument
is the one you should type now. After you type that one and a comma, the next one
becomes bold.

Figure 1-5: Refer to the ScreenTip as you type the arguments for a function.

Nesting One Function in Another

You might want to nest one function inside another. To do so, put one function inside
the other function's parentheses, omitting the equal sign for the inner function.

For example, in the steps in the preceding section, you ended up with this function in
cell B6:

=PMT(D3,B5,B4)

The result is negative. If you want it to appear as a positive number, nest it in an
=ABS function, which calculates the absolute value of a number. To do this, change
the content of cell B6 to

=ABS(PMT(D3,B5,B4))

Further, suppose you want to round up the payment amount to the nearest whole
dollar. You can use the ROUNDUP function for that, encasing the previous function in
it like this:

=ROUNDUP(ABS(PMT(D3,B5,B4)),0)

Try it now:

In Int-Practice1.xls, select cell B6.1.
In the formula bar, edit the function to read:2.

=ROUNDUP(ABS(PMT(D3,B5,B4)),0)

Save your work and leave the file open for later.1.

The ROUNDUP function requires two arguments: the number to be rounded, and
the number of decimal places. That's why a comma and a 0 are near the end of
the preceding example. Commas separate one argument from another in a multi-
argument function. The ABS(PMT(D3,B5,B4)) represents the first argument, and 0
represents the second argument.

You'll learn how Excel works with dates and times in formulas and functions in the
next section.
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Working with Dates and Times

In Excel, dates are numbers. Even though they might look like dates, behind the
scenes they're simple numeric values. To see this for yourself, start a new blank
workbook and try the following:

In a new worksheet, enter 01/15/1900 in cell A1.1.
Change the cell's number formatting to General. (On the Home tab, in the2.
Number group, open the Number Format list, and then select General.) The
value changes to 15.

When you enter a date, Excel silently converts it to a number that represents the
number of days between that date and January 1, 1900. In this case, there are 15
days, so the value is 15. It formats the number with the Date format, so you can
continue thinking of it as a date, but Excel has already converted it to a number.

Now continue the experiment:

Change the number format of cell A1 to Short Date (again, from the Home tab1.
in the Number group).
Enter 1000 in cell A2. It appears as a normal number.2.
Use Format Painter (the paintbrush tool on the Home tab, Clipboard group) to3.
copy the formatting from cell A1 to A2. A2's value now appears as a date:
09/26/1902.
In cell A3, enter this formula: =A2-A1. The result is 985, which is the number of4.
days between the two dates. (If a date appears here instead, change the cell's
number format to General.)
Close this workbook and don't save your changes to it.5.

Using the NOW and TODAY Functions

Two functions are available for displaying the current date and time in a worksheet:

=NOW() returns the current date and time.
=TODAY() returns the current date (not the time).

Neither of these functions takes any argument, so you just put blank parentheses after
them. These functions are useful for creating automatically updated dates for
worksheets that you frequently revisit and update.

Try out the TODAY function in the example worksheet, using its value to perform a
calculation. In Int-Practice1.xls, type the following text:

In cell A8, type Today's Date:1.
In cell A9, type Rate Valid Until:2.
In cell B8, type =TODAY()3.
In cell B9, type =B8+304.

The result in cell B9 should be a date 30 days after the current date in cell B8. If the
result in cell B9 doesn't automatically format itself as a date, set its number format to
Short Date.

Some spreadsheet programs, including some very old versions of Excel, show
dates in relation to January 2, 1904, instead of January 1, 1900. If you open such
a worksheet in a modern version of Excel, all the dates appear to be off. You can
correct this by clicking the Microsoft Office Button, and then clicking Excel
Options. Select Advanced in the left pane, and in the When calculating this
workbook section, check the Use 1904 date system check box.
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Next up, you'll learn about Excel's relative and absolute referencing of cells, which
makes a difference when you copy formulas and functions from one cell to another.

 

Copying Formulas and Working with Absolute References

Usually, when you copy a formula that contains cell references, Excel adjusts those
references to refer to cells that are relative to the new location. For example, suppose
you have this formula in cell C5:

=A5+B5

This formula essentially means "sum the values in the two cells immediately to the
left." Therefore, if you copy this formula to cell N8, it becomes =L8+M8, because
those are the two cells immediately to the left of the new location.

Excel does this as a convenience to you. Usually, when you copy a formula, you don't
want it to be exactly the same as the original; you want it to apply referentially to a
new location. Therefore, the makers of Excel made relative references the default.

The alternative to relative references is absolute references. An absolute reference
doesn't shift when copied. Absolute references are indicated with dollar signs
preceding both the row and the column. For example, to refer absolutely to cell B4,
you type $B$4.

The two dollar signs are required because you might want to use a mixed reference,
which "freezes" just the row or just the column. For example, $B4 freezes only the
column; whereas B$4 freezes only the row. To set up an absolute or mixed reference,
manually type the dollar signs into the formula or function. Or, as a shortcut, after you
click the cell reference, press F4 to cycle through all the available absolute, relative,
and mixed combinations.

Try it.

In the Int-Practice.xls workbook, click the Compare tab. This worksheet1.
calculates what your monthly payment would be if you borrowed various
amounts at a certain loan length and interest rate.
In cell B7, type =ABS(PMT($D$3,$B$4,A7)). Here's a break down of what you2.
just typed there:

The ABS function makes it an absolute value (positive number).
PMT is the function that calculates the payment. It has three required arguments --
Rate, Number of periods, and Present value.
$D$3 is an absolute reference to the cell containing the monthly rate.
$B$4 is an absolute reference to the cell containing the number of periods.
A7 is a relative reference to the cell containing the present value (that is, the loan
amount).

Copy the formula from cell B7 to the cell range B8:B14. (The easiest way is to1.
drag the fill handle, which is the little black square in the lower-right corner of
cell B7 when it is selected.) If you create and copy the function correctly, the
results should match Figure 1-6.
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Figure 1-6: The finished worksheet with absolute and relative references used in the
calculations.

See how to copy formulas and work with absolute references. (1.5 MB file)

In the next section, you'll learn about named ranges, which can take the place of cell
row-and-column references in formulas and functions.

 

Creating Named Ranges

So far in this lesson, you've seen ranges referenced by listing the top-left and bottom-
right cells with a colon between them like this: A1:C12. In most cases, that's the most
efficient way of doing it.

However, if you're going to refer to the same range many times in a worksheet, you
might find it advantageous to name the range. Naming a range assigns a text
reference to it that (presumably) has a logical meaning you'll be more likely to
remember.

For example, cells B1, B2, and B3 are named Goods, Labor, and Price, respectively.
Cell C5 uses these names in the formula in that cell:

=price-(goods+labor)

Figure 1-7 shows how this looks in the worksheet.

Figure 1-7: Cells in the range B1:B3 have been given names, and those names are
used in a formula in cell B4.

You can name a single cell or a range of cells. The process is the same either way:

Select the cell(s).1.
Click the Name box, which is at the left end of the formula bar. (It's where the2.
active cell's row and column reference normally appear.)
Type the name you want to use for the range, and then press Enter.3.
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Named ranges are absolute references by default. A reference to the range does
not change when you copy it to another cell.

Now that you understand the concept, try creating some named ranges yourself.
Follow these steps:

In the Int-Practice1.xls workbook, click the Sales tab.1.
Select the range B2:D2. Click the Name box, and then type Donna.2.
Select the range B3:D3. Click the Name box, and then type Pete.3.
Select the range B4:D4. Click the Name box, and then type Mike.4.
In cell E2, type =SUM(Donna). In cell E3, type =SUM(Pete). In cell E4, type5.
=SUM(Mike).
In cell D5, type Grand Total. Widen column D as needed to make it fit.6.
In cell E5, type =SUM(Donna,Pete,Mike). The finished worksheet should look7.
like Figure 1-8.

Figure 1-8: These functions use range names.

Now you know how to create some basic named ranges. In the next section you'll
learn how to manage those ranges.
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Working with Name Manager

Excel 2007 provides several useful tools for working with range names. They're all
located on the Formulas tab in the Defined Names group.

Using the Name Manager

The Name Manager provides a list of all the named ranges in the workbook, along
with the cell references to which they refer. From there, you can delete any of the
range names, modify a range, and add comments. To open the Name Manager, click
the Name Manager button on the Formulas tab. The Name Manager is shown in
Figure 1-9.

Figure 1-9: The Name Manager makes it easy to view and edit named ranges.
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To practice working with the Name Manager, do the following:

In Int-practice1.xls, on the Sales tab, change cell A2 to Marie.1.
On the Formulas tab, click Name Manager.2.
Click Donna on the list in the Name Manager dialog box.3.
Click Edit. The Edit Name dialog box opens.4.
In the Name box, change Donna to Marie.5.
In the Comment box, type Formerly Donna.6.
Click OK. The range now shows up in the Name Manager as Marie, and the7.
comment appears in the Comment column, as shown in Figure 1-10.

Figure 1-10: Modify a named range in the Edit Name box.

Click Close.1.
Select cell E2, and then notice in the formula bar that the function is now2.
=SUM(Marie), reflecting the new name.

Automatically Creating Named Ranges

You can use the Create from Selection feature in Excel 2007 to automatically create
named ranges based on column or row headings.

To try this out, do the following:

In Int-practice1.xls, on the Sales tab, select cell D5 and press Delete, clearing1.
that cell.
In cell A5, type Total.2.
Select the cell range B1:D4.3.
On the Formulas tab, click Create from Selection. The Create Names from4.
Selection dialog box opens.
Check the Top row check box, and then click OK. Excel creates the following5.
ranges:

Jan: B2:B4

Feb: C2:C4

Mar: D2:D4

In cell B5, type =SUM(Jan). In cell C5, type =SUM(Feb). In cell D5, type1.
=SUM(Mar).
Save your work, and then check it against Figure 1-11.2.
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Figure 1-11: The completed worksheet.

Next you'll practice formula and function usage by creating a checkbook register.

 

Creating a Checkbook Register

Now that you know the basics of formulas and functions in a worksheet, let's look at a
practical example.

Suppose you need a computerized checkbook register. If all you want to do is track
your checkbook balance, you don't need a full-blown financial program; you can use
Excel:

Start a new, blank workbook.1.
On Sheet1, enter the labels shown in Figure 1-12 and format them as bold,2.
underlined, and with a grey-shaded background. Widen the columns as
needed, and then merge and center the My Checkbook label across the top
row. Use the =TODAY() function to show today's date and left-align it. Save
your work as MyCheckbook.xlsx (Excel 2007 format).

Figure 1-12: Create this worksheet to start a checkbook register.

Enlarge image

In the first line of the register (cell E6), enter the opening balance. For this1.
exercise, use $10,000. (It's nice to dream, eh?)
In the next row of the Balance column (cell E7), enter a formula that starts with2.
the previous balance, subtracts any withdrawal in the line, and then adds any
deposit in the line. Can you figure it out?
Just in case, here's the formula:3.

=E6-C7+D7

Copy that formula into the cells directly below it (say, 50 rows or so). The1.
easiest way to do that is with the fill handle, which is the small black square in
the lower-right corner when the cell is selected. Drag the fill handle down so
the formula fills the cells under it, as shown in Figure 1-13. The copies are
relative references, which is what you want here. All the copies read
$10,000.00 at this point because you haven't entered any transactions.
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Figure 1-13: Copy the formula into the rows below using the fill handle.

Enlarge image

Now add a column for the check number. Select the column to the right of1.
where it should appear, and then on the Home tab, click Insert and click Insert
Sheet Columns. In this case, insert the new column between the Date and
Payee columns and label it Chk#.
Now enter a withdrawal transaction in row 7, and a deposit transaction in row2.
8. Don't start with row 6 because that's where the raw opening balance
appears; any transaction entered in that row wouldn't calculate properly.

For example, enter the transactions shown in Figure 1-14.

Figure 1-14: Enter these transactions.

Enlarge image

Now continue working on the checkbook register by completing the following optional
finishing touches:

Add another narrow column in which you can place an R for Reconciled when you
balance your checkbook. You can put it anywhere, but a common placement for
such a column is to the left of the Withdrawal column.
Format all currency cells as Currency with two decimal places.
Shade every other line pale green. To do this, shade one line (row 7), but not the
next line (row 8). Next, select both rows, click Format Painter, and then drag across
the range of cells on which to paint this format.
Apply borders on all sides of all cells in the register's data grid. For example, you
might start at cell A5 and apply the borders to all cells in the range below and to its
right.

Figure 1-15 shows a portion of the finished register.

http://adminivillage.dc.powered.com/workbench/media/ns/11740//Library_Excel2007Int01fg13_large.jpg
http://adminivillage.dc.powered.com/workbench/media/ns/11740//Library_Excel2007Int01fg14_large.jpg


Figure 1-15: The completed register.

Enlarge image

You now have a completed electronic checkbook register that you can save and
modify later.

Moving On

In this lesson, you learned many handy tips and tricks for working with formulas and
functions, and you learned about relative and absolute cell references and how to
create named ranges. In Lesson 2, you'll learn how to work with multiple sheets in a
workbook. You'll create and delete sheets, rename them, change their tab colors, and
create cross-references between sheets. Before you move on, do the assignment and
quiz to make sure you've grasped the key concepts presented in this lesson.

Assignment #1

In this assignment, you'll create the formulas and functions needed to create a working amortization
table for a loan. An amortization table shows how the loan payments are distributed between principal
and interest and tracks the loan balance after each payment.

To complete this assignment:

Download IntExcel07-Assign1.xls, and then open it in Microsoft Excel.1.
Autofill the numbers 1 through 360 in cells A10 through A369. (To do this, enter 1 in cell A10, 22.
in cell A11, and so on through cell A14. Select the range A10:A14, and then drag the fill handle
down.)
In cell D3, enter 6%. Ensure that the cell is formatted as Percentage.3.
In cell D4, enter =D3/12. This formula creates a monthly interest rate out of the yearly one.4.
Apply the Percentage format, with two decimal places shown.
In cell D5, enter 0 and apply the Currency format with two decimal places.5.
In cell D6, enter 200,000 and apply the Currency format with two decimal places. Widen column6.
D if needed.
Apply the Currency format with two decimal places to columns B, E, F, G, and H, plus the range7.
D10:D369.
In cell D7, enter 360. (That's 12 payments a year times 30 years, for a 30-year mortgage.)8.
Apply the General number format to that cell, if necessary.
Create the following range names:9.

D4: Rate, D6: Amount, D7: Length

In cell B10, enter =ABS(PMT(Rate,Length,Amount)). Copy that function to the range1.
B11:B369.
In cell C10, enter the first day of next month. (For example, if it's now October 15, 2007, enter2.
11/01/07.)
In cell C11, enter the next month following the one you just entered. For example, if you entered3.
11/01/07 in cell C10, enter 12/01/07 in cell C11.
Autofill the other dates in the range C12:C369. (To do this, select the range C10:C11, and then4.
drag the fill handle down.)
In cell E10, enter =D6*D4. That formula calculates the interest paid in the first loan payment.5.
In cell D10, enter =B10-E10. That formula calculates the principal paid in the first loan6.
payment.
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Copy the formula from cell D10 to the range D11:D369. Don't worry that the numbers are all the7.
same; they'll change later as you enter other data.
In cell H10, enter =D6-D10-F10-G10. Widen the column, if necessary. This formula calculates8.
the balance of the debt after the payment and after any extra payments you might make.
In G10, enter an absolute reference to cell D5: =$D$5. Copy that formula into G11:G369.9.

So far, the formulas and functions you created for that first payment have referred to the opening
balance. That won't work for the next payments because they should refer to the remaining loan
balance instead. Therefore, you need to set them up separately.

In cell E11, enter a formula that calculates the interest on the current loan balance: =H10*$D$41.
.

Notice that the reference to H10 is relative so that when you copy the formula later, it refers to the
current balances, but the reference to D4 is absolute because that's always where the monthly rate
is.

Copy the formula from E11 to E12:E369.1.
In cell H11, enter a formula that calculates the loan balance after the current payment: =H10-2.
D11-F11-G11, and then copy that formula to H12:H369.

Congratulations -- you've completed the amortization worksheet. It should resemble Figure 1-16 if you
did it correctly.

Figure 1-16: The completed amortization sheet.

Enlarge image

But wait -- there's more. You can use this worksheet to play "what if" with your loan. Try the following:

Enter $100 in cell D5 to find out what would happen if you paid $100 extra each time. Scroll down
and see that you would save more than 60 payments (that's 5 years) if you did that. The row where
the Balance amount turns negative (in parentheses) is the line of the last payment.
Change cell D5 back to $0 and enter $1,000 in cell F10. Scroll down to find out how making a one-
time payment of $1,000 at the beginning of the loan period would decrease the loan length. It
shaves five payments off the end, saving you almost $6,000.
Clear cell F10 again, and then change the interest rate in cell D3 to 5.5% and format the cell for one
decimal place. It doesn't change the loan term, but it does change the amount of each payment.

 

Quiz #1
Question 1:
Which of these is a correctly written formula?
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A)  =(A1:A10)
B)  =SUM(#name#)
C)  =A1+A2+A3+A4
D)  =AVG(A1:A10)
 
Question 2:
Suppose that cell A1 contains 5 and cell A2 contains 2. What would be the answer to the formula =A1+A2*3^2?

A)  23
B)  441
C)  63
D)  41
 
Question 3:
Which of these is an absolute reference to cell A2?

A)  $A2
B)  $A$2
C)  A$2$
D)  A$2
 
Question 4:
If you display the date 1/3/1900 as a General number format, what number will it appear as?

A)  365
B)  2
C)  100
D)  3
 
Question 5:
If the range A2:A6 is assigned the name Wholesale, which of these formulas would correctly calculate the sum
of that range? (Check all that apply.)

A)  =SUM(A2:A6)
B)  =SUM(Wholesale)
C)  =A2+A3+A4+A5+A6
D)  =Wholesale
 

Microsoft Excel Tutorial: Working with Multiple Worksheets
A Microsoft Excel workbook is more than just a single sheet. In this lesson, you'll go 3-D and learn how to use
multiple sheets, name and format sheet tabs, and create formula and function references to cells on multiple
sheets.

 

Naming, Creating, and Deleting Sheets

Welcome back. In Lesson 1, you learned about formulas and functions in a
worksheet. In this lesson, you'll learn how to expand past two-dimensional single
sheets and work with 3-D workbooks containing multiple sheets and references
among them.

A single data file (a workbook) can have many tabbed sheets in it. Each sheet is its
own separate row-and-column grid. By default, a workbook starts out with three
sheets: Sheet1, Sheet2, and Sheet3. You can switch among them by clicking their
tabs in the lower left corner of the Microsoft® Excel window.

Naming a Sheet

You'll probably want to rename the sheets with more descriptive names than Sheet1,
Sheet2, and so on. It's much easier to remember your checkbook register on a tab
named Register than on a tab named Sheet1.
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To rename a tab, double-click the tab to move the insertion point there, and then type
the desired name. You can also right-click the tab and then select Rename.

You can make names as long as they need to be; however, a long name makes the
tab very wide, leaving less room to see other tabs. If you're going to refer to a sheet's
name in a formula on another sheet (called 3-D referencing and covered later in this
lesson), use a short sheet name with no spaces in it. That makes the name easier to
reference.

Adding and Deleting Sheets

To add a sheet, click the Insert Worksheet tab to the right of the existing sheet tabs,
shown in Figure 2-1, or press Shift+F11.

Figure 2-1: Insert Worksheet tab.

It's not necessary to delete the extra blank sheets in a workbook; just ignore them. If
you prefer, you can easily delete unneeded sheets; however, one sheet must remain
in the workbook, so you can't delete the last one standing.

To delete a sheet, right-click its tab, and then select Delete. If anything's on that
sheet, a warning box appears; if the sheet was empty, it just goes away.

Undo doesn't work on sheet deletions. When the sheet is gone, it's gone for good.
If you accidentally delete an important sheet, and you haven't resaved your work
since you opened the workbook, close the file without saving your changes and
then reopen it.

In the next sections, you'll learn more sheet-handling skills.
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Displaying and Arranging Sheets

Now that you know how to create and delete sheets, you'll learn about some sheet-
handling techniques.

Selecting Multiple Sheets at Once

You might want to perform an operation on more than one sheet at a time, such as
deleting multiple sheets. To select multiple sheets, hold down the Ctrl key as you click
each tab, or click the first tab in a contiguous range, and then hold down Shift while
clicking the last tab.

Scrolling through Sheet Tabs

When you have a lot of worksheets with long names, or when the Excel window is
fairly narrow, you might not be able to see all the tabs at once. Use the arrow buttons
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to the left of the tabs to scroll from side to side through the workbook's tabs, as shown
in Figure 2-2.

Figure 2-2: Use the arrow buttons to scroll through the tabs in the workbook.

Hiding and Redisplaying Sheets

By default, all sheets in the workbook are available as tabs in the lower-left corner of
the window. You can hide certain tabs, either to get lesser-used sheets out of the way
or to provide some security protection for sensitive data.

Hiding a sheet isn't very good protection for it. If you don't want users to see a
certain sheet, remove it from the workbook. If that's not possible because formulas
rely on data from that sheet, consider protecting the sheet as well as hiding it.
You'll learn how to protect a sheet later in this lesson.

To hide a sheet, right-click its tab, and then select Hide.

To redisplay a hidden sheet, right-click any of the displayed tabs, and then select
Unhide. In the Unhide dialog box, select the sheet to unhide, and then click OK.

Changing a Tab Color

All tabs start out white by default; however, you can color-code your workbook by
changing the tab colors. For example, you might make all the tabs for a particular
division or fiscal year the same color to differentiate them from others.

To select a tab color, right-click the tab, and then select Tab Color. On the palette of
colors that appears as shown in Figure 2-3, select the color you want. You can use
theme colors or standard colors.

Figure 2-3: Selecting a worksheet tab color.
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Do you want the background color to apply to the entire worksheet, not just the tab?
Select the entire worksheet (Ctrl+A), and then select a fill color from the Home tab, in
the Font group.

Now that you understand how to display and arrange worksheets and change tab
colors, read on to learn how to copy and move worksheets.

 

Copying and Moving Sheets

To rearrange the sheet order, drag a sheet's tab to the right or left. A black triangle
with an icon that looks like a piece of paper shows where it's going. Release the
mouse button when the triangle gets to the point where you want the sheet to be
moved.

If you want to copy a sheet rather than move it, hold down the Ctrl key as you drag it.

Another way to move or copy a sheet is with the Move or Copy command. (That's a
single command: "Move or Copy.") It's more powerful than the drag-and-drop method
because you can use it to move or copy a sheet from one workbook to another if
desired. To use this command, just select one or more sheets, right-click a selected
sheet tab, and then select Move or Copy from the shortcut menu. The Move or Copy
dialog box opens, in which you can select a destination workbook and a sheet position
within that workbook.

Practicing Sheet Handling

Try out the skills you just learned about by doing the following:

Start a new blank workbook.1.
Rename the sheets Sales, Marketing, and Accounting.2.
Add a new sheet, and then name it Operations.3.
Delete the Marketing sheet.4.
Hide the Operations sheet.5.
Redisplay the Operations sheet.6.
Change the Operations sheet's tab color to red. Set the Sales tab to yellow and7.
set the Accounting tab to blue. (Use standard colors for each tab.)
Use the drag-and-drop method to move the Operations sheet to the leftmost8.
position.
Hold down Ctrl as you drag to create another copy of the Sales sheet to the9.
right of the original, and then rename the copy Marketing. Change the color of
the new copy's tab to green.
Start a new workbook, and then use the Move or Copy feature to copy all four10.
tabs into the new workbook.
Delete Sheet1, Sheet2, and Sheet3 in the new workbook.11.
If you followed the steps correctly, the tabs should resemble Figure 2-4.12.

Figure 2-4: There should be four tabs, each a different color, after completing the
steps.

Save the new workbook as Int-Practice2.xlsx (Excel 2007 format) and leave it1.
open for future use in this lesson. Close all other copies without saving
changes.

In the next section, you'll learn how to view multiple sheets at the same time.
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Viewing Multiple Sheets at Once
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Sometimes you might want to see multiple sheets onscreen at once -- for example, to
compare their content or to copy data from one to another.

To view multiple sheets at once, open as many new windows as you need, and then
arrange them. (The controls for doing this are on the View tab.)

To walk through the process with the example file Int-Practice2.xlsx from earlier in the
lesson, follow these steps:

On the View tab, click New Window three times. Now you have a total of four1.
open windows, all with the same view of the same worksheet.
On the View tab, click Arrange All. The Arrange Windows dialog box opens.2.
Select Tiled, check the Windows of active workbook check box, and then click3.
OK.
In each window, select a different tab. Now all four tabs are visible4.
simultaneously on one screen, as in Figure 2-5.

Figure 2-5: Each sheet is displayed in a different tiled window.

Enlarge image

By default, each new workbook has three sheets. To change this number, click the
Microsoft Office Button, and then click Excel Options. On the Popular tab, change the
Include this many sheets value.

See how to view multiple worksheets simultaneously. (1 MB file)

The next section covers a very handy formula reference that let's you refer to a cell or
group of cells on a different sheet.
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Referring to a Cell on a Different Sheet
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Because each sheet uses the same row-and-column naming scheme (for example,
every worksheet has an A1, an A2, and so on), several cells in each workbook have
the same names. That's not a problem as long as each formula and function is limited
to the two-dimensional confines of its own sheet. However, when you need to refer to
another cell on a different sheet, some naming clarification is required.

To refer to a cell on a different sheet, precede the name with the sheet name, followed
by an exclamation point; for example, A1 on Sheet1 is

=Sheet1!A1

This is why you should keep the sheet names short. It saves time when you put the
sheet name in the reference.

If you want to use a long name on a sheet that requires a lot of formulas, first give the
sheet a very short name (or use the default name) and then use that name as you set
up all your formulas. When you're finished, rename the sheet to the long name you
want; all the formulas change their references automatically.

When a sheet name has spaces in it, you must enclose its name in single quotes
when referring to it in a formula, like this:

='My Sheet'!A1

Building 3-D Formulas by Selecting

It's often easier to select the cells you want when building a formula than it is to type
the names manually. It's not much different when those cells are on different sheets
than when they're on the same sheet.

Try this exercise to see how to build a formula by selecting:

Download and open the file Int-Practice2A.xls. This is the same basic1.
workbook you created earlier in the lesson, but with some sample data added
for your convenience.
On the Summary tab, click in cell B3.2.
Type =SUM( and then click the Operations tab.3.
Select cells in the range B3:B6 on the Operations tab.4.
Press Enter. The sum of those cells appears on the Summary tab in cell B3.5.
Using this same technique, sum the sales, marketing, and accounting6.
information in cells B4, B5, and B6, respectively, all on the Summary tab.
In cell B7 on the Summary tab, type =SUM(B3:B6), and then press Enter.7.
Save your work and leave it open for use later in this lesson.8.

If you've done the exercise correctly, the total in cell B7 should be 6675.

You just learned how to link content between sheets in the same workbook. Next,
you'll learn about linking content between different workbooks.
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Linking Content from Other Workbooks

Now you know how to refer to one worksheet's cells on another worksheet. What
about referring to cells in an entirely different workbook? For this, you need to create a
link.
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For example, suppose you have several workbooks that each contain a certain type of
data and one workbook called Summary.xls in which you want to summarize the totals
from all the various workbooks. Copy the values (or formulas) from one workbook to
the other using the Clipboard. Then, instead of pasting normally, select Edit > Paste
Special. In the Paste Special dialog box, click the Paste Link button.

To see how it works, try the following:

Start a new workbook, and then save it as Summary.xlsx.1.
Open Int-Practice2A if it's not already open. (You worked with it in the previous2.
section.) Select cell B7 on the Summary tab.
Press Ctrl+C to copy the formula from cell B7 to the Clipboard.3.
Switch to Summary.xlsx, and then select cell A1.4.
On the Home tab, open the drop-down menu for the Paste button, and then5.
click Paste Special.
In the Paste Special dialog box, click the Paste Link button. The link is inserted6.
in cell A1 of Summary.xls like this:
='[Int-Practice2A.xls]Summary'!$B$7
Switch back to Int-Practice2A, click the Operations tab, and then change the7.
value in cell B6 to 200.
Switch back to Summary.xlsx. Notice that the number has automatically8.
changed.
Now break the link. In Summary.xlsx, click the Microsoft Office Button, and9.
then select Prepare > Edit Links to Files. The Edit Links dialog box opens.
Select the link, and then click Break Link. A confirmation box appears; click10.
Break Links to confirm.
Click Close to close the dialog box.11.
Switch back to Int-Practice2A, and then type a different number in cell B7.12.
Switch back to Summary.xlsx. The number doesn't change this time because13.
there's no link.
Close both files. You can delete Summary.xlsx if you want; you're done with it14.
for this lesson.

See how to link and unlink content between two workbooks. (1.6 MB file)

Next, you'll learn how to protect a sheet from changes while still enabling other sheets
in the same workbook to be changed.
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Protecting a Sheet from Changes

Within a workbook, you might have some sheets that shouldn't be modified -- at least
not easily or by accident. For example, in the Int-Practice2A.xls file, the Summary tab
collects data from all the other sheets. You might not want a user to be able to modify
the Summary tab's contents, because you need to rely on its formulas accurately
transferring the data from the other tabs. The other tabs, however, need to remain
editable so users can update their values.

To protect a sheet, right-click its tab, select Protect Sheet, and then check or clear the
check boxes in the Protect Sheet dialog box. If you want to password-protect the
disallowed types of edits, type a password in the Password to unprotect sheet text
box shown in Figure 2-6. You can also get to this same dialog box from the Review
tab by clicking the Protect Sheet button there.
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Figure 2-6: Protect the sheet against specified types of edits.

To unprotect the sheet, click the Unprotect Sheet button on the Review tab or right-
click the worksheet tab, and then select Unprotect Sheet.

Tracking Changes

If you want to enable users to make changes and track their changes, you can use the
Track Changes menu on the Review tab. Select it, and then select Highlight Changes.
In the Highlight Changes dialog box, check the Track changes while editing.-This also
shares your workbook. check box, and then click OK. (Some other warnings or
confirmations might appear after that; click OK to move through them as needed.)

When you make further changes to the worksheets, comments appear indicating
what's been changed. You'll see a triangle in the upper-left corner of a changed cell;
point to the cell to display the comment box shown in Figure 2-7.

Figure 2-7: Change comments appear when you point at the cell.

After reviewing the changes, you can do the following to accept or reject them:

On the Review tab, select Track Changes, and then select Accept/Reject1.
Changes.
When prompted to save the workbook, click OK. The Select Changes to2.
Accept or Reject dialog box opens.
Narrow down the changes you want to work with, if desired. For example, you3.
can select only comments that haven't been reviewed, as shown in Figure 2-8,
or comments from a certain person or within a certain range.
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Figure 2-8: Specify which comments to review.

In the Accept or Reject Changes dialog box, each change appears, one by1.
one. Click Accept or Reject for that one change, or click Accept All or Reject All
for all at once. After the last change, the dialog box closes automatically.

After finishing this section, you no longer have any excuse for losing track of changes
made to your worksheets.

Moving On

In this lesson, you learned various ways of working with multiple sheets in a
workbook, including adding, deleting, renaming, moving, copying, and protecting
them. Now you can't just work in two dimensions; you can work between sheets in 3-
D as well. In the next lesson, you'll learn about Excel's capabilities for finding, sorting,
and filtering data. Before you go on to Lesson 3, take the quiz and do the assignment
to solidify your knowledge.

Assignment #2

For this assignment:

Open IntExcel07-Assign2.xls, which already has a checkbook register in it similar to the1.
one you created in Lesson 1.
Customize the checkbook register for your own checking account as needed.2.
Name the checkbook register tab Checking, and then apply a color to its tab.3.
Add another sheet to the workbook, name it Credit Card, and then apply a different color to4.
its tab.
Create a register on the Credit Card tab appropriate for storing information about your5.
credit card transactions. This register will be similar to, but not the same as, the checkbook
register.
Create a new blank sheet at the beginning of the workbook (leftmost position) and call its6.
tab Summary.
On the Summary tab, enter the data shown in Figure 2-9.7.

Figure 2-9: Enter this data.

On the Summary tab, create references to the balances in each of the other tabs in cells1.
B3 and B4.

In cell B5 on the Summary tab, create a function that sums the range of cells B3:B4.1.
(Optional) If you have any other bank accounts for which you want to create registers, add2.

http://adminivillage.dc.powered.com/workbench/media/ns/11740//IntExcel07-Assign2.xls


more tabs to the workbook, create their registers, and then add their balances to the
Summary tab.
Save your work and exit Excel.3.

Solution

Check your work by downloading IntExcel07-Assign2-solution.xls and comparing it to your
workbook.

 

Quiz #2
Question 1:
What's the shortcut key combination for adding a sheet to a workbook?

A)  F11
B)  Shift+F11
C)  Ctrl+F11
D)  Alt+F11
 
Question 2:
To select more than one worksheet tab at once, click the first one and then hold down ______ as you click the
additional tabs you want to select.

A) Ctrl
B) Alt
C) F11
D) F1
 
Question 3:
To copy a worksheet, hold down the ________ key as you drag it to the left or right to a new position.

A) Ctrl
B) Alt
C) Shift
D) F11
 
Question 4:
To view two sheets at once, first open a new window by clicking the ___________ button on the ____________
tab. Then use Arrange All to arrange the open windows and view a different sheet in each window.

A) Zoom, New Window
B) Reset Window, Reset Window
C) Synchronous Scrolling, Reset Window
D) New Window, View
 
Question 5:
Which formula would you use to refer to cell B15 on a worksheet named Q1 Results?

A)  =Q1 Results!B15
B)  ='Q1 Results'!B15
C)  =B15!Q1Results
D)  =B15″Q1 Results″
 

Microsoft Excel Tutorial: Finding, Sorting, and Filtering Data
Long lists of data can be intimidating, but Microsoft Excel has excellent sorting and filtering capabilities to help
bring that data under control. This Microsoft Excel tutorial shows you several strategies for finding and
organizing data.
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Welcome back for Lesson 3. In the preceding lesson, you learned how to work with
multiple-sheet workbooks. This lesson teaches you how to use Microsoft® Excel as a
database application, including finding, sorting, and filtering data.

When you think about creating a database in a Microsoft® Office 2007 application,
you probably think about Microsoft® Access, right? It's the official database
component of the Office suite. However, for simple lists of data, Excel can function as
a perfectly good database application too, and is simpler to use. Using Excel might
save you some expense as Excel comes with all versions of Office 2007, whereas
Access comes only with the higher-end versions.

Excel works great for flat file databases. A flat file database consists of a single sheet
of rows and columns. The first row contains the column headers, and the subsequent
rows contain data. Figure 3-1 shows an example of a flat file database.

Figure 3-1: A flat file database is a single datasheet.

Enlarge image

More complex databases contain multiple sheets joined together in some way.
(Access calls them tables.) For example, you might have two tables: one with
customer address data and another with order information. Each order links to the
customer table via the customer's ID number, so when the order is processed, the
customer's address automatically appears on the packing slip. This is called a
relational database, and you can't create that kind of database in Excel. You need a
full-featured database program such as Access for that.

But wait -- didn't you just learn in Lesson 2 that an Excel workbook can have multiple
sheets and that you can create references between them? How is that different from a
relational database? Technically, you could set up a relational database in Excel by
using Excel's cross-referencing capabilities. However, it would be laborious to do so
because you'd have to create so many formulas. In Access it's much easier. You
might need to take some time to learn Access, but if you're serious about creating a
relational database, the time spent learning is worthwhile.

This lesson assumes that you don't need a full-fledged database program, but that
you just have some simple lists to maintain. For example, perhaps you need a list of
your tax-deductible charitable contributions for the year or a roster of people in a club
and their contact information. For situations like these, Excel can be a great database
utility.

Let's get started! In the next section you'll learn how to create a data table in Excel.
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Creating Your Data Table

First, let's review some database terminology, using a familiar example -- an address
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Business
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book.

When constructing a data table in Excel, it's important to put the field names in the
first row. Field names describe the type of data placed in each column. For an
address book, the field names might include FirstName, LastName, Address, City,
State, and ZIP. In subsequent rows, enter the specific entries for each person. Each
row is for a different person and is called a record.

Some people put a database title in the first row and the field names below that. If
you're planning to keep the database in Excel for the long term, that's okay.
However, if you later import the data into some other program, like Access, that
title could cause problems. It's better to keep the field names in row 1 if possible.

The first step in creating a data table, then, is to place the field names in row 1. You
can format the field names differently if you like (such as making them bold or a
different color), but that's purely a matter of aesthetics; Excel doesn't assign any
particular meaning to the formatting.

Follow these steps to create a phone list for a club:

Start a new workbook, and on Sheet1, enter the following:1.

A1: First

B1: Last

C1: Phone

D1: Membership

Select row 1, and then apply bold and underline formatting to it.1.
Select columns A through D, and then set their column widths to 15. (To do2.
this, click the Home tab, select Format, and then select Column Width. Type 15
in the Column width text box, and then click OK.)

Figure 3-2 shows the data table so far.

Figure 3-2: The formatted worksheet.

Next, enter records into the worksheet. Enter the records shown in Figure 3-3.1.

Figure 3-3: Enter this data.

Save your work as Int-Practice3.xlsx (Excel 2007 format), and then close the1.
file.
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The next section walks you through importing data from other programs.

 

Importing Data from Other Programs

If you already have data in some other program -- an Access table, a plain text file, a
Word document table -- you can transfer it into Excel. One way to do this is with a
simple copy-and-paste operation:

View your data in a datasheet in its current program, and then select the data.1.
Copy it to the Clipboard (Ctrl+C).2.
In Excel, select cell A1 on a blank sheet.3.
Paste from the Clipboard (Ctrl+V).4.

You can also open other file formats in Excel to import the data. This works well if you
don't already have a datasheet started in which to place the data and you want to
create a new workbook to hold it. To accomplish this, do the following:

Click the Microsoft Office Button, and then select Open.1.
Change the file type to the type of data you want to import (for example,2.
Access Databases).
Select the file and open it as you would any other file. If prompted to select a3.
particular table or other component, do so.

Now let's try it. In the following steps, you'll import the data from Int-Practice3A.mdb
(an Access database) into Excel:

Download Int-Practice3A.mdb.1.

Don't just click the hyperlink provided in step 1; the download probably won't work
properly because of the way most browsers handle Access files. Instead, right-
click the hyperlink, and then select Save Target As. In the dialog box that opens,
change the file name to have an .mdb extension, not .htm.

In Excel, click the Microsoft Office Button, and then select Open.1.
Set the file type to Access Databases.2.
Navigate to the location where you saved the downloaded file.3.
Select the database file, and then click Open.4.
If a security notice appears, click Enable. The data is imported into Excel.5.
Excel even formats it nicely for you!
Save the Excel file as Int-Practice3B.xlsx (Excel 2007 format). Leave it open6.
for later use in this lesson.

Now that you know how to import data from other programs, read on to learn how to
find and replace data in a worksheet.
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Watch the Video!

 

Finding and Replacing Data

So far, most of the worksheets you've worked with in this course have been small, so
it was easy to find data at a glance. When you get 50 or so records in a database,
however, finding a specific record starts becoming more difficult by just browsing.

You can locate data in an Excel database in many ways, but perhaps the simplest and
most user-friendly is the Find command. To use it, press Ctrl+F or, on the Home tab,
select Find & Select > Find. Either way, the Find and Replace dialog box opens, with
the Find tab displayed. Type the text string you want to locate, and then click Find
Next to jump to the next cell in the worksheet that contains that string.

You also can set options for finding. Try the following exercise to see some of them:

In Int-Practice3B, on the Home tab, select Find & Select > Find.1.
In the Find and Replace dialog box, type Wayne in the Find what text box.2.
Click the Options button to expand the options, as shown in Figure 3-4.3.

Figure 3-4: The expanded Find and Replace dialog box.

Enlarge image

Leave the Within, Search, and Look in boxes set at their defaults for now.1.
Here's what each of those settings does:

Within: Specifies whether to search the current sheet only or the entire
workbook.

Search: Specifies whether to search by row or by column.

Look in: Specifies whether to search in formulas, values, or comments.
Unless a particular cell contains a formula or function, it makes no
difference whether you select Values or Formulas.

Check the Match case check box. This limits the search to the capitalization1.
you typed in the Find what text box.
Click Find Next. Keep doing that until you've cycled through all instances in the2.
sheet. Notice that it finds four instances of "Fort Wayne" and one instance in
which Wayne is the person's name.
After you reach the first instance again, check the Match entire cell contents3.
check box. Then click Find Next. This time Excel doesn't find anything because
no cells contain only "Wayne". Click OK.
Drag the Find and Replace dialog box off to the side, but don't close it.4.
Select cell F22, and then apply Bold formatting to it. Click cell A1.5.
In the Find and Replace dialog box, click the Format button. If a menu opens,6.
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click Format. The Find Format dialog box opens.
Click the Font tab, and in the Font style area, select Bold, and then click OK.7.
Uncheck the Match entire cell contents check box.8.
Click Find Next. Excel finds the instance of Fort Wayne that was made bold but9.
none of the others.
Click the Format button again in the Find and Replace dialog box. In the Find10.
Format dialog box that opens, click the Clear button to clear the formatting
specifications, and then click OK.
Click Close to close the Find and Replace dialog box.11.
Select cell F22 again, and then press Ctrl+B to toggle the bold formatting off.12.
Leave the file open for later use in this lesson.13.

You can also use the Find and Replace dialog box to replace data. Click the
Replace tab and specify what you want to replace the found text with.

Next up, you'll learn how to sort the data in a worksheet.

 

Sorting Worksheet Data

As you just learned, one way to locate certain data is to use the Find feature. Another
way is to sort the records by a particular column and then scroll through the data to
find what you want.

To do a simple sort by a single column, use the Sort & Filter button on the Home tab.
Follow these steps to try it out with your sample file:

In Int-Practice3B, click in the First Name column (any row).1.
On the Home tab, select Sort & Filter > Sort A to Z.2.
Click the Data tab. (More sorting options are available on the Data tab.)3.
In the Sort & Filter group, click the Sort Z to A button (which is labeled with a Z4.
on top of an A with a down-pointing arrow).
Notice that every cell in row 1 has a drop-down arrow on it and that the one in5.
column B has a small arrow on the button. That indicates that the data has
been sorted by that column.
Click the drop-down arrow for the Last Name column, opening a menu, and6.
then select Sort A to Z. The list goes back to being sorted by last name.
Notice that the Filter button is selected on the Data tab. Click that button to7.
deselect it. The drop-down arrows go away.

You can also do more advanced sorts by multiple columns at once. For example, if
duplicate values are in the primary field by which you're sorting, Excel refers to the
secondary sort field.

To try out a multiple-field sort, follow these steps:

In Int-Practice3B, on the Data tab, click the Sort button. The Sort dialog box1.
opens.
Open the Sort by list, and then select State.2.
Click Add Level.3.
Open the Then by list, and then select Zip, as shown in Figure 3-5.4.
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Figure 3-5: Set up a multiple-column sort.
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Click OK. A warning appears that the sort key might not sort as expected1.
because it contains some numbers formatted as text.
Select the Sort anything that looks like a number, as a number option.2.
Click OK.3.
Re-sort the list by the ID field from A to Z.4.

See how to sort data in a worksheet. (1.3 MB file)

By the way, the database list you've been using in Int-Practice3B is more than a
simple range of cells -- it's a table. You'll learn about tables in the next section.

great advice on getting
started.
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Understanding Tables

Excel 2007 lets you define certain ranges of the worksheet as tables, which makes
them easier to manage as databases. When you created Int-Practice3B.xlsx earlier in
the lesson, Excel automatically converted the imported data to a table. The fact that
it's a table made some subtle differences in the way the sorting feature worked in the
preceding section.

In Excel 2003, tables were called lists.

To try it out and convert the data back to a regular range, follow these steps:

In Int-Practice3B.xlsx, click the Design tab. (This tab is available because the1.
data is in a table; otherwise it wouldn't be present.)
Click Convert to Range. A warning box appears. Click OK. The Design tab2.
goes away, and you're returned to the Home tab.
Now try that sorting operation again. Click anywhere in the First Name column3.
(column B).
On the Home tab, select Sort & Filter > Sort A to Z. Notice that the formatting4.
that formerly kept every other line a different color has gotten mish-mashed,
with different line colors all mixed up. Without the table structure, each line
retains its original color when the data is sorted.
Select the entire column A, and then click the Sort A to Z button on the Data5.
tab again. This time, because it's no longer a table, a Sort Warning dialog box
opens asking whether you want to expand the selection (to keep the records
together) or sort only this one column, keeping the other data in other columns.
In this case you want to expand the selection, so select that option as shown in
Figure 3-6, and then click Sort.
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Figure 3-6: When sorting after selecting an entire column in non-tabular data ranges,
you're asked whether you want to expand the selection.

Let's turn the range back into a table again. Select the range A1:H74.1.
On the Insert tab, click Table. The Create Table dialog box opens.2.
Click OK. It goes back to being a table, and the Design tab reappears.3.
On the Design tab, in the Properties group, type a new name for the table --4.
Addresses -- in the Table Name text box.
Click the Data tab, and then click the Filter button to turn off the down arrows in5.
row 1.
Select the entire column A again. Notice that now the Sort & Filter buttons on6.
the Data tab are unavailable. Click the Home tab and notice that Sort & Filter is
unavailable there too. That's because you can't sort a table with the entire
column selected.
Click cell A1, and then notice that the Sort & Filter options become available7.
again.
Save your work.8.

Now you know how tables work in Excel 2007. Next up, you'll learn how to filter data.
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Filtering Data

As you learned in the preceding section, sorting helps you find specific records that
met particular criteria alphabetically in a certain field. For example, when you sort by
ZIP code, it's easy to scroll through the worksheet and find the people who live in any
given ZIP code.

However, a filter can be an even better way of finding certain records, because a filter
enables you to hide the records that don't meet your criteria.

The easiest way to filter a list is to turn on the Filter feature (on the Data tab), if it isn't
already on, and then use the drop-down list buttons at the top of each column to set
up your filtering.

Give this a try with your sample data. Follow these steps:

In Int-Practice3B.xlsx, click the Data tab. If the Filter button isn't already1.
selected, click it.
Open the drop-down list at the top of the State column (column G), and then2.
clear the Select All check box. Check the IL and IN check boxes, as shown in
Figure 3-7, and then click OK. The list is filtered to show only people who live in
those two states.
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Figure 3-7: Filter the field to show only certain values.

Click the Clear button on the Data tab. The filter is removed, and the full set of1.
data reappears.
Now let's filter by the First Name field to show only couples -- that is, only2.
entries where there is an "and" in that field. Open the First Name column's
drop-down list, and then select Text Filters > Contains. The Custom AutoFilter
dialog box opens.
In the text box to the right of "contains," type and as shown in Figure 3-8.3.

Figure 3-8: Specify a text string the field should contain.

Click OK. The list is filtered to show only those records that match the criteria.1.
Click the drop-down list button for the First Name column again, and on the2.
menu, select Clear Filter From "First Name."
Close the file, saving your changes.3.

A lot more possibilities for filtering are available than the few shown here, but that
should be enough to get you started.

See how to filter data. (1 MB file)

In the next section, you'll learn how to split data into multiple columns.
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Splitting Data into Multiple Columns
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Sometimes when you set up a database, you make a bad decision initially about what
information will be separate and what will be combined. For example, many people
decide to put first and last names together in a single column in an address book,
calling it Name. Later, they realize they want to be able to sort the list by last name,
but there's no way to do it because each entry begins with the person's first name.

The opposite can also occur. Perhaps you originally decided to separate the first and
last names, but then you decide you want to use them together.

Neither of these problems is insurmountable.

First, look at a situation in which two words exist in a single cell and you want them
separated. To experiment with this, follow these steps:

Start a new blank workbook, and then save it as Int-Practice3C.xlsx.1.
Enter the data shown in Figure 3-9.2.

Figure 3-9: Enter this data for the example.

Select the range A1:A6.1.
On the Data tab, click Text to Columns.2.
Select Delimited, and then click Next.3.
Clear the Tab check box, and then check the Space check box, as shown in4.
Figure 3-10.

Figure 3-10: Break the data where a space occurs.

Enlarge image

Click Next.1.
Click Finish. The names are broken into two separate columns.2.
Save your work. Leave the file open for later use in this lesson.3.

Notice that the steps split the data into the column to the right of the current one. You
must have a blank column to the right of the column containing the original data when
you use this command.

Make Mine a $Million
Business

Co-founded by Count
Me In for Women’s
Economic
Independence and
OPEN from American
Express®, this
organization helps
women entrepreneurs
build million-dollar
companies. Each year,
the group’s award
program presents
women with money,
mentoring, and
marketing support.

Learn More! 

Just My Business
Interview

iVillage and renowned
business journalist JJ
Ramberg bring you the
"Just My Business"
interview series. In this
exciting series JJ will
interview emerging
and experienced
entrepreneurs. You
will get an inside
scoop on what it’s like
to own your own
business as well as
great advice on getting
started.

Watch the Video!

http://adminivillage.dc.powered.com/workbench/media/ns/11740//Library_Excel2007Int03fg10_large.jpg
http://ilearn.ivillage.com/outgoing?productId=2110&placementId=3101&lessonId=36650&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B122718104%3B18279001%3Bt%3Fhttp%3A%2F%2Fwww.makemineamillion.org
http://ilearn.ivillage.com/outgoing?productId=2110&placementId=3101&lessonId=36650&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B122718104%3B18279001%3Bt%3Fhttp%3A%2F%2Fwww.makemineamillion.org
http://ilearn.ivillage.com/outgoing?productId=2110&placementId=3101&lessonId=36648&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B122718104%3B18279001%3Bt%3Fhttp%3A%2F%2Fwww.makemineamillion.org
http://ilearn.ivillage.com/outgoing?productId=2110&placementId=3101&lessonId=36650&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B122718104%3B18279001%3Bt%3Fhttp%3A%2F%2Fwww.makemineamillion.org
http://ilearn.ivillage.com/outgoing?productId=3709&placementId=2600&lessonId=36650&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B188184551%3B4798747%3Be%3Fhttp%3A%2F%2Filearn.ivillage.com%2Fsponsors%2Fvideo_player.jsp%3FcampusId%3D1100%26ivillagepsession.id%3D766211a8dd26ea8f35bda5f2219f
http://ilearn.ivillage.com/outgoing?productId=3709&placementId=2600&lessonId=36650&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B188184551%3B4798747%3Be%3Fhttp%3A%2F%2Filearn.ivillage.com%2Fsponsors%2Fvideo_player.jsp%3FcampusId%3D1100%26ivillagepsession.id%3D766211a8dd26ea8f35bda5f2219f
http://ilearn.ivillage.com/outgoing?productId=3709&placementId=2600&lessonId=36648&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B188184551%3B4798747%3Be%3Fhttp%3A%2F%2Filearn.ivillage.com%2Fsponsors%2Fvideo_player.jsp%3FcampusId%3D1100%26ivillagepsession.id%3D766211a8dd26ea8f35bda5f2219f
http://ilearn.ivillage.com/outgoing?productId=3709&placementId=2600&lessonId=36650&courseId=34244&eventType=PDC&targetUrl=http%3A%2F%2Fad.doubleclick.net%2Fclk%3B188184551%3B4798747%3Be%3Fhttp%3A%2F%2Filearn.ivillage.com%2Fsponsors%2Fvideo_player.jsp%3FcampusId%3D1100%26ivillagepsession.id%3D766211a8dd26ea8f35bda5f2219f


Next, you'll look at the opposite situation: concatenating data.

 

Concatenating Data

Now let's look at the opposite situation from the previous section. Suppose that you've
already split data into two or more columns and now you decide you want it combined.
(That's what concatenate means -- to combine.)

You can combine data in two ways: a temporary way and a permanent way. Use the
temporary way when you want to use the data in a single cell elsewhere in the
worksheet but retain the separate values. Use the permanent way when you don't
need to go back.

Concatenating Data Temporarily

To merge data temporarily, create a new column, and in it, set up formulas that
concatenate the values of the individual cells.

Let's do this with the example file:

In Int-Practice3C.xlsx, in cell C1, enter the formula =A1&" "&B1.1.

The & sign is the concatenation operator, so technically =A1&B1 would put the
two values together. However, there would be no space between them. That's
why the " " exist. It's a space, nestled between two quotation marks.

Copy the formula from cell C1 to the range C2:C6.1.
Widen column C as needed.2.

You can also use the CONCATENATE function to do the same thing, like this:

=CONCATENATE(A1," ",B1)

Notice that with the function, you separate the pieces with commas rather than &
signs because each piece is a separate argument.

Concatenating Data Permanently

The formulas or functions you set up in the preceding section maintain their reference
to the original cells, so the new values don't really replace the old ones. You couldn't
delete the original first and last name columns, for example, because then the
formulas or functions would have errors.

If you want to permanently replace the two-column names with the one-column
names, create the formulas or functions, as in the preceding section, and then use
Paste Special to paste only the values.

Follow these steps to try it out on your sample data:

In Int-Practice3C.xlsx, in cell C1, select C1:C6, and then press Ctrl+C to copy1.
the range to the Clipboard.
Click cell D1.2.
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On the Home tab, click the down arrow under the Paste button and click Paste3.
Values.
Select column D, and then press Ctrl+X to cut it.4.
Select column C, and then press Ctrl+V to paste the values into that column.5.
Save your work and close the file.6.

You should now understand how to combine data temporarily and permanently. Use
the permanent way when you don't need to retain the original separate values.

Moving On

In this lesson, you learned how to create flat-file databases in Excel and how to
search, sort, and filter them. You also learned how to split and merge data in cells to
recover from database organization errors you might have made initially. Now you're
ready to use Excel to store all kinds of data, from address lists to inventories. In
Lesson 4, you'll learn about some formatting techniques that can make your
worksheets easier to read and understand. Before you move on to the next lesson, do
the assignment and take the quiz to help you remember what you've learned.

Watch the Video!

Assignment #3

This is a fun assignment because it's very free-form. You can create something useful and
practical for yourself.

Start a new workbook.1.
Create a database for storing information about a collection you own, such as antiques,2.
CDs, DVD movies, sports cards, or recipes, to name a few. Think carefully about the
fields you want to include and create them in row 1.

You might want a field called ID# in which you enter a unique number for each record. Then if
you ever want to put them back in original order after sorting them some other way, you can re-
sort by ID#.

Enter the records in subsequent rows.1.
Highlight all data.2.
Make the data range into a table using the Table button on the Insert tab.3.
Use the formatting tools on the Design tab to format the table the way you like. The4.
formatting tools weren't covered in this lesson, but they're mostly self-explanatory.
Use your data to practice searching, sorting, and filtering in any ways you think you might5.
actually use the data. For example, if you created a database of your DVD movie
collection, you might practice sorting by release date.

 

Quiz #3
Question 1:
Which type of database is most suited for Excel?

A)  Compound
B)  Relational
C)  Flat File
D)  Linking
 
Question 2:
In an address book, each person's information is a ___________.

A)  Record
B)  Field
C)  Query
D)  Index
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Question 3:
From which tabs can you access the Sort A to Z feature? (Check all that apply.)

A)  Home
B)  Insert
C)  Page Layout
D)  Formulas
E)  Data
F)  Review
G)  View
 
Question 4:
To toggle the drop-down list buttons in the top row of a table on and off, which button will you click on the Data
tab?

A) Advanced
B) Filter
C) Consolidate
D) Connections
 
Question 5:
If you want to combine the contents of cells A1 and B1 with a dash between them, which of these formulas or
functions will accomplish that? (Check all that apply.)

A)  =CONCATENATE(A1-B1)
B)  =CONCATENATE(A1&"-"&B1)
C)  =A1&"-"&B1
D)  =CONCATENATE(A1,"-",B1)
E)  =A1,"-",B1
 

Microsoft Excel Tutorial: Advanced Formatting
In this lesson, you'll learn powerful formatting skills, such as styles, custom headers and footers, and conditional
formatting, for making your Microsoft Excel workbooks the best they can be.

 

Formatting: Beyond the Basics

This course started out at the intermediate level, so it's assumed you already know
the basics of formatting in Excel, such as changing font size, colors, and attributes;
applying borders and shading; changing cell height and width; and so on. All these
skills were covered in the Introduction to Excel 2007 course, so if you need to refresh
your skills in that area, try that course.

If you're ready to move past those basics to more complex and interesting formatting
techniques, then you're going to love this lesson! In it, you'll explore topics including
themes, styles, conditional formatting, and custom number formats.

Reviewing Formatting Themes

Formatting themes are new in Excel 2007. They enable you to switch a worksheet's
fonts and colors easily without the need to select and manually change each cell. If
you took the Introduction to Excel 2007 course, you're already familiar with formatting
themes; however, because they're a new feature, they're worth a brief review.

In Microsoft® Office 2007 programs (Excel, Word, and PowerPoint), you can apply
fixed fonts and colors to text and other objects, or you can apply placeholders to them.
If you do the latter, you can redefine the formatting of those placeholders via themes.

A theme defines three things:
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The fonts used for any text that doesn't have a fixed font assigned to it, but instead
is formatted with either the Heading or Body placeholder.
The colors used for any text, formatting, or objects that don't have a fixed color
assigned to them, but instead a color placeholder.
The appearance effects (fill, border, and so on) for any graphical objects, such as
drawn lines and shapes and SmartArt.

When you apply a theme, you get the theme's combination of those settings. You can
also apply font themes, color themes, and effect themes that individually change each
aspect.

To try out the Themes feature, follow these steps:

Start a new workbook, and then enter the data shown in Figure 4-1.1.

Figure 4-1: Enter this data in a new workbook.

Change font sizes as follows:1.

cell A1: 20 point

range B3:C3: 12 point

range A4:A7: 12 point

Select cell A1 and ranges B3:C3 and A4:A7 as a non-contiguous range. (Hint:1.
Hold down the Ctrl key when selecting.)
Open the Font drop-down list, and then select Cambria (Headings) from the top2.
of the list.
Open the Font Color drop-down list, and then select the Red, Accent 2 theme3.
color (the sixth color swatch in the row directly under the Theme Colors
heading).
On the Page Layout tab, select Themes > Foundry. Both the fonts and the4.
colors change.
On the Page Layout tab, select Colors > Verve. Only the colors change; the5.
font stays the same.
On the Page Layout tab, select Fonts > Civic. Only the fonts change; the colors6.
stay the same.
On the Page Layout tab, select Effects > Apex. Nothing happens because no7.
graphic objects are available to be formatted.
Save your work as Int-Practice4.xlsx. Leave the file open for later use in this8.
lesson.

Now that you've reviewed the basics of formatting themes, you can move on to
exploring cell styles.
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Working with Cell Styles

If you've used a word processing program before, you're probably familiar with the
concept of a style. A style is a collection of formatting presets you can apply to
selected text (or cells in a table or worksheet) to quickly format them a certain way.
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Styles save time by enabling you to apply multiple formatting commands in a single
step.

Excel 2007 has greatly expanded its style feature from earlier versions and offers a
variety of style presets. To use them, select the cells you want to change, and then
select from the Cell Styles drop-down list on the Home tab.

To try out styles with the practice file you created earlier, follow these steps:

In Int-Practice4.xlsx, select the range B3:C3.1.
On the Home tab, select Cell Styles in the Styles group, and then in the Titles2.
and Headings section, select Heading 2, as shown in Figure 4-2.

Figure 4-2: Applying the Heading 2 style.

Enlarge image

Select the range B4:B7, and then apply the Heading 4 style to that range.1.
Select the range B4:B7 (if not already selected), and then apply the first pink2.
20% - Accent1 style. (It's pink because of the color theme you chose earlier; it
won't be pink if you switch to a different theme or color theme.)
On the Page Layout tab, select Themes > Flow. Both the colors and the fonts3.
change to reflect that theme.
On the Home tab, open the Cell Styles menu. Notice that the styles have all4.
changed; they're based on the fonts and colors of the current theme.
In cell A8, type Total. In cell B8, type =SUM(B4:B7). In cell C8, type5.
=SUM(C4:C7).
Select the range B8:C8, and then apply the Total style from the Cell Styles6.
menu.
Save your work and leave the worksheet open.7.

See how to work with styles. (1 MB file)

In the next section, you'll learn how to create your own cell styles.
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Defining Your Own Cell Styles

You can create your own cell styles in Excel 2007. To do this, format some cells the
way you want them, and then select New Cell Style from the Cell Styles menu.

Let's try it using the sample data:

In Int-Practice4.xlsx, select the range B4:C7.1.
On the Home tab, select Cell Styles > New Cell Style. The Style dialog box2.
opens.
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In the Style name box, type Italic Body.3.
Clear the Number and Border check boxes, as shown in Figure 4-3. You don't4.
want those features to be part of the style in this case.

Figure 4-3: Creating a new cell style.

Click OK.1.
Open the Cell Styles menu again. Your new custom style should appear at the2.
top, in the Custom section.
In the Cell Styles menu, select Normal, applying normal style to the selected3.
range.
Open the Cell Styles list again and apply your custom Italic Body style again.4.
Now modify your style. Open the Cell Styles menu, right-click your Italic Body5.
custom style, and then select Modify from the shortcut menu. The Style dialog
box opens.
In the Style dialog box, click Format. The Format Cells dialog box opens.6.
Click the Fill tab, and then select the color swatch directly below the currently7.
selected one. This deepens the color by one shade. Click OK.
Click OK to close the Style dialog box.8.
Save your work. Leave the file open for later use in this lesson.9.

In the next section, you'll learn how to share styles between workbooks.
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Sharing Custom Styles Between Workbooks

User-created styles are available only for the workbook in which you're working.
However, you can carry over styles between workbooks in either of two ways:

You can create a Book template and set it as the startup template. This works well
when you want the styles to be available in every future workbook you create.
You can copy the styles from one workbook to another. This has a less global
scope and is useful when you don't necessarily want every workbook to have the
same styles.

Creating a Book Template
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Excel has its own built-in Normal template that it uses to create new workbooks.
However, you can override this template by creating a new template called Book and
placing it in the Program Files\Microsoft Office\Office12\XLSTART folder. When a
Book file is present, Excel uses it as the default template. If you decide you want to go
back to the original settings, delete the Book file from that location.

To create a Book file, follow these steps:

Start a new blank workbook, creating all the styles in it that you need. Clear1.
any content and formatting you created in the process of creating the styles.
Click the Microsoft Office Button, and then select Save As.2.
Open the Save as type list, and then select Excel Template.3.
Change the file name to Book.4.
Change the save location to \Program Files\Microsoft5.
Office\Office12\XLSTART.
Click Save.6.
Close Excel, and then reopen the program.7.
Open the Cell Styles menu to make sure that your custom style is there.8.

If you don't want to create a book template, you can just copy the styles from one
workbook to another.

Copying Styles between Workbooks

To copy styles between workbooks, open both workbooks in Excel, and then do the
following:

From either workbook, select Cell Styles > Merge Styles. The Merge Styles1.
dialog box opens.
Select the workbook with which you want to merge styles.2.
Click OK.3.

In the next section, you'll learn how to create conditional formatting.
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Creating Conditional Formatting

Some of the built-in number formats in Excel show negative numbers in red. That's
conditional formatting at work. Conditional formatting formats the value or label in a
cell differently, depending on its content.

You might have noticed this before; if not, try the following experiment to see
conditional formatting in action:

In cell A1 of a new worksheet, type -10, and then press Enter. Move the cell1.
selector back to cell A1.
On the Home tab, in the Number group, select Number Format > More Number2.
Formats.
In the Category list, select Number.3.
In the Negative numbers list, select one of the red formats.4.
Click OK. The number appears red.5.
Change the content of cell A1 to a positive number (hint: edit the cell to delete6.
the minus sign). The number appears black.
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Certain number formats have conditional formatting built in, as you've just seen;
however, you can also create your own custom conditional formats for special
purposes. For example, suppose you're a manager and you have a spreadsheet that
lists your salespeople and their sales figures for the month. If you want to follow along
with this example, create the worksheet shown in Figure 4-4 and save it as Int-
Practice4A.xlsx (Excel 2007 format), or download Int-Practice4A.xls and open it in
Excel.

You must save in Excel 2007 format, because the new types of conditional
formatting aren't supported in earlier formats.

Figure 4-4: Create this worksheet or download Int-Practice4A.

For example, each salesperson must meet a 1,000-unit quota, and you want an alert
when someone doesn't meet the quota. You could set up a conditional format for the
cells containing the amounts, so if the amount is less than 1,000, it's formatted in an
eye-catching way.

Follow these steps to set up conditional formatting for the worksheet shown in Figure
4-4:

Select cells B2:B7.1.
On the Home tab, select Conditional Formatting > Highlight Cells Rules > Less2.
Than. The Less Than dialog box opens.
In the Format cells that are LESS THAN text box, type 1000.3.
In the with drop-down list, select Light Red Fill with Dark Red Text. (It may4.
already be selected.)
Click OK.5.

You just saw how to apply a preset format; now let's customize that:

Select cells in the range B2:B7.1.
On the Home tab, select Conditional Formatting > Highlight Cell Rules > Less2.
Than.
Enter 1000 again for the amount.3.
In the with drop-down list, select Custom Format. The Format Cells dialog box4.
opens.
On the Border tab, select the dotted border in the Style area (the second line5.
down from None).
Open the Color list, and then select Red in the Standard Colors section.6.
Click the Outline button, and then click OK. The Less Than dialog box opens.7.
Click OK. Click away from the selection to see the formatting.8.

See how to create and apply conditional formatting. (1.2 MB file)

Next, you'll see a more complex example of conditional formatting.
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The conditional formatting example you just saw was extremely simple. It had only
one condition, and it referred to a constant value. Now let's look at a more complex
example.

To try this one, create the worksheet shown in Figure 4-5 or download and open Int-
Practice4B.

Figure 4-5: Create this worksheet or download Int-Practice4B.

Follow these steps to set up a multiple-condition formatting situation that refers to
values in cells rather than to constants:

Select the cell range B2:B8.1.
On the Home tab, select Conditional Formatting > New Rule. The New2.
Formatting Rule dialog box opens.
Select Format only cells that contain.3.
In the Edit the Rule Description area, set the cell value to be greater than or4.
equal to the value in cell E2. (Use absolute cell references throughout this
section.)
Click Format, and in the Format Cells dialog box, click the Fill tab.5.
Select a light blue standard color, and then click OK. The New Formatting Rule6.
dialog box should look like Figure 4-6 at this point.

Figure 4-6: This rule formats cells containing 500 or more with a blue fill.

Enlarge image

Click OK to create the rule.1.
With the range B2:B8 still selected, repeat the process: on the Home tab,2.
select Conditional Formatting > New Rule.
Select Format only cells that contain.3.
Set the cell value to be between cell E2 and E3 in value and apply a bright red4.
fill, as shown in Figure 4-7. Click OK to create the rule.
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Figure 4-7: This rule formats cells containing between 250 and 500 with a red fill.

Enlarge image

Repeat the process one more time, creating a rule that sets the cell value1.
between E3 and E4 and applies a bright yellow background color.

When you're finished, the cell formatting should appear as shown in Figure 4-8.

Figure 4-8: The result of applying all three conditional formatting rules.

Now let's continue experimenting with conditional formatting by trying some of the
new formatting options unique to Excel 2007.

Select cells in the range B2:D8, and then clear all formats (use the Clear1.
button in the Editing group of the Home tab).
Select the range B2:B8.2.
Select Conditional Formatting > Color Scales, and then hover the mouse3.
pointer over the various options there. These options apply colors to cells
based on their values, with different colors representing the upper and lower
ranges.
With the Conditional Formatting menu still open, point to Data Bars, and then4.
hover the mouse pointer over the options. These options show data bars of
various lengths behind the cells based on their values, with longer bars
representing the higher numbers.
With the Conditional Formatting menu still open, point to Icon Sets, and then5.
hover the mouse pointer over those options. The icons are assigned to the
cells based on their values.
Select the Red To Black icon set (the four circles: red, pink, gray, and black).6.
Circles appear next to each value in column B; however, they're not the correct
values being used, so you'll need to edit the rule.
Select Conditional Formatting > Manage Rules.7.
In the Conditional Formatting Rules Manager dialog box, select the Icon Set8.
rule, and then click Edit Rule.
Next to the red dot, set the Type to Formula, and then set the Value to =$E$2.9.

Set the Type first, because changing the type to Formula might clear the Value
box.

http://adminivillage.dc.powered.com/workbench/media/ns/11740//Library_Excel2007Int04fg07_large.jpg


Next to the pink dot, set the Type to Formula, and then set the Value to =$E$3.1.
Next to the gray dot, set the Type to Formula, and then set the Value to =$E$4.2.
Click OK, and then click Apply to see the result in the worksheet. If you're3.
satisfied, click OK to close the Conditional Formatting Rules Manager dialog
box. If not, click Edit Rule and continue to work on the rule.
Save your work and close the file.4.

Save in Excel 2007 format, because these new conditional formats don't work in
earlier formats.

In the next section, you'll learn about custom number formats.

 

Using Custom Number Formats

Excel 2007 offers a wide variety of number formatting options. You can choose any of
the formats from the Number group (on the Home tab), or you can click the dialog box
selector for any group to open the Format Cells dialog box and specify options on the
Number tab. Figure 4-9 shows this feature.

You can also right-click a cell or range and select Format Cells to open this dialog
box.

Figure 4-9: Standard number formatting can be applied from the Number tab of the
Format Cells dialog box.

Enlarge image

However, sometimes you might want a really unusual number format that isn't
represented by any of the presets. For example, you might want negative numbers to
display in green instead of red, or you might want currency values to display with
three decimal places rather than two. (Those are really odd examples, but what if?)
For situations like that, you would need to create a custom number format.

When you define a custom number format, you create a string of codes that tells
Excel exactly how you want the numbers to appear. The following table shows the
symbols you can use.

Symbol Description
# A digit that's displayed only if it's significant. For example, in 04.0, both

zeros are insignificant because if you leave them off, the value is exactly the
same.

0 A digit that's displayed even if it's insignificant.
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? Space for insignificant zeros on either side of the decimal point so the
decimal points align.

[color] The color to use. The color must be one of the following: Black, Blue, Cyan,
Green, Magenta, Red, White, or Yellow.

, The punctuation you use if you want the number format to separate the
number with commas.

$ The symbol to use (a dollar sign or other currency symbol) if you want it to
be included in the number format.

m Months or Minutes, depending on the context. With months, a single m
shows as a number (12 for December, for example). Three m's (mmm)
abbreviates the date, as in Dec. Four m's (mmmm) spells out the complete
month.

d Days
y Years
h Hours
s Seconds
_ A space. Follow the _ by a character to create a space the width of that

character. For example, when you use _), a space the width of a closing
parenthesis is inserted. This helps negative numbers in parentheses line up
with positive numbers.

* Repeating characters. Whatever character follows the * is repeated to fill the
cell.

"text "
@

Text string. Excel adds the text string to the beginning of whatever text is in
the cell. For example, if you use "Final "@ as the code and the entry in the
cell is Answer, the cell displays Final Answer.

Table 4-1: Custom number format symbols

Keep this table handy (you might even want to print it), because on the next page
you'll work with some examples.

Parts of a Custom Number Format

A custom number format has four sections: Positive, Negative, Zeros, and Text.
They're separated by semicolons, like this:

#,###.00_);[Red](#,###.00);0.00;"FW: "@

The following table provides an explanation of this code.

Code Explanation
#,###.00_) Positive numbers are displayed with a comma separator and with

significant digits only when to the left of the decimal point. Two
digits are to the right of the decimal point, even if they're zeros.
There's a right-parenthesis-sized blank space to the right of the
number.

[Red](#,###.00) Negative numbers are displayed the same as positive ones except
that they're in red and have parentheses around them.

0.00 Zero values are displayed as 0.00.
"FW: "@ FW: precedes all text strings.

Table 4-2: Custom number format codes

Now that you know how to use custom number formats, in the next section you'll learn
how to modify them.

started.

Watch the Video!
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Modifying a Custom Format

You can often modify an existing custom format, so you don't have to reinvent the
wheel every time.

Do the following to try modifying a custom format:

Select a cell that has a number in it. Type a number into a cell, if needed.1.
Right-click the cell, select Format Cells, and then click the Number tab in the2.
Format Cells dialog box.

You can open the Format Cells dialog box in other ways, including clicking the
dialog box launcher in the Number group on the Home tab.

From the Categories list, select Custom.1.
Scroll through the list of custom formats, and then select this custom format:2.

#,##0_);[Red](#,##0)

Replace the word Red with Green in the Type text box, as shown in Figure 4-1.
10.

Figure 4-10: Modify a custom number format to show green rather than red for
negative numbers.

Enlarge image

Click OK to apply the format to the number. The color doesn't change, yet.1.
Edit the number so it's negative. The number's font color turns green.2.

Modifying existing formats saves time and still gives you the results you want.

Creating Your Own Custom Formats

Using the symbols described earlier in the lesson, you can develop your own custom
formats.

Try this one to test yourself. Create a format that shows the currency symbol, but
doesn't use commas, and uses no decimal places. For negative numbers, have them
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appear in red and with a minus sign preceding them, but not in parentheses. Force
one digit to display; all others are optional. Don't indicate anything special for zero or
text format.

This is the answer:

$###0;[Red]"-"$###0

For the first part (the positive number), it's a simple dollar sign followed by three
optional digits with no commas, ending with a required digit so that if the value is zero,
it'll show $0 instead of just being blank.

For the second part, [Red] indicates that negative numbers will be red. The "-" is for
the minus sign. The rest is the same as for the positive number.

Moving On

Congratulations, you've completed this course! In this lesson, you learned advanced
formatting techniques for Excel. You learned how to use themes, styles, conditional
formatting, and custom number formats. Before you move on, complete the
assignment and take the quiz for this lesson to help reinforce important concepts and
techniques.

We hope you've enjoyed taking this course and that you'll consider taking other
courses here at this learning center.

Assignment #4

For this assignment:

Download IntExcel07-Assign4.xls, and then save it in Excel 2007 format.1.
Format the worksheet any way you like. Here are some ideas:2.

Select the data range (A1:H74), and then use Format as Table on the Home
tab to apply automated formatting.

Widen columns as needed so data will display without being truncated.

Apply a theme to the worksheet from the Page Layout tab.

Use conditional formatting so anyone who lives in Indiana (IN) is formatted with the1.
state code in column G in bold and green.
Insert four rows at the top of the worksheet.2.
In cell B1, enter =TODAY() to insert today's date.3.
Create a custom number format for cell B1 that shows the month, day, and year4.
with the month fully spelled out, like this: June 25, 2007.

To spell out the complete month, use four m's like this: mmmm.

Save your work and exit the program.1.

 

Quiz #4
Question 1:
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Which types of formatting does a theme define? (Check all that apply.)

A)  Styles
B)  Fonts
C)  Colors
D)  Font sizes
E)  Appearance effects for graphical objects
 
Question 2:
On which tab does the Cell Styles menu button appear?

A)  Format
B)  Home
C)  Page Layout
D)  Insert
 
Question 3:
To create a template that applies to the new workbook that opens automatically when Excel starts, create a file
called _______, and then store it in the Program Files\Microsoft Office\Office12\XLSTART folder.

A)  Blank
B)  Default
C)  Book1
D)  Book
 
Question 4:
In a cell where the content is 123 and the custom number formatting code is $#,##0.00_);($#,##0.00), how will
the cell content appear?

A)  123
B)  $123
C)  $123.00
D)  ($123.00)
 
Question 5:
In a cell where the content is =NOW( ), the current date is 6/18/2008, the current time is 11:15 a.m., and the
custom number formatting code is mmmm d, yyyy h:mm AM/PM, how will the cell content appear?

A)  June 18, 2008 11:15 AM
B)  June 8, 2007 1:15 AM
C)  6 8, 2007 11:15 AM
D)  6/18/2008 11:15 am
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