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Getting Started  
with Excel 



XP 
Objectives 

• Understand the use of spreadsheets and Excel 

• Learn the parts of the Excel window 

• Scroll through a worksheet and navigate 
between worksheets 

• Create and save a workbook file 

• Enter text, numbers, and dates into a 
worksheet 

• Resize, insert, and remove columns and rows 



XP 
Objectives 

• Select and move cell ranges 

• Insert formulas and functions 

• Insert, delete, move, and rename 
worksheets 

• Work with editing tools 

• Excel Shortcuts and formulas 
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XP 
Introducing Excel 

• Microsoft Office Excel 2007 (or Excel) is a computer 
program used to enter, analyze, and present 
quantitative data 

• A spreadsheet is a collection of text and numbers 
laid out in a rectangular grid. 

– Often used in business for budgeting, inventory 
management, and decision making 

• What-if analysis lets you change one or more values 
in a spreadsheet and then assess the effect those 
changes have on the calculated values 
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XP 
Introducing Excel 
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XP 
Exploring Excel 
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XP 
Exploring Excel 
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XP 
Navigating a Worksheet 

• Excel provides several ways to navigate a 
worksheet 
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XP 
Planning a Workbook 

• Before you begin to enter data into a 
workbook, you should develop a plan 

– Planning analysis sheet 
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XP Entering Text, Numbers, and Dates  
in Cells 

• The formula bar displays the content of the 
active cell 

• Text data is a combination of letters, 
numbers, and some symbols 

• Number data is any numerical value that can 
be used in a mathematical calculation 

• Date and time data are commonly 
recognized formats for date and time values 
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XP Entering Multiple Lines of Text  
Within a Cell 

• Click the cell in which you want to enter the text 

• Type the first line of text 

• For each additional line of text, press the Alt+Enter 
keys (that is, hold down the Alt key as you press the 
Enter key), and then type the text 
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XP Changing Column Width  
and Row Height 

• A pixel is a single point on a computer 
monitor or printout 

• The default column width is 8.38 standard-
sized characters 

• Row heights are expressed in points or 
pixels, where a point is 1⁄72 of an inch 

• Autofitting eliminates any empty space by 
matching the column to the width of its 
longest cell entry or the row to the height of 
its tallest cell entry 
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XP Changing the Column Width  
and Row Height 

• Drag the right border of the column heading left to decrease the 
column width or right to increase the column width 

• Drag the bottom border of the row heading up to decrease the 
row height or down to increase the row height 

or 
• Double-click the right border of a column heading or the bottom 

border of a row heading to AutoFit the column or row to the cell 
contents (or select one or more column or rows, click the Home 
tab on the Ribbon, click the Format button in the Cells group, and 
then click AutoFit Column Width or AutoFit Row Height) 

or 
• Select one or more columns or rows 
• Click the Home tab on the Ribbon, click the Format button in the 

Cells group, and then click Column Width or Row Height 
• Enter the column width or row height you want, and then click 

the OK button 
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XP 
Inserting a Column or Row 

• Select the column(s) or row(s) where you 
want to insert the new column(s) or row(s); 
Excel will insert the same number of 
columns or rows as you select 

• In the Cells group on the Home tab, click the 
Insert button (or right-click a column or row 
heading or selected column and row 
headings, and then click Insert on the 
shortcut menu) 
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XP 
Inserting a Column or Row 
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XP 
Deleting and Clearing a Row or Column 

• Clearing data from a worksheet removes the 
data but leaves the blank cells 

• Deleting data from the worksheet removes 
both the data and the cells 
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XP 
Working with Cells and Cell Ranges 

• A group of cells is called a cell range or 
range 

• An adjacent range is a single rectangular 
block of cells 

• A nonadjacent range consists of two or 
more distinct adjacent ranges 

• A range reference indicates the location and 
size of a cell range 
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XP 
Selecting Cell Ranges 

To select an adjacent range: 
• Click the cell in the upper-left corner of the adjacent range, 

drag the pointer to the cell in the lower-right corner of the 
adjacent range, and then release the mouse button 

or 
• Click the cell in the upper-left corner of the adjacent range, 

press the Shift key as you click the cell in the lower-right 
corner of the adjacent range, and then release the Shift key 

To select a nonadjacent range of cells: 
• Select a cell or an adjacent range, press the Ctrl key as you 

select each additional cell or adjacent range, and then 
release the Ctrl key 

To select all the cells in a worksheet: 
• Click the Select All button located at the intersection of the 

row and column headings (or press the Ctrl+A keys) 
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XP 
Selecting Cell Ranges 
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XP 
Moving or Copying a Cell or Range 

• Select the cell or range you want to move or copy 
• Move the mouse pointer over the border of the selection until 

the pointer changes shape 
• To move the range, click the border and drag the selection to a 

new location (or, to copy the range, hold down the Ctrl key and 
drag the selection to a new location) 

or 
• Select the cell or range you want to move or copy 
• In the Clipboard group on the Home tab, click the Cut button or 

the Copy button (or right-click the selection, and then click Cut or 
Copy on the shortcut menu) 

• Select the cell or upper-left cell of the range where you want to 
move or copy the content 

• In the Clipboard group, click the Paste button (or right-click the 
selection, and then click Paste on the shortcut menu) 
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XP 
Moving or Copying a Cell or Range 

21 



XP 
Inserting and Deleting a Cell Range 
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XP 
Inserting or Deleting a Cell Range 

• Select a range that matches the range you want to insert or 
delete 

• In the Cells group on the Home tab, click the Insert button 
or the Delete button 

or 
• Select the range that matches the range you want to insert 

or delete 
• In the Cells group, click the Insert button arrow and then 

click the Insert Cells button or click the Delete button arrow 
and then click the Delete Cells command (or right-click the 
selected range, and then click Insert or Delete on the 
shortcut menu) 

• Click the option button for the direction in which you want 
to shift the cells, columns, or rows 

• Click the OK button 
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XP 
Inserting and Deleting a Worksheet 

• To insert a new worksheet into the workbook, right-
click a sheet tab, click Insert on the shortcut menu, 
select a sheet type, and then click the OK button 

• You can delete a worksheet from a workbook in two 
ways: 

– You can right-click the sheet tab of the worksheet you 
want to delete, and then click Delete on the shortcut 
menu 

– You can also click the Delete button arrow in the Cells 
group on the Home tab, and then click Delete Sheet 
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XP 
Renaming a Worksheet 

• To rename a worksheet, you double-click the 
sheet tab to select the sheet name, type a 
new name for the sheet, and then press the 
Enter key 

• Sheet names cannot exceed 31 characters in 
length, including blank spaces 

• The width of the sheet tab adjusts to the 
length of the name you enter 
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XP 
Moving and Copying a Worksheet 

• You can change the placement of the 
worksheets in a workbook 

• To reposition a worksheet, you click and 
drag the sheet tab to a new location relative 
to other worksheets in the workbook 

• To copy a worksheet, just press the Ctrl key 
as you drag and drop the sheet tab 
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XP 
Editing Your Work 

• To edit the cell contents, you can work in 
editing mode 

• You can enter editing mode in several ways: 

– double-clicking the cell 

– selecting the cell and pressing the F2 key 

– selecting the cell and clicking anywhere within 
the formula bar 

27 



XP 
Editing Your Work 
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XP 
Using Find and Replace 

• You can use the Find command to locate 
numbers and text in the workbook and the 
Replace command to overwrite them 

29 



XP 
Using the Spelling Checker 

• The spelling checker verifies the words in 
the active worksheet against the program’s 
dictionary 
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XP 
Changing Worksheet Views 

• You can view a worksheet in three ways:  

– Normal view simply shows the contents of the 
worksheet 

– Page Layout view shows how the worksheet 
will appear on the page or pages sent to the 
printer 

– Page Break Preview displays the location of the 
different page breaks within the worksheet 
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XP 
Changing Worksheet Views 
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XP 
Changing Worksheet Views 
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XP Working with Portrait  
and Landscape Orientation 

• In portrait orientation, the page is taller 
than it is wide 

• In landscape orientation, the page is wider 
than it is tall 

• By default, Excel displays pages in portrait 
orientation 
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XP Working with Portrait  
and Landscape Orientation 

• To change the page orientation: 

– Click the Page Layout tab on the Ribbon 

– In the Page Setup group, click the Orientation 
button, and then click Landscape 

– The page orientation switches to landscape 
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XP 
Printing the Workbook 

• You can print the contents of your workbook by 
using the Print command on the Office Button 

• The Print command provides three options: 
– You can open the Print dialog box from which you 

can specify the printer settings, including which 
printer to use, which worksheets to include in the 
printout, and the number of copies to print 

– You can perform a Quick Print using the print 
options currently set in the Print dialog box 

– Finally, you can preview the workbook before you 
send it to the printer 
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XP 

Excel Shortcuts 
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XP 
Excel Keyboard Shortcuts 

  When you are first getting used to Excel 
you will probably be focused on just getting 
your task done rather than learning how to 
work more efficiently. However, when you 
are ready to learn about the Excel keyboard 
shortcuts this lesson will teach you the most 
important and useful Excel shortcuts 
currently available. 



XP 

• The benefits of using a keyboard shortcut are twofold: 
• It is quicker to keep your hand on the keyboard then shift 

from keyboard to mouse to keyboard 
• You will experience less stress on your muscles if you 

shift your hands less 
• We have divided the keyboard shortcuts into related 

areas. This way you can focus on learning a group of 
shortcuts at a time, rather than all at once! 

• Shortcut Help: Combination keyboard shortcuts, those 
that have a plus (i.e. Ctrl + S), require that you hold the 
first key (Control) then press the second key (S) while 
still holding down the first key. 
 



XP 
Excel Shortcuts: Files 

  This small group of shortcuts is useful for 
opening, closing and saving your Excel 
workbooks. 

 

• Ctrl+S: Save your Excel workbook 

• Ctrl+O: Open an existing Excel workbook 

• Ctrl+N: Create a new Excel workbook 

 



XP 
Excel Shortcuts: Editing 

  These are common shortcuts you will use to edit your Excel workbook. 
Our favorite shortcut in this list is, quite obviously, Ctrl+Z. 

 
• Ctrl+C: Copy the current selection to the clipboard. After you copy something, 

you can paste it with the paste shortcut. 
• Ctrl+V: Paste the current item from the clipboard. 
• Ctrl+X: Cut the current selection and place it on the clipboard, which can be 

pasted. The difference between cut and copy is that cut will delete your 
selection, while copy will not. 

• Ctrl+Z: Undo your last change. This is can be repeated to remove again and 
again to undo many changes. 

• Ctrl+Y: Redo your last Undo. This only is available if you have just issued an 
Undo command. 

• Backspace: Deletes the current cell and enters edit mode for that cell. This will 
only delete one cell and not a selection. 

• Delete: Deletes the current selection. Use the delete key when you want to 
delete more than one cell at a time. 
 



XP 
Excel Shortcuts: Getting Around 

  These shortcuts will help you move around your Excel workbooks and 
worksheets with great ease! 

 
• Page Up: Move one page up in your worksheet 
• Page Down: Move one page down in your worksheet. Note: The number of 

rows moved in both page up and page down depend on how many rows are 
currently displayed. The more rows you have displayed the greater amount the 
row jump will be when you do a page up/down. 

• Ctrl+Home: Move to the beginning of your worksheet 
• Ctrl+End: Move to the end of your worksheet 
• Tab: Move right one column 
• Shift+Tab: Move left one column 
• Ctrl+Page Up: Go back one worksheet 
• Ctrl+Page Down: Go forward one worksheet. Note: If you are not using multiple 

worksheets in your workbook you will probably not use this shortcut! 
 



XP 
Excel Shortcuts: Formatting 

  These shortcuts will help you 
quickly format your data. 

 

• Ctrl+B: Toggles bold on and off for your 
selection 

• Ctrl+I: Toggles italic on and off for your 
selection 

• Ctrl+U: Toggles underline on and off for 
your selection 

 

• Ctrl+1: Opens up the Format Cell popup  

 



XP 
Excel Shortcuts: Menu 

  These shortcuts allow you to active the various options on the menu bar 
without have to mouse-click them.  

 
Note: These shortcuts use Alt as their combination key. 
 
• Alt+F: Accesses the File menu 
• Alt+E: Accesses the Edit menu 
• Alt+V: Accesses the View menu 
• Alt+I: Accesses the Insert menu 
• Alt+T: Accesses the Tools menu 
• Alt+D: Accesses the Data menu 
• Alt+W: Accesses the Window menu 
• Alt+H: Accesses the Help menu 
 
  After you have used one of these shortcuts you can use the arrow keys to 

navigate the menu choices and use the Enter key to select a choice. 
 



XP 
Excel Shortcuts: Selecting 

  These shortcuts help you to quickly 
select items in your Excel file in various 
ways. 

 

• Shift+Spacebar: Select the current Row 

• Ctrl+Spacebar: Select the current column 

• Ctrl+A: Select All, will select everything on 
the current worksheet. This is most often 
used in conjunction with the copy shortcut. 

 



XP 
Excel Shortcuts: Miscellaneous 

  And the two black sheep of the shortcut 
essentials: 

 

• F1: Opens up the quick help feature 

• Ctrl+P: Print your worksheet 

 



XP 

Excel 2007 Formula 



XP Excel 2007 Formula: A foundation to 
start writing a formula! 

• A formula is an equation that performs operations on 
worksheet data. You can use an Excel 2007 formula to 
perform mathematical operations, such as addition and 
multiplication, or they can compare worksheet values, 
join text, averaging a student's test results, etc.  
 

• Formulas can refer to other cells on the same worksheet, 
cells on other sheets in the same workbook, or cells on 
sheets in other workbooks. In addition, if you change the 
data in your spreadsheet, Excel will automatically 
recalculate the answer without you having to re-enter 
the formula.  



XP 

• A basic formula format will start with an 
equals sign (=) followed by one or more 
operands, separated by one or more 
operators. Operands can be values, text, cell 
references, ranges, defined names, or 
function names. Operators are symbols used 
to represent the various arithmetic and 
comparison operations you can perform on 
the operands. 

 



XP 

  In Microsoft Excel 2007, operators are 
executed in this order: 
 

 



XP 

To enter a formula  
 
• Place the cursor in the cell where the formula will appear, i.e.E5. 
•  Enter  an = sign. All Excel formulas start with the ‘equal’ sign.  
• Enter the expression that will produce the result you want. This can 

consist of operands, values, variables, and symbols which represent 
mathematical procedures such as + or – to add and subtract, e.g. 
A5+C5.  

• When the formula is complete, press Enter. The result of the formula 
will be calculated and displayed in the cell E5.  

• You can see the formula in the Formula bar at the top of the screen by 
placing the cell pointer on the cell E5. 
 
 
 



XP 

• If there is an error in a formula, an error message is displayed which will 
begin with a # sign. 
 

To know the formula error messages  
 

• When writing formulas it is easy to make a mistake. Here are some 
common mistakes: 
 
 



XP 
 To enter a cell or range reference by pointing  
 
• Place the cursor in the cell where the formula will appear.  
• Enter the formula up to the point of the cell or range reference, 

e.g. to enter the formula =E2+E5, only enter the = sign.  
• Using the arrow keys, move the cell pointer to the first cell 

reference, in this case E2. The formula will track your progress 
and enter the current address into the formula. 

•  Enter the operand, + sign.  
• Using the arrow keys, move the cell pointer to the second cell 

reference, in this case E5. If you are calculating a range of cells, 
hold down the Shift key while using the arrow keys to move to 
the intended cells.  

• Press Enter to complete the formula when you have reached the 
cell you require. 
 



XP 
Excel Formulas 

• A forumla is nothing more than an equation that you 
write up. In Excel a typical formula might contain 
cells, constants, and even functions. Here is an 
example Excel formula that we have labeled for your 
understanding. 
 

    =B3 * 5 / SUM(B4:B7) 
 

• cell(s): B3 and the range of cells from B4:B7 
• constant(s): 5 
• function(s): SUM() 

 



XP 
Creating Your First Formula 

  This first formula will be as simple as they come and 

will teach you the basic form of an Excel formula. Create a 
new spreadsheet and then follow these steps: 

 

• Select cell A1 

• Type the following basic arithmetic formula into cell A1: =1+1 

 

 



XP 

• Press Enter and notice how cell A1 changes from your formula to 
the result! 
 
 
 
 

• This may seem simple, but there are a some very important 
things you should get out of this example. When you start off a 
cell entry with the equal sign "=" you are telling Excel that you 
want it to evaluate the following formula. 

• In our case we had a simple "1+1" we wanted Excel to solve for 
us. You can do this for addition, subtraction, multiplication, 
division and any other operation you can think of. 
 

  Remember, if you do not start your entry with the equal 
sign, then Excel will not evaluate the cell! 
 



XP Using Cells to Create Dynamic 
Formulas 

  The most powerful aspect of Excel is not the simple calculator abilities 
we describes in our first formula example, but rather the ability to take 
values from cells to be used in your formulas. 

 
• Let's set up a basic sales spreadsheet to help explain this topic. 
• In cells A1-D4 enter the following information: 

 
 
 

 
 
• Notice: that cell D2 and D3 are blank, but should contain the amount of money from 

selling 150 candy items and 3 vegetables. By referencing the Quantity and Price cells we 
will be able to do this! Let's begin with Candy. 

 
 



XP 

• Note:It is very important to follow these steps exactly without interruptions! Select cell 
D2, candy's "revenue", and type the equal sign "=" to begin your formula. 

 

• Left-click on cell B2, Candy's Quantity and notice your formula is now "=B2" 
 

 

 

 

 

 

 

• We want to multiply Quanity(B2) by Price(B3) so enter an asterisk (*) 
 

 



XP 

• Now left-click on Candy's Price (C2)to complete your formula! 

 

 

 

 

• If your formula looks like ours then press Enter, otherwise you can manually 
enter the formula "=B2*C2". However, we really think it is easier and preferred 
to click on cells to reference them, instead of entering that information 
manually. 

• After you pressed Enter your Candy Revenue cell should be functioning properly 
and contain the value 75. 
 

 
 



XP 

• Using your newly gained knowledge please 
complete Vegetable's Revenue by repeating 
steps 2-7 for Vegetable 

• Your spreadsheet should now look like this: 
 
 
 
 
 

• Cheatsheet: If you are having trouble creating 
the formula for Vegetable's Revenue it is 
"=B3*C3" 
 



XP Advanced Excel Formulas: Using 
Formulas in Formulas 

  Now that we have created separate revenues for both Candy and Vegetable it would be 
nice to somehow combine these two values to get the Total Revenue. Although both Vegetable 
Revenue and Candy Revenue contain formulas, we can still use these cells as we have been 
doing and add them together to get our total. 
 

• Select cell D5 (directly below "Total") 
• Type the equal sign "=" 
• Left-click cell D2 
• Type the plus sign "+" 
• Left-click cell D3. Cell D5 should now contain this formula "=D2+D3": 

 
 
 
 
 
 

• Press Enter to complete your Total Revenue!  
 

 
 



XP Excel 2007 Functions: An 
Introduction 

Excel 2007 Functions are build-in, special 
commands that incorporated into the 
formulas to perform mathematical 
calculations. It can be used to make complex 
operations simple. Excel 2007 contains a 
build-in list of worksheet functions, which 
are categorised to make it easy to search for 
the ones you need. 

 



XP 

• Functions are special commands used in 
formulas to perform mathematical 
processes. 

 



XP 

• Excel has over 300 built-in functions divided into various 
function categories, including: 
– Financial 
– Logical 
– Text 
– Date & Time 
– Lookup & Reference 
– Math & Trigonometry 
– Information 
– Database 
– Statistical 
– Engineering 
– Cube 
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• Here are some commonly used functions: 
AVERAGE: Used to determine the average value of the 
selected cells contents. 
COLUMNS: Used to return the number of columns within a 
reference.  
COUNT: Used to count how many numbers are in the list.  
MAX: Used to return the maximum number from a list.  
MIN: Used to return the minimum number from a list.  
ROUND: Used to round off numbers to a specified number 
of decimal points.  
SUM: Used to add the contents of selected cells.  



XP 
To display all the available functions 

• Open a blank Excel workbookClick on 
the Formulas tab and within the Function 
Library group click on the Insert 
Function icon. 



XP 



XP 

• From the Insert Function dialog box 
displayed, under Or select a 
category: section, select a particular 
category function, the related functions will 
displayed. 



XP To enter functions directly into the worksheet 
cell 

• Select the cell into which the formula will be entered. 
• Insert an equal (=) sign to begin the formula. 

The formula toolbar buttons will appear. 
• Enter the name of the function [e.g. SUM], followed 

by an opening parenthesis [(], any arguments 
required for the function [e.g. E2:E5], and closing 
parenthesis[)]. 

• Press Enter. If there are no errors in the formula, the 
result of the function will be entered in the cell. If 
you activate the cell again, the function will be 
displayed in the formula bar. 
 



XP 
To use the AutoSum function 

• The functions can be accessed through 
the AutoSum icon on the Standard toolbar. 

• The functions included in the AutoSum drop-
down menu will insert the function and 
predict the arguments. 

• For example, if the active cell is positioned at 
the bottom of the list of values, AutoSum 
will display a sum function with the list of 
the arguments.  
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• Sum -- add the contents of the list of 
arguments. 

• Average -- determine the average 
value of the list of arguments. 

• Count -- count the number of values 
in the list of arguments. 

• Max -- return the maximum number 
in the list of arguments. 

• Min -- return the minimum number in 
the list of arguments 



XP Example: Using the Average 
function 

• Enter the values as shown below from B1 to B5 and 
select the cell B6 which the formula will be 
entered. 



XP 

• From the Insert Function dialog box 
displayed, under Or select a 
category: section, select a particular 
category function, the related functions will 
displayed. 



XP 

• Click the down arrow beside the AutoSum icon on 
the Standard toolbar and choose Average from the 
drop-down menu. 

• If the predicted range is correct, press the Enter key. 
If it is incorrect, select (click and drag) the range you 
want with the mouse and press theEnter key. 

• The result will show in cell B6. You can use the same 
method to do other functions such as SUM, Max, etc. 
 
Note: Excel formula and function is one of the most 
powerful feature in Microsoft Excel.  



XP Viewing and Printing Worksheet 
Formulas 

• You can view the formulas in a workbook by 
switching to formula view, a view of the 
workbook contents that displays formulas 
instead of the resulting values 

• To change the worksheet to formula view, 
press the Ctrl+` keys 

• Scaling a printout reduces the width and the 
height of the printout to fit the number of 
pages you specify by shrinking the text size as 
needed 
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XP Viewing and Printing Worksheet 
Formulas 
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XP Viewing and Printing Worksheet 
Formulas 
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