Cours Packet Tracer

Explorer Packet Tracer V5.3 en PDF


Télécharger Explorer Packet Tracer V5.3 en PDF

★★★★★★★★★★3.5 étoiles sur 5 basé sur 1 votes.
Votez ce document:

Télécharger aussi :


Session Title:  Exploring Packet Tracer v5.3 – IP Telephony & CME

Scenario

With the scheduled release of Packet Tracer v5.3 in the near future, this case study is designed to provide you with an insight into some of the new features.  Here you will be working with the new IP Telephony features, where you will be configuring Call Manager Express, setting up dial peers and connecting IP phones as well as analogue phones.

This activity is designed to provide you with an insight into what is now possible within Packet Tracer, how to use the various telephony devices, and finally how to apply the configuration.

For the purposes of this activity we will assume that Company XYZ has two remote buildings.  Each building contains a router configured with DHCP, CME, & other telephony features. It also contains a Multilayer Switch configured to handle voice packets, and finally there are a number of telephone devices.  The telephone devices vary, in some cases; the phones located within the buildings are IP Phones, or IP Communicators, or Analogue Phones.  All phone devices must be able to call one another internally within a building as well as being able to call phones located within other buildings.

You will need to work through the steps provided within this document, completing the configuration and inserting the various devices where needed.

Learning Objectives

To explore the new features of Packet Tracer v5.3

Configure basic router & switch functions

Configure DHCP, Call Manager Express, Dial Peers, & Telephony Features

Topology Diagrams

The topology that you should end with is shown below:

 

The topology that you start with is shown below:

 

Tasks

Step 1:  ‘Building_One_Router’ needs to be configured for DHCP to provide addressing for each IP Phone to be connected.  Once DHCP is configured, you will need to configure the FastEthernet0/0 interface and ensure that the IP Phone connected to the multilayer switch receives an IP Address.

For ‘Building_One_Router’, apply the following dhcp configuration:

Building_One_Router>enable

Building_One_Router#configure terminal

Building_One_Router(config)#ip dhcp pool CATC                   

#Sets the DHCP pool name: CATC#

Building_One_Router(dhcp-config)#network 1.0.0.0 255.0.0.0

#DHCP network 1.0.0.0 with /8 mask#

Building_One_Router(dhcp-config)#default-router  1.1.1.1 

#Specifying the default router#

Building_One_Router(dhcp-config)#option 150 ip 1.1.1.1      

#Supports Cisco IP Phone requirement for DHCP#

Building_One_Router(config)#interface FastEthernet0/0         

#Selects the Fa0/0 interface for configuration#

Building_One_Router(config-if)#ip address 1.1.1.1 255.0.0.0

#Applying the IP address#

Building_One_Router(config-if)#no shutdown                           

#Activating the interface#

Verify that ‘IP Phone 1’ has received an IP address by placing your cursor over the phone until a configuration summary appears.  (This may take a short while - please be patient).



Step 2:In order for ‘Building_One_Router’ to handle voice packets, you must now configure the Call Manager Express telephony service.  You will also need to specify the maximum number of phones that the router will support and dial numbers.

For ‘Building_One_Router’ apply the following configuration:

                Building_One_Router(config)#telephony-service                                     #Configuring the router for telephony services#

                Building_One_Router(config-telephony)#max-ephones 5                      #Setting the number of phones#

                Building_One_Router(config-telephony)#max-dn 5                                #Setting the number of directory numbers#

Building_One_Router(config-telephony)#ip source-address 1.1.1.1 port 2000 #IP Address source#

                Building_One_Router(config-telephony)#auto assign 4 to 6                 #Automatically assigning ext numbers to buttons#

                Building_One_Router(config-telephony)#auto assign 1 to 5                 #Automatically assigning ext numbers to buttons#

Step 3:  Switchport’s Fa0/1 – 5 on ‘Building_One_Switch’ need to be set to ‘voice’ in order to handle voice packets belonging within VLAN 1.

For ‘Building_One_Switch’ apply the following configuration:

                Building_One_Switch(config)#interface range fa0/1 – 5                          #Configuring interface range#

                Building_One_Switch(config-if-range)#switchport voice vlan 1           #Setting switchport’s to handle voice packets#

Step 4:IP Phone 1’ is already connected to the multilayer switch port Fa0/2, in order to configure this IP Phone with a dial number you will need to apply the following configuration to ‘Building_One_Router’:

                Building _One_Router(config)#ephone-dn 1                                              #Defining IP Phone directory number#

                Building_One_Router(config-ephone-dn)#number 1101                        #Assigning the number#

Ensure that this IP Phone receives an ‘IP Address’ from the DHCP server configured on ‘Building_One_Router’ and also a

‘Line Number’.  (Please note that this can take a short while).

You are now at the stage where you can add additional IP Phones to Packet Tracer.  You will also need to apply the configuration to each router stating that a phone has been connected and the dial number that should be assigned to the particular phone.

Adding IP Phone 2

Place an IP Phone into the physical workspace within Packet Tracer and name it ‘IP Phone 2’. Connect the switchport of the IP Phone to port Fa0/3 of ‘Building_One_Switch’.

Now apply the following configuration on ‘Building_One_Router’:

                Building _One_Router(config)#ephone-dn 2                                              #Defining IP Phone directory number#

                Building_One_Router(config-ephone-dn)#number 1201                        #Assigning the number#

After a short while, the IP Phone will be configured with an ‘IP Address’ and also a ‘Line Number’ should appear within its configuration.  Verify that this has occurred.



Adding IP Phone 3

Place an IP Phone into the physical workspace within Packet Tracer and name it ‘IP Phone 3’. Connect the switchport of the IP Phone to port Fa0/4 of ‘Building_One_Switch’.

Now apply the following configuration on ‘Building_One_Router’:

                Building _One_Router(config)#ephone-dn 3                                              #Defining IP Phone directory number#

                Building_One_Router(config-ephone-dn)#number 1301                        #Assigning the number#

After a short while, the IP Phone will be configured with an ‘IP Address’ and also a ‘Line Number’ should appear within its configuration.  Verify that this has occurred.

Adding the IP Communicator

Repeat the above process, however, this time add a ‘Laptop’ instead of an IP Phone to Packet Tracer. Here you will use the ‘IP Communicator’ inplace of a physical IP Phone. Connect the Ethernet port of the laptop to port Fa0/5 of ‘Building_One_Switch’. Ensure that the laptop has been set to receive an IP Address via DHCP!

Now apply the following configuration on ‘Building_One_Router’:

                Building _One_Router(config)#ephone-dn 4                                              #Defining IP Phone directory number#

                Building_One_Router(config-ephone-dn)#number 1401                        #Assigning the number#

After a short while, the laptop will be configured with an ‘IP Address’ and a ‘Line Number’ should also appear within its IP Communicator configuration.  Verify that this has occurred.

Step 5:  Testing & Verification.  The information shown in the below table should be similar to your IP Configuration & Line Numbers.  Please verify that you have similar results:

Building

Phone

IP Address

Line Number

Building One

IP Phone 1

1.0.0.1

1101

IP Phone 2

1.0.0.2

1201

IP Phone 3

1.0.0.3

1301

IP Communicator

1.0.0.4

1401

Building Two

Administrator IP Phone

2.0.0.1

2101

Analogue Phone

-

2501

Within each building check to see if you can call between IP Phones, for example, select IP Phone 1 (take the receiver off the phone) and dial IP Phones 2, 3, or the IP Communicator.



Step 6:  At the moment ‘Building_One_Router’ and ‘Building_Two_Router’ are not connected.  You will need to establish a WAN serial connection between the two routers by connecting both S0/3/0 interfaces.  You will then need to define a static route on each of the two routers notifying them of route information to each network.

First of all place a serial connection between interfaces S0/3/0 of each router.  Note that ‘Building_One_Router’ should be designated as the DCE.

Apply the following configuration to ‘Building_One_Router’:

Building _One_Router(config)#interface serial 0/3/0

Building_One_Router(config-if)#ip address 3.0.0.1 255.0.0.0

Building_One_Router(config-if)#clockrate 56000

Building_One_Router(config-if)#no shutdown

Apply the following configuration to ‘Building_Two_Router’:

Building _Two_Router(config)#interface serial 0/3/0

Building_Two_Router(config-if)#ip address 3.0.0.2 255.0.0.0 Building_Two_Router(config-if)#no shutdown

Step 7:  Now that the interfaces have been configured, you will need to configure Static Routes on each router so that traffic can be routed from network 1.0.0.0/8 through to 2.0.0.0/8 via network 3.0.0.0/8.

Step 8:  Finally, now that you have connectivity between all phone devices within each Local Area Network, and that you have established a WAN connection between both routers defining static routes; you are now ready to configure the ‘Dial Peer Mapping’ so that an IP Phone belonging within one LAN can call across the WAN to another IP Phone.

In order to do this you will need to configure dial peer information on ‘Building_One_Router’:

                Building _One_Router(config)#dial-peer voice 1 voip                                             #Assigning the dial-peer#

                Building_One_Router(config-dial-peer)#destination-pattern 2…                       #Destination dial pattern begins with n.o.2#

                Building_One_Router(config-dial-peer)#session target ipv4:3.0.0.2                    #Gateway to Building_Two_Router#

Dial peer information for ‘Building_Two_Router’ has already been configured.

Step 9:  Testing & Verification.   

Please complete the following tests to ensure that you have end-to-end connectivity between all telephone devices.  Note, to make a call: first select a phone with your mouse cursor; looking at the GUI, click on the receiver to dismount it from the telephone; then finally dial the destination telephone number.

1.    Test that you can call from ‘IP Phone 1’ through the WAN to the ‘Administrators IP Phone’.

2.    Test that you can call from the ‘Analogue Phone’ to the ‘IP Communicator’.

Once a call is placed, you should see similar results to the below screen capture.  Here we have the IP Phone 1 (right) calling the Administrators IP Phone (left).  Notice the caption above the phone on the Administrators IP Phone stating that “The phone is ringing”.

 



428