
Tổng hợp các Tutorials về Gimp
Sưu tập và tổng hợp bởi ThiênLong (http://thegioiquay.tk)

Nội dung:
1. Text Effects   :

1. Neo Glow  

2. Cool glowing text  

3. Gold Text  

4. Transparent Glass Lettering  

5. Text to Path  

6. Hot text on flames / fire  

7. Web 2.0 Text logo  

8. Text Outline  

9. Neo inscription  

10.The Beveled Text Dance  

11.iText  

12.Metallic Text  

13.Rounded Corners  

14.Smelting text / Creating blood text  

15.Tutorial: Rays of Light (behind text)  

2. Photos / Wallpapers :  

1. Perfect masking using a highpass  

2. Infrared / Monochrome Effect  

3. Smoke and Flames  

4. Old Parchment Paper  

5. How to generate realistic mass waterdrops on a surface  

6. Planet in a wireframe model  

7. Simple Scanlines  

8. Exploding Planet  



9. Creating the Che Guevara Effect  

10.Hot Wallpaper with Flames  

11.Create a cool starfield  

12.Turning people into stone  

13.Create a shocking sphere/ball  

14.How to change a boring sky to a cool cloudy sky  

15.Vexel Simulation on Photos  

16.Old Photo  

17.Popout Photo  

18.Adding photo frames to a photo in Gimp  

19.Choosing your photo  

20.Create an Apple like reflection with Gimp  

3. Buttons, Icons :  

1. Orb-Icons for Websites  

2. Creating a simple Company Logo  

3. Stylish buttons  

4. Creating 3D icons  

5. Smileys with The Gimp  

6. Create soft glassy buttons  

7. Create a shield symbol  

8. Vista Button  

9. Rounded Navigation Bar  

10.Windows Vista Folder Icon  

11.Button Tutorial for Gimp  

12.Designing With Gradients  

13.Creating Glassy Buttons  

14.Creating a Navigation Button  

15.Chains  

16.Glassy Spheres  

17.Gear Wheel  



18.Create a metallic glass button  

19.Web 2.0 Badges  

4. Website Layouts :  

1. Blog Theme Design tutorial  

2. Modern Navigation  

3. Creating Your Own Website Design Using Gimp  

4. The Complete Website Tutorial  

5. Create A Professional looking Logo Using Gimp  

6. Creating the Simnor Computing navigation menu  

7. SimplyBlue web layout - Part I  

8. SimplyBlue web layout - Part II  

9. Creating a ProBoards forum colour scheme  

10.Creating a Website Template  

11.Technical Border  

12.Sigs in Gimp  

13.How to Create Cool Signatures  

5. Effects :  

1. Generate a stripe-like texture  

2. Creating a bloody splatter texture  

3. Create a mystic chaos Voodoo-Pattern  

4. Generate a cool tech pattern  

5. A colored swirl of light  

6. Crazy Ions  

7. Create futuristic looking tech pattern  

8. Sun Ray Effect  

9. Glow Effect  

10.Lightning  

11.Gimp Fire  

12.Drop Shadow  

13.Wallpaper  



14.Galaxy  

6. Textures :  

1. Textured Design  

2. Make a Gimp pattern from scratch  

3. Snake Skin  

4. Water Surface  

5. Create a web 2.0 stripe header with Gimp  

7. Painting :  

1. blend colors  

2. Paint Cactus  

3. Drawing Trees  

8. Misc :  

1. Advance Orb  

2. Spam Flame sig  

3. Mac style Wallpaper  

4. Brave Attempt to Teach Layers in 3 Hours  

5. Software Boxes  

6. Convert Photoshop Layer Styles to Gimp Gradients  

7. iPod Dancer Tutorial  

8. Chocolate bar with GIMP  

9. Drawing Shapes with Bezier Tool  

1.Text effects

1.1 Neon Glow
In this simple tutorial I'm gonna show you how to create a cool neon glow text in only 5 very simple 
steps!

1. Create an empty file: 500x180 px. Choose black as background color. Choose the text-tool and 
write "neon text" in a size of 80. Move the text to the middle. Then do Layer / Layer to Picture 
size.



click to enlarge
2. Take the brush tool, choose a hard brush of a size of 13, now draw connections between the letters 

as seen on the picture. It doesn't have to be too exactly... We need these connections because neon 
text is always connected.

click to enlarge
3. Now go to Filter / Blur / Gaussian blur: 15px.

After that choose (GIMP 2.2: Layer ) / Colors / Curves and select ALPHA in the top left corner as 
channel. Now move the bottom left point to the center, the to right one move to the left also to the 
center.

click to enlarge
4. - Filter / Alpha to Logo / Neon and enter these values: 

Effect size: 40
Background color: black
Glow color: choose any cool color you like

http://www.gimpusers.com/images/tutorials/65/1.png
http://www.gimpusers.com/images/tutorials/65/2.png
http://www.gimpusers.com/images/tutorials/65/3.png
http://www.gimpusers.com/images/tutorials/65/4.png


click to enlarge
5. Now we're just adding a bit more glow to the text. You should have a layer named "Neon Tubes" 

and another named "Neon Glow" now. Activate the Glow layer and duplicate it. On the duplicate 
apply a Gaussian Blur: 35px. If you still don't have enough glow (like me ;)) just duplicate the 
layer again!

The whole thing could look like this:

Have fun!

click to enlarge

1.2 Cool glowing text
Written by devvv (18 May 2007 11:10 PM) 

In this tutorial I'll show you how to get this pretty nice glowing text effect using GIMP. In my opinion 
glowing text looks much better if you have text with a rounded font. Take a look at the rounded corners-
tutorial if you want your special font to be rounded off.

1. New file: 500x200px.
- Fill the background with black color.
- Take the text-tool and write any text you want onto a new layer. Use a font size of 60 for this at 
least.
- Layer / Layer to picture size. Now your text-layer should be renderend and have the same size as 
the whole picture.

click to enlarge
2. The next step is to create a strong outer glow.

http://www.gimpusers.com/users/devvv.html
http://www.gimpusers.com/images/tutorials/65/5.png
http://www.gimpusers.com/images/tutorials/69/1.png


- Click the layer with your right mouse button in the layers dialog menu. Choose "Selection from 
Alpha".
- Select / Grow: 3px
- Add a new layer, name it "schein nach aussen" (which measn outer glow in German ;)).
- Fill the selection on this layer with #007eff
- In the layers dialog move the layer behind the text-layer

click to enlarge
3. - Select / None (CTRL SHIFT A)

- Filter / Blur / Gaussian: 45px.
- Duplicate the layer and apply a gaussian blur again: 30px.

click to enlarge
4. My layers look like this now:

http://www.gimpusers.com/images/tutorials/69/2.png
http://www.gimpusers.com/images/tutorials/69/3.png


click to enlarge
5. Click the glowing text-layer in the layers dialog to activate it.

- duplicate it
- on the duplicate apply another gaussian blur. Take a value of 15.
- Set the layers mode (found in the layers dialog at the very top above the opacity) to "Dodge".

click to enlarge
6. - Duplicate the "schein nach außen" / "other glow"-layer.

- in the layers dialog move it to the top of all layers, so thats it is above all the other layers. Set the 
layers mode to "Dodge" again. This step makes the glow effect even stronger ;)

Thats it. Have fun with your own glowing text!

http://www.gimpusers.com/images/tutorials/69/4.png
http://www.gimpusers.com/images/tutorials/69/5.png


7. click to enlarge

1.3 Gold Text
Step 1

Create a new image. Give the background a radial gradient in the middle (#4d4932 to #201e1b):

Step 2

Set your foreground color to white and select the text tool. Type your text in the middle of your canvas. 
Then, making sure your text layer is selected, click "Create Path from Text":

http://www.gimpusers.com/images/tutorials/69/6.png


Step 3

Create a new layer above your text layer (I called it "Main"). Hide your text layer. Select the new layer 
and then Select > From Path (Shift+V).

Step 4

I've created a special Gold gradient. Download and install it by putting it in the "gradients" folder of your 
GIMP installation. Now switch back to your canvas, and make you sure what you did in step 3 is still 
intact. Select the gradient tool and choose the "Gold Fill" gradient (the one you just installed).

Download Gold-Fill.ggr

(Right-click, save link as...)

Fill your selection with this linear gradient (bottom to top):

Step 5

Duplicate the "Main" layer (I called it "Outline"). Make sure your text outline is still selected (if not, just 
Shift+V). Now Select > Shrink by 1px and delete the selection; both the "Delete" key and Ctrl+X work.

Turn up the layer's brightness all the way (Colors > Brightness-Contrast...) and set the blend mode to 
Overlay:

http://gimpology.com/uploads/3_245_5.ggr


Re-select the "Main" layer. Filters > Light and Shadow > Drop Shadow:

Duplicate your "Main" layer again (leave it above the "Main" layer, below the "Outline" layer). Filters > 
Distorts > Emboss...

Set this layer's blend mode to Overlay and set its opacity to 50%.

Done!



1.4 Transparent Glass Lettering
Step 1

Create a new file and fill the background with a dark gradient. I used #0f291a to #22502b.

Now type in a word with a nice font and a light color. I used Myriad Pro, 144px at #72bd90:

Step 2

Select your text layer and set its opacity to 60%. Now select the text tool and click on your text, then 
click "Create Path from Text":



Step 3

Select your text layer, then click Layer > Layer to Image Size. Now add a drop shadow (Filters > Light 
and Shadow > Drop Shadow). I set my offsets to 2, blur radius to 20, color to black, opacity to 80 and 
unchecked allow resizing:

Step 4

Create a new layer. Then select Select > From Path (Shift+V). This will create a selection around your 
text. Now Select > Feather at 10px. Then pick a light, yellowish color (#e8ffb1) and bucket fill your 
selection. Next, Select > Shrink by about 2px. Delete this selection by pressing the Delete key on your 
keyboard (or Edit > Cut). Set the layer mode to Screen and set the opacity to 50%:



Step 5

Create another layer. Select your path again (Shift+V), then Select > Shrink by about 8px. Now Select > 
Feather by 10px. Fill your selection with black and set the layer mode to Overlay at 100%:

Step 6

Almost done! Create a new layer. Select your path again (Shift+V). Now choose the Ellipse Select Tool 
and set the mode to Intersect:

Make a big selection over the top half of your text:



Set your foreground color to white (#fff) Now select the gradient tool, set the shape to radial and gradient 
to "FG to Transparent":

Fill in your selection, dragging from the top-left of your first letter to the lower-right of your last letter. 
Set the layer mode to Overlay at 50% and you're done! Viola:



Tip: Ctrl+Shift+A will clear any selections.

1.5 Text to Path
Preview:

This short tutorial will teach you how to create text to path technique using the Gimp.

1: Create your desired path. you don't need to hit enter you can open the path dialog and click on the eye 
icon to see the path.

2: With "Text tool" type in the words you would like to run along your path.

3: Then click on "text along path" in the "Tool options", you should get this red/pink outline of your text 
aligned with your path.you can delete the original text layer if its getting in the way.



4: Go to the path dialog and right click the text path and select "Path to selection"

5: Now that your path is under selection you will still see this pink stuff around your text don't worry to 
remove that click the eye icon beside your "TEXT PATH" that can be found in the "PATH DIALOG" 

if you did step 5 correctly you should get a normal selection shown in the example image below.



6: Now you can add a new layer and fill it with the paint bucket or gradient fill. :)

1.6 Hot text on flames / fire
Written by devvv (15 Jun 2007 11:29 PM) 

There are many ways to create fire text, but believe me, no other text is looking that cool and real as this 
one ;) Of course it maybe a lil' more effort to get it. I will show you how to create such a hot flames text 
with GIMP.

1. Create a new File of any size. I chose 420 x 200px. As BG-Color choose black. Done so write 
some white text to a new layer (bold text, white color, size: 50).

click to enlarge
2. Right click the text-layer in the layers dialog and choose "merge down". You should only have 

one single layer now.

http://www.gimpusers.com/users/devvv.html
http://www.gimpusers.com/images/tutorials/76/1.png


click to enlarge
3. Now, that we have all one one single layer, we create our flames. Use the Smear-Tool to do so and 

choose the values that are shown on the picture.

click to enlarge
4. Zoom in to 200%. Now start at the first letter of your text: Hold down your left mouse button and 

http://www.gimpusers.com/images/tutorials/76/2.png
http://www.gimpusers.com/images/tutorials/76/3.png


smear around the border of this single letter to make it somehow gray as seen in the picture. It 
should look real so it must not be perfect. If you watch flames you will see the natural chaos ;)

It is important to change the super white into gray tones.

click to enlarge
5. After that make some flame-like movements to the top.

click to enlarge
6. Let your creativity come out and do this with all the letters now.

click to enlarge
7. Well, we are almost done already. Now we simply have to add the correct colors of fire.

Choose Layer / Colors / Color Balance:

http://www.gimpusers.com/images/tutorials/76/4.png
http://www.gimpusers.com/images/tutorials/76/5.png
http://www.gimpusers.com/images/tutorials/76/6.png


Shadows
------------
+100
+30
-30

Midtones
------------
+100
+30
-30

Highlights
------------
+100
0
-100

click to enlarge

1.7 Web 2.0 Text logo
-Using a Mask layer to create the text logo reflection.
-Using the Ellipse Selection tool on subtract mode to create the glassy effect.
-Using Grow Selection to create Smooth outline/borders.

This it the outcome of this Text logo tutorial

I'm currently using Gimp 2.4 candidate version and i think some things might be different I'll mention it 
in the tutorial when coming across it.

Step:

1) open a new image 420x300 select the Text Tool from the Tools Dialog and choose your font and type in 
a word, Rename the Text layer to "Main text"

http://gimp-tutorials.net/node/91#
http://gimp-tutorials.net/node/91#
http://www.gimpusers.com/images/tutorials/76/7.png


2) in the layer dialog tick the "lock alpha channel"
* In 2.2 its located abit on the right.

3) Now will use the "Web 2.0 Grey Blue 3D" Gradient from the Pre-made web 2.0 Gradient pack
that can be found here but if you don't have don't worry ill show you how.

4) skip this step if you have downloaded the Gradient pack.
To create the gradient click on "New Gradient"

Name it "Web 2.0 Grey Blue 3D" or anything that you will remember.
Click on the little left Triangle Add the color 6291c0 for the "Left Endpoint" then clicking on the right 
little triangle and adding cce6f9 for the "Right Endpoint", and finally sliding the middle triangle to the 
right side as shown in the image below, then save.

5) now that we have the Gradient color select the "Blend tool" and from the Gradient Dialog select the 
newly created Gradient "Web 2.0 Grey Blue 3D" and place it below the text and drag from bottom to top.

http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp
http://gimp-tutorials.net/node/91#


This is how it should look

6) creating smooth outlines was something that took a while to figure out,to do this first right click on the 
"main text" layer and select "Alpha to selection".

7) Then go to Select>Grow to access the "Grow Selection" dialog or you can right click ontop of the Text 
and in the menu click on Select then Grow, will add 3px for the Grow Selection.

Click on "Create new Layer" Name it "Border" and fill it with 293a47 Dark blue using the "Bucket Fill 
Tool", place it behind the "Main Text" layer to become a border.



Will Create the reflection effect by duplicating the "Main Text" Layer and the "Border" layer and merging 
them down

8) Right click on the Border Layer and in the menu click on "Duplicate Layer" Move the layer ontop of 
the "Main text" layer by 

do the same for the for The "Main text" layer and move it ontop of the "border Copy" layer

9) Now Merge the two new duplicated layers by right clicking on on the "Main Text#1" layer and in the 
menu click on "Merge Down" now Rename the layer to "Reflection"

10) Before we move the reflection into position De-select any selected layer by going to Select>None

Using the "Move Tool" place the the new duplicated text logo image below the original text logo, Grab 
the "Flip tool" make sure its on Vertical mode, then drag upwards to finally flip it.



11) Right click on the "Reflection" layer and in the menu click on "Add Layer Mask" and select "Black 
Full Transparency" now click Add.

12) Grab the Blend tool and select the "FG to BG (RGB)" Gradient and apply it to the reflection from 
bottom to top.

It should look like this

13) Were almost finished now all thats needed is the glassy effect :)

Grab the "Ellipse Select Tool", make sure its on "Subtract mode" 



14) Now that you have the "Ellipse Selection" Tool Right click on the "Main Text" Layer, and in the menu 

click on "Alpha to Selection" then drag across the lower bottom part of the "Main text" logo and hit Enter, 
now in the layer dialog click on "Create new layer" and name it "Glassy effect".

 to finish it off Grab the the "Bucket fill tool" and apply a "White" color to the highlighted selection.

15) This is the final step:D go to the Layer dialog and slide the opacity to 30.5.

There you go! you should have the same outcome as mine :)

let us see your outcome in the showcase forum section, and of course just ask if you need any extra 
help :) feedback always appreciated to get that energy boost needed to write some more tutorials :D.

Note: The xcf Source file is attach at the bottom for download.

1.8 Text Outline
Preview:

http://gimp-tutorials.net/forum
http://gimp-tutorials.net/node/91#
http://gimp-tutorials.net/node/91#


In this tutorial will learn how to create a strong Text outline text using gimp and also teach you how to 
create your own custom Brushes in the process.

You should have a basic idea on how to use Gimp but ill try to make it easy and simple even for first 
timers.

Step:
1)Open up a new Image 300x150.
2)Choose the Text-tool and apply text,i typed in the word
"Effect" pick a font as well i went with.

3)On the Layer dialog Tick the Keep Transparency box. make sure you have the text layer selected.
(CTRL+L)to show up the Layer dialog.

http://gimp-tutorials.net/outlinetext#


4)Now will add color to the text using the 'Fill with Gradient tool' and Selecting the FG to BG 
(RGB)Gradient,press (CTRL+H) to display the Gradient Dialog-window.

5)Change the FG color to ff0000 and BG to ffffff now apply color by dragging the the fill tool from 
bottom to top.

it should look like this now

6)In the Layers Dialog-window. click on the text layer with the right mouse button and choose 'Alpha to 
Selection', this will select the text.
7)Create a new layer,When prompted type in 'Outline' for the name the layer
8)Open the Brushes-dialog window by going to Dialogs>Brushes.

Now will create our Own brush to get the outline we want which is a 2px outline around the text.

9)In the Brushes Dialog click on the small Create new Brush icon thats at the bottom of the window.



here are the Brush settings we want
-Enter the name 'rounded 2px' for the brush name
-Select the circle shape
-Radius 2.0
-Spike 2
-Hardness 1.00
-aspect ratio 1.0
-Angel 0.0
-spacing 1.0
Now save the Brush settings.

10)We want a Black outline so Reset your foreground-color to black by clicking the mini black and white 
overlapping squares in the color selector.
11)make sure you have your new brush selected then go to Edit>Stroke selection and pick 'Stroke with a 
paint tool'

Your done!



If you need any help just leave a message here and ill try my best to help out :)

1.9 Neo inscription
First, create a new image, size 420×300px with black background. 

1. Next, type your inscription, using a big font (for example Orange LET Ultra-Light) 135px-sized. 
This font can be downloaded from here. 

Pic.2 Outcome after step 2 

2. Now, duplicate the layer with the text, and change its color to #1757AE. 
3. After that, duplicate the layer with #1757AE color, so you get 2 layers with the same color. 
4. Create 2 new layers and put them between the layers with text. 
5. Fill the lower one with color #888888, and the higher one with #CDCDCD. 
6. For both these layers change Mode to Dodge. 

http://www.noss.yoyo.pl/noss/gimp/40240___.rar


Pic.3 Now you should get this set of layers 

7. Right-click on every layer with text, and set “Layer to Image Size”. 
8. Now, duplicate the lower layer with text, move to the top, and don’t touch it any more. 
9. Next, use Gaussian Blur (Filters->Blur->Gaussian Blur): for the second layer from top, set Radius 

to 2, for the middle one set it to 5, and for the bottom one – 10. 

Pic.4 Now you have your neon inscription. 

Pic.5 The same, but with a bigger blur (top layer: 3, middle: 8, bottom: 15) 

And here you are! 



1.10 The Beveled Text Dance

First we need to make a new image. (size 256x100, type 
RGB) 

Open the 'Layers&Channels' -dialog window by pressing the 
right mousebutton on the image and choose 
Dialogs>Layers&Channels from the menu. 

On the Layers&Channels-window click the layer name 
('Background') with the right mousebutton and choose 'New 
Layer' to add a new layer to your image. 

Your Text String. Make sure you have the New Layer 
selected on the layers-dialog, and choose the Text-tool 
and apply your text string preferably with a bold, fat 

font. The freefonts package has some good examples. In 
general, almost any font will work, but the effect looks better on 
blocky characters. 

Try to place the text in the center of the image, there must be 
little free space around the text, since we must fit the frop-
shadow there. Once the text is in proper place, press Ctrl-H or 
select Layers>Anchor Layer from the 
RightMouseButtonMenu(tm) 

There is a tiny little button in the Layers&Channels 
window that says: 'Keep Trans'. This is the key to the 
next step we are going to take. Make sure it is pressed 

in. If the next step gets screwed up, you forgot it. 

Next we will fill the text with a gradient. First we need to select 
the colors - choose yellow as the foreground-color (upper-left 
square in the toolbox color selector) and slightly dark red as the 
background color (lower-right square). 

Once you think the colors are OK, select the Blend tool 
(gradient fill tool). Make a nice gradient from up to down and 
just a little to right, so that the blend looks like that orange text 
on the right. (See the arrow for example direction) And IF it 
gets ALL orange, you forgot something I told you :) 

OK, you are doing fine.. Now we switch to a higher 
gear here.. In the Layers&Channels -dialog, right-click 
the 'New Layer' name (that orange-text-layer) and 

choose 'Duplicate Layer'. You now have 2 orange texts, though 



you only see one as they are identical and the top layer overlaps 
the bottom layer. 

Click on the topmost text layer (New Layer copy) and 
put the 'Keep Trans' -button down again. Choose 
Select>All from the right-mouse menu and take the 

Bucket Fill tool. Choose white as forefround color (top-left 
color in the toolbox). Fill the text white. You notice that when 
the 'Keep Trans' -button is pressed, the transparent areas in the 
text-layer are not painted. 

You should get a white text over the orange. The outline of the 
orange shows just slightly under the white. 

Unselect the 'Keep Trans' button from the white text 
layer and select Filters>Blur>Gaussian Blur RLE. Set 
the blur radius to 6. You should see the outlines of the 

white text soften and the orange text shows even more. 

Select the 'orange text' layer by clicking on it's name 
in the layers dialog. 

From the right-mouse-menu again select Filters>Map>Bump 
map and adjust the values so that they are approximately equal 
to those on the picture. The only changed values are 'Elevation' 
and 'Depth', the rest are just default. 

You should select the 'New Layer copy' as the map, since that is 
our white image. 

The shape of the bevel can be somewhat controlled by the map 
type selector. 

'Compensate for darkening' is usually a good thing to select 
also, if the text looks too dark. 

Once it looks good, click OK and off we go... 

Select the white text layer that is invisible by clicking 
on it in the layers dialog. 

From the right-mouse-menu again (in the picture window) 
select Image>Colors>Invert so the white blurry text becomes 
black blurry text. In the layers dialog (again with right mouse 
button on the layer name) select Lower Layer to put it behind 



our orange text. 

Final Touch(tm) 

While the black text is still selected, click your right 
mousebutton on the image and select Image>Transforms>Offset 
- X-offset 2 and Y-offset 3. 

The black text is amazingly transformed to a spiffy drop-
shadow and our image is ready. Now you should save it. (At 
least now...) If you intend to use it in a webpage, you should 
flatten it (Layers>Flatten Image) and save as jpeg or convert to 
indexed color (Image>Mode>Indexed) and save as gif. 

1.11 iText
1. First you need to create a new 320*320 pixel transparent image. 
2. Then, select the text tool  (press T), Select the "Bitstream Charter Bold Italic" font (available 

here), and a size of about 402px. Choose a light blue colour such as #007FFF. 
3. Click the image and then type an "e" character in the text dialog that pops up. 
4. Using the move tool  (press M), roughly centre the new text layer. 

5. Click Layer->Merge Down, to merge the newly created text layer into the transparent 

http://gug.sunsite.dk/tutorials/itext2/charter-1.0.tar.gz?PHPSESSID=28da3b1476be2c52588905a1b253c915


background layer. 
6. Click Layer->Transparency->Alpha To Selection, to select everything on the current layer that 

isn't transparent. 
7. Now click Select->Save to channel to save the current selection as a new channel. Doing this 

will enable us to either "recall" the selection at a later date, using Channel To Selection, or as in 
this case, we can modify the selection and use it as a mask for the lighting effects filter. 

8. Click Select->Shrink and shrink the current selection by 10px. This value will vary if you're 
using a different sized image. 

9. Create a new layer, with Layer->New Layer and make sure it is the active layer. 
10.Select white as the foreground colour, and using the fill tool , fill the selection on the new 

layer with white. 

11.Select None (Ctrl+Shift+A). Click Filters->Blur-Gaussian Blur (IIR) and perform a 20px blur 



on the white layer. 
12.Change the layer mode to "Overlay" in the layers dialog. Now duplicate the layer (Layer-

>Duplicate Layer). This duplication will help to enhance the highlights. 

13.Now activate the channel we saved earlier and repeat the 20px gaussian blur (Filters->Repeat 
"Gaussian Blur (IIR)"). This provides us with a nice 3-D mask to base the lighting effects on. 
You may not be able to see the blur actually happen, but as you can see in the closeup screenshot, 
it does do the blur we want. If you want to see/edit the channel mask in the main image window, 
you can in fact hide all layers using their eye icons, and then show the channel using it's eye icon 
(this is off by default). 

14.Create a new layer and fill it with black, in the same way we filled with white earlier. Make sure 
this black layer sits at the top of the layer stack, set the layer mode to "Screen". 

15.Click Filters->Light Effects->Lighting Effects to open the lighting effects filter 
16.Make sure all the settings are specified as shown in the following screenshots. The "Bump Map" 



tab has a dropdown where you need to select the channel that we blurred, if you didn't give the 
channel an easy to remember name, it should be identifiable by the blurry thumbnail. 



17.Almost done! 

18.This is what the finished product looks like after creating a white backdrop, and a light drop 
shadow.



  

1.12 Metallic Text
How to make metallic text:

1. Make some white text on a black background. Use a sans serif font and make it big.

2. Apply a heavy Guassian blur. About 16.0 The purpose of this is to give the text some rounded corners 
and smooth edges.



3. Layers-> Colors-> Levels... squeeze the outer arrows together. This is just like in the rounded corners 
tutorial at the GUG.

4. Lighter Gaussian Blur. About 7.0 This time we are forming the beveled edges of the metal.

http://gug.sunsite.dk/tutorials/rounded-corners/
http://gug.sunsite.dk/tutorials/rounded-corners/


5. Color-select the black area, invert the selection.

6. Get that Layers dialog open (Ctrl-L). Make a new Layer #2 and set it transparent. Switch off Layer #1 
and focus Layer #2 (by clicking it in the dialog), so you have a floating selection on transparency.



7. Fill the transparency with a dark-gray to light-gray gradient. De-select the layer.

8. Bump map Layer #2 using Layer #1 for the map. Gimp's bump map dialog wants to use the active 
layer for the map by default, so make sure that the drop-down menu in the upper right of the bump map 
dialog is set to use your #1, non-transparent layer.



9. Now get ready for a surprising effect. From the image menu choose Layers-> Colors-> Curves to get 
the color curves dialog. Make the line for all-channels wavy. That's the first graph line to show up, so just 
grab and drag it all up and down. Watch the image change. Stop when it looks like metal. Notice my 
example line.

Throw away layer #1 if you want, or use it for masking or other effects. Add background and shadow to 
taste.



Example #2 was done by selecting the Golden gradient and applying it to Layer #2 via Filters-> Colors-> 
Map-> Gradient map.

Example #3 was made by duplicating Layer #2 at step 8 and doing the original layer the same way, but 
doing the duplicate with separate color channels in the Color Curves dialog and blending the two layers 
with "overlay".



You can apply this to any wacky two-color design you want, not just text.

Hope this was helpful. Comments, corrections, and suggestions are welcome!

PS Oh, ah, ahem, and I've started this new category "graphics tutorials", for all my doodling HOWTOs.

1.13 Rounded Corners
Written by devvv (12 Aug 2006 07:33 PM) 

In this tutorial I show you how to easily round off existing hard edges from text or other objects.

1. Open up a new file. Create one or more layers with text on it. The written text should be relatively 
big in size so that you can see the final effect clearly.

click to enlarge
2. Now render the text (Layer / Discard Text Information) and apply a Gaussian Blur. -> Filter / Blur 

/ Gaussian with a value of 15. The higher the value the more rounded are the edges at the end. It 
should look like that now:

http://www.gimpusers.com/users/devvv.html
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click to enlarge
3. Click right on on this layer, apply Colors / Curves. At the top left set the channel to "Alpha". After 

that move the point at the bottom left to the middle, the one top right move at the opposite 
direction, also towards the middle.

What happens here? The transparent part (the socalled alpha-channel) is moved together as far as 
possible until there is no half-transparent space left in the layer. The result of this is that there are 
either totally visible (100% transparency) pixels or totally invisible pixels (0% transparency).

click to enlarge
4. Thats it! The final result should look like this:

click to enlarge
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1.14 Smelting text / Creating blood text
Written by devvv (05 Sep 2007 08:59 AM) 

In this tutorial I show you how you can liquify / smelt text or other graphical objects. I'm going to 
demonstrate this by creating a blood text.

1. Make a new file: 600x400 px. White background. Write one or two words with a sans-serif-font 
(i.e. "bloody GIMP" ;)).

Size: 140px.
Line height: ca. -15
Color of text: #870000 (a dark red)

Layer / Layer to Image size. After this the text cannot be changed because it is rendered.

click to enlarge
2. The next technique is optional. The blood looks simply better when your text has rounded 

corners. We've a seperate tutorial for the rounded corners-technique. The technique is very useful. 
Have a look at it.

These are the quick steps to get rounded corners on this text:
- Apply Filter / Gaussian Blur
- 10px
- Repeat the filter by Pressing CTRL+F
- Repeat it again
- Choose Colors / Curves, top left choose Alpha as channel. Move the point at the bottom to the 
middle, do so with the point that is at the top right. You'll see immideate changes in the picture. 
Do this until you have nice rounded off corners.
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click to enlarge
3. Create a new layer and choose the pencil-tool. Make sure the color is the same as before #870000.

Paint even vertical lines down now. (You get exact lines when clicking a single dot someqhere 
into the text - this is the starting point - then hold SHIFT and set the endpoint). Do this a few 
times as seen on the image below.

The strength of the pencil should be 7.

click to enlarge
4. After being satisfied with the lines click "Merge down" by clicking right in the layers dialog. The 

Text and the lines should then be on a single layer.

To make the lines look like a part of the text we use the Liquify-Filter. Filters / Distorts / IWarp. 
Choose "grow".

Deform radius: 9
Deform amount: 0.26

All Work is done in the preview-window of this filter: Now first work on the area where the 
'blood' is coming out of the text and running down. Click and hold your mouse down at the 
exitpoint of the blood of the text and make small circular movements. The hard edges look more 
as they would have been a part of the text. Repeat this for every line.

The next step are the endings of the lines. They should look like drops in the end, do this with the 
same teqchnique as with the exitpoints.
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After that use "shrink". Now shrink the middle parts of the lines so that they become much 
thinner. To do this move the mouse (while holding down the mousebutton) from top to bottom 
until you find it thin enough. It should be uneven to look real!

You should the have a result of something like that:

click to enlarge
5. If your satisfied with the result you're done ;)

If you want to look the text even more like blood follow these steps:

Duplicate the layer with the blood and click the "Lock"-Button in the layers dialog (it is found 
above the layers). It's called "Sperre" in the image below.

click to enlarge
6. Rightclick in the layers dialog "Selection from Alpha". Then click the Channels dialog (Dialogs / 

Channels). Add a new channel: "Initialize from selection".

Click the channel in the channels dialog, then go to Select / None. Filter / Gaussian Blur 4 times 
with these values: 10px, 6px, 3 and finally 1 px.
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http://www.gimpusers.com/images/tutorials/93/5.png


click to enlarge
7. Click the visibility (eye icon) of the channel to make it invisible.

Change to the layers dialog, click the duplicated blood layer. Choose #818181 as new foreground 
color. 
- Edit / Fill FG-Color. The duplicated layer should now be all gray.

click to enlarge
8. Filters / Lights and Shadow / Lighing Effects. As bumpmap choose the channel we just created. 

Max. height: 0,05

For the Materials tab choose the values of the picture (they are in the same order in the english 
version of Gimp)

click to enlarge
9. Then we need 2 lights.

For the first light use these values:

Light 1
Type: Directional
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Color White
Intensity: 1

Direction:
X Y Z: -0.9 / -1.5 / 0.7

click to enlarge
10.For the second light use these values:

Light 2
Type: Directional
Color White
Intensity: 1

Direction:
X Y Z: 1.4 / 1.65 / 1.0

click to enlarge
11.The layer is still alpha locked. Now apply the Gaussian Blur again. 3 times. every time use 2px 

for the blur.

click to enlarge
12.Set the layers mode to "Hard light" and you get nice dark blood ;)

Have fun by making your own blood!
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click to enlarge

1.15 Tutorial: Rays of Light (behind text)
Written by devvv (07 Oct 2006 11:07 PM) 

I bet you all know this effect where cool rays of light can be seen behind some text. In this tutorial I'll 
show you how to make such an explosion. This effect is also very often used by gaming companies.

1. - New file: 900 x 900px. Black Background.
- add three text-layers: "The" "ULTIMATE" "Source".
- Take a very bold font, that gives us a better look.
- "The" and "Source" should have a size of 35, "ULTIMATE" has a size of 55px.
- Move the 3 text-layers together (as seen on the picture below).

click to enlarge
2. Merge these 3 layers. To do this select (in the layers-dialog) the text-layer thats on top of all the 

text-layers. Right-mouse-click and choose "Merge Down". Repeat once.

Now the whole text should be on a single layer.
Move the Text to the very center of the picture. To do this you can either use the Alignement-Tool 
or just use guides. Go to Image / Guides / New Guide: Choose horizontal: 450px - then click OK, 
same again with a vertical guide. Move the text-layers "M" (from the "ultiMate") to the point 
where the guides are crossing.
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Go to View / Show guides (Deselect).

Now go to Layer / Layer to Image Size. Duplicate this layer. Now merge the layer thats above the 
Background-layer down with the Background-layer.

Name that text-layer "Source" and the Background-layer "Strahlen" (which is the german word 
for "rays").

Click the Eye-Icon for the "Source"-layer in the layers-dialog to make it invisible. After this long 
step your layers should look like this:

click to enlarge
3. - Make sure that the "Strahlen"-Ebene is active.

- Go to Filter / Distorts / Polar coordinates and take the values from the picture below.

click to enlarge
4. Go to Image / Transform / Rotate 90° clockwise

http://www.gimpusers.com/images/tutorials/59/2.png
http://www.gimpusers.com/images/tutorials/59/3.png


click to enlarge
5. Go to Filter / Distorts / Wind and choose the options from the picture below.

click to enlarge
6. Repeat the filter once but now choose "Left" as direction, the other options remain unchanged.

Go to Image / Transform / Rotate 90° counter-clockwise. After that apply the polar-coordinates 
filter again. Click the "To Polar"-option. The text should look like this now.
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click to enlarge
7. Choose the Rectangle-Select-Tool and draw a selection around the rays. 

- Select / Invert.
- Choose black as FG-color.
- After that: Edit / Fill FG-color.
- Select / None.

click to enlarge
8. The rays look pretty bad... To change this go to Filter / Blur / Motion Blur and choose the values 

from the image below:
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click to enlarge
9. Click the Source-layer in the layers-dialog and choose "Alpha to Selection". Create a new layer, 

name it "Glühen" (german word for glow). Activate the created layer.

- Select / Grow: 2px
- Fill the selection with white.
- Press CTRL+SHIFT+A to deactivate the selection
- Filter / Blur / Gaussian: 10px
- Choose "Screen" as layermode (you can find the layer modes dropdown-menu in the layers-
dialog above the transparency-control.

click to enlarge
10.- Move this layer between "Source" and "Strahlen", in case it is not already there.

- Click the Eye-Icon of the "Source"-layer to make it visible. Go to Colors / Invert. (in Gimp 2.2 
this option is under Layer / Colors / Invert).
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click to enlarge
11.Choose the "Strahlen"-layer and go to (Layer /) Colors / Color Balance

For a blue shine take these values:
------------------------------------
Shadow 0 | +30 | +40
Midtones: -70 | -35 | +30
Highlights:-85 | -25 | -50 

For a gold shine:
---------------------------------
Shadows 100 | +50 | -50
Midtones: +70 | -30 | -100
Highlights: +20 | 0 | -50 

Done ;)

Tip: If you want your rays to shine even more, duplicate the "strahlen"-layer, blur it with gaussian 
blur and set the layers mode to "Screen".

click to enlarge
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2. Photos / wallpapers

2.1 Perfect masking using a highpass
Written by devvv (05 Sep 2007 08:00 AM) 

There are several methods to extract/mask objects or persons from the background. But sometimes you 
need perfect masking that includes for example the hair of a woman. The method i use for this is called 
highpass. We need to simulate this filter because there is no filter in GIMP that does this for us. The point 
of the techqnique is that you'll save lots of time for the difficult hair part, because when you do 
everything right the hair is extracted automatically.

1. Open any picture that contains a big shot of a person / celebrity / whatever. I use a picture of a 
well known celebrity.

click to enlarge
2. Duplicate the background layer 2 times, you should that layer 3 times then. On the top layer use 

Filter / Gaussian Blur: 18px. Set the layer to 50% transparency in the layers dialog.

Then go to Colors / Invert. You should have something similar to my picture now.

click to enlarge

http://www.gimpusers.com/users/devvv.html
http://creativecommons.org/licenses/by-nc/2.0/at/deed.en
http://www.gimpusers.com/images/tutorials/92/1.png
http://www.gimpusers.com/images/tutorials/92/2.png


3. Click the right mousebutton on the layer in the layers dialog and choose "Merge down".

Colors / Desaturate (average). The go to Colors / Curves and apply a soft S-curve as seen on the 
image below.

click to enlarge
4. Then choose Brightness & Contrast from the same menu. This step can vary when you use a 

diferent picture. We're aiming to get a good clearly vivisble contrast. Its important thyt you get 
nice contrast in the hairs area.

We're now done with the highpass filtering.

click to enlarge
5. Go to Colors / Invert.

click to enlarge
6. Now you need to take a brush and paint the body of the person / object with white. To make it 

easier to correct mistakes you should create an empty layer above the highpass-layer and paint on 
this layer, when done merge the layer down. You can move the background-layer above all layers 
and set the transparency to 20% or so to see what parts you have to paint.

IMPORTANT
You don't have to paint the hair! Thats the point of this technique / tutorial. The hair should be 
already white, and everything behind the hair should be dark gray or black so you dont have to 
use time to get the hair extracted. 
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click to enlarge
7. When you have the person white you have to paint the background black. Start at the borders of 

the body. You can do this fast when you first use a smaller black brush to paint around the person 
(where the gradient from black to white is visible), and then using a very big brush to fill the rest 
of the background with black.

If you use a sperate layer dont forget to merge it down at the end.

click to enlarge
8. At the end you should have an image containg almost only black an white. We use this as a layer 

mask now.

Press CTRL+A (Selection / All), copy this using CTRL+C (Edit / Copy). Activate the background 
where the person is. Click right in the layers dialog, choose Add Alpha channel.

Click right again and add a layer mask. Press CTRL+V (Edit / Paste) then and use the anchor-
button in the layers dialog to get the copy onto the layer mask. You should the see the result 
immideatly. Make a white new layer behind all, then you can see the results even better!

Good luck and have fun!
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click to enlarge

2.2 Infrared / Monochrome Effect
Written by devvv (11 Dec 2007 12:11 PM) 

Black/White or Monochrome effects on pictures are evergreens in image manipulation and picture 
presentation. Also some speak of the so called infrared-effect which is just a special adjustment of the 
graytones.

1. Before you start: Because all pictures look different you can not use this tutorial 1:1 for any 
picture in the same way. You can only do it ecxactly like me when using my picture (download 
from the right).

Ok, let's go. Open up your image in GIMP. Duplicate the background layer 2 times and click the 
eye symbol of the duplicates to make them invisible. If something goes wrong you still have the 
original image.

click to enlarge
2. The effect that I'm trying to do now is also commonly known as the "infrared effect". 

Why infrared you ask? In the past and in the analog photography times the photographer put an 
infrared filter before the camera. The picture then got an extraordinary contrast of the blacks and 
whites and the photo looked somehow surreal. Why surreal? Thats because the infrared filter sees 
and records colors that cannot be seen by the human eye.

Ok lets continue with the effect. Click the visible background layer in the layers dialog to activate 
it. First we have to better the quality of the picture. You don't have to do this when you have a 
good picture. But if you zoom into my picture at 300% and look at the clouds you can see the 
noise. Thats what we eliminate now.
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click to enlarge
3. Use the free selection tool and make a selection around the clouds in the middle. After that go to 

Selection / Feather: 75px.

click to enlarge
4. Next go to Filter / Enhance / Despeckle. (1 / -1 / 256). Check both checkboxes.

We've get rid of the most noise now.

click to enlarge
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5. Next we further enahance the picture quality by using Filter / Blur / Selective Gaussian Blur: 10px 
/ MAx.Delta: 13. That should be enough to get a smooth transition / fading.

Selective Gaussian Blur maintains contures and sharpness while blurring only areas of very 
similar color. So thats perfect for clouds.

click to enlarge
6. Selection / None.

All preparations are done, no we're going to simulate the infrared-effect. There are LOTS of ways 
to get different grayscale images. So it is not always clear which one to use. If you really want 
nice and aesthetic looking images you should consider the most comfortable method: the channel 
mixer.

Some basic things so that you understand how that all works: Every picture in the RGB-Color-
Model consists of 3 colors: Red, Green and Blue. These together result in the final color image. 
You can see these 3 colors by looking into the Channels-Tab (Dialogs / Channels).

To do very good image enhancements and editing many professionals just only work on one of 
these channels to not affect the others. For removing noise you would i.e. work on the green or 
blue channel, to adjust contrast you would work mostly in the red channel. We are editing these 
channels now by using the Channel Mixer.

Change back to the layers dialog now.
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click to enlarge
7. Pretty well hidden, the channel mixer can be found under Colors / Components / Channel Mixer. 

Click the "Monochrome"-Button to the bottom of the dialog.

Look at my screenshot to see the values i used. Important: Try it yourself! Have the information I 
told you in the last step in your mind while you move the sliders of each channel.

Note that you normally should not get plain white or black areas. When doing this you would 
loose detail (and image/pixel information) in your picture.

click to enlarge
8. Our infrared-like image is done now ;) That was easy!

Now if you're interested: Comprae our created grayscale image with another one you only applied 
the Colors / Desaturate-Filter on. The difference looks pretty cool!
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click to enlarge
9. Ah, another thing: You can easily get colors back into play - that looks cool too!

In the shot below I made a copy of the original background visible, set the opacity/transparency 
slider to 35% and the layers mode (in the layers dialog at the very top) to Color.

click to enlarge
10.And here we go with the well known "dream"-effect for which the infrared-effect is also a very 

good basis:

From step 9: duplicate the gray layer, apply Filter / Gaussian Blur to it (between 20px - 40px. this 
varies and depends on the size of your picture). then go to Colors / Color Balance and choose a 
color of your choice - this is the dreamy color - then set the layers mode to "Screen".

Optional: you can duplicate this layer again to strengthen the effect.

I used these color balance values:

Shadows: 40 / -10 / -30
Mids: 30 / 15 / -30
Highlights: -30 / -30 / -30

Done!
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click to enlarge
11.Here's another grayscale image with this technique.

click to enlarge
12.... and a last one! Hope you enjoied the tutorial!

click to enlarge
13.Clouds give the the effect a very nice depth! Have fun by doing this on your own.

2.3 Smoke and Flames
Written by devvv (18 May 2007 08:27 AM) 

In this tutorial, I'll show how to create fairly realistic smoke in the GIMP. After that I'll show you how to 
convert the smoke into cool looking flames in just some very easy steps. Enjoy!

1. Create a new file: 800x600px. (black background-color)
- add a new layer, it shall be transparent
- take a big, white brush and paint some big dots as seen on the picture below.
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click to enlarge
2. Now take the Eraser-Tool, and delete some parts of these dots, so that you get something like a 

half moon at the end.

click to enlarge
3. Next apply a gaussian blur to this layer: Filter / Blur / Gaussian

click to enlarge
4. This step is now very important: Go to Filter / Distorts / IWarp.

Adjust the settings as seen on the picture.

Deform Mode: Swirl CW. In the preview window hold your left mousebutton down and start to 
zigzag from left to the right pretty fast.

The purpose of this is to get points that are streched a little bit. DON'T click the OK button yet.
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click to enlarge
5. Now swith to another Deform Mode: Move. This step will take some time until you're finished. 

Try to move the single points/dots together and alsy try to move them a little to the top. Look at 
my picture to see what it should look like. 

When finished click OK.

click to enlarge
6. It looks like this now (of course you will have no the identical image but you should now have 

something like this):

click to enlarge
7. Duplicate the layer. Select the Flip-Tool (SHIFT+F), click the layer once and you should have a 

flipped layer.
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click to enlarge
8. - Filter / Blur / Gaussian: 10px.

- Move the layer a little more to the bottom.
- In the layers dialog click the one layer that is at the top.
- Click right and choose "Merge down".

click to enlarge
9. - Filter / Blur / Gaussian: 10px.

Okay. So that does not look like real smoke, doesn't it. It is to thick/strong. To get rid of the 
strongness go to Colors / Curves. Top left select "alpha". Then adjust the curve seen below.

click to enlarge
10.Now it looks better!
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click to enlarge
11.We want to make our smoke look more realistic, so we have to remove some parts of the picture 

that don't look natural ;)

For this take the Erase-Tool. In the settings chhoose a big soft brush. (If you don't habe a big soft 
brush you've to create one in the brushes-editor first!)

In my picture I've removed some smoke in the top middle.

click to enlarge
12.We're now done with the details of the smoke. To get a better overall feeling we're going to 

enhance it with a very slight backgound that shoud give us the feeling of have some sort of 
environment smoke.

Take the free select tool (F) and draw a selection around our smoke (like an outline).

click to enlarge
13.- add a new layer

- Filter / Render / Clouds / Solid noise.
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Random: checked, others unchecked.
X/Y: 4/4.
Details: 1

click to enlarge
14.Adjust the opacity of the layer to 20%.

click to enlarge
15.Smoke dows also have a structure/pattern. We're goint to simulate this as follows:

- add a new layer on the very top.
- Fill it with a medium grey tone.
- Filter / Noise / HSV and take these values
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click to enlarge
16.Filter / Enhance / Sharpen: 85px.

Set the layers mode to Divide and the opacity / transparency to 40%.

click to enlarge
17.Now we're just going to colorize our smoke a little bit.

Create a new layer on top of all. Fill it with #afbeff and set the layers mode to "Color", the opacity 
to 10%.

The smoke is done!
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click to enlarge
18.Here is a photo which I added our just created smoke to.

click to enlarge
19.Now we're going to convert our smoke to some cool looking flames.

Save your smoke to smoke.xcf.

Click the eye icon of the blue layer to make it invisible.

Duplicate the smoke-layer, flip it, move it to another place in the image and remove some parts of 
the duplicated layer so that we don't see that it is just a duplicate.

click to enlarge
20.- Go to Edit / Copy visible.

- Edit / Paste

Click the anchor-button in the layers dialog to get the pasted to a seperate layer.

After that choose the IWarp Filter again, select Move and in the preview window move the 
"flames" from left to the middle and from right to the middle. It looks like this now:

click to enlarge
21.Colors / Brightness & Contrast: 60/50.

Then apply Colors / Color Balance
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Shadows: 100 / -100 / -100
Midtones: 100 / 100 / -100
Highlights: 100 / 100 / -100

Thats it ;)

click to enlarge
22.I've you're playing around abit like me you can do some cool flames. I'm using this one as a 

desktop wallpaper atm ;)

click to enlarge
23.Or you can just colorize it blue, looks cool too!

click to enlarge
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2.4 Old Parchment Paper
Written by devvv (15 Jun 2007 10:43 PM) 

This tutorial is a bit aimed on fantasy-fans! I will show you how to generate an old parchment paper. You 
can than add an old map, a photo or just plain text to it!

1. Open a new file: 400x500 px and set the background color to black.

click to enlarge
2. Create a new transparent layer, fill it with #bc8b46.

click to enlarge
3. Go to Filter / Noise / RGB Noise and use these values as input:

Independent RGB Channels: checked
RED: 0,20
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GREEN: 0 
BLUE: 0
ALPHA: 0

click to enlarge
4. - Filter / Blur / Gaussian Blur: 10px.

The noise-effect should be still very little visible- 

click to enlarge
5. Now, we're going to bring some depth into play. Open the channels tab (Dialogs / Channels). 

Create a new channel there, name it "knittern" or "crinkle" which is the english word for this.

Opacity to 100%.
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click to enlarge
6. Click the just created channel to make it active.

Apply Filter / Render / Plastic Noise. Activate "Random".

Values:
--------
Random: on
X: 2,3
Y: 3,3
Details 15.

You get this kind of picture:
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click to enlarge
7. In the channels tab deactivate the eye-symbol to make it invisible.

click to enlarge
8. Change to the layers-tab and click the brown layer to make it active. Now apply Filter / Light and 

Shadow / Lighting Effect. In the tabs of the filter enter these values

Options:
(optinal) Distance: 2000

Light:
------
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Light1:
Type: Directional
Color: White:
Direction: X: -2,25 Y: 1,75 Z: 1

Material:
Glow: 0,5
Bright: 0,75
Shiny: 0,12
Polished: 20

Bumpmap:
use the "crinkle"-Channel
Max Height: 0,01

click to enlarge
9. - Filter / Enhance / Sharpen: 60.

After that choose the "Free selection"-tool. Draw a selection as seen on the picture.
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click to enlarge
10.Now choose Selection / Invert. Cut that part or just delete it using DEL (or CTRL+K in GIMP 

2.2).
Deactivate the current selection by pressing CTRL+SHIFT+A or Selection / None

click to enlarge
11.The next step is to create some more cuts into the parchment. Use the free selection tool for this 

again. Cut many small cranks into the parchment. You can also do small very thin ones in the 
middle.
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click to enlarge
12.Now we're adding a darker border to it.

- Right click in the layers dialog. "Alpha to selection". This gives us a perfect selection of the 
layer.
- Add a new empty layer
- Selection / Invert
- Fill this selection with #7a340d
- Selection / None

click to enlarge
13.Apply Filter / Blur / Gaussian: 75.
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click to enlarge
14.Activate the parchement layer. Choose "alpha to selection" from the right click context menu of 

the layers dialog again.

Activate the just blurred layer. Press CTRL+I to invert the selection and the press DEL to delete 
the unwanted parts. The brown inner shine should be visible now.

The hard part is done ;) Now you can finetune your parchment paper by using Brightness and 
Contrast. Or you can apply the depth-effect again if you want more crinkle! Feel free to play 
around with it.

click to enlarge
15.You can the add a photo to it or write some text or you can also add an old map to make your own 

treasure map! Have fun!
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click to enlarge

2.5 How to generate realistic mass waterdrops on a surface
Written by devvv (08 Jul 2007 12:19 AM) 

Learn how you can make very cool and realistic waterdrops with GIMP.

1. a word before we start: I'm using the dialogue "Color" very often in this tutorial. If you use GIMP 
2.2 the options i mean are found under Layer / Colors, since 2.3 this is only the menu "Color".

Create a new file: 800x600px. Fill it with any background color you want. I did a soft blue 
gradient - that looks cool.

click to enlarge
2. Add a new Layer. Filter / Render / Solid noise. User max values: 16/16.
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click to enlarge
3. Colors / threshold, look at the pic below to see the values )left: 86, right: 172).

click to enlarge
4. You'll get a picture that looks like mine below:

click to enlarge
5. Choose Colors / Color to Alpha and choose white to make all white transparent.

After this invert all the pixels: Colors / Invert. After that all black should be white.
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click to enlarge
6. Duplicate this layer, make it invisible by clicking the eye icon left to the layer in the layers dialog. 

Right click the layer in the layers dialog: "Selection from Alpha".

- Dialogs / Channels. Add a new channel there while still having the selection active. Click 
"Initialize from selection".

Press CTRL+SHIFT+A to deselect all. 
- user Filter / Blur / Gaussian Blur 3 times with these values: 7 then 3 and finally 1. Click the eye 
symbol to make the channel invisible.

Switch back to the layers dialog and click the layer that contains the white "drops".

click to enlarge
7. Make sure the white drops layer is active. Now the heart piece of this tutorials follows:

Filter / Light & Shadow / Lighting effects...

We will now illuminate the drops from 2 sides (from top and from bottom) so we get some pretty 
real hightlights for the water. We need 2 directional light sources. Use my values (see the picture 
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below). Don't forget to use the channel we created in step 6 as bumpmap.

click to enlarge
8. You get something like this:

click to enlarge
9. Lock the alpha channel ("Lock alpha channel") of this layer. This option is found above all layers. 

Then use Filters / Blur / Gaussian Blur: 4px. 

Using this option has the effect that all filters or anything else you may do on a layer is only 
applied to the visible pixel.

In this step we use this to get nice little blurred grays. However we need to see clear differences 
between bright and dark gray as well as a clear white. 

After this you make the gray in the middle transparent by using Colors / Color to Alpha again 
(pick the gray in the middle).

You get the following:
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click to enlarge
10.As for now the result look already pretty good but we can still make some improvements: Any 

drop needs a soft black shadow to look more real.

Rightclick the invisible white layer in the layers dialog and choose "Selection from alpha".

With this selection active use Filter / Light and Shadow / Drop Shadow: X:2,Y:3 - Transparency: 
30. Deselect "Allow resize".

Deselect all: Selection / None.

click to enlarge
11.Our drops are a bit too white and not enough transparent. Activate the visible drops layer: Colors / 

Curves, use the Alpha channel (top left option) and apply the curve seen on the picture. We're then 
finished ;)
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click to enlarge
12.Hope you like it!

Tip: Smaller the size of the picture afterwards to get an even more realistic look!

click to enlarge

2.6 Planet in a wireframe model
Written by devvv (07 Sep 2007 12:15 PM) 

You'll see these so-called wireframe models mostly in the 3d-sector of computer graphics. They just look 
pretty cool when they're faded into the real looking object. The problem is that you cannot use any 3d 
coordinates in image manipulation programs such as GIMP. In this How To I will show you how to make 
such an effect by using a planet that is being faded into a wireframe-globe.

1. Create a new File: 600x600px. Background shall be black. 
- Layer / Transparency / Add alpha channel
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click to enlarge
2. Filter / Render / Pattern / Checkerboard: 20px.

click to enlarge
3. We're making a nice grid from the chessboard now: Filter / Edge-Detect / Edge. Use the Sobel-

Algorithm, Amount: 2, and Smear. (that yould be all on by default).

Optional you could have used Render / Pattern / Grid. But for this tutorial we don't need a pattern 
that is such detailed.
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click to enlarge
4. Now choose Filter / Map / Bumpmap. As bumpmap choose the same layer you're just working on.

Map-Type: linear
Compensate for darkening: checked!
Azimuth: 0
Elevation: 90 
Depth: 6

The remaining options set to 0.

click to enlarge
5. Now choose Filter / Map / Map Object:

SETTINGS:
Map to: Sphere
Transparent background: checked.
Enable antialiasing

LIGHT:
No light
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MATERIAL:
Intensity
----------
Ambient: 0.3
Diffuse: 1

Reflectivity
----------
Diffuse: 0.5
Specular: 0
Highlight: 27

In the orientation tab use these values:

Position: 0,5 | 0,5 | 0
Rotation: -1,5 | 70 | 45

After applying you should get this result:

click to enlarge
6. The wireframe cannot be seen so clearly, so we're enhancing the contrast now.

Colors / Colorize: 195 / 100 / 20

After that go to Colors / Brightness & Contrast: 60 / 70
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click to enlarge
7. Goto Colors / Color to transparency and choose black as color.

Create a new layer, move it to the total bottom in the layers dialog and fill it black. Name that 
layer: "BG".

click to enlarge
8. Choose the wireframe layer. Goto Layer / Duplicate.

Name the top layer "Wireframe front". The one below name "Wireframe back". The layers should 
look like this now:
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click to enlarge
9. Activate the "Wireframe back" layer and set the transparency to 50%.

Activate the Flip-Tool now (SHIFT+F). Hold down CTRL and click in the image to flip the layer 
vertically.

Now you should get the impression of a transparent 3d-wireframe-sphere.

click to enlarge
10.Now we're doing the earth-part. Save the image of your choice (top right) - Earth or Moon.

Choose File / Open as layer and use the file you downloaded to open it as a seperate layer.

http://www.gimpusers.com/images/tutorials/95/8.png
http://www.gimpusers.com/images/tutorials/95/9.png


click to enlarge
11.- Layer / Scale Layer: 301x301. Move the earth / moon exactly above the the wireframe.

After that change the layer order so that the earth is between the two wireframes.

click to enlarge
12.We're almost done. Set the layer mode of the "Wireframe front"-layer to Screen.

We're applying a layer mask now for all layers to get a nice gradient. Right click each layer in the 
layers dialog (except the background-layer) and choose "add layer mask".
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click to enlarge
13.Select the standard preset colors by pressing D (Black and White). Choose the gradient tool (L) 

and be sure to make the gradient in the mask from left to right.

For the earth-layer-mask drag the gradient from top right to the bottom left third of the image.

click to enlarge
14.We're done! Voila ;)
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click to enlarge

2.7 Simple Scanlines
Written by devvv (04 Apr 2007 11:09 AM) 

The effect of scanlines is pretty popular, mainly for forum-signatures. This tutorial shows probably the 
easiest way to do this simple effect in the GIMP, in just 4 very short steps!

1. Open up a photo, or something else that you want to provide with scanlines. If you just want to 
test this tutorial download my sample-signature from the right and open it.

click to enlarge
2. Create a new empty layer. Take the Bucket Fill-Tool, choose white as foreground color and then 

fill the layer with it.

click to enlarge
3. Now apply Filter / Distorts / Erase every other row and just click OK. The lines are divided 

already, but the effect is not clearly visible. Click the picture to see what i mean.
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click to enlarge
4. We're going to enlarge the layer.

Take the Scale-Tool. Click the layer. In the upcoming dialog choose 200 "Percent" as Value for 
height and width. Click OK.

Now set the layer mode to "Overlay".

Done, enjoy the effect ;)

click to enlarge

2.8 Exploding Planet
Written by devvv (09 Dec 2007 05:58 PM) 
Translated to English by Paraknight 

Various special effects are just there to get to know some techniques that you might need once. The result 
of this tutorial will probably not be further used, but it still looks cool ;)

1. Like some others, this tutorial is an implementation of an existing Photoshop tutorial.

Create a new image (700px * 700px) with a black background colour.
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click to enlarge
2. Download the attachment to this tutorial (right), open the JPG and copy the cracked soil (ctrl+c) 

into your new GIMP-File onto a new layer. Press CRTL+T to transform and type in 700x700 
pixels. Now move the layer into the middle, so that everything can be seen. 

Optional: To achieve an exact positioning, you can also use the alignment tool. Click the tool, 
click on the layer with the cracked soil. Now go to: "Relative to:". Then click the icon for the 
horizontal and vertical middle each once - your layer should now exactly fit in the size of the 
image!

click to enlarge
3. Now, stretch the active layer on a ball: Go to Filters / Map / Map object and select "sphere". See 

the settings in the picture below. In the "light" tab select: No light.

click to enlarge
4. Invert the colors (Color / Invert). You will get a blue and white sphere:
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click to enlarge
5. We will now add the exploding rays. For this we first need the sphere streched on the layer: Filters 

/ Distorts / Polar coords. Disable the bottom-right checkbox "To Polar". Click OK. 

Then go to Image / Transform / Rotate 90° CW.

click to enlarge
6. Click Filters / Distorts / Wind with the values:

Wind
Direction: Right
Edge affected: Leading
Threshold: 5
Strength: 37

Use the filter again by pressing CTRL+F.
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click to enlarge
7. Now we must undo the stretching from before to get our sphere:

- Turn the Layer by selecting Layer / Transform / 90° CCW. It should now be on the top side. 
- Now select Filters / Distorts / Polar coords. Check the box for "To Polar" again. 

click to enlarge
8. Then it looks quite cool. Take the Select Eliptical Regions tool (Key E) make a selction around 

the planet - invert this and cut the white edge away.

After that go to Select / None to make the existin selection dissappear.

Press CRTL+B to make the tool window appear - then L to activate the Gradient tool. Search for 
the gradient seen on the picture.
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click to enlarge
9. Turn it around and go to Colors / Map / Gradient Map and you have your exploding planet!

Optionally, you could duplicate the planet layer. Soften this layer with the value 11, turn the 
transparency of the layer to 65% and change the layer mode to "screen" or "color". Thus, it 
reached a little more color intensity and softer transitions. Have fun with it.

click to enlarge
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2.9 Creating the Che Guevara Effect
Written by devvv (19 May 2007 01:02 PM) 

Probably the most popular picture that uses this black/white-effect is one of the famous revolutionist of 
Cuba: Che Guevara. To create such an effect for your own it is only necessary to take a few minutes of 
time.

1. Take a picture of yourself or anyone else. Open it.

click to enlarge
2. To get an optimal effect you've to mask your face. You don't have to take special time being very 

exact. Maybe the fastest way to this us the free selection tool. Make a selection around your face, 
invert the selection (Select / Invert) and remove the parts. 

Again, it is not important to be too exact.

Now choose #aeaeae as FG-Color and press CTRL+, (EDIT / Fill FG) to fill the selection with 
that color. Press CTRL SHIFT A to deselect.
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click to enlarge
3. Now go to (Layer /) Colors / Desaturate. That step is not totally necessary but i helps us to higher 

the amount of gray tones in the picture.

click to enlarge
4. Next go to: (Layer/) Colors / Threshold and move the little triangle-controls to similar places as I 

did. Alternatively you could enter 120 to the left and 215 to the right.

You should have good results with it.
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click to enlarge
5. You're done ;) Congratulations!

click to enlarge
6. Here we see the famous original picture of Che Guevara:

click to enlarge

2.10 Hot Wallpaper with Flames
Written by devvv (19 Aug 2006 09:39 AM) 
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In this desktop background tutorial I will show you how to create a hot wallpaper with Angelina Jolie. 
She is surrounded from and standing in hot flames ;)

1. Google images search, look for "Angelina Jolie", click the Dropdown to only view large images. 
You'll find this picture pretty easy. Save the picture and open it up in the GIMP.

click to enlarge
2. First of all we've to mask Angelina (free her body from the background). There are many ways to 

do this, one easy way is to use the paths-tool. Click B, thats the hotkey for the bezier-paths-tool. 
Check the "Polygon"-Option. Duplicate the picture and make the copy invisible by clicking the 
eye-icon in the layers-dialog.

In the layers-dialog activate the background-layer, click right and choose "Add Alpha-Channel".

Your layers should look like this now:

click to enlarge
3. Be sure to have the Paths-Tool active. Now start to click in the left bottom (where her hand is). 

Zoom the picture in to 300%, now click in small intervals along her skin. When encountering 
edges do very small click intervals. do this for the whole picture. First only for the outer part.
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click to enlarge
4. When you finished you need to hold CTRL and click the first point you set. This is to complete 

your path - it is completed as seen on the picture below.

If you did some points wrong or change anything in the path you can do this now by moving the 
single points. By holding CTRL and scrolling the wheel on your mouse you can zoom out/in. 
After you're satisified with your path hit ENTER and the path becomes an active selection.

click to enlarge
5. The part is now selected. Hit CTRL+I to invert the selection or go to Selection / Invert and 

remove the selected part (hit DEL):

click to enlarge
6. Now repeat step 3 with the inner - not yet transparent - part of the picture.
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click to enlarge
7. Angelina (freed from the background) should now look like this:

click to enlarge
8. Move her to the right, then go to Layer / Layer to picture size. Create a new, empty layer and fill it 

black. Move the layer to the total bottom in the layers-dialog.

click to enlarge
9. Now we need to some inner glow to her body!

- Add a new transparent Layer above the body layer
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- Set #ff7200 as FG-color.
- rightclick the layer with her body (layers-dialog), choose "Alpha to Selection"
- Select / Shrink: 5px
- Select / Feather: 20px
- Selection / Invert
- select the just created layer
- Edit / Fill with FG-Color
- Selection / None
- rightclick the body-layer again (layers-dialog) and again choose "Alpha to Selection".
- Selection / Invert
- activate the orange layer and cut the selection.

You should now have a inner glow on her!

click to enlarge
10.Next we need a strong drop shadow. 

- Filter / Light and Schadow / Drop Shadow (in GIMP 2.2 this filter is found under Script-Fu)

Radius: 60-70
Color: #ff6000
Opacity: 100%

click to enlarge
11.To make the glow more visible duplicate the layer 2 times.

Another way to get a nice glow is:
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- Alpha to Selection from the body-layer
- Selection / Expand: 5-10px
- create a new layer, move it behind (below) her body in the layers dialog
- fill the layer with any red or orange color
- deactivate the selection (SElection / None)
- choose Filter / Blur / Gaussian Blur and blur the layer pretty much until you're satisfied!

click to enlarge
12.Now we gonna duplicate her face and move it to the back, lower the opacity, so that it can be very 

little seen.

- Press Shift+T to get the Scale-Tool active.

In the popup-dialog set the chains to be linked! Set 2000px as new width. Click OK. Then move 
the layer directly above the black layer in the layers dialog.
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click to enlarge
13.Now we let her fade a bit. Press F (free selection tool) and make a slection as seen on the picture.

Optinal you can also use layer-masks if youre familiar with this technique.

click to enlarge
14.Then click Selection / Fade: 450px.

Delete the selected part.
- Selection /None

Now lower the opacity of this layer until you're satisfied. 

Optional you can colorize the layer now (Colors / Colorize)

click to enlarge
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15.Next we make the picture pretty hot ;) Open your browser (oh, damn I gueass it is already open ;)) 
google images search and search for a cool fire, or you download my fire (Tutorial-Details to the 
right).

- Open the fire.
- Selection / All
CTRL+c top copy alls

switch to our picture, press CTRL+v to paste and click the "add layer"-button in the layers dialog. 
Then you should have the fire on a seperate layer.

click to enlarge
16.Colors / Color to transparent. (in GIMP 2.2 this is found under Layers / Transparency / )

click to enlarge
17.The next step is totally up to you. Play around with the fire, duplicate the fire-layer a few times, 

some of them give in front of Angelina, some put behind her. Transform each layer, rotate, scale, 
do as you please until you're satisfied with it. Use the Erase-Tool with a big faded (soft) brush to 
delete certain pieces and fade the seperate fire layers to look like one peace.
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click to enlarge
18.Finally we want her glow very softly, we want to strenghten the shine.

- Duplicate the body-layer.
- Flter / Blur / Gaussian Blur: 40px
- Set the layer-mode to "overlay". The layer modes dropdown menu is found top to the opacity-
setting in the layers dialog.

Optinal you can use the selective blur instead of the gaussian to preserve some sharp countours.

Thats it! ;) Have fun doing your own wallpapers.

click to enlarge

2.11 Create a cool starfield
Written by devvv (15 Jun 2007 06:56 PM) 

This is maybe one of the oldest desktop wallpapers - nevertheless it is still a great motive! In this tutorial 
I'm gonna show you how you create a cool very realistic starfield with all the little details.

1. Create a new document: 1024x768 px (or any other size - just as you wish).

Fill the background layer black. Go to Filter / Noise / HSV-Noise. Look at the picture and use 
these values

http://www.gimpusers.com/users/devvv.html
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click to enlarge
2. - Colors / Brightness & Contrast -25 / +55.

You should get some whie dots on a black background. Name this layer "small stars" or "kleine 
Sterne" (as me).

click to enlarge
3. Duplicate the layer (the background-layer), name it "big stars" or "große Sterne" (as i did).

Again choose Brightness & Contrast from the colors menu: -70 / +40.

Now we have to enlarge this layer by doubling the size. That helps us to make the small stars on 
this layer even bigger so that they become bigger ones. Press SHIFT+T (or use the scale tool) and 
enter 200% as value.
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click to enlarge
4. We're going to enhance these stars to make them better visible. 

- Invert the layer by Color / Invert. That is to see the stars better.
- Colors / Threshold. Click the "automatic"-button to the right. Our dots should now be much 
better visible.

click to enlarge
5. Now invert the layer again (Colors / Invert) to see a black layer again. Scale the layer back to its 

almost original size. Press Shift+T and enter 53%.

Position the layer in the middle of the image. The easiest way to do this is to use the alignment-
tool (which is a new tool since GIMP 2.3.x series).

To use the alignment-tool do the following:

- Click the tool to activate it
- Click the layer in the image (that should be the big stars)
- The preferences of this tool should become active now.
- Choose "relative to image/picture"
- Then click both middle icons in the preferences to position your layer exactly to the middle of 
the screen.

The whole thing should look like this now:
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click to enlarge
6. In the layers-dialog choose "Screen" in the layers mode dropdown menu. Now we have a zoom or 

echo-effect. To avoid this we simply rotate the layer by 180°. (Shift+R to use the rotate tool: enter 
180°).

click to enlarge
7. Save your result.

We're nowgetting to the point in which we give our plain starfield some live. 

Use the free selection tool (F) and select randomly all over the layer. This is a wild action ;) View 
my picture to see what i mean.

click to enlarge
8. Grow the selection (Selection / Grow: 8px) and after that delete the selected parts in the picture by 

pressing DEL (or CTRL+K if you still use GIMP 2.2).

There should be only some big stars left in the image.
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click to enlarge
9. Create a new layer below the "small stars" layer ("kleine sterne"). Fill this layer totally black.

Now lets activate our small stars layer. Right click the layer in the layers dialog, choose "Add 
alpha channel".

Again use the free selection tool to select some parts of the image by random move the selection 
tool all over the layer, but it should be much less than the wild selection in step 7.

click to enlarge
10.Selection / Fade: 50px. Remove the selected area by pressing DEL. The small stars should be still 

crearly visible but some parts are darker or completely black.

click to enlarge
11.To see what my layers look like:
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click to enlarge
12.The next step is pretty easy: Image / Merge Image. Name this layer "Stars".

Now use the clone-tool, in the preferences choose "Screen" in the layers mode drop down. Now 
use the "Sparks"-Brush (the yellow one).

We're randomizing our stars now so that they look real. This step is easily done. Set a starting-
point by holding down CTRL and click a part in the image. Then simply paint at any other part of 
the image. The area is then copied all over and added to the current position. They're added 
because we use the "screen"-mode in the preferences. That means that our stars never become less 
- the become more all the time. If you want lesser stars in an area you need to change the mode 
back to "normal" and clone a region that contains only few stars.

Lots of text ;) now just start to give your space live! and repeat the action of cloning.

My result looks like that:
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click to enlarge
13.Duplicate the layer. Name it "Stars glow" or "sternen glühen" as me.

- Filter / Blur / Gaussian Blur: 15px
- Colors / Color Balance:

Shadows: -100 / 0 / 40
Mids: -100 / 30 / 40
Highlights: -100 / 30 / 40

- Set the layers mode to "addition" or "screen".

Your starfield should now glow blueish. If you want to have it glow even more just duplicate the 
glow layer.

click to enlarge
14.Now some rather small steps follow to give our picture more cool details. We will make some 

bright glowing stars.

Create a new layer: fill it black.
- Filter / Light and Shadow / Supernova
Having the filter dialog open enter any values you like to create you shining star. But don't make 
it too big for the first time and place it in the middle.
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click to enlarge
Set the layers mode to "Addition" and move the layer to any position you want to have the star. Duplicate 
it, scale it (SHIFT+T) to a smaller or bigger size and move it to any other position.

Repeat this until you are satisfied with the result.

Optional: You can add some more color if you like. To do so you simply have to select the appropriate 
area in the "stars glow" layer with the free selection tool, fade this selection, and the apply Colors / 
Colorize to change the color of that area.

My final starfield looks like this. Have fun creating you very own starfields ;) This can also be nicely 
used as a wallpaper.

click to enlarge

2.12 Turning people into stone
Written by devvv (06 Jul 2007 11:49 PM) 

It is a very very hard thing to turn people to stone and make it look real. Not every picture can be used 
and there is a lot of fine-tuning necessary. If the effect is not working well just give it a new title: 
"Turning people into a zombie" ;)

1. Open up an image that shows a person that you want to turn into stone.

The next action is not needed if you want to print the picture: Go to Image / Scale: 1024 x 768.
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click to enlarge
2. The first step is to free the person/the face of the person from the background. Use the paths-tool 

and set points along the outline of the person. Do this as long as you have come around the whole 
face. Then connect the last point with the first one by holding down CTRL when clicking the first 
point.

click to enlarge
3. Now press ENTER. You're getting a selection then. The next step is to add a layer mask. Right 

click the layer in the layers dialog and choose "Add layer mask". Choose "selection" from the 
popping dialog. The person is now masked.

Now add a new layer, fill it totally black. Move this layer down to the very bottom.

click to enlarge
4. My layers look like this now:
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click to enlarge
5. The next step is to get a selection of the face itself. Because we worked with the paths-tool (...and 

paths are automatically saved...) we save a bit of time using an existing path and alter it.

Dialog / Paths. In the dialog duplicate the existing path, name it "Face" (= "Gesicht" on the 
image). Double click the path. This activates the paths-tool and shows the existing path.

Switch to the layers dialog and click the layer with the body.
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click to enlarge
6. Click the bottom edges now and press backspace on your keyboard to delete a point. Our goal is 

to (in my picture) seperate the cloths from the face. 

Repeat the deletion of the points until you're having a line between the left and the right side of 
the face. See the picture to understand what i mean.

Now choose "Edit" in the preferences of the paths tool.

click to enlarge
7. Then click the long line and move it down so border where skin ends and is covered by the cloths. 

Repeat this step until you get a nice completed path.

http://www.gimpusers.com/images/tutorials/82/5.png
http://www.gimpusers.com/images/tutorials/82/6.png


click to enlarge
8. Press ENTER when done and CTRL+c to copy, CTRL+v to paste. Click the "Add layer"-button 

to get the pasted onto a new layer.

Press M to select the Move-tool. The path should disappear.

click to enlarge
9. We are now prepared to start the stoney part.

2 easy steps follow:

- Activate the Body-layer
- Colors / Colors&Saturation - the saturation option move to the left to -75.
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- Activate the Face-layer: Colors / Desaturate.

click to enlarge
10.Now follows an important part for the eyes so that your stoney face gets a realistic look.

Use the paths tool again. Make a nice selection around the left eye. It should be very nice detailed 
and then press ENTER to get a selection of it.

click to enlarge
11.Choose the clone-tool now and take a soft brush (17). Hold CTRL down and set the point from 

which you want to start your cloning. You'll maybe want to select a part on the forehead. Release 
CTRL then.

Leave the selection active. Now add a new empty layer. On this layer clone the skin of your front 
over the eye.

click to enlarge
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12.Let the selection active and activate the dodge/burn-tool. Set "Burn" as option and use a soft 
brush to paint along the border of the eye. Burn the borders of the eye until the darkness is pretty 
much the same as in the corner of the eye. See my image to get a feel for this.

click to enlarge
13.With the selection active go to Filter / Blur / Gaussian Blur: 8px. Deactivate the selection.

To get some structure/pattern we add noise now: Filter / Noise / HSV: 3 | 0 | 0 | 15

Then use the Gaussian Blur again: 1px.

click to enlarge
14.Repeat the steps for the eye on a new seperate layer.

click to enlarge
15.My layers look like this now:
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click to enlarge
16.Merge the two layers with the eyes and the face-layer now: (use "Merge down" from the right 

click context menu of the layers dialog). Eyes and face should now be on a single layer.
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click to enlarge
17.Colors / Brightness & Contrast: +90/+90

click to enlarge
18.Download the "Stone-Texture" from the top right of this tutorial.

Click File / Open as new layer and choose the location of the texture.

Desatuarte using Colors / Desaturate. The layer should be atop all other layers.
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click to enlarge
19.Now move the texture layer at a position where it coveres the whole face. Use the Rotate-tool to 

cover more of the face.

click to enlarge
20.Next step is to activate the face layer. In the layers dialog click right and choose "Selection from 

Alpha". Activate the texture layer again and add a layer mask. Choose "Selection" from the 
popup-dialog. Now the stone should have the shape of the face.

- Selection / None

click to enlarge
21.Set the layers mode to "Multiply", lower the opacity to 60% and apply Filter / Enhance / Sharpen: 

45px.
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click to enlarge
22.To get more depth we duplicate the layer with the face. Move the duplicate to the very top of all 

layers.

Colors / Brightness & Contrast: -90/+50 and set the layers mode to Overlay. Opacity to 60% 
again.

click to enlarge
23.Because stone is never totally grey we need to colorize it a little bit. A soft yellow-green or 

yellow-red would be nice: Colors / Color Balance:

Mids: 45/45/-45

click to enlarge
24.And because we masked our body at the beginning we can now easily put our stoney face to a 

more attractive background (I tried google image search for "graveyard"). Open the picture as 
new layer and put it above the black background layer like i did here:
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click to enlarge
25.Here you'll see my final layers:

click to enlarge
26.And this is just another version i played with. It reminds me of Warcraft 3 (The undead cd 

cover ;))

click to enlarge
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2.13 Create a shocking sphere/ball
Written by MaleXx (11 Aug 2007 02:33 PM) 

In this tutorial our user MaleXx wll show you how you can create a shocking sphere by combining some 
tutorials of gimpusers.de to a new one. Have fun!

1. First we are making the shock ball. For that we create a new file with the size 500x500px.
2. Filters>Render>Clouds>solid noise, use parameters from picture

click to enlarge
3. Filters>Artistic>Cubism, use parameters from picture and then Filters>Edge-Detect>Edge with 

standard parameter

click to enlarge
4. Now your picture should look like this:
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click to enlarge
5. Filters>Map>Map Object, use parameters from picture, select by Lightsource type “no light”

click to enlarge
6. Now your picture should look like this:

click to enlarge
7. Filters>Distorts>Polar Coords, use parameters from picture
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click to enlarge
8. Bild> Transform>Rotate 90 degrees CCW, then Filters>Distorts>Wind, use parameters from 

picture

click to enlarge
9. Then repeat with Ctrl+F. Image>Transform>Rotate 90 degrees CCW, then Filters>Distorts>Polar 

Coords, use parameters from picture (look at the left picture)

Now your picture should look like this:(look at the right picture)

click to enlarge
10.Now there is a white border round the image. Select therefore the ball with the selection tool and 

click on Select>Invert
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click to enlarge
11.After you cut out the white border, duplicate the layer with the ball and adjust the upper layer on 

“screen” mode.

Now the white parts in the picture are brighter.

click to enlarge
12.Your picture should look like this now:
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click to enlarge
13.Right click the Layers dialog: "Merge down".

Here the picture can be colored. For that click on Layer>Colors>Colorize and create the color you 
like.

click to enlarge
14.Create the „atmosphere“. Built a transparent layer und put it in the background. Click on 

>Filters>Light Effects>GFlare and take the parameter out of the next image.

The color doesn´t matter. Repeat effect with Ctrl+F. Create a second layer the same way and click 
again on Filters>Light Effects>GFlare, with the same parameters. This layer needs to b e shift one 
level before the planet layer.
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click to enlarge
15.Now create a black layer und put it in the background. 
16.The ball is complete now. Add a name. Use the Text Tool and write a short name with a font with 

less details.

click to enlarge
17.The color should be the same as used on the planet.

Your image and the layer now should look like this:

click to enlarge
18.Create a new transparent layer and scroll it under the text layer. 

Go to the layer toolbox and select the “text layer”. Then click with the right mouse-button on it 
and choose “Merge down“
Go to Filters>Light-Effects>Lighting Effects and put the blue point into the middle of your text, 
that the light flashes text in the middle. After that, choose OK.

click to enlarge
19.Now click on Script-Fu>Shadow>Drop-Shadow and use the parameters of the next image.
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click to enlarge
20.Done. The final picture should look like this:

click to enlarge

2.14 How to change a boring sky to a cool cloudy sky
Written by Kiri (17 Jan 2008 08:33 AM) 

A brief tutorial, to change a boring sky into an interessting cloudy sky. Because no one will believe, that 
you've got such a fine weather in the alps.

1. Select the whole blue sky with the magic-wand-tool. To select the whole sky, move the mouse a 
little bit to the right side, while you push the mouse-button
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click to enlarge
2. Add a new, transparent layer from the selection. Entitle this layer „Clouds“. In my example 

(„Wolken“ which is the German word for clouds)

click to enlarge
3. Call the layer-dialogue (STRG+L). Activate the cloud-layer
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click to enlarge
4. Apply Filter / Render / Clouds / Plasma. 

click to enlarge
5. Colours, Desaturate. 

click to enlarge
6. Now change the layer mode to either: 

„Screen“ or „Overlay“ or „Soft Edges“

click to enlarge
7. Feel free to experiment with the transparency of the layer. Or you can duplicate the clouds-layer 

to get a stronger look - just as you like!

2.15 Vexel Simulation on Photos
Written by devvv (12 Aug 2007 10:21 AM) 
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Some of you might know this very cool effect where a person is looking somehow 'vectorized' or 
fragmented into vector shapes. However GIMP is not the best choice since it is not a vector-program. But 
I found a cool way to simulate that effect without using vector shapes. Enjoy!

1. In the first step open up an image of your choice. An existing wallpaper with a celebrity will work 
best I think.

If you find Rihanna looks good for this you can of course use my template (download from the 
right) to follow the tutorial step by step and learn the technique.

click to enlarge
2. If you don't use this wallpaper you probably have to extract/mask the person first. That will help 

the effect to look better in the end. In this case our person is already on black background. Thats 
good enough.

We're preparing the effect now:

Filter / Blur / Selective gaussian Blur: 18px.
Delta: 30

Tip: This kind of blur mechanism makes it possible to blur similar areas of the image without 
effecting the sharper edges. Thats important here to preserve the general detail of the image.

click to enlarge
3. We see a slight problem occuring now. When looking at her skin it has many small white dots we 

don't want.
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Second problem: If you look at the eyes they also have a white dot, but thats one we want!

We're using the free selection tool now. Do a small selection around her eyes. Then do:

Selection / Feather: 50px.
Selection / Invert.

click to enlarge
4. Now we've everything selected except her eyes and we can now work on the small white dots.

Go to Filter / Enhance / Despeckle.

Adaptive on.
Values: 3 / 0 / 240

Repeat the filter by pressing CTRG+F. Now all the white dots should have gone.

click to enlarge
5. The selection should still be active. We need to blur very strong now to gain a good smooth 
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curves at the end.

Again use Filter / Blur / Selective gaussian blur. This time use these values: 15px (Radius) and 
35px (Delta)

Tip for those who use another picture: Take a close look on the smooth areas. They have to be 
really smooth, while the detail of eyes and lips or on this picture the detail of her earrings have to 
be preserved. You can achieve this by makinf free selections and feathering them as we did with 
the eyes before.

click to enlarge
6. Selection / None.

Duplicate the layer now. The go to Color / Desaturate: Average.

click to enlarge
7. Colors / Posterize. You can play around with these values now. It looks usually good when using 

values between 8 and 15.

click to enlarge
8. Vector pictures are from nature very sharp and have clean edges. We can make this better in our 

picture by just using Filter / Enhance / Sharpen: 45px.
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click to enlarge
9. Move the grey duplicate down in the layers dialog. Click the photo-layer to activate it and use the 

layer mode "Color". We're done ;)

click to enlarge
10.The final picture looks like this after some minimal brightness & contrast adjustments.

click to enlarge
11.Here's an image with Jennifer Garner which i played with, but the effect looks better on the 

picture with Rihanna I guess. At the picture with Jennifer it was very hard to get smooth curves 
and preserve detail.

Have fun!
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click to enlarge

2.16 Old Photo
Preview:

This tutorial will teach you how to transform a normal photo into something that looks like the 1890s 
very neat effect.

1. Open the image of your choice.

Make sure it's RGB (not Indexed), of course.

-Go to layers>transparency>add alpha channel.
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Image After Step Two

2. Go to Image>Canvas Size... Click the "chain" to break it keeping aspect ratio.

-Increase the new width and new height by about 20 apiece (may vary according to your image size, but 20 
is a good size for smaller images).

-Click center to center the image, and then OK

3. In the Layers, Channels, and Paths dialogue box, create a new white layer.

-Fill it with the color #a7986f (a brown). Move it below your photo layer.

4. Do Layers>alpha to selection on your original photo layer.

-Grow selection by 5 (that is, one-fourth of what you increased the canvas size).

5. Feather selection by 20.

-Make a new transparent layer, move it between

the original photo layer and the brown layer. 

-Fill the selection with white.

-Deselect (Selection>None).

http://gimp-tutorials.net/oldphoto#


Image after Step Six

6. Duplicate the feathered white layer... Each time you do, a little more of the brown will be covered. I 
copied twice for this image.

7. Select your original photo layer.

-Select colors>desaturate.

-Copy your original photo layer, and fill it completely with #a7986f (same brown as before).

-Set the layer blending mode to Overlay. You may at this point duplicate and modify the opacity of this 
layer to produce the amount of brown you wish to have shown in your picture, fiddle with the contrast of 
the original black and white layer (very recommended). You can make it look as if it has been washed 
out, or more sepia than anything. Or you could just leave it how it is. :P

-You may flatten the image, but it looks rather boring. Let's continue below for more effects.



Image after step seven

Optional Steps to increase detail: 8. Obtain a nice set of grunge brushes (ahem Prowler's Brush Packs)

http://silence.carchive.net/?section=resources.php


Image after most of Step Nine

9. To make it seem as if the photo has been scratched off a bit, use grunge brushes along the edges and a 
little bit in the center of the original photo layer and erase portions of it (make sure you duplicate it just in 
case you overdo it, make the copy invisible so you can see what happens when you erase).

-Personally I use Part 2-3 (Scratches), Prowler Grunge 14#6, Prowler Grunge 7, Prowler Grunge 6, 
Prowler Grunge 10#2, and from another brush pack, Grunge 23 and 24. *This tutorial is four years old, so 
I can't remember the name of that particular pack.*

-Do this a little to the border itself so it doesn't look too uniform: add a little black shading, also. Coffee 
stains also work well.. 

-To make the border appear distressed or ripped, you could use the hard erase tool and use one or two of 
the brushes to remove parts of the bottom white layer. Look at the above image to see where I erased 
parts. The very tips of grunge brushes work well.

-Afterwards, you can flatten the image, and copy and paste it to a much larger sized image... I usually 
scale down my photo about 33.3% (Ratio X,Y ,667). I then use the transform tool to rotate it about 15º. 
Copy the layer, fill it with black, layer to image size, and, making sure keep trans. is off, blur by about 
3x3 (and copy if necessary for a thicker shadow).

I usually add a staple, paper clip, or tape around this time. I did a tape tutorial, but the other two should 
be fairly easy to figure out. I no longer have the saved gfig shape for the paper clip. >_< 
http://silence.carchive.net/?section=images/tutorials/tapetutorial.html

And there you have it. I might have an error or two or an old location in this tutorial. Just let me know.

http://silence.carchive.net/?section=images/tutorials/tapetutorial.html


2.17  Popout Photo
Really, this tutorial will be about masking: taking a photograph and separating a foreground subject from 
the background, for the purposes of doing something interesting with it.

This kind of subject may prove unsatisfying, because when you sit down to write a tutorial, you're free to 
pick whatever nice clean image you want as your subject. In the real world, clients come to you with 
fuzzy, blurry, low-res JPGs that have been saved numerous times, with a whole circus of noise in the 
background. So that's how these masking tutorials make it look so easy: we cheat. If you find this work to 
be slow, frustrating, and tedious, you're right: masking is just like that, and takes some skill to pull off.

So, for our nice, clean, no-hassle subject image, we'll use this Model-A Ford photo from Wikimedia 
Commons. From the featured images, yet!

How to mask a subject

1. Generally, the first step is to go Filters-> Colors-> Decompose, and in the dialog check "RGB" and 
"decompose to layers. You will have a new image with three layers for the channels red, green, and blue. 
The reason for this is that in noisy photos, the green channel will usually have the best contrast. In some 
cases with less co-operative pictures, you can combine the channels together in different ways to bring 
out better contrast.

2. Copy the channel into a new layer on top of your source image. We'll work with this to get our 
selection. You can close the channels image. You'll always want to use the magnify tool to blow up the 
image as much as you can. And select the scissors tool.

http://commons.wikimedia.org/wiki/Image:1928_Model_A_Ford.jpg


3. Generally, the process is going to be:

1. Use scissors to find the rough outline of the subject. 
2. Use the lasso select tool in addition mode to include any parts of the subject border and in 

subtraction mode to cut out parts that aren't part of the subject. 
3. Copy the section from the source to a new layer. 
4. Use the eraser to shave off bits of the background from the image border. 

Now, the scissors tool is an inexact, buggy way to select a subject, but we'll be able to correct its mistakes 
later. To use it, click a series of dots around the subject. Make your dots close together, like this:



The closer you make your dots, the easier time the scissors tool will have finding the border of your 
subject. In areas where there isn't a nice, clear border contrast, make the dots even closer. Remember that 
we'll take several more steps to clean this up, so it doesn't have to be exact. But the closer we get it, the 
less time it will take to clean up. When you've traced dots all the way around the image, click the first dot 
you laid down and then click inside the image to turn it into a selection.

Here, I've cut away all the not-selected parts to illustrate where we are:



4. What a lucky shot; with this nice, clean image with a subject that's all straight lines and well-defined 
curves, we've got it mostly done in one step. Magnify your image some more and start using the lasso 
selector to either include missing chunks in the selection in addition mode or to cut background off of the 
selection. Note that you have to start clicking and dragging the selector cursor outside your selection, or 
else it will think you want to move the selection.

Here, I have stroked the path of our initial selection in red, then drawn a blue box around the part I want 
to cut off, with a blue X to mark where I start with the lasso selector. Note the pink oval, which is 
showing the part of the selection options dialog where you change modes between replace, add, subtract, 
and intersect.



5. After you have the selection roughly where you need it, copy the original source image layer to a new 
layer and cut out all the parts not in the layer (Select-> Invert and Ctrl-K, for instance). In this case, I 
have added a white background and highlighted the next step, which is using the eraser tool to erase 
around the border and smooth off rough edges. The eraser is using a small fuzzy-circle head, and I'm 
holding down the shift key to get a straight line along this edge.

Other selection tricks which may work will be: setting the selection options to anti-aliasing, setting them 
to feather edges, and growing the selection by one pixel, all prior to copying. I have here neglected these 
steps to illustrate what to do when you have to wipe bits off the border of the selection. No two images 
will have the same steps.

We now return to the earlier finished selection I did:



6. Now that you (or, at least, I) have a cleaned-up model separated from the background, the actual work 
from here is a breeze. First in the layers dialog, let's delete the black and white layer, rename our cut-out 
subject's layer "Subject", and the white layer "Frame". Move the frame up between the subject and 
background. Have the eyeballs on for the subject and white frame. And move a horizontal guide out in 
the image to where you want the edge of the frame to be. Now with the white frame layer active, Select-> 
All and use the "Perspective Transform" tool to make that white rectangle into a trapezoid which will be 
the frame's shape.

7. Turn off the eyeball in the layers dialog next to the Subject, leaving only the Frame layer visible. Use 
the magic-wand selector tool to select the white trapezoid, then do Select-> Shrink and have it shrink by 
about 15 pixels. Hit Ctrl-K to delete the new shape inside of the frame shape. Note that you may also 



want to apply a Guassian Blur of about 2.0 to the frame to eliminate aliased jaggies along the slanted 
frame edges.

8. Now use the magic wand selector tool again, to click outside the white frame. With that selection 
active, in the layers dialog make the background visible, make it the active layer, and in the image hit 
Crtl-K to cut out everything outside of the frame's border.



9. Almost there! Make all of the layers visible, and merge them all down on top of each other. Make a 
new layer with foreground color set to neutral gray and move it to the bottom layer and flatten the image.

I hate to say "Voila!" with such a sloppy job, but here it is, anyway:

Note that there's a lot we neglected, here. The car's shadow doesn't continue out of the frame. To get that, 
we would have to make a separate mask for the car's shadow. I blurred the car a bit to smooth out rough 
edges. I cropped the tires too close when cutting the shadow from them. But to the casual glance, this 
project is moderately acceptable. I would of course taken much more time had this been a professional 
assignment.

Of course, I did more work than was necessary for the finished effect - I could have just masked the front 
half of the car. But actually I masked the whole thing as a project before deciding what to do with it.

Conclusion: masking is an expert-level image hack, and takes much practice. But it is good to have, 
because professionally you run into it all the time: clients have an old logo they want modified and don't 
have the source images, or they want a subject moved to a different background, and so on.

2.18 Adding photo frames to a photo in Gimp
In this tutorial I am going to show how to create a simple but great looking photo frame for your photos. 
The finished result will look something like this:



1. Firstly open your chosen photo. I am using a photo of me when I was a child playing on my first 
proper keyboard (ahh, the memories). I have resized the image to 500px x 333px  for the purpose 
of this tutorial. 

2. Add a new layer (Ctrl + L [activates the layers dialog] and clicking the add new layer button). Set 
the background as white. 

3. Draw a rectangle inside the layer like this:

 
4. Press Delete:

 



5. This has created the simple frame, so now we can add a shadow to the frame to give it a sense of 
reality. To do this go to Filters -> Light and Shadow -> Drop Shadow and change the settings to 
these:

 
6. This will give the following result:

 
7. Now we can add a texture to the frame, I am going to go for a wooden texture. To do this select 

the frame layer you created, activate the canvas window and press Ctrl + A followed by Ctrl + X 
and Ctrl + V. This will cut and paste the contents of that layer meaning that the area where the 
content is can now be edited without affecting the blank space in the middle where the image is 
shown. 

8. Go to the main window (Ctrl + B) and select the paint bucket tool, in the options below change it 
to pattern fill and select the Wood #1 pattern. Go back to the canvas and click on the selected area. 

9. And that is it, you can experiment with different patterns or colours and make it exactly how you 



would like it, the finished result will look something like this:

 

2.19 Choosing your photo
This effect tends to work best with photos with vivid colors (sky, grass, etc). This is the photo we will be 
using:

Swirly Grass and Sky by habitatgirl

Adjusting your photo

The following steps are for this photo. Remember to experiment as each photo is unique!

http://flickr.com/photos/mrshall/
http://flickr.com/photos/mrshall/2147350134/


Once you've opened your photo, go to Colors > Brightness-Contrast... and set the contrast to +20.

Colors > Hue-Saturation:

Now go to Colors > Curves. Select "Red" from the Channel drop-down and adjust the curve:

Next, adjust the "Green" channel:



And the "Blue" channel:

Click OK.

Go to Colors > Hue-Saturation again:



Adding a Vignette

Create a new layer. Set its opacity to about 50%.

Select the ellipse select tool and draw a selection that covers your entire canvas.

Select > Feather by 150px:

Select > Invert.

Fill your selection with black.

Final Touch

To give your photo a pinkish tone (associated with sun burn of old photos), create a new layer. Set its 
opacity to about 8%.

Fill it with a very vivid magenta (#FF0090).

Ta-da!



2.20 Create an Apple like reflection with Gimp
Creating a professional looking apple-like reflection is simple to do with The Gimp and it will give your 
website a great look of professionalism.
Follow these simple steps and you could soon have an amazing looking reflection:

1. Start by opening the image you would like to create the effect with. 
2. Select Canvas Size from the Image menu. 
3. On the window that appears click the Anchor image.



 
4. Now change the height property to double the size as it is now and click the Resize button. 
5. Now you need to go to the Layers window, to do this press Ctrl + L 
6. Click the Duplicate layer button

 
7. Select the new layer in the layer window. 



8. Go back to the image window and press “R”, now use the down arrow key to move it to below the 
original image. 

9. Now press Shift + F 
10.Go to The Gimp main window and change the property from Horizontal to Vertical

 
11.Click the reflected image with the special cursor that is shown.

 
12.Now go back to the Layers window by pressing Ctrl + L and right click on the reflected layer and 

select “Add Layer Mask” 
13.On the window that is shown select the first option if it isn’t already selected and click OK.



 
14.Press “L” or click the Gradient option on the main window. 
15.Change the Gradient option to “FG to Transparent” 
16.Now go to the image and click and drag the cursor from the bottom of the reflected image to the 

top of the image

 
17.And there you have it, your very own Apple like transparent image.



 

3. Buttons, Icons

3.1 Orb-Icons for Websites
Written by devvv (18 Mar 2007 02:11 PM) 

Of course you know these small little icons which can be often seen all around the web that look like a 
small glossy orb. Pretty nice to enhance also your personal website with it!

1. Create a new file: 250x250px. Fill the background with #828282.

click to enlarge
2. Take the Elliptical Selection-Tool and create an exact circle. After that create a new empty layer, 

take the Gradient-Tool (L). As a FG-color choose #571f00, for the BG-color choose #ff5a00.

Now draw a gradient from top to the bottom of that layer.

http://www.gimpusers.com/users/devvv.html
http://www.gimpusers.com/images/tutorials/60/1.png


click to enlarge
3. The selection should still be active.

Again create a new layer. Fill it black. To do this very fast first press D then press CTRL+,

Now follow these steps:

- Select / Shrink: 1px
- Select / Feather: 100px

After that press DEL two times to delete the selected part. 

click to enlarge
4. Activate the layer that contains the gradient.

Go to Filter / Licht & Shadow: Drop Shadow. X/Y: 0/0, Tranparency: 60%.

click to enlarge
5. Activate the layer that contains the gradient. From the context-menu of the layers-dialog choose 

"Alpha to selection".

Add a new layer. Choose white as FG-color. Take the "Gradient-Tool". In the preferences-box of 
this tool choose the fourth option in the drop-down-menu for the gradients: "FG to Trasparent". 
Apply this gradient from top to bottom.

click to enlarge
6. - Select / None

- Activate the Scale-Tool
- Click the layer, when the popup-menu appears enter 175 as width and 150px for the new height. 
Click OK.

http://www.gimpusers.com/images/tutorials/60/2.png
http://www.gimpusers.com/images/tutorials/60/3.png


click to enlarge
7. Take the Move-Tool now and move the white shine (the gradient ;)) to the top in the upper center 

of the sphere.

click to enlarge
8. Go to Filter / Blur / Gaussian Blur: Value: 5.

click to enlarge
9. We're almost done. Now you can add for example a single character or any small symbol you 

want.

I took the Text-Tool and simply wrote a question-mark "?" in white color into the middle of the 
orb. Then i chose "Grain extract" from the layers-mode drop-down.

click to enlarge
10.Thats it! Have fun with your new orbs ;)

http://www.gimpusers.com/images/tutorials/60/6.png
http://www.gimpusers.com/images/tutorials/60/7.png
http://www.gimpusers.com/images/tutorials/60/8.png


click to enlarge

3.2 Creating a simple Company Logo
Written by devvv (26 Apr 2007 08:12 PM) 

Today we want to create a simple logo, which is pretty neutral so you can use it for many different things. 
We're first drawing some text and then decorate it with a nice colored and curved path!

1. If you want to use my font download it from the right side (tutorial details), install it in your OS 
and restart GIMP.

Create a new file. I've used a small size, just for demonstration purpose, you can use any size you 
want.

click to enlarge
2. Now write two text-pieces on the layer. I've user "gimpusers" (white color) and "design" (#cbcbcb 

as color). Font size: 40px. Deactivate the "hinting"-option, since it is only useful for small fonts. 

http://www.gimpusers.com/users/devvv.html
http://www.gimpusers.com/images/tutorials/60/10.png
http://creativecommons.org/licenses/by-nc/2.0/at/deed.en
http://www.gimpusers.com/images/tutorials/63/1.png


We've relatively big ones here ;)

Take the Move-Tool and put the text to the position shown on the picture below.

click to enlarge
3. The next step is to create a path, so that our text more becomes a real logo. We will draw a nice 

curved "thing" ;) around our text.

To do this please take the paths-tool (B). Start clicking in the bottom left until you have the same 
points as seen on the picture. I have set the opacity for "design" very low to better show you the 
points I made.

click to enlarge
4. When reaching the first point, holt CTRL to unify the last point with the first. You should then 

have a fully closed path. You can still move points around if you're not satisfied with your path.

After completion move the bottom edge downwards (click in the middle of the edge and drag it to 
the bottom). It should be a curve now!

http://www.gimpusers.com/images/tutorials/63/2.png


click to enlarge
5. With the two dashed lines appearing now you can affect the curve. Drag the left dashed line a 

little more to the middle, it should become more even. The right dahed line move a bit to the right. 
If you look at the line above the dashed line should become one long even line.

After that take the edge thats above the line we just adjusted. Move the dashed lines as seen in the 
picture!

click to enlarge
6. Click ENTER now and you should get a selection of the path.

- create a new, empty layer
- set #dcf6ff and #00b8e0 as BG-color.
- take the gradient-tool or just press L

http://www.gimpusers.com/images/tutorials/63/4.png
http://www.gimpusers.com/images/tutorials/63/5.png


Look at the settings on the picture!

click to enlarge
7. Now draw the gradient anywhere on the layer, doesn't matter where. The selection is then filled 

with the gradient.

Press CTRL SHIFT A or go to Selection / None to deselect all.

http://www.gimpusers.com/images/tutorials/63/6.png
http://www.gimpusers.com/images/tutorials/63/7.png


click to enlarge
8. Colors / Brightness & Contrast: -25/+35.

click to enlarge
9. My layers look like this at the moment:

click to enlarge
10.Now we add a small shadow to give the logo more depth.

http://www.gimpusers.com/images/tutorials/63/8.png
http://www.gimpusers.com/images/tutorials/63/9.png


- rightclick the layer with the colored form in the layers-dialog.
- "Alpha to Selection"
- add a new layer below the form-layer.
- fill the selection with black and set the opacity of this layer to 25%.
- take the Move-Tool now, in the settings select "Move the active layer" and then move the layer a 
bit to the bottom!

Thats it! I hope you like it!

click to enlarge

3.3 Stylish buttons
Written by devvv (25 May 2007 06:47 PM) 

Buttons are pretty nice for many things in the web. As long as you dont use them too much they can give 
your website a good look. In the following tutorial, we're going to make some cool and stylish looking 
buttons. At the end you can colorize them with a very simple technique.

1. Open a new file. 120x30px. Black background.

click to enlarge
2. Create a new transparent layer. 

- Selection / All (or just press CTRL A)
- Selection / Shrink: 3px.
- Selection / Rounded Rectangle.

http://www.gimpusers.com/users/devvv.html
http://www.gimpusers.com/images/tutorials/63/10.png
http://creativecommons.org/licenses/by-nc/2.0/at/deed.en
http://www.gimpusers.com/images/tutorials/71/1.png


click to enlarge
3. Now choose any fore- and background-color you like. i.e.: FG #ab6000 and BG: #f88c00. Fill this 

new layer with the standard gradient. (Take the Gradient-Tool and draw a gradient from top to 
bottom), so that the brighter color is seen at the top.

click to enlarge
4. Still let the selection active! Create a new layer, fill it totally white. Go to Selection / Shrink: 1px 

and remove the selected part. A 1px border should remain. 

-Selection / None

click to enlarge
5. In the layers dialog set the layers mode to "Soft light". Transparency / Opacity to 60%. The layers 

look like this now.

http://www.gimpusers.com/images/tutorials/71/2.png
http://www.gimpusers.com/images/tutorials/71/3.png
http://www.gimpusers.com/images/tutorials/71/4.png


click to enlarge
6. Now choose the Text-Tool (T). Write any text you like, choose white as color for this text.

click to enlarge
7. Move the text a little to the right and choose the paths-tool (B). 

- Add a new empty layer.
- Do a path as seen in the picture.
You can end the path while holdig CTRL down and clicking the point of your beginning.

click to enlarge

http://www.gimpusers.com/images/tutorials/71/5.png
http://www.gimpusers.com/images/tutorials/71/6.png
http://www.gimpusers.com/images/tutorials/71/7.png


8. After that press ENTER to become a selection out of the path. Fill this selection with any color 
brighter that your background. I.e.:##ffcb4b.

- Selection / None to get rid of the selection.

click to enlarge
9. Duplicate the layer and move the duplicate a little bit to the right.

click to enlarge
10.Now we're doing the glossy part of the button.

Activate the colored gradient layer. Right click it in the layers dialog and choose "Selection from 
Alpha". Click the layer at the most top - then add a new layer on top of it.

- Selection / Shrink: 1px.
- Press L to active the Gradient-Tool.

As gradient choose the 4. one from the drop down menu (named "Color to transparent"). Click in 
the top are of the button and move your mouse a little to the bottom. When holding CTRL while 
drawing the gradient it helps you to get an exact horizontal gradient.

click to enlarge
11.Now if you want you button in any other color do the tutorial again, haha. Damn no, I'm just 

joking ;) If you want to test some other colors do this:

Above all layers create a new empty one, fill this layer with the color you want to test. Select 
"Color" in the layers mode drop down. And instantly your buttons color has changed. You can 
also try gradients!

http://www.gimpusers.com/images/tutorials/71/8.png
http://www.gimpusers.com/images/tutorials/71/9.png
http://www.gimpusers.com/images/tutorials/71/10.png


Tip: You can only use the base color tones. Fades to grey don't have any effect.

Your buttons could look like this:

click to enlarge

3.4 Creating 3D icons
Written by devvv (25 May 2007 07:31 PM) 

Want some cool 3d-icons? Then you're right here ;) We're going to create some 3d-icons today. We're 
demonstrating the 3D-effect with a simple arrow that could be used as a download-button.

1. Create a new file: 300x300px. Set the background to any color of your choice. I chose #bbbbbb as 
color.

click to enlarge
2. The first step is to create the basic form of the arrow.

- Add a new empty layer.
- Rectangle Selection Tool. Draw a selection as seen on the picture. To get rounded corners go to: 
Selection / Rounded Rectangle: 35px

click to enlarge

http://www.gimpusers.com/users/devvv.html
http://www.gimpusers.com/images/tutorials/71/11.png
http://creativecommons.org/licenses/by-nc/2.0/at/deed.en
http://www.gimpusers.com/images/tutorials/72/1.png


3. Fill the Selection with: #929292. Deactivate the selection afterwards (CTRL+SHIFT+A)

click to enlarge
4. Deactivate the visibility of this layer (click the eye icon in the layers dialog). After that create a 

new layer.

Draw a quadrate. Fill the selection with the same color as before: #929292. Deactivate the 
selection.

Take the Rotate-Tool. 45° and rotate it.

click to enlarge
5. Now draw a rectangle selection above more than a half of the rotated quadrate and remove that 

part of the object by pressing CTRL+K (if you're using GIMP 2.3 just press DEL).

After that go to SELECTION / None to deselect all.

click to enlarge
6. Make the layer that we made insvisible visible again by clicking the eye icon in the layers dialog.

http://www.gimpusers.com/images/tutorials/72/4.png
http://www.gimpusers.com/images/tutorials/72/5.png


click to enlarge
7. Arrange both layers so that you get an arrow as seen below. If the rounded Rectangle is to big cut 

the bottom.

click to enlarge
8. Now merge these layers. To do this click the layer at the top, right click it in the layers dialog and 

choose "merge down". We now have the whole arrow on one single layer. Now go to Filter / 
Map / Bumpmap. Choose values from below:

click to enlarge
9. In the layers dialog click right: "Selection from Alpha".

- Add a news layer.
- Selection / Shrink : 15px.
- Choose #b1d631 as FG color and #55a32a as BG color.
- Fill the layer susing the gradient tool. Draw the gradient from the left bottom to the top right.
- decativate the selection.

http://www.gimpusers.com/images/tutorials/72/6.png
http://www.gimpusers.com/images/tutorials/72/7.png
http://www.gimpusers.com/images/tutorials/72/8.png


Now you should have this picture.

click to enlarge
10.Use the Bumpmap filter again, and apply the same values as before to this layer.

- Merge down these two layers.

click to enlarge
11.Duplicate the layer now.

The we're going to flip it. 

- Layer / Transform / Flip vertically.

Move the layer down as seen on the picture. Merge down these two layers again so that the arrow 
and the flipped one are on a single layer.

click to enlarge
12.Now use the Perspective-Tool. Zoom out a bit to get a better view.

Then click the layer. 4 points appear. Move the points as seen below. Then click OK.

click to enlarge
13.Move the layer a bit more to the middle. It should look like this now.

http://www.gimpusers.com/images/tutorials/72/9.png
http://www.gimpusers.com/images/tutorials/72/11.png


click to enlarge
14.The 3D-Effect is done pretty easy. Duplicate this layer, activate the duplicate in the layers dialog 

by clicking it. That should be the layer below the original one. Click in the picture to make it 
active. The click the "Right arrow"-key on you keyboard to move the layer exactly 1px to the 
right.

Duplicate the duplicate again, activate it and move it with you arrow key again to the right.

Repeat this step 3 more times. You should then have 5 layers of this in total. Some depth can be 
already seen.

click to enlarge
15.To speed things up, click the eye symbol in the layers dialog of the background layer. Press CTRL

+M or go to Image / Merge visible layers.

click to enlarge
16.Now repeat step 14. and move the layer 4 px to the right with your keyboard. Then merge the 

visible layers again.

http://www.gimpusers.com/images/tutorials/72/13.png
http://www.gimpusers.com/images/tutorials/72/15.png


click to enlarge
17.Zoom into the middle of the picture. Take the selection tool and cut the arrowheads so that they 

have a nice horizontal edge.

click to enlarge
18.Go to (GIMP 2.2: Layer /) Colors / Brightness & Contrast and lower the brightness by -25, set the 

contrast to +25.

click to enlarge
19.Now make the background visible again and fill it white. Draw a rectangle selection over the 

bottom (the flipped) arrow.

http://www.gimpusers.com/images/tutorials/72/16.png
http://www.gimpusers.com/images/tutorials/72/17.png


click to enlarge
20.Cut the part by using CTRL+X and paste it with CTRL+V. Click the "New layer"-Button to get 

this layer to a seperate one.

click to enlarge
21.Move the part to the same position as before. In the layers dialog right click the layer and add a 

layer mask.

http://www.gimpusers.com/images/tutorials/72/19.png
http://www.gimpusers.com/images/tutorials/72/20.png


click to enlarge
22.Press D to reset the colors to black and white. Choose the gradient tool. Draw a gradient from 

point 1 to point 2 on the picture.

click to enlarge
23.You're done ;)

http://www.gimpusers.com/images/tutorials/72/21.png
http://www.gimpusers.com/images/tutorials/72/22.png


click to enlarge

3.5 Smileys with The Gimp 

Hello everyone, this is my first “tutorial” on how to make a smiley with GIMP. There might be a 
possibility that you see this tutorial a bit confusing if you are using the GIMP for the first time. 

Now, let’s get started!

You will need:

1. A few cans of coke

2. Snacks? 

3. And the gimp 2.4.x (SUPER RECOMMENDED)

In this tutorial I will cover the gif terror, it is suggested that you follow what I say at some point, and I’ll 
the rest to your creativity. 

Fire up the Gimp

Create a 20 x 20 Layer, with 96 DPI. Transparent background

http://www.gimpusers.com/images/tutorials/72/23.png
http://creativecommons.org/licenses/by-nc/2.0/at/deed.en
http://bp3.blogger.com/_xTUAqBvHIew/R745f39onNI/AAAAAAAAACs/LwFNQsoEFhk/s1600-h/smiley.gif


Choose the gradient

Create a new layer and do a circle that resembles a smiley for you. You can use either gradients or solid 
colors, which ever you prefer.

Gradients I used was 

#ffe400

#FFFFFF

Use the gradient tool, and work your way till you get a perfect blend.

Stroking and blurring

In this step I stroked the circle without doing a new layer; I kinda suggest you do a new layer before 

http://bp2.blogger.com/_xTUAqBvHIew/R743kn9onHI/AAAAAAAAAB8/Qfs0LqVYllA/s1600-h/1.png
http://bp3.blogger.com/_xTUAqBvHIew/R743739onII/AAAAAAAAACE/LCpuT3rO2QY/s1600-h/2.png


stroking.

 

In this screenshot you’ll see the image with some kind of border, which you are right, I did use a border 
to it. Follow my direction, right-click the smiley template and select “Alpha to Selection” which should 
give you the selection back. 

In Select -> Grow, 1.0

Then Select -> Border, 2.0

Why border or grow? What are these in GIMP? Well, they’d become pretty useful, gimp Alpha to 
Selection does not select all the pixels, which sadly seems like a bug. I chose grow so we don’t miss out 
those pixels before Gussian Blur it. 

If there wasn’t any miscalculation, it should be exactly like the screenshot, more or less. If you notice that 
the selection are to close to the pixels, then do a Grow 1 pixel. 

Now go to Filter -> Blur -> Gussian Blur (1.0 or 2.0, it might depend on how you would like it) 

IF YOU DID PLACE A NEW LAYER FOR THE STROKE, BE SURE TO GUSSIAN BLUR IT.

Phew, we are done with the annoying part!

Give it a face!

That’s right! We are about to end. 

Create three layers, for eyes and mouth. You can either follow on how I have it on the screenshot or try it 

http://bp0.blogger.com/_xTUAqBvHIew/R7438H9onJI/AAAAAAAAACM/dLEzuZUNoy8/s1600-h/3.png


on your own J

What? You finished already?!

The trick in GIF

GIFs are annoying in my opinion, loses too much quality, but oh well that’s the nature of gifs. Now you 
might want to use this smiley on a web/forum/blog/CMS whatever. Saving the picture won’t do, the 
edges will lose its smoothness. 

The trick is! 

Do another layer, I called it “treces” or … secret! 

In your GIMP toolbar, you should see the paint brush, in that layer, put it below the smiley template.

http://bp1.blogger.com/_xTUAqBvHIew/R7438X9onKI/AAAAAAAAACU/3iP4I_odVyA/s1600-h/4.png
http://bp1.blogger.com/_xTUAqBvHIew/R7438X9onLI/AAAAAAAAACc/akyQMq8T7XA/s1600-h/5.png


 

Choose the paintbrush, scale it down if it’s too big. Choose the color white and color the edges. Look at 
the screenshot if you are confused. 

Finalizing

Well, now you learned how to make this smile, and how to put it on your projects or website without 
needing to worry about anything.

Download the XCF File

3.6 Create soft glassy buttons
Written by devvv (06 Jul 2007 11:10 PM) 

This tutorials shows you how to create a soft and glassy / glossy button.

1. Create a new file: 150x35 px. White background. Activate the gradient-tool (L). Now choose 
#005a71 as primary (foreground) color. Use #00eaff as background-color. Drag the gradient from 
inside the upper edge of the image to the bottom: cname the layer: "Gradient". I named it 
"Farbverlauf" which is the german word for gradient.

click to enlarge
2. Create a new transparent layer. Name it "Glass".

Choose white as foreground color. In the preferences of the gradient-tool use the drop-down and 
choose the "Foreground to Transparent"-gradient (the 4th one). Make a gradient again on this 

http://www.gimpusers.com/users/devvv.html
http://allenskd.diinoweb.com/files/dump/Tut.xcf
http://bp2.blogger.com/_xTUAqBvHIew/R7438n9onMI/AAAAAAAAACk/Fxz0D2BWppY/s1600-h/6.png
http://www.gimpusers.com/images/tutorials/81/1.png


layer from top to bottom.

click to enlarge
3. Take the Rectangle Selection-Tool and make a new selection starting from the bottom left as seen 

on the image below.

click to enlarge
4. Cut this part by pressing DEL or (CTRL+K if you still use GIMP 2.2).

- Selection / None to deselect all.

click to enlarge
5. Next we create a small little border. Add a new layer, fill it totally black. Name it "Border" or 

"Rahmen" as i did in the picture.

click to enlarge
6. Press CTRL+A to select all, then go to SELECTION / SHRINK: 1px.

Remove the selected part and a border should remain.

http://www.gimpusers.com/images/tutorials/81/2.png
http://www.gimpusers.com/images/tutorials/81/3.png
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click to enlarge
7. Add a new layer again (transparent). Name it "Desaturate" (i called it "entfärben").

Now activate the Gradient-Tool again. Make sure the "Foreground to Transparent"-Option is still 
selected in the preferences.

Use black as foreground-color. Drag the gradient again from top to bottom, but this time a bit 
below the bottom edge/border of the image (into the gray space).

click to enlarge
8. On the same layer do the same gradient but from right to left, again a little bit into the gray space 

of the left image border.

At the end only little blue to the bottom left should shine through.

click to enlarge
9. Now press CTRL+L to view the layers dialog or go to Dialog / Layers. Set the layers mode to 

"Saturate" - in the image its called "Sättigung".

This mode makes all parts of the layers below gray (all parts that are filled with the black on this 
layer).

http://www.gimpusers.com/images/tutorials/81/6.png
http://www.gimpusers.com/images/tutorials/81/7.png
http://www.gimpusers.com/images/tutorials/81/8.png


click to enlarge
10.The button should look like this now:

click to enlarge
11.Now take the text-tool and write any text to the layer. Move the text to the left corner.

The text layer has to be below the black "Saturate"-layer.

Activate the "Border"-layer and set the transparency of this layer to 20%.

click to enlarge
12.Now we're making the whole button a little nicer. 

- Edit / Copy visible
- Edit / Paste

Then press the add layer button to get the pasted on a new layer.

http://www.gimpusers.com/images/tutorials/81/9.png
http://www.gimpusers.com/images/tutorials/81/10.png
http://www.gimpusers.com/images/tutorials/81/11.png


click to enlarge
13.- Colors / Brightness & Contrast: -20 / +30

click to enlarge
14.You're done ;) If you want to test some other colors do it the fast way ->

- Add layer
- Fill with your preferred color
- set Layer mode to "Color".

A little tip: The buttons look best on white background with a very slight black shadow.

click to enlarge

3.7 Create a shield symbol
Written by myke (12 Sep 2007 10:16 PM) 

In this user tutorial our user myke shows you how you can create a shield symbol/icon for (e.g.) all kinds 
of security issues.

1. Create a new picture in a size of 320x240 und fill it with a light grey (e.g. #eaeaf0).

click to enlarge
2. Choose the paths tool and create three points like in the picture. Take the two points on the top 

http://www.gimpusers.com/users/myke.html
http://www.gimpusers.com/images/tutorials/81/12.png
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and drag them while pressing the Ctrl key into the right positions.

click to enlarge
3. Choose the selection from the path and create a new layer. Then fill the selection with white and 

rename the layer to "Basic form". 

click to enlarge
4. Now add a shadow in Filter -> Light and Shadow -> Drop Shadow. Choose these settings:

0, 0, 5, black, 80

click to enlarge
5. The picture will look like this:

http://www.gimpusers.com/images/tutorials/97/2.png
http://www.gimpusers.com/images/tutorials/97/3.png
http://www.gimpusers.com/images/tutorials/97/4.png


click to enlarge
6. Let's make the image more like 3D. Add a new layer named "Shadow" and add a black layer 

mask. Then choose the "Basic form" layer, get the selection of the alpha channel and fill the 
selection in the mask with white. Deactivate the selection (Select / None) and check the shadow 
layer. Set black as your foreground color and set the blend tool to blend from foreground color to 
transparency. Now drag the gradient like in the picture.

click to enlarge
7. Set the opacity of the layer between 30% and 10%. I have chosen 15%.

click to enlarge
8. Creating the shape of the shield: Add a new layer named "Form" and fill it white. Select again the 

alpha channel of the "Basic form" layer and shrink the selection by 2 pixels. Fill the selection with 
black, unselect it and draw a white line through the form. For straight lines hold the Shift key.

http://www.gimpusers.com/images/tutorials/97/5.png
http://www.gimpusers.com/images/tutorials/97/6.png
http://www.gimpusers.com/images/tutorials/97/7.png


click to enlarge
9. Make the border softer: Use the Gaußian blur and radius 5 and choose the Curves tool (Colors -> 

Curves). Adjust the curve as to see in the screenshot and press OK. Remove the white color by 
clicking Colors -> Color to Transparency -> White. Hide the layer.

click to enlarge
10.Copy the layer, show it and rename to "Color". Lock the alpha channel and fill with an 

appropriate color (e.g. #274383). The lock icon can be found atop all layers in the layers dialog 
(next to the transparency).

click to enlarge
11.Create a new layer, name it "Shadow Color", select the alpha channel of the "Basic form" layer 

http://www.gimpusers.com/images/tutorials/97/8.png
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and shrink the selection by 2 pixels. Choose a darker color as the previous one (e.g. #13295a), set 
the blend shape to "Shaped (angular)" and activate "reverse". Create a new blend by dragging. 
Add a black layer mask, choose the alpha channel of the form layer and fill it with white.

click to enlarge
12.Duplicate the layer "Shadow", delete the content, move it to the top of the layer list in the layers 

dialog and set the opacity to 100%. Drag a linear blend (White to Transparency) like shown in the 
image and move the layer to the top of the layer list.

click to enlarge
13.Create a mirror effect by hiding the background layer and clicking Edit -> Copy Visible. Edit -> 

Paste => new layer (click the new layer button in the layers dialog to get this on a new layer). Flip 
the layer vertically and move it downwards. Add a layer mask and drag a blend (White to Black) 
from top to down. Name the layer "Mirror" and set the opacity to 30%. Show the background 
layer.

click to enlarge
14.Add a short text in the light color and rotate it by -45°. Move the layer in the middle of the shield 

and add a shadow (radius 5). You're done.

http://www.gimpusers.com/images/tutorials/97/11.png
http://www.gimpusers.com/images/tutorials/97/12.png
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click to enlarge
15.The layers dialog list:

In the picture some layer names are German: 
"Spiegelung" is our "Mirror"-layer 
"Grundform" is our "Basic form"-layer
"Schattierung-Farbe" is our "Shadow Color"-layer.

click to enlarge
16.Some variations I made:

http://www.gimpusers.com/images/tutorials/97/14.png
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click to enlarge
17.And another possible use:

click to enlarge

3.8 Vista Button
Preview:

Have a look at the end result you really need to see it to appreciate this tutorial :) also inside is a 
html/java script example of a Rollover in action.
.

A friend of mine requested that i make a simple yet cool Vista style button tutorial for gimp, here is the 
end result 

Step:
1:Create a new image, 200x100 would be enough.
2: Create new layer and name it vistabutton,grab the rectangle tool and draw a 100px50 rectangle.

http://gimp-tutorials.net/node/111#
http://gimp-tutorials.net/tutorials/vistabutton/rollover/rollover_example.html
http://www.gimpusers.com/images/tutorials/97/16.png
http://www.gimpusers.com/images/tutorials/97/17.png


3:Will need to creat a New Gradient for the vista button, in the Gradient Dialog click on new gradient 
then right click on the left point and enter the color 252525 and then right click the right end point and 
enter 9a9a9a...

still in the gradient Right editor, right click on the middle point and
select "Split segment at midpoint", then drag both new segments to the middle as shown below, then 
save.

4:Grab the Blend tool select the new Vistabutton gradient we made and apply it from bottom to top, make 
sure its perfectly straight, if you make a mistake then press CTRL+Z to Undo it.

5: Now will Create a 1px outline around the button by Right click on the vista button layer and click on 
"alpha to selection" Create a new layer name it Outline then go to select>Grow>1px.



6: Change your foreground color to 424242 and fill the outline layer and finally setting the layer behind 
the vista button layer

7:Zoom in to make it easy and and with the selection tool create a rectangle inside of the button as shown 
below

8: Now will subtract the inner side of the rectangle we just created by either clicking on the "subtract 
from the current selection" button in the tool options or pressing CTRL while draw the rectangle

9: Create a New layer, Grab the Blend tool and apply a solid White color to Transparent (FG to 
Transparent) Gradient from top to bottom ( make sure its straight) and finally adjusting the opacity to 64.

10: Note* if make sure you you have the selection mode on "Replace the current Selection" after doing 
step 8. ok grab the rectangle selection tool and create another inner rectangle but this time at the bottom 
of the button.

11: Grab the Blend tool, and in the Tool Options Drag the Opacity to 25 and change the " Shape to 
"Radial" now apply from the center and drag the blend tool around 100px down.

http://gimp-tutorials.net/node/111#


this is how it should look

12: Grab out favorite tool and create a 1px gradient at the bottom of the button

13: Grab the "Blend tool" and adjust the "Opacity" to 80 and Shape to "Radial" and applly it from the 
middle to around 95px down

should look like this



14: Finally will Create the Reflection of the vista button by creating a rectangle selection half the size of 
the button,

15: Set the Foreground color set to cdcbcb use the (FG to Transparent) Gradient and apply it from from 
top to bottom. your done! a Vista style button! 

a sweet idea would be to make 2 different colors for rollover effect by changing the color of the radial 
gradient in step 11 to a blue color like here is an example of a blue version.

Here is a live Html+javacript rollover example.Rollover in action

3.9 Rounded Navigation Bar
Preview:

In this tutorial i will create a Navigation bar with round corners.

http://gimp-tutorials.net/tutorials/vistabutton/rollover/rollover_example.html


1. Create a new Document 648 x 115 px.
2. Go to Layer > New Layer, and Click OK

3. Now with the Marquee Square tool (R) make a rectangle like this:

4. Go to Select > Rounded Rectangle .. Radius 30%. Click OK 

5. With the Fill tool (Shift + B) . Paint the selection White.
6. Now go to Layer > New Layer .. OK
7. Go to Select > Shrink > 3 .. OK
8. Change the Foreground color to: #F0B259 and the Background to: #F87811.

9. With the Gradient Tool (L) Drag it from the top to the bottom of the selection. Go to Select > None. It 
should look like: 

10. Now to Select the 1st layer. the one with the white rectangle. Go to Script - Fu > Shadow > Drop-
Shadow. Select: 

http://gimp-tutorials.net/node/110#


Click OK. You should have: 

11. With the Text Tool (T). Create a new Layer, and type: Home. Click OK

Change your settings to.
Font > Verdana, Size > 25, Color > White:

http://gimp-tutorials.net/node/110
http://gimp-tutorials.net/node/110#


Looks like: 

12. Create a New Layer (Layer > New Layer > OK)
13. Create a 2 Pixel Line like this: 

14. Change your color to White, and with the Fill tool (shift +b) Paint on the line:

15. Adjust the opacity of the line to 17.

16. Duplicate the lines and space them out between each button then finaly add your text. 



thats it your done :)

3.10 Windows Vista Folder Icon
Preview:

In this tutorial I will show you how to make a Windows Vista Icon in Gimp.
This is the first time I use GIMP. so if I name a tool name wrong, sorry.
I was using GIMP 2.2 on Mac OS X during the tutorial.
Enjoy! 

 

  

1. Go to File > New and create a new image 250 x 250px.

http://gimp-tutorials.net/node/95#


2. Create a new Layer, and with the Path Tool create something like this:

3. Click on "Create selection from path" in the path's tool options.

4. Now you will see the the design you made with the path tool is selected and dotted.

Change your colors to: #fff29e to ffd46f : 

And with the Gradient Tool, drag it from the top of the folder to the bottom, this is how it should look:



5. Select the folder and go to Select > Grow - Grow by 1 Pixel.
Now go to Select > Border - Border Selection by 1 Pixel.
Change your color to: #fff4db, and with the Paint Bucket (Shift + B) Paint the border.
Now go to Select > None.

6. Select Again the folder. and go to Select Grow by 2 pixels.
Now go to Select > Border - Selection by 1 Pixel.
Change your color to: #f4c85b, and with the Paint Bucket (Shift + B) Pain the border.
Now go to Select > None, and should look like this:



7. Go to Layer > Layer Duplicate
Hide the first Layer: like this: 

8. With your 2nd layer. Select the "Change Prespective Tool" (Shift + P) and do this:



9. Select the Scale Took (Shift + T) and Scale the image down to: 



10. We are done with the folder, now we need to add the shadow. 

11. Make a New Layer. Now with the "Select Elliptical Regions Tool" (E). Create a circle like this one: 

 



12. Color the Circle in the new layer with whatever color you want (color will not affect the final result).
Now click Select > None.. You should have this: 

 

  

13. Now on the Layers option, change the opacity to 0.0 

 

14. Now go to Script-Fu > Shadow > Drop Shadow and Apply this Settings: 

http://gimp-tutorials.net/node/95#


 

15. A New Layer called Drop Shadow will be made. Drag that Layer between Background and the First 
Layer: 

 

  

16. Drag the Layer Shadow back of the folder, and you should get this: 



 

Now you can add Papers, Music Notes, Movies inside the folder and make it for whatever you want. 
Enjoy!! 

3.11 Button Tutorial for Gimp
Preview:

Wondering how you make those web 2.0ish button you see every where? well here is how you do it in 
gimp.

first download the 30 "Ultimate Web 2.0 Layer Styles for Gimp"we will use the pre-made gradients from 
that to get the effect.

http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp


Here are some examples of what you can make with the
With pre-made Gradients pack.

Step:

1) create a new image and a new Layer and name it button, select the "rectangle selection tool" and create 
a button size rectangle.



2) Now if you installed the "30 Ultimate Web 2.0 Layer Styles for Gimp" select the "Web 2.0 Brown 
Gloss" Gradient, Grab the Fill tool and place it bellow the rectangle and drag from bottom to top.

You should have something like the example below,Add some text and your Done!

http://gimp-tutorials.net/20ishbutton#


Play with different gradients from the"30 Ultimate Web 2.0 Layer Styles for Gimp" pack and rounded 
selection feature to get different shapes and color styles.

If your have trouble using the Gradient fill tool or anything els feel free to ask in the Forum and i will be 
glad to help out.

Feedback always appreciated :)

3.12 Designing With Gradients
Sometimes creating shapes can be a pain, with this tut I'll show you a great new way to design, that gets a 
unigue result.

http://gimp-tutorials.net/forum
http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp


Open up a new image, I used 400x 400 px.

 
Set the background to black.

 
Set your gradient to "default".



 
In your tool options, adjust the settings to reverse, and shape to radial.

 
Now add a new transparent layer, set its mode to lighten only.



 
Do a gradient fill any where on the transparent layer.

 
You should have something like this.



 
Add a new transparent layer, change its mode to lighten only also.

 
Do a gradient fill just like before, onto the layer you just created.
You can place it anywhere.



 
The new gradient fills into the previous layer without covering it up.
If you dont like how the fill came out, just undo and try again, or if the size is right just get the move tool 
and move the new layer around.

 
Since its set to "lighten only" you can move it just about any where.
Like this it sorta looks like a bug, so lets go with that and make it look more like one.



 
You can only add one fill per layer, so add new layers as needed, or duplicate one, and move it around.

 
You can merge 2 layers together by setting the lower layer to normal, then merge the one above down.
Then change the merged layers setting back to lighten only.
You can also move the merged layer where you like.



 
Grouping layers like this give you the ability to add some detail, like color to the different layers.
An easy way to add color is with the corlorize tool, be carefull not to change the background too much.

 
When you have your basic shape done just merge the visable layers.
You can seperate it from the background using the magic wand.



 
From here you can add your effects and spice it up a little.

 

3.13 Creating Glassy Buttons
Most Photoshop techniques make heavy use of "layer effects" when it comes to creating glassy buttons. I 
modified one of those techniques so that it could be applied to the Gimp environment that lacks this 
feature. The following tutorial shows you how to create a glassy button in 5 easy steps.
The result:



1) First, open a new document in the Gimp and create a basic button shape on a new layer. One way of 
creating a button shape is shown in the following image. When it is done fill it with medium gray.

2) Duplicate the button shape layer 2 times. Name the layers as shown below.

3) Create a selection similar to the one in the following picture; while still selected make the top layer as 
your active layer and clear the selection (Edit>Clear).

http://bp3.blogger.com/_HtSI6QxIfSg/RrZv-mlN3OI/AAAAAAAAAOs/lm2iswtq96E/s1600-h/gloss.png
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http://bp0.blogger.com/_HtSI6QxIfSg/RpfT_7A07DI/AAAAAAAAAJg/NAx7f24uN_Q/s1600-h/layer_dialog.png


4) Next, fill the top and the bottom layers with gradient to look similar to the image below. If you want 
you can blur the top layer a bit (1 or 2 pixels) to make the gloss line smoother.

5) And lastly, load the selection of the base shape, go to Select>Shrink and shrink the selection about 2 
pixels; invert the selection, activate the bottom and the top layers in subsequent steps and clear the 
selection. This creates an edge around the button.

http://bp2.blogger.com/_HtSI6QxIfSg/RpfU0bA07EI/AAAAAAAAAJo/n0OwnwCtv5Y/s1600-h/selection.png
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And this basically completes the tutorial. If you want you can add text to the button as I did but this is not 
absolutely necessary.

3.14 Creating a Navigation Button
Navigation buttons are essential features of both web pages and application interfaces. In the following 
tutorial, we create an attractive navigation button in a few simple steps that can be followed even with 
limited Gimp knowledge.

The button you are going to create looks like this:

1) First, let's create a basic button shape with rounded corners. The Gimp sucks when it comes to creating 
rounded rectangles. The following two examples explain one way of creating them.

http://bp3.blogger.com/_HtSI6QxIfSg/RpfW_rA07GI/AAAAAAAAAJ4/JnGZSEk_2NM/s1600-h/creating_frame.png
http://bp2.blogger.com/_HtSI6QxIfSg/RpfXqbA07HI/AAAAAAAAAKA/2Cg0tzjFm4o/s1600-h/text.png
http://bp0.blogger.com/_HtSI6QxIfSg/RrZrJ2lN3NI/AAAAAAAAAOk/OPe3vi6RG-c/s1600-h/navigate.png


a) Open the Gimp and go to Preferences>Default Grid and set the Grid Spacing Width and Height to 10 
pixels. Restart the Gimp.

b) Create a new document with a white background. Add a new layer. Go to View and check the Show 
Grid and Snap to Grid options.

c) Using the Ellipse selection tool create four small circles like in the image below. Then with the 
Rectangle Select tool create a selection; look at the image. Fill the selections with medium gray.

d) And finally create another selection like the one below and fill it with the same gray. And here you 
have the rounded rectangle.

2) Now, that we have the basic button shape we duplicate the button shape layer two more times; name 
the layers as in the following image.

http://bp0.blogger.com/_HtSI6QxIfSg/Rp6KJLA07II/AAAAAAAAAKI/ePI2pdTCNCE/s1600-h/makeRondRect1.png
http://bp0.blogger.com/_HtSI6QxIfSg/Rp6KqLA07JI/AAAAAAAAAKQ/SnKK99dfyfk/s1600-h/makeRondRect2.png


3) Fill the white layer with white, load its selection, go to Select>Shrink and shrink the selection about 2 
pixels; inverse the selection and delete it. Do the same with the grad layer but here shrink the selection 
about 3 pixels. Then create a gradient similar to the subsequent image.

4) Next, we create an arrow, which for the sake of simplicity, will be a triangle; but if you want to create a 
more sophisticated shape go ahead and do it; here the arrow signifies action. Add a new layer to the stack 
and if they are not on, turn on the Show Grid and the Snap to Grid options; activate the pen tool by 
clicking on its icon in the toolbox and click on the grid points to create a triangle shape similar to the one 
on the image below. When you do the last click hold down the Ctrl key to close the path. When it is done, 
go to the Path dialog and at the bottom of the dialog box click on the Path to Selection button, this will 
make a selection out of the path. Fill the selection, this time with some color, mine is orange. If the 
triangle is too large scale it to fit over the button. After that, you can turn off the Grid and delete the path 
object.

http://bp1.blogger.com/_HtSI6QxIfSg/Rp6LLbA07KI/AAAAAAAAAKY/TjWocvcSz9I/s1600-h/layer_dialog.png
http://bp1.blogger.com/_HtSI6QxIfSg/Rp6MKbA07LI/AAAAAAAAAKg/l1B2WE0jDeU/s1600-h/grad_in_place.png


5) Next, we create two vertical lines that sort of separating off the arrow from the rest of the button 
content. Add a new layer and with the Rectangle selection tool make a selection about 2 pixels wide. Fill 
the selection with medium gray; duplicate the layer and fill the duplicate with white; offset the white line 
about 2 pixels along the x-axis. Now you should have an image like the one below.

6) Finally, add white text to the button like I did; to enhance both the text and the arrow shape add drop 
shadow to them. That is all there is to it.

The final artwork.

http://bp0.blogger.com/_HtSI6QxIfSg/Rp6NJLA07MI/AAAAAAAAAKo/HB4VXuHkeRs/s1600-h/triangle.png
http://bp1.blogger.com/_HtSI6QxIfSg/Rp6N3bA07NI/AAAAAAAAAKw/jArAkhu3q5k/s1600-h/dividing_lines.png
http://bp2.blogger.com/_HtSI6QxIfSg/Rp6OWrA07OI/AAAAAAAAAK4/eU4xhA5ZSG0/s1600-h/final.png


3.15 Chains
This tutorial will show you how to create a nice iron chain. One warning in advance: This one is hard to 
do in Gimp! So you will need a bit more patience and more experience in using Gimp than for most other 
tutorials. The result should look like this. 

    Step1 

Create a new image, with 500 x 500 pixels size and some nice background color. 

Create a new transparent layer, name it "chain_top". 

Create a hair cross in the middle of the image then do a perfect circle selection in the middle of the image 
using the hair cross to aim. 

Now open the gradient dialog, and set "rounded_edge" as gradient. 

Open the tool-options dialog, and activate the gradient tool. 

In the tool-options change "Blend" to "Custom Gradient" and "Gradient" to "Radial". 

Now do a nice gradient, in your selection from the exact middle (use your hair cross) to outside of the 
selection. 

After that, shrink selection about 30 - 35 pixels, invert selection, and cut the rest off. 

Now check "keep trans." and blur the donut with gaussian blur at a value of 35.  

Compare if it looks similar to mine.

     Step2 



Shrink "chain_top" to 100x100 pixels. 

Remove the old guides, and create new ones, that are cross-hairing the donut exactly in the middle. 

Now select the right half, with the rectangular selection tool, and cut & paste it into a new layer and name 
it "right_donut".
Move the "right_donut" away. 

Now the tricky part: Do a selection, from right beside the vertical guideline with 1px distance, to the left 
side of the guideline with exact 1px distance. 

Tha goal is, to have a 1px wide selection of the donut. 

After you did that, scale this selection by 1000px in width. Insertit as new layer. 

Now, move "right_donut" to the top of the layerbox, so it becomes visible. 

Adjust its position so it becomes congruently with the scaled layer and move it to the right, so you get 
something that looks like a part of a chain. 

Cut off the rest of the scaled layer. 

Duplicate the scaled layer you just cut, 2 times. 

Now, merge down all chain-layers to one. Create a new transparent layer, select your chain and cut it out. 
Paste it into, delete the old layer, and merge it down to the just created transparent layer. Name this one 
"chain_top" again. 

If everything worked just fine, it should look like mine here.

     Step3 

Throw away the guides from Step2, and create a new guideline which divides the chain horizontally 
exact in the middle. 

Select the bottom half, cut it out, and paste as new layer. Name it "bottom_chain". 
Move "bottom_chain" away. 

Now do the same with scaling, like in Step2. Just do it horizontally, not vertical. 



After that put "bottom_chain" on top of the layers, and make it congruent to the scaled layer. Move 
"bottom_chain" downwards, so far, that the black space in between is big enough that one chain half 
could fit into it. 

Then cut the rest of the scaling away, so it looks nice. Merge down the chain-layers, cut the chain out, 
create a new layer, delete the old chain-layer, and merge it down to the new created transparent layer. 
Name it "chain_top" again. 

If everything worked, it should look like this one

     Step4 

Now use the magic wand, to select the black-space inside the chain. Feather the selection by 1px and 
delete the inside. 

Create a new layer, and name it "chain_side". Do a circle selection just as big that it fits in the space you 
just deleted. 

Activate the gradient tool, and reset the options. Change "Gradient" to "Radial". 

Select white as fg-color and black as bg-color. Now do a gradient from the exact circle-selection middle 
to outside the circle. Try to get it looking similar to the gradient "chain_top" has. 

After that, deselect. 

Now cut the circle vertically in two equal parts. 

Move the left one to the left beginning of "chain_top" and the right one to the end of "chain_top" make it 
congruent. 

Now do the same scaling like you did the steps before from the left half on. Cut, adjust, make congruent, 
merge layers, all the same like the steps before. 

Should look like mine



     Step5

Now, duplicate the layer several times, and arrange them like i did. Use guidelines to adjust them proper. 

Now you should be able to do chains like seen here. 

Have fun :-)

3.16 Glassy Spheres



Here is one way to make glass spheres that contain 
diffuse glows, highlights, halos and specular reflections 
of the surrounding environment. An interesting feature 
is the extensive use of selection feathering and cutting.

The specular reflection is useful for large spheres 
because it helps to create the illusion of spherocity. For 
very small glassy balls (used for "buttons" and such) the 
specular reflection can simply be omitted.

The specular reflection is going to be achieved by 
mapping an image onto a sphere. Because of the way 
the mapping function works in GIMP, we have to start 
with a perfectly square image whose dimension is 
exactly twice the diameter of the glass sphere we intend 
to make.

This tutorial presents just the basics and is meant only 
to be suggestive; almost every step I describe involves 
some subjective judgment, leaving plenty of room for 
experimenting and innovating. 

 

1. Open a new image of 300 X 300 pixels, choosing a background color against which to view your 
sphere. Over that make a transparent layer. On this new layer use the Select Elliptical Regions tool to 
make a perfectly centered circular selection 150 pixels in diameter. Now fill the selection with a dark 
color of your choice. I arbitrarily used the color #351000, a dark orangy red, and labeled the layer 
"Base Color"



2.  Next, with the selection still active, create a new transparent layer. On this layer we're going to create 
a gentle glow. Using the Color Selection, GIMP tab, take your original color, #351000 in my case, and 
increase its Value a bit. I chose #c13300. Use the Fill tool to fill the selection with the new color as 
shown in the left illustration.

Now, Grow the selection by 12 pixels. Then, using the Move tool with the Alt key depressed, drag the 
selection down and to the right so that your total move is 55 X 55 pixels. Feather the selection by 75~85 
pixels or so. Invert the selection and clear it (Edit->Clear), but only once. Change the layer Mode to 
Screen and knock the Opacity down to about 50 for now; we'll make a final adjustment later. I labeled 
this layer "Glow With Cut" in the illustration above. 





3.  In the next step, we'll make a second glow. Get the 
circular selection of the bottom layer (labeled Base 
Color) and make a new transparent layer on top (I label 
it "Glow 2"). Select a lighter version of the last color; I 
just increased the Value of the last color somewhat to 
give the color #ed3f00. Now, working on the Glow 2 
layer, shrink the selection by 5 pixels, feather it by 5 
pixels and fill it with this new color. See illustration on 
the left.

Next, Grow the selection by 100 pixels. Using the Move 
tool with the Alt key depressed, move the selection 
down and to the right so that you just "cut off" a thin 
sliver on the lower right of the colored circle, as seen in 
the illustration above center; in my case, this was a 
move of about 165 X 165 pixels. This is somewhat 
subjective, as you'll see. Now invert the selection, 
feather it by 17 pixels or so, and then Clear the area 
outside the selection. You may want to Clear twice, 
depending on taste. Use Undo and Redo to decide. (In 
the example I cleared once). Set the layer Mode to 
normal or screen to suit your taste and the Opacity to 
about 56 -- for now.

For a more crescent shaped glow, move the selection in 
the opposite direction, up and to the left, until a small 
sliver of color shows outside the selection, and then 
feather and cut. See the examples at the end of the 
tutorial. 



4. The next step is to add a reflection. Make a new transparent layer on top, which I'm going to label, 
"Reflection." Copy the picture of a stone window from my illustration on the left above and paste it into 
the new layer, right over your orb. Or use any other picture you like that might be a reasonable source of 
light. While the selection is floating, move it to a position so the brightest part is somewhere over the 
upper left quadrant of the glass ball, as shown above (left). 

Now go to the Map to Object filter. On the Options tab select Map To: Sphere and Transparent  
Background. On the Lighttab select Lightsource Type: No Light, and click the Preview! button. On the 
Orientation tab adjust the the Rotation X,Y and Zvalues, checking each time with the Preview! button, 
until you have the brightest part of your window over the upper left quadrant of the sphere in some 
pleasing way. Click OK and you should see your picture mapped onto the sphere as shown above center. 
Incidentally, this is the step that requires the image size to be square and twice the diameter of the glass 
sphere, as I mentioned earlier. 

I found this window image by searching Google Images for "window". Other images such as interiors 
can be made to work, too. Also, you may want to try adding secondary reflections in the lower quadrants 
of the sphere.



5. In the next step, we have to trim the reflection photo, i.e. the window, and adjust its Mode to make it 
look more like a reflected image. To start, set the Mode of the Reflection layer to Screen and reduce the 
Opacity to about  45 so that we can begin to see what we have. Next, get the selection from the Base 
Color layer and Grow it by 65 pixels. Move the selection into something like the position labeled "1" in 
the illustration, above left. Feather the selection by about 55 pixels and clear the selection once. Now 
repeat the procedure starting with a fresh selection from the Base Color layer, but this time move the 
selection into a position similar to that marked "2", feather again by 55 pixels then Clear once to obtain 
something like that shown in the center illustration. This is only meant to be an example. The trimming 
can be done in different ways, depending on the nature of the photo used. Often a single cut can be used, 
or more or less feathering will be required. The basic idea is simply to trim the reflection image down 
and to use large feathering and Screen Mode so that it looks convincing. Just play with it.

Note: The center illustration was obtained by cutting with the selection "2" more to the right and up than 
is suggested by the illustration on the left -- the two illustrations were made at different times. 



6. 
Now 
we 
add 
a 
final 

highlight like that in the upper left quadrant of the sphere shown on the left. (To save space, I'm omitting 
an illustration of the Layers Channels and Paths menu from this point on. We'll be adding two more 
layers.) 

To do this we need to create two brushes like those shown on the left, labeled Highlight Halo and 
Highlight Point.  Next, add a new transparent layer on top and use the Pencil tool, with color set to white, 
to single-click an image of the Halo brush at the point the highlight is to appear. You'll get a big, klunky 
oval. Blur this by 14 or 15 pixels. The brush image will turn dark and nearly disappear -- don't panic. Just 
click on the Keep Transparent button and paint over the area; your blurred halo will appear. Set its Mode 
to Overlay (or possibly Normal) and adjust Opacity. (You may later want to use Duplicate Layer to create 
a copy and adjust the second layer to get more brightness.) 

Finish off the highlight by making yet a new transparent layer on top. Use the Zoom tool to enlarge the 
halo somewhat and then single- or double-click an image of the Highlight Point brush right over the halo 
you just made, not necessarily precisely centered on the halo. Set its mode to Screen and adjust Opacity 
to suit. You may want to blur the Highlight Point image by 2~3 pixels.

There is a lot of arbitrariness here; both brushes could have been larger, for example.

Finally, at this point, we can go back and readjust all our layers (Opacity, etc.) to optimize the appearance 
of the image.



On the 
left are 
some old 
images 
that I 
made. 
Your 
glass orb 
takes on a 
new 
character 
when 
finally 
viewed in 
some 
kind of 
context.

Once completed, the image can be manipulated by adjusting its color, value and saturation. The milky 
sphere in the center is the result of reducing saturation. A sphere can be altered into just about any color 
in this way.

Small spheres like the green one seen on the left can be made by simply omitting the reflection image, 
steps 4 and 5. 

These examples also show the crescent shaped second glow mentioned in  step 3. 

3.17 Gear Wheel

 
This tutorial will show you how to make a 3D gear in gimp.

The resulting image will look something like this: 



Create new image 256 x 256, white background, RGB. Create a new layer 

name it "Black". Right click on the image choose select->all and paint the selection black with the fill 
tool

Toggle layer transparency on the "Black" layer clicking on transparency icon

Create another new layer

named "Gear Template". Layers, Channels, and Paths dialog should look something like this: 

 



 Right click on image, select filters -> render -> 
gfig. In gfig hit new

name the object "gear".  Select snap to grid, 

display grid, and set grid spacing to 12.  On 
brush tab, set brush to pencil, click set brush button

set size to: circle (03) (3x3).  On options tab, 



set grid type to polar.  Click create line button.

7 sections up from bottom or 3 sections down from top on the center veritcal axis draw the gear as 
shown. Left click the starting point once, then click and drag mouse one section to the right horizontally. 
Click the same point drag the mouse 2 sections down vertically and one section to the right in a stair 
stepped fashion. Continue from the same point and drag mouse 1 section to the right and 2 sections up 

then one section over horizontally.  Continue this tooth 
pattern around the gears circumference. Note: If you make a mistake select the delete an object button

and delete your point. Reselect create line

and continue. Click on the save button



and name our object gear.  Leaving gfig open, set 
foreground color to black

then click paint

in the gfig dialog. Click

Your image should now look like this: 

While holding the shift button using the zoom tool

zoom to a magnification of 300%. In layers, channels, paths, select paths tab, click new path



Double click on the newly created path to bring up the name change box, and name the path "Gear". 
Select New Point

create a path following gear outline. Note: Do not click and drag, click points only. 

 Encompass gear circumference as shown. 

 



 Create a new

layer named Test Gear.  On paths tab reselect gear, 
click paths to selection button



then paint gear with a random color other then black or white, using fill tool

Deselect gear (shift+ctrl+a), set transparency

on "Gear Template".  Zoom out to examine resulting gear 
for flaws. Tweak gear path if necessary using the edit point button

To tweak path, first click path tab, select "Gear" path, then while holding down ctrl key click and drag 
mouse to modify points. 

Copy path "gear" using the duplicate path button

while the newly created path is selected, double click on it to bring up the change name dialog and name 
it "Back Path". Activate the path transform lock



by clicking the white space just to the left of the newly created "Back Path"

Select layers tab and create a new layer named "Back Gear". Select paths tab, selecting "Back Path" path, 
and click the path to selection button

Select the transform tool

then right click on image and select dialogs->tool options. In the tool options dialog set transform tool 
type to perspective as shown above. Mouse click inside of the gear. Move lower left control point to 

coordinates 80,160 as shown.  Click transform button

and anchor

Toggle "Test Gear" layer transparency



  While "Back Path" is selected click path to 
selection button

then on layer "Back Gear" paint gear with dark blue using fill tool

Deselect newly created gear (shift+ctrl+a), and set transparency



you should have something similar to whats shown.  

 Create new layer

name it "Front Gear". On paths tab copy "Back Path" using duplicate path button



double click on it and name it "Front Path".  Click edit 
point

holding down ctrl-alt drag gear to point shown and release. 

 Click path to selection



select layers "Front Gear", paint gear with light blue using fill tool and deselect image (shift+ctrl+a)

 

Create new layer

name it "Teeth Sides". Zoom

to 200%. Select "Front Gear" and decrease opacity to approx 65.5 by adjusting opacity slider on Layers 
tab. Note: Be sure to return layer opacity to its orignal state when finished. This setting should allow you 
to see the points that would normally be hidden from view enabling you to make the paths correctly. 

 Select path tab and create new path



double clicking newly created path and naming it "Sides Path". Use the new point path tool

to encompass gear teeth sides clicking on the corners of each polygon. Note: Do not click and drag, click 
points only. The finished "Sides Path" path should look something like this. See next image for a zoomed 

view.  Zoomed in for clarity. 

 Reselecting "Teeth Sides" layer, Select path tab and reselects 
"Sides Path" and hit the path to selection button

Paint each tooth side with a 44% value gray color using the fill tool



(ie set to black or white and drag the V slider of the color chooser till it reads 44). 

 

 Select Layers tab, create new layer

and name it "Inner & Outer Circumference". Select paths tab, create new path



and name it "Inner & Outter Path", in a fashion similar to that of "Teeth Sides", use path tool to 
encompass the gear teeth outermost and innermost sections clicking on the corners of each polygon (ie 
the peaks and valleys on and in between teeth) Note: Do not click and drag, click points only. The 
finished "Inner & Outter Path" should look something like this: 

 Click path to selection.

Select "Inner & Outter Circumference" on layers tab, paint each tooth side with a 74% value gray color 
using the fill tool

(ie set to black or white and drag the V slider of the color chooser till it reads 74). Toggle layer 
transparency on the "Back Gear" selecting layer and clicking on transparency icon

At this point we play with our coloring because it is quite inadequate at the moment. First off toggle the 
"Black" layers transparency

you should now have a black background. Next create a new layers



name it "Gradient". Select the "Gradient" layer, set the foreground color to #b942ff and the background 
color to white (#ffffff)

Click the paths tab and select "Front Path", then hit the path to selection button

Using the gradient tool

make a diagonal gradient starting in the upper right point coordinates 120,120 (Note: point coordinates 
shown in the lower left corner of the image window), and dragging diagonally to the images lower left 
point coordinates 60,190. Your gradient should look like the image on the right. 

 At this point you can right click on the "Black" layer and 
select merge visible, however I suggest duplicating those layers that are visible deselecting all the rest 
and then merging visible layers (ie merge the copies). Next save your work as an .xcf so that you preserve 
all the layers you've created for future tweaking. From the merged layer you can save the gear in any 
format you like.

3.18 Create a metallic glass button
In this tutorial I’ll show you how to make this cool little button in GIMP:



Make a new image document (mine is 300×200). Create a new layer (Layer > New Layer) called ‘drop-
shadow’, make a circular selection (E for ellipse tool) on the left side of the canvas (making sure to hold 
SHIFT to make a perfectly round selection); then fill with black (SHIFT+B).

Duplicate the ‘drop-shadow’ layer (Layer > Duplicate Layer). Go Layer > Transform > Flip Horizontally, 
then merge the ‘drop-shadow copy’ layer down (right-click on ‘drop-shadow copy’ in the layer stack and 
choose ‘Merge Down’); you should have the following:

Create a new layer (name is not important); make a rectangular selection (R) between the two spheres 
and fill with black, then merge the layer down as before:

Right-click the ‘drop-shadow’ layer and choose ‘Alpha to Selection’ then create a new layer called 
‘border’. Apply a linear gradient of #b7b7b6 to #686868 from top to bottom of the selection (don’t worry 
if the edges seem a little rough, we’ll sort them out shortly). 

Using the rectangular select tool in subtract mode (hold CTRL before selecting to change to subtract 
mode) deselect the lower half of the selection, then create a new layer called ‘border-highlight’ and apply 
a white to transparent gradient:

Right-click the ‘border’ layer and choose ‘Alpha to Selection’ then create a new layer called ‘button-
indent’. Go Select > Shrink and shrink by 6px, then apply a linear gradient of #686868 to #b6b6b5 from 
top to bottom of the selection. You’ll have to move the ‘button-indent’ layer above the ‘border-highlight’ 
layer in the layer stack (simply click and drag the layer above the other in the stack).



Go Select > Shrink and shrink by 4px. Create a new layer called ‘button-outer-shadow’ and fill with 
#7e7e7e, shrink by 1px; then press delete (or CTRL+K) to clear the selection. Create a new layer called 
‘button-inner-shadow’ then go Select > Feather and set to 6px. Fill the selection with black and then press 
delete (or CTRL+K). 

Shrink by 1px (Select > Shrink). Create a new layer called ‘button-highlight’; using the rectangular select 
tool in subtract mode (hold CTRL while selecting) deselect the lower half of the selection, and apply a 
white to transparent gradient.

Now it’s time to add the button text (press T for text tool), I chose this text in a green color (#adff2f). 

When you’ve added the text, right-click the text layer and choose ‘Alpha to Selection’; create a new layer 
called ‘text-outer-shadow’ then go Select > Grow and grow by 1px. Apply a gradient of #959594 to 
#383838 (from top to bottom), move this layer below the text layer in the layer stack.

Right-click the text layer and choose ‘Alpha to Selection’; create a new layer called ‘text-inner-shadow’ 
then go Select > Feather and feather by 2px. Fill the selection with black and then press delete (or CTRL
+K).

http://www.dafont.com/nippon-tech.font


Right-click the ‘border’ layer and choose ‘Alpha to Selection’; create a new layer called ‘border-soften’. 
Press D then X (to reset and swap the current colors) then apply a white to transparent radial gradient:

Now we’ll sort out the rough edges and give our button more of a presence. Deselect (CTRL+SHIFT+A), 
select the ‘drop-shadow’ layer then go Filters > Blur > Gaussain Blur and set blur radius to 5px; then 
lower the layer opacity to 90% (near the top, to the right of the layer stack).

The button is now complete:

Hope you enjoyed this tutorial 

3.19 Web 2.0 Badges
Today I will be teaching you how to make Web 2.0 badges in Gimp. Pretty simple to catch on I must say.

1) Create a new image that is 300x300, white background.

2) Add a new layer. Select the ellipse select tool . Select an area that nearly fills up the canvas.
3) Now we want our border color. Select color 0159d2 and fill the circle with it using the paint bucket 

tool . Do not deselect yet. You should have something like this:

http://lh5.google.com/sglider12/RwMD7zC6m5I/AAAAAAAAAOg/TcmKz0hTqNY/s144/circle%20image.PNG
http://lh4.google.com/sglider12/R37R3HfpF3I/AAAAAAAAAdo/Jnz1ZWRB2jU/s144/paintbucket.png


4) With the circle still selected, create a new layer. Go to Select -> Shrink. Shrink the selection by two 
pixels. Press D to reset your foreground and background colors. Press X to switch them. White should be 
in front.

5) Click the gradient tool . In the gradients menu, select FG to Transparent. Fill the selection with the 
gradient by dragging it from top to bottom. Hold the CTRL button while you do it to keep the line 
straight. You should have something like this:

6) Now we will add some text. Add the text toward the center with white font. Position it somewhere in 
the center. Merge the text layer down with the rest of the badge.

7) Now we will create a reflection on the badge. Click the ellipse select tool. Select somewhere toward 
the top left corner of the badge. Then, click the magic wand tool. Put it in subtract mode, and, with the 
badges layer selected, select the empty space. This should leave just part of the badge selected:

8) Now, create a new layer. Fill the selection with white. Lower the opacity to about 33. Merge the layers.

http://bp0.blogger.com/_J5ekMDNQzF4/R5UZmHfpGKI/AAAAAAAAAgg/uPARwKmMVZo/s1600-h/Screenshot.png
http://lh3.google.com/sglider12/RwL0CjC6mtI/AAAAAAAAANA/Wsj7LdLKWUg/s144/gradient%20image.PNG
http://bp1.blogger.com/_J5ekMDNQzF4/R5UbWXfpGLI/AAAAAAAAAgo/A0H6tziesGI/s1600-h/Screenshot.png
http://bp1.blogger.com/_J5ekMDNQzF4/R5UdSXfpGMI/AAAAAAAAAgw/wBzRoTT-tGY/s1600-h/Screenshot.png


9) Select the layer the badge is on. Go to Filters -> Light and Shadow -> Drop Shadow. Set the offsets to 
zero, the blur radius to 10. Uncheck allow resizing. Raise opacity to about 85.

10) Select the layer that the badge is on. In the layers dialog, click the duplicate layers button. You should 
now have two badges. Select the duplicated layer. Go to Layer -> Transform -> Flip Vertically. Move the 
flipped layer under the original layer. Now you can merge the original badge layer with the drop shadow 
layer.

11) Right click on the flipped badge's layer in the layers dialog and select Alpha to Selection. Select the 
gradient tool. Choose FG to Transparent. Make sure white is in the foreground. Drag the gradient tool 
from bottom to top. There you have it! A basic web 2.0 badge.

4. Website Layouts

4.1 Blog Theme Design tutorial
Preview:

finally i have managed to put my self together and create another blog template tutorial!
sorry to all those who were counting on it before,i just didn't have the time for it but anyway here it is. so 
enjoy!

creating this template is very easy, it just needs some patience and a little effort, so what ever you do. 
don't give up.

http://gimp-tutorials.net/blog-theme-design-with-gimp#
http://bp0.blogger.com/_J5ekMDNQzF4/R5UmbHfpGPI/AAAAAAAAAhE/K5CLizbyf3s/s1600-h/Untitled.png


here is the outcome of this tutorial.

Click to Enlarge

hopefully a member of the forum will help out in coding this template to a working wordpress theme, so 
keep an eye out for it :).

before we jump into this gimp tutorial ill need to remind you that i will only go into details of how to do 
cretin techniques once and then ill just describe it briefly when ever its repeated so pay attention.

Step 1: Create a New image at 1024X900 and fill the background image with the color 3f3534 adjusting the 
zoom rate to %50 as i did might to help you compare your progress with mine. 

first thing will do is create the content box's transparent border. this effect is easy and gives a nice touch 
to the design.

Step 2: make sure you have the "Tools option dialog" on your screen,
then start off by Grabbing the "Rectangle Select tool" now draw a Rectangle at any size and in the "Tool 
option dialog" adjust the position to 98 and 150 and size to 590x695.

http://gimp-tutorials.net/blog-theme-design-with-gimp#
http://gimp-tutorials.net/blog-theme-design-with-gimp#
http://gimper.net/
http://gimp-tutorials.net/tutorials/bloglayout/bloginprog.png


if you did that right you should have something like this.



Step 3: while the selection is still active, in the "Tool Options" dialog Tick the Rounded Corner Box and 
change the Radius value to 13.7 



once your done you can click inside your selection to finalize your changes.

here is how it should look.



Step 4: Create a new Layer and name it "Border Main content box", now fill your selection with Solid 
White. then change the Opacity to 50.

now that we have the border set we can create the actual base of the content box with a few simple steps.



Step 5: Right click on your image and the then go to Select > Shrink. now change it to 5 then press OK, 
below in the example image is how your selection should look by now.

Step 6: as in step 4 Create a new Layer name it "Main Content box" and fill the selection with Solid 
White. you can un-select everything by going to Select> None. *Tip make sure the Transparent layer is 
Below the "Main content Box" layer.



Now that you know how to create these content box's with there borders i won't go through them again 
instead ill just briefly mention what to name the layers and the values like size,position... etc.

Step 7: will start with the search box .

Create a new layer name it :Border Search Box
With the rectangle select tool draw a selection and change values as the following:
position:697:150px
Size: 229x65px.
Rounded corners: radius to 13.7
Color Fill:Solid white
Layer Opacity:50

make sure you have the selection from the border search box still active,now right click then go to 
Select>Shrink at 5px.
Create a new layer name it "Search box base" fill with solid white and unselect the layer by going to 
select>none. this is how yours should look.



Step 8: The Menu Box

Create a new layer name it : Menu box Border
With the rectangle select tool, draw a selection and change values to the following:
position:698:225px
Size: 228x360px.
Rounded corners: radius 13.7
Fill Color :Solid white
Layer Opacity:50

Create new layer name it: Menu box Base
with the selection of the menu border layer still active, right click and go to select>Shrink 5px, finally fill 
with solid white. and unselect by going select>none



Step 9: 2nd Menu Box

Create a new layer name it : 2nd Menu Border
as we have done a few times now grab the rectangle select tool, draw a selection and change values to the 
following:
position:698:594px
Size: 228x249px.
Rounded corners: radius 13.7
Fill Color :Solid white
Layer Opacity:50

Create new layer name it: 2nd Menu Base
with the selection of the 2nd menu border layer still active, right click and go to select>Shrink 5px, 
finally fill with solid white. and unselect by going select>none.

you should have something like this by now.



so far we have made all the main components of the website now its time to add some nice brushes to the 
background.
i used the Floral Brushes set by solenero73 , you can use your own if you wish, the trick is to apply the 
brushes on each corners but don't go too out of control with it, the less you use the better.
you can download them from here: Download the floral brushes here.

http://gimp-tutorials.net/node/204


Step 10: once you have downloaded and installed the brushes have your foreground color set to fffe87, 
Create a new layer and name it "Floral effect" and place the layer just after the background layer.



now smartly place the brushes around the corners, see my result.

Now its time to create the top menu buttons, depending on how much you intend on having you might 
want adjust the width, in this gimp tutorial i intend to only have three main buttons.

Step 11: Button/Tabs

you might want to zoom in to 100% to make it easier.
Create a new layer name it : Tab border
grab the rectangle select tool, draw a selection and change values to the following:
position: doesn't matter right now.
Size: 140x62px.
Rounded corners: radius 13.7
Fill Color :Solid white
change Layer Opacity to 50

Create a new layer name it: "Tab base" and with the selection of the "tab border" layer still active, right 
click and go to select>Shrink 5px, finally fill with solid white. and unselect by going select>none.
this is how it should look



that part was repeated many times but now here comes something different. what we are going to do is 
merge the two layers that make up the tab button so that we can add some changes to it later on.

Step 12: to merge the two tab layers you need to hide all the layers we've created, except the final two 
which are the "Tab base" and "Tab Border" layers. to do that simply un click the "EYE" icon shown 
beside each layer.
you layers dialog should look like this



Step 13: once you have that done, right click on the tab base layer and click on "merge Visible Layers" in 
the Merge Layers window keep it on its default "expanded as necessary" then hit OK.

Step 14: now its merged into one image go ahead and change its name to just "Tab" and display all the 



hidden layers by clicking on the eye icons again.

before we put the tab into position we want to delete part of the transparent borders on tab so when we 
overlap the tab above the content box it blends in perfectly. you might want to zoom in to about 200% to 
make it easier.

Step 15: Grab the "Eraser tool" then go to the brushes dialog and create new brush with the values set as 
the following
Radius:18.6
spikes:2
Hardness:1
Aspect ratio:1
Angle:0
Spacing 0 

then name it what ever you like and save it.



Step 16: place the tab above content box and using the eraser and brush we created, eraser the 
overlapping border, you might not get it the first time so keep trying took me 1 min to get it right. 

Step 16: now duplicate 2 more tabs and space them out evenly as shown in the image below.



Time to create the menu buttons for the category side I'm going to use two colors the blue for mouse 
overs and the gray for normal status.

Step 17: Grab our favorite tool the "Rectangle select tool" draw a rectangle and enter these values in the 
"tool options" dialog.
Rounded corners: 62.7
Position 708:253
Size:206x30px

once you have the oval shape fill it with the color 36afdc.



now will duplicate a few more menu button but this time changing the color to gray.
Step 18: right click on the menu button and click on "alpha to selection" create a new layer name it 
"Menu button 2" then fill it with this color a09999



Step 19: now duplicate 5 of these menu button name as menu1-menu2 etc.. and space them out evenly 
like as i did in the image below.



now we need to create three more rounded buttons for the titles of the links that will be placed at the 
bottom.

Step 20: Create a rounded rectangle using these values
Create a new layer name it "Bottom content buttons"
Rounded corners: 5.0
Position:309:640
Size: 168x32px
fill using the color d2d2d2
duplicate 2 more of them and place them evenly at the bottom of the content box.



now we will create content dividers that will go between each post.

Step 21: Grab the selection tool and draw a 563x1px rectangle which is basically a line, once you have 
that right, duplicate it twice and place them as i did in the example below (notice the blue arrows).

http://gimp-tutorials.net/blog-theme-design-with-gimp#


Step 23: we should have done this before but anyhow make sure you add another rounded button for the 
search fild with these values.
Create a new layer name it "Bottom content buttons"
Rounded corners: 5.0
Position:717:166
Size: 168x32px
fill using the color d2d2d2

so far we're done with the main layout and can now move on to adding icon/content elements which will 
really make it look good once its done.
we will start with the icons. fist of all i didn't create these once to save time i instead bought them off 
istockphoto, its pretty cheap so unless your going to make your own you might shell out a few cents and 

http://www.istockphoto.com/index.php?refnum=solidnuts


buy some.

Step 23: your going to need a search,RSS, and a Comment icon. now i don't think i need to explain much 
here so just look at where i placed mine and do the same. try not to have icons bigger than 32x32.except 
for the RSS icon see what matches. here is what i picked off istockphoto

and my placements seen in this example.

now for the content. its probably the hardest part when starting from scratch, laying out content is key to 
great design, you can have a perfect design but if you don't place content in just the right place and style 
it can ruin everything. so pay attention to where i placed mine and notice how i try my best to keep white 
space equally on the sides all the time.

http://www.istockphoto.com/index.php?refnum=solidnuts
http://gimp-tutorials.net/blog-theme-design-with-gimp#


since all i did was add text ill try to give a few pointers for when you apply your own content.

- images in post should be consistent i gave my self around 128x128.
- i used the font "Trebuchet MS Bold" for everything except the right category buttons, i used "Verdana 
Bold"
- here are all the colors i used for text.
Headers, Blue"36afdc"
post text, light brown "939191"
bottom lists, medium brown "5f5b5b"
Dates in post, "d2d2d2"
Comments count, "3f3534"

so thats it! there you have a great blog theme design created in gimp. you might want to modify colors 
and other elements to suite your taste.

Click to Enlarge

the gimp XCF source file is attached at the bottom of the tutorial.and one last work give credit where its 
dew.

Note Please forward you questions on steps in the Help forum section.

4.2 Modern Navigation
Preview:

http://gimper.net/
http://gimp-tutorials.net/tutorials/bloglayout/bloginprog.png
http://gimp-tutorials.net/blog-theme-design-with-gimp#


In this gimp tutorial i will show you how to Create a cool modern website Navigation, this navigation 
works well with both dark and light backgrounds see examples at the end of this tutorial.

i made the width under 500px so it fits inside gimp-tutorials.net site, but if you look at the end of this 
tutorial there is a linlk showing how the site would look like on a wider 800px website. lets get started

Step 1Create a new image 500x100 

Step 2 From the tool box select the "Rectangle select tool" and draw a 490X50 rectangle 

 

Step 2 now will want to create a rounded corner around our selecting, you can do that by right clicking 
and then under "Select>Rounded rectangle", in the dialog enter the value 50 and press ok.

 

if you entered the 50 value right correctly you should have a rounded cornered selection like mine.

 

Step 3 Now Create a new layer name it "Base" and from the Tool box Grab the "Bucket fill Tool" and fill 
the Selection with the color cdd0d4 which is a dark gray

 

Step 4 Will want to repeat what we did in the previous steps but with a slight difference in the hight of 
the rectangle, grab the "Rectangle Selection tool" from the tool box and draw a 490X48 Rectangle, and 

http://gimp-tutorials.net/modern_navigation_gimptutorial#


like the first one will want it rounded so right click then click on "Select>Rounded Selection" enter the 
same value as before which was 50 then press ok. 

 

Step 5 This time will fill using the "Blend Tool", first create a new layer and name it "Base2", Change the 
Foreground color to 4f4f51 and the background color to9fa0a4, make sure in the "Tool options" that the 
Gradient is on FG to BG (RGB), and the shape to "Linear",now apply it from bottom to top its essential 
that the position is the same as mine,so make sure you pay attention to the image below.

 

If you position you blend tool right you should have the same results as mine

 

Step 6 Right click on the base layer then click on "alpha to selection". once you have the selection around 
the base layer right click again in the image area and then click on "select>Shrink" in the dialog enter 
2px.

 

if you followed through right you should have a nice small rounded selection like< mine.

 

Step 7 Create a new layer name it "Base3", and Once again grab the "Blend tool" change the foreground 
color to a4a5a6 and the background color to c1c4c8, now apply it from top to lower bottom, check the 
image for the position.



 

this is how it should look

 

Step 8 Grab the "Rectangle Selection" and draw a 482x39 at the lower part of the navigation.

 

Step 9 right click on the layer and go to "Select>Rounded rectangle", in the dialog enter the value 50 and 
press ok..

 

Step 10 Create a new layer name it "Base4", Grab the "Blend Tool" Change your foreground color to 
a3a6a9 and background color to eff0f1and apply it as i did in the image below. fill the background canvas 
with 16181c.

 

you might not get it right on your first try so try a few times till its like mine.

 

Step 11 Create another new layer name it "Divider", grab the Rectangle selection and draw a 2x45 
rectangle, this will be the divider between the text, use the "pencil tool" to color in the left side with the 



color 838387 and e8e9ea for the right.

 

Step 12 Now Duplicate the divider 5 times and space them out as shown in the image

 

Step 13 Not to add a drop shadow, Right click on the the layer we named "Base", right click to "Alpah to 
Selection", then go to "Filters>Light and Shadows>Drop Shadow" and enter "0 for Offset X" and "3 for 
Offset Y", "3 for Blur Radius" and finally 80 for opacity.



 

Step 14 Finally the text. i used the font "Marlett" in case you don't have it,the font "Sans" would just do 
fine, the color of the text that i used is 666666.

thats it here is the finished results with all the text filled in.

 

i used a dark background in this tutorial but this navigation even better on a white as well as you can see 
below.

 

i created a narrow navigation for this tutorial so it fits the width of gimp-tutorials.net but here is rough 
mock up how it would look inside a website layout.



Enlarge

Enjoy!

4.3 Creating Your Own Website Design Using Gimp
Preview:

It's only been a few days since i started with gimp and i already feel pretty comfortable with it, so i decide 
to create a website tutorial using Gimp.

for first time users its advisable to check out gimp.org for a quick overview of Gimp's tools and 
interference none the less its pretty straight forward and easy.
This is the out come of this tutorial 

Step:
1) Create a new Image 780x1000
2) Fill the background with the color ededed using the fill bucket tool.

Header will be simple and clean
3)Create a new layer and name it 'Header'.

http://gimp-tutorials.net/websitetutorial#
http://gimp-tutorials.net/tutorials/pro_nav/example.png


4)Use the Rectangle select tool and Drag across the full width which is 780x and a height of 125x use the 
Ruler as guides.
5) Now Select the Fill with Gradient tool and pick the FG to BG (RGB) Gradient and add the color 
000000 for FG and BG to 3a4146
6) Now Drag from top to bottom make sure the fill line straight

Click here to Enlarge

It should look like this now

Click here to Enlarge

Logo will just create a simple text as a logo with some reflection effect.
2)Add text Gimp-tutorials.net with size 30px and font 'Trebuchet MS Bold' you can try your own name 
and fonts of course :)
3) now to create the reflection duplicate the text name it logo reflection and place it below the original 
one
4)Using the flip tool will flip the logo reflection layer vertically

http://gimp-tutorials.net/websitetutorial#
http://www.gimp-tutorials.net/tutorials/layout/image2full.png
http://gimp-tutorials.net/tutorials/layout/image1full.png


5)Select the logo reflection layer and tick the
'Keep the Transparency box'.
6) Use the Gradient fill tool and select
'FG to transparency' and change the color of the FG to 3a4146

7)Now drag from bottom to top several time to fad-out the bottom part of the reflection logo text

Top Navigation bar
8)Create new Layer and use the rectangle selection tool to drag to the full width of 780x and hight of 20x

Click here to Enlarge

9) now using th gradient fill pick
FG to BF (RGB) Gradient and add the color 0276cf for FG and BG to 82c9ff, apply the gradient from 
bottom to top as shown below

http://www.gimp-tutorials.net/tutorials/layout/image5full.png
http://gimp-tutorials.net/websitetutorial#


Tabs
10)Create a new layer and name it Tab
11)Use the rectangle tool and draw a rectangle 105px wide and 8px high again use the Ruler for guidance
12)now right click on the tab and go to Select>rounded and change the Radius% to 45
13)Now use the Gradient fill using th same colors as the nav bar,0276cf for FG and BG to 82c9ff
14)now drag from bottom to top make sure you start from around 225px on the ruler and end at 125x on 
the ruler, or els the tab wont blend in with the nav bar very well, you you can see how i started and ended 
the fill line in the picture below keeping on trying till its perfect, i did :D

it should look like this



15) Duplicate the Tabs 3 times,rename them to stay organized
and space them out like this

16) now we would like to Center the tabs, will do that by clicking on all the chain looking icons in the 
layer dialog/window

17) now add text for each tab, ill type in home,products,contacts,about.
its a good Idea to save your work right now using the XFC format to be on the safe side.

http://gimp-tutorials.net/websitetutorial#


Click here to Enlarge

Right left Bar simple clean sidebar that works will with CSS Based sites.
18)Create new Layer, name it 'left menu bar'
19) use the rectangle selection tool and draw a 200px and 950x high which is all the way to the bottom 
then fill it with the color 232323 

20) chain link the tabs as well as the text and move it so its aligned like this

21)now to Create the line separators for the left menu bar, create a new layer, name it Line, Zoom in to 
about 300% so you can see,draw a rectangle thats 1px high and almost the width of the menu the then fill 
with the color 232222 

22)Draw another line and use the color 4e4c4c.

this is how it looks zoomed in at 200%

23)Duplicate 7 of the lines layer and space them out like this.

http://gimp-tutorials.net/websitetutorial#
http://gimp-tutorials.net/websitetutorial#
http://www.gimp-tutorials.net/tutorials/layout/image11full.png


24)Add some light Gradient effect to the background first Create a new layer name it 'gradient effect' then 
draw a 205px rectangle and fill it from bottom to top with the color ededed for FG and ffffff for BF. 

25)Create another layer and do the same for the bottom part of the body but this time draw from top to 
bottom.



now the main layout design is done, time to add some basic content, will need some nice photography touch 
going in there, one of my favorite free stock image sites is http://www.stockvault.net/ its 100% free! it 
wont cost you even a penny :P. head over there and download a suitable picture.

here is the what i used 

 

you can download it from here
http://www.stockvault.net/details.php?gid=98&sgid=&sgid=&pid=6296

26)open your new downloaded photography image and select the Scale tool and resize it from 1500 x 
1835px to 1024x705, because the image is too big will only want a nice scene of it, so grab the select tool 
and drag across to about 569x width and 179x height from the desired scene/area,then extract/cut it by 
pressing CTRL+C then going to our website tutorial window and pressing CTRL+V to paste it,
align and place it under the the header as shown below.

http://www.stockvault.net/details.php?gid=98&sgid=&sgid=&pid=6296
http://www.stockvault.net/
http://gimp-tutorials.net/websitetutorial#


26) now will add text links to the left menu, so grab the text tool type in about 5-6 words and align it 
perfectly in the middle of the divider lines.

27) Repeat this to the other dividers and always make sure its aligned perfectly, alignment is everything 
when it comes to graphic design, this is how it should look

28)again grab the text tool add a few paragraphs and place it in the center of the the empty space make 
sure all sides have equal space to get it perfectly aligned. 

http://gimp-tutorials.net/websitetutorial#


Click here to Enlarge

29)now the footer usely would have just the copywriter text with maybe an extra nav links, i just added the 
Gimp mascot that can be found on gimp.org and a small text of gimp-tutorials.net url.

Thats it you have a full template All done with Gimp :)

http://gimp-tutorials.net/websitetutorial#
http://www.gimp-tutorials.net/tutorials/layout/content.jpg


Click here to Enlarge

i changed the text logo to suite the site more, its always good to experiment different fonts to get that 
perfect look. :D

http://www.gimp-tutorials.net/tutorials/layout/finalfulllogo.png


Click here to Enlarge

stuck on something or need help leave a message here and ill reply to it :) feedback really appreciated.

4.4 The Complete Website Tutorial
Preview:

All in one tutorial,Design your layout with Gimp, slice it and code it, here is the outcome of this 
tutorial....

http://www.gimp-tutorials.net/tutorials/layout/finalfull.png


Click to Enlarge

1) Images maybe too dark as I was looking at the layout from my old computer and the images very 
tooooooo dark. I made this tutorial using my new computer and the screen is really bright so I apologize 
if the images are too dark.2)You must be pretty familiar with how GIMP works as i don't have pics for 
every single step as this tutorial is mostly your imagination.
3)Images maybe low quality from what they were designed to be since the file format of pics (to reduce 
file space) is .jpg. Thanks.
4)I would like to apologize for the delay as I've been sick and wasn't able to post sooner.

This is what we will be doing:
1) Planning and thinking
2) The Sketch
3) Navigation
4) Content Boxes
5) Slicing the layout
6) Adding content to HTML document
7) Making the style sheet 

Before starting to create your site, you may want to consider the following. First of all you have to know, 
which kind of site you are going to make. Is it a designer site? Clan site? Car selling site? Or whatever. 
After considering that, your site must have a name. The name is one of the most important things. Your 
name must be easy to remember, and also when someone hears the name, the first thing they think about 
must be your site. Now you must ask yourself some things: Why? What do you want to say? To whom? 

http://gimp-tutorials.net/node/71#
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/preview-1.png


What do other people benefit from it? What do you yourself benefit from it? Now you must think about 
the theme / colors for your site. To pick the right colors is also a very important thing to think about. In 
this tutorial I am going to recreate GimpTalk home page. I will choose some dark colors for it. Some dark 
Wilbur’s brownish color for shade probably / black / grey. After considering all those things, I think we 
can start making the layout! 

Click to Enlarge

Start of by making a new layer 900x600 and fill a new layer with the background color of your template.

Now take your Rectangular Selection tool  and make a selection for you banner.
A banner is nothing more than a larger version of a sig thus I will not be going into much detail of how 
you should make a banner but I would like to say that make something that will compliment to the style 
and the color of your web page. If you don’t know how to make a banner find a sig tutorial and instead of 
making sig size canvas, make something like 900x160 (banner size). BTW my banner size is 900x160. 

Click to Enlarge

Now that we have the banner, make a new layer and then take your Rectangular Selection Tool and make 
a selection right below your banner as this is where the buttons will go

Click to Enlarge

Now take you gradient tool  and with your foreground color to black and background color to 
something that compliments your style and banner, run a gradient. I used black and white. 

http://www.gimp-tutorials.net/tutorials/wbesitetutorial/5.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/4.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/2.jpg


Click to Enlarge

Now we will stroke our selection to give it more depth. I personally don’t like using the Stroke Selection 
to stroke my selection instead I use a 1px default brush to draw the lines. To make it simple for us I’ll use 
the stroke selection from the edit menu. Select your button layer if already now selected and then go to 
Layers>Transparency>Alpha to Selection and with the selection selected create another transparent layer. 
Then go up to Edit>Stroke Selection and stroke the selection with a solid line of one pixel. If it works 
fine for you and looks nice don’t change the layer mode but for me it doesn’t do a stroke of one pixel thus 
I set this layer to Overlay. Experiment with your stroke layer to see what works best for you.
It may not be that clear but this put across a black canvas is clearly visible.
Right After Stroke: 

Click to Enlarge

After changing the Layer Mode: 

Click to Enlarge

Now for creating boxes the put text, pics etc in.
Start of by duplicating your button layer. Then to the duplicated, scale it for height so that the width is 
same as the button row but the height is smaller for the scaled layer. Note I will refer to this layer 
throughout the rest of the tutorial as maybe scaled, button layer or something of that sort so you should 
know that I’m referring to this layer.
Button layer duplicated: 

Click to Enlarge

Scaled afterwards ( please ignore the black space as it is not part of the scaling. Thanks. Tell me if I 
should clarify more.)

Click to Enlarge

Very Important: Since we want to create a field for the content, rotated the scaled layer that you created 
by 180 degrees or upside down. Note again please ignore the black space since to save me time I rotated 
what is being displayed up. 

http://www.gimp-tutorials.net/tutorials/wbesitetutorial/11.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/10.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/9.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/8.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/7.jpg


Click to Enlarge

Now depending on how you want to lay out your website, created using the scaled layer of buttons places 
where the content will go.
First we’ll define the size of the top of the content box where the title will go.
This is what we’ll be doing ultimately so if you understand/know where and how I’ll do it, please feel 
free to skip the next few steps. 

Click to Enlarge and View the Animated version

First of all with the scaled rotated button layer selected, go to Layers>Layer to Image Size. Select part of 
the button content. 

You should now be able to move the selected floated layer. 

Move it to where you want to place it and align it with the other content of the layer so it looks like a 
whole. 

http://www.gimp-tutorials.net/tutorials/wbesitetutorial/13.gif
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/12.jpg


Click to Enlarge

This is what you should have now. Note this is only an example and you should define the dimensions to 
how big you want this contents box to be. 

Click to Enlarge

Now we will define the background of the contents box. You should at this point chose a color for the 
background of your contents box that will blend in well. The easiest way to chose a color is to zoom into 
to the scaled button layer and using your color picker, chose probably the second to last pixel from the 
color. I say this because the last pixel if you were following my directions is stroked and when we put 
this contents box together, we will want the “written stuff” to stand out.

Click to Enlarge

After you’ve done that. Make a new layer and with the dimensions of your contents box defined, using 

the Rectangular Selection Tool , make a selection on your new layer with the dimensions that 
you have decided on. Fill the selection with the color you picked as you background color. Now make a 
new layer and stroke the selection (if the selection is not selected go back to the layer with the 

http://www.gimp-tutorials.net/tutorials/wbesitetutorial/18.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/17.jpg
http://www.gimp-tutorials.net/tutorials/wbesitetutorial/16.jpg


background for your content box and go up to Layers>Transparency>Alpha to Selection and then active 
the layer you just created) with white or complimentary color to your theme of one pixel and set to 
overlay or other mode that’s to your liking. 

4.5 Create A Professional looking Logo Using Gimp
Preview:

Some of the best logos in the world are simple,logos which consists of basically text and a unique 
symbol.
a few famous examples are myspace,youtube,Yahoo,google.

in this logo tutorial for Gimp will create text and a simple symbol using the Path tool and color using 
Gradient fills from the 30 Ultimate Web 2.0 Layer Styles for Gimp pack that can be found in the 
download section.

Step

1)Create a new image, 300x400 will do.

2)I will use Segoe UI Bold. Pick your own suitable Font if you don't have the same as mine, fonts are one 
of the most important things in Designing logos, its a hard decision sometimes, so spend extra time and 
see what suits the style of your site. 

3)Type in a word, i typed in Amixroed.com which is one of my graphic design service sites name.

4)now I'm assuming you downloaded the "web 2.0 layer styles for gimp" pack if you haven't and you 
wanna do it the hard way, you can create your own gradient style your self by going to Gradient 
tab/Dialog,and click on New Gradient now enter the values of 3f4c6b for the Left ends point and 606b88 
for the Right Ends point.

if you did download the the pack then where going to use the "Web 2.0 Grey 3D" Gradient".

5)Make sure you have Lock alpha channel ticked in the layer dialog.

6)Now apply the "Web 2.0 Grey 3D" Gradient" Gradient from top to bottom

http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp
http://gimp-tutorials.net/prologo_withgimp#
http://gimp-tutorials.net/download
http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp


Make sure its straight so the colors are not on an angle, it should look like this

6)Now duplicate the layer and fill it with the same gradient but this time from bottom to top. make sure 
this layer is at the back and behind the other layers.



7)Create a new layer name it Symbol then Grab the Path tool make sure its on Design mode and Draw a 
strangle, then close the triangle by clicking on Edit mode and clicking to the end point.

8) now still in Edit mode drag click on the middle of the right line and drag to a few px and it will curve 
as shown below



9)Now click the Create selection from path button,
Grab the Gradient fill tool if you have the 30 Ultimate Web 2.0 Layer Styles for Gimp Gradients select 
the Web 2.0 Red 3D Gradient and apply it from left to upper right as shown in the picture, if you don't 
have the gradients create your own one as mentioned in step 4 but this time d11414 for the Left End's 
point and fe1b01 for the Right End's point.

10)duplicate the Symbol layer make sure its behind the original symbol layer and make the opacity to 27

There you go! you very own logo :)
now you should try to be more creative and draw more complex symbols with the pen tool.

http://gimp-tutorials.net/prologo_withgimp#


i hope this was useful to anyone out there :) feedback is appreciated , i check more then 5 times a day so 
if anyone needs help just post here or use the forum and be sure that i will reply.

you can download the Source of this tutorial attached below.

4.6 Creating the Simnor Computing navigation menu
Hi, have you taken a look at this site and thought thats a nice navigation menu, no… okay never mind.
Only joking. I will tell you how to make it using The Gimp, you can maybe do the same with Photoshop 
and the other design packages with a bit of tweaking.

1. To start off with create a new project, I am going to make it 36px by 900px 
2. Give the background a colour or an image if you wish. 
3. Create a new layer 
4. Now we will create the base line, to do this click the select tool and select a region at the bottom 

of the canvas about 4px high and fill it with the colour (#661414) or any other colour you want. 
5. Add a new layer and select about 2/3 of the width and an appropriate height. See the image 

below:

 
6. Select the “Select” menu and select (thats a lot of selects, lol) Rounded Rectangle and change the 

value to 10 
7. Now fill it with the colour white and change the layer opacity to 10.0

 
8. Add a new layer 
9. Now would be a good time to zoom in a bit, maybe to 400% 

http://gimper.net/
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-3-layers-900x36.png
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-4-layers-900x36.png


10.Select a region like in the screenshot below, this is 90px by 29px 
11.Again select the Rounded Rectangle from the Select menu, and set the value to 30 
12.Go to The Gimp window (Ctrl + B), and change the colours to #661414 and #ab3e3e 
13.Fill the rounded rectangle with #661414 
14.Now unselect the region and select the base of the rounded rectangle to make the bottom not 

rounded by filling the region. Take a look at the screenshot:

15.Now unselect it and press Ctrl+A and then Ctrl+X which will cut it and then Ctrl+V to paste it 
again, this will make it all selected 

16.Press L or select the gradient tool and click and drag the tool like in the screenshot

 
17.Now unselect it and then select a third of the tab on the right:

 
18.Copy this (Ctrl+C) and paste it, select the Flip tool (Shift-F) 
19.Now click the selected are and it should flip. 
20.Press R or select the Select tool 
21.Use the left arrow to move the selected region to the other side of the tab:

 
22.Unselect the region and select the pencil tool and create a new layer. 
23.Now draw an outline on the outer edges of the tab:

 
24.Now go back to The Gimp window and click the swap colours icon which is the double headed 

http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-4-layers-900x36-3.png
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-5-layers-900x36.png
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-4-layers-900x36-4.png
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-5-layers-900x36-1.png
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-4-layers-900x36-5.png


arrow next to the colour selectors 
25.Draw another line under the line you just drew with the lighter red:

 
26.And there you have it a basic menu similar to my site designed in The Gimp. 

This effect can be added to loads of things, just take a look above and you will notice that there are a 
number of boxes under the header of this site, these use the same effect with different colours and 
dimensions, this effect can be used for loads.

I hope this tutorial helped.

The final outcome:

The source .xcf file: Download here 

4.7 SimplyBlue web layout - Part I
I’m going to show you how to create a complete web layout using GIMP. This tutorial consists of two 
parts: The first part covers creating and preparing the graphics for the layout. The second part will go 
over marking up the layout in XHTML 1.0 Strict and styling with CSS 2.0.
(Click on the thumbnail below to see a live version of the layout)

Part I: Creating the graphics

In this part we’ll create a mock-up of the layout, from which we’ll save the graphics for the template. 

The headers

We’ll begin by creating a new image of 800×600 (CTRL+N). Fill the image with #292929 (SHIFT+B for 
fill tool, or CTRL+, to fill with current foreground color). Create a new layer (Layer > New Layer) called 
‘headers’. Make a rectangular selection that spans the top of the image with a height of 140px (the width 
is not so important).

http://simnorcomputing.com/simnorcomputing.com/webdesign/workarea/menulinks.xcf
http://simnorcomputing.com/wp-content/uploads/2008/01/screenshot-untitled-10-rgb-4-layers-900x36-6.png
http://simnorcomputing.com/wp-content/uploads/2008/01/menulinks.png
http://technomono.com/tutorials/examples/SimplyBlue/simplyBlue.html


Fill the selection with a gradient of #0394FD to #0077F8 (L for gradient tool). Make another selection, 
28px tall, about an inch away from the selection we just filled; the width isn’t too important. Apply the 
same gradient as before to this selection, then deselect (CTRL+SHIFT+A). You’ve just made a content 
box header.

Create a new layer (Layer > New Layer) called ’stripes’ and fill with the Warning pattern (CTRL+SHIFT
+P will show the pattern dialog). To apply the pattern, just click and drag it onto the canvas. It is not the 
color we want, so to change it go Colors > Colorise (GIMP 2.2 users go Tools > Color Tools > Colorise) 
and set Hue:180, Saturation:0, Lightness:0. Change the layer mode to ‘Overlay’ (drop-down bar at the top 
of the layers window) then lower the layer opacity to 6 % (top right of the layers window). 

Notice the stripes cover the entire image; we don’t want that. Right-click the ‘headers’ layer and choose 
‘Alpha to Selection’. Click on the ’stripes’ layer in the layer stack, then invert the selection (CTRL+I or 



Select > Invert) and press delete (GIMP 2.2 users press CTRL+K).

Now we’ll add the highlight along the top of the headers. Right-click the ‘headers’ layer and choose 
‘Alpha to Selection’. Create a new layer called ‘highlights’. Press D then X (to reset and swap current 
colors) then fill the selection with white (#FFFFFF). Now deselect (CTRL+SHIFT+A). Make a selection 
along the lower half of the top header and delete like so:

Now do the same for the smaller header:

Now lower the ‘highlight’ layers opacity to 8%. To finish off the headers, we’ll add a border to the 
bottom of the large header. Create a new layer called ‘headerBorder’. Now we need to draw two lines 
with the pencil tool. Select the pencil tool (N) and change the brush size to 1px (named ‘Circle (01)’ in 
the brush list in the tool options directly below the tool box). 



Note: If you click once at the start of where you want the line to begin, then press and hold SHIFT
+CTRL and click where you want the line to end, GIMP will draw a straight line for you.

Set the color to #2598E6 and draw a line along the bottom of the large header, then draw another line 
directly below that one but with a color of #0067BE:

This step is optional because we’ll add this through XHTML/CSS, though it will give us an idea of how 
the layout will look when its done. Create a new layer called ‘contentBG’, then make a rectangular 
selection directly below the small header, make it the same width and a decent height. Fill it with 
#3C4040, then deselect (CTRL+SHIFT+A or Select > None). Now select the move tool (M) and press 
the down key once. You may not have noticed any change but what you’ve done is given a 1px space 
between the small header and the content background; this gives the header more definition:

The Logo

Now to add the logo. I’ve made a very simple text logo with my site name, though you can use whatever 
you wish. To make the same as mine, use the text tool (T) and click on the image to add your text. I used 
Arista font at 38px. Set the color to white. Use the move tool (M) to move the text to the left of the large 
header, about half way down:

http://www.dafont.com/arista.font


Duplicate the text layer (Layer > Duplicate Layer) then go Layer > Transform > Flip Vertically (this will 
be the logo’s reflection). Move the duplicate text down with the move tool:

Right-click the duplicate layer (in my case ‘TechnoMono#1′) and choose ‘Add Layer Mask’, this will 
bring up a little dialog with many options, choose white and click Add. Reset your colors (D then X) and 
apply a gradient to the reflection:

Lower the layer opacity to about 24% and save your file as ’simplyBlue.xcf’.

OK, we have now completed the first part of the web layout. Next up, the cropping of the layout, after 
which we’ll cover the XHTML & CSS. Though I won’t go into detail, I will explain what each section 
does and provide further resources for learning XHTML & CSS.

Preparing the template images

You should have your simplyBlue.xcf file open in GIMP; if you don’t, then open it up.

We shall start with the header background. Make a 20×142 selection on a clear part of the header (not 



over the logo). This selection needs to start at the end of a dark-blue stripe. You will need to zoom in: 
Hold CTRL and scroll mouse wheel (GIMP 2.2 users press SHIFT instead).

When you have a selection, go Edit > Copy Visible (this will copy everything visible within the 
selection). Now we need to paste it to a new image: Go Edit > Paste as > New Image (GIMP 2.2 users go 
Edit > Paste as New). Go File > Save (CTRL+S) and save as ‘headerBG.jpg’, a dialog will pop up with a 
message like ‘JPEG can’t handle transparency’, just click Export. This will bring up some options: Set 
the quality to 95% and expand Advanced Options, make sure ‘Progressive’ is checked then click Save. 

One image down, two to go  

Now for the logo. Make a selection 142px tall and wide enough to encapsulate your logo (the width 
MUST be a multiple of 10 to line up with the ‘headerBG.jpg’ tile, mine is 280px wide). Make sure to 
start the selection at the end of a dark-blue stripe, finishing at the end of another dark-blue stripe after 
your logo (as we did with the header background). 

Copy the selection (Edit > Copy Visible) and paste it (Edit > Paste as > New Image) then save it as 
‘logo.jpg’ using the same settings as before.

Last one! Zoom in on the small header and make a selection 20×32 like so:

Then copy and paste as previously done, and save it as ’smallHeaderBG.jpg’. Our cropping is now 
complete. You can now save your work and close GIMP. Next up we code the layout.



4.8 SimplyBlue web layout - Part II
Coding the layout

In this part we will be looking at the XHTML and CSS. We’ll start with structuring the layout with 
XHTML. The XHTML acts as the framework for the layout upon which we’ll apply stying using a CSS 
style sheet. The framework consists of several modules:

It’s assumed that both the XHTML document and style sheet reside in the same directory, and that all 
images used by the layout reside in a subdirectory called ‘images’ (in which the images we created in Part 
I are saved).

XHTML

(Save the following in a text file called ‘SimplyBlue.html’)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
 
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
  <head>  
    <title>SimplyBlue web layout</title>
    <meta http-equiv="content-type" content="text/html;charset=utf-8" />
    <meta http-equiv="Content-Style-Type" content="text/css" />
 
    <link rel="stylesheet" type="text/css" href="styles.css" />  
  </head>
  <body>
 
    <!-- HEADER -->
    <div id="header">
 
      <!-- This is the header where your logo will go -->
 
      <a href="http://www.technomono.com">    
      <img src="images/logo.jpg" style="width:280px; height:142px;" alt="TechnoMono.com" /></a>
 
    </div>
    <!-- /HEADER -->
 
    <!-- WRAPPER -->
    <div id="wrapper">
      <!-- CONTENT -->
      <div id="content">      
 
        <h2>Content</h2>
        <p>This is where you'll place your main content</p>
 
      </div>
      <!-- /CONTENT -->

http://technomono.com/blog/simplyblue-web-layout-part-i/
http://technomono.com/blog/simplyblue-web-layout-part-i/


34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56

 
      <!-- MAIN NAV -->
      <div id="subContent">      
 
        <h2>Navigation</h2>
        <p>Place your site navigation here along with additional links/info</p>
 
      </div>
      <!-- /MAIN NAV -->
 
      <!-- FOOTER -->
      <div id="footer">
 
        <!-- The footer can contain contact/copyright info -->
        <p>&copy; your site 2007</p>
 
      </div>
      <!-- /FOOTER -->
    </div>
    <!-- /WRAPPER -->
 
  </body>
</html>

The XHTML links to an external style sheet called ’styles.css’. 

CSS

You’ll notice that we’ve centered the text within the body using text-align: center. We’ve done this to 
bypass a problem with IE 5.x and IE 6 (they don’t honor auto margins in quirks mode). IE 
misunderstands text-align: center; it actually centers everything, including the wrapper. Of course, it also 
centers the text within the wrapper, which is easily overcome with text-align: left. 

Since the header isn’t in the wrapper, it spans the length of the page. The content area and navigation are 
floated right and left, respectively. The footer sits at the bottom of the wrapper, clearing the floats above it 
with clear: both.

Also, a couple of classes are provided for floating images. Here’s the CSS in it’s entirety:

(Save the following in a text file called ’styles.css’)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

* {
  /* This is the universal selector: It allows us to style every element
      on a page. In this case, we remove the default browser padding 
      and margin on every element */
  margin: 0;
  padding: 0;
  }
 
body {
  /* Styles applying to the entire page */
  font: 11px/1.5 Verdana, Sans;
  color: #f8f8f8;
  background: #292929;
  text-align: center;
  }
 
#header {



18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75

  /* To the header we apply a background image which tiles horizontally */
  height: 168px;
  text-align: left;
  background: url('images/headerBG.jpg') repeat-x top left;
  }
 
#wrapper {
  /* The wrapper contains the content area, navigation and footer.
    It's positioned in the center of the page using auto margins */
  width: 780px;
  margin: 0 auto;
  text-align: left;
  }
 
#content, #subContent {
  /* Both the content area and navigation share the same background color */
  background: #3c4040;
  }  
 
#content h2, #subContent h2 {
  /* Section headers share the same tiled background image and font */
  background: #0290fc url('images/smallHeaderBG.jpg') repeat-x top left;  
  font: bold 14px/28px Sans;
  text-indent: 1em;
  }  
 
#content {
  /* The content area is positioned to the right using a right float */
  float: right;
  width: 560px;
  }
 
#subContent {
  /* The navigation is positioned to the left using a left float */
  float: left;
  width: 210px;
  }
 
  /* The following styles apply to lists and links within the navigation */ 
#subContent ul {
  list-style: none;
  margin: 1em;
  }
 
#subContent a {
  color: #ccc;
  font: bold 1.1em Sans-Serif;
  text-decoration: none;
  }
 
#subContent a:hover {
  color: #f0f0f0;
  text-decoration: underline;
  }
 
  /* The following styles apply to the footer and it's contents */
#footer {
  clear: both;
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  text-align: center;
  padding: 10px;
  font: 0.8em Sans-Serif;
  }  
 
#footer a {
  color: #27aefe;
  }
 
#footer a:hover {
  color: #FFF;
  }    
 
  /* General styles */  
img {
  border: none;
  }
 
img.left {
  float: left;
  margin: 1em 1em 1em 0;
  }
 
img.right {
  float: right;  
  margin: 1em 0 1em 1em;
  }  
 
p, h3, h4 {
  margin: 11px;
  }

Resources for learning XHTML/CSS

4.9 Creating a ProBoards forum colour scheme
Before we can get started on choosing forum colours, I’ll give a brief guide to selecting and applying 
colours in the GIMP.

Background and Foreground Colour Boxes

The Background and Foreground Colour Boxes are located at the bottom of the Toolbox.



The top colour box is the Foreground Colour, and the bottom colour box is the Background Colour. 

Click on one of the colour boxes to select, and click again to open up the Colour Selection Dialogue.

The colours can be changed by moving the sliding rules on the colour box, and gradient bar. The hex 
colour code is also generated in the HTML Notation box. Hex Colour codes are used to input colours for 
ProBoards Forums.



Using the Bucket Fill Tool

The Bucket Fill Tool is easy to use. I’ll give a brief explanation and then we can move one to actually 
creating a colour scheme.

Go to File > New (or Ctrl + N), to open the Create a New Image Dialogue, and make these settings:

1. Width: 200 pixels 

2. Height: 200 pixels 

And Press OK.

In the Toolbox, select the Paintbucket Icon

In the Bucket Fill Palette Check BG Colour Fill.



Double-Click on the Background Colour Box to open up the Change Background Colour Dialogue, and 
select any colour. 

Place the Cursor over the blank canvas and click to fill the image with the selected colour.

We will use the Bucket Fill Tool entirely for applying colours to the ProBoard Canvas.

Using a ProBoards Canvas

Adding Colour codes directly into your forum before you have a set colour scheme is time consuming, 
not to mention rather frustrating. I’ve found that it helps to create the colour scheme first, and then when 
done, input all the colour codes together. 

To do this I use an image I call my ProBoards Canvas, which you can save, and open up in GIMP (File > 
open).



Window Colour(s)

The window colour is the most important background colour for the forum. This is the colour that will 
predominate all the other colours, and it is important that it is appropriate for your forum members. A 
Heavily white/light colour is the safest route to take when choosing a window colour, as a majority of 
people find it difficult to stare at a dark screen for long periods of time. 

Also, we should avoid any mid-range window colours, if we want to provide enough contrast between the 
background and the foreground/text colour. If the background and text are not clearly defined, there is a 
risk that many members (including potential members) will not be able to read the text on their monitors. 

A brilliant tool for assessing your background and foreground colours is Jonathan Snook’s Colour 
Contrast Check. 

Select the Magnify Tool, and with Zoom In Checked, click on the image twice to enlarge.

http://snook.ca/technical/colour_contrast/colour.html
http://snook.ca/technical/colour_contrast/colour.html


Click on the Background Colour Box to open up the Change Background Colour Dialogue Window. 

Select a Window Colour, and Press OK. For my Window Background Colour, I’m choosing a light green-
blue hue. 

Select the Bucket Fill Tool, with BG Colour Fill checked, and fill the window backgrounds on the 
ProBoards Canvas. 



Title and Category Backgrounds

Eventually, we will be adding images, known as gradients, to the Title and Category Backgrounds. For 
now they can be filled with the same colour as the window Background. 

Forum Background Colour

For the background colour I’m using a darker shade of the window background colour. There are a few 
things that need to be considered when choosing the background colour. The background also contains 
text and link colours, so we need to provide enough background-foreground contrast. 

However, we will also be using an image for the background that will be a much lighter colour (while 
retaining the html colour code for the borders of the background), in which case, we needn’t worry to 
much about providing enough contrast, at this stage.

When you have selected your background colour, select the Bucket Fill Tool, with BG Colour Fill 
checked, and fill the forum background on the ProBoards Canvas.



Border Colour

For the border colour, I’m using a darker shade of both the window and body backgrounds. You’ll notice 
that the solid back colour makes the forum boards look boxy. We want to use a colour that is both well-
defined and well-balanced with the window and body backgrounds, yet visually softer than the solid 
black.

Use the Bucket Fill Tool to add the border colour.



Window Highlight Colour

The window highlight colour appears when hovering over a board over thread table cell. I’m using a 
lighter almost white shade of the window background colour.

Using the Text Tool in GIMP

Before moving on to the foreground colours, I’ll give a brief explanation on how to use the Text Tool in 
GIMP.

Reset the Colour Boxes to Default (Press D), and go to File > New (or Ctrl + N), to open the Create a 



New Image Dialogue, and make these settings:

1. Width: 200 pixels 

2. Height: 200 pixels 

And Press OK.

In the Toolbox select the Text Tool (or press T).

You can alter the text using the Text Tool Palette. Click on the Font Dropdown List to display the 
Typesets installed on the computer. 

Each Typeset has four font settings:

1. Normal 
2. Bold 
3. Bold Italic 
4. Italic 

The text colour can be changed by clicking the font colour bar, and opening the Text Colour Dialogue 
Window.

Click on the blank canvas to open up the GIMP Text Editor Dialogue Window, input some text.



While the text is selected you can continue editing the text in the Text Tool Palette.

Each new text selection made creates a new layer. Open the layers palette, and go to Dialogues > Layers 
(or press Ctrl + L), to view all layers.



To move the Text Selection, select the Move Tool in the Toolbox (or press M), and click on the text layer 
in the layers palette.

That’s pretty much all we need to know about the text tool for this tutorial. Now we can move on to the 
foreground colours.

Foreground/Text Colours

The foreground colours can be broken down into two main groups:

1. Title, Category, and Links:   2 colours   

http://www.mahudsblog.ourgardenpath.com/?p=647#tcl
http://www.mahudsblog.ourgardenpath.com/?p=647#tcl


2. Main Text:   1 colour   

Title, category, and link colours

For the Title Category and links, we need to choose a colour that will stand out from the main text colour.

Complimentary colours

A possible solution in choosing a foreground colour, would be to use a colour that is complimentary to 
the background.

Complimentary colours are colours that oppose each other when displayed on a colour wheel.

Because I used a blue-green hue for my background colour, I am using an orange-red hue for my Title, 
Category, and Link Colours.

The Font settings are:

1. Font: Verdana Bold 

2. Size: 13 pixels 

3. Hinting: Checked 

4. Force auto-hinter: Unchecked 

5. Antialiasing: Unchecked 

For the main link colour I’m reverting back to the blue-green hue.

http://www.mahudsblog.ourgardenpath.com/?p=647#mt
http://www.mahudsblog.ourgardenpath.com/?p=647#mt


Main text colour

For the main Text Colour, I am using a very dark shade of the blue-green hue, for maximum readability.

The board description font settings are:

1. Font: Verdana 

2. Size: 10 pixels 

3. Hinting: Checked 

4. Force auto-hinter: Unchecked 

5. Antialiasing: Unchecked 

The board italic font settings are:

1. Font: Verdana Italic 

2. Size: 10 pixels 

3. Hinting: Checked 

4. Force auto-hinter: Unchecked 

5. Antialiasing: Unchecked 



Select the colours using the Colour Picker Tool

Now we have all our forum colours, we can make preparations to input them into the forum.

In the Toolbox, select the Colour Picker Tool (or Press O), and select the Background Layer in the Layers 
Palette.

In the Dropper Tool Palette check Set Background Colour.

Use the dropper tool to select the background and foreground colours. When you click on the image 
layer, the Colour Picker Infomation dialogue will open up. If you have selected the correct colour, press 
close.

Next, click on the Background Colour Box to open up the Change Background Colour Dialogue, And 
copy and paste all the colour codes in a text editor (eg: notepad).

Remember to click on the appropriate Text layers in the Layers Palette when colourpicking the 
foreground colours.

Window Background 1: ecf8f5 
Also add to:
Window Background 2
Title Background
Category Background
News Title Background
News Background
Popup Window Background
Popup Window Title Background 

Board Highlight: f0f9f7 
Also add to:



Thead Highlight 
Background: cddbd8 
Border: a8bab6 
Text: 2d5f54 

Also add to:
Popup Window Text 

Main Link: 8aaca5 
Active Link, Visited Link, Title and Category Text: e74d3d 

Also add to:
News Title Text
News Text
Popup Window Title Text 

And Finally…

All that’s left now is adding the colours to the forum itself. If you are unsure how to input the forum 
colours, read the Skin/forum colours section of my Installing a   PB   Template tutorial  .

This is the end of the ProBoards forum colour scheme tutorial. This tutorial will eventually be part of a 
complete ProBoards skinning tutorial for GIMP.

I hope you have found this tutorial helpful. Why not post your results? I’d love to see them  

If you are having difficulties with this tut in any way, leave a comment, and I’ll try and help out  

http://www.mahudsblog.ourgardenpath.com/?p=17
http://www.mahudsblog.ourgardenpath.com/?p=17
http://www.mahudsblog.ourgardenpath.com/?p=17
http://www.mahudsblog.ourgardenpath.com/?p=17#sfc


4.10 Creating a Website Template
In an effort to contribute to Gimp's greatness I have accidentally discovered a solution to (I feel) Gimp's 
ONLY drawback. Since I am not a programmer and cannot contribute to coding or even to writing scripts 
for Gimp, I have never been able to really contribute. Now I can.
Over the years I've seen Gimp really develop and become more and more like Adobe Photoshop TM and 
in many cases surpass it. It's become better (to me) in almost every area EXCEPT it's ability to create 
website templates.

In Photoshop a user can create an image for a website, slice it up into specific boxes and output the 
individual images and have them added to or create an HTML table to displace the sliced images as a 
whole.

In Gimp however slicing up an image required using guides. To create a slice a user would click and drag 
their mouse from either the top or the left rulers and position the guides where you would want/need 
them.

The problem occurs when you try to use Guillotine ( Image>Transfom>Guillotine) or when you use the 
plug-in script Web-o-tine.

In this example, You will notice that the guides ONLY go completely across the image. While this will 
create a sliced image it will create way too many slices. Plus it will break up images that you don't / or 
shouldn't want broken up.

Using the guidelines as above just try and make the expandable content area.

Until now, these are the images that you would get by using Guillotine or Web-o-tine. I've spaced the 
slices for reference.

This would be the text area. Notice that using it this way would not allow you to go across the cells 
smoothly

This wouldn't be a problem if you just wanted to load the full image and just 
broke it up to load faster. 

http://www.gimp.org/


However if you wanted to create a Home and a Search button, then use the text area to hold your site's 
content.

This is what the slicing SHOULD look like is only six slices.

With slicing done like this, one can create a single cell graphic that spans across the entire image and 
expands with the website's content.

HOW TO SLICE THE IMAGE

This is VERY easy and, in fact, I discovered it by accident and now I'm going to show how it's done.

The first thing you need to do is draw out your lay out as I've done in this example.

Then save as an XCF file to preserve the layers.

Now, once you've created your XCF file, flatten the image and save it again as an XCF file under a 
different name. (This is the file you will be working with)

Now, working with the flattened website template you're going to need to start creating slices. In the 
example above I would insert the guidelines just as they were. The 
guidelines will be used for EXACTLY that – Guiding.

Now that you've inserted your guidelines open the layer box (CTRL+L) 
While the background layer is selected, choose the square selection tool 
like such:

Now go back to your image and select an area you want to make slice of. 
Such as the logo portion of the site.

Once this selection is made, (again while the background layer is 
selected) Copy and Paste it.

In the Layer's Box you should see a “Floating Layer” . If you see this 
then click the “Add New layer” button (The far left button)

You've now successfully made your first slice. Rename the slice to keep 
track of it.

Now for the slice that Guillotine and Web-o-tine cannot do.



Following the sames steps as before. Select the background layer 
then select your slice.

Again, Copy then paste the selection. Once it's pasted and you see 
the floating layer, add the new layer.

Repeat these steps for the rest of the slices thus creating a new 
layer for each slice.

Once you have all of the slices the way you want them, now it's 
time to save the images.

This is the easiest part.

Open the layer box (CTRL+L) make sure all of the layers are 
visible.

Now select one of the layers by simply highlighting it like so:

Now that the layer is selected (it's actually one of your slices).

Go to File>Save a Copy>

Save image as homebutton.png.

If you've done everything correct, you should see this warning:



Select IGNORE and save the file as you normally would.

Repeat these steps with each layer. When you're finished you 

will have all of the slices the way you need them. Now all you have to do is place them into an HTML 
table and you're set to go.

4.11 Technical Border 
1.Open a new image, pick your size and mark it as transparent in Advanced Options. I chose 150x400. 
Create a new layer and call it ‘Main Shape’. Now to the cutting, use your paths tool to create a shape, 
which will be your main shape, but keep in mind to leave some room for later use.
Go click ‘new path’ in the path section in ‘Layers, Channels…’ window. A pop-up window will appear 
and click ok, and after that double click on the mini-image. In your main window, you should now see 
your path tool is selected, click on ‘create selection from path’.
When you are done, go to Select > From Path.
This is my shape:

http://gimper.net/index.php?topic=458.0#


(Optional): If you like your shape, you can save the path by go to your ‘Layers, Channels…’ window and 
to the path section and right click on your path, and click on ‘Export path’ and when you want it again, 
you click on ‘Import path’ – remember when you import the path, make sure to show all the files, 
otherwise you might not be able to see your saved path.

2.Now go to Select > Save to Channel, call it Main Shape Selection.
Next is, you have selected your Main Shape layer, now you are going to color your shape by using the 
gradient tool. Choose whatever color that suits your future render best. In the gradient tool option, choose 
a Bi-linear shape. Hint: when you going to fill the shape, start from the middle and go top in a straight 
line. This is what I chose:

3.Now go to Script Fu > Shadow > Drop Shadow with these settings:



After that, go to Script Fu > Décor > Bevel and put in a radius of 5 and deselect ‘work on copy’. Now 
create a new layer, call it Secondary Shape. Make another creative shaped path in the open area. When’re 
you done, go to Select > From Path. This is mine:

4.When you still have selected the Secondary Shape, make a channel to that one too and call it Secondary 
Shape Selection. After that, repeat the gradient, drop shadow, and the bevel to this selection. Once that is 
done, create a new layer and call it Connections 1 and put that layer under all of the other layers, except 
for the Background. Make one or two rectangle(s) by using the Rectangular Selection and hold shift 
down while making them. This is how mine looks like:



5.Repeat the gradient, drop shadow, and add bevel to this selection. But for the gradient, use black to the 
Foreground and white to the Background. (Optional): You can also add some ‘light grunge’ or tech 
brushes in black on the two pipes.

6.This step will be adding the real interesting parts of the signature. First select none, then go select the 
Main Shape Selection (‘add to selection’ in the channel section in ‘Layers, Channels…’ window), and go 
to Select > Shrink, by 6 pixels. This is another important selection, so make a channel to this one too, and 
call it Grunge.
Create layers for the grunging, and call them ‘Grunge 1,2,3…’.
Now in this selection, do your normal grunging. I mixed a bit grunging with some tech brushes, but you 
can also wait with the tech brushes for later, like I did.
Make sure you don’t leave this selection, and also make sure for the first Grunge layer, fill the whole 
selection or it will cause troubles later.
Now we need to add a border to the grunge section, so make an ‘Alpha to Selection’ of the grunge by 
right clicking on a layer with all of the selection filled, then go to Select > Shrink, and choose 3pixels. 
Fill it with whatever color suits you best, I chose black. This is mine:

7.Create a new layer, call it Little Background. It’s time to fill the second shape. Select none and make 
your Secondary Shape Selection and shrink it by 6pixels, also add a channel to this one and call it Little 
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Background Selection, then again, start with fill it and make some grunge. After that, make a new layer 
and call it Second Shape Border. Alpha select your Little Background layer and goes to Select > Border, 
and do 3pixels. I filled it again with black. This is how it looks like until now:

8.I filled it with all white for a purpose of I’m going to put a full render into that little box later. But first 
for the last steps, it’s time to add the render, first to the big area. Merge all your ‘old grunge’ layers into 
one, by right clicking on the layers and ‘Merge Down’. After that, alpha select the remaining grunge layer 
and select your Grunge from the channels. Now add some extra colors that match your render, by go to 
Layers > Colors > Color Balance and change it as you like, also now it’s time to add some tech brushes. 
This is how mine looks like:

9.(Optional): To make the light on the background look a bit more interesting, open a whole new image, 
any size do it, but recommend it would be on the same size as your signature. Fill it with either black or 
white, depends on how you want the light. Now copy that image, and paste it into your remaining grunge 
layer. While the pasted image is still selected (not anchored yet) set the mode to overlay and the opacity 
whatever you like. Like this:



You can see the top is a bit darker than the bottom. Keep doing this until you are satisfied.

10.Now create a new layer and call it Render 1, and put it on top of all other layer and go to your 
channels and make your Grunge selection and select Render 1 by just click on the layer and ‘Paste Into’ 
with your render. Now you can also add some new tech brushes, on the purpose there should be some on 
the render. Like this:

11.Now finally to the little background. Select none, and create a new layer and call it Render 2. Go to 
your channel section and select Little Background Selection. Select Render 2 and make a grunge 
background, paste a picture or whatever you like. I putted an eye in it ..lol

12.Last you only need to add some cool text and you’re done! Select none, make a new layer and go to 
channel section and select Grunge, and then add your text. This is my final result:



4.12 Sigs in Gimp
1) First, we need to make a background. I am going to make a grunge style background based on the 
tutorial from GimpTalk. First, you need to get some grunge brushes in order to do this. Go to 
DeviantArt.com and search for grunge gimp brushes or just Google some. Now, create a new image, 
400x150, with a white background. Create a new layer, name it grunge. Brush your grunge brushes on it 
with a black color. Completely cover the layer.

2) Now, go to Colors -> Color Balance. Change the color balance of the grunge layer to something that 
suits your needs. You can also go to Colors -> Colorize and change the colors from there.

3) Do a motion blur. Go to Filters -> Blur -> Motion Blur. Blur Type: Linear, Length:121, Angle:115.

4) Create a new layer. Now use your grunge brushes in white on the layer. Do a motion blur on the layer 
again. Linear, 160, 0. Lower the opacity to about 60.

5) Create a new layer, name it clouds. Go to Filter -> Render -> Clouds -> Solid Noise. Leave the settings 
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as they are. Now go to Colors -> Color Balance. Play around with the settings until you come up with 
something you like.

6) Create a new layer. Paint your grunge brushes on this layer in black. Fill up the layer but don't get too 
dark. When you're done, change the layer mode to Overlay. Create another layer and paint your grunge 
brushes in white. Set the mode to Overlay. Repeat steps one and two as many times as you want but don't 
use too dark of colors. Then, use the color balance again.

7) Alright, now that you have a background, you need a render. Go to PlanetRenders.net or Google one. 
Add your new render to your sig. Position it toward the left or somewhere you like it. What I did with 
mine was after I positioned it, I made it about 80% opaque, duplicated the layer, then set that layer to 
overlay.

8) Now, we need to add some text. Position it towards the right. I lowered the opacity on the text, then 
duplicated the layer, setting the second layer to overlay. There you go. A simple way to make sigs.

4.13 How to Create Cool Signatures
A TUT on how to make a cool signature.
1. Open Gimspter (GIMP)
2. Go to File>New then change the width to 400 and the height to 150. (This is the requirements for most 
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forums)
3. (optional, but if u add it, it looks supa cool) This feature is called flames. It adds affect to almost 
everything. But who knows, maybe it just to cool for you. To add flames go to
Filters>Render>Nature>Flame.

4. Now you should see a screen pop-up.

Pick a flame you like by hitting randomize. Once you 
have picked a flame you like, change the camera angle by hitting the camera tab. Adjust zoom, X, or Y.
5. It may take a wile to load your flame if your signature is big, so be patient. Once its loaded, it should 
look similar to this.

8. Yes its dul, but lets color it!!!! This is the fun 
part.....go to colors>colorize and choose your COLOR!!!!!!!!!!!!!!!
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YAY!!!!
9. Now add a picture!!!!!! FUN!!!! To do this, pick a picture from google image or somewhere else and 
put it in a -NEW- gimp window. Edit it, and then paste it in your sig.
10. Ok, your done....simple sig. Here are a few products...

5. Effects

5.1 Generate a stripe-like texture
Written by devvv (14 May 2007 11:50 PM) 

You'll often need some short techniques to create a website banner, a forum signature or wallpapers. In 
this tutorial I'll show you how to create such a simple "texture" in less than five minutes!
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1. Open up a new file: 500x500px.
Add a new empty layer.
Choose Filter / Render / Clouds / Solid noise.
Choose the values shown in the picture below:
(x:0.1, y:16, random)

click to enlarge
2. Go to: Layer / Rotate Layer or just press SHIFT+R. Rotate it for 25°

click to enlarge
3. Choose the crop tool, adjust it to a certain part of the picture so that everything inside the 

selection is covered by the texture. Press ENTER.

Optional: Filter / Enhance / Sharpen if you want to see more detail in your texture.

click to enlarge
4. Now choose (in GIMP 2.2: Layer /) Colors / Colorize.

Move the brightness up a bit and take a color of your choice! I've taken a soft blue.

Thats it!

click to enlarge

5.2 Creating a bloody splatter texture
Written by devvv (15 Jun 2007 11:49 PM) 

Today we will create a cool bloody texture that should look as there were random splatter all over the 
place.

1. Open a new file, any size. I used 377 x 233 px. Fill the background with #d0d0d0.
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click to enlarge
2. Use the Airbrush-Tool and use the brush named "Sparks". It is the yeloow one.

click to enlarge
3. Add a new empty layer and paint around randomly. It is important that the sparks overlay each 

other sometimes.

http://www.gimpusers.com/images/tutorials/77/1.png
http://www.gimpusers.com/images/tutorials/77/2.png


click to enlarge
4. Now click the "lock transparency" icon in the layers dialog. This option is found right above the 

transparency-changer.

Choose a new color as foreground-color: #680000.
- Edit / Fill FG-Color.

Everything should now be in a slight dark red.

click to enlarge
5. Now please deactivate the "lock transparency"-option again.

Go to Colors / Curves, choose "Alpha" as channel (top left). Apply the curve as seen on the 
picture. 
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click to enlarge
6. After that you're done 

5.3 Create a mystic chaos Voodoo-Pattern
Written by AtroCty (06 Jul 2007 07:34 PM) 

This tutorial shows you a simple effect which should look like mystical symbols of witches (Voodoo). I 
hope you understand it well, because it's my first (english) tutorial.

1. Of course we make a new file first. I take a size of 1000x400px, its the double size of a regular 
signature. (I do this for a better look, you can make it smaller later of course) Background-color: 
White

click to enlarge
2. Filter / Artistic / Cubism. Look at the values of the picture.
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click to enlarge
3. Filter / Blur / Gaussian Blur: 2px.

click to enlarge
4. Now the picture is little blurred. Do Filter / Edge-Detect / Edge... now and take these values. You 

can play around and take what you want.

click to enlarge
5. We're almost done now ;) But the picture looks boring without color. You can colorize it by your 

own. I took these values (Colors / Colorize):
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click to enlarge
6. Optionally you can duplicate the layer and set the layers mode (fint it at top of the layers dialog , 

above all layers) to "Addition". The pattern looks much more saturated then (see left side of the 
image below, the original is to the right).

click to enlarge
7. Done ;) Have fun with this kind of background!

5.4 Generate a cool tech pattern
Written by devvv (07 Jul 2007 01:13 AM) 

Someone often needs a cool pattern that can be used for a forum signature, a banner, a wallpaper or 
something else. This simple technique shows you how to make such "tech" pattern.

1. File / New: 500x300px. You can just work on the background layer. The color is irrelevant for 
this. Filter / Render / Coulds / Plasma. Choose any values.

click to enlarge
2. Filter / Blur / Pixelize: X:10 | Y:10

click to enlarge
3. Filter / Map / Bumpmap and enter the values of image below:
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click to enlarge
4. You should get something like this:

click to enlarge
5. Next apply: Filter / Edge-Detect / Edges:

Algorithm.:Roberts
Amount: 2
Wrap

click to enlarge
6. You can of course apply Colors / Brightness & Contrast to get some personal fine tuning. And 

also consider Filter / Enhance / Sharpen which looks cool too if you sharpen the image a bit.
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Below you see 3 different versions of this and how it could look like!

click to enlarge

5.5 A colored swirl of light
Written by devvv (05 Sep 2007 01:23 PM) 

Some effects are just very simple to do and look still pretty cool. This one here is such an effect, usable 
vor all kind of graphics things such as flyers, splash-screens, wallpapers etc. I'll show you how to create 
such an colored light swirl below!

1. Create a new Image. 640x480. You can take any size. Apply Filter / Render / Clouds / Plasma.

click to enlarge
2. Now do Filters / Distorts / Whirl and Pinch...
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Whirl angle: 130
Pinch amount: 1
Radius: 1

It should look like that now.

click to enlarge
3. Create a new transparent layer.

Use the gradient tool, use white as foreground color and black as background color. The fastest 
way to do this pressing D to reset colors and then X to swap the colors.

Form: Radial

Move the gradient from the center of the image to one of the four corners.

click to enlarge
4. Duplicate the layer. The original one name "fade black". For this set the layer mode to "Multiply".

The duplicate, which should be at the top, name "light".
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click to enlarge
5. Click the light layer.

- Colors / Brightness & Contrast, use values -65 / +45

Now apply Whirl and Pinch again. The values should be still saved from step 2, if not enter the 
same values. Only one value has to be changed: Pich from 1 to 0.8.

Apply the filter.

click to enlarge
6. Set the layer mode for the layer to Dodge. Duplicate the light layer to enhance the effect.

Activate the background-layer. Filter / Blur / Selective Gaussian Blur.
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Radius: 50
Max. Delta: 70

click to enlarge
7. If you want a single color use Colors / Desaturate, then Colors / Colorize or Colors / Color 

balance like me if you want an icy version:

Shadows -30 / -30 / +30
Mids: -30 / +10 / 0
Highlights: 0 / 0 / 30

Have fun.

click to enlarge
8. Here is just an example i played with: a splash screen for gimp 2.4 ;)

click to enlarge

5.6 Crazy Ions
Written by MaleXx (04 Nov 2007 02:00 PM) 
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This tutorial shows again which great things you can do easily with The Gimp. Also it is my 2nd Tutorial. 
Have a good time with it !

1. Create a new file with the size 500x500 Px (size doesn't matter but it has to be square)
2. Choose any color gradient and use the same parameters as in the image below.

click to enlarge
3. Create the gradient (click on a point in the image, hold and drag a line)

click to enlarge
4. click the right mousebutton on your image, then select Filters>Artistic>Cubism and use the same 

parameters as in the image below
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click to enlarge
5. click the right mousebutton on your image, then select filters>blur>Motion blur and use the same 

parameters as in the image

click to enlarge
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6. click the right mousebutton on your image, then elect filters>blur>Gaussian Blur strength 3
7. click the right mousebutton on your image, then elect filters>Edge-Detect>Edges and use the 

same parameters as in the image

click to enlarge
8. For simulating a light depth click the right mousebutton, then select filters>Blur>Motion blur> 

and use the same parameters as in the image
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click to enlarge
9. We're done ;) I hope you like the result!

click to enlarge
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5.7 Create futuristic looking tech pattern
Written by devvv (22 Feb 2008 11:45 PM) 

This is one of these simple to do tutorials, but the effect just looks cool and pretty futuristic. So I've 
written a tutorial for it. Enjoy!

1. Create a new image: 640x480 px. The Background should be plain white. Now choose Filters / 
Render / Clouds / Plasma.

Take these values: 10.000 / tubulence: 7

click to enlarge
2. Go to Colors / Desaturate: Brightness and choose OK.

click to enlarge
3. Now we're giving our pattern the special look which it will have at the end. We're using the Dilate 

filter, a very simple filter that smallens the dark areas in an image. Don't be confused if you look 
at the quick description when hovering the entry in the filter menu - I think currently in Gimp 
2.4.4. this is a wrong description.

Choose Filter / General / Dilate.

After this repat that filter 30 times. Use CTRL+F to repeat the filter quickly.
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click to enlarge
4. Got to Filter / Map / Make seamless.

click to enlarge
5. Sharpen the picture now using Filter / Enhance / Sharpen: ~85.

Now we're giving our picture some color: Use Colors / Color Balance
Shadows: -50 | 30 | 30
Mids: 0 | 30 | 50
Highlights: -65 | -40 | 20

click to enlarge
6. If you zoom into the image very closely you'll notice some gradients that are not very nice 

looking. 
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click to enlarge
7. To get rid of this we use Filter / Blur / Selective Gaussian Blur.

Values: 5 / Max Delta: 13

click to enlarge
8. Now we want to have some cool glowing edges so that everything look really future style like.

Zoom back to 100% (do this fast by clicking the "1"-key).

Click "duplicate layer" in the layers dialog or just use the hotkey: CTRL+SHIFT+D

On the duplicate use Filter / BLur / Gaussian Blur: 10.

Set the layers mode (directly above the opacity ruler in the layers dialog) to "Lighten only".

http://www.gimpusers.com/images/tutorials/109/6.png
http://www.gimpusers.com/images/tutorials/109/7.png
http://www.gimpusers.com/images/tutorials/109/8.png


click to enlarge
9. Thats all, we are finished! The softer result is in the left part of the picture below.

Option 1: If you want your edges to be sharper and more clearly looking use Filter / Enhance / 
Sharpen (40/50) again on the background-layer.

Option 2: If you want the whole picture a bit darker (less white glow and more saturated colors) 
simply create a new totally black layer above all layers and set the layers mode to "Overlay".

Have fun with this ;) Hope you enjoyed this easy tutorial.

5.8 Sun Ray Effect
Preview:

Although this is a very simple straight forward effect i though it would be good for people getting 
famillier with gimp to try something not too hard. i call this effect "sun Ray" its pretty common with so 
called web 2.0 websites these days.

i'm using Gimp 2.4 so i would advise downloading so there isn't any different. 

Step:

1 Open a new image at 400x400 and in the new image dialog under the advance section select Transparent 
fill.

http://gimp-tutorials.net/node/153#
http://gimp-tutorials.net/gimp24-download
http://www.gimpusers.com/images/tutorials/109/9.png


3 Now will want to activate the GRID by going to Veiw> Show Grid or pressing CTRL+SHIT+T, will 
also need the "Snap to Grid" feature active, go to Veiw>Snap to Grid. 



4 Now with the path tool will draw our first ray pay attention to where i drew my ray using the grid 
points. remember when drawing your path be sure to have it on "design" mode and to close it you must 
have it on Edit mode or hold down CTRL. 



once you have drawn your path in the path dialog click on "Selection from Path" 



5 Create a new player name it "1" 6 Change the forgound color to white,select the "Blend tool" or press L 
and in the the Graident dialog select the "FG to Transparent" Gradient. 

7 Now apply the Gradient from bottom to top as shown in the image below. 

8 now you can de-select the Ray by going to Select>None or Shift+CTRL+A 



9 now move the it to the center of the grid, it as shown in the image. 

Now what will do is basically duplicated the layer again and again to compleat a full circle 10 Duplicate 
the Ray and name the layer "5" 11 Now select the Rotate tool or Shift+R, now rotate the ray either by 
dragging to approximately the position i have mine at or use the rotate dialog to enter 83 for angle and 



Center both X and Y at 192 

12 Using this same technique create 13 more rays and use the grid to position them with equal space 
between each ray. just remember having make sure you adjust the center point to 192. 



this is just an example of how these neat sun ray effects can add a nice cool look to a design like a header, 
wallpaper, background ect. all i did was use a simple two colour light toned gradient named "Web 2.0 Wax 
Dark " that can be found in the 30 ultimate web 2.0 pack here on this site, adjusted the whole ray opacity 
to 50 and added a pre made speach bubble in the middle and thats it :) 

just one more last note i noticed alot of the other tutorials comments are asking for help i would advise 
everyone to use the help forum section for that. 

5.9 Glow Effect
Preview:

what started off as a experiment turned out to be a cool effect and worth a tutorial :)

http://gimp-tutorials.net/forum/16
http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp
http://gimp-tutorials.net/node/153#


step 1 Will start off by creating a new image and filling it with a solid Black color. i started off with 
420x300 so it fits the sites width. you might want to use your final outcome as a wallpaper so try 
1600x1200 then zoom out to 33% to get the a decent few of the whole image. 

2 Now will want to create the Lines using the "Path Tool" but first Create a new Layer, name it something 
like "Middle line" then select the "Path tool" and add one point above the image area and another at the 
lower bottom, drag the bottom point to the right to get a similar curve as mine. 

3 Now we need to create a new thin brush to stroke the path with. go to the Brushes dialog and at the 
bottom you will see a little "New brush" icon, click on that and enter all the values shown in the image 
below. once your finished name it and save. 

http://gimp-tutorials.net/node/123#


3 Change your Foreground color to solid white, Make sure the new brush is selected, then go to 
Edit>Stroke to Path, now inside the Stroke to Path dialog click on the "Stroke Path with a Paint tool" 
radio button and finally press Stroke. 

4 Now for the outglow of the lines will Create a new layer, change the foreground color to 5babe8 and in 
the brushes dialog you should have a brush named Circle (05) if not then create a new brush with the 
following values 



now as we did in step 3 will repeat it again, go to Edit>Stroke to Path, now inside the Stroke to Path 
dialog click on the "Stroke Path with a Paint tool" radio button then finally press Stroke. 

5 Once you have the solid light blue will add the glow effect by using the "Gaussian blur" this can be 
found in Filters>Blur>Gaussian Blur".change the values to 10px for both Horizontal and vertical fields. 



you should have something like this now 

6 Draw two more lines with the Path tool and Repeat the same steps done earlier to achieve the same 
glow effect on the lines. 



7 Using the radial tool will create three spot light effects, one in the upper right corner , the second in the 
upper left corner and the third in the lower left corner, will do that by first creating a new layer, then 
grabbing the "blend tool",changing the foreground color to white and the background to black, make sure 
you have the FG to BG (RGB) Gradient and changing the the gradient shape to "Radial". once you have 
all that set apply the blend tool as shown in the image 

8 now that you have applied the radial blend in the upper right corner change the layer mode to 
"Addition" you will find this option in the Layer dialog. 



9 New Layer, create another spot light in the bottom left corner, drag the blend tool starting from the 
middle . then set the Layer mode to "Dodge" 

10 Create another new Layer for the final spot light, this time apply the Blend tool in the upper left corner 
where the two lines join and change the mode to "dodge" 



11 Will add some particles using different sizes of brushes, just select the brush we first created or any 
tiny 2 radius brush select the color white and paint random dots here and there,for the bigger particles 
change the size and the opacity in the "Tool Options dialog" to get a better effect. There you go, you're 
done! 

Like everything there is always room for improvements here i added some text and applied all the 
techniques we just learned . 



hope you found that useful :) if there is any mistakes or something un clear let me know. 

-Members can download the attached Xcf source file of this tutorial below

5.10 Lightning

 
This tutorial should show you the creation of naturally looking lightnings breaking the clouds.

  

First, create a new image and fill it with a gradient like shown here. I've chosen 0:0:0 as foreground color 
and 191:191:191 as background color.



  

Now, create a second layer above the gradient. Set its mode to 'difference'. Render a plasma <Image>-
Filter-Render-Clouds-Plasma... and desaturate it.

  

You should get something like this. Try out different plasma to achieve the desired shape.

  

Merge the both layers and invert the colors.



  

Here comes the tricky stuff. You have to play around with levels. I propose to start with the values shown 
here.

  

Your (possible) result.

  

Play around with color levels and/or curves to get a blue shining into your image.



  

That's all! Rotate your result, blur it, rescale it... Have fun!

5.11 Gimp Fire
Step 1 - Creating a new image

 

The Gimp has steadily grown in popularity over the years. It is available on many platforms, including 

http://www.gimp.org/


Windows and Mac OS X. There's been a lot of great websites for tutorials on The Gimp over the years, 
but one tutorial that seemed to be lacking is a good realistic fire tutorial. 

Step 2 -Using the transparent layer

For this tutorial, I'll be using a 256x256 pixel image, with a plain black background, as illustrated here. 
Now, that you have you're starting image, add a transparent layer, which we will use to put the gradient 
on, for the flames. Note that this image has two layers. 

Now, to make the flame truly usable, we're going to want to render it on the transparent layer. This way, 
we can put the flames on top of another image, and just generally manipulate it much more effectively 
than we could if it was on the black layer below. 

The next thing we're going to do, is select the gradient to use. To start out with, I opened up the 
'incandescent' gradient (you may have to copy this gradient before you can edit it) in the gradient editor, 
and set the black end to Alpha (transparent). Then, I tweaked the amount of white in the gradient on the 
right hand side. Anyone who's ever seen a plain fire, knows that there is very little white in the flame, and 
only where it is hottest. I then saved the modified incandescent gradient as 'fire'. Here, you can see it in 
my gradient list To save everyone the hassle of tweaking the gradient yourself, I'll provide a download 
link to the finished gradient that I use at the end of the tutorial. 

When you are preparing to use the gradient tool, it's very important that you have the settings for the tool 
properly configured. You don't want to use a radial gradient (circular) to render a flame, you'll just end up 
with something slightly resebmling a sun. You have to make sure that you have the gradient tool set to 
use a Linear shaped gradient. If you haven't used the gradient editor very much, then the default values 
should work ok. Here's an illustration of the proper setup of the gradient tool.

Step 3 - Selecting the gradient



Once you have the gradient tool set up, you need to draw the gradient on to the transparent layer. You're 
going to want to start about half way from the top of the image, hold your left mouse button down, and 
drag down to almost the bottom of the image. You want to get the gradient drawn as level as possible. 
You'll get some assistance from the gradient tool by the guideline it draws showing the start and end 
points of your gradient. Just try to make it as close to a straight line as possible. If you screw up, or don't 
like the way that the gradient came out, just Undo the gradient, and try it again. It's very important that 
you Undo the gradient you have drawn, because if you don't, you'll just draw another gradient on top of 
the old one, basically blending the two together. The results of that aren't all that good looking.

You can download the actual gradient file I use here: http://www.jraleigh.com/fileman/Flame.ggr. Just 
right click, and save as. On unix systems, this goes in your ~/.gimp-2.0/gradients/ directory.

Step 4 - Setting up the gradient tool

http://www.jraleigh.com/fileman/Flame.ggr


I've provided an illustration to help give you an idea of what you are trying to accomplish. As long as 
what you have looks relatively similar to the illustration in Step 5, you should be in business.

Step 5 - Draw the gradient

 

Step 6 - IWarp Move tool - Before 



Now that we have the gradient drawn, the real fun begins. You'll need to use the IWarp plugin, which 
can be found by Right Clicking on the canvas area of the image. When the menu opens up, just go to 
Filters->Distorts->IWarp. Once you open the IWarp plugin, you should see something like this. To 
simplify things, I have circled the tool you need to use first, which is the Move tool. I have also drawn in 
the pattern you will want to use to get the desired effect. If you hold your left mouse button down and 
follow the guidelines as illustrated, you'll be in business.

Step 6 - IWarp Move tool - After



Your results should look something like this. You may have to go over the same spot a couple of times to 
rough up the gradient a little bit, but you should be getting the idea here. If you get your image all 
screwed up, just hit the Reset button, and it will revert to it's original state. Keep in mind that this will 
undo all of the distorts you have done with the IWarp plugin. 

Step 7 - IWarp Swirl tool CCW

Now, the next thing you need to do, is add some life to those flames. To do this, you just use the 
SwirlCW and SwirlCCW tools. These are pretty self explanitory. SwirlCW means swirl clock wise, and 
SwirlCCW is swirl counter clockwise. This gives the flames the realistic look that we are aiming for. 
Now, this part is probably the hardest part of creating realistic flames. I have provided some guidelines on 
this illustration to give you an idea of how to move your mouse. Keep in mind that they are just 
guidelines, so feel free to experiment with them.

Step 8 - IWarp Swirl tool CW



Ok, we're pretty much doing the same thing as step 7, but we're using the swirl CW tool instead. this is 
pretty much the last step in this tutorial. Once you get the flame looking how you want it to, just hit Ok 
and The Gimp will render out the flame. 

You're Done!

Finished sample

Well, that's all there is too it. I hope everyone finds this tutorial easier to use than my original version. As 
with the original, this document is free to use in any way you see fit. Feel free to mirror it, print it, 
publish it in books, etc. All I ask is that you leave this line in it.

5.12 Drop Shadow
This tutorial is an updated version of Stauns' drop shadow tutorial. It will show you how to create simple 
drop shadows for just about any shape. 

1. To start with, the shape you're creating a shadow for needs to be on a single layer, if it's not, then you'll 
just need to repeat the steps detailed here for each layer that requires a drop shadow. Here is the shape I'm 
going to use: 

 



2. Next, you need to duplicate the layer. Select your chosen layer in the layers dialog, then click 
"Duplicate Layer". The new layer should now be active. Now check the "Keep Transparency" checkbox. 
The layers dialog should look like this: 

 

3. With the duplicate layer still active, press Ctrl+A to select the entire image. Now select the bucket tool 
and open the bucket fill options dialog. In the "Affected Area" section, make sure "Fill Whole Selection" 
is selected. Go back to the image and click anywhere. The shape on the duplicate layer should now be 
filled with black: 

 

4. Uncheck the "Keep Transparency" checkbox on the layers dialog, and blur the entire layer by Right-
Clicking, and choosing Filters->Blur->Gaussian Blur (IIR). A setting of 10x10 should be sufficient. I 
repeated the blur step four times, but do whatever looks right for your image. I've hidden the blue shape 
layer in the next screenshot, so that you can see the blurred image properly: 

 

5. Move the shadow layer behind the shape layer by using the down arrow in the layers dialog. Select the 
shadow layer, and then select the Move tool. Select the image and move the shadow layer down and right 
slightly. I used the arrow keys and moved the shadow down and right by 4 pixels each, in the following 
screenshot: 



 

6. Either add a new, white layer behind the shadow layer, or you can fill the background layer with white 
using the fill tool. Either way, it should come out looking something like this: 

 

If you'd like to play around with the original XCF file for this, then you can download it here

5.13 Wallpaper
Step 1

Open GIMP 2.4 and if you don’t have it, download it and give it a try.

Create a new document, in my case I used 1600x1200, and using the Bucket Fill Tool (Shit+B), fill the 
background layer with a very dark purple.

http://gug.sunsite.dk/tutorials/cmarshall2/DropShadow.xcf


Step 2

Using the Free Selection Tool (F), draw a shape like the one I did. That will be the source of our light, so 
the position here is very important. Try to place it more at the bottom of the image. After that, fill it with 
white. Tip you can add a blur or a feather to the selection.



Step 3

Go to Filters>Render>Clouds>Difference Clouds and apply the filter. Select Randomize, Turbulent 
and Tileable.



Step 4

Go to Filters>Blur>Motion Blur and change the settings to: Blur Type ZOOM and the length to the 
maximum. It will take a little bit to generate the effect. 

This will generate that light burst.



Step 5

After that go to Colors>Colorize. Now we will add colors to our light. Change the hue, saturation and 
lightness settings until you get a sort of dark pink.

Hue: 311 Saturation: 62 Lightness: 33



Step 6

Now lets just duplicate layers, scale and rotate them. The shape you use will define how many times you 
will have to do that. In my case I had to duplicate and rotate twice. Besides that, I duplicated each layer 
once to make the light stronger with the Blending mode.

I have in my file 6 layers and the blending mode for each in order is: Screen, Hard light, Normal, 
Normal, Screen, and Screen.

You can use the erase to correct some issues with the layers.

Step 7

Here I changed the color of the second layer to a red using the Colorize again.



Step 8

Duplicate one layer, and using the Colorize again, lets create the blue light. As in the step 4, just change 
the hue, saturation and lightness until you get a blue color. Don’t worry if the color is not strong enough, 
we will duplicate the layer to make it stronger. For the blue light I duplicated the layer twice, so I have 3 
layers for that light. The order of blending options is Normal, Dodge, Dodge.



Step 9

Now lets add the stars. Create 2 new layers and fill them with black. One will be for the small stars; the 
other for the big ones. Change their blending mode to Dodge. Set white for the foreground color and 
select the Paintbrush Tool (P). 

When you select the Paintbrush the Tool Options will open. There you will change the parameters. 
Specially the Apply Jitter. The image below shows the values for the big and small stars.



Final Result 

I know that it does not look exactly as the Apple's wallpaper, but it's pretty close. However the most 
important thing here is that the new GIMP is an excellent tool, we can create all sorts of effects with it 
and it's free. The only thing that bothers me is that it still needs the X11 to run on my mac.



Click on the Image to to see it bigger.

Download the GIMP file here 

5.14 Galaxy
Although I really like the Adobe’s main product, I have seen a lot of articles about GIMP, that stands for 
GNU Image Manipulation Program, and people creating amazing effects using this tool. So I decided to 
give it a try. 

I have to say, it’s possible to achieve very good results using GIMP. There are great variety of Filters, 
some of those I wish Photoshop had. However the interface is not that friendly. It lacks a lot of features 
like organizing layers in folders, the layer styles and running native on Mac OS X, if you compare to 
Photoshop. 

But I don’t want to compare or review software here, I just want to show my first creation using GIMP 
and how I did that. The idea for the image was inspired by the new Mario Galaxy game.

1- Open a New Document, I used 1440x900.

http://e3.nintendo.com/wii_supermariogalaxy.html
http://www.gimp.org/
http://abduzeedo.com/files/apple_gimp.xcf.zip
http://abduzeedo.com/files/u1/abduzeedo_boreallis_gimp.jpg
http://abduzeedo.com/files/u1/abduzeedo_boreallis_gimp.jpg


 

2 - Create a Gradient: Set the shape to radial, and choose black for the background and any color for the 
foreground.

3 - Adding some smoke: add a new layer, set the foreground to white and go to 
Filters>Render>Clouds>Solid Noise. Set the layer mode to Overlay 44%.



Set randomize, 1 to detail, and X and Y size to 16. 

4 - Creating the Beam of light: Create a new layer, choose the Create and edit paths tool (B) and draw 
a triangle to be the beam of light. After that create a selection clicking on the button to create selection 
from the path. Fill the selection using the Fill tool (shift+B) with a blue color.



6 - Create 2 copies of the Beam of light layer, and apply the Gausian Blur to them. Set Overlay to the 
layer that is in the back, and Dodge to the others. This will produce the lighting effect.

7 - Creating the sparks: Add a new layer. Using the Paing fuzzy brush strokes (P) to create the sparks 
like the picture bellow and apply Dodge to the layer mode.



8 - Add colors to the sparks: Using Filters>Colors>Colorify to change the color of the sparks.



Tip: Duplicate the layers and add a little blur to create that glowing effect. 

9 - Creating the light circle: Create a new layer, go to Filters>Light Effects>GFlare, choose 
hidden_planet in the selector tab. Try some different setting values or like the ones I used. Set the layer 
mode to Dodge.

11 - Resize the Layer to add the perspective.



12 - Some dust: Duplicate the light circle layer and add a Filters>Blur>Motion Blur. Type linear, and 
angle 90. The layer Mode is Dodge again.



13 - The Supernova: Add a new layer, fill it with black, go to Filters>Light Effects>Supernova. Again, 
try different values and choose the ones you like or follow the image bellow. After that apply Screen to 
the layer mode.



14 - More depth: In a new layer, use the Gradient but this time with a blue foreground and black 
background, create a radial gradient from the top left corner to the bottom right. Set the layer mode to 
Screen with 65%.



15 - Add some noise: Add a noise Filters>Noise>Hurl to the first layer, the background gradient of the 
image. 

16 - The Final Result:



If you want to create the stars, like in the Final Result image, just follow the photoshop tutorial about 
how to create the Leopard Starburst effect in Photoshop. It's exactly the same in GIMP. 

The GIMP file can be downloaded here (13mb), and the icons can be found at iconbase.com

6. Textures

6.1 Textured Design
Preview:

In this tutorial i will create a textured background with a very neat abstract touch to it. the end results 
probably isn't that useful for anything other then wallpapers but nonetheless if your still learning how to 
use gimp then this tutorial is another great exercise for you.

before i get started ill just remind you that my original image size it 1024x678 but I've resized the images 
for the sites width.

Step 1 create an image area of 1024x768 or if intend to use it as your wallpaper then which ever 
resolution your on will do.

Step 2 set your foreground color to 931818 and your background color to 000000

http://iconbase.com/
http://abduzeedo.com/files/gimpTutorial.zip
http://abduzeedo.com/leopard-starburst-effect-photoshop
http://abduzeedo.com/files/gimpTutorial.jpg


Step 3 grab the "Blend tool" and in the Tools option dialog make sure your Gradient is set to FG to BG 
(RGB) and the shape to Radial.

Step 4 Apply the Gradient from the center of the image area to the bottom corner.

Step 5 Still with the blend tool selected, create a new layer then change the Gradient to a pre made gimp 



gradient named Abstract 2. now apply it from top to bottom

Step 6 now make sure you have the last layer we created highlighted then go to Filters>Distorts>Emboss.
now in the Emboss window set the Azimuth to 256.76 Elevation to 132.35 and depth to 84 then press 
ok.

once you've done step 6 your once rainbow looking gradient is now a cool texture like with some cool 
abstract lines.(image is zoomed at 100%)

Step 6 now set the layer mode to "OVERLAY"



this is how it should look once you set the mode to overlay. ( image zoomed at 100%)

here it is wih the image at %50 

Step 8 we're almost done, create a new layer and game your foreground and background color to black 
and change the gradient to FG to Transparent and the shape to Liner.



Step 9 Apply the gradient from the lower right corner to the center of the image area, this is where the 
text will go so adding the extra dark shade would help the text blend in more.

finally pick a nice font for the text, i used "Diavlo" which you can download from Here ,the colors i used 
are white as you can see :)
here is my outcome, you can click on the image below to enlarge it.

Click here to Enlarge

as always the final XCF source file is attached below for download. please if your very new to gimp and 

http://gimp-tutorials.net/tutorials/wallpaper-design/simpledesignfull.png
http://www.josbuivenga.demon.nl/diavlo.html


have a lot of very basic questions please post your questions in the Gimp forum section Gimp forum 
section this helps keep the tutorial pages for quick questions only.

6.2 Make a Gimp pattern from scratch
in this tutorial i will show you how to create a metal like textured pattern from scratch as well as adding 
text with an engraved effect to it.
this could be useful for websites background that repeats as well as signatures,headers etc.
will start by first creating the actual pattern design and then how to save and place it in the correct folder 
and finally creating an example using the pattern with some text.

lets get started.

Step 1: Create a new 8x8 image.

Step 2: so we can see what where doing will set the zoom level to 1600%, you could make it bigger if 
you wish.

now will get to the part where it becomes very repetitive and sort of boring but its worth it, what will do 
is create two different pattern boxes which have 8 different colors
with in them. once we have these two boxes will duplicate them to create a checkered pattern.

here is what were trying to do.

Step 3: Grab the "rectangle selection tool" and draw a s small 1px square and fill it with the color 

http://www.gimper.net/
http://www.gimper.net/


4C4C4C using the "bucket fill tool"
Tip when creating your selection hit enter to start editing within your selection.

Step 4: again create another 1px square but this time add the color 494949

Step 5: create another 1px square with the color 383838

Step 5: create another 1px square for this box and fill it with the color 373737



now that we know how to create and fill these little 1px boxes will want to create another four using the 
colors shown in the image below.

Step 6: if you have reached here then your pattern is almost done :) will want to grab the "rectangle 
selection" tool
and draw a selection over both boxes we have made.press enter once you have it selected.

Step 7: With the selection still active on the two boxes Press CTRL+C to copy and then CTRL+V to 
paste it, then
in the layer dialog you will need to click on "new layer". 



Step 8: with the "move tool" or shortcut (M Key) move it to the right side. as you can see by now will be 
able to
duplicating the boxes to create the checkered pattern i showed earlier .

Step 9: to make it easier when copying cretin parts , will need to flatten all the layers.
this can be done by right clicking on the new pasted layer and selecting "Merge visible layers"



so now you know how to copy and paste selected areas will want to duplicate it many times to create a 
fully checkered pattern.
just be sure to create a new layer as well as flatten when pasting copied selections. here is how it should 
look.

Step 10: save the file to your desktop as .Pat

right, we've finished with our pattern design and have saved it using the .pat format for gimp patterns, 
now will need to place it in the correct folder so that is shows up in gimp pattern dialog.

Step 11: in the gimp tools box click on File>Preferences, when the preference windows shows up
go to folders, and notice the path of the pattern folder, in my case it was C:\Documents and 
Settings\Administrator\.gimp-2.4\patterns place the pattern we created in that folder following that 
path , close gimp and re-open it again and it should
be inside gimp's patterns now.

http://gimp-tutorials.net/gimp-pattern#


so we have our pattern working perfectly in gimp, now ill make a simple banner/sig using the pattern as 
an example for this tutorial

Step 12: Create a new image 500x100, go to your pattern dialog and drag out pattern to the emptey image.

Step 13: now for the text i chose the color e8e8e8 and the font "Trebuchet MS Bold" and the size at 48px 
as well as 6.0 for letter spacing.

http://gimp-tutorials.net/gimp-pattern#


this is how mine looks.

Step 14: Right click on the on text layer and select "alpha to selection" then in the menu click on 
select>grow to 4

Step 15: Create a new layer and make sure its behind the the text layer

http://gimp-tutorials.net/gimp-pattern#


Step 16: set your foreground color to black and in the gradient dialog select the "FG To transparent" then 
with the blend tool drag from top to bottom.

do the same for the gimp text and thats it your done its really simple i know but I'm sure someone might 
find it useful.



source files attached below. enjoy:)

6.3 Snake Skin
Create a first layer

 

filter->render->plasma & image->color->desaturate & image->color->color balance (use green and 
yellow)



filter->render->mosaic Create a second layer

 

filter->render->plasma & image->color->desaturate & filter->map->bump map on first layer with second 
(increase depth) & hide second Create a third layer



 

use linear gradient tools (foreground to alpha) to make a nice drakening area

6.4 Water Surface

 
We all know that with the GIMP you can make some nifty water-like effects using "Filters->Distorts-
>Ripple" or "Filters->Distorts->Waves". But sometimes that doesn't give you what you want...especially 
the "waves" filter. Sometimes you want to achieve the look of water as seen from directly overhead. Not 
only that; the filters can make the end result appear more 'mechanical' than natural.

This tutorial will explain one method of making a water-like texture that contains both larger waves and 
little "wavelets". The final image will remind you of what you might see looking down from a high point 
onto a body of water below.



 

First, fill the image with "Filters->Render->Clouds->Solid Noise".



  

Next, change the positions of some of the pixels using "Filters->Noise->Spread". This will work out best 
if you use a value for the 'horizontal' input approximately ten times that for the 'vertical'; e.g., in this 
image, I used "90" for the horizontal and "9" for the vertical.

 

Apply RLE Gaussian blur to the image. Smaller values will work better in this step. You want to achieve 
some "chunkiness" rather that smoothing everything completely, since the chunkiness will make the 
image look more like little waves of water.



  

Bump-map the image against itself. Crank the "Elevation" and "Depth" way up to produce a more 
'watery' effect:

 

Use the "Curves" tool (Image->Colors-
>Curves) to enhance the watery look; note I'm 
only changing the 'value' curve, and not any of 
the red/green/blue curves:



 

Finally, use the "Levels" tool (Image->Colors->Levels) 
to add some color; I added a little bit of green and a little 
bit of blue. Add the color by moving the dark triangle the 
right on the 'Output Levels' slider bar. You may also want 
to change the 'value' settings here to improve the contrast 
(i.e., to make the highlights lighter and the shadows 
darker); alternatively, you could do the same using 
"Image->Colors->Brighteness-Contrast" or the "Curves" 
tool again.

One final note: as in most things with the GIMP, experimentation and Ctrl-Z (undo) are your best friends. 
:-) Enjoy!



6.5 Create a web 2.0 stripe header with Gimp
In this tutorial I will show you how to create your very own web 2.0 stripe header, you may see this effect 
a lot on many web 2.0 websites as it is a very popular technique. I will show you how to create this in 
The Gimp. You can download the source (XCF) here: download, when finished it will look like this:

1. Firstly, create a new file. I am creating a 860px x 150px canvas as the website is designed for 
resolutions 1024 x 768 and above, if you are designing for lower resolutions then use a smaller 
width. 

2. Next I am going to set the colours, to do this go to the main Gimp window (Ctrl+B) and change 
the forecolour to 31bcc8 and the back colour to 217077 so that the colour chooser looks like this:

 
3. Next select the gradient tool (L) and drag from the bottom of the canvas to the top so it looks like 

http://help-developer.com/wp-content/uploads/2008/02/header.xcf


this:

 
4. Now we will add the stripes so create a new layer and call it Stripes. 
5. Go to the main Gimp window and click the fill button (Shift + B), in the options change it to 

Pattern Fill and select the Warning pattern:

 
6. No click on the canvas and it should fill with this pattern. 
7. Select “Colour to Alpha” from the “Colours” menu, click the big button with the white rectangle 

on it next to the word “From:” and type into the text box next to “HTML notation” the value 
“ffff00″, without the quotation marks and click OK. 

8. Go to the layers window (Ctrl + L) and change the transparency of the Stripes layer to “3.0″, It 
should now look like this:

 
9. Go to the main Gimp window again and select the gradient tool (L) and change the Gradient 

option to “FG to Transparent” and drag the tool from the bottom of the canvas to the top. 
10.It should now look like this:

 
11.Now create a new layer called Top and draw a rectangle the full width of the canvas and the top 

half of the canvas and fill it with the colour #FFFFFF 



12.Go to the layers window and change the transparency of this layer to “5″ and your finished. The 
outcome should look like this: 

 

Thats it, you can change the colours so that it fits your website template. You can also apply this effect to 
any component such as buttons, advertisements and many more.

7. Painting

7.1 blend colors
Preview:

  

In this tutorial Im going to show you how I blend colors in order to get better looking paintings.

This process can be also achieved in other raster programs like photoshop, and thus its not rare, its in fact 
widened usen. I normally find blendings done using the smudge tool, or the blur tool, but using them 
solely doesn't gives great results. 

We start with the 2 colors we want to blend in, they might be similar or very diferent. In this case I chose 
a light blue and a nice red. 

http://gimp-tutorials.net/node/128#


 

  

Next we set up with a brush with an opacity around 30 to start with and a quite wide brush in relation to 
the area to fill. We are going to move the mouse as the arrows show (image below) on a zig zag 
movement. If you are using a tablet you can tap short strokes from one color to another. 

In this case we start blending using red, so we are going to paint zig zag short lines from the blue area. 



 

  

Next before starting the next set of lines we have to grab one from the pic. with the brush tool selected 
press (Ctrl + click) to grab a color. pick the lightest red (in this case is placed at the top most place). move 
it as to invade some red to start blending it. 



 

Notice the green circles on the above image, those are the places where I grab colors. In order to repeat 
the zig zag movement and get a better blending, keep resizing your brush smaller as you keep blending in 
orde to get better overall look. 

Remember to keep your strokes short and picking different percentages of blending. 

  



Keep repeating until it blends. As your tip gets thinner you get a smoother result, and once is smooth 
enough you can use blur or smudge tool to finish the job in case you want perfect gradients. 

 

As you can see the blending we start is taking more shape as I keep detailing. 

At the top and at th ebottom I used a tablet with pressure set to opacity to get a faster blending, its the 
same technique with a little help. You can try to emulate this with a mouse by using "fade out". Also you 
can use "jitter" to get a more random result, witch helps to get the illusion. 

Test diferent blendings using dierent values, change the hardness of your tip and even try it alternating 
with other tools such as smudge and blur. :] 

I hope this tutorial was clear enough, its the first tutorial I make. 

7.2 Paint Cactus
In this tutorial, you can have an in depth walk through of creating a digital painting of a cactus.

The final artwork would be as follows.



Without waiting further, let us start the editor with a large enough canvas size - a little larger than 
480×640 pixels. Always start with a canvas larger than the final required resolution.

Draw a sketch of the basic shape of the cactus in a new layer. Use reference images if required.

Do not bother to add details. Just get the basic shape roughly. You do not need to have a clean line art 
either.

Next take a large brush, select a dark green color, and paint to fill the boundaries in a separate layer.



Do not worry if it goes out of the sketch boundaries.

Take a lighter color, more yellow than green and paint the area which is facing the light source - the sun.

Make a note of where the smudge and smoothen/convolve tool is in your tool panel.

Use those tools to get a smooth gradation. In digital painting, it is better if you do not use the gradient fill 
and paint the different colors and smudge the gradation yourself.

Now mark out the darker areas of the cactus - the area away from the sun.



Again, use the smudge and convolve tool to give it a cylindrical shape.

We will be adding detail to this basic form.

As you start to detail, you need to keep selecting the smaller brushes. Note that only normal round 
brushes of different sizes are used. Take a light yellow green color and draw the crease from top to 
bottom at the left edge of the main cactus stem. Draw similar lines, and every time choosing a darker 
shade of yellow green. This would serve as the highlight area, and as we move away from the light 
source, it becomes darker.

Does it look ugly? Do not worry - we will fix that soon.

Now take the same brush and a darker shade of green and draw lines adjacent to the lighter lines. The 
dark lines should be on the right side of the light lines, away from the light source. The light lines and the 
dark lines should be touching each other. The logic behind this is that wherever there is a bump up, one 
side would have highlight and the opposing side would have a shadow.

Note that I continue to draw the shadow lines on the dark side of cactus with an even darker shade of 
green. It is a very dark shade of green - it is not black. Avoid choosing a color from the edge of the 
palette. Avoid using absolute white or absolute black. You never know when you need to go a shade 
darker or a shade lighter.



Do the similar process with the smaller cactus appendages. Use a smaller brush if needed.

It is time to make it look less ugly.

Use your trusty smudge tool to blend the different colors. Now it looks like nice creases on the cactus 
surface.

Now that we are getting the basic shape of the cactus, and have made it recognizable, it would be time to 
loose the sketch. Before that, let us give it a little more definition.

Take a dark shade of green (not black) and with a small brush, mark out along the sketch lines. Try to 
have only a single line - confident strokes.



Switch off the sketch layer - make it invisible. Use your smudge tool over the dark outlines you had 
drawn.

It is time to clean the mess.

Select the eraser tool and remove the paint area that is outside the dark outline you had drawn. Use a soft 
edged eraser when you are cleaning near the edge.

We will visit the cactus again, to give it more detail. But before that, let us set some mood to the lonely 
cactus and give it some foreground and background elements.

Choose a range of colors from yellow-orange to yellow-brown. Paint the sand/mud in front of the cactus 
in a new layer. The places where it meets the cactus, carefully trace the creases of the cactus. This will 
further cue the viewers brain to think that it is a 3d form.

Paint a little more than I have shown above. After that, create another new layer - this time, behind the 
cactus layer.



In that layer, use the same set of colors, but with a bit lower saturation and paint the ground. Basic rules 
still apply - lighter shade near the source of light, darker shade away from the source of light.

It is time now to make the sand/mud to look more grainy instead of a smooth surface.

Use your paint brush, smudge, and convolve/blend tool and render a bumpy surface in the foreground. 
Leave the background as it is - as the object goes away from the viewer, the detials get blended together. 
Hence, we should not be detailing the background too much.

Use a small brush, and detail the hightlights and shadows casted by the small pebbly surface.



Use the blend/convolve tool and blend it a bit. Take a soft large brush, and in the background layer, draw 
the shadows casted by the cactus. This gives it the depth.

Create another background layer behind all other layers.

Paint the sky. Use different tones of desaturated blue, and with a large brush, paint the sky. Do not use a 
gradient.

Use smudge and blend tools to smoothen the sky.

For the next step, you can either choose to paint in a seperate layer, just above the sky layer, or paint it on 
the sky layer itself.



Take dark desaturated green and draw the faint shapes of the cactus that are far away. Use a soft edged 
brush. You do not need to give too much detail for the farther ones.

I did say, we will get back to our main cactus - did I not? Well, now is the time. Switch back to the main 
cactus layer.

Take a fine brush, and a very light yellow color and mark out the thorns using a single stroke. Like the 
creases, mark them out only on the lighter side of the cactus. The thorns are not to be drawn at random - 
they have a pattern. Now might be a good time to go back to any reference images you have started out 
with.
What applies for the creases, applies for the thorns too. Since we have drawn the highlight area of the 
thorns, we will now draw the shadow areas.

With the same brush, but a very dark brown color, draw the thorn. Zoom in if you need to. The strokes 
should be on the top-right side of the light colored strokes. Choose a darker color and draw the thorns in 
the shadow areas. Draw few thorns on the edges of the cactus.

You are done. Crop it and sign it.

Export it to whatever format your editor is compatible with.

7.3 Drawing Trees
We'll mainly use two Inkscape tools: 'random tree' to make the trunk, and 'fractal (Koch)', used to make 
the foliage.



1. Effects-> Render-> 'Random tree' gives you a slightly different tree within the two parameters you 
specify. The 'initial size' parameter will be the overall size of the tree, and the 'minimum size' parameter 
will determine how many times the branches fork on average. This is easier to demonstrate than explain, 
so here's some typical examples:

Yes, lower numbers for 'minimum size' give you more branches. Is this a bug, or were they just playing 
with us?

Of course, these objects are paths, so if you didn't get the exact shape you had in mind you can always 
use the node edit tool to alter it.

When you have the branches in the position you want, conform your stick diagram into something more 
like a real tree by selecting it, hitting Ctrl-L a few times to smooth the path, then Ctrl-) (Control-Shift-
right parenthesis) to outset the path. Maybe outset it a couple of times to get a thicker trunk.

2. Move to another space in the drawing and use the Bezier lines tool to draw out a line segment with a 
couple of angles in it. We're going to use the C-curve method. Something like this:

3. Now with the segment selected, pick Effects-> Modify Path-> Fractal (Koch) load pattern. The pattern 
will load, taking a second. Select the segment again and Effects-> Modify Path-> fractal (Koch). Repeat 
that last move a few times.

4. When you have the top of the foliage shaped, hit Ctrl-D to duplicate it, hit Ctrl-] (Control- square 
bracket) twice to flip it over, move it below, but overlapping, the top shape. Then select them both and hit 
Ctrl-+ (Contol-Shift-plus) to paste them together.

5. The shape you probably ended up with looks a little too geometrical, so let's rough it up. Go Effect-> 

http://en.wikipedia.org/wiki/L%C3%A9vy_C_curve


Modify Path-> Radius Randomize. Use a value of between 5.0 and 10.0 in the dialog. this will stagger the 
path's nodes, making it a little chaotic. You can then smooth it a little with Ctrl-L a couple of times.

6. Use the fill 'n' stroke dialog to change the colors of the tree parts (I kept them in black outlines so you 
can see how they go), and bring them together. Hit Page-Up with the trunk selected to move it onto the 
layer on top of the foliage.

7. Here's the finished example after I exported the bitmap from Inkscape and got it into Gimp, where I 
ran some effects on it. The effects were the cloud noise and hurl filters on the foliage and bump-map on 
the whole thing, if anybody's interested.

Now, this is OK for a quick drawing, but a realistic tree is beyond the grasp of this - and possibly any - 
tutorial. When it comes to natural elements, you get out of them what you put into them. Use this for a 
starting point for a basic technique, then elaborate to taste.

Here's one I've done with a lot more work put into it. In Inkscape, I did some detailed node editing after 
generating the shapes. I then exported three separate layers. In Gimp, I built the layers with the trunk 
sandwiched between two layers of foliage. I then applied a few more filters to rough up the texture of the 
various layers and different levels of bump-mapping to the front and back foliage layers. Then I finally 
just did some good old-fashioned brush work in Gimp.

8. Misc

8.1 ADVANCE ORB
You really need to see the end results to appreciate this tutorial, the preview image doesn't show 
much :),this Gimp tutorial is meant for Intermediate and above users, but never the less i advise beginners 
to have a go at it since i do try my best to explain the steps in detail.
Many of the steps are Repeated and all the technical words get abit boring after a while so hang in there, 
the results are worth it. now lets get started shall we?

Step 1 Create a new image Area with the size of 420x321 and fill it with the color black.

Step 2 Grab the Ellipse Tool from you Tool box or Press (E), Draw a 200x200 prefect circle, you can 
enter the values in the tool options dialog.



 

Step 3 Grab the Blend tool and in the "tool Options" dialog change the Gradient to FG to BG (RGB) and 
the Shape to Radial, finally change the your foreground color to a22d5f and background to 5e042a. here 
is how all the blend tool settings should look like.

 

Step 4 ok now that you have all you the Blend tools right Create a new layer name it "Orb1" and apply 
the Gradient from the center of the circle to the lower right, check the image for the exact angel.

the result should look this.



 

Step 4 Duplicate the the Orb1 layer name it Orb2 and change the mode of the layer to "Overlay".

 

Step 5 Create a new layer and Grab the Blend tool, and again in the "Tool Options" change the Graidnet 
to "FG to Transparent", and Shape to Radial, change the Foreground color to ff958a. now apply it from 
the center to the lower bottom,check the image below on the exact position.

 

this is the result of step 5



 

Step 6 Create a new layer, Grab the Ellipse tool and draw a 121x96 circle.

 

Step 7 Fill the new created cirecle and fill it with solid white and adjust the Opacity to 12.2.

 

Step 8 Select the "Orb2" Layer and right click on it and click on "alpha to selection" Create a new layer 
place it above the rest, grab the Ellipse tool and in the "Tool Option" select the Subtract mode.



 

Step 9 Now draw an oval shape circle to subtract the top right part which will result in a eclipse shape, 
the image below displays the size i used as a subtraction.

 

it should look like this

 

Step 10 create a new layer and fill in the selection with the a solid white and change the opacity to 4.5.



 

Step 11 grab the Ellipse tool change back the mode to normal, which is the "Replace the current 
selection" icon in the "Tool options", now draw a 105x71 oval circle, it should look like this.

 

Step 12 Still with the Ellipse tool change the mode back to subtract and draw a 144x75 oval circle at the 
bottom.

 

Step 13 Create a new layer and fill it with solid white click on Select>none to de-select any 
selections,grab the "Rotate tool" and rotate it an angel of 40.



 

Step 14 Grab the Path tool and draw a path that will use to split the shape at one end to give it a reflection 
effect, one side is wider then the other side,once you have the path drawn press on the "Selection from 
path" found in the tool options.

below is the image of the path you need to draw as well as the selection.

 

Step 15 ok once you have the path drawn and the selection hit the delete key.

 

Step 16 de-select the selection by going to select>none and changing the opacity to 7.1



 

Step 17 Grab the Ellipse tool and draw a 285x297 circle.

 

Step 18 Now with the Ellipse tool change the mod to "Subtract" and draw a 291x271 Circle.

 

Step 19 Create a new layer, fill the selection with a solid white and change the opacity to 5.9, and finally 
place the layer right at the bottom just after the background.



 

Step 20 now will repeat what we just did, Create a new layer,Grab the Ellipse tool and draw a 297x271 
circle.

 

Step 21 Now with the Ellipse tool change the mod to "Subtract" and draw a 286x275 Circle.

 

Step 22 Create a new layer, fill the selection with a solid white and change the opacity to 5.9, place the 
layer just after the background.

this is how it should look so far



 

Step 23 Now for the final touch, grab the Text tool, change the size to 28 and use the font Sanas,

 

Step 24 Right click on the text layer and click on "Alpah to Selection" once you have the text selected 
delete the text layer.

 

Step 25 grab the the Blend tool and in the "tool options" change the gradients to (FG to Transparent) and 
change the Shape to Liner, and apply it from top to bottom.



 

Thats it your done! you very own advance ORB :)

 

i actually re- did it later on my own and played with the colors and made some small changes and this 
was my outcome.

 



The Gimp Xcf source file is attached below for members to download.

if you need help with the any steps please use the help section in the new forum we created 
http://gimper.net

8.2 Spam Flame sig
This is what I call the "Spam Flame" technique. Why is it called that? Because we're going to be getting 
very familiar with the Flame Filter 
** Note: I won't be working with layers in this tut, because I developed this style before I knew how to 
do that. However, feel free to get creative with this tut, as I'm sure it can be greatly improved.

Finishing Banner -

1. First of all, open up your document (mine will be 400x150 pixels in size).

2. Fill your document with black

3. Now change your background color to white, and your foreground color to whatever color you want 
the overall banner to be (I'll be using blue).

4. Now we get to start spamming Flame (hehe). Right click and go to Filters > Render > Nature > Flame. 
If you want, you can click the dotted lines right above "Flame" so that it pops up in it's own window. 
Then you won't have to keep going to that menu.

5. Now in the Flame window, go to Edit. Change the variation to Linear (it doesn't have to be that. That's 
just what I prefer), and keep clicking Randomize until you find a flame you like->

http://gimp-tutorials.net/node/154#


6. Once you've found one that you like, click Okay. Then go to the Camera tab. Using the three bars 
you'll see, move your flame to the position you want.

7. Continue steps 5 and 6 until your entire document is filled with all the Flame that you want-

7.5. [Optional]- This step is just to get you background to be more "one color". Right click and go to 
Tools > Color Tools > Colorize. Colorize your banner to whatever color you want (although it's probably 
best if you use a shade of your original color). Here's what you'll get



8. Now we're going to put a bunch of black flames on there. I think it gives the background a bit of a 
"shadowy" feel to it, and it gives it more depth as well. However, because the flame palette thing (or 
whatever it's called >.>) is black, you'll want to make both of your colors white, and choose your flame 
and position of said flame first. After you've chosen your flame, exit out of the flame window, change 
your colors to black, and then place your flame. I hope that's not too confusing. If it is, try doing this step 
with layers. This is what you should get

** Note: Sometimes it looks better if you use white instead of black. Just mess around with it and see 
what you like better.

9. Now switch back to the colors you started with- your main color (mine is blue) for the foreground, and 
white for the background. Add a couple flames to your document. You should get something like this-

10. Now we get to do something different... not! More flames! ^_^ Add another flame or two to your 
document to give it more depth (step . You should now have this-



11. Guess what? You're ready to place your render! Does that mean you're done with Flame? No! ^_^ I'll 
be using Rikku from Kingdom Hearts. Try to make sure that whatever render you use, it won't look too 
funky if it's shaded the same color as your BG. Before you place your render on the background you've 
made, we need to change the coloring of your render slightly. Get the Color Selection Tool (the eye 
dropper), and pick out the shade of blue that is most used in your background. Put that color on for both 
of your colors. Then get the Gradient Tool. Make sure that you change the mode to Overlay, and your 
Shape to Linear. Here's what your Gimp should look like

12. In your render window, drag your mouse over it once or twice. You should only need to do it once, 
but it's your banner, so do what you want. Also, depending on the coloring of your render, you may not 
need to shade it. Again, do as you please.

13. Place your render on your BG



14. The Flame is back! This step is going to help make your render looks like it actually belongs in your 
document, rather than just pasting it on top. Change your background color back to white, and your 
foreground color back to your main color (it might be better to have both of your colors set to black. Try 
them out and see what you like better). What you want to do is place a Flame, maybe two, over your 
render, leading off onto your BG. Here's what you should get

Main color version

Black version-

I like the first one better, so I'll use that. And guess what folks? That was your last flame! Yaaaaaay!

15. Now it's time for your border. You can make it the way you want, but here's my favorite method. Get 
your Rectangle Select Tool, and make sure Feather Edges is selected. Give it a radius of about 10. Select 
your entire document, leaving about a 3 or 4 pixel wide gap inbetween the edge. Not go to Select > 
Invert. After that, get your Bucket Fill Tool, and fill the selection with black. You should now have this

http://gimp-tutorials.net/node/154#


16. Now it's time for your text. I'm just going to go simple and use white. Here's what I have

Congradulations! You have just over used one of the many features of Gimp ^_^

Please post your results :)

8.3 Mac style Wallpaper
Preview:

Saw this great Wallpaper tutorial on Psdtuts.com by Collis for PS and i really liked the outcome, i have 
re-created it with Gimp using different techniques to achieve the same effect.

even though this original wallpaper was inspired by macs wallpaper i added a touch of Ubuntu logo,lately 
Ubuntu has really caught my attention to the extent I'm considering buying a Dell laptop Inspiron 
Notebook 1420 N with pre-installed Ubuntu on it and best of all its only $749 :).

this tutorial is intended for intermediate users but i encourage beginners to have a go at it,the quickest 
way to learn anything, is to just jump right into it :), it took me around 5 tries to get my final result, not 
because of the techniques, their they're quite simple and easy,but getting everything smoothly blended 
with each other is what's difficult, so don't give up on your first try! now lets begin.

Note: i recommend saving your work in .xcf very often i mean after every move often :P.

Step:

1 Before creating an image decide what resolution you want the wallpaper to be, its always best to start 
off big like 1600x1200 as i did, since its always easy to adjust the image size to smaller resolutions later 
on.

Now create a new image 1600x1200, you might want to zoom out so you have a good view of the image 
space, i put mine on 30% because I'm working on a small 1024x768 screen.

2 Grab the Blend tool , adjust the foreground color to d03500 and e46a18 for the background. now apply 
it from bottom to top (make sure its straight).

http://gimp-tutorials.net/node/106#
http://gimp-tutorials.net/node/106#


3 Create a new Layer Select the Blend tool again and pick the color white for the foreground, now adjust 
the settings of the Gradient in the Tool Options, to 

"FG to Transparent" for the Gradient type
"Radial" for the shape

4 Apply the "Radial Gradient" starting from the center and moving out to the lower right corner as shown 
below.

adjust the layer to "Overlay" mode,this is how it should look. if its not exactly positioned the same way 
you can always move it with the move tool.



5 New layer,grab the Path tool and draw an odd looking triangle shape as shown in the image.

6 Take the Blend tool and in the "Option Tool" change the Shape to "Linear" select the "FG to 
Transparent" and make sure your foreground is set to a White color.



Set the Layer to "overlay"

7 New layer, With the path tool draw another triangle opposite to the one we just made but this time use 
the color black for the foreground "FG to Transparent",then adjust the mode to "overlay and "opacity" of 
the layer to 7.5. 



8 With the Path tool Draw a half-oval looking shape then with the Blend tool apply "FG to Transparent" 
with white foreground from left to right. Set the layer in "Overlay mode"

9 again with the Path tool draw the shape shown below.



10 Pick the color Black for FG then Grab the Airbrush tool select "Circle Fuzzy (19)" brush and scale the 
size to 10.00 now add a touch of black to the inner side of the path as shown in below.

right click mouse go to select>invert and brush the outer side of the lower part of the path as shown in the 
image.



11 New Layer, while still having the selection active grab the "Bucket fill" tool and fill the path solid 
White,adjust the mode to "Overlay" and finally the "Opacity" to 43.5

13 New Layer, with the same path selection right mouse click to Selection>Grow by 14px grab the 
Airbrush they we Used before and brush the outline of all the path, place the brush half way above the 
path as shown in the image.



once you have brushes all the outlines adjust the "Opacity" to 33.3.

14 again with the path tool Draw the roundish shape that covers almost all the image except the lower left 
part. with color White selected as fourgound and
"FG to Transparent" Gradient apply it from the middle of the path to upper right.

set the layer to "Overlay" mode



15 now will want to add abit of shade of light to the left top part of the wallpaper, create a new layer, grab 
the Blend tool with White as the foreground and
"FG to Transparent" gradient,example below.

then set mode as "Overlay".



15 Repeat step 15 by creating New Layer, garbing the Blend tool and applying it in the bottom left corner 
to the center.

Set the layer to "Overlay" mode and your done! :)



Here is the Final version,added the ubuntu logo brushed it solid white white and set the mode to 
overlay :) Enjoy!

-Mac Style Wallpaper for Ubuntu Download pack sizes from 1600x1200 to 1024x760 in a zip
-Members can download the .xcf source file Attachment
-If you you need specific help please use the forum http://gimper.net :)

http://gimper.net/
http://gimp-tutorials.net/files/macwallpaper_xcf.zip
http://gimp-tutorials.net/node/107


8.4 Brave Attempt to Teach Layers in 3 Hours
We start by opening a new image - make it 300x400 pixels and select the RGB mode. Also set the default 
fill to background and check that your background color in the Gimp Toolbox is black. Our image 
background is black so it is practical to start from a solid black background. Once you have the image in 
front of you, choose File  Save As and save it as tutorial.xcf. From now on, it is a good 
practice to press Ctrl-S every now and then to save the work in progress. 

Next we need to make a new layer. This layer will be used to make the clouds, so we name it "Clouds". 
Your Layers dialog should look like the one below. (To open the Layers dialog, press Ctrl-L over your 
image or select File  Dialogs  Layers & Channels 

We created a new layer named "Clouds"

Then we want to create some clouds. Filters  Render  Plasma is perfect for this 
purpose. Choose something between 2 and 3 for the Turbulence value. The Clouds layer should now look 
like a colourful mess of all colors. We dont want these colors in this image, so we merrily select 
Image  Colors  Desaturate from the menus and we should have a black-and white 
cloudy image in front of us. 



Black and White Clouds

Our sky must not be gray. So we need to colorize this cloud image. Select Image  
Colors  Color Balance and select the following values: 

Adjusting the Color Balance

Now our cloudy image should be nice and blue. This will make the background for the sky scenery. Your 
image should now look like the one below: 



Blue Sky

Now the next step is to make it look more natural. Sky color is usually a bit gradual, in a sunset or sunrise 
the color is brighter near the horizon and it gets darker away from it. 

The easiest way to achieve that is to use a new layer, and have a gradient on it. The idea is to apply a 
gradient from black on top to white on bottom. Dot this: 

• Select white as your background color and black as your foreground color 
• Drag a gradient with the Gradient Tool from top to bottom of your image 

We then set the layer's mode to Multiply. I called this layer "Sky gradient", you can see it on the image 
below. 

Layer dialog with the Sky gradient layer



Now you should have a blue sky with some clouds, and the sky should get darker from bottom to up. If 
you see a black-to-white gradient instead, be sure to check that the layer mode is multiply. See below for 
a reference image how it should look like. 

Blue Sky with Gradient

Stars! The Audience Cries for Stars! Off we go again with a new layer. We shall call it "Stars", and this 
time lets make it black. To create a black layer set the foreground color to black, and choose foreground 
fill for the new layer. The image should look completely black at this point. 

The Noisify -plugin is a good tool to create a starfield for our image. So we select Filters  
Noise  Noisify. The default values are ok, but please uncheck the independent toggle. That 
controls if we want colored or grayscale noise. In this case we want to avoid color. 

You should now have a black image with some noise. It looks a bit like a TV screen that is just displaying 
the "snow" thing. (Look at the leftmost image below) 

Then we want to make the stars brighter, so we select Image  Colors  Contrast 
Autostretch (Below, right) 

Noisify (left) and contrast enchanged noise (right)

Now it starts to look a bit like stars, but there are too many of them. Now, what we want to do here, is to 
take out most of the small bright dots and leave the most large ones. 

We could again use many tools to solve this task, but lets try Image  Colors  



Curves. When you first see the dialog, there is a square with a diagonal line accross it from left bottom to 
top right. Be sure to have the Stars layer selected! 

The Curves Dialog

What the curves dialog does? It can be used to adjust the lightness of colors just like adjusting brightness 
and contrast does, but with more control on what pixels to brighten or darken. We want to darken the 
gray, less bright dots so only the more bright ones remain visible. Try adjusting the curve yourself, the 
image shows the preview of how it will look. Look below for how the curve should approximately look 
like. 



The Curves Dialog with our adjustment

Now the layer starts to look a bit like a starfield. You can control the amount of "stars" with the curves 
adjustment, the more you pull the curve to bottom right, the less stars you get. And vice versa. 

The Starfield layer

Now, we also want to see our clouds in the image. We can accomplish this again by changing the layer 
mode. This time we want to use Lighten Only since we are only interested in the stars on this layer. 



Stars layer set to "Lighten Only" mode

Now it looks like we want. It is quite nice sky background - and we didnt draw a single stroke with the 
paint tools. 

The starfield with clouds

Now I'd like to make the clouds look a bit softer so I use the Gaussian Blur -plugin (Filters  
Blur  Gaussian Blur) with the following values: (Dont forget to select the Clouds -layer 
first!) 



(Yes, I had a typo here. Thanks for Csaba and Erik for pointing this out. We definitely want to blur the 
clouds, not the stars :) 

Gaussian Blur the Clouds layer

Now it looks even nicer: 

The Finished Starfield with clouds

Now we have the background in a nice shape. Some mountains wouldnt hurt though. So again, new 
transparent layer (yes, I love using a lot of layers :) Lets call the layer "Landscape". It should be the 
topmost layer. 

Use the Bezier tool and try to create a landscape form on the bottom part of the image (The bezier tool is 
the second button on the second row in the toolbox, it looks a bit like an ink pen with a curve) The image 
below is an example, but your landscape will look very different anyway, and that doesnt matter at all. If 
you have a hard time working with the tool, you can have a look at my Bezier tool tutorial at 
http://tigert.gimp.org/gimp/tutorials/. 

http://tigert.gimp.org/gimp/tutorials/


Bezier curve for the landscape

You can resize the image window a bit larger so you can click outside the image canvas. Once your curve 
is ok, click inside it to turn it into a selection. Then fill the selection with black color and we have a nice 
landscape: 

The Landscape



Since I am writing this near Christmas time, let us add a nice star to the scenery. Again, one more 
transparent layer, and we run Filters  Light Effects  Supernova. Set the color to 
white and the radius to 3. I set the Spokes setting to 59 but you can experiment with that. Just try 
different values and undo (Ctrl-Z) if you dont like it. You can also alter the color slightly to experiment 
with the look. If you make the color a bit darker, the plugin seems to generate more spokes. 

The Finished Image

Many times I have one problem: After I finish the image, and some time passes, it starts to look a bit dull 
to me. It might be that your eye gets used to it or something. But it happens a lot to me. What we can do, 
is to add some contrast to the image if we want. Below is a contrast-enchanged version of the image, you 
tell me if it is better or not. 



The Finished Image with Contrast Boost

So here we are with a finished work. It wasnt that hard, was it? Now you should know a bit more about 
layers and how to use them. Thanks for the interest, I hope you enjoyed this tutorial! 

8.5 Software Boxes
Here's that tutorial I promised on how to make a software box. (You can click on the images to enlarge 
them.)

1) Open Gimp. Create a new image with a white background, that is 400px by 550px.
2) First, we need to make the boxes face that will be in the front for all to see. Create a new transparent 

layer. Name it front base. Select the Rectangle Selection tool and create a box that is about 260 by 

340 pixels. Using the Paintbucket tool , fill your selection with whatever the base color of your box 
will be. I am making a Firefox software box so my base color will be blue. You should have something 
like this:

http://bp3.blogger.com/_J5ekMDNQzF4/R37RSnfpF2I/AAAAAAAAAdg/gShWs0BAGq4/s1600-h/rect_select.png
http://bp1.blogger.com/_J5ekMDNQzF4/R37R3HfpF3I/AAAAAAAAAdo/vbd_sQl8GTo/s1600-h/paintbucket.png
http://bp2.blogger.com/_J5ekMDNQzF4/R37SyXfpF4I/AAAAAAAAAdw/z5mOU0P1Cpo/s1600-h/1.png


3) Now, using the perspective tool , we will change the perspective of the front of the box so it appears 
as if we are viewing it from an angle. Just mess around with the box until you find something similar to 
mine:

4) Now we need to make the side of the box. Create a new layer, name it side base. Pick the Rectangle 

Selection tool again. Make another rectangle whose length is equal the side of the box we have 
already made. Fill it with your base color, then get your perspective tool again, and shape it to where it 
looks like the two pieces form a box. It will take a bit of work to get it just right. Leave a tiny bit of white 
space between the two pieces to make it look more like a box. It should look somewhat like mine:

5) Now we will add the graphics that you see on boxes. Graphics differ from box to box so yours may not 
turn out like mine. For the Gimp one I made, I simply took a screenshot of Gimp, put that on the front, 
and took the Gimp logo and the splattered Wilber images from the Gimp website. Theres no limit to what 
your box can look like. Use your imagination. But here's the catch: everything you put on your box has to 
be in perspective. So, when you add your logo or screenshot or whatever, make it in perspective using the 
perspective tool. Here's what mine looks like:

http://bp1.blogger.com/_J5ekMDNQzF4/R37TWHfpF5I/AAAAAAAAAd4/hGFixbWAL1U/s1600-h/persp_tool.png
http://bp3.blogger.com/_J5ekMDNQzF4/R37RSnfpF2I/AAAAAAAAAdg/gShWs0BAGq4/s1600-h/rect_select.png
http://bp0.blogger.com/_J5ekMDNQzF4/R37hz3fpF9I/AAAAAAAAAeY/HqZsAx8Mrmg/s1600-h/3.png
http://bp3.blogger.com/_J5ekMDNQzF4/R37dJnfpF7I/AAAAAAAAAeI/8CYFMUERb8c/s1600-h/2.png


6) Merge all the layers together except for the background layer. We will now add a drop shadow. Go to 
Filters -> Light and Shadow -> Drop Shadow. Set the X offset to -5, the Y offset to 5, the blur radius to 
15, opacity to 80, and do not allow resizing. You should have something like this:

There you go. Now what I gave you are extremely basic instructions on how to make a software box. 
Play around with it and figure out what you like best. You can add neat little designs to it such as stripes 
and curvatures and such like the orange bars on my Gimp box, which you can see in my last post.

Well, there you go.

8.6 Convert Photoshop Layer Styles to Gimp Gradients
Alright, so I was browsing the forums at Gimper.net and Gimper asked in a post to convert the rest of 
these Photoshop Layer styles to Gimp gradients...all 130 of them. So I said I would and I did. These are 
the original layer styles by dezinerfolio:

http://www.dezinerfolio.com/2007/05/06/ultimate-web-20-layer-styles/
http://bp0.blogger.com/_J5ekMDNQzF4/R37oW3fpF_I/AAAAAAAAAeo/eBHAHg5hP8w/s1600-h/4.png
http://bp0.blogger.com/_J5ekMDNQzF4/R37px3fpGAI/AAAAAAAAAew/e3wEiNnCRtQ/s1600-h/box.png


These are the 30 Gimper converted:

So now, here's a tutorial on how to convert gradients.

Here are the layer styles I downloaded, scroll down a bit to find the download link: 
http://www.dezinerfolio.com/2007/05/06/ultimate-web-20-layer-styles/

You will also need Photoshop (I used CS3 but it doesn't really matter what version you use..) and you will 
also need Gimp.

First, I will show you how to make the regular, two colored gradients, like this:

Open Photoshop. Make a new image. Any size will do. I used 300x300 pixels, but it doesn't really matter. 

http://www.gimp.org/downloads/
http://www.dezinerfolio.com/2007/05/06/ultimate-web-20-layer-styles/
http://gimp-tutorials.net/30-Ultimate-Web-20+Layer-Styles-for+-Gimp
http://www.dezinerfolio.com/wp-content/uploads/2007/05/web20layerstyles_l.jpg
http://gimp-tutorials.net/news/preview2.png
http://bp3.blogger.com/_J5ekMDNQzF4/R1XxOdUXF8I/AAAAAAAAAT4/VyXr36odjtQ/s1600-h/twocolorstyle.PNG


Select the Custom Shape Tool . Now select the black rectangle shape and click and 

drag it to a reasonable size on your canvas. Now select one of your layer styles by going here:  
and pick one similar to the one we are working with. Your shape should take on the layer style you 
selected:

Now you can easily view your layer style. Now open Gimp. Don't start a new image. Instead, go to File -

> Dialogs -> Gradients. Click on the new gradient button . You are represented with this 
screen:

Name the gradient whatever you like. For the purposes of this tutorial, I will name mine Gradient 1. Now 

go back to Photoshop. Select the eyedropper tool . With the eyedropper tool, select a color 
furthermost to the top of the image, circled in red, for the foreground. Then select a color furthermost to 
the bottom of the image, circled in blue, for the background. Try not to select part of the stroke on your 
gradient. It'll mess you up.

http://bp2.blogger.com/_J5ekMDNQzF4/R1Xx4NUXF9I/AAAAAAAAAUA/4LgantX9pKc/s1600-h/customshapetool.PNG
http://bp1.blogger.com/_J5ekMDNQzF4/R1Xyc9UXF-I/AAAAAAAAAUI/fC00znwADaQ/s1600-h/rectangleshape.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1X9eNUXGJI/AAAAAAAAAVg/7Lz_Er6dE3U/s1600-h/style.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1XzVtUXF_I/AAAAAAAAAUQ/rZmWUJ1gCtI/s1600-h/1.PNG
http://bp3.blogger.com/_J5ekMDNQzF4/R1X1jdUXGAI/AAAAAAAAAUY/JqjTzmB9FKk/s1600-h/newgradienttool.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1X19tUXGBI/AAAAAAAAAUg/O_uTWCo7XQA/s1600-h/2.PNG
http://bp3.blogger.com/_J5ekMDNQzF4/R1X2jdUXGCI/AAAAAAAAAUo/ON04v8Gymec/s1600-h/eyedroppertool.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1X4GNUXGDI/AAAAAAAAAUw/Kye5h-ZSbKA/s1600-h/3.PNG


Click on the foreground color box. A Foreground Color Picker should pop up. Copy the 6 numbers 

(HTML notation) in the # box . Go back to Gimp. Right click on the bottom bar (section) and 
select Left Endpoints Color. Paste the HTML notation in the HTML notation box. Press Ok. The left 
color on your gradient should be your foreground color from Photoshop.

You should now have something like this (although your left color may not be the same):

Now for the right color. Go back to Photoshop and open up the Background Color Picker by clicking on 
the background color box. Copy the HTML notation once again. Go back into Gimp and right click on 
the bottom bar again. Then click on Right Endpoints Color. Paste the HTML notation into the HTML 

http://bp3.blogger.com/_J5ekMDNQzF4/R1X5PdUXGEI/AAAAAAAAAU4/bXPdF-vJYMo/s1600-h/htmlbox.PNG
http://bp3.blogger.com/_J5ekMDNQzF4/R1X6hdUXGFI/AAAAAAAAAVA/UQH1xfPsljU/s1600-h/4.PNG
http://bp1.blogger.com/_J5ekMDNQzF4/R1X7P9UXGGI/AAAAAAAAAVI/iEBlK4nPfWU/s1600-h/5.PNG


Notation box. Press Ok. You should now have something like this:

Now we're done with this type of gradient. Save it. The other two types that come with the layer style 
pack are glossy and flat. The flats consist of one color so we don't really need to go over those. I will now 
show you the glossy kind, like this:

Go back to Photoshop. Click on the Custom Shape Tool , and then select a new layer style here: 

and pick one similar to the one we are working with.

Now, these gradients are a bit different. Selecting the colors are different here. First, select a color near 
the top for our foreground color. Then, select one near the middle, which would be just above the black in 
my gradient.

Go back to the Gradients dialog in Gimp. Click the new gradient button. First thing we have to do is right 
click on the bottom bar then click on Replicate Segment..

http://bp1.blogger.com/_J5ekMDNQzF4/R1X8I9UXGHI/AAAAAAAAAVQ/M9EJjzhAklw/s1600-h/6.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1X82NUXGII/AAAAAAAAAVY/X9-mswutFik/s1600-h/glossygradient.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1Xx4NUXF9I/AAAAAAAAAUA/4LgantX9pKc/s1600-h/customshapetool.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1X9eNUXGJI/AAAAAAAAAVg/7Lz_Er6dE3U/s1600-h/style.PNG
http://bp1.blogger.com/_J5ekMDNQzF4/R1X-J9UXGKI/AAAAAAAAAVo/rARv9AwBcKc/s1600-h/7.PNG


In the Replicate Segment dialog, slide the slider to 2, and press Ok. Your gradient should now look like 
this:

Go back to Photoshop and click on the foreground color box. It should be the color of the top of your 
layer style. Copy the HTML Notation.
Now, back in Gimp in the Gradient Editor, left click on the left bar, between the two black triangles. The 
left bar should now be grey, with the right bar as white.

http://bp0.blogger.com/_J5ekMDNQzF4/R1X_JtUXGLI/AAAAAAAAAVw/NnEX5RS5kjM/s1600-h/8.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1X_ptUXGMI/AAAAAAAAAV4/vUo3MQg0Sd8/s1600-h/9.PNG


Now right click on the left bar. Then click on Left Endpoint's Color button. Paste the HTML notation in 
the HTML notation box. Press Ok. The very left color should now be like mine or similar:

Go back to Photoshop, and click on the background color box. Copy the HTML notation. Go back to 
Gimp, right click on the left bar again, and select the Right Endpoint's Color option. Paste the HTML 
notation. Click Ok. It should be similar to mine:

http://bp1.blogger.com/_J5ekMDNQzF4/R1YAGtUXGNI/AAAAAAAAAWA/G6bsEH4cMpI/s1600-h/10.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1YBAdUXGOI/AAAAAAAAAWI/1nuAUp4pu0o/s1600-h/11.PNG


Now, left click on the right bar. The left bar should be white now and the right bar should now be grey. 
Go back to Photoshop. For your foreground color, select a color near the top of the middle, which would 
be in the black, not in the grey of my image, circled in red, and for the background, select a color near the 
bottom, circled in blue.

Now click on the foreground color box. Copy the HTML notation. Go back to Gimp. Right click on the 
right bar, and select the Left Endpoint's Color option. Paste the HTML. Click Ok. Go back to Photoshop, 
click on the background color box. Copy the HTML. Go back to Gimp. Right click on the right bar, and 
select the Right Endpoint's Color option. Paste the HTML. Click Ok. It should now be similar to mine:

http://bp0.blogger.com/_J5ekMDNQzF4/R1YBodUXGPI/AAAAAAAAAWQ/0bVS6gTqNog/s1600-h/12.PNG
http://bp3.blogger.com/_J5ekMDNQzF4/R1YCeNUXGQI/AAAAAAAAAWY/FNv_7CLJTqA/s1600-h/13.PNG


Now we're done. Save it and there you go. I haven't figured out how to get that stroke of color on there 
that seems to border the gradient. It's probably something that'll have to be manually added to your image 
if you want it. That's the tutorial.

8.7 iPod Dancer Tutorial
You know those iPod commercials where the people are black and the earbuds are white and they are 
dancing and such? Well, I had this crazy idea, literally two seconds ago.

I decided, hey, why not make a tut for all to see about how to make the little dancers with white earbuds 
in Gimp? So I did.

EDIT: Video iPod Dancer Follow-Up

1) Get a picture of someone dancing. It doesn't matter who. Anyone. I got mine from GettyImages:

2) Open your image in Gimp. If you want, you can clear out that logo if you got it from a stock website. 
Also do some housekeeping, such as making the background one color, cleaning up anything fuzzy, etc.

http://www.gettyimages.com/
http://sglider12.blogspot.com/2008/02/ipod-dancer-video-tutorial.html
http://bp0.blogger.com/_J5ekMDNQzF4/R1YDNdUXGRI/AAAAAAAAAWg/AP_E5f2khVQ/s1600-h/14.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1jKrjEEcAI/AAAAAAAAAXw/jJnSMbqm6lY/s1600-h/dance.jpg


3) Create a new transparent layer. Name it "Black." Click the paths tool . Make sure in the toolbox, the 
paths tool is in Design Mode and polygonal is unchecked. Now, start outlining your dancer with the paths 
tool. When you get to the end, hold down CTRL and click on the beginning dot. It should look somewhat 
like mine:

3) Now click on the "Selection from Path" button. You should now have a selection around your dancer. 
Click on the Paintbucket Tool, and, with black as your foreground color, fill the selection. It should fill 
your dancer completely black. Now you can go around a clean up the edges a little if they're not smooth 
or some of the original picture is showing. It should look like mine:

So now it looks like we're getting somewhere. Now we'll make the background, so the earbuds will show 
up. You can delete the original image now.
4) Create a new white background layer. Drag it under your black layer. Pick a color for your 
background. I'm using a green one that I've seen in the commercials. Apply it to the white background 
layer.

http://bp3.blogger.com/_J5ekMDNQzF4/R1jMGTEEcBI/AAAAAAAAAX4/UqN7w687BSA/s1600-h/paths.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1lMMKHtDII/AAAAAAAAAYI/_2v2j5AIIVs/s1600-h/2.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1lLIqHtDHI/AAAAAAAAAYA/yPjRvTecXjE/s1600-h/1.PNG


Now we will add the earbuds...yay!
5) Select the paths tool. Zoom in on the ear and draw the shape of an earbud. Fill it with white.

6) Now, using the paths tool, draw an iPod in his hand. Here's mine (yes, I know my iPod is smaller than 
it should be):

http://bp0.blogger.com/_J5ekMDNQzF4/R1oJ-6HtDJI/AAAAAAAAAYQ/g3lK2xVXuT4/s1600-h/3.PNG
http://bp1.blogger.com/_J5ekMDNQzF4/R1oQvKHtDLI/AAAAAAAAAYg/dk-k4ygTxYE/s1600-h/3.PNG


If you want, you can draw fingers and thumbs to the hand to make it look like he is holding the iPod.

7) Use the paths tool again to draw the cord. Instead of clicking selection from path, this time you will 
click stroke path. Experiment with the boldness of the line.

http://bp0.blogger.com/_J5ekMDNQzF4/R1oSC6HtDMI/AAAAAAAAAYo/uIMYqaEqL5w/s1600-h/4.PNG
http://bp2.blogger.com/_J5ekMDNQzF4/R1oSRaHtDNI/AAAAAAAAAYw/pKnF21Aoi_I/s1600-h/5.PNG
http://bp0.blogger.com/_J5ekMDNQzF4/R1oT66HtDOI/AAAAAAAAAY4/l6VWoGLSSqc/s1600-h/6.PNG


And now for some final touches:

Now you have an iPod dancer. Have fun.

8.8 Chocolate bar with GIMP
1. Create a transparent (advanced options > fill with: transparency) picture 120×80 pixels in size. 

http://bp2.blogger.com/_J5ekMDNQzF4/R1oVpaHtDPI/AAAAAAAAAZA/TCjSUg7Pn9Y/s1600-h/6.PNG


Pic.1 Creating new image

2. Add two new layers and name them “projection” and “brick”. 

Pic.2 Adding new layer with a name

3. Select the whole layer “projection” by choosing All from the Select menu. 



4. Reduce the selection by about 10 pixels by using Select > Shrink 

Pic.3 Shrinking selection

5. Next, from the Select menu choose Rounded Rectangle and set the slider to 25%. 

Pic.4 Selecting a rectangular area with rounded corners

6. Fill the selection with white, then select “None” and from the Filters menu choose Blur -> 
Gaussian blur. Set the blur radius to 10 pixels. 

http://polishlinux.org/reviews/gimp/chocolate/shrink.png
http://polishlinux.org/reviews/gimp/chocolate/rectangle.png


Pic.5 Adding some blur

7. Now fill the brick > layer with rgb(97,49,2). 

Pic.6 Setting a color 

http://polishlinux.org/reviews/gimp/chocolate/blur.png
http://polishlinux.org/reviews/gimp/chocolate/colorset.png


Pic.7 Layers, as they should look

8. From the Filters > Map menu choose Bump Map. In the mapping dialog set layer “projection” as 
bump map. Set the Depth slider to 5 and set X and Y offset to -1. Set Ambient to 100. 

Pic.8 Mapping layers to get a nice bar

9. From the Script-Fu menu choose Decor -> Add bevel, uncheck Work on copy, set Thickness to 5. 

http://polishlinux.org/reviews/gimp/chocolate/map.png


Pic.9 Using Script-Fu to make the bar look smoother

10.Repeat Add bevel. 

A chocolate bar with some text engraved looks much better, so move on.

11.Add your text, preferably in white. Rotate the text layer about an arbitrary angle if you feel like it. 

Pic.10 Rotating a layer

12.Blur the text with Gauss with a radius of 1. 
13.To end up with two types of pieces with different labels, duplicate the layer “brick”. It’s 

understood that you should have a second label too. 
14.Apply Bump Map to the layer “brick”. Set your label as the mapped object. It’s easier when you 

have previously reset the filters’ settings. In the Mapping dialog set Map Type to Spherical, check 

http://polishlinux.org/reviews/gimp/chocolate/decor.png
http://polishlinux.org/reviews/gimp/chocolate/rotate.png


Invert bumpmap, set Depth to 1, set Ambient to 100. 

Pic.11 Mapping layers to get text on the bar

15.Render the second label onto the other copy of the layer “brick”, the same way as done before. 
16.Now set Text layers covering to 5%. Turning appropriates layers’ visibility on and off lets you see 

your bricks 
17.Create a new transparent picture 720×320 in size. 
18.Turn Snap to grid and Show grid on in the View menu. 
19.Create two new layers. 
20.Change your current view to that one with bricks. 
21.Copy one of the bricks with Edition menu -> Copy visible. 
22.Go to the new picture and paste into the one of new layers, Edit -> Paste into. 
23.You proceed simirarly with the second brick, except that you paste it on the second layer. 
24.Now crop both layers with bricks in them with Layer menu -> Autocrop layer. 
25.Subsequently duplicate layers to obtain 12 bricks. 

Pic.12 Brick with label “Kifer71″

http://polishlinux.org/reviews/gimp/chocolate/map2.png


26.Place bricks with the help Layers’ movement and selection tool. 
27.If you want to, scale the bar down. 
28.Save once you’re done. 

Pic.13 The chocolate bar is ready. Yummy!

Modifications

Pic.14 Linux is sweet!

Here comes a handy shortcut.
Starting from point 16 of this tutorial do the following:

• Before you create a new image, make a pattern from your bar of chocolate. Select the whole 
image, by selecting layer brick and by Selection -> All. Then from menu choose Script-Fu -> 
Selection -> To Pattern…. 

• Name your pattern “bar” for example. 

Pic.15 Creating a pattern

http://polishlinux.org/reviews/gimp/chocolate/pattern.png
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• Create a new image as it was in the 17th step of this tutorial. The size can be different but still the 
best effect is when it is a multiplication of bar’s size. For example 600 x 240px 

• Find the pattern and drag&drop it over the new image. 

•

Pic.16 Using drag&drop with the pattern

• And that’s it!! 

8.9 Drawing Shapes with Bezier Tool
Shapes with Bezier!?

This tutorial is about making simple geometrical shapes with The Gimp. I will 
concentrate on the Bezier tool since I find it so useful for this purpose. I hope you get 
some help and new stuff to put in your Gimp Tricks Sack :) I personally use this 
technique for nearly all my work. 

Notice! This is not a 'back to basics' -tutorial. You should be familiar with Gimp's dialogs 
and menus. I was thinking about this, and I did not want to make this an 'entry level' thing, basically to 
avoid bloating this too big and duplicating other people's work. Beziers are covered in my other tutorial, 
and I recommend you to read it before going further if you find the material here confusing. If you are 
new to Gimp I suggest you to go to the Gimp homepage in www.gimp.org and first read through the 
Documentation section there. 

Let's get started!

First we must create a new image for our creation. Make the size 256x256 pixels and choose RGB for 
the type. The image background should be white. 

Open the Layers & Channels -dialog with the right-button-menu: Dialogs  
Layers  Channels 

http://www.gimp.org/
http://www.tigert.com/gimp/tutorials/bezier/
http://polishlinux.org/reviews/gimp/chocolate/beforechocolate.png


1. Left side

Now create a new transparent layer, and name it Left_side so you know what layer 
I'll talk about later on. Make sure you have the new layer active by checking the 
layers-dialog. If it is not selected, click the layer's name in the dialog. 

Imagine the blue cube on the right side into your canvas, we'll be doing side #1 
now. 

Choose the Bezier-selection tool and make 
something like the side #1 on the blue cube, 

think about the perspective. (If this causes you 
trouble, don't worry. You will learn by experience). 

You can adjust the points' places if you can't get them 
right at the first try, see the Bezier tutorial for more 
information on that. Your bezier should look 
something like the one on the right. 

Once you are satisfied with your 'box' click inside it to 
make the selection. 

Next we must choose some nice colors for our 
gradient, choose white for the foreground color and 
some dark-blue for the background (we are making a 
blue box, remember?) Something like that on the 
image nearby. 

 

Select the gradient-fill tool and, starting from 
the top-left of the selection, 'drag' the gradient 

quite far down-right (see the arrow in the image. This 
way you get a quite light-colored face for the cube, 
and it is just what we want here. We also want the 
lighter end of the gradient to be near our imaginative 
light source. (The light was coming from the left) 

 

http://www.tigert.com/gimp/tutorials/bezier/


2. Right side

Now on to the right side, side #2. Create a new 
transparent layer and name it Right_side. Use the 
Bezier Tool and try to make the right side of the cube 
and turn it into a selection. 

Take the Gradient Tool again and, still with the same 
colors, make a gradient from farther up-left to near 
the selection's lower-right corner (see image on right). 
This way we get a darker gradient suitable for the 
shadow-side. 

Hint! Be careful with the edges. You don't want to 
leave any holes so the background can be seen 
through... It's better to overlap the lower layer a bit 
than leave a space between them.  

3. Top side

Our final ultimate task is to create the top, side #3. 
Again, create a new transparent layer and name it 
(who quessed? :) Top_side. 

Now you probably know we want to make yet one 
bezier selection and this time the gradient has to be 
even lighter than in the first side. So I suggest you 
lighten the dark blue color a fair amount, it's easier to 
get a light gradient that way. 

This time you pull the gradient from left to right, 
according the arrow in the picture. Once you find the 
shading look good, you can flatten the image and our 
little tutorial-cube is finished. Now apply for your 
'Cube Gimp Licence' from the nearest Gimp Station ;)  

4. Finished Work

Now you have a cool image of a Light-Source-Shaded Cube. You can choose Layers  
Flatten Image to merge the layers togerher so you can save as jpeg or any other format than xcf. Or, 
better still, from the layers dialog, make the background invisible and choose Layers  Merge 
Visible Layers so you will have the background on a separate layer and you can work further on it if you 



like. 

The next thing is to start using the geometrical shapes as building blocks to make things. And you can 
twist the beziers to make a bit more fancy stuff... 

I have provided the xcf-file for the image we just created, if you want to experiment with it, although 
you should be perfectly able to do just as good yourself. 

Thanks for your interest. 

http://www.tigert.com/gimp/tutorials/bezier_shapes/xcf/example.xcf.gz
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