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Sending SMS from FileMaker Pro

About This Tutorial
In just a few short years SMS (Short Message Service), sometimes known as “texting”, 
has become one of the mainstays of modern communication. With trillions of messages 
now sent annually, SMS is used by individuals young and old; companies large and small; 
schools and universities; government… well… everyone! Low cost, quick and easy to send, 
SMS is ideal for sending notifications: your car is ready to be collected; your child is not 
at school; your hair appointment is at 9am tomorrow; the DVD you ordered has arrived.

This Tech Tip, provided by training company uLearnIT, guides you through the process of 
sending an SMS message from within a FileMaker Pro database. Using FileMaker Pro 8.5’s 
amazing new Web Viewer and an account with an on-line messaging provider, we’ll have 
you “texting” from FileMaker in no time at all. 

Sending SMS via a Web Browser
To send an SMS, you need an account with a messaging service provider. The provider will 
supply the necessary URL syntax to send a message via a web browser. This will include 
a minimum of your user ID, password, receiving mobile number and the message. For 
example:

http://www.sendsms.com.au/smsgateway.pl?user=0402123456&pass=1234&to=6140283

9829&message=Hello world

This URL accesses the SMS gateway of the messaging provider. Each SMS you send 
is authenticated with a user ID and password. The arguments after the ? provide the 
authentication, destination (mobile number) and the message to be sent.

You could enter the URL in a standard web browser such as Internet Explorer. When 
the page loads, the text message is sent and a confirmation message is shown. In 
this tutorial, we are going to be using the web viewer in FileMaker Pro 8.5 to send the 
message.

Creating the Database
There are several tutorial files provided, each at a different stage of the tutorial. These 
allow you to jump in at any stage and to compare your work with an example.

The first step is to create a new database. To make things easier, we will use a template 
supplied with FileMaker Pro – Contact Management.

Open FileMaker Pro 8.5. In the New Database dialog, 
select “Create a new file using a template:” and select one 
of the categories that lists the “Contact Management.fp7” 
file (e.g. Home – General).

Note: If you do not see templates listed when you choose to 
create a new database, the preference to show templates has 
been turned off. Open the FileMaker Pro Preferences (Windows: 
Edit > Preferences, Macintosh: FileMaker Pro > Preferences) and, 
in the General tab, turn on the checkbox for “Show templates 
in New Database dialog”. Close the Preferences and select New 
Database… from the File menu.

Click the OK button to create the database using the 
selected template. In the next dialog, select a location to 
save your database (keep the name provided) and click 
the Save button. The Contact Management database is 
opened for you.

Note: You can also begin by opening the “Contact Management 1” file provided for you.
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The new database has no records, so click 
the New button at the top left to create a 
new record. Enter your details in the new 
record. There are two fields for phone 
numbers. In this tutorial, we will be using 
the first phone field (called Phone 1) for a 
land line number and the second (called 
Phone 2) for a mobile number.

Creating New Fields
So now we have a database where we can 
record the details of people to whom we 
wish to send text messages. The next step 
is to build an interface for creating a text 
message to send. For this, we will create a 
new text field for the message.

Choose File > Define > Database… and select the Fields tab to display fields for the 
Contact Management table. These fields have been created for you in the template. We 
are going to create a new field. Type smsMessage in the field name box and make sure 
Text is selected as the field Type. Click the Create button. Click OK to close the dialog.

Now we are going to add the new field to the current layout. First we will add a new tab 
to the tab object provided (it currently has three tabs – Main Address, Second Address 
and Related Records).

Switch to Layout mode (Windows: Ctrl-L, Macintosh: Apple-L).

Double-click the words (in blue) Main Address to open 
the Tab Control Setup dialog. 

Enter a new tab name Text Message and click the Create 
button. Click the OK button to close the dialog. You will 
see a fourth tab has been added to the tab control on the 
layout.

Click on the words (in blue) Text Message to activate the 
new tab. There will be nothing on the tab. 

Add a new field by dragging the Field tool 
from the left onto the layout and onto the tab 
control. Release the mouse button and select 
the smsMessage field from the field list.

Resize the field so that it is about 10cm wide 
and displays about four lines of text.

This field will be used to enter a text message 
we will send to the person on the current 
record.

The next step is to create fields that will be used to store the user ID and password for 
authenticating text messages. 

Warning: The method used here is a simple method that does not protect use of the account in any 
way. If you require this protection or if you need to allow use of multiple user accounts, you will need 
to set up a more complex structure that is beyond the scope of this tutorial.
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The user ID and password will be stored in the table as calculations.

Choose File > Define > Database… and select 
the Fields tab to display fields for the Contact 
Management table. Type smsUserID in the 
field name box and make sure Calculation is 
selected as the field Type. Click the Create 
button. Enter a string in quotes for the 
SMS user ID for your SMS account (e.g. 
“david06”). Make sure the calculation result is 
set to Text. Click the OK button to create the 
calculation.

Repeat the process creating a calculation field 
called smsPassword with a text string of the 
password for your SMS account (e.g. “1234H”).

Note: A copy of the database up to this stage has been provided for you. If you want to continue with 
it from here, open the “Contact Management 2” file.

Different messaging providers have different requirements for the format of the mobile 
phone number you will be sending to. Some require that there be no spaces, others 
require that the number starts with the country code. For this reason, it is best to create 
a calculation field that will store the mobile number in the required format.

Create a calculation field called smsMobileSend with a text result. 

A calculation that will strip all characters other than digits from the mobile number 
entered into the Phone 2 field is:

Filter ( Phone 2 ; “1234567890” )

The International format for mobile phone numbers in Australia substitutes the leading 
0 with a 61 (e.g. 0402 123 456 becomes 614021234546). A calculation that will strip all 
characters other than digits from the mobile number and return the International format 
is:

“61” & Middle ( Filter ( Phone 2 ; “1234567890” ), 2, 9)

In this tutorial, we will be using the first calculation for the mobile number.

Creating the Interface
The next step is to create the interface for sending the SMS using a web viewer object. 
Since the message will be sent each time the web viewer is loaded, we need to protect 
the access to the web viewer so that it is only loaded when the user wants to send the 
message. To do this, the web viewer will be created on a separate layout. The script used 
to send the SMS will open the layout in a new window, and pause for the message to be 
sent. When the user clicks a Continue button, the window will close and return to the 
original window.

Switch to Layout mode (Windows: Ctrl-L, Macintosh: Apple-L). 
Create a new layout by choosing Layout >New Layout/Report… 
or by using the keyboard shortcut (Windows: Ctrl-N, Macintosh: 
Apple-N). Enter Send SMS as the new layout name and select 
Blank layout as the Type. Click the Finish button to create the 
layout.

Add a web viewer object to the layout. Select the web viewer tool 
(the picture of a globe). Drag out a web viewer on the layout (like 
drawing a rectangle). 
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When you release the mouse, the Web 
Viewer Setup dialog pops up. This is where 
you will enter the custom web address for 
sending the SMS.

Select Custom Web Address from the Choose a Website list.

Enter the Web Address required to send the SMS as a calculation that is a string of text 
and fields such as:

“http://www.sendsms.com.au/smsgateway.pl?user= “  

& Contact Management::smsUserID 

& “&pass=” & Contact Management::smsPassword  

& “&to=” & Contact Management::smsMobileSend  

& “&message=” & Contact Management::smsMessage

In this calculation, the fields for smsUserID, smsPassword, smsMobileSend and 
smsMessage are accessed to enter data into the web address. The result of the calculation 
(used by the web viewer) may look like:

http://www.sendsms.com.au/smsgateway.pl?user=david06pass=1234H&to0402123456&

message=Hello David

Note that the user ID and password would be retrieved from the calculation fields, while 
the mobile number and message are those entered for the current contact record.

Note: A copy of the database up to this stage has been provided for you. If you want to continue with 
it from here, open the “Contact Management 3” file.

Scripting the Sending Process
We will now automate the process of sending the SMS with a sending script that will open 
a new window with the web viewer layout, wait for a response and then close the window 
to return to the original layout.

Open the ScriptMaker (Scripts menu) to create a new script. Click the New… button and 
enter Send SMS for Current Record as the script name. Find and add the following 
script steps:

Allow User Abort [Off]

New Window – click Specify and set “Send SMS”, 300, 500, 100, 100

Show/Hide Status Area – click Specify and select Hide
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Go to Layout – click Specify and select the Send SMS layout

Pause/Resume Script [Indefinitely]

Close Window [Current Window]

Adjust Window – click Specify and select Maximise

Click the OK button to save and close the script. Uncheck the checkbox next to the script 
so it does not show in the Scripts menu (you need to control when it is run by using a 
button to access the script). Click the OK button to close the ScriptMaker.

Adding Buttons
Now we need to add buttons to run the script (to send the SMS) and to continue the 
script when the web viewer has loaded in the new window.

Switch to Layout mode (Windows: Ctrl-L, Macintosh: Apple-L). Select the Form View 
layout from the layout pop-up menu (or from View > Go to Layout > Form View). Click 
the Text Message tab to go to the tab where you placed the smsMessage field. Using the 
button tool (the picture of a button with a hand), drag a button next to the smsMessage 
field that is about 4cm wide and 1cm high. Select Perform Script and click the Specify 
button. Select the Send SMS for Current Record script. Click the OK button and then 
the next OK button to return to the layout. Type Send SMS Now for the button name.

While still in layout mode, select the Send SMS layout. Add a button next to the web 
viewer object. Select the Resume Script action and click the OK button to close the 
dialog box. Type Continue for the button name.

Go back to the Form View layout and return to Browse mode (Windows: Ctrl-B, 
Macintosh: Apple-B).

Congratulations!
You now have a fully working database that will send an SMS to the current contact. Try 
the Send SMS Now button. When you click it, a new window will pop up on the Send SMS 
layout, and try to load the web viewer with the web address. When you click the Continue 
button, the new window closes and the original window is maximised.

Note: A completed database has been provided for you. If you want to view it, open the “Contact 
Management 4” file.
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Extra Credit Topics
So what if you really want this technique to fly? We need to study the processes, trap for 
possible errors and record data about the sent message.

Here are some other things you might like to consider:

What if there is no mobile number entered?

What if the mobile number is invalid? e.g. wrong number of digits

What if there is no text message?

What if the text message is too long? Text messages are limited to 160 characters. 
Your messaging provider may chop the message off at 160 characters and discard the 
rest, or send longer messages as two messages (which you pay for).

Can you record the date and time the message was sent?

Can you record the response from the SMS gateway? The responses vary between 
providers but may include words such as “successful” or “failed”.

What do you want to do if sending the SMS fails?

Can you send the same message to a set of found records?

Tutorial Credits
This tutorial and the associated sample files have been developed by uLearnIT, providers 
of FileMaker Pro training in the Asia Pacific region. For details about training courses, see 
the website at www.ulearnit.com.au or call 1300 797 201.

The original template (Contact Management) is provided by FileMaker Inc., and ships with 
the FileMaker Pro 8.5 product. A demonstration version of FileMaker Pro is available on 
the website www.filemaker.com.au. 
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