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De SketchUp a Blender

Prérequis pour le modeéle SketchUp
Avant d’exporter le modéle SketchUp deux points sont a veérifier :

Premiérement, I’importation dans Blender de « Composants » SketchUp ne fonctionne
actuellement pas. Des lors, les composants compris dans le modele SketchUp doivent
étre éclatés avant I’export. Pour étre sdr qu’il n’existe plus de composants dans une
scene, selectionnez I’ensemble des objets [ctrl-a] et vérifiez que I’option « Eclater »
n’est plus disponible dans le menu contextuel (clic-droit). Dans le cas contraire,
éclatez le modeéle autant de fois que possible.

Deuxiemement, étant donné que les faces sont dédoublées lors de I’export, il faut dans
la mesure du possible s’assurer que la méme couleur (ou texture) est appliquée des
deux cotés de chaque face. Ou alternativement, ne pas appliquer de couleur sur le c6té
non visible de la face et y laisser par conséquent la couleur par défaut.

Export du modéle

Le modele SketchUp est ensuite exporté (Fichier->Exporter->Modéle 3D...) au format
COLLADA. Un fichier « .dae » est alors créé et assorti éventuellement d’un dossier portant le
méme nom. Ce dossier contient les textures utilisées dans le modele SketchUp, il est
important de le conserver avec le fichier afin que Blender puisse aussi importer ces textures.
Le résultat de cet export est rassemblé dans I’archive piéce.zip (disponible sur la page web du
cours) qui comprend le fichier piece.dae.

Import du modele
Afin d’importer le modele COLLADA dans Blender :

1

2.
3.
4.

Décompressez I’archive piéce.zip dans votre dossier de travail.

Lancez Blender et effacez [x] le cube présent par défaut.

Dans le menu File choisissez : Import->COLLADA (.dae).

Naviguez ensuite jusqu’au fichier piece.dae sélectionnez-le et cliquez sur « Import
COLLADA »

Adaptation du modele en vue d’un rendu par Blender

Mise a échelle
L’importation dans Blender d’un modéle créé avec MENES All Scenes

SketchUp génére parfois un modéle dont les dimensions
sont mal adaptées & Blender. Cela ne se produit
normalement pas avec le fichier piéce.dae. Cependant dans
le cas ou la taille de I’objet serait nettement plus grande
que la caméra, il est préférable d’effectuer une mise a
échelle afin d’éviter des complications par la suite.

1.

)

SketchUp

L’« Outliner » permet d’afficher I’ensemble des
objets contenus dans le fichier. La situation
obtenue est présentée ci-contre.

L’« Outliner » permet de facilement identifier les
objets importés du modele SketchUp d’apres leur
nom.

Pour effectuer une sélection multiple dans
I’« Outliner », faites un clic droit sur I’objet que &
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vous voulez ajouter a la sélection et choisissez « Select». Sélectionnez ainsi
I’ensemble des objets dont le nom commence par SketchUp.

3. Replacez ensuite le curseur de la souris dans la fenétre 3D. Appuyez sur [s] afin
d’activer le mode de mise a échelle et tapez « 0.1 » comme facteur de mise a échelle
puis [Enter] pour valider.

Ajout d’'une caméra et des lampes

1. Passez en mode filaire en appuyant sur [z] et en projection orthogonale [5].
2. Déplacez la caméra et la lampe déja présente par défaut et ajouter une lampe
supplémentaire afin d’obtenir la situation suivante :

Lo 4 ‘ ‘

Vue du haut Vue de face

3. Pour la lampe que vous venez de créer activez I’option « Ray Shadow » afin que ces
deux lampes projettent des ombres. Cette option est disponible dans I’onglet
« Shadow» du panneau « Object Data » m de la fenétre de propriétés.
5. Sélectionnez la caméra et passez dans le panneau« Object Data » E de celle-ci.
o0 Pour qu’une portion plus grande de la scene soit visible au rendu, ajustez le
parameétre « Focal Length » situé dans I’onglet « Lens ».

Orthographic Panoramic

“Focal Length: 15.000% Millimeters

6. Si vous lancez un rendu maintenant vous pourrez voir que celui-ci est trés mauvais et
bruité. En réalité, les faces des objets provenant de SketchUp sont dédoublées. Ce
dédoublement perturbe le calcul d’ombre de Blender et donne lieu au probleme
observé.



Suppression des dédoublements de faces

Le dédoublement des faces provient du fait que SketchUp crée pour toute surface une face
avant et une face arriére. Ceci lui permet d’appliquer un matériau différent de chaque c6té de
la surface. Deux cas de figure sont possibles :
e Soit le méme matériau est appliqué des deux cotés. Dans ce cas on peut supprimer
indifféremment les nceuds situés d’un c6té ou de I’autre (« Remove Double »).
e Soit il n’a pas été possible d’appliquer le méme matériau des deux c6tés. Il faut alors
recourir a la sélection par matériau et effacer les nceuds correspondant aux matériaux
par défaut de SketchUp

Matériaux identiques

Dans le modeéle SketchUp fourni pour la séance, c’est le cas des murs, du sol et du plafond.
Afin de supprimer les nceuds superflus de ces trois objets, la démarche est la suivante :
1. Sélectionner I’objet et passer en « Edit Mode » [Tab].
2. Sélectionner I’ensemble des nceuds [a].
3. Cliquez sur le bouton « Remove Doubles » sous I’intitulé « Remove » du panneau de
gauche de la fenétre de visualisation.
4. Afin de corriger les normales, cliquez également sur « Recalculate » sous I’intitulé
« Normals ».
Effectuez ces quatre opérations pour le sol, le plafond et les murs.

Matériaux différents

A la différence des murs, les faces des deux cubes disposés dans la piece sont dédoublées et
possedent des matériaux différents de chaque c6té. C’est le cas lorsque I’une des faces était
inaccessible lors de la modélisation sous SketchUp. Sachant que le matériau par défaut
(blanc) est alors appliqué sur les nceuds internes a I’objet, nous allons pouvoir sélectionner ces
nceuds a I’aide de leur matériau et les effacer.

1. Sélectionnez I’objet.

2. Passez en « Edit Mode »

3. Dans I'onglet « Materials » H de la fenétre de propriétés vous pouvez voir que

I’objet est relié a deux matériaux. Sélectionnez le matériau blanc dans cet onglet.

4. Cliquez sur le bouton « Select » afin de sélectionner les nceuds auxquels le matériau
blanc est affecte.
5. Replacez le curseur de la souris dans la fenétre 3D et supprimez [X] les vertices
sélectionnés.
Lorsque ces opérations ont été effectuées pour les deux cubes, le rendu peut étre recalculé. Il
ne doit alors plus présenter de bruit.



Création d’une animation

Animation simple de la caméra

Nous allons commencer par une animation dans laquelle la caméra pivotera simplement sur
I’axe vertical. Pour cela nous allons utiliser le « Graph Editor » qui est disponible via le menu
« Window Type » placé a I’extréme gauche du header de chaque fenétre. Cette fenétre permet
de visualiser I’évolution des paramétres d’un objet (position,...) au cours du temps (le temps
étant représenté par un numéro d’image). L’éditeur de courbes fonctionne de maniere
similaire a la fenétre 3D :

Le clic droit permet de sélectionner les points de contr6le d’une courbe.
Le clic avec la roulette permet de se déplacer.

[ctrl+clic roulette] permet de zoomer.

[Home] ajuste la fenétre a I’ensemble des courbes.

[g] permet de déplacer I’entité sélectionnée.

[ctrl+clic gauche] permet d’ajouter des points a une courbe.

Pour réaliser I’animation :

1.

2.

10.

Ajoutez une fenétre (ou prenez en une existante) et sélectionnez « Graph Editor »
comme type.

Sélectionnez ensuite la caméra et placez-la dans la position de départ souhaitée (en
direction de la lampe située a sa gauche par exemple).

Appuyez ensuite sur [i] et sélectionnez « Rotation » dans le menu qui apparait. Cela a
pour résultat d’ajouter trois courbes a I’éditeur de courbes. Ces trois courbes
correspondent aux trois angles de rotation de la caméra.

Passez ensuite a I’image 100 en utilisant le champ indiquant I’image courante dans le
header de la fenétre « Timeline » située en bas de I’écran.

Start:1  * | ¢ End:250 I-If 100 r]

Positionnez la caméra en position finale. Par exemple a 90° vers la droite de la
position de départ afin d’effectuer un balayage de la piéce.

Appuyez une nouvelle fois sur [i] et sélectionnez « Rotation » pour insérer un nouveau
point dans I’éditeur de courbes. La courbe d’évolution de I’angle de rotation est
automatiquement interpolée (par une courbe de Bézier par défaut).

Il reste maintenant a définir les images de fin et de début de I’animation. Rendez-vous
a nouveau dans le header de la fenétre « Timeline » et insérez I’indice de la premiére
(1) et de la derniére (100) image de I’animation respectivement dans le champ
« Start » et dans le champ « End ».

Start: 1 '1' End:100 *

L animation peut maintenant étre testée en appuyant sur [alt-a] ou a I’aide des boutons
de contrble du header de la fenétre « Timeline ».

Afin que le rendu ne soit pas trop long fixez la taille de sortie & 25% dans I’onglet
« Dimensions » du panneau « Render » E
Avant de lancer le rendu, sélectionnez le
format de sortie de I’animation dans I’onglet
« Output » du panneau « Render» de la
fenétre de propriétés. Par défaut I’animation -
est simplement sauvée comme une série - RGBA | ¥/ Ovenarite
d’images. Pour obtenir un fichier au format
vidéo, AVI JPEG semble fonctionner dans




de nombreux cas.
0 Le fichier est placé dans le répertoire spécifié sous I’intitulé de I’onglet.
Chaque changement de format nécessite un rendu pour étre effectif.

11. Finalement cliquez sur le bouton « Animation » de I’onglet « Render » situé en haut

du panneau du méme nom ou utilisez le raccourci [Ctrl-F12].

Suivi d’'une trajectoire

Blender permet également de définir la trajectoire d’un objet (tel que la caméra) a I’aide d’une
courbe (Bézier par exemple) définie directement dans la fenétre 3D.

Création de la trajectoire

1.

2.

3.

4.

Placez-vous dans la vue du dessus et insérez une courbe de Bézier (Add->
Curve->Bezier).
Passez en « Edit Mode » et modifiez a votre guise la courbe obtenue, il est possible
d’ajouter des points a celle-ci en sélectionnant I’un de ses points d’extrémité puis, tout
en appuyant sur [Ctrl], en cliquant avec le bouton gauche de la souris a I’endroit
souhaité.
Sortez de I’« Edit Mode », placez la courbe a la hauteur désirée et ajoutez ensuite une
nouvelle caméra (Add->Camera).
Afin que la caméra suive le chemin que nous venons de tracer, nous allons lui ajouter
une contrainte.

0 Sélectionnez la caméra et activez le panneau « Object Constraints » [g de la

fenétre de propriétés.

o0 Cliquez sur le bouton « Add Constraint » et sélectionnez « Follow Path » dans
la colonne « Relationship ».

0 Un nouvel onglet associé a la
contrainte apparait. Dans le
champ « Target » sélectionnez la
courbe de Bézier.

0 Cochez la case « Follow Curve »
afin que [I’orientation de la
caméra suive la courbe

o La rubrique « Forward » indique
I’laxe de la caméra qui devra
rester tangent a la courbe (et
orienté dans le méme sens que celle-ci). Sélectionnez « X » ou « -X » pour que
la caméra reste perpendiculaire a la courbe ou « -Z » pour que la caméra soit
tangente & la courbe.

o Finalement la rubrique « Up » indique I’axe de la caméra qui doit étre orienté
vers le haut. Sélectionnez « Y »

Si a ce stade, la caméra ne se trouve pas sur la courbe, passez dans la fenétre de
visualisation et activez le panneau de propriétés [n]. Sélectionnez ensuite la cameéra et
mettez ses coordonnées a 0 (position et rotation).

Comme pour I’animation préceédente, il faut maintenant définir la position de la
caméra (sur la courbe) pour au moins deux images (images clés).

0 Sélectionnez la courbe et activez le panneau « Object Data » H de celle-ci.




0 Recherchez I’onglet « Path Animation ». La valeur du champ « Frame » par
défaut est de 100. La valeur de ce champ représente la longueur de la courbe.
Vous pouvez laisser la valeur par défaut.

1 Frarmes: 100 4

1 Evaluation Tirme: 0.000 *

0 Le champ « Evaluation Time » donne la position courante de la caméra sur la
courbe. La valeur de ce champ peut varier entre 0 (début de la courbe) et la
valeur du champ « Frame » (fin de la courbe).

= Placez-vous a I’'image 1 et fixez « Evaluation Time » a 0.

= Avec la souris placée sur le champ « Evaluation Time » pressez [i] afin
d’introduire la premiére image clé.

= Placez-vous ensuite a I’image 100 et fixez « Evaluation Time » & 100.
Pour placer la caméra a la fin de la courbe.

= Pressez a nouveau sur [i] avec la souris sur le champ « Evaluation
Time » pour inserer la seconde image clé.

6. Une courbe a été ajoutée dans la fenétre « Graph Editor ». Seules les courbes relatives
a I’objet sélectionné dans la fenétre 3D sont visibles dans cette fenétre.

o0 L’interpolation par défaut entre les images clés est une courbe de Bézier. Pour
obtenir une interpolation linéaire, appuyez sur [a] (éventuellement a deux
reprises) pour sélectionner tous les points de la courbe puis dans le menu
« Key » (header de la fenétre « Graph Editor ») choisissez « Interpolation
Mode->Linear ».

7. Finalement, pour rendre la nouvelle caméra active, retournez dans la fenétre de
visualisation 3D et sélectionnez celle-ci. Dans le header de la fenétre de visualisation
choisissez « View->Cameras->Set Active Object as Camera ».

o L’animation peut alors étre testée en passant en vue Camera [0] et en appuyant
sur [alt-a]

o |l est possible d’incliner la caméra vers le bas en modifiant la valeur de
« Rotation » selon X dans I’onglet « Transform » du panneau propriétés de la
fenétre de visualisation [n].

o0 Lorsque le résultat est satisfaisant, le rendu peut étre calculé [Ctrl-F12].



